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Agenda:

1. Top level system design using ADS New Budget analysis

2. Modeling “off the shelf components” In terms of data
based models or parametric models.

3. Creating Layout libraries for off the shelf components

4. Creating an EM based RF board model.

5. Release for manufacturing.
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Topics for this Module

* Overview of ADS Graphics Export Options
* Detalled look at Gerber artwork export

e Overview of Intermediate File Format
( IFF) Export Options to Mentor and
Cadence board-level tools
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Avallable Graphics Export Options

DXF Import/Export
EGS Archive Import/Export
GDSII Stream Import/Export
Gerber Export only

IGES Import/Export
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Detalled Look at Gerber Export

e Gerber Artwork
— Export selectec

‘ranslator
layers from ADS layout to

Gerber photo p

otter

— Supports Gerber RS274D, Gerber RS274X,
and MDA Autoplot formats

e Gerber Viewer

— Used to visually inspect Gerber output before
committing to fabrication

— also used for generating drill file and tooling

reports from dri
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Preparing a layout for Gerber Export

Many ADS layout elements meet with no overlap:

Gerber plotter will fill each object individually, creating two potential problems:

1) Aperture radius divot at 2) If film is slightly underexposed,
boundary of filled area microscopic gap between objects
could appear
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Generate Artwork/Edit>Merge>Or

These two steps will avoid gaps or divots in board artwork:

1) Use File>Generate Artwork — copies an ADS layout, then
removes all hierarchy — results in a flat layout with only
primitive elements: circles, rectangles, polygons, text

2) Select All, then Edit>Merge>Or — joins primitive objects
which touch into complex polygons

No “seams” ensures no divots, no gaps
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Exporting Gerber Files

1. In the layout window, click File > Export to open the
Export dialog box and select Gerber

Export:37 il

File Type

2. Click on More Option to
set them as you want

Gerber

Destination Directory
4. Choose the L |RS\ADS20044USER Gerber_dema_prj Browse. . |
Destination Cancel | _| Export GERBER Opuwns:10 |
Directory Urits ScaleX ScaleY - Altributes
(defaults to [same =] [0 [0 [ Auto Merge
- " [~ Arcs Az Polygons
- Define Layers... |
current prOJECt) 5' CIICk OK to Start [ epers Laver Number(s] [T Rectangles &z Polylines
the export process s | ~Hole Format
Laver File Mame(z] " Hales As Paolygons
® B I {* Holes As Cutlines
Etch Factor  Miter &ngle " Prezerve Holes
o {30.0
3. Click OK to dismiss . Carcel | e |
this window
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Exporting Gerber Files

 The Mask Files field displays the mask file created in the Export dialog
box. This is the file that the Gerber translator converts into Gerber

format. MTOOLS v3.50 (2/20/2003) {res 1.109) x|
« The Aperture/Config File GERBER |

field displays the o 2 powse |

configuration file used to Aperturs/Contig Fie:

hold all of the translation Jengih o5 TN

parameters and

Gerber File Options
Gerber apertures . -

p 6 SEt the Mask FIIES Translation Settings
and Aperture File Edit Apertures
paths Tranzlate
Wiew Mask
Wiew Gerber

Esit fbout.. | Help
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Exporting Gerber Files

1. Set the
Gerber File Options

MTOOLS +3.50 {2/20,2003) {rcs 1.109) x| Gerber File Dptions E3
GEFBER | Gerber Unit IMCH -

Select Mask Files: C:hwzershdefault] Bhlayout_lab_prj

I"imp_enp_gerher_m mzk" EI Browse I Format 44 hd
ApertureConfig File: Zem Suppress ILeading "I
englizh. apt Browse

| _Bone | petatioce [P =]

Gerber File Options

Translation Settings | ENE Charaster
Edit Apertures | Bl Shing MOz ¥
Translate | CR/LF I Suppress - I
Wiew b azk |
Cancel | Help |
Wiew Gerber |
Edt | About. Help
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/. Gerber File options

e Gerber Unit. Available units are INCH or MM Gerber File Options |
 Format. The number of integers before o = |
and after the implied decimal point. Resolution ™™ I44 =
should be sufficient to avoid round-off errors €510 SUpIESS :LE“"‘Q j
[Nata Made Abzalute -

e Circular — Options are 360 or Off. Use 360 if
Gerber plotter supports arc interpolation. ot T

[
=
e Zero Suppress. Available settings are Leading . [ =
and None CRJLF [suppress =]

« Data Mode. The program always writes out
absolute coordinates.

« CR/LF - only enable if Gerber file is to be viewed
In a text editor

Circular 380

Lancel | Help |
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Exporting Gerber Files

8. Set the
Translation Settings

GERBER
| Line OCode Id:25 ArcRes I9
Select Mask Files: C:huszershdefault] Bhlayout_lab_prj 1
- m Scale Factor I APT Cut INDne LI

I imp_exp_gerber_01.msk! EI Browsze |

&perture/Config File: eyl

[engiish.apt Browse_| & Outline Filled! IdEU If’21 Ernpty IE’E?2 Ifﬂz3
« Fil StatapT |10

Gerber File Optiong | —Compensation
Tranzlation Settings | = Shrink
: ID inch 1 Sywell
Edit Apertures |
& [{one
Translate |
— Offget Output
Wiews Magk | e ID v (D
Wiew Gierber | —Gerher Qutput Farmat
i RS274D (Gerther)  hDA Autoplot
El A Az & RS274X £ Barco DPF

Use RS274D format if wou plan to merge the output files inthe Gerber viewer.
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8. Translation Settings

Outline/Fill

Choose “Outline” if plotter
supports automatic filling of
polygons

“Fill” will explicitly paint
Interior of polygons

Gerber Output Format:
RS274X is recommended,
contains aperture information
within the plot file itself

Monday, February 14,
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x
Line DCode I':ﬂ25 ArcRes I9
Scale Factar I1 APT Out INDne ﬂ
— Qutline /Fill
& Outline Filled IdEU |f>121 Empty |dzz |d23
 Fil Start APT If“”
—Compensation
£ Shrink
ID inch ¢ Swell
= [one
— Dffset Output
* ID v: [0
— Gerber Output Format
= RS274D (Gerber)  hADA Autoplot
o RE274 £ Barca DFE
Use R5274D format ifyou plan to merge the outputfiles in the Gerber viewer.
OFK Cancel Help |
12
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Exporting Gerber Files:

9. Specify apertures
setting with
Edit Apertures

Edit Aperture - englizh_apt

MTOOLS ¥3.50 (2/20,2003) (rcs 1.109)

[D-code Type = [INCH] ¥ Block Mame
GERBER | 0| [EmE [0oo00 [oomon | ﬂ Save_|
Select Mask Files: C:huzershdefault] Bhlapaut_lab_pri ll |Hnund ||:|_|:|02|:||j ||:|_|:||:|2[||j |
0 Save A
["mp_esp._gerber_O1.msk =l _E2] [Foud [0o0400 [o00a00 | ET
Aperture/Corfig File: 13| [Round {nooso0 |o.ooso0 Cancel |
[englsh.apt B ﬂ |Round [nots00 |o.oisoo
~ 15| [Round {n.02500 o.02s00 | Help |
et e Ot | 18] [Round {004000 [0.04000
Gerber File Options il I I I I
Tranzlation Settingz | El I I I I
— s | |
Edit Apertures | IF'u:ue:-: ID ID I
Tranzlate | ﬂl IP':'E“ ID ID I
_ 2| [Fon R
Yiew Mask | 28] [Pon [0 [0 |
Wiew Gerber | ﬂl I I I I
25| [Round {oootoo fo.ooioo -]
it | abou | Up | Dowr| Home| End|  ClearLine| StdList | Bt
Clear&ll | Flash Circles |
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9. Edit Apertures

Edit Aperture - english.apt

B
D-code Type = [IMCH] Block Mame
Ape_rtl_”es are the 0| [ {oomion [oomioo | ﬂ Save |
basic images the 1] [Round [ao0z00 [o00z00 | Savels |
; 12| [Round (000400 [0.00400 |
Gerber plotter will use
) 13| [Round {oooson |o.00800 | Cancel |
to paint the artwork 14| [Round [oots00 [o.oms00 |
objects on film 15| [Round {oozs00 |o.ozs00 | Help |
16| [Round {0.04000 [0.04000 |
7] ] |
8] | |
a9 |
ﬂl IPDE:-: IEI IEI I
ﬂl IF'DE:-: IEI IEI I
22| [Pain [o [0 |
23| [Poin [0 [0 |
2] | |
25| [Round {oooton [oomiod | |
Up | Dowr| Home| End|  Clear Line| Gitd List Auto Flash |

Clear Al Flazh Circles/R ectangles.-"F'DI_l,lgDnsI

“Flashing” Circles, Rectangles, Regular-shaped Polygons is more efficient,
This button adds the necessary aperture listings
NOTE: This step is necessary to enable generation of drill output
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Exporting Gerber Files

MTOOLS ¥3.50 (2,/20/2003) (rcs 1.109)
GEREEF |

Select translation layers |

Laver Mo, GDSI Layer  Laver Name

Select bMaszk Files: C:hwizershdefault] Bapout_lab_ pr

caond I"imp_e:-:p_gerl:uer_m gk

Aperture/Config File:

—

Ienglish.apt

10. Click Translate to select the |  seserric ot
layers you want to translate into

I

I

| the Gerber file Edispertres |
e ; 5 Trangzlate |
Elear.-'l'-.lll Cancel | |
I

Tranzlation Settingz

Wigw b ask

Wiew Gerber

Browse |
_ Bowss |

Browse

Edt |

About...

Help

11. After selecting the layers, click OK to Output files will be
complete the translation. A window <layer name>.gbr,

appears briefly, indicating that the layers in the destination
are being converted to Gerber format directory
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Exporting Gerber Files

MTOOLS ¥3.50 (2,/20/2003) (rcs 1.109)
GEREEF |

R¥U - cond.job, cond.apt

Select bMaszk Files: C:hwizershdefault] Bapout_lab_ pr

File Edit Wiew Tools Info Plob Help I"imp_e:-:p_gerl:uer_ﬂ'l.msk" EI Browsze |

Fill | Layer | Apenurel Flat Screen Flot'Window | Apt. H|gh||ght|

I""I

Aperture/Config File:

Ienglish.apt Browse |

Gerber File Options

Tranzlation Settingz

Edit Apertures

Trangzlate

Wigw b ask

Wiew Gerber

Edt | About. | Hep |

12. Visually Inspect Gerber output before

committing to manufacturing

||Click mouse button at a zoom WINDOYY cormer | 0165834 |

4

011413 |
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12. Visually Inspect Gerber Output

Eﬁ GBR¥U - cond.job, cond.a ;Iglil

File Edit “iew Tools Info Plab Help

User “Layer”
control to set
layer visibility,

color, layer order

Check individual
layers, and layer
combinations P

||CI ok mouse button at a zoom WINDOW comer 016898 D11413|
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Drill Output Considerations

* In ADS, a Drlill File is derived from a
Gerber file of a “hole” layer or layers

 Requires that you “flash” circles on hole
layer

e Associate circle apertures with drill tool
numbers, drill sizes

Monday, February 14, ] )
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Drill Output Considerations

Back at Step 9, when defining apertures:

Edit Aperture - C:idatahusers'adsZ2004auser’ Gerber_Failure_prjienglish.apt

W (NCH)

D-code Type

Block Name

3. Save the updated
—'/ aperture file

A

2. Note size and D-code
for each C (circle)

aperture

o [oooto0  [oooto0 | ii save |
1 0.00200  [0.00200
El In.nmnn ID.DMDD I ﬂl
il [noosoo  fooosoo | Cancel |
4 [ootso0 [norso0 |
£| [Round [nozso0  foozsoo | Help |
i! |Round [no4o00  foodo00 |
[ 17 IRDund |n.ussnn |D.DSEDD |CID_DSE
il IRound |n.mnnn |D.D1DDD |CID_D1
19| [Round [o.01000 footoon  Joio o
20| [Posx o o |
il IPDex ID ID I
22| [Poin [0 [o |
23| [Poin [o [o |
ﬁ| [Round [no3oo0  foosooo  ci0_o3
ﬂl [Round [pootoo  foootoo ~|
Up | Downl HDmel Endl CIearLinel Std List Auto Flash |\
ClearAll |

FlashCircles,fRectangIes,"PDIyguns| < \ 1. Select “FIaSh” Opt|0n

Monday, February 14,
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Drill Output Considerations

After generating Gerber files for artwork and drill layers:
1) View JUST the hole layer in the Gerber viewer
2) Select the Aperture button

Aperture - hole.job, hole.apt

f| [ ok ] Locate the Circle D-codes

you noted when defining
apertures

]Assign Drill Tool # to each

D-code Type ®O(NCH) Y Tool Dirill
#  Diameter
| 10 |Round fo.0010000 fo0oo0oo0 | |
| 11 |Round fo.00z0o00 foooooooo || Cancel |
| 12 |Round f0.0040000 {0 0000000 | |
| 13 |Round f0.0080000 fo.0000000 | |
| 14 |Round f0.0150000 f0.0000000 | |
| 15 |Round [0.0250000 {o.00o0000 | |
| 16 |Round {o.0400000 [o.000000D | ]
17 | [Found fo.0850000 fo.0oo0ooo |1 fooss0000)
18 | [Found 0.0100000 [ooooooon |2 [o.0100000
| 19 |Round 0.0100000 |0.0000000
| 20 |Round fo.0000000 {o0oo0oo0 | |
| 21 |Round fo.0000000 {o0oo0oo0 | |
| 22 |Round f0.0000000 f0.0000000 | |
| 23 |Round f0.0000000 f0.0000000 | |
| 24 |Round 00300000 [o.oooooon | |
| 25  |Round fo.0010000 fo0000000 | |

Up | Downl Homel Endl

|

ClearLine| ClearAll |

Assign Drill Diameter to each
(by default, the same size as
the hole graphic

representation in ADS layout)

Monday, February 14,
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Exporting the Drill File

+ With just the hole laver visible. G Lo ZeoSupge)
] Report Excelon (Mo Zer Suppress)
SeleCt TOOlS > D”” Tranzlators P X Table
Eilmn kMerge...
o 2 main formatS: SpertureFereratarn..
o Extract Setup...
- Excellon to create a drill file. Exdtract
- Table to create an X-Y table.
x

 Choose the format

Layer # Drill File Mame Tool Count

Only the “hole” layer

you want to generate, ) .
should be identified,

then this box appears:

Tool Count=# of
unique drill sizes

Drill Format:  Excellon Repart | Ok |
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Exporting the Drill File

Click on Report to display the Drill Report file:

e ittt i +
| ORI LL T o OL 5 TAELE |
4o - f-—mm——— - R ettt o +
| Dr111 | Drill | Drill | |
|  Tool | Size |  Count |  Remark |
N R R ettt oo +
|  TO1 | OR50 | 000001 | D17 |
|  TOZ | 0100 | 000576 | D18 |
4 - 4-———————- - - o +
Monday, February 14,
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Overview of Intermediate File Format
(IFF) Export Options

 Mentor
DesignArchitect/BoardStation

 Mentor Expedition

« Cadence Concept/Allegro ‘ Cd d ence

Each interfaces assumes a specific use model, we’ll review
specific requirements for each design flow
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ADS ->Mentor DesignArchitect/BoardStation

Appropriate for integrating RF Sub-circuit with larger mixed-signal design

Assumes synchronized packaged parts libraries, strict synchronization between ADS
schematic and layout

Library Toolkit LMS

ADS <
Library 1 @rary
DA Schematic

ADS
" Schematic |« IFF -
]] ﬂ

ADS BoardStation Layout

Layout |, IFF

Requirements: Schematic and Layout IFF interfaces for ADS,
RF Architect and RF Layout interfaces for DA/BoardStation
ADS Packaged Parts Library derived from Mentor LMS library

A

A

+Layer Map
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ADS ->Mentor Expedition

Appropriate for precise RF copper structures (spirals, couplers, splitters) which
would be hard to produce in Expedition

No intelligent transfer of packaged parts, entire ADS layout becomes a single
“geometry” in Expedition library

Craft & validate Copper-only object with Momentum, Momentum optimization

Expedition Layout

»
>

ADS IFF
Layout

»
»

+Layer Map

Requirements: Layout IFF interface for ADS, Layout IFF importers for Expedition
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2005 %2 Agilent Technologies



ADS ->Cadence Concept/Allegro

RF Circuit with packaged parts and transmission lines

ADS Schematic becomes Concept sub-circuit,
ADS layout becomes grouped set of elements in Allegro

Concept Schematic

IFF

IFF H
+Layer Map Allegro Layout

+ geom/Via Map -

Requirements: Schematic and Layout IFF interfaces for ADS, Schematic and Layout
IFF importers for Concept/Allegro,

ADS packaged parts should be enhanced with Concept properties,

ADS geometries should (approximately) match Allegro geometries
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ADS ->Cadence Allegro

Copper-only RF Elements, no packaged parts

Appropriate for precise RF copper structures (spirals,
couplers, splitters) which would be hard to produce in
Allegro

Craft & validate Copper-only object with Momentum,
Momentum optimization

ADS layout becomes grouped set of elements in Allegro

+Laver Ma Allegro Layout
ADS IFF Y D

Requirements: Layout IFF interface for ADS, Layout IFF importer for
Concept/Allegro
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For more information about
Agilent EEsof EDA, visit:

www.agilent.com/find/eesof

Agilent Email Updates

www.agilent.com/find/emailupdates
Get the latest information on the
products and applications you select.

@ Agilent Direct

www.agilent.com/find/agilentdirect
Quickly choose and use your test

equipment solutions with confidence.

.

www.agilent.com

For more information on Agilent Technologies’
products, applications or services, please
contact your local Agilent office. The
complete list is available at:

www.agilent.com/find/contactus

Americas

Canada
Latin America
United States

(877) 894-4414
305 269 7500
(800) 829-4444

Asia Pacific

Australia 1800 629 485
China 800 810 0189
Hong Kong 800 938 693
India 1800 112 929
Japan 0120 (421) 345
Korea 080 769 0800
Malaysia 1800 888 848
Singapore 1800 375 8100
Taiwan 0800 047 866
Thailand 1800 226 008

Europe & Middle East

Austria
Belgium
Denmark
Finland
France

Germany

Ireland

Israel

Italy
Netherlands
Spain

Sweden
Switzerland
United Kingdom

082087 44 11

32 (0) 2 404 93 40
4570131515

358 (0) 10 855 2100
0825 010 700"
*0.125 €/minute
01805 24 6333
**0.14 €/minute

1890 924 204
972-3-9288-504/544
3902 92 60 8484
31 (0) 20 547 2111
34 (91) 631 3300
0200-88 22 55

0800 80 53 53

44 (0) 118 9276201

Other European Countries:
www.agilent.com/find/contactus
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