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Are you a signal integrity engineer?
Heard about ADS but haven’t used it yet?
Want a quick way to try it out for yourself?

Great, we created this e-book for you! It shows you how to drive ADS
and gives you a glimpse of some of its features and their benefits.

Sanjeev Gupta

Colin Warwick

Let’s get started!
Below, we’ll assume Windows ® and a default installation folder
C:\ADS2009U1\ .

First, request an evaluation license at this link:
(http://eval.soco.agilent.com/onlineevals/faces/home.
jsp?prodfam=SIVT&cmpid=34689)

When you receive your license file (license.lic):

• Click on the “New Evaluation License” tab:

• Save a copy to the folder C:\ADS2009U1\licenses .
• From the Start menu, start ADS:

• Send in the completed form.
• Download the installation zip file for your operating system from:
http://www.agilent.com/find/eesof-ads-latest-downloads
• Unzip into a fresh folder, say, C:\ads_cdimage\ .
• Inside that folder double click on setup.exe and follow the
instructions given by the installer.
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A First Look at ADS Using an Example Project
After the splash screen, the Main ADS window appears with the
‘Getting Started with ADS’ window over it. This has several Help
Center links on the right, but since you’ll be following this guide,
skip those for now. Instead:

• Choose or double click the SignalIntegrity folder.
• Don’t double click,
but use the Choose
button to select the
ChannelSimulatorPCIe2_prj project. (If
you do double click,
you’ll push down into
the project hierarchy
instead of choosing
the project. If so,
back out and use the
Choose button.)

• Click the Open an example project link:

The schematic window
named A_Readme.dsn
opens.
• From the menu bar of this window, select File ► Open Design…
► PCIe_channel_4.dsn
• In this Open Design
dialog box, click OK.
The schematic (a PCI
Express design) opens.
Note that the components EyeDiff_Probe1
and Eye_Probe1 are
collecting data before
and after the receiver
component, Rx_Diff.
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Simulate the Example Schematic
In the tool bar of this schematic window, click on the Simulate icon:

The before and after eye diagrams are nearly identical because the
receiver equalization is turned off.
• Back in the schematic, double click on the Rx_Diff component to
open its dialog box.
• Enable the Feed-forward equalizer:
• Click OK to dismiss
the dialog box.
• Simulate.
After completion, the
data display window
updates.

First the status window opens with some warnings (ignore these for
now), then messages about simulation progress, then after a minute
or so the data display opens:

Note the improvement
in post-receiver eye
height and width:
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Start a New Project
• Switch to the ADS Main window

• The New Project dialog box appears:

• Close the example project by selecting File ►Close Project:

• Enter: C:\users\
default\pcie in
the Name field.
• Click OK.
• ADS appends
_prj to the
project folder
name. By
default, the
Schematic
Wizard appears, but skip it for now and follow this guide instead.
• In the Schematic Wizard dialog box, select the No help needed
radio button.
• Click on the Finish
button to dismiss the
Wizard.

• Start a new project by selecting File ► New Project… from the
Main ADS window.
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Overview: The ABCs of ADS
In a nutshell:

A blank schematic window appears:

A) Place components, connection lines (called nodes), and simula.
tion controller onto the schematic. (The icon for schematic is
Later, we’ll explore the option to associate layout artwork
.)
with a schematic. The layout icon is
B) Create a dataset by clicking on the “run simulation” icon:

.

C) Create a data display to view your results in. The icon for the data
display is
.

That’s it! That’s all there is to it!
The ABCs will quickly become second nature to you. But for this first
pass, let’s walk through each one in detail by building a simple design
to look at the eye diagram that we will be transmitting later on.
From this point, there are only three steps between
you and answers you need in ADS. We call them:

The A B C ‘s of ADS

Schematic

Simulation

Data
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A. Place Components and Simulation Info on Schematic
• Select File ► Save Design As… from the Schematic menu bar.
The Save Design As dialog box appears:

• Click on the Diff Tx (differential transmitter) icon

.

• The cursor becomes a crosshairs with a ghostly image of the
component:

• Enter tx as the File
Name. ADS appends
.dsn to the file name.
• Click the Save button.
ADS saves the schematic in the networks
subfolder of your project folder pcie_prj. Save
early, save often.

• Click on the blank canvas to place the transmitter.
• The ghost image remains, so cancel out of the command by
pressing the Esc key or clicking on the End Command icon

Mirroring the real world, there are
thousands of components available
.
in the ADS library

• Pick the Diff Term (differential termination) icon and place it to the
right of the transmitter.
Some components are used so much they live not in a palette but on
the toolbar, e.g. Wire and Ground.

The palette on the left of the schematic is a tool to help organize them.
By default, the Lumped-Components
palette is displayed.

• Pick the Wire icon:

.

• Join the + and – nodes to + and – , respectively. The red dot turns
blue to indicate connection has been made.

• Click on the arrow to show the list
of available palettes.
• Select Simulation-ChanSim.
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A (cont.): Complete the Schematic
• Pick and place the EyeDiff_Probe (differential eye probe)
like so:

• Double click on the Tx_Diff1 instance to open its dialog box.
On the PRBS tab set:
• Set Bit Rate = 5 Gbps
• Vhigh = 1.2 V
• Vlow = –1.2 V
• Rise/Fall Time = 30 ps
• Register Length = 23
Click on the Help button to
bring up the doc page for the
component.

Any time you make a mistake, you can simply click on the undo
on the tool bar. If you change your mind, you can undo
button
.
the undoing by clicking on the redo button

The documentation pages
contain a wealth of information
about the parameters and
algorithms used.

You can set up the parameters of a given component instance
directly on the schematic or via its dialog box. We’ll use the latter
method for now.
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A: Set Component Parameters, (Continued)
B: Simulation Controller and Simulation,
C: Data Display
• On the Encoder tab set the encoding to 8B10B.

Step B: Simulation Controller and Simulation

• On the EQ tab, set Choose equalization method to Specific
de-emphasis and set De-emphasis as a positive quantity.

• Click on the Channel Simulator icon

.

• Drop the controller onto the schematic, then hit Esc to End
Command.
• Edit NumberOfBits to 20, by
directly clicking on the schematic.
• Click away to finish editing.
• On the schematic toolbar, click
.
on Simulate
Again the status window opens,
the simulation runs in a few seconds, and then the data display window opens.
• Click OK to
dismiss Tx_Diff1.

Step C: Data display

• Double click on
EyeDiff_Probe1.

• In the palette, click on the
Rectangular Plot icon and
drop a blank plot onto the
display area.

• In its dialog box,
set the Data rate
to 5 Gbps.
• Click on the
Measurement tab,
>> Remove >>
the default measurements, >> Add >> Waveform instead.
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C: Data Display (Continued)
When you drop a fresh plot
onto the data display canvas,
its dialog box opens automatically, with the default
data set tx selected.

• Click on a one that follows a one:

• Select Waveform.

• In the palette, select Eqn

• Click the >> Add >> button.

• Drop the equation onto the
canvas.

The de-emphasis is 0.802 V. Data
display equations are handy for all
sorts of things including calculation
of check values.

• Click OK.

.

• In its dialog box, enter the following
equation:

The plot appears. When a
one follows a one or a zero
follows a zero de-emphasis
has been applied. Check the
voltage.
• Click Insert a New Marker
.
icon

• Click OK.
• In the palette, select List
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C: Data Display, DesignGuide Installation (Continued)
• Instead of the default
dataset, select Equations
from the drop down list.

• Select DesignGuide
► Add DesignGuide…
from the main ADS
window.

• Select your deemp result
and >> Add >> it.

• You can add it as
Personal or Global
DesignGuide.

• Click OK
As expected, the value
agrees:

• Navigate to and select:
20090924_PCIExpress.
deb.

Congratulations!
You can manage your DesignGuides by selecting
DesignGuide ► List/Remove DesignGuide…

You completed the first simple “A B C” project.
We’ll pick up the pace now by using one of ADS’s powerful features: DesignGuides. These are pre-built project templates and tools.
In our case, we’ll use one that jump starts our PCI Express project.

• Create a fresh schematic window, for example by clicking on
in the Main window.
• Save As… pcie.dsn.

• Login to our Knowledge Center and download the PCI Express
Workshop DesignGuide from:
http://edocs.soco.agilent.com/display/eesofkc/PCIExpress
• Save it to your Desktop as 20090924_PCIExpress.deb .
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Determine Eye Diagram Performance for PCI Express Gen 2
We’ll add source/load impedance, transmitter and eye probe to the
pre-built DesignGuide PCI Express channel, then insert the receive
mask and check for violations.

• Select the differential source termination:
DesignGuide ► PCI Express ► PCI Express Source/Load
Terminations ► Source Impedance.
• Connect it to the differential input pins.

• On pcie.dsn place a PCI Express Channel model using the
schematic’s menu: DesignGuide ► PCI Express ► PCI Express
Interconnect Models ► Channel Model.
• Use the tool bar icon Push and Pop icons
the channel design hierarchy.

• Select Edit ► Move ► Move Component Text, then click on a text
block and move it if needed.
• Select the differential load termination: DesignGuide ► PCI Express
► PCI Express Source/Load Terminations ► Load Impedance.

to explore

• Connect three of them to other three differential pins:
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A Diversion Into S-Parameters
If you pushed into the hierarchy, you’d have noticed some
components were defined using S-parameters. So let’s take a short
break from the keyboard and first say why we use network parameters in general, and S-parameters in particular, to characterize high
frequency structures and components.

So, instead of a single transfer function, it might seem we now
need two parameters to characterize a 2-port component at each
frequency. In fact, the situation is more complex. The output port is
also being bombarded with waves reflected off of the component
in front of it in the cascade. These reverse waves are also partly
transmitted (backwards down the cascade) and partly reflected off
of the output port (heading back up the cascade). So we actually
need four numbers per frequency point. Each is a complex number,
representing magnitude and phase of the respective wave, relative
the incident wave.

For low speed digital logic we only consider
the forward propagation of signals, because,
although reflections exists, they generally
die down quickly if the interconnection flight
time (propagation time) is short compared to
the rise and fall times and the bit period. In fact, the incident signal
or wave is partly transmitted and partly reflected:

For reasons given below, it is convenient to collect the four numbers together in a two-by-two matrix called network parameters.
There are several formats each of which have their pros and cons.
The most convenient format for measurement purposes is the
S-parameter format, because you can measure S-parameters using
standard load, source, and connector impedances such as 50 ohms.
In contrast, direct measurement of, say, Z parameters requires
opens and short loads and sources, which are difficult to make at
high frequencies and can damage some components. Once you have
the S-parameters measured, there are simple calculations to convert
to other formats if needed.

Lightwave analogy

Incident

Transmitted

Reflected
Above figure: Agilent Application Note AN 1287-1, “Understanding
the Fundamental Principles of Vector Network Analysis”
http://cp.literature.agilent.com/litweb/pdf/5965-7707E.pdf
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A Diversion into S-Parameters (continued)
For a 2-port network, the S-parameters are:
Description

Network parameters can be generalized to more than two-ports and
more than simple cascade connection. Here we’ll use a 4 X 4 matrix
S-parameters to represent a four-port network: a pair of coupled
transmission lines such as those used in a differential interconnect.

Symbol

Desired transmission forwards of forward wave
incident on input port

S21

Unwanted reflection backwards of forward wave
incident on input port

S11

Unwanted transmission backwards of backward
wave incident on output port.

S12

Unwanted reflection forwards of backward wave
incident on output port

S22

One of the things ADS does really well is convert frequency domain
S-parameters into a time-domain model. Other tools often leave you
with an incorrect non-causal or non-passive conversion.
For more information on S-parameters, please see Agilent
Application Note AN 95-1, S-Parameter Techniques for Faster, More
Accurate Network Design, by Richard W. Anderson, available in two
formats:
• Slides plus interactive features:
(http://contact.tm.agilent.com/Agilent/tmo/an-95-1/index.
html?cmpid=34689)

The beauty of network parameters is that you don’t have to sum
an infinite series of partly reflected and partly transmitted waves
bouncing up and down the cascade. The trick is that you can easily
calculate the network parameters of arbitrary cascade of two-port
components using a simple matrix calculation. All the internal
reflections inside the newly created “black box” can be ignored, and
the cascade treated as a composite two-port network, characterized
by only four parameters per frequency point.

• Scan of the classic 1967 article:
http://cp.literature.agilent.com/litweb/pdf/5952-1130.pdf
Now let’s return to our PCI Express project…
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Add the Transmitter
From the Simulation–ChannelSim palette:
• Select Tx_Diff.
• Connect it to the input differential pins.
• Double click on Tx_Diff1 instance.
• Go to the appropriate tabs to edit the following parameters:
PRBS ► Bit rate
PRBS ► Vhigh
PRBS ► Vlow
PRBS ► Rise/Fall
PRBS ► Register Length
Encoder ► 8B10B
EQ ► Specify de-emphasis

5 Gbps
1.2 V
–1.2 V
30 ps
23
Enable
3.5 dB
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Add Eye Probe and Simulation Controller
• Select the EyeDiff_Probe from the same palette and connect it to
the differential output pins.

• Select the Plot Options tab.

• Place a Channel Simulation Controller (ChannelSim) on the
schematic page.

• Click OK.

• Select Format ► Engineering.

• Set the ChannelSim1 parameter NumberOfBits to 50000.

• Click in the Simulate tool bar icon:

.

A new data display window opens.
• Save the data display as pcie.dds.
• Place a rectangular plot and add the Density trace
from the default pcie data set.
• Place a List and add Summary measurements.
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Add an Eye Mask, Check for Mask Violation
• Go back to the pcie.dsn schematic.

• From the Measurements tab, Click the >> Add >> button to add
EyeMaskViolation measurement.

• Copy the receive mask file to current project directory by selecting: DesignGuide ► PCI Express ► PCI Express Mask ► PCI
Express Receive Mask.

• Click OK to dismiss the EyeDiff_Probe1 dialog.
• Simulate

• Double click on EyeDiff_Probe1.

.

• In the pcie data display, double click on the frame of the density
plot to open its dialog box.

• In its dialog box (Parameters tab), set the Use Eye Mask check
box.

• Click the >> Add >> button to add the Mask data.

• Click Browse.
• Navigate to PCIE Rx.msk and click Open.

You can double click
on any trace and set
the thickness, color,
etc. from the Trace
Options ► Trace
Options tab.

• Click the View/Edit button.
• Set Level zero to -0.4 and
Level one to 0.4.
• Click Refresh.
• Click Edit.
A text editor opens, showing the
mask file. You can edit or create
these files to suit. The format is
the same as those for Agilent
oscilloscopes.
• Dismiss the text editor.
• Dismiss the Eye Mask Viewer
dialog box.

A MaskViolated value of 0 (false) indicates no mask violation.
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BER Contours Using Statistical Mode of Channel Simulator
• Go back to the pcie schematic.

• Simulate

• Choose Statistical instead of Bit-by-bit mode from
ChannelSim1 ► Analysis tab.

.

• In the data display density plot, >> Add >> Contour.
• In rectangular plots, plot VoltageBathtub and, separately,
TimingBathtub.

• Customize the Title of the plot and the Min, Max, Step, and Label
of its axes from the Plot Options tab.

• >> Add >> Bathtub and Contour using the
EyeDiff_Probe1 ► Measurements tab.
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Channel Simulator: Bit-by-Bit Mode
Phase 1: SPICE-like transient response of single step – runs on
existing schematic.

By now you might be asking, “What’s the difference between
traditional transient (SPICE-like) simulation and the two modes of
Channel Simulator?”
Bit-by-bit mode works in two phases. First, we probe your schematic
with single step input. We use transient simulator but we also automatically use convolution (to deal with any components defined in
the frequency domain) and EM simulators (to deal with distributed
or layout components). The (computationally expensive) transient
simulation need run only for a short length of time, equal to the
pulse response also called the channel memory.
In phase two we use the step response from phase one as a linear
time invariant model. We use (computationally inexpensive) superposition to calculate the output for millions of bit without having to
call the transient, convolution, or EM simulators again.

Phase 2: Million-bit-per-minute throughput using superposition
Superposition

ISI
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Channel Simulator: Statistical Mode
In statistical mode, again we have two phases. The first phase is the
same as for bit-by-bit mode, but the second step is much quicker.
There’s no need for brute force superposition of each bit: just some
calculations based on:

Phase 1: SPICE-like transient response of single step – runs on
existing schematic

• ISI and crosstalk implied in the through
and crosstalk pulse responses
• Jitter spec
• Equalizer spec
• Line coding

Phase 2: Statistical calculations including ISI, crosstalk, jitter specification, equalizers, and encoding
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Comparison of Techniques
This table compares the three techniques.

Method

Applicability

Transient (SPICE-like)
Simulator

Channel Simulator,
Bit-by-bit mode

Channel Simulator,
Statistical mode

Modified nodal analysis of Kirchoff’s
current laws for every time step

Bit-by-bit superposition of step
responses

Statistical calculations based on
step response

Any circuit

LTI channel; finite, user-specified
bit pattern; adaptive or fixed eq.
taps

LTI channel; stochastic props of
infinite bit pattern; fixed eq. taps

~10-6

~10-16

BER floor in one minute
~10-3
simulation

Now, back to our project…
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Modeling Crosstalk,Comparing Two Simulations
• Save

• Connect it to the FEXT source termination.

the pcie schematic file.

Channel
Simulator
requires exactly
one Tx component, but you
can add as many
Xtlk2_Diff aggressors as you need.

• Delete the load termination at the far end of the crosstalk
channel (FEXT).
• Replace it with source termination.

• Select the Random radio button of the Phase Relative to Tx
setting of Xtlk2_Diff1 ► PRBS.
We’ll compare results with and without FEXT by saving the
modified version with a different name.

• From the Channel Simulator Palette, select the Xtlk2_Diff
transmitter.

• From the schematic menu select File ► Save Design As… and
enter pcie_fext.dsn.

• Click Mirror About Y Axis to flip the ghost cursor.

• Simulate

.

A new, blank data display window opens, but we want to re-use the
previous one, so:
• Close pcie_fext.dds .
• Go to your previous data display window.
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Compare Simulation With and Without Crosstalk
You can compare corresponding traces from two different datasets
by using their full names. These have the format: dataset..trace
(trace alone is just a shorthand for that item in the default dataset).
• Double click on the timing bathtub plot.
• Select pcie_fext, then add TimingBathtub:
• Similarly, add VoltageBathtub to that plot, and Summary to the

The eye height and width are reduced by FEXT, but the mask isn’t violated.

Let’s see if we can push
this design to a higher bit
rate…

List plot.
Overlaying two density and two contour traces on one plot is
possible but messy, so:
• Create a separate density and contour plot for the new data set.
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Explore the Design Space at 8 Gigabits per Second: Equalization
• Save

The mask still isn’t violated at our selected 10-12 BER contour, but
it’s getting close. How can we improve our margin? The channel
impairs the signal by acting like a low pass filter, and introducing
echo-like reflections. These smear out the impulse response.

the 5 Gbps version of the schematic.

• Change the data rate of Tx_Diff1 and EyeDiff_Probe1 to 8 Gbps.
• File ► Save Design As… and enter pcie_fext_8.
• Simulate

.

We can add an equalizer at the receive end that mitigates these
impairments. An equalizer is simply a filter whose response is the
inverse of the channel response.

• Compare the eye diagram as we did before.

Mitigate channel impairments with an equalizer
Mitigate impairments using:

Channel causes impairments

h(t)

δ(t)
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e(t)

Add a Feed Forward Equalizer (FFE)
For the Feed Forward Equalizer, we define the nth received sample as
r(n), and the Nth tap coefficient as t(N), then the nth output sample
e(n) is:

• Save

• From the Simulation-ChanSim palette, select and place an Rx_Diff
component.
• Add a single-ended eye probe like so:

N-1

e(n) =

Σ

the 8 Gbps version of the schematic.

t (k) r (n - k)

k=0

r (n)

t ×
0

Delay

r(n − 1)

Delay

t ×
1

r(n − 2 )

t ×
2

...

r (n − (N- 1))

t

N-1

×

• Edit Rx_Diff1 and Enable the FFE with Initial tap calculations as
Optimized, number of Pre-cursor taps as 1 and Post cursor taps as 2.

+
e(n)

• File ► Save Design As… and enter pcie_lfe.
• Simulate.
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Equalization Results, Next Steps
• Plot eye diagram before equalization and after equalization.
The receiver component has automatically calculated the optimized
tap coefficient values. You can output optimized tap coefficients:
• Double click on Rx_Diff1 and select Edit… ► Output ► Browse.
• In the Browse window, using right mouse click create a new file
taps.txt .
• Re-simulate the design and open taps.txt file to look at the taps
coefficients.

T

hank you for completing this tutorial. For more examples, please
login to our Knowledge Center:

http://agilent.com/find/eesof-knowledgecenter.
Also, please contact us if you’d like to purchase an annual or
perpetual ADS license.
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For More Information…
www.agilent.com
Selected web pages related to this e-book
Signal Integrity Analysis
http://www.agilent.com/find/signal-integrity
Signal Integrity Blog
http://signal-integrity.tm.agilent.com/
Evaluation License Request
(http://eval.soco.agilent.com/onlineevals/faces/home.
jsp?prodfam=SIVT&cmpid=34689)
Downloads
http://www.agilent.com/find/eesof-ads-latest-downloads
On-line Documentation
http://www.agilent.com/find/eesof-docs
Knowledge Center (examples)
http://www.agilent.com/find/eesof-knowledgecenter
Training Classes
http://www.agilent.com/find/eesof-class
Technical Support
http://www.agilent.com/find/eesof-support
Connected Solutions (connectivity to Agilent instruments)
http://www.agilent.com/find/eesof-connectedsolutions
Supported Computers and Operating Systems
http://www.agilent.com/find/eesof-platforms
Newsletter Subscription
http://www.agilent.com/find/eesof-visitreg
Community Forums
http://www.agilent.com/find/eesof-forum
Contact Info
http://www.agilent.com/find/eesof-contact
Windows is a U.S. registered trademark of Microsoft Corporation.

For more information on Agilent Technologies’ products, applications or services,
please contact your local Agilent office. The complete list is available at:
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Thailand

1 800 629 485
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800 938 693
1 800 112 929
0120 (421) 345
080 769 0800
1 800 888 848
1 800 375 8100
0800 047 866
1 800 226 008

Europe & Middle East
Austria
Belgium
Denmark
Finland
France
Germany
Ireland
Israel
Italy
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Spain
Sweden
Switzerland
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Other European Countries:

43 (0) 1 360 277 1571
32 (0) 2 404 93 40
45 70 13 15 15
358 (0) 10 855 2100
0825 010 700 (0.125 €/minute)
49 (0) 7031 464 6333
1890 924 204
972-3-9288-504/544
39 02 92 60 8484
31 (0) 20 547 2111
34 (91) 631 3300
0200-88 22 55
0800 80 53 53
44 (0) 118 9276201
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