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Chapter 1: Introducing the Filter Design
Guide
This chapter introduces the Filter DesignGuide. This manual assumes you have
installed the DesignGuide with appropriate licensing codewords.

Getting Started
The Filter DesignGuide provides SmartComponents and automated-assistants for
the design, simulation, and performance analysis of common passive filters.
Automated-assistants include a Filter Assistant, Simulation Assistant, Yield
Assistant and Display Assistant, which enable you to quickly create and verify a
design. All SmartComponents can be modified when selected. You simply select a
SmartComponent and with little effort redesign or verify their performance.

The complexity of the Advanced Design System (ADS) is made easily accessible
through the automated-assistants. This enables a first-time or casual ADS user to
begin using the capability of ADS quickly, and experienced ADS users will be able to
perform tasks faster than ever before. As an example, a singly terminated bandstop
elliptical filter can be designed, verified and a layout generated in a few minutes
saving the designer substantial time.

Note This manual is written describing and showing access through the cascading
menu preference. If you are running the program through the selection dialog box
method, the appearance and interface will be slightly different.

Setting Preferences

All DesignGuides can be accessed through either cascading menus or dialog boxes.
You can configure your preferred method in the ADS Main window or from the
Schematic window.
Getting Started 1-1



Introducing the Filter Design Guide
Note This manual is written describing and showing access through the cascading
menu preference. If you are running the program through the selection dialog box
method, the appearance and interface will be slightly different.

To configure access through menus or dialog boxes:

1. From the Main or Schematic window, select DesignGuide > Preferences .

2. In the DesignGuide Menu Style group box, choose either Use a selection dialog
box  or Use cascade menus .

3. Close and restart the program for your preference changes to take effect.

Note On PC systems, Windows resource issues might limit the use of cascading
menus. When multiple windows are open, your system could become destabilized.
Thus the dialog box menu style might be best for these situations.
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The ADS Main window DesignGuide menu contains the following choices:

DesignGuide Developer Studio  > Start DesignGuide Studio  is only available on this
menu if you have installed the DesignGuide Developer Studio. It launches the initial
Developer Studio dialog box.

DesignGuide Developer Studio  > Developer Studio Documentation  is only available on
this menu if you have installed the DesignGuide Developer Studio. It brings up the
DesignGuide Developer Studio documentation.

Note Another way to access the DesignGuide Developer Studio documentation is by
selecting Help > Topics and Index > DesignGuides > DesignGuide Developer Studio
(from any ADS program window).

Add DesignGuide  brings up a directory browser in which you can add a DesignGuide
to your installation. This is primarily intended for use with DesignGuides that are
custom-built through the Developer Studio.

List/Remove DesignGuide  brings up a list of your installed DesignGuides. Select any
that you would like to uninstall and choose the Remove button.

Preferences brings up a dialog box that enables you to:

• Disable the DesignGuide menu commands (all except Preferences) in the Main
window by unchecking this box. In the Schematic and Layout windows, the
complete DesignGuide menu and all of its commands will be removed if this box
is unchecked.

• Select your preferred interface method (cascading menus vs. dialog boxes).

Filter Design Flow

The Filter DesignGuide follows standard design procedure:

1. Select a component needed for your design.

2. Provide specifications.

3. Design and analyze the component.

4. If the component performance needs adjustment, optimize the component.

There are two important general concepts: SmartComponents and Automated
Assistants.
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SmartComponents

The DesignGuide provides many passive SmartComponents such as doubly and
singly terminated filters. SmartComponents contain specification parameters and a
schematic representation of the design.

SmartComponents are manipulated using several Automated Assistants. These
assistants enable you to easily design and simulate the SmartComponents.

SmartComponents are smart sub-network designs that can be placed into a
schematic. The Doubly Terminated Lowpass Filter Component is shown here.

The components are placed in the schematic by selecting the desired
SmartComponent from the palette and clicking at the point where you want them
placed in the schematic. The desired specifications of the SmartComponent are
entered by clicking on its parameters and changing them. In addition, a dialog box
containing all parameters is available by double-clicking on the SmartComponent.

The SmartComponent design (schematic) can be viewed by pushing into the
SmartComponent’s subnetwork. A SmartComponent subnetwork is empty until the
Design Assistant is used to generate the design. For details on the
SmartComponents, refer to Chapter 4, SmartComponent Reference.

Hint Place a doubly terminated lowpass filter SmartComponent into a schematic by
clicking the LowpassDT palette button and clicking within the Schematic window at
the desired placement location.

Edit SmartComponent
Parameters Here
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Creating a Design using SmartComponents

1. Choose and place a SmartComponent.

2. Edit the SmartComponent parameters (specifications).

3. Design the SmartComponent using the Filter Assistant.

4. Analyze the SmartComponent’s performance using the Simulation and Yield
Assistants.

5. Display the performance of the SmartComponent using the Display Assistant.

Automated Assistants

Five Automated Assistants are available in this DesignGuide. They provide quick
design, simulation, yield analysis, and performance display for SmartComponents.
They also enable transformation of lumped elements to transmission line elements.
Each Automated Assistant has a command page that is accessed from DesignGuide
control window. Explore each command page by selecting the associated tab (or
dialog) on the control window. Following are descriptions of each Automated
Assistant.

Filter Assistant  is used to generate/update a SmartComponent’s schematic
design for filter networks. After a SmartComponent is placed and the
parameters are specified, you start the Filter Assistant to design the

component. Subsequently, if the parameters of the SmartComponent are modified,
you start the Filter Assistant again to update the design. For more information, refer
to “Filter Assistant” on page 3-1.

Simulation Assistant  is used to automatically perform a simulation of a
SmartComponent. After a SmartComponent has been designed using the
Filter Assistant, you start the Simulation Assistant to automatically analyze

the component. You can easily examine the simulation results using the Display
Assistant. For more information, refer to “Simulation Assistant” on page 3-4.

Yield Assistant  is used to automatically perform a simulation of a
SmartComponent’s network sensitivity. After a SmartComponent has been
designed using the Filter Assistant, you start the Yield Assistant to

automatically analyze the component. You can easily examine the sensitivity results
using the Display Assistant. For more information, refer to “Yield Assistant” on
page 3-6.
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Display Assistant is used to automatically display the analysis results
generated using the Simulation Assistant. By starting the Display
Assistant, you can quickly display the results generated from the most

recent simulation of a SmartComponent. For more information, refer to “Display
Assistant” on page 3-11.

Transformation Assistant is provides an interactive environment for
transforming lumped elements to transmission lines within a designed
SmartComponent. For more information, refer to “Transformation

Assistant” on page 3-15.

Accessing the DesignGuide

The Filter DesignGuide is accessed from a Schematic window within ADS. First you
must create or open a project. From the ADS main window, select File > New Project
or File > Open Project, as shown here. For this example, create a new project called
QuickStart.

To open a Schematic window, select Window > New Schematic or click the New
Schematic Window toolbar button.

File Menu

New Schematic Window
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A new Schematic window appears, as shown here. The DesignGuide features are
accessed using the menu, control window, and SmartComponent palettes. The Filter
DesignGuide menu is available from the DesignGuide menu.

Note  Depending on how your ADS preferences are set, a Schematic window may
automatically appear when you create or open a project.
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The Filter DesignGuide Control Window

All DesignGuide features are available from the Control Window that houses menus,
a toolbar, and SmartComponent manipulation controls.

The window can be placed anywhere on the screen. To access the Control Window,
select the Filter Control Window sub-menu from the Filter menu. The menus and
toolbar buttons perform the basic functions for each automated Assistant (Design,
Simulate, Yield, and Display) as well as display the SmartComponent palettes. Full
features are available from each of the tab pages on the window. Explore each
Automated Assistant tab page by clicking on the tab at the top of each page. Explore

ToolbarMenus

Filter DesignGuide Control Window

Tab Pages
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the window menus as well to familiarize yourself with the basic DesignGuide
capabilities.

The window includes the following features and functions:

• You can place the window anywhere on the screen:

• With the fields at the top of the Control Window, you can navigate multiple
Schematic windows and SmartComponents.

• The Current Schematic drop-down list box enables you to select any of the
currently opened Schematic windows. This field is also updated when Passive
Circuit Control Window is selected from the Passive Circuit menu.

• The current design name is also displayed below the Current Schematic. The
SmartComponent drop-down list box enables you to select any of the
SmartComponents on the currently selected schematic window.

• The SmartComponent Capability field informs you of what functions (design,
simulate, optimize, and display) the DesignGuide can perform for that
particular component.

• To close the Control Window, select File > Exit DesignGuide from the Control
Window menu bar. The window may also be closed using the window close
feature of the operating system (a button marked with an ‘x’ at the top of the
window).

SmartComponent Palette Access

The SmartComponent palettes are displayed by using the right button group in the
control window toolbar or from the control window menu View menu. (They can also
be chosen from the palette list box in the Schematic window toolbar.) The Filter DG -
All Networks palette contains all of the filter SmartComponents. A blue accent in the
upper-left corner of a palette button indicates the component is a SmartComponent.
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Using the Filter Design Guide
This step-by-step example will take you through the design, analysis and sensitivity
simulation of a doubly terminated lowpass Chebyshev filter. After completing this
example, you should have a basic understanding of the DesignGuide.

Note This example is based on the assumption that you are familiar with the basic
features of Advanced Design System.

Create a New Design

A new schematic design is needed to contain the lowpass component for the following
exercises. Follow these simple steps to create a new design named Example.

1. Open a new Schematic window.

2. Select File > New Design from the Schematic window to create a Analog/RF
Network design named Example.

Open the DesignGuide Control Window

1. From the DesignGuide menu on the ADS Schematic window, select Filter.

2. From the Filter window, select Filter Control Window and click OK.

Design and Analyze a Lowpass Filter

A lowpass filter can easily be designed using the default component parameter
settings. Follow these simple steps to design a lowpass filter.

1. Display the Filter DG - All Networks palette . (Refer to the section,
“SmartComponent Palette Access” on page 1-9.)

2. Insert a LowpassDT component in the schematic . Click LowpassDT component,
then click within the schematic window at the desired placement location.
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3. Edit the LowpassDT component parameters . Select the LowpassDT component by
selecting it in the SmartComponent drop-down list box on the control window.
Select the Filter Assistant  tab. Change the response type by selecting the
Response Type drop-down menu box. Choose Chebyshev .

4. Design the LowpassDT component.  On the Filter Assistant  tab, click the Design
button. This will start the Filter Assistant and generate the design for the
SmartComponent.

5. Examine the LowpassDT filter design. Select the component LowpassDT and click
the Push Into Hierarchy  button on the schematic toolbar. After examining the
design, pop out of the SmartComponent by clicking the Pop Out of Hierarchy
toolbar button.

6. Analyze (simulate) the lowpass filter. Select the Simulation Assistant  tab page on
the control window and click the Simulate  button (accept default
frequency/display specifications). This will start the Simulation Assistant and
analyze the SmartComponent. The analysis results are shown here.

Lowpass DT

Push Into Hierarchy

Pop Out of Hierarchy
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7. Close the lowpass filter analysis results window. Close the display window by
choosing File > Close Window  from the menu.

Analyze Yield of the Lowpass Filter

After the design process, the component sensitivities of the lowpass filter network
can easily be checked using the Yield Assistant .

1. Find components to analyze. Select the Yield Assistant tab page on the control
window. Choose the View Components button that lies beneath the Statistical
Components list box, and then the Modify Statistics/Optimization button. The
matching network will be displayed in the schematic along with the following
dialog box.
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2. Choose components . Select Enabled  under Statistics Status  and then press the
Next  button to move on to the next component. Repeat this until all three
components in the network are enabled, and then choose Done.

3. Analyze yield sensitivity of the network. In the Yield Assistant tab, click
Automatically Set Frequencies > Simulate . This will start the Yield Assistant and
analyze the yield sensitivity to the selected component values. The sensitivity
histogram for component C1 is shown here. You may select other pages in the
display under the Page menu on the display window.
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4. Close the filter yield analysis results window. Close the display window. Select File
> Close Window  from the menu.

5. Delete the LCLowpassDT SmartComponent. Select Tools  > Delete
SmartComponent  from the DesignGuide control window menu.

Note This is different from the Delete button on the ADS schematic window
toolbar.
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Chapter 2: Using SmartComponents
This chapter describes how to use SmartComponents to design your filter.

Overview
This DesignGuide provides a large number of passive SmartComponents such as
doubly terminated filters, singly terminated filters and bandpass transformers.
SmartComponents are smart sub-network designs that can be placed into a
schematic and provide the container for specification parameters and a schematic
representation of the design. Several automated-assistants enable you to easily
design, simulate (analyze) and check sensitivities of the SmartComponents.

SmartComponents can be placed, copied, edited and deleted like other components in
the Advanced Design System. The basics of placement, copying, editing and deleting
are described here.

There are two methods to display the desired SmartComponent palette.

• Open the Filter DesignGuide control window by selecting DesignGuide > Filter >
Filter Control Window . Display the desired SmartComponent palette by selecting
the Component Palette button from the control window toolbar or by selecting
View > Component Palette - All from the control window menu.

• Select the desired SmartComponent palette from the Component Palette
drop-down list box in the Schematic window toolbar (directly above the palette).

Placing SmartComponents
To place a SmartComponent:

1. Click on the desired component button in the SmartComponent palette.

2. Click within the Schematic window at the location you want the
SmartComponent placed.

3. You may change the orientation of the SmartComponent before placement by
selecting from the Insert > Component > Component Orientation commands or by
repeatedly selecting Rotate by -90  from the schematic toolbar.

4. The place component mode will remain active until you choose End Command
from the schematic toolbar.
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Using SmartComponents
The available component palettes is as follows:

• All contains all of the SmartComponents.

Note When a SmartComponent is initially placed, a temporary component is used to
initially place and specify the parameters for the SmartComponent. This component
does not contain a subnetwork design. After the Design Assistant has been used to
design the SmartComponent, the temporary component is replaced with a permanent
component. The SmartComponent is renamed to DA_ComponentName_DesignName
and an autogenerated design is placed inside the SmartComponent’s subnetwork
design file. Subsequently, if the SmartComponent parameters are edited, the Design
Assistant will need to be used again to update the subnetwork design file.

Copying SmartComponents
SmartComponents can be copied within a design, to another design, or to another
Schematic window.

Copying Within A Design

1. Click the SmartComponent to be copied.

2. Select Edit > Copy  and then Edit > Paste  from the schematic window.

3. Click where you want the copy placed.

Copying Between Designs or Schematic Windows

1. Click the SmartComponent to be copied.

2. Select Edit > Copy from the Schematic window.

3. Display the design or schematic window you want to copy the SmartComponent
to.

4. Select Edit > Paste to copy the SmartComponent to the design.

5. Click where you want the component placed.
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Note All copied SmartComponents will initially refer to the same SmartComponent
design. When the Design Assistant is used to perform a design operation, it will
transform each copied SmartComponent into a unique SmartComponent design. A
design operation is accomplished by launching the Design Assistant from the
DesignGuide Control Window.

Editing SmartComponents
A SmartComponent’s position, orientation, and parameters can be edited like any
other component in ADS.

Position and Orientation

A SmartComponent is moved by dragging it to any location in the Schematic window.
It’s orientation is changed by following these steps.

1. Select Edit > Advanced Rotate/Mirror > Rotate  from the Schematic window or
select Rotate Items  from the toolbar.

2. Click on the desired SmartComponent.

3. Rotate the component.

4. The rotate mode will remain active until you select the End Command from the
toolbar.

Parameters

Parameters are changed by clicking on a SmartComponent parameter in the
Schematic window and editing it or by double-clicking a component and editing the
parameters in the component dialog box. Parameters may also be changed directly
from the DesignGuide control window.

Deleting SmartComponents
SmartComponents can be deleted from a design like other components, but
completely removing a SmartComponent’s files requires the actions described here.
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Delete From Current Design

A SmartComponent can be deleted from a design by selecting the component and
pressing the Delete key, selecting Delete from the toolbar, or by selecting Edit > Delete
from the schematic window. However, this does not remove the SmartComponent files
from the project directory.

Delete From Current Project

To delete a SmartComponent and all associated files from your project, follow these
steps.

1. From the DesignGuide control window or control toolbar, select the Delete
SmartComponent button.

2. Click on the SmartComponent you want deleted. This will delete the
SmartComponent from the current design and remove all of its files from your
project.

3. The SmartComponent delete mode will remain active until you select the End
Command from the schematic toolbar.

Delete Manually Using File System

You may use your computer’s file system to delete a SmartComponent by deleting the
appropriate files in the network subdirectory of a project. Delete files that start with
DA_, SA_’ and SEN_, contain the SmartComponent title, and end with .ael or .dsn.

Design, Analysis, and Yield
The DesignGuide contains several automated assistants that provide automatic
design, analysis, and sensitivity simulation for the SmartComponents. The following
assistants are available.

• Filter (Design) Assistant. The Filter Assistant is used to generate and update the
design contained within a Filter SmartComponent. It invokes a synthesis
engine that generates a design from the given specification. Refer to “Filter
Assistant” on page 3-1 for more information.

• Simulation (Analysis) Assistant. The Simulation Assistant is used to analyze the
design contained within a SmartComponent. It creates a simulation circuit
containing the SmartComponent, then performs a simulation. It can also
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automatically display the results of the simulation. Refer to “Simulation
Assistant” on page 3-4 for more information.

• Yield Assistant. The Yield Assistant is used to analyze the sensitivity of the
network contained within a SmartComponent. It creates a yield analysis circuit
containing the SmartComponent, then performs a simulation. Refer to the
chapter “Yield Assistant” on page 3-6 for more information.

• Display Assistant . The Display Assistant is used to quickly display the
performance of a SmartComponent. Display templates have been created for all
of the SmartComponents. The display templates are preconfigured displays
that provide a comprehensive look at the component’s performance. Refer to
“Display Assistant” on page 3-11 for more information.

Stand-Alone SmartComponent Usage
Once SmartComponents are designed and tested, they can be used as stand-alone
components. The Filter DesignGuide is not needed to use them in new designs unless
you wish to modify or analyze them.

Using an Existing SmartComponent Within the Same Project

1. Open the Component Library window by selecting Insert > Component  >
Component Library  from the Schematic window or Display Component Library
List  from the toolbar.

2. Select the project name under All > Sub-networks in the Libraries list at the left
of the Component Library window. Available components will be listed in the
Components list at the right of the Component Library window.

3. Select the desired SmartComponent in the Components list.

4. Place the desired SmartComponent into your design by clicking in the
Schematic window at the location you wish it placed.

5. The insert mode will remain active until you select End Command  from the
toolbar.

Using an Existing SmartComponent in Any Project

A library of predesigned reusable SmartComponents can be easily created. This is
done by placing the reusable SmartComponents in a project. This project can be
Stand-Alone SmartComponent Usage 2-5



Using SmartComponents
included in any project and its SmartComponents will be accessed using the
Component Library. Follow these steps.

1. Select File  > Include/Remove Projects  from the main ADS window.

2. Select the project that contains the desired SmartComponent from the File
Browser at the left of the Include & Remove window.

3. Choose the Include button to include the project in the hierarchy.

4. Chose the OK button.

5. Open the Component Library window by selecting Insert > Component >
Component Library  from the Schematic window or Display Component Library
List from the toolbar.

6. Select the included project name under All > Sub-networks  in the Libraries list
at the left of the Component Library window.

7. Available components will be listed in the Components list at the right of the
Component Library window.

8. Select the desired SmartComponent in the Components list.

9. Place the desired SmartComponent into your design by clicking in the
Schematic window at the location you wish it placed.

10. The insert mode will remain active until you select End Command  from the
toolbar.
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Chapter 3: Using Automated Assistants
This chapter describes the four Automated Assistants used to design, simulate,
optimize, analyze, and transform SmartComponents.

Filter Assistant
The Filter Assistant is used to generate and update the design contained within a
single SmartComponent from the given specifications. The Filter Assistant is
accessed using the Filter DesignGuide control window. From the control window, full
design control is enabled from the Filter Assistant  tab. Component design operations
can also be accomplished using the control window menu and toolbar. Any parameter
change made from the Filter Assistant  tab is reflected on the SmartComponent in the
schematic.

To view a SmartComponent, select the desired SmartComponent from the
SmartComponent drop-down list box in the upper right corner of the control window.
The SmartComponent parameters are shown inside the Filter Assistant  tab.
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Impedances

• Source - source termination impedance(Rg), in Ohms. This value must be a real
number greater than zero.

• Load - load termination impedance(Rl), in Ohms. This value must be a real
number greater than zero.

• First Component - Either parallel or series. Refers to the first component in the
network topology after designing. Parallel will design for minimal inductor
values in the network. Series will design for minimal capacitor values in the
network.

Order

The filter order is automatically calculated depending upon the parameters specified
for all the response types except Bessel-Thomson and Gaussian. For these two
responses a filter order must be input manually using the Order (N) text box.

Design Information

Design Information is not editable, but rather shows information about the filter.

• Order - is the filter order.

• Minimum Insertion Loss - shows the minimum insertion loss due to unequal
terminations. The insertion loss is zero if terminations are matched.

Response Type

There are six filter response types that can be used for designing: Maximally Flat
(Butterworth), Chebyshev, Elliptical, Inverse-Chebyshev, Bessel-Thomson, and
Gaussian. A plot of the filter response is show below the Response Type drop-down list
box. Pressing the Redraw button will automatically scale and redraw the response
plot.

Frequency

Frequency settings can be changed by either moving the vertical frequency slide bars
on the response plot or by changing the values in the frequency text boxes. The
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frequency text box captions dynamically change depending on the SmartComponent
being used. For any lowpass or highpass network:

• Fp - passband corner frequency

• Fs - stopband frequency edge

• Units - used for both frequencies

For any bandpass of bandstop network:

• Fp1 - lower passband corner frequency

• Fp2 - upper passband corner frequency

• Fs1 - lower stopband frequency edge

• Fs2 - upper stopband frequency edge

• Units - used for all frequencies

Attenuation

Attenuation settings can be changed by either moving the horizontal attenuation
slide bars on the response plot or by changing the values in the attenuation text
boxes.

• Ap - passband attenuation, in dB

• As - stopband attenuation, in dB

Zooming in/out of the response plot is possible using the dB/square spin-box.

Realizations

These parameters tell the Filter DesignGuide how many networks to show after
designing. If View All is not checked only one network will be synthesized. If View All
is checked the number of shown networks can be specified in the Max # text box.

Design

The design is accomplished using one of the following methods.

• Push the Design button on the Design Assistant tab. The design progress is
indicated on the tab page.
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• Push the Design  button on the Control Window toolbar.

• Select Tools  > Auto-Design  from the Control Window menu.

If multiple realizations for the filter network were found, a dialog box will appear.

All networks can be viewed using the Component List spin box. Each network will be
viewed in two places:

• Dialog Box - shows a text based description of the current network.

• Schematic Window - shows the actually drawing of the current network.

Choosing the Done button causes the dialog box to close. The last viewed filter
network will become the subnetwork of the designed SmartComponent.

Simulation Assistant
The Simulation Assistant is used to analyze the design contained within a
SmartComponent. It creates a simulation circuit around the SmartComponent, then
automatically performs the appropriate simulation. If desired it will also
automatically display the simulation results.

The Simulation Assistant is accessed using the Filter DesignGuide control window,
where full simulation control is enabled from the Simulation Assistant tab. Basic
simulation can also be accomplished using the control window menu and toolbar.
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For all simulation operations, the selected SmartComponent is designed if necessary,
a simulation schematic is created, the simulation is performed, and the results are
displayed. The simulation frequency sweep must be specified on the Simulation
Assistant tab in the control window as described in detail below.

Simulation Frequency Sweep

The simulation frequency sweep is specified on the Filter DesignGuide control
window. While performing the simulation from the control window, select the
Simulation Assistant tab and specify the sweep by entering the start frequency, stop
frequency, and either frequency step size or number of points. The values entered are
stored in the selected SmartComponent (as displayed in the SmartComponent
drop-down list box) and will be recalled each time this SmartComponent is selected.

Automatically Display Results

If the Automatically Display Results box on the control window Simulation Assistant
tab is selected, the simulation results will be automatically displayed upon
completion of the analysis.
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Starting the Simulation

The simulation may accomplished using one of the following methods.

• Choose the Simulate button on the Simulation Assistant tab.

• Choose the Simulate  button on the control window toolbar.

• Select Tools  > Auto-Simulate  from the control window menu.

Simulation Templates

In some cases, it might be useful to manually simulate the SmartComponent. To
generate a simulation schematic around the selected SmartComponent, press the
Create Template button on the control window Simulation Assistant tab. You can
examine or modify the simulation schematic, then manually start the simulation by
selecting Simulate  > Simulate  from the Schematic window. When you are finished,
pressing the Update from Template  button on the Simulation Assistant tab will
transfer any changes you have made to the SmartComponent on the simulation
schematic to the original SmartComponent and redesign if necessary. You may also
manually close the simulation schematic using File  > Close Design  from the
Schematic window menu, although this will result in loss of any changes you have
made to the SmartComponent.

Yield Assistant
The Yield Assistant is used to analyze the design sensitivities contained within a
SmartComponent. It creates a yield analysis circuit containing the SmartComponent,
then performs a simulation. By sweeping the component values for a selected set of
components in the network, this analysis generates a probability density function of
the performance given statistical variations of the component values. The probability
that the performance will remain within the specified bounds is the yield of the
network.

The Yield Assistant is accessed using the Filter DesignGuide control window, where
full control is enabled from the Yield Assistant tab. Basic yield analysis can also be
accomplished using the control window menu and toolbar.
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The selected SmartComponent must be designed before yield analysis can be
performed. The analysis proceeds by statistically sweeping the value of each selected
component and analyzing the impact of this component value variation on the
frequency response of the network.

Simulation Frequency Sweep

The simulation frequency sweep is specified on the Yield Assistant tab of the Filter
DesignGuide control window. From this tab, specify the sweep by entering the start
frequency, stop frequency, and either frequency step size or number of points. The
values entered are stored in the selected SmartComponent (as displayed in the
SmartComponent drop-down list box) and will be recalled each time this
SmartComponent is selected.

Statistical Components

The Statistical Components list-box displays all components that will be statistically
varied during simulation.

Pushing View Components will bring up a dialog box that shows the yield status of
the components in the network.
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Pressing Modify Statistics/Optimization  brings up the dialog shown below to simplify
the process of selecting components. The filter network will also be shown in the
schematic with the currently selected component highlighted.

To sweep this component value statistically during the analysis, select Enabled in the
Statistics Status box. You can then specify the parameters of the statistical sweep.

Once you have specified all parameters for a component, pressing Next  proceeds to
the next component in the network. The analysis allows for a maximum of 4
components to be selected at one time. Once you have finished specification, press
Done .

Click View Statistical Components to view a summary of the statistical parameters for
each selected component. Click Modify Statistics/Optimization to open the Modify
Component Parameters dialog from this summary dialog to facilitate editing of the
statistical sweep parameters.

The # Simulations parameter specifies the number of Monte Carlo simulations that
will be used to estimate the statistical behavior of the network. Increasing the
number of simulations will increase the statistical sample size and therefore provide
a better estimate of the performance at the expense of increased computational time.
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Yield Optimization

The network component values can also be optimized so that the performance is less
sensitive to component value variations. This can be accomplished by selecting the
Yield Optimization check box. The simulation will use the ADS engine to optimize the
selected component values.

Specifying an appropriate set of Yield/Optimization Goals is a critical step in
ensuring this optimization yields acceptable results. The # Iterations parameter
available for Yield Optimization specifies the maximum number of optimization
iterations that the simulation will perform to try to find the appropriate network
component values.

Yield/Optimization Goals

Yield and Yield Optimization simulations require that a set of performance (yield)
goals be specified for the network. The yield is defined as the probability that the
network frequency response will satisfy these performance specifications given the
statistical properties of the individual components.

Yield simulations use these goals to determine the percentage of networks that will
satisfy the specifications given tolerances of the components. Yield Optimization
simulations use the goals in determining suitable component values that maximize
the yield.

Each component has a default set of goals depending on the type of response
(lowpass, bandpass, etc.). You can modify these goals, including adding or deleting
goals, by pressing the Set Yield Spec/Goals  button on the Yield Assistant tab which
will bring up the following dialog.

Each goal specifies the desired insertion loss performance of the network in dB and
can represent a specification that the value stay above or below the stated level. The
specification can be at a single point, or over a given frequency band. New goals can
Yield Assistant 3-9



Using Automated Assistants
be added using the Add Goal  button. Individual goals can be deleted using the Del
button to the right of the goal, or all of the goals can be deleted using the Delete All
Goals  button. The goals can be reset to their default values using the Default  button.
A goal will be used in the analysis only if the Active box at the left of the goal line is
checked.

Automatically Display Results

If the Automatically Display Results box on the control window Yield Assistant tab is
selected, the simulation results will be automatically displayed upon completion of
the analysis.

Starting the Simulation

The yield analysis may accomplished using one of the following methods.

• Push the Simulate button on the Yield Assistant tab.

• Push the Simulate Yield button on the control window toolbar.

• Select Tools  > Auto-Simulate Yield from the control window menu.

Yield Results

For each component (up to a maximum of 4) chosen for yield analysis, a yield
sensitivity histogram will be displayed. The yield definition can be changed on the
first page of the display by setting passband frequencies Fp_1 and Fp_2 as well as the
maximum insertion loss at these frequencies, and stopband frequencies Fs_1 and
Fs_2 as well as the minimum insertion loss at these frequencies. Other pages in the
display show the overall statistics of the yield as well as the frequency response for
each of the Monte Carlo simulations.

Yield Templates
In some cases, it might be useful to manually simulate the SmartComponent. To
generate a simulation schematic around the selected SmartComponent, press the
Create Template button on the control window Yield Assistant tab. You can examine or
modify the simulation schematic, then manually start the simulation by selecting
Simulate > Simulate from the Schematic window. When you are finished, pressing the
Close Template  button on the Yield Assistant tab will return you to the original
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design. You may also manually close the simulation schematic using File  > Close
Design  from the Schematic window menu.

Display Assistant
The Display Assistant is used to easily and quickly display the performance of a
SmartComponent. The display templates are preconfigured display files that provide
a comprehensive look at the performance of the component. You can create your own
displays or modify the included display templates using the built in features of
Advanced Design System, but in most situations, the included display templates will
provide all the information you need.

The Display Assistant is accessed using the Filter DesignGuide control window,
where full display control is enabled from the Display Assistant tab. Basic display
selection can also be accomplished using the control window menu and toolbar.

Display Template Features

The display templates opened by the Display Assistant have common features that
are discussed here. For features unique to the display templates of some
SmartComponents, refer to the chapter Chapter 4, SmartComponent Reference.
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Basic Layout

Following is the basic layout of the display templates. Area one of the display
template contains a graph of the most important parameters of the
SmartComponent. Area two contains several graphs that give a comprehensive look
at the component’s performance. Area three contains a table listing the basic
specifications and performance of the component.

Typical Area One Graph

A typical graph from area one of a display template follows. The frequency range of
the graph is determined by the Simulation Assistant. As you change the frequency
range in the Simulation Assistant, this graph will update appropriately. The markers
A and B are used to define the frequency range of the graphs in area two. This feature
is used to zero in on the region of interest and obtain a comprehensive look at the
component’s performance. The marker M1 can be moved by dragging it with the
mouse. The performance at the frequency given by M1 will be shown in the table in
area three.

1.

2.

3.
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Typical Area Two Graphs

Typical graphs from area 2 of a display template are shown here. These graphs
provide a quick, comprehensive look at the component’s performance. Their
frequency range is determined by the location of the “A” and “B” markers found in the
main graph. Any markers such as M2 shown here can be moved by dragging them
with the mouse. Performance criteria at the marker frequency will be displayed in
the table in area three.
Display Assistant 3-13



Using Automated Assistants
Typical Area Three Templates

A typical table from area three of a display template is shown here. The white rows
show the desired specifications and important performance criteria for the
component. The gray rows give the performance criteria at the user defined marker
frequencies. The box below the table provides explanatory information for the table.

Display Assistant Operation

Before using the Display Assistant, a valid dataset from a simulation of the selected
SmartComponent must exist in the current project data directory. This simulation
can be conveniently accomplished using the Simulation Assistant. Refer to the
Simulation Assistant chapter for details on this step.

Opening a Display

To display results from a SmartComponent simulation using the control window,
select the desired SmartComponent from the SmartComponent drop-down list box in
the upper right corner of the control window. The display is then launched using one
of the following methods.
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• Choose the Display button on the Display Assistant  tab.

• Choose the Display button on the control window toolbar.

• Select Tools  > Auto-Display  from the control window menu.

If no valid dataset exists for the selected SmartComponent, the Display button on the
Display Assistant  tab will be insensitive. If the toolbar or menu are used to try to
display the results, a message will appear indicating that no dataset exists.

Display Templates

In some cases, it might be useful to use one of the display templates provided with
the DesignGuide for other applications. To gain access to one of these templates,
select the desired template from the Available Templates field and press the Open
Display Template  button on the control window Display Assistant tab. You can then
insert a dataset of your choice using the dataset pull-down list box in the upper left
corner of the display. You may find that some parameters in the display template are
not defined in the selected dataset and may want to make appropriate modifications
to the display. These changes can be saved using the commands in the display File
menu.

Transformation Assistant
Once a Filter DesignGuide SmartComponent has been designed, the lumped
inductors and capacitors can be transformed into equivalent distributed element
counterparts using the Transformation Assistant. This feature enables you to quickly
and easily transform an ideal filter topology to a form that is realizable for
high-frequency systems.

Accessing the Transformation Assistant

The Transformation Assistant dialog box is accessed from the Filter DesignGuide
control window, either by selecting Tools  > Distributed Element Transformations from
the control window menu or from the Toolbar.
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When the Transformation Assistant is opened, the SmartComponent subnetwork
appears in the schematic window and a dialog box is opened. The transformations are
then accomplished using the controls on the dialog.

Selecting a Transformation Type

The type of transformation to be applied is selected from three options:

• LC to TLine - Transforms lumped inductors and capacitors to ideal
transmission line elements. Eight different inductor/capacitor combinations can
be transformed to different series lines, series stubs, or shunt stubs.

• TLine to TLine (Kuroda) - Apply Kuroda’s identities in order to transform series
short circuited stubs to shunt stubs that are realizable in microstrip and other
printed transmission line technologies.
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• LC, TLine to Microstrip - Transforms lumped inductors and capacitors as well
as ideal transmission line structures to microstrip equivalent components.
Application of this transformation requires a valid license for the Passive
Circuit DesignGuide.

Once a transform has been selected, the graphical area displays the components that
can be transformed using the current selection. Black components represent
elements included in the original circuit available for transformation, while gray
components represent elements not included in the original circuit.

From this graphical area, use the left mouse button to select one of the available
component types. The graphical area will change to reveal the different distributed
element equivalents available for substitution. The example below shows the
transformations available when a series inductor circuit has been selected.
Transformation Assistant 3-17



Using Automated Assistants
From this point, the type of equivalent network can be selected using the left mouse
button from the available structures at the right of the graphics area. A box
highlights the currently selected structure. Text at the bottom of the window changes
as different selections are made, providing help for the particular transform selected.

Component Selection

Once the type of circuit component to be transformed is selected, the actual circuit
elements to apply the transform to can be selected using the Component Selection
tools. As the left and right arrows within this area are pushed, valid components
within the original circuit will be highlighted, and their instance names (i.e. L1, C4)
will appear in the text box on the Transformation Assistant dialog. The three buttons
are used to select which specific components should be subject to the current
transformation:

• Add - Add the currently selected component(s) to the transformation list.

• Add All  - Add all circuit components of the appropriate type to the
transformation list.

• Cut - Remove the currently selected (highlighted) item in the transformation
list from the list.

Transformation Buttons

The buttons across the bottom of the dialog box are used to accomplish the
transformation on the selected components.

• Transform - Apply the selected transform to the component in the
transformation list.

• Undo - Undo the last performed transform. This button can be used repeatedly
to undo all previous transformations.

• OK - Accept the current transformed circuit and close the dialog box. Once the
transformed circuit has been accepted, transformations cannot be undone.

• Cancel  - Close the dialog box and revert to the original, untransformed circuit.

Changing Component Type

Once all transformations have been made on a specific component type (such as
series inductor), performing a left mouse click on the red return arrow in the upper
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left hand corner of the graphic area (or performing a right mouse click anywhere on
the graphic area) can be used to return to the main component selection page.
Another component type can then be selected, and the transformation steps can be
repeated for this new selection.

Transmission Line Types

There are five basic transmission line elements that can be produced using the
Transformation Assistant. These are identified as follows:
.

Additional Transformation Functions

Unit Element

For certain transformations, either the electrical length or characteristic impedance
of the resulting transmission line must be specified by the user. If the Unit Element
box is checked, the resulting transmission line will have an electrical length of 45
degrees and the characteristic impedance will be computed appropriately. If the Unit
Element  box is unchecked, then the Characteristic Impedance (Z 0) box will become
active and the computation will use this characteristic impedance to compute the
appropriate length.

Series Transmission Line

Series Short Circuit Stub

Series Open Circuit Stub

Parallel Short Circuit Stub

Parallel Short Circuit Stub
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Characteristic Impedance

The Characteristic Impedance (Z 0) box is used to specify the desired transmission line
characteristic impedance for certain transformations. In cases where either the
electrical length or the characteristic impedance can be specified, this box works in
conjunction with the Unit Element box as discussed above. In certain other cases,
this Characteristic Impedance (Z 0) box is used alone. For example, when adding lines
to the front or end of a network as part of Kuroda’s identities, the characteristic
impedance of the transformation can be specified using this box.

Add Transmission Lines

As part of the TLine to TLine transformation, unit element (45 degree electrical
length) transmission lines can be added to the front or end of the network. The
characteristic impedance of these lines is specified using the Characteristic Impedance
(Z0) box. Such lines can be added as needed during the transformation process.

Note Addition of these lines will change the phase response and, if the
characteristic impedance is not equal to the network terminal impedance, the
magnitude response of the network.

Microstrip Substrate

When performing LC, TLine to MLine transformations, the microstrip substrate
thickness (h) and relative permittivity (Er) must be specified. All microstrip elements
within a design must share the same substrate parameters. The substrate
parameters used in the final design will be the values that appear in the boxes after
the final transformation step.

TLine to TLine Transforms (Kuroda Identities)

The TLine to TLine transforms are typically used to transform series short-circuited
stubs to parallel open circuited stubs in preparation for implementation in planar
transmission line technologies. These operations, however, only work on Unit
Element lines with electrical lengths of 45 degrees. Therefore, when performing
lumped to ideal distributed transformations, it is necessary to perform substitutions
that conform to this Unit Element specification. Preferred stubs (highlighted in blue
on the graphical area) as well as series transmission lines (transformed with the Unit
Element  box checked) will be able to be transformed in this way. When adding
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transmission line elements before or after the network, the electrical length will be
45 degrees and only the characteristic impedance must be specified.

Microstrip Transforms

Note This set of transforms is only available if a valid license for the Passive Circuit
DesignGuide exists.

The LC, TLine to MLine transformations form a somewhat unique class of operations.
This set of transformations takes lumped inductor/capacitor combinations as well as
ideal series transmission lines and shunt transmission line stubs (obtained from the
LC to TLine transformations), and converts them to microstrip. Note that series
stubs cannot be used in this transformation since they cannot be realized in
microstrip.

In addition to the standard transmission line topologies, certain lumped elements can
be replaced with SmartComponents from the Passive Circuit DesignGuide. The
available SmartComponents are as follows:

When making such substitutions, the design capabilities of the Passive Circuit
DesignGuide are used to realize the topologies. In this case, however, the design
procedure is approximate, and some tuning of the elements may be required before

Interdigital Capacitor (can be in series or parallel)

Series Microstrip Thin Film Capacitor

Rectangular Spiral Inductor (can be in series or paralle

Spiral Inductor (can be in series or parallel)

Parallel Radial Stub

Parallel Butterfly Radial Stub
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the substituted device will offer the correct performance. In such cases, following
completion of the transformation, push into the SmartComponent on the schematic
window and open the Passive Circuit DesignGuide control window. The Simulation
and Optimization Assistants in the Passive Circuit DesignGuide SmartComponent
can then be used to quickly and efficiently tune the performance of each individual
element.
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Chapter 4: SmartComponent Reference
This chapter provides detailed information for all filter SmartComponents.

SmartComponent List
LCLowpassDT (Doubly Terminated Lowpass Filter)

LCHighpassDT (Doubly Terminated Highpass Filter)

LCBandpassDT (Doubly Terminated Bandpass Filter)

LCBandstopDT (Doubly Terminated Bandstop Filter)

LCLowpassST (Singly Terminated Lowpass Filter)

LCHighpassST (Singly Terminated Highpass Filter)

LCBandpassST (Singly Terminated Bandpass Filter)

LCBandstopST (Singly Terminated Bandstop Filter)
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SmartComponent Reference
LCLowpassDT (Doubly Terminated Lowpass Filter)

Symbol

Parameters

Fp = passband corner frequency, in hertz

Fs = stopband frequency, in hertz

Ap = passband attenuation, in dB

As = stopband attenuation, in dB

N = order of filter, unitless

ResponseType = type of filter response

MinLorC = mininum inductance or capacitance

Rg = source impedance, in ohms

Rl = load impedance, in ohms

MaxRealizations = maximum number of realizations during synthesis

Notes

1. A doubly terminated lowpass filter provides a lowpass frequency response
between the input (pin 1) and output (pin 2) ports. This component can have
any real, non-zero impedance at either the source or load terminations.

2. The type of frequency response (i.e. Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response
depend on the filter order.

3. The filter order is either set manually or is calculated by the passband and
stopband frequencies and attenuations.
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Example

A maximally flat lowpass filter was designed for 3dB attenuation at 1 GHz and 20dB
attenuation at 2 GHz with matched 50 ohm terminations. This resulted in a filter
order of N=4.
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SmartComponent Reference
LCHighpassDT (Doubly Terminated Highpass Filter)

Symbol

Parameters

Fs = stopband frequency, in hertz

Fp = passband corner frequency, in hertz

Ap = passband attenuation, in dB

As = stopband attenuation, in dB

N = order of filter, unitless

ResponseType = type of filter response

MinLorC = mininum inductance or capacitance

Rg = source impedance, in ohms

Rl = load impedance, in ohms

MaxRealizations = maximum number of realizations during synthesis

Notes

1. A doubly terminated highpass filter provides a highpass frequency response
between the input (pin 1) and output (pin 2) ports. This component can have
any real, non-zero impedance at either the source or load terminations.

2. The type of frequency response (i.e. Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response
depend on the filter order.

3. The filter order is either set manually or is calculated by the passband and
stopband frequencies and attenuations.
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Example

A chebyshev highpass filter was designed for 20dB attenuation at 1 GHz and 3 dB
attenuation at 2 GHz with matched 50 ohm terminations. This resulted in a filter
order of N=3.
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SmartComponent Reference
LCBandpassDT (Doubly Terminated Bandpass Filter)

Symbol

Parameters

Fs1 = lower stopband frequency, in hertz

Fp1 = lower passband corner frequency, in hertz

Fp2 = upper passband corner frequency, in hertz

Fs2 = upper stopband frequency, in hertz

Ap = passband attenuation, in dB

As = stopband attenuation, in dB

N = order of filter, unitless

ResponseType = type of filter response

MinLorC = mininum inductance or capacitance

Rg = source impedance, in ohms

Rl = load impedance, in ohms

MaxRealizations = maximum number of realizations during synthesis

Notes

1. A doubly terminated bandpass filter provides a bandpass frequency response
between the input (pin 1) and output (pin 2) ports. This component can have
any real, non-zero impedance at either the source or load terminations.

2. The type of frequency response (i.e. Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response
depend on the filter order.

3. The filter order is either set manually or is calculated by the passband and
stopband frequencies and attenuations.
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Example

An elliptical bandpass filter was designed for 3dB attenuation between 1 GHz and
2 GHz and 20 dB attenuation below .5 GHz and above 2.5 GHz with matched 50 ohm
loads. This resulted in a filter order of N=4.
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SmartComponent Reference
LCBandstopDT (Doubly Terminated Bandstop Filter)

Symbol

Parameters

Fp1 = lower passband corner frequency, in hertz

Fs1 = lower stopband frequency, in hertz

Fs2 = upper stopband frequency, in hertz

Fp2 = upper passband corner frequency, in hertz

Ap = passband attenuation, in dB

As = stopband attenuation, in dB

N = order of filter, unitless

ResponseType = type of filter response

MinLorC = mininum inductance or capacitance

Rg = source impedance, in ohms

Rl = load impedance, in ohms

MaxRealizations = maximum number of realizations during synthesis

Notes

1. A doubly terminated bandstop filter provides a bandstop frequency response
between the input (pin 1) and output (pin 2) ports. This component can have
any real, non-zero impedance at either the source or load terminations.

2. The type of frequency response (i.e. Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response
depend on the filter order.

3. The filter order is either set manually or is calculated by the passband and
stopband frequencies and attenuations.
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Example

An Inverse-Chebyshev bandstop filter was designed for 20 dB attenuation between
1 GHz and 2 GHz and 3 dB attenuation below .5 GHz and above 2.5 GHz with
matched 50 ohm loads. This resulted in a filter order of N=4.
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SmartComponent Reference
LCLowpassST (Singly Terminated Lowpass Filter)

Symbol

Parameters

Fp = passband corner frequency, in hertz

Fs = stopband frequency, in hertz

Ap = passband attenuation, in dB

As = stopband attenuation, in dB

N = order of filter, unitless

ResponseType = type of filter response

MinLorC = mininum inductance or capacitance

Rg = source impedance, in ohms

Termination = open or short load termination

MaxRealizations = maximum number of realizations during synthesis

Notes

1. A singly terminated lowpass filter provides a lowpass frequency response
between the input (pin 1) and output (pin 2) ports. This component will have a
real, non-zero source termination and either an open or short at the load
termination.

2. The type of frequency response (i.e. Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response
depend on the filter order.

3. The filter order is either set manually or is calculated by the passband and
stopband frequencies and attenuations.
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Example

A maximally flat lowpass filter was designed for 3 dB attenuation at 1 GHz and 20 dB
attenuation at 2 GHz with matched 50 ohm terminations. This resulted in a filter
order of N=4.
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SmartComponent Reference
LCHighpassST (Singly Terminated Highpass Filter)

Symbol

Parameters

Fs = stopband frequency, in hertz

Fp = passband corner frequency, in hertz

Ap = passband attenuation, in dB

As = stopband attenuation, in dB

N = order of filter, unitless

ResponseType = type of filter response

MinLorC = mininum inductance or capacitance

Rg = source impedance, in ohms

Termination = open or short load termination

MaxRealizations = maximum number of realizations during synthesis

Notes

1. A singly terminated highpass filter provides a highpass frequency response
between the input (pin 1) and output (pin 2) ports. This component will have a
real, non-zero source termination and either an open or short at the load
termination.

2. The type of frequency response (i.e. Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response
depend on the filter order.

3. The filter order is either set manually or is calculated by the passband and
stopband frequencies and attenuations.
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Example

A chebyshev highpass filter was designed for 20 dB attenuation at 1 GHz and 3 dB
attenuation at 2 GHz with matched 50 ohm terminations. This resulted in a filter
order of N=4.
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SmartComponent Reference
LCBandpassST (Singly Terminated Bandpass Filter)

Symbol

Parameters

Fs1 = lower stopband frequency, in hertz

Fp1 = lower passband corner frequency, in hertz

Fp2 = upper passband corner frequency, in hertz

Fs2 = upper stopband frequency, in hertz

Ap = passband attenuation, in dB

As = stopband attenuation, in dB

N = order of filter, unitless

ResponseType = type of filter response

MinLorC = mininum inductance or capacitance

Rg = source impedance, in ohms

Termination = open or short load termination

MaxRealizations = maximum number of realizations during synthesis

Notes

1. A singly terminated bandpass filter provides a bandpass frequency response
between the input (pin 1) and output (pin 2) ports. This component will have a
real, non-zero source termination and either an open or short at the load
termination.

2. The type of frequency response (i.e. Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response
depend on the filter order.

3. The filter order is either set manually or is calculated by the passband and
stopband frequencies and attenuations.
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Example

An elliptical bandpass filter was designed for 3 dB attenuation between 1 GHz and
2 GHz and 20 dB attenuation below .5 GHz and above 2.5 GHz with a 50 ohm source
and shorted load. This resulted in a filter order of N=4.
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SmartComponent Reference
LCBandstopST (Singly Terminated Bandstop Filter)

Symbol

Parameters

Fp1 = lower passband corner frequency, in hertz

Fs1 = lower stopband frequency, in hertz

Fs2 = upper stopband frequency, in hertz

Fp2 = upper passband corner frequency, in hertz

Ap = passband attenuation, in dB

As = stopband attenuation, in dB

N = order of filter, unitless

ResponseType = type of filter response

MinLorC = mininum inductance or capacitance

Rg = source impedance, in ohms

Termination = open or short load termination

MaxRealizations = maximum number of realizations during synthesis

Notes

1. A singly terminated bandstop filter provides a bandstop frequency response
between the input (pin 1) and output (pin 2) ports. This component will have a
real, non-zero source termination and either an open or short at the load
termination.

2. The type of frequency response (i.e. Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response
depend on the filter order.

3. The filter order is either set manually or is calculated by the passband and
stopband frequencies and attenuations.
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Example

A maximally flat bandstop filter was designed for 20 dB attenuation between 1 GHz
and 2 GHz and 3 dB attenuation below .5 GHz and above 2.5 GHz with a 50 ohm
source and an open load. This resulted in a filter order of N=7.
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