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Chapter 1: Using Instrument Interfaces

There are two approaches to using instruments in ADS:
1. Using the Connection Manager

The Connection Manager (CM) is the recommended method for instrument
connectivity from ADS. The Connection Manager employs a client-server
environment, where the clients are supported on all ADS platforms, and the
server is on a PC. There are two types of Connection Manager based clients in
ADS

= The CM client Ul that provides simple S-parameter, spectrum, and voltage
waveform measurements.

= The CM simulation components that download data to/from instruments
during simulation.

For more information, refer to Connection Manager.
2. Using legacy instrument interfaces

Though the CM is recommended for ADS instrument connectivity, ADS
continues to support legacy instrument interfaces like the Instrument Server
and older instrument components on Windows platforms only.

Note Instrument connectivity using the Instrument Server and legacy
instrument components is supported on the Windows® 2000, Windows NT® 4.0

and Windows XP platforms only. On Unix® platforms, instrument connectivity
is supported primarily through the Connection Manager architecture.

The Instrument Server and older instrument components rely on the older
SICL 10 library for instrument connectivity. For this reason, instrument
connectivity through the Instrument Server and older instrument components
are supported on PC platforms only.

For more information on the Instrument Server, refer to “Using the Instrument
Server” on page 2-1.

For more information on instrument components, both CM and legacy, refer to
“Instrument Components” in the Signal Processing Components manual.GPIB
Interfaces
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Using Instrument Interfaces

The Instrument Server and legacy instrument components in ADS support the

following GPIB hardware and software interface kits.

Windows 2000/XP (Agilent IO Libraries can substitute for the NI-488.2M drivers.)

Description Part Number
Agilent LAN/GPIB Gateway Interface/ SICL drivers E2050A/B w/ Opt AG6
Agilent LAN/GPIB Gateway Interface/ SICL drivers E5810A
Agilent USB/GPIB SICL/VISA drivers 82357A
Agilent GPIB PCI card / SICL drivers 82350A
Agilent GPIB EISA card / SICL drivers 82341C
National Instruments AT-GPIB/TNT card/NI-488.2M drivers 776836-01
National Instruments PCMCIA-GPIB card/NI-488.2M drivers 777332-02
National Instruments PCI-GPIB card/NI-488.2M/SICL drivers for Windows NT (Agilent 10 Libraries can | 777073-01
substitute for the NI-488.2M drivers.)

National Instruments PCI-GPIB card/NI-488.2M/SICL drivers for 778032-01

Configuring the Driver for the GPIB Interface

To use GPIB interfaces with the Instrument Server or legacy instrument components
in ADS, download and install the most recent version of the Agilent 10 libraries from

the website:

http://www.agilent.com/find/iolib

After installation is complete, run the 10 Config program by selecting Start >
Programs > Agilent IO Libraries > 10 Config from the Windows main screen. The

following graphic illustrates the 10 Config application.
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Agilent |0/ Libraries Configuration - 10 Config
File Options  Help

10 Config configures and edits Agilent 10 interfaces.
- To configure a new interface, select the interface in ‘Available Interface Types' and click Configure’
- To edit a configured interface, select the interface in 'Configured Interfaces' and click 'Edit’
- To automatically configure the interfaces identified with =, click ‘Auta Config’

Available Interface Types Configured Interfaces
WISA Type  Interface Description WISA Mame  SICL Mame
ASHL *R5-232 COM Parts A GPIBD gpib0 * dta Config
ASAL V154 LAN Client (2.0, E58 GPIET gpib
GFIB *82350 Pl GPIB Card e -
GFIB “GPIB Using NI-488.2 Ok
GPFIE 82341 154 GPIB Card
GPFIE 82357 USE to GPIB
GFIE e Client (=.g. E5S Help
GPIB A GPIBA%I Command kaodu
TCFIF “LaM Client [LAM Instrume
L5k “USE Instruments
USE W54 LAN Client for ISE
Kz 8491 |EEE-1334 ta Wl
nla L&M Server [PC as Server ™

*MOTE: &uto Config will configure interfaces identified with an **

To use a GPIB card installed locally on the PC, from the Available Interface Types
field, select the relevant GPIB option (based on the Interface Description provided on
the right hand side) and click Configure > OK . The default settings are correct.

To use a remote LAN/GPIB gateway, from the Available Interface Types field, select

VISA Lan Client > Configure . Enter the hostname or IP address and the sicl-name of
the LAN/GPIB gateway, and click OK.

Note If the Instrument Server reports it's unable to find an interface, check to see if
the system path contains either gpib-32.dll, sicl32.dll or both.
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Chapter 2: Using the Instrument Server

The Instrument Server provides a way to write and read data to and from an
instrument.

Applications for using transferred data include:

= Reading measured instrument data into a dataset, and comparing measured
data to simulation results in a data display.

= Reading data into a dataset for use with components, such as the VtDataset
source, that can read data from a dataset.

= Writing S-parameters from a dataset to a specific file type. The S-parameter file
can then be read by a component, such as a P2D amplifier.

These are just a few examples, there are many other applications for transferring
data between Advanced Design System and outside systems.

This chapter describes how to transfer measured data between datasets and files,
network analyzers, spectrum analyzers, oscilloscopes, and the Agilent 70820A
Microwave Transition Analyzer.

The Instrument Server can transfer data between many instrument models and file
formats. A list of supported instruments appears at the start of each section.

Note Currently, instrument connectivity for the Instrument Server is only
supported on the following platforms: Windows 2000 and Windows XP.
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Using the Instrument Server

Installation Requirements

Note For details on the hardware and software installation, refer to “For more
information on instrument components, both CM and legacy, refer to “Instrument
Components” in the Signal Processing Components manual.GPIB Interfaces” on
page 1-1.

To use the Instrument Server, you must first perform the following installation steps:
< Install a GPIB card and software in your computer.
= Run any installation procedures to set symbolic names, bus speed, et cetera.

= Set GPIB and Instrument Server configurations in Advanced Design System.

Note As part of the interface card installation, a symbolic name is assigned to the
card. When you install the card, make a note of this name, you will need it when you
use the Instrument Server. For details on specifying a symbolic name, refer to
“Specifying a Symbolic Interface Name” on page 2-23.

Starting and Exiting the Instrument Server

To start the Instrument Server, from a Schematic window, choose Tools > Instrument
Server.

= To exit the Instrument Server, choose File > Close Window from the Instrument
Server menu bar.

The Instrument Server Dialog

The following illustration shows the default appearance of the Instrument Server
user interface.
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The layout of the interface and names of the various elements vary with the task
being performed (read or write) and whether a network analyzer, spectrum analyzer,
oscilloscope, or microwave transition analyzer is selected.

The following are the more frequently used elements of the interface:
= The Menu bar displays the menus available from the dialog.

< READ and WRITE display lists of items that you can read from and write to.
Depending on your selection, additional instrument options are displayed.
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Using the Instrument Server

Update Dataset List updates the list of available datasets.

Display Status Log activates the transfer of information to the Status Server.
Any errors that occur during the data transfer or messages that indicate the
progress of the transfer will appear in this window.

Display Comments Dialog enables you to add comments to a dataset.

The Datasets field list the datasets in the current project. The selected dataset
or the name of a new dataset is displayed in the Dataset Name field.

The Blocks field lists the blocks (variables) in the selected dataset. The selected
block is displayed in the field below the list.

The Read Instrument and Write To Instrument buttons execute the configured
measurement.

Connecting to Instruments

Several interface bus choices must be specified when you transfer data to or from an
instrument (Windows based systems only).

Data is transferred via the GPIB interface. (References to HP-IB in this text also
refer to GPIB).

To configure the interface bus, do the following:

1.
2.

Choose HP-IB > Timeout . The HPIB Timeout dialog box appears.
Enter the amount of time, in seconds, allowed to transfer data and click OK.

When this time is exceeded, the communication between the instrument and
computer is terminated. Do not specify an excessively long time because if the
data transfer fails, it may be difficult to terminate the connection between the
computer and the instrument until the time has expired. If you do not specify a
time interval, a default value of 10 seconds is used.

3. Choose HP-IB > Symbolic Name . The HPIB Symbolic Name dialog box appears.

. Enter the symbolic name of the interface card and click OK.

This name is required to transfer data via GPIB. For details on specifying a
symbolic name, refer to “Specifying a Symbolic Interface Name” on page 2-23.

. The HP-IB Address field enables you to the identify the instrument that you

want to connect to by GPIB address.
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The steps to complete these settings begin with “Specifying a Symbolic Interface
Name” on page 2-23.

Data Transfer Considerations

To ensure successful data transfers, before initiating a transfer, be sure to:

= Specify a timeout duration which is sufficient to complete the data transfer
from an instrument.

= Set the instrument to hold or single sweep mode. This is particularly important
when retrieving averaged data from an instrument, or the data acquisition time
for an instrument is relatively long.

= Do not change any settings on an instrument while a transfer is in progress.

= Not all instruments have the same memory or trace locations, so be sure to
select a location that is valid for your instrument or an error will occur when
you attempt to transfer data.

= You may need to use the Data File Tool to place data in a final format. For
example, you may have S-parameters in a Touchstone file and want them in
P2D format. Using the Data File Tool, you would read the S-parameters from
the Touchstone file to a dataset, then write the data from the dataset and into a
P2D file. For more information see, “Chapter 4, Working with Data Files,” in
Using Circuit Simulators.
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Using the Instrument Server

Reading and Writing Network Analyzer Data

Data can be transferred to and from the following network analyzers.
Table 2-1. Network Analyzer Data

Model Number Description

Agilent 8510B/C/XF High Performance uw VNA

Agilent 8712X 300kHz - 1.3 GHz Low Cost (Trans, Refl) RF VNA

Agilent 8714X 300kHz - 3 GHz Low Cost (Trans, Refl) RF VNA

Agilent 8719X 50 MHz — 13.5 GHz VNA

Agilent 8720X 50 MHz — 20 GHz VNA

Agilent 8722X 50 MHz — 40 GHz VNA

Agilent 8752X 300kHz - 6 GHz Reflection Transmission VNA

Agilent 8753X 30kHz-6 GHz High Performance RF VNA

Agilent 8702X 300 kHz - 6 GHz Mod Freq Lightwave Component Analyzer
Agilent 8703X 130 MHz - 20 Ghz Mod Freq Lightwave Component Analyzer
Wiltron 360 High Performance uw VNA

Agilent E880X 300 kHz - 9 GHz Performance Network AnalyzerT

Agilent E835X 300 kHz - 9 GHz Performance Network Analyzer f

Agilent N338X 300 kHz - 9 GHz Performance Network AnalyzerT'JrJr
Agilent E836X 45 MHz - 50 GHz Performance Network AnalyzerT

tInstrument Server does not support writing data to the analyzer waveform memory.
ttInstrument Server will only support reading S-parameters from ports 1 and 2.

Network Analyzer Data Formats

The network analyzer stores measurements as raw, corrected, or formatted data,
depending on the settings of the network analyzer:

< Raw data are the values measured at the detector, with no correction or
alteration.

= Corrected data are the values measured at the detector, plus correction data
applied.

= Formatted data is corrected data plus any smoothing, or other processes that
can be applied with network analyzer.
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Most Agilent Analyzers have two channels, each having its own set of raw, corrected
and formatted data arrays. For all analyzers except the 8712 and 8¢l Instrument
Server accesses the data in channel 1 only.

Using the Agilent PNA Family Network Analyzers

Agilent PNA Family of Network Analyzers includes the E880X, E835X, E836X and
N338X

Note For the PNA family of network analyzers, including the E835X, E880X,
E836X, N388X families, the Instrument Server does not support writing to the
analyzer waveform memory.

The Instrument Server has the ability to interface with the Agilent PNA Family of
network analyzers. The Instrument Server reads from the Channel 1 data arrays.
There are two NWA data formats to choose from.

- Corrected Transfer the data in the analyzer's Corrected data array to the
dataset.

< Raw Transfer the data in the analyzer's Raw data array to the dataset. Raw
data for all four S parameters is available regardless of whether a full
2-port-calibration is in effect.

Corrected and Raw data is always stored in the dataset variable as complex real
imaginary pairs of the requested S parameters.

The Instrument Server will expect the data in the dataset to be complex.

Using Agilent 87XX-Series Network Analyzers

The Instrument Server reads from and writes to the Channel 1 data arrays. The data
of interest in channel 1 does not have to be currently displayed to be read. If
averaging is ON, the Instrument Server will put the instrument in HOLD mode
before reading the data. Therefore make sure that the instrument has sufficiently
averaged the data before reading the array.

In Read Mode there are three NWA data formats to choose from.

- Formatted Transfer the data in the analyzer's Formatted data array to the
dataset.

Reading and Writing Network Analyzer Data 2-7



Using the Instrument Server

- Corrected Transfer the data in the analyzer's Corrected data array to the
dataset.

< Raw Transfer the data in the analyzer's Raw data array to the dataset. Raw
data for all four S parameters is available regardless of whether a full
2-port-calibration is in effect.

Data is always stored in the dataset variable as complex real imaginary pairs of the
requested S parameters.

In Write Mode there are two NWA Data Locations to choose from.

< Memory Transfer complex data from the selected dataset variable to the
Channel 1 Memory array.

< Raw Transfer complex data from the selected dataset variable to the Channel
1 Raw data array. If a full 2-port-calibration is in effect, any of the four
S-parameters can be written to the 4 available raw data arrays. If a full
2-port-calibration is not in effect, S11 data must be selected in order to write to
the single Raw data array available.

The Instrument Server will expects the data in the dataset to be complex.

Using Agilent 8752 Network Analyzers

Only Sq; (reflection) and Sy, (transmission) data can be read from or written to an

Agilent 8752 network analyzer. This network analyzer only makes reflection and
transmission measurements, and reading or writing data for other parameters
produces unpredictable results.

Before data is written into a raw data array in the Agilent 8752 network analyzer,
the error correction that is built into the instrument must be turned off. This is not
necessary if data is written into memory in the instrument.

To turn off error correction in the Agilent 8752, follow these steps:
1. Press the menu key SYSTEM.
2. Press the function key SERVICE.
3. Press the function key SERVICE MODES.
4. Press the function key MORE.
5. Press the function key FREQ RESP to turn off the calibration.
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When this has been complete, you can write data into the raw data array in an
Agilent 8752 network analyzer.

Note Be sure to turn on error correction before making additional measurements
with the network analyzer.

Using Agilent 8510 Network Analyzers

The Instrument Server reads from and writes to the Channel 1 data arrays. The data
of interest in channel 1 does not have to be currently displayed to be read. If
averaging is ON, the Instrument Server will put the instrument in HOLD mode
before reading the data. Therefore make sure that the instrument has sufficiently
averaged the data before reading the array.

In Read mode there are three NWA data formats to choose from.

- Formatted Transfer the data in the analyzer's Formatted data array to the
dataset.

- Corrected Transfer the data in the analyzer's Corrected data array to the
dataset.

< Raw Transfer the data in the analyzer's Raw data array to the dataset. Raw
data for all four S parameters is available regardless of whether a full
2-port-calibration is in effect.

Data is always stored in the dataset variable as complex real imaginary pairs of the
requested S parameters.

In Write mode there are two NWA data locations to choose from.

< Memory Transfer complex data from the selected dataset variable to the
Channel 1 Corrected data array.

< Raw Transfer complex data from the selected dataset variable to the Channel
1 Raw data array. If a full 2-port-calibration is in effect, any of the four
S-parameters may be written to the 4 available raw data arrays. If a full
2-port-calibration is not in effect, S11 data must be selected in order to write to
the single Raw data array available.

The Instrument Server will expects the data in the dataset to be complex.
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Reading Instrument Data from a Network Analyzer

To read measured data from a network analyzer:

1.

Configure the network analyzer by setting the stimulus, calibration, and other
parameters.

. From an open Instrument Server window, click READ.

3. Under Read From, click Network Analyzer .

. Under NWA Data Format, select one of the following formats:

¢ Formatted
* Corrected

« Raw

. Under Read Network Analyzer Data, select the S-parameters that you want to

use as the data source. You can select one set of the S-parameters or create an
S-matrix of all S parameters.

Note

For PNA's that have more than two ports, the Instrument Server will only

support reading S parameters from ports 1 and 2. Specifically, the Instrument Server
will read: S11, S12, S21, and S22 (selecting “All S parameters” will read S11, S12,
S21, and S22).

10.

11.

. Type the network analyzer address in the HP-1B Address field.

. Select HP-IB > Symbolic Name and enter a symbolic interface name. For more

information, refer to “Specifying a Symbolic Interface Name” on page 2-23.

. If you want the data transfer to include a timeout, select HP-IB > Timeout . For

more information, refer to “Specifying a Transfer Timeout” on page 2-24.

. Click Display Status Log to view any messages and errors that may occur during

the transfer.

Click Display Comments Dialog to add comments to a dataset. For instructions,
refer to “Entering Comments into a Dataset” on page 2-24.

Enter a name in the Dataset Name field, or select an existing dataset from the
Datasets list.
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12. Enter a unique block name in the Enter Unique Block Name field. The
instrument data will be stored in this block name.

Note You can select an existing block from the Blocks list, but you must edit the
selected block name in the Enter Unique Block Name field so that it is unique.

13. Click Read Instrument to send the measured instrument data to the dataset.

Writing Data to a Network Analyzer

Data in a dataset can be written to the network analyzer raw data array or memory
array. The memory array can only hold one parameter.

If data is to be written to the Channel 1 Raw data array, and a full 2-port-calibration
is in effect, any of the four S parameters may be written to the 4 available raw data

arrays. If a full 2-port-calibration is not in effect, S11 data must be selected in order
to write to the single Raw data array available.

To write to a network analyzer:
1. From an open Instrument Server window, click WRITE.
2. Under Write To, click Network Analyzer .

3. Under NWA Data Location, select the network analyzer data locations to
identify where you want to send the data.

4. Under Write Network Analyzer Data, select the type of S-parameters that you
intend to send to the analyzer.

5. Type the network analyzer address in the HP-1B Address field.

6. Select HP-IB > Symbolic Name and enter a symbolic interface name. For more
information, refer to “Specifying a Symbolic Interface Name” on page 2-23.

7. If you want the data transfer to include a timeout, select HP-IB > Timeout . For
more information refer to “Specifying a Transfer Timeout” on page 2-24.

8. Click Display Status Log to view any messages and errors that may occur during
the transfer.

9. The source of the data can be any block in a project dataset. The data in the
dataset block must be complex data. Select from the list of existing datasets and
blocks.
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10. Enter a unique block name in the Enter Name from Block List field.

11. Click Write To Instrument to send the data to the specified network analyzer
location.

Reading and Writing Spectrum Analyzer Data

Data can be read from and written to a wide range of spectrum analyzers. Supported
spectrum analyzers are listed below.

Table 2-2. Spectrum Analyzer Data

Model Number Features

Agilent 70000 Modular Analyzers (MMS)

Agilent 8566B 100 Hz-22 GHz

Agilent 8567A 10 kHz-1500 MHz

Agilent 8568B 100 Hz-1500 MHz

Agilent 859XX Portable Economy Analyzer Series
Agilent 856XX Portable Mil Spec Analyzer Series

Reading Instrument Data from a Spectrum Analyzer

When data is read into a dataset, the location specified as the source of the data
(trace A, B, or C) is read immediately without the selected trace being put into view
mode. When reading data from a spectrum analyzer, keep in mind the following:

= The 856X series of analyzers do not have a Trace C.

= The Instrument Server doesn’t wait for the trace to complete before the data is
read.

= For traces with long sweep times, make sure the instrument has completed one
sweep of the desired spectrum before reading the data.

= No peak search is performed before the data is transferred.
- Data is read in exactly as it appears on the screen.

= The data written to the dataset variable has the amplitude units of the analyzer
at the time the data was read.

To read data from a spectrum analyzer:

1. From an open Instrument Server window, click READ.
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2. Under Read From, click Spectrum Analyzer .

3. Under Read Spectrum Analyzer Trace, select the trace you want to use as the
data source.

4. Type the spectrum analyzer address in the HP-1B Address field.

5. Select HP-IB > Symbolic Name and enter a symbolic interface name. For more
information, refer to “Specifying a Symbolic Interface Name” on page 2-23.

6. If you want the data transfer to include a timeout, select HP-IB > Timeout . For
more information refer to “Specifying a Transfer Timeout” on page 2-24.

7. Click Display Status Log to view any messages and errors that may occur during
the transfer.

8. Click Display Comments Dialog to add comments to a dataset. For instructions,
refer to “Entering Comments into a Dataset” on page 2-24.

9. Enter a name in the Dataset Name field, or select an existing dataset from the
Datasets list.

10. Enter a unique block name in the Enter Unique Block Name field.

Note  You can select from the list of existing blocks in the Blocks list, but you must
edit the selected block name in the Enter Unique Block Name field so that it is
unique. The instrument data will be stored in this block.

11. Click Read Instrument to send the measured instrument data to the dataset.

Writing to a Spectrum Analyzer

Existing data in the instrument memory to which data is being written is
overwritten, and the dataset data is displayed as if it were measured data. Since
dataset data is deleted from the instrument when another measurement is made, the
Instrument Server places the instrument in single sweep mode to prevent the dataset
data from being overwritten. Dataset data is deleted from the instrument when
another measurement is made.

When data is written into the spectrum analyzer, the frequency range, number of
points, and other stimulus values in the instrument are not changed. Interpolation is
used (if necessary) to display the dataset data at the frequency points given by the
current spectrum analyzer settings. There must be some overlap between the
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frequency range of the dataset and the analyzer’'s current frequency range. The
spectrum analyzer does not extrapolate. Data values for all frequencies above or
below the frequencies in the dataset appear as zero.

The Instrument Server searches the selected dataset variable for an attribute labeled
“Amplitude Units”. If it is not found, the Instrument Server prompts the user for the
unit value of the dataset variable data. The dataset variable data must be real data,
complex data will result in an error.

To write to a spectrum analyzer:

1.
2.
3.

From an open Instrument Server window, click WRITE.
Under Write To, click Spectrum Analyzer .

Under Write to Spectrum Analyzer Trace, select the trace where you intend to
send the data.

. Type the spectrum analyzer address in the HP-1B Address field.

5. Select HP-IB > Symbolic Name and enter a symbolic interface name. For more

10.

information, refer to “Specifying a Symbolic Interface Name” on page 2-23.

. If you want the data transfer to include a timeout, select HP-IB > Timeout . For

more information, refer to “Specifying a Transfer Timeout” on page 2-24.

. Click Display Status Log to view any messages and errors that may occur during

the transfer.

. Click Display Comments Dialog to add comments to a dataset. For instructions,

refer to “Entering Comments into a Dataset” on page 2-24.

. The source of the data can be any block in a project dataset. Enter a name in the

Dataset Name field, or select a dataset from the Dataset list.

Enter a unique block name in the Enter Name from Block List field. The
instrument data will be stored in this block.

Note

You can select an existing block from the Blocks list, but you must edit the

selected block name in the Enter Name from Block List field so that it is unique.

11.

Click write To Instrument to send the dataset or block to the spectrum analyzer
trace.
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Reading and Writing Oscilloscope Data

Data can be read from and written to a wide range of Agilent oscilloscopes. Supported
oscilloscopes are listed below.

Table 2-3. Oscilloscope Data

Model Number Features

Agilent 54100A 1 GHz rep BW, 2-channel.

Agilent 54100D Agilent 54100A with dual trigger.

Agilent 54110D Agilent 54100D with color CRT and PaintJet output.

Agilent 54111D 500 MHz Rep BW, 250 MHz 1-shot, 2-channel dual trigger.

Agilent 54120T 20 GHz rep BW, 4-channel.

Agilent 54123T 34 GHz rep BW, 4-channel.

Agilent 54124T 50 GHz, 4-channel.

Agilent 54720D 2 GHz, 8 GSample/sec Modular Oscilloscope (using Agilent 5471X and 5472X plug-ins)
Agilent 54750A 20 GHz Sampling Modular Oscilloscope (using Agilent 5475X plug-ins)
Agilent 86100A 50 GHz DCA (digital communications analyzer)

Agilent 86100B 50 GHz high speed DCA (digital communications analyzer)

Reading Instrument Data from an Oscilloscope

Not all channels or memory locations exist on all supported oscilloscopes. Requesting
data from a nonexistent channel results in an error message and no data is
transferred.

Table 2-4 summarizes the memory locations from which data can be read in various
Agilent oscilloscopes.

Table 2-4. Oscilloscope Memory Locations

Memory5
Memoryl Memory3 Memory5 through
Oscilloscope Memory2 Memory4 Memory6 Memory8
Al Tt .
Agilent 54120T . .
Agilent 54123T . .
Agilent 54110D . .

T All instruments except Agilent 54100A/D oscilloscopes with firmware revisions earlier than
March 1986. In these earlier oscilloscopes, data is read from Channel 1 or 2 only.
¥ Memory5 = fcnl, Memory6 = fcn2.
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Table 2-4. Oscilloscope Memory Locations

Memory5
Memoryl Memory3 Memory5 through
Oscilloscope Memory2 Memory4 Memory6 Memory8
Agilent 54111D . . .

Agilent 547XX N . .

T All instruments except Agilent 54100A/D oscilloscopes with firmware revisions earlier than
March 1986. In these earlier oscilloscopes, data is read from Channel 1 or 2 only.
¥ Memory5 = fcnl, Memory6 = fcn2.

It may take a long time to read some extreme cases of averaged data. It is not
uncommon for it to take 10 to 15 minutes to accumulate 500 points of data averaged
2048 times. If such a trace is desired, store the trace in memory first, then read the
data directly from memory.

Also note that the Agilent 54111D oscilloscope stores 8192 points of data in waveform
memories 1 through 4 even though only 512 of these points are displayed at any one
time. The result is that even if only two periods appear on the display, reading the
memory will take as long as is needed to read points for 16 periods.

Using Agilent 541XXX-series Oscilloscopes

When reading data from an active channel, all Agilent 541XXX-series and Agilent
547XX-series oscilloscopes first digitize the data into a waveform memory.

Table 2-5 traces the flow of the data in each oscilloscope.
Table 2-5. Oscilloscope Data Flow

Agilent Agilent Agilent Agilent Agilent

54100A/D t 54110D 54111D 5412xx 547xx
Where channel 1 is Internal memory | Memory 1 Memory 1 or Memory 1 Internal
stored Memory 5 memory
Where channel 2 is Internal memory | Memory 2 Memory 2 or Memory 2 Internal
stored Memory 6 memory
Where channel 3 is Memory 3 Internal
stored memory
Where channel 4 is Memory 4 Internal
stored memory
 Agilent 54100A/D oscilloscopes with firmware revisions later than March 1986 behave like Agilent 54110D
oscilloscopes.
¥ The Agilent 54111D oscilloscope digitizes real-time traces from channels 1 and 2 into Memory 1 and Memory 2. It
digitizes averaged traces from these two channels into Memory 5 and Memory 6.
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To read data from an oscilloscope:

1.
2.
3.

From an open Instrument Server window, click READ.
Under Read From, click Oscilloscope .

Under Read Oscilloscope Data, select the channel or memory location that you
want to use as the data source.

. Type the oscilloscope address in the HP-1B Address field.

5. Select HP-IB > Symbolic Name and enter a symbolic interface name. For more

10.

information, refer to “Specifying a Symbolic Interface Name” on page 2-23.

. If you want the data transfer to include a timeout, select HP-IB > Timeout . For

more information, refer to “Specifying a Transfer Timeout” on page 2-24.

. Click Display Status Log to view any messages and errors that may occur during

the transfer.

. Click Display Comments Dialog to add comments to a dataset. For instructions,

refer to “Entering Comments into a Dataset” on page 2-24.

. Enter a name in the Dataset Name field, or select an existing dataset from the

Datasets list.

Enter a unique block name in the Enter Unique Block Name field. The
instrument data will be stored in this block.

Note

You can select an existing block from the Blocks list, but you must edit the

selected block name in the Enter Unique Block Name field so that it is unique.

11.

Click Read Instrument to send the measured instrument data to the dataset.

Writing Advanced Design System Data to an Oscilloscope

Not all memory locations are on all supported oscilloscopes. Writing data to a
nonexistent channel aborts the process with an error message and no data changes.

Table 2-6 summarizes the memory locations that are available for writing data in
various Agilent oscilloscopes.
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Table 2-6. Oscilloscope Memory Locations

Memory5
Memoryl Memory3 through

Oscilloscope Memory2 Memory4 Memory8
ALL .
Agilent 54120T . .
Agilent 54123T . .
Agilent 54110D . .
Agilent 54111D . ° .
Agilent 547XX . .

When data is written into the oscilloscope, the time range, number of points, and
other stimulus values in the waveform memory are not changed. Interpolation is
used (if necessary) to display the dataset data at the time points given by the current
oscilloscope settings. This means that the desired time/div, volts/div, delay, and other
settings must be adjusted on an active channel and then stored in memory.

The oscilloscope does not extrapolate. Data values for all times above or below the
frequencies in the dataset appear as zero.
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To write to an oscilloscope:

1.
2.
3.

From an open Instrument Server window, click WRITE.
Under Write To, click Oscilloscope .

Under Write To Oscilloscope Memory, select the memory location where you
intend to send the data.

. Type the oscilloscope address in the HP-1B Address field.

5. Select HP-IB > Symbolic Name and enter a symbolic interface name. For more

10.

information, refer to “Specifying a Symbolic Interface Name” on page 2-23.

. If you want the data transfer to include a timeout, select HP-IB > Timeout . For

more information, refer to “Specifying a Transfer Timeout” on page 2-24.

. Click Display Status Log to view any messages and errors that may occur during

the transfer.

. Click Display Comments Dialog to add comments to a dataset. For instructions,

refer to “Entering Comments into a Dataset” on page 2-24.

. The source of the data can be any block in a project dataset. Enter a name in the

Dataset field, or select a dataset from the Datasets list.

Enter a unique block name in the Enter Name from Block List field. The
instrument data will be stored in this block.

Note

You can select an existing block from the Blocks list, but you must edit the

selected block name in the Enter Name from Block List field so that it is unique.

11.

Click Write To Instrument to send the dataset or block to the specified
oscilloscope memory location.

Reading and Writing Microwave Transition Analyzer
Data

Data can be read from and written to the Agilent 70820A Microwave Transition
Analyzer (MTA).
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Reading Instrument Data from an MTA

You can read MTA data from a trace, memory, or a table. Data can be in the following
format. The data read from a trace or memory location is formatted by the following
Read MTA data selections.

e Formatted The format of the data depends on the instrument’s current Domain
setting, which dictates how the trace data is to be displayed. Basically, this is a
What You See Is What you Get mode. The dependent data returned may be in
Complex (real, imaginary), Real, Imag, Magnitude, Phase, or Complex
(magnitude, phase) formats. The independent data can be either frequency or
time.

« Complex versus time  The dependent data returned will be complex data, and
the independent data will be time. It doesn’'t matter what is currently being
displayed on the screen. The measured data will be transformed as necessary to
output complex data vs. time. For instance, if the instrument is currently
displaying magnitude data vs. frequency, an inverse FFT is performed so the
independent data is time, and the dependent data will be complex (real,
imaginary).

= Complex versus frequency The dependent data returned will be complex data,
and the independent data will be frequency. It doesn’'t matter what is currently
being displayed on the screen. The measured data will be transformed as
necessary to output complex data vs. frequency. For instance, if the instrument
is currently displaying real data vs. time, a FFT is performed so the
independent data is frequency, and the dependent data will be complex (real,
imaginary).

If data is to be read from the MTA table, the Instrument Server checks to see if there
is more than 1 signal in the signal list. If there is more than 1 signal in the list, the
Instrument Server will prompt the user for the signal of interest. The magnitude
data is changed to absolute amplitude values if it is originally relative. When the
transfer is started, the transition analyzer is put into hold mode if it is not in this
mode already. Then the data is read. This makes it possible to set up a trace, put the
instrument in hold mode, and then read the data. After the data has been read, the
transition analyzer is returned to its original sweep mode.

Details on transition analyzer domains appear under the description of the waveform
subsystem in the Agilent 70820A Transition Analyzer Remote Programming Manual.
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To read data from an MTA:
1. From an open Instrument Server window, click READ.
2. Under Read From, click Microwave Transition Analyzer
3. Under Read MTA Trace, select one of the MTA Trace Formats:
e Trace 1-4: a displayed MTA trace
e Memory 1-4: an MTA memory location

= Table: If there is more than one signal in the signal list, the Instrument
Server will prompt the user for the signal of interest. The structure of the
table is retained. For example, a table may contain the magnitude and phase
values of a fundamental frequency and each of its harmonics. The data is
transferred to the dataset in the same order.

. Under Read MTA Data, select one of the MTA Data Formats:

N

= Formatted
« Complex vs. Time

= Complex vs. Frequency

ol

. Type the microwave transition analyzer address in the HP-1B Address field.

D

. Select HP-IB > Symbolic Name and enter a symbolic interface name. For more
information, refer to “Specifying a Symbolic Interface Name” on page 2-23.

~

. If you want the data transfer to include a timeout, select HP-IB > Timeout . For
more information, refer to “Specifying a Transfer Timeout” on page 2-24.

[ee]

. Click Display Status Log to view any messages and errors that may occur during
the transfer.

©

. Click Display Comments Dialog to add comments to a dataset. For instructions,
refer to “Entering Comments into a Dataset” on page 2-24.

10. Enter a name in the Dataset Name field, or select an existing dataset from the
Datasets list.

11. Enter a unique block name in the Enter Unique Block Name field. The
instrument data will be stored in this block.
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Note

You can select an existing block from the Blocks list, but you must edit the

selected name in the Enter Unique Block Name field so that it is unique.

12.

Click Read Instrument to send the measured instrument data to the dataset.

Writing Data to an MTA

Any data that in the instrument memory location that you select to write to will be
overwritten with the dataset data. The frequency range, number of points, and other
stimulus values in the instrument are reset to fit the trace being written.

To write to an MTA:

1.
2.
3.

10.

11.

From an open Instrument Server window, click WRITE.
Under Write To, click Microwave Transition Analyzer

Under Write to MTA Memory, select the memory location where you intend to
send the data.

. Under Write MTA Data, select one of the MTA data types:

= Frequency Domain  Data as a function of frequency

= Time Domain Complex data as a function of time

. Type the microwave transition analyzer address in the HP-1B Address field.

. Select HP-IB > Symbolic Name and enter a symbolic interface name. For more

information, refer to “Specifying a Symbolic Interface Name” on page 2-23.

. If you want the data transfer to include a timeout, select HP-IB > Timeout . For

more information, refer to “Specifying a Transfer Timeout” on page 2-24.

. Click Display Status Log to view any messages and errors that may occur during

the transfer.

. Click Display Comments Dialog to add comments to a dataset. For instructions,

refer to “Entering Comments into a Dataset” on page 2-24.

The source of the data can be any block in a project dataset. Enter a name in the
Dataset Name field, or select a dataset from the Datasets list.

Enter a unique block name in the Enter Name from Block List field. The
instrument data will be stored in this block.
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Note You can select an existing block from the Blocks list, but you must edit the
selected block name in the Enter Name from Block List field so that it is unique.

12. Click Write To Instrument  to send the dataset or block to the specified MTA
memory location.

Specifying a Symbolic Interface Name

The symbolic interface name is the name assigned to the interface card when the
card is installed. This name can be redefined at any time and is required by the
Instrument Server to transfer data to or from an instrument. For the E2050
Lan/GPIB gateway box, the symbolic name is of the form:

lan[IP_address]:hp-ib_name
To enter the symbolic name:
1. From the menu bar choose HP-IB > Symbolic Name .

2. The HP-IB Symbolic Name dialog box appears. Type the name into the field in
the dialog box.

3. Click OK.
Example:

If an E2050 Lan/GPIB gateway box with an IP address of 18.9.134.213 is to be
addressed, the symbolic name is:

1an[18.9.134.213]:hpib that is, lan[IP_address] : hp-ib_name

Refer to the documentation for the E2050 for details on changing the hp-ib_name.

Note Interface cards for the PC are often bundled with a diagnostics program. If the
diagnostics software is installed, you can run it to identify the card name. UNIX
platforms are not supported.
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Specifying a Transfer Timeout

A transfer timeout specifies the length of time allowed to transfer data. When the
time is exceeded, the instrument and computer are disconnected. You should always
set the timeout option before a data transfer to ensure the connection between the
instrument and Advanced Design System can be terminated.

To set a timeout:
1. From the menu bar choose HP-IB > Timeout .

2. The HP-IB Timeout dialog box appears. Type the amount of time you want to
allow to elapse, in seconds, before the timeout occurs.

3. Click OK.

Note The optimum transfer time depends on the hardware speed and the amount of
data to be transferred. If you transferring data from an instrument and are
averaging data, transferring a large amount of data, or have a long sweep time, put
the instrument in hold or single sweep mode or change the timeout setting to an
appropriate value before attempting to transfer data.

Entering Comments into a Dataset

You can enter comments into a dataset. Comments such as the origin of the data can
be useful to identify the contents of the dataset.

To enter comments:
1. Click Display Comments Dialog

2. Type in comments that you want to add to the dataset. The comments are
entered into a comments field of the dataset.

3. Click OK to add the comments to the dataset.
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Chapter 3: Command Reference

File Menu

Close Window

Closes the Instrument Server window.

HP-IB Menu

Symbolic Name

Specifies the symbolic interface name assigned to the interface bus card.

Timeout

Specifies the maximum length of time allowed to transfer data. Instruments
disconnect after this time has elapsed.

Help Menu

What's This?

Displays context-sensitive help for a menu, command, button, or control that is
selected subsequently.

Topics and Index

Provides access to a brief list of topics for each product area, as well as access to an
index of topics in all product areas.
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Agilent EEsof Web Site

Launches the browser (Netscape by default) defined in Options > Preferences >
Web Browser in the Advanced Design System Main window, provided the path for
the browser has been established.

About the Instrument Server

Displays version, copyright, and technical support information. Provides a direct
link to the Agilent EEsof web site.

Read Instrument (Button)

Sends the measured instrument data to the dataset.

Write To Instrument (Button)

Sends the selected dataset to the instrument.
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