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Customizing the ADS Environment

The Advanced Design System suite of tools uses a humber of configuration files. The files contain definitions for
configuration variables and environment variables.

Customizing Environment Variables

Environment variables are usually initialized in a shell start-up file such as .cshrc (C-shell) or .profile (Bourne-shell) in
your home directory. The following table describes the most common environment variables used by the Advanced
Design System. On the PC, these environment variables get set automatically at installation.

Name Default Value Description
HPEESOF_DIR /hpeesof The location where the software has
been installed (also called the root
location).
AGILEESOFD_LICENSE_FILE $HPEESOF_DIR/licenses/license.lic Specifies the location of the FLEXIm

security license files.



EESOF_64BIT

PRINTER

EESOF_BROWSER

CDS_INST_DIR

Advanced Design System 2008

Not set by default.

Ipr
Not set by default. Example setting:

EESOF_BROWSER=/usr/bin/firefox

Not set by default. The Connection
Manager Client does not use the

Specifies whether 64-bit systems use
the default 64-bit simulators or
32-bit simulators. Set
EESOF_64BIT=0 to force 64-bit
systems to use the 32-bit simulators.

Specifies the printer used by the
hpeedit program.

Specifies the browser to use for
viewing online help.

Specifies whether the Connection
Manager Client uses ADS or RFDE

value. The presence or absence of online help. If CDS_INST_DIR is not

this variable determines which online ' set, ADS online help is used. If

help to display. CDS_INST_DIR is set, RFDE online
help is used.

The environment variable HPEESOF_DIR is used extensively throughout Advanced Design System. It does not need to
be set if Advanced Design System has been installed in the directory /hpeesof.

Customizing Configuration Variables

The default values of the configuration variables should get you up and running, but they can be customized to better
reflect your work environment. By default, the program searches for these configuration files in the following order,
and uses the first one found:

e Your current project directory

Define configuration variables here that apply only to this project.
¢ Your personal directory = $HOME/hpeesof/config

Define configuration variables here that apply to all your projects.

© Note

On the PC, %HOME% represents the path you specified as the Home Folder during installation (by default,
C:\users\default)

e Your site's customized site directory $HPEESOF_DIR/custom/config
Define configuration variables here that apply to all projects of all users on a site-wide basis. Configuration
variables defined here will not be overwritten by installation of subsequent program patches or updates.

e The ADS installation directory $HPEESOF_DIR/config
Define the default installed configuration variables here that apply to all projects of all users. Configuration
variables should not be customized here.

Each of the individual Advanced Design System tools has its own configuration file. The supplied configuration files can
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be found in the directory $HPEESOF_DIR/config (where $HPEESOF_DIR represents the complete installation path).
The filenames for each of the tools are shown in the following table.

Product/Tool Filename
Design Environment de_sim.cfg
Digital Filter dfilter.cfg
Digital Synthesis dsynthesis.cfg
Data Displays hpeesofdds.cfg
Data Sets hpeesofdss.cfg
Instrument Server hpeesofinstrio.cfg
Momentum momentum.cfg
Browser (Vendor and component parts) hpeesofbrowser.cfg
Simulation and Synthesis Message Window hpeesofsess.cfg
Layered A.P.IL. eeapi.cfg
Ptolemy models and MATLAB hpads.cfg
Colors hpeecolor.cfg
Fill patterns hpeefill.cfg
GUI search paths hpeesof.cfg
Online help system hpeesofhelp.cfg
AEL search paths hpeesofsim.cfg
Library translator hplibtrans.cfg
Ptolemy hptolemy.cfg
SMG search path smg_ui.cfg
Spice to IFF spctoiff.cfg
Spice translator spice_xlator.cfg
LineCalc linecalc.cfg

Configuration File Format

Configuration variables are defined using standard assignment syntax:

<vari abl e>=<val ue>
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where variable is the configuration variable name and value is the string that is assigned to the variable. This value
can be a directory, search path, numeric value, or other value defined by the program. For example, the location of
the preferences could be set by:

PREFERENCES_DI R={ $HPEESOF_DI R}/ de/ def aul t s

where $HPEESOF_DIR is an environment variable representing the complete installation path.
Note the following details about file format, illustrated in the accompanying example:

¢ Any line starting with # is a comment line and is ignored

e Blank lines are ignored

e Blank spaces to the left or right of the equal sign are ignored
e Empty assignments are acceptable (as shown by env_var_2)

Example

#

# This is a sanple configuration file
#

env_var_1 = first_val ue

env_var _la = val ue-1la

#

env_var_2 =

env_var_3 = 17

env_var _4 = $SYSTEM %HOVE/ ex4

env_var _4a = {$HPEESOF DI R}/ de/ def aul t s/ {%env_var _la}. ex4da

References to environment variables $name and ADS configuration variables %name can appear in any order; they
are resolved inside each ADS program. A reference to an environment variable or configuration variable name may be
enclosed in braces { } when their use is not followed by a punctuation character. The braces are not included in an
expanded value.

Configuration Variable Description

ADS configuration variables are identified by a case-insensitive string of 1 to 31 alphanumeric characters (an
underscore is allowed). Variables that are longer than 31 characters are automatically truncated when the
configuration file is read. When a variable is set from a configuration file, the line
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<vari abl e>=<val ue>

is parsed and variable is set to the value.

A configuration variable can contain a reference. A reference may be enclosed in braces and the text is preceded by
either a $ or % (see ADS Configuration Variables). For example,

PREFERENCES DI R={ $HPEESCOF_DI R}/ de/ def aul t s

assigns the string $HPEESOF_DIR/de/defaults to the configuration variable PREFERENCES_DIR, and $HPEESOF_DIR is
defined in a start-up file.

ADS Configuration Variables

Configuration variable Description

$name The configuration variable is replaced by the text string
assigned to name in the environment.

%name The configuration variable is replaced by the text string
assigned to name in the ADS configuration file.
Certain ADS variables have a pre-defined meaning in a
given program. All of the special ADS configuration
variables that are recognized are given in the shipped
{$HPEESOF_DIR}/config/<app-name>.cfg file.

Most ADS configuration variables are assigned a single value. This text can represent a humber, string, file, or path as
in the following examples.

STATUS_DISP = 0

EESTATUS LOG FI LE = O f

HPEESOF_KEY = $HPEESOF_DI R/ | i censes/ hpeesof . key
PREFERENCES_DI R={ $HPEESCF_DI R}/ de/ def aul t s

Note that when the file is outside of a project configuration, it is necessary to include the full path with the filename to
ensure that the file is found.

Some ADS configuration variables accept a path assignment. A path is a list of one or more directories, where each
directory is separated by a colon.

vari abl e=directory: directory:
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These variables can represent search paths or load paths, depending on the variable and the program. Ordering of the
list is significant. When treated as a search path, the list is only scanned until the item needed is found. For loading,
the entire list is sequentially examined with the last directory usually taking precedence.

The documentation for each specific variable indicates the type of value allowed. Some variables may have a limited
type, such as a range of numbers or list of specific strings.

Configuration Variable Expansion

Configuration variable expansion refers to the process of replacing all references and variables that make up the
configuration variable with their text equivalents until the complete value of the configuration variable is known.
(There are no limits to the levels of referencing you can use.) Note that this expansion is done internally by the

program; the file that contains the variable assignments is not modified.

For example, assume that the environment variable HPEESOF_DIR is set to /hpeesof/mysite and the following two
lines exist in the file de_sim.cfg.

PRQIECT3 = de
SYSTEM _CUSTOM DE_SYMBOLS = {$HPEESOF_DI R}/ cust om { “®PRQIECT3}/ synbol s

After expansion within hpeesof tool:

SYSTEM CUSTOM DE_SYMBOLS = / hpeesof/ nysi te/ cust om de/ synbol s

As in the environment, you may redefine and add your own ADS variables in any ADS configuration files to help
manage system- and user-specific configurations. However, a given ADS program only uses certain expanded ADS
configuration variables, but the unexpanded value could contain any number of user-defined and/or ADS variables.

How a Configuration is Determined

Each configuration is distinguished by its name. Each named configuration contains all of the variables needed for
describing that particular setup. At the topmost level is the configuration file named hpeesof.cfg, which is associated
with all ADS programs. Other named configurations are associated with specific programs.

Each named configuration is determined by the location and content of any related configuration files. For example,
the complete hpeesof configuration could consist of:

10
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The file hpeesof.cfg, located in the install directory $HPEESOF_DIR/config

An edited copy of this same file, located in the customized site directory $HPEESOF_DIR/custom/config
An edited copy of this same file located under your home directory $HOME/hpeesof/config

An edited copy of this same file located in a particular project directory

As noted earlier, configurations in the user directory take precedence over the installation directory, and
configurations in the project directory take precedence over the user directory. This is because the search order for
configuration information is: project directory, user directory, site directory, and installation directory.

Note that variables in each successive file override any previously set value. You can even put two lines in the same
configuration that assign values to the same variable, as in:

MY_VARL
MY_VARL

entry_a
entry_b

When expanded, MY_VAR1 will always have the value of entry_b.

The following table shows a list of named configurations used in the programs.

Named Configurations

Activity Configuration
Design entry hpeesof
Fill patterns hpeefill
Online Help hpeesofhelp
Colors hpeecolor
Simulation hpeesof
de
de_sim

comms_ckt (Communications Design Suite only)

Status/Synthesis Messages hpeesof
eestatus

Data Displays hpeesof
eehelp
hpeefill
hpeecolor
eegraph

Special Variables

11
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There are two configuration files that have a different syntax than the others: hpeecolor and hpeéefill. Their formats
are presented here. Note that the naming convention and loading of system-wide, site-wide, home directory, and
project-specific configurations still apply. Only the internal file format differs.

Color Definitions, hpeecolor.cfg

The design windows (Schematic and Layout), Data Display windows, and plotters use the colors defined in the
hpeecolor configuration. By default, these colors are read from {$HPEESOF_DIR}/config/hpeecolor.cfg, but can be
overridden at the site, user, or project level (any of which can have an hpeecolor file).

The hpeecolor file format differs from the variable=value syntax. Each line contains these major fields:

e RGB color values
e Color name
e Plotter pen number

The syntax for each line is as follows:
<Red #> <Green #> <Blue #> : <Col or nane> : <Pen nunber>

The following example illustrates the format of a typical color definition file:

E G B ¥11 ecoler Plotter pen
name number
0 0 0 black 1
255 0 0 red 2
0 255 0 greesn 3
0 0 255 blue 4
255 255 255 white 5
128 64 0 )
calmon 7

Colors are described in the first and/or second fields of this file. You can enter three RGB color values (in the range
0-255) in the first field and/or you can enter the X color name from the RGB color database (found in
/usr/lib/X11/rgb.txt for Motif or /usr/openwin/lib/rgb.txt for Sun's Open Windows) in the second field. If both are
entered, the RGB values take precedence, and the color name is ignored.

The last field specifies which pen number to use for hard-copy output when performing HPGL plotting. An entry in this
field is required and pen numbers may be recycled and repeated.

By default, the current implementation uses shared server colors from the RGB color database and uses no privately
allocated color cells for X Window displays. This is done to simplify the color specification and to promote sharing of

12
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colors. Sharing of color cells can only happen if two clients allocate read-only color cells with the same X color name or
RGB values.

 Important
On UNIX, we strongly recommend that you only use the names given in the RGB color database instead of
explicit RGB values; on the PC, only RGB values are supported.

Because of differences in screen hardware, the same RGB values may generate different colors on different hardware.
By using names from the color database, you are more likely to get colors close to the ones requested across different
hardware platforms.

It is also important to note that values corresponding to color names are not fixed. Therefore, they may not be exactly
the same across all platforms or correspond to an exact RGB value.

 Note

Some platforms have limited color resources and some platforms may use non-shared colors, resulting in color
exhaustion problems. When ADS programs run into these types of color problems, the solution is to reduce the
number of requested colors until color conflicts stop occurring. As an example, truncating the list of colors in
hpeecolor.cfg to 64 colors may be a good start.

An example hpeecolor configuration file is shown:

13
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If the ADS configuration file cannot be found or the hpeesof configuration does not contain an HPEESOF_COLOR
variable (which determines the location of the ADS color definition file), a set of ten basic default server colors are
automatically loaded as follows:

1 = black
2=red

3 = yellow
4 = green

5 = cyan 9 = white
6 = blue 10 = medium blue
7 = magenta

8 = gray

Fill Pattern Configuration, hpeefill.cfg

Besides colors, the design windows (Schematic and Layout), Data Display windows, and plotters also use the fill
patterns defined by the hpeefill configuration. By default, these patterns are read from
{$HPEESOF_DIR}/config/hpeefill.cfg, but can be overwritten at the site, user, or project level (any of which can have

14
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an hpeefill file).
The hpeefill file format differs from the variable=value syntax. Each line contains two major fields.

e Path and filename of the fill pattern
e HPGL/2-pattern-specification

The syntax for each line is as follows:

<Bitmap_file_location> : <Fill type> <Line spaci ng> <Angl e>

where

¢ Fill type-is the pattern inside an object's border

e Line spacing-is the distance between the hatched lines in plotter units (where a plotter unit is typically
1/72-inch).

¢ Angle-is the angle of hatch lines in the fill pattern, expressed in degrees (for fill type 3 or 4 only).

The following example illustrates the format of a typical fill pattern definition file:

/fill/pat/path/patl.pattern : 3 50 15
/fill/pat/path/pat2.pattern : 3 50 30
/fill/pat /path/pat3.pattern 4 60 45
/fill/pat/path/patd.pattern 4 60 90
I— Angle
Line Spacing
Fill Type

Fill patterns use standard X-bitmap files that can be easily created with the X bitmap utility. The first field specifies the
path to the X-bitmap file, which is used for pattern fills, while the remaining fields are the HPGL/2 fill pattern
specification.

Fill type description Fill type number
Solid bidirectional 1
Solid unidirectional

Hatched

A W N

Cross hatched

 Note

Solid bidirectional fill is faster than solid unidirectional fill, but is not supported by all plotters.

15
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An hpeefill configuration file is shown in the following example:

.H: s s s s e e e e e e e e e e e

# EEzof Fill Pattern Configuration File

.H': E=mmm=m—=m==m==—=—m=—==—=m====m==m=m====m===m===m====

# Screen Output : Hardocopy Output

# X Bitmap Filename : Type Spacing Angle

B o

¥ path/pattern_filel 3 70 15

# path/pattern_file2 : 4 50 45

# path/pattern_file3 4 45 90

.H': E=mmm=m—=m==m==—=—m=—==—=m====m==m=m====m===m===m====

¥

[SHPEESOF_DIR}/1ib/PDE/fill_patternz/patl.pattern 1 0 0
[ SHPEESOF_DIR}/1ib/PDE/fill_patterns/patl.pattern 3 50 30
[ SHPEESOF_DIR}/1ib/PDE/fill_patterns/pat2.pattern 3 50 45
[ SHPEESOF_DIR}/1ib/PDE/fill_patterns/pat3.pattern 3 50 90
[SHPEESOF_DIR}/1ib/PDE/fill_patterns/patd.pattern 4 50 15
[ SHPEESOF_DIR}/1ib/PDE/fill_patterns/patS.pattern 4 50 30
[ SHPEESOF_DIR} /1ib/PDE/fill_patterns/patb.pattern 4 G50 45
[SHPEESOF_DIR} /1ib/PDE/fill_patternzs/pat7.pattern 4 50 90
[ SHPEESOF_DIR} /1ib/PDE/fill_patterns/pat8.pattern 3 70 15

If the ADS configuration file cannot be found or the hpeesof configuration does not contain an HPEESOF_FILL variable
(which determines the location of the ADS fill definition file), a single, unidirectional, solid fill pattern is automatically
loaded.

Viewing Details of the Current Configuration

The Configuration Explorer enables you to search, view, save to file, and print the current settings of ADS
configuration files. You can browse the configuration files in the following locations:

¢ Installation directory

e Site-wide customization directory
e User directory

e Current project

To launch the Configuration Explorer:

From the ADS Main window, choose Tools > Configuration Explorer.

16



Advanced Design System 2008

To view the properties of a given file:

1. Select the desired configuration directory from the drop-down list.
2. Click the desired filename. The file location, size, date, and permissions are displayed in the Status pane, as well
as the location of any additional files by that same name.

File Mame : C;Ausers/defaulthpeesof ‘config/de_zim.cfg

File Size : 924

Filg Drate ; Jun 4, 16:34

File Permizgions ; -per-i--

Cther de_sim. cfg files :
C:hugers\defaulihpeesofuconhio\de_sim.chg <<<
C:haDS 2007 vcustombconhghde_simuchg
C:AADS2007 veconhghde_sim cfg

To access the pop-up menu:

Position the pointer over any filename and click right.

Expand Selected File
Expand All

Collapze Selected File
Collapse All

Load vanables from selected file
Refresh

e Use the uppermost group of commands to quickly expand and collapse the tree.

¢ Use Load variables from selected file to explicitly load into memory changes you have made to a
configuration file since launching ADS.

e Use Refresh to view changes you have made to a configuration file since launching ADS.

To view the list of variables in a given file:

Click once on the plus sign (expand) in front of the filename to display the list.

To view the current setting of a given variable:

¢ Click once on the variable name to display the value in the Status pane, or
¢ Click once on the plus sign in front of the variable to display its value in the browser pane

17
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Brormar Pans Slaus Pans
#- @ PROJECT_E=TEMSION PROJECT_LISTING az zetin C:‘wzershdefault\hpeezoficc
= @ PROJECT_LISTING Literal Setting:  TRUE
TRUE . .
4 @ PROJECT OFEN_HISTORY 1 Current value in ADS environment: TRLE
#- @ PROJECT_OPEMN_HISTORY_2

To search for a specific variable name and/or value:

Select Variable in the Search pane.

Optionally, refine your search by selecting Variable Name and/or Variable Value.

Optionally, refine your search by selecting Exact Match.

Type the search string in the Search for field and click Search. The results are displayed in the Status pane.

.

To search for a specific filename:

1. Select File in the Search pane.
2. Optionally, refine your search by selecting Exact Match.
3. Type the search string in the Search for field and click Search. The results are displayed in the Status pane.

To retain the results of all listings and searches:

Select the Keep history option in the Status pane. Note that to retain the variable value listings, you must
display the values in the Status pane, not the Browser pane. To clear the history click Clear.

To print the contents of the Status pane:

Click Print. The contents are sent to your default printer.

To save the contents of the Status panel to a file:

1. Click Save Status. A dialog box appears prompting you for a filename.
2. Change paths as desired, supply a filename, and click OK.

This information may be especially helpful when discussing configuration issues with Technical Support.

Typical Variables
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The remaining variables use the variable=value syntax.

 Note

The Design Kit variables are documented in the Design Kit Installation and Setup manual.

Variables in the File de.cfg, de_sim.cfg

A number of resources related to the user interface and simulation can be customized in the file de_sim.cfg. This file
can be customized for individual projects, all projects, etc., as described in, Customizing Configuration Variables. You
will find a default copy of this file, with a limited number of variables in it, in the following locations:

e In your /hpeesof/config directory under $HOME (on UNIX) or c:\users\default (on PC, or whatever directory you
chose instead during installation)
e Every project directory you create

You can add to this file (or modify, if they currently exist in the file) all variables described in the table below.

& Note

The variables described in the table are defined in either de.cfg or de_sim.cfg (under $ HPEESOF_DIR/config),
however when you customize any of these variables, it must be done in de_sim.cfg. To minimize typing and
ensure accuracy of the variable names, copy the variables you want to customize from one or both of these
files to the appropriate de_sim.cfg file and modify them there .

Variable, description, and example Value(s)
FILE_FORMAT ascii
Specifies the format for writing design files. Use ASCII binary
for
portability and upgrades; binary is faster and uses less
disk
space.

Example: FILE_FORMAT = ascii

LAYERS_PATH Path
Specifies the layer file search path.

Example: LAYERS_PATH =

./:{$HPEESOF_DIR}/de/defaults

PREFERENCES_PATH Path
Specifies the preference file search path.

Example: PREFERENCES_PATH =
./:{$HPEESOF_DIR}/de/defaults

LOCAL_AEL Filenames
Specifies the project-specific AEL files to be automatically = (without extension)
loaded or Path

each time when a project is opened. It should be set only
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in the

de_sim.cfg file located in the project directories. These
AEL

filenames may have absolute, relative, or no path
specified, but

since the files are generally located in the project

directory, a

relative path would be used beginning with a dot and
slash (./).

An AEL file that is already in the networks subdirectory
will be

automatically loaded. Any other AEL files that you would
like

included should be placed here.
Example: LOCAL_AEL = my_file

USER_AEL Filenames

Specifies the user-specific AEL files to be automatically (optional extension)
loaded or Path

once at startup. It should be set only in the de_sim.cfg

file located

in the user's personal customized directory
$HOME/hpeesof/config. If you specify a path, rather than
filenames, it cannot be a relative path; it must be an
absolute

path, or you can use an environment variable. A typical
use would

include $HOME to reference files in the user's home
directory.

Example: USER_AEL = $HOME/hpeesof/MyLibrary/ael/

USER_DSN_PATH Path
Specifies the directory (or directories) separated by a
colon (:)

where user-specific design files are located. It should be
set only

in the de_sim.cfg file located in the user's home
directory. This

variable cannot specify a relative path; it must be an
absolute

path, or you can use an environment variable. A typical
use would

include $HOME to reference files in the user's home
directory.

Note: this variable should be used in conjunction with
USER_AEL.

Example: USER_DSN_PATH =
$HOME/hpeesof/MyLibrary/designs/

SITE_AEL Filenames
Specifies the site-specific AEL files to be automatically (optional extension)
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loaded or Path
once at startup. It is typically set in the de_sim.cfg file

located in

$HPEESOF_DIR/custom/config. If you specify a path,

rather than

filenames, it cannot be a relative path; it must be an

absolute

path, or you can use an environment variable.

Example: SITE_AEL = {$ADS_DESIGNS}/libraryl/ael/

Example: SITE_AEL = Q:\ads_designs\libraryl\ael\

SITE_DSN_PATH Path
Specifies the directory (or directories) separated by a
colon ()

where design files for site-wide use are located. It is
typically set

in the de_sim.cfg file located in
$HPEESOF_DIR/custom/config.

This variable cannot specify a relative path; it must be
an

absolute path, or you can use an environment variable.
Note: this

variable should be used in conjunction with SITE_AEL.
Example: SITE_DSN_PATH =
{$ADS_DESIGNS}/libraryl/designs/

Example: SITE_DSN_PATH =
Q:\ads_designs\library1\designs\

HPEESOF_LANGUAGE Language name
Specifies the language used by the PDE program.
Example: HPEESOF_LANGUAGE = english

ENGLISH_MSG_EXT English = eng
Specifies the language of the program messages. German = ger
Example: english_MSG_EXT = eng French = fra
ENGLISH_MSG_FONT European = 9x15

Specifies the font supporting the selected local language. Japanese = 8x16
Example: ENGLISH_MSG_FONT = 9x15 bold

PDE_MSG_FILE Path
Specifies the full path to the PDE message directory file.
Example: PDE_MSG_FILE =
{$HPEESOF_DIR}/msgs/english/PDE/PDE.msg

NETLIST_FILE_NAME Filename
Specifies the netlist filename.
Example: NETLIST_FILE_NAME = netlist.log

EGSLIST_FILE_NAME Filename
Specifies the filename for the EGS translator option.
Example: EGSLIST_FILE_NAME = ./egslist.log
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EGS_OPTION_FILE: Path
Specifies the path to the EGS translator option files.

Example: EGS_OPTION FILE =

./:{$HPEESOF_DIR}/config

GDSII_OPTION_FILE Path
Specifies the path to the GDSII option files.

Example: GDSII_OPTION_FILE =

./:{$HPEESOF_DIR}/config

MASK_OPTION_FILE Path
Specifies the path to the mask translator option files.

Example: MASK_OPTION_FILE =

./:{$HPEESOF_DIR}/config

IGES_OPTION_FILE Path
Specifies the path to the IGES translator option files.

Example: IGES_OPTION_FILE =

./:{$HPEESOF_DIR}/config

SPICE_OPTION_FILE Path
Specifies the search path for the Spice files.

Example: SPICE_OPTION_FILE =

./:{HPEESOF_DIR}/config

IFF_OPTION_FILE Path
Specifies the search path for the IFF option files.
Example: IFF_OPTION_FILE = ./:{HPEESOF_DIR}/config

DIALOG_TIME_OUT Time in
Specifies the time before the copyright or information milliseconds
dialog box

is automatically dismissed.
Example: DIALOG_TIME_OUT = 10000

BALLOON_HELP_TIMEOUT Time in
Time taken for balloon help to appear when icon is milliseconds
selected.

Example: BALLOON_HELP_TIMEOUT = 600

BALLOON_HELP_DISMISSAL_TIMEOUT Time in
Time taken for balloon help to disappear when icon is milliseconds
selected.

Example: BALLOON_HELP_DISMISSAL_TIMEOUT = 2500

BALLOON_HELP TRUE or FALSE
Sets whether balloon help exists or not.
Example: BALLOON_HELP = TRUE

DOUBLE_CLICKS_TIME_OUT Time in
Specifies the time interval in which a double-click is milliseconds
registered.

Example: DOUBLE_CLICKS_TIME_OUT = 200
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QUERY_PROCESS_STATUS Time in seconds
Specifies how often PDE should query the child process

status.

Example: QUERY_PROCESS_STATUS =1

MAX_PROCESS_READY_TIMEOUT Time in seconds
Defines when PDE should quit waiting for the child

process to be

ready after it's spawned

Example: MAX_PROCESS_READY_TIMEOUT = 300

BOM_LIST Report types
Specifies the list of report types presented in the Bill of

Materials

dialog box.

Example: BOM_LIST = Agilent EEsof (Agilent EEsof BOM
format/de_bom

PARTS_LIST Report types
Specifies the list of report types presented in the Parts

List dialog

box. Example:

PARTS_LIST = Agilent EEsof (Agilent EEsof PL

format)/de_parts:Agilent EEsof (netlist format)/de_net

BOM_ITEM Integer
Specifies the spacing allocated for item name field in the

Bill of

Materials dialog box.

Example: BOM_ITEM = 30

BOM_QTY Integer
Specifies the spacing allocated for quantity field in the

Bill of

Materials dialog box.

Example: BOM_QTY = 7

BOM_DESC Integer
Specifies the spacing allocated for description field in the

Bill of

Materials dialog box.

Example: BOM_DESC = 50

TEXT_EDITOR_PROGRAM_NAME Editor name
Text editor
Example: TEXT_EDITOR_PROGRAM_NAME = write.exe

INVOKE_DDS_ON_BOOTUP TRUE or FALSE
Program Preference.
Example: INVOKE_DDS_ON_BOOTUP = FALSE

INVOKE_LIB_SERVER_ON_BOQTUP TRUE or FALSE
Program Preference.
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Example: INVOKE_LIB_SERVER_ON_BOOTUP = FALSE

FILE_ OPEN_HISTORY_COUNT Integer
Maximum number of files to be shown at the end of the

File Menu

in the Schematic and Layout windows.

Example: FILE_OPEN_HISTORY_COUNT = 4

PROJECT_OPEN_HISTORY_COUNT Integer
Maximum number of projects to be listed at the end of

the File

Menu in the Schematic and Layout windows.

Example: PROJECT_OPEN_HISTORY_COUNT = 4

DESIGN_LIST_COUNT Integer
Maximum number of designs to appear at the end of the

Windows Menu in the Schematic and Layout windows.

Example: DESIGN_LIST_COUNT =9

SCHEMATIC_COMPONENT_PALETTE_LIST_COUNT Integer
Maximum number of palettes displayed in the

component palette

drop-down list on the Schematic window toolbar.

Example:

SCHEMATIC_COMPONENT_PALETTE_LIST_COUNT = 16

LAYOUT_COMPONENT_PALETTE_LIST_COUNT Integer
Maximum number of palettes displayed in the

component palette

drop-down list on the Layout window toolbar.

Example: LAYOUT_COMPONENT_PALETTE_LIST_COUNT

=16

SCHEMATIC_COMPONENT_PALETTE_LIST_WIDTH Integer
Width of the component palette drop-down list on the

Schematic

window toolbar.

Example:

SCHEMATIC_COMPONENT_PALETTE_LIST_WIDTH = 16

LAYOUT_COMPONENT_PALETTE_LIST_WIDTH Integer
Width of the component palette drop-down list on the

Layout

window toolbar.

Example: LAYOUT_COMPONENT_PALETTE_LIST_WIDTH

=16

SCHEMATIC_COMPONENT_HISTORY_LIST_COUNT Integer
Maximum number of components displayed in the

component

history drop-down list on the Schematic window toolbar.

Example:

SCHEMATIC_COMPONENT_HISTORY_LIST_COUNT = 10
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LAYOUT_COMPONENT_HISTORY_LIST_COUNT

Maximum number of components displayed in the
component

history drop-down list on the Layout window toolbar.
Example: LAYOUT_COMPONENT_HISTORY_LIST_COUNT
=10

SCHEMATIC_COMPONENT_HISTORY_LIST_WIDTH
Width of the component history drop-down list on the
Schematic

window toolbar.

Example:
SCHEMATIC_COMPONENT_HISTORY_LIST_WIDTH = 7

LAYOUT_COMPONENT_HISTORY_LIST_WIDTH

Width of the component history drop-down list on the
Layout

window toolbar.

Example: LAYOUT_COMPONENT_HISTORY_LIST_WIDTH
=7

LAYER_LIST_COUNT

Maximum number of layers to be shown in the layer list
drop-down list on the Layout window toolbar.

Example: LAYER_LIST_COUNT = 10

LAYER_LIST_WIDTH

Width of the drop-down layer list on the Layout window
toolbar.

Example: LAYER_WIDTH = 14

SIMULATION_HOST_LIST

Remote simulation host names
Example: SIMULATION_HOST_LIST =
machine.company.com

MAIN_WINDOW_X_LOC, MAIN_WINDOW_Y_LOC

The default location of the Main window. The upper left
corner

of the window is positioned at the specified X,Y screen
coordinates, where 0,0 is the upper left corner.
Example: MAIN_WINDOW_X_LOC =0

Example: MAIN_WINDOW_Y_LOC =0

MAIN_WINDOW_WIDTH, MAIN_WINDOW_HEIGHT
The default size of the Main window in pixels (window
can still

be re-sized manually).

Example: MAIN_WINDOW_WIDTH = 365

Example: MAIN_WINDOW_HEIGHT = 340

SCHEMATIC_WINDOW_X_LOC,
SCHEMATIC_WINDOW_Y_LOC

Integer

Integer

Integer

Integer

Integer

Host names

Integer

Integer

Min. Width = 340

Min. Height = 300

Integer
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The default location of the Schematic window. The upper
left corner

of the window is positioned at the specified X,Y screen
coordinates, where 0,0 is the upper left corner.

Example: SCHEMATIC_WINDOW_X_LOC = 260
Example: SCHEMATIC_WINDOW_Y_LOC =0

SCHEMATIC_WINDOW_WIDTH,
SCHEMATIC_WINDOW_HEIGHT

The default size of the Schematic window in pixels
(window can still

be re-sized manually).

Example: SCHEMATIC_WINDOW_WIDTH = 780
Example: SCHEMATIC_WINDOW_HEIGHT = 530

LAYOUT_WINDOW_X_LOC, LAYOUT_WINDOW_Y_LOC
The default location of the Layout window. The upper left
corner

of the window is positioned at the specified X,Y screen
coordinates, where 0,0 is the upper left corner.

Example: LAYOUT_WINDOW_X_LOC = 30

Example: LAYOUT_WINDOW_Y_LOC = 30

LAYOUT_WINDOW_WIDTH, LAYOUT_WINDOW_HEIGHT
The default size of the Layout window in pixels (window
can still

be re-sized manually).

Example: LAYOUT_WINDOW_WIDTH = 1012

Example: LAYOUT_WINDOW_HEIGHT = 500

ELW_WINDOW_OPEN_WITH_SCHEMATIC

When True, the Layers window will automatically be
displayed

when a schematic window is opened.

Example: ELW_WINDOW_OPEN_WITH_SCHEMATIC =
FALSE

ELW_WINDOW_OPEN_WITH_LAYOUT

When True, the Layers window will automatically be
displayed

when a layout window is opened.

Example: ELW_WINDOW_OPEN_WITH_LAYOUT = TRUE

ELW_WINDOW_AUTO_REDRAW_DESIGN

When True, the current design representation's
schematic or

layout window will be redrawn whenever the Layers
window

changes the design representation's layers information.
Example: ELW_WINDOW_AUTO_REDRAW_DESIGN =
TRUE

Integer
Min. Width = 760
Min. Height = 500

Integer

Integer
Min. Width = 760
Min. Height = 500

TRUE or FALSE

TRUE or FALSE

TRUE or FALSE
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ELW_WINDOW_INITIAL_X_LOC, Integer
ELW_WINDOW_INITIAL_Y_LOC

The default initial location of the Layers window. The

upper left

corner of the window is positioned at the specified X, Y

screen

coordinates, where 0,0 is the upper left corner.

Example: ELW_WINDOW_INITIAL_X_LOC =0

Example: ELW_WINDOW_INITIAL_Y_LOC = 100

ELW_WINDOW_INITIAL_WIDTH, Integer
ELW_WINDOW_INITIAL_HEIGHT

The default initial size of the Layers window in pixels

(window

can still be resized manually).

Example: ELW_WINDOW_INITIAL_WIDTH = 200

Example: ELW_WINDOW_INITIAL_HEIGHT = 450

SAVE_PROJECT_STATE TRUE, FALSE
Sets a default to be used for any project for which no
save_project_state.ael file exists. This file is
created/modified

when you change projects or exit the program and the
Save

Project State on Exit option is on. When on (TRUE), the
status of

every currently open Schematic and Layout window will
be saved

and subsequently restored, the next time you open that
project.

Note that only windows with named designs are saved;
untitled

windows are not saved.

Example: SAVE_PROJECT_STATE = TRUE

COMMAND_DIALOG_WIDTH Integer
Sets the width, in pixels, of the Command Line dialog

box

( Options > Command Line in the Main window). The

default is

400; a wider setting may be helpful for viewing lengthy

AEL

functions.

Example: COMMAND_DIALOG_WIDTH = 400

DATA_FILES Path
Specifies the search path for data files.

Example: DATA_FILES =
./data:{$HOME}/hpeesof/my_datafiles

OPEN_PROJECT_AUTO_SCHEMATIC TRUE, FALSE
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Sets a default for all projects. When TRUE, an empty

Schematic

window is automatically displayed when you create a

project.

Example: OPEN_PROJECT_AUTO_SCHEMATIC = TRUE

OPEN_PROJECT_AUTO_LAYOUT

Sets a default for all projects. When TRUE, an empty
Layout

window is automatically displayed when you create a
project.

Example: OPEN_PROJECT_AUTO_LAYOUT = FALSE

SCHEMATIC_ANALOG_DEFAULT_PALETTE

Sets the specified palette as the default palette for
Analog/RF

designs in the Schematic window.

Example:
SCHEMATIC_ANALOG_DEFAULT_PALETTE =
Devices-MOS

LAYOUT_ANALOG_DEFAULT_PALETTE

Sets the specified palette as the default palette for
Analog/RF

designs in the Layout window.

Example:

LAYOUT_ANALOG_DEFAULT_PALETTE = TLines-Stripline

SCHEMATIC_DSP_DEFAULT_PALETTE

Sets the specified palette as the default palette for DSP
designs

in the Schematic window.

Example: SCHEMATIC_DSP_DEFAULT_PALETTE = Timed
Linear

LAYOUT_DSP_DEFAULT_PALETTE

Sets the specified palette as the default palette for DSP
designs

in the Layout window.

Example: LAYOUT_DSP_DEFAULT_PALETTE = Block Text
Fonts

USER_MENU_FUNCTION_LIST

Controls which functions are called every time a new
window is

opened.

Example: USER_MENU_FUNCTION_LIST =
app_add_user_menus

OPEN_DDS_AFTER_SIM
Establishes a default state for whether or not to
automatically

TRUE, FALSE

Standard or custom
palette name,
exactly as it appears
in program.

Standard or custom
palette name,
exactly as it appears
in program.

Standard or custom
palette name,
exactly as it appears
in program.

Standard or custom
palette name,
exactly as it appears
in program.

Function names

TRUE or FALSE
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open a Data Display window upon completion of a
simulation.

This setting can be overridden for any given simulation
using the

Simulation Setup dialog box.

Note: If this variable is not defined, or is defined but set
to

something other than TRUE or FALSE, the initial state for
Analog/RF designs is TRUE and for DSP designs is FALSE.
Example: OPEN_DDS_AFTER_SIM = TRUE

CONFIG_EXPLORER_VARS E_<VariableName>,
Controls which variables are listed when you launch the C_<VariableName>,
Configuration Explorer. This list is delimited by S_<VariableName>

semicolons. Each

variable name is preceded by one of the following
designations,

as well as an underscore character:

E_ For Environment variables

Example: CONFIG_EXPLORER_VARS = E_HPEESOF_DIR
C_ For Configuration variables

Example: CONFIG_EXPLORER_VARS = C_SITE_AEL

S_ For System variables (PC only)

Example: CONFIG_EXPLORER_VARS = S_TEMP

CONFIG_EXPLORER_CMP_VARS Yes or No
Controls whether or not the Configuration Explorer
evaluates the

value of every variable and compares it against the
current value

in the environment. If the setting of a given variable is
the same

as the current value in the environment, it is preceded
by a green

dot; if the values are different, it is preceded by a yellow
dot.

(Note: Setting this variable to yes is helpful for
troubleshooting

configuration problems but takes your system
considerable time

to perform the evaluations.) The default value is no.
Example: CONFIG_EXPLORER_CMP_VARS = yes

MAKELIB_USER_AEL_PATH Path
Complete path for .ael files (associated with .dsn files)

added to

a user library using the custom library tool. Multiple

libraries can

be defined by specifying a semicolon-delimited list.
Example: MAKELIB_USER_AEL_PATH =
{$HOME}/hpeesof/circuit/ael
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MAKELIB_USER_DSN_PATH Path
Complete path for .dsn files added to a user library using

the

custom library tool. Multiple libraries can be defined by
specifying

a semicolon-delimited list.

Example: MAKELIB_USER_DSN_PATH =
{$HOME}/hpeesof/circuit/networks

MAKELIB_USER_DATA_FILES Path
Complete path for data files referenced by designs added

to a

user library using the custom library tool.

Example: MAKELIB_USER_DATA_FILES =
{$HOME}/hpeesof/datafiles

MAKELIB_USER_LIBRARY_NAMES Default or custom
The library name(s) that are used if no Library Name library name

was

specified in the Design Parameters dialog box. Multiple

libraries

can be defined by specifying a semicolon-delimited list.

The

members of this list must have a one-to-one

correspondence

with the lists set for the three aforementioned variables.
Example: MAKELIB_USER_LIBRARY_NAMES = User
Library

MAKELIB_SITE_AEL_PATH Path
Complete path for .ael files (associated with .dsn files)

added to

a site library using the custom library tool. Multiple

libraries can

be defined by specifying a semicolon-delimited list.

Example: MAKELIB_SITE_AEL_PATH =
{$HPEESOF_DIR}/custom/circuit/ael

MAKELIB_SITE_DSN_PATH Path
Complete path for .dsn files added to a site library using

the

custom library tool. Multiple libraries can be defined by
specifying

a semicolon-delimited list.

Example:

MAKELIB_SITE_DSN_PATH =
{$HPEESOF_DIR}/custom/circuit/networks

MAKELIB_SITE_DATA_FILES Path
Complete path for data files referenced by designs added
to a
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site library using the custom library tool.
Example:

MAKELIB_SITE_DATA_FILES =
{$HPEESOF_DIR}/custom/datafiles

MAKELIB_SITE_LIBRARY_NAMES Default or custom
The library name(s) that are used if no Library Name library name

was

specified in the Design Parameters dialog box. Multiple

libraries

can be defined by specifying a semicolon-delimited list.

The

members of this list must have a one-to-one

correspondence

with the lists set for the three aforementioned variables.
Example: MAKELIB_SITE_LIBRARY_NAMES = Site
Library

Variables in the File hpeesof.cfg

All programs that are part of the ADS suite read the hpeesof configuration file.

Variable, description, and example

HPEESOF_LM_LICENSE_FILE Filename
Complete path to FLEXIm license.lic file.

Example:

HPEESOF_LM_LICENSE_FILE =

{$HPEESOF_DIR}/license/license.lic

HPEESOF_COLOR Filename
Complete path to system-wide color configuration file.

Example: HPEESOF_COLOR =
{$HPEESOF_DIR}/config/hpeecolor.cfg

HPEESOF_FILL Filename
Complete path to system-wide fill pattern configuration

file.

Example: HPEESOF_FILL =

{$HPEESOF_DIR}/config/hpeefill.cfg

HPEESOF_FONT_FILE Directory
Directory where TrueType raster fonts are located.

Example: HPEESOF_FONT_FILE =

{$HPEESOF_DIR?}/config

HPEESOF_OCCIDENTAL_FILE Filename
Complete path to European Hershey vector fonts.
Example:
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HPEESOF_OCCIDENTAL_FILE =
{$HPEESOF_DIR}/config/hersh.oc

HPEESOF_ORIENTAL_FILE

Complete path to Asian Hershey vector fonts.
Example: HPEESOF_ORIENTAL_FILE =
{$HPEESOF_DIR}/config/hersh.or

HPEESOF_LANGUAGE
Specifies the default language.
Example: HPEESOF_LANGUAGE = english

AGILEESOFD_LICPREF

Controls bundle selection for all systems on a network
with access

to the license server.

Example: AGILEESOFD_LICPREF = bundle_a

AGILEESOFD_LICPREF_<hostname>

Controls bundle selection specifically for the system
identified by

<hostname>.

Example: AGILEESOFD_LICPREF_alpha = bundle_b

Variables in the File dfilter.cfg

This configuration file is used by the Digital Filter tool.

Variable, description, and example

DF_AEL_PATH
The AEL path for Digital Filter designs.

Example: DF_AEL_PATH = ./:$HOME/hpeesof/dfilter/ael:

Filename

Language name

License bundle name

License bundle name

Path

$HPEESOF_DIR/custom/dfilter/ael:$HPEESOF_DIR/dfilter/ael

DFUI_DATA_FILE

Data file, only for Digital Filter UI
Example: DFUI_DATA_FILE =
$HPEESOF_DIR/dfilter/ael/firdemoui.ael

DFUI_SPEC_HEADING_COLOR

Foreground color for spec heading data, only for Digital

Filter UI
Example: DFUI_SPEC_HEADING_COLOR = BLUE

DFUI_SPEC_EDITABLE_COLOR

Foreground color for spec editable data, only for Digital

Filter UI
Example: DFUI_SPEC_EDITABLE_COLOR = BLACK

Filename

Color name

Color name
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DFUI_SPEC_NOEDITABLE_COLOR Color name
Foreground color for spec non-editable data, only for

Digital Filter UI

Example: DFUI_SPEC_NOEDITABLE_COLOR = GRAY

DFUI_SPEC_CELL_WIDTH Integer
Column width for spec data, only for Digital Filter UI
Example: DFUI_SPEC_CELL_WIDTH = 7

DF_DDS_IDEAL_TRACE_COLOR Integer
Trace color index to be used in hpeesof data display

server

Example: DF_DDS_IDEAL_TRACE_COLOR =1

DF_DDS_SCALED_TRACE_COLOR Integer
Trace color index to be used in hpeesof data display

server

Example: DF_DDS_SCALED_TRACE_COLOR = 3

DF_DDS_SPEC_TRACE_COLOR Integer
Trace color index to be used in hpeesof data display

server

Example: DF_DDS_SPEC_TRACE_COLOR = 4

Variables in the File eeapi.cfg

This configuration file is used by the layered Application Programming Interface (API).

Variable, description, and example Value(s)

API_BALLOON_HELP_TIMEOUT Time in milliseconds
Time taken for balloon help to appear when icon is

selected.

Example: API_BALLOON_HELP_TIMEOUT = 600

API_BALLOON_HELP TRUE or FALSE
Sets whether balloon help exists or not.
Example: API_BALLOON_HELP = TRUE

API_BALLOON_HELP_DISMISSAL_TIMEOUT Time in milliseconds
Time taken for balloon help to disappear when icon is

selected.

Example: API_BALLOON_HELP_DISMISSAL_TIMEOUT =

6000

API_DOUBLE_CLICKS_TIME_OUT Time in milliseconds
The time between two clicks required for them to be

recognized

as a unit, or double-click.

Example: API_DOUBLE_CLICKS_TIME_OUT = 400
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API_NO_TEAR_OFF_MENU O=allow tear-off menu
Turn on/off Motif's tear-off menu 1= do not allow tear-off menu
Example: API_NO_TEAR_OFF_MENU =0

Variables in the File hpads.cfg

This configuration file is used by PTOLEMY for locating user-compiled models and the location of MATLAB software.

Variable, description, and example Value(s)

ADSPTOLEMY_MOD_PATH Path
Controls where ADS Ptolemy will look for models. You
must reference the

ADSPTOLEMY_MODEL_PATH variable here so that
user-compiled models

are found. If ADS is started with the -b option, then
$HPEESOF_DIR/adsptolemy/beta will be appended to

load beta models.

Example: ADSPTOLEMY_MOD_PATH =
$HOME/hpeesof/adsptolemy:
$ADSPTOLEMY_MODEL_PATH: $HPEESOF_DIR/adsptolemy

MATLAB Directory
The MATLAB variable should point to the root of your

Matlab 5 installation

(directories bin and extern should be there).

Example: MATLAB = /usr/local/matlab

MATLABCMD Command
If the command to invoke Matlab is not matlab, you'll

need to set the

MATLABCMD variable. See the documentation for

engOpen in the Matlab

Application Programming Interface Guide for more

details on what you can

do here. This variable is ignored on Windows.

Example: MATLABCMD = "matlab -c licensefile"

Variables in the File hpeesofbrowser.cfg

This configuration file is used by the Browse and Search dialog box.

Variable, description, and example Value(s)

HPEESOF_BROWSER_WINDOW_X_LOCATION Integer
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The default X coordinate of the Component Library
window relative to the upper

left corner of the screen.

Example: HPEESOF_BROWSER_WINDOW_X_LOCATION
= 100

HPEESOF_BROWSER_WINDOW_Y_LOCATION Integer
The default Y coordinate of the Component Library

window relative to the upper

left corner of the screen.

Example: HPEESOF_BROWSER_WINDOW_Y_LOCATION

= 100

HPEESOF_BROWSER_WINDOW_WIDTH Integer
The default width of the Component Library window.
Example: HPEESOF_BROWSER_WINDOW_WIDTH = 600

HPEESOF_BROWSER_WINDOW_HEIGHT Integer
The default height of the Component Library window.
Example: HPEESOF_BROWSER_WINDOW_HEIGHT = 400

HPEESOF_BROWSER_TIME_OUT Time in
The default time-out for warning/information messages. = milliseconds
Example: HPEESOF_BROWSER_TIME_OUT = 10000

HPEESOF_BROWSER_AEL_PATH Path

Path for the browser AEL files.

Example: HPEESOF_BROWSER_AEL_PATH =
$HOME/hpeesof/hpeesofbrowser/ael: $HPEESOF_DIR/hpeesofbrowser/ael

HPEESOF_BROWSER_AEL Filename
Top level AEL file
Example: HPEESOF_BROWSER_AEL = Ibb_main

HPEESOF_BROWSER_PATH Path
Path for the control, records and Device Libraries Binary

File. Path can only have

System variables.

Example: HPEESOF_BROWSER_PATH =
$HOME/hpeesof/hpeesofbrowser/records;
$COMPL_DIR/ComponentLibs/records

HPTOLEMY_BROWSER_PATH Path
ADS Ptolemy related control, record and IDF files. All the

control files and the IDF

files in these directories are read to create the ADS

Ptolemy related libraries and

sub-libraries

Example: HPTOLEMY_BROWSER_PATH =
$HPTOLEMY_MODEL_AEL; $HPEESOF_DIR/CustomEncoded/records

HPEESOF_BROWSER_LIBRARIES_FIELD_WIDTH Integer
The default width of the component library tree
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structure.
Example:
HPEESOF_BROWSER_LIBRARIES_FIELD_WIDTH = 30

HPEESOF_BROWSER_PARTS_DISPLAY_WIDTH Integer
The default width of the Component column. (This

column is always visible.)

Example: HPEESOF_BROWSER_PARTS_DISPLAY_WIDTH

=15

HPEESOF_BROWSER_FIELD_NUM_ROWS Integer
The default number of rows of components listed for any

selected sub-library.

Example: HPEESOF_BROWSER_FIELD_NUM_ROWS = 20

HPEESOF_BROWSER_COMPONENT_DESCRIPTION_VISIBLIE0 = False
The default visibility status of the Description column. 1= True
Example:
HPEESOF_BROWSER_COMPONENT_DESCRIPTION_VISIBLI:

=1

HPEESOF_BROWSER_PARTS_DESCRIPTION_WIDTH Integer
The default width of the Description column.

Example:

HPEESOF_BROWSER_PARTS_DESCRIPTION_WIDTH =

20

HPEESOF_BROWSER_COMPONENT_VENDOR_VISIBLE 0 = False
The default visibility status of the Vendor column. 1= True
Example:

HPEESOF_BROWSER_COMPONENT_VENDOR_VISIBLE =

0

HPEESOF_BROWSER_PARTS_VENDOR_WIDTH Integer
The default width of the Vendor column.
Example: HPEESOF_BROWSER_PARTS_VENDOR_WIDTH

=10

HPEESOF_BROWSER_COMPONENT_LIBNAME_VISIBLE 0 = False
The default visibility status of the Library column. 1= True
Example:

HPEESOF_BROWSER_COMPONENT_LIBNAME_VISIBLE =

0

HPEESOF_BROWSER_PARTS_LIBNAME_WIDTH Integer

The default width of the Library column.
Example: HPEESOF_BROWSER_PARTS_LIBNAME_WIDTH

=20

HPEESOF_BROWSER_COMPONENT_PLACEMENT_VISIBLE 0 = False
The default visibility status of the Placement column. 1= True
Example:

HPEESOF_BROWSER_COMPONENT_PLACEMENT_VISIBLE
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=0

HPEESOF_BROWSER_PARTS_PLACEMENT_WIDTH

The default width of the Placement column.

Example:
HPEESOF_BROWSER_PARTS_PLACEMENT_WIDTH = 15

HPEESOF_BROWSER_COMPONENT_WEBSITE_VISIBLE
The default visibility status of the Website column.
Example:
HPEESOF_BROWSER_COMPONENT_WEBSITE_VISIBLE =
0

HPEESOF _BROWSER_PARTS_WEBSITE_WIDTH

The default width of the Website column.

Example: HPEESOF_BROWSER_PARTS_WEBSITE_WIDTH
=20

HPEESOF_BROWSER_COMPONENT_AVAILABILITY_VISIBLE:
The default visibility status of the Availability column.
Example:
HPEESOF_BROWSER_COMPONENT_AVAILABILITY_VISIBLE
=0

HPEESOF_BROWSER_PARTS_AVAILABILITY_WIDTH
The default width of the Availability column.

Example:
HPEESOF_BROWSER_PARTS_AVAILABILITY_WIDTH =
10

HPEESOF_BROWSER_COMPONENT_LICENSE_VISIBLE
The default visibility status of the License column.
Example:
HPEESOF_BROWSER_COMPONENT_LICENSE_VISIBLE =
0

HPEESOF_BROWSER_PARTS_LICENSE_WIDTH

The default width of the License column.

Example: HPEESOF_BROWSER_PARTS_LICENSE_WIDTH
=10

ADS_COMPONENT_SORT_ORDER
The sort order for components.
Example: ADS_COMPONENT_SORT_ORDER = Default

ADS_ANALOGRF_LIBRARY_SORT_ORDER

The sort order for the analogRF library.

Example: ADS_ANALOGRF_LIBRARY_SORT_ORDER
Default

ADS_HPTOLEMY_LIBRARY_SORT_ORDER

The sort order for the Ptolemy library.

Example: ADS_HPTOLEMY_LIBRARY_SORT_ORDER
Ascending

Integer

0 = False
1= True

Integer

0 = False
1= True

Integer

0 = False
1= True

Integer

Default
Ascending
Descending

Default
Ascending
Descending

Default
Ascending
Descending
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HPEESOF_BROWSER_COMPONENT_HIDE_OBSOLETE 0 = False
Hides obsolete ADS library components from view in the = 1= True
ADS library browser.

Example:

HPEESOF_BROWSER_COMPONENT_HIDE_OBSOLETE = 1

HPEESOF_BROWSER_COMPONENT_HIDE_UNLICENSED 0 = False
Hides unlicensed ADS library components from view in 1= True
the ADS library browser.

Example:

HPEESOF_BROWSER_COMPONENT_HIDE_UNLICENSED

=1

ADS_BROWSER_DEFAULT_WEBSITE URL String
Default website for ADS library records that do not have

a website defined.

Example:

ADS_BROWSER_DEFAULT_WEBSITE =
http://www.tm.agilent.com/tmo/hpeesof

HPANALOGRF_BROWSER_PATH Path

ADS Analog/RF libraries related control, record and IDF

files. All the control files

and the IDF files in these directories are read to create

the ADS Analog/RF related

libraries and sub-libraries.

Example: HPANALOGRF_BROWSER_PATH =
$HOME/hpeesof/circuit/records;

$HOME/hpeesof/esyn/records; $HOME/hpeesof/rfsynthesis,/records;
$HOME/hpeesof/CustomEncoded/records; $HPEESOF_DIR/circuit/records;
$HPEESOF_DIR/esyn/records; $HPEESOF_DIR/rfsynthesis/records;
$HPEESOF_DIR/CustomEncoded/records;
$HPEESOF_DIR/custom/circuit/records;
$HPEESOF_DIR/custom/esyn/records;
$HPEESOF_DIR/custom/rfsynthesis/records; {%DESIGN_KIT_BROWSER_PATH}

HPVENDORLIB_BROWSER_PATH Path
ADS Device libraries related control, record and IDF files.
All the control files and

the IDF files in these directories are read to create the
ADS Vendor Component

device related libraries and sub-libraries.

Example:

HPVENDORLIB_BROWSER_PATH =
$HOME/hpeesof/hpeesofbrowser/records;
$COMPL_DIR/ComponentLibs/records;
$HPEESOF_DIR/CustomEncoded/records

HP_TEMPLATE_BROWSER_PATH String|Path
Path information for the DDS template files. Each entry
is in the form of
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<name>|<path> where <name> is the top level node
displayed in the browser

and <path> is the path to the directory containing the
templates.

Example:

HP_TEMPLATE_BROWSER_PATH =
Product|{$HPEESOF_DIR}/circuit/templates;
Customized|{$HPEESOF_DIR}/custom/circuit/templates;
User|{$HOME}/hpeesof/circuit/templates;
{%DESIGN_KIT_TEMPLATE_BROWSER_PATH};
{%MOMENTUM_TEMPLATE_BROWSER_PATH}

Variables in the File hpeesofdds.cfg

This configuration file is used to configure data displays.

Variable, description, and example

AEL_PATH Path
Top level AEL file

Example: AEL_PATH =
$HOME/hpeesof/dds/ael/:$HPEESOF_DIR/custom/dds/ael
/:$HPEESOF_DIR/dds/ael

DDS_DEFAULTS_FILE Filename
Users default defaults file. This file gets read at start-up

and written at

shutdown with the current set of defaults.

Example: DDS_DEFAULTS_FILE =
$HOME/hpeesof/config/ddsdefaults.ael

DDS_WIN_FOREGROUND Integer
Window foreground color
Example: DDS_WIN_FOREGROUND

Il
o

DDS_WIN_BACKGROUND Integer
Window background color
Example: DDS_WIN_BACKGROUND

Il
o]

DDS_WIN_HEIGHT Integer
Window height
Example: DDS_WIN_HEIGHT = 510

DDS_WIN_WIDTH Integer
Window width
Example: DDS_WIN_WIDTH = 655

DDS_HIGHLITE_LINE_TYPE Integer
System-wide highlight line type
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Example: DDS_HIGHLITE_LINE_TYPE = 0 [= solid]

DDS_HIGHLITE_LINE_WIDTH Integer
System-wide highlight line width
Example: DDS_HIGHLITE_LINE_WIDTH
points]

56 [=4

DDS_HIGHLITE_LINE_COLOR Integer
System-wide highlight line color
Example: DDS_HIGHLITE_LINE_COLOR = 1 [= red]

DDS_DRAWING_UNITS_PER_INCH Integer
Default graphical object characteristic:

Internal database resolution

Example: DDS_DRAWING_UNITS_PER_INCH = 1000

DDS_PAGE_WIDTH Integer
Default graphical object characteristic:

Plotting area width

Example: DDS_PAGE_WIDTH = 33000

DDS_PAGE_HEIGHT Integer
Default graphical object characteristic:

Plotting area is height

Example: DDS_PAGE_HEIGHT = 21000

DDS_DEFAULT_LINE_WIDTH Integer
Default graphical object characteristic:

Plotting line width

Example: DDS_DEFAULT_LINE_WIDTH = 7

DDS_LEFT_CLICK_SENSITIVITY Integer
A left-mouse-button press-and-hold drag must move this

many pixels or

else it is considered a left click

Example: DDS_LEFT_CLICK_SENSITIVITY= 2

DDS_DEFAULT_PLOT_WIDTH Integer
Default width of new plots
Example: DDS_DEFAULT_PLOT_WIDTH = 3750

DDS_DEFAULT_PLOT_HEIGHT Integer
Default height of new plots
Example: DDS_DEFAULT_PLOT_HEIGHT = 2318

DDS_DEFAULT_FONT Font size,
Default font in points
Example: DDS_DEFAULT_FONT = HersheyRomanNarrow

DDS_NUMBER_OF_TRACE_COLORS Integer
Number of trace colors
Example: DDS_NUMBER_OF_TRACE_COLORS = 16

DDS_TRACE n _COLOR Integer
n th color, where n = 1 to
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DDS_NUMBER_OF_TRACE_COLORS
Example: DDS_TRACE16_COLOR = 90

Variables in the File hpeesofhelp.cfg

This configuration file is used to locate the online documentation.

Variable, description, and example Value(s)

TOPLEVEL_DOC Directory
Top level Index document location.
Example: TOPLEVEL_DOC = $HPEESOF_DIR/doc

LOCAL_DOC_PATH List of Paths
List of additional paths for the Help Server to search.

Example: LOCAL_DOC_PATH =

C:\newpath1;C:\newpath2;{%

DESIGN_KIT_DOC_PATH}

LOCAL_BOOK_NAMES List of names
Optional list of new books.

Example: LOCAL_BOOK_NAMES =

newbook1;newbook2;{%

DESIGN_KIT_BOOKNAMES}

Variables in the File hpeesofinstrio.cfg

This configuration file is used by the Instrument Server.

Variable, description, and example Value(s)

AEL_PATH Path
Top level AEL file

Example: AEL_PATH = $HOME/hpeesof/instrio/ael/:
$HPEESOF_DIR/custom/instrio/ael/: $HPEESOF_DIR/instrio/ael:./

Variables in the File momentum.cfg

This configuration file is used by Momentum.

Variable, description, and example Value(s)

SUPL_GF_DATABASE Directory
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Location of supplied Momentum Substrate files.
Example: SUPL_GF_DATABASE =
{$HPEESOF_DIR}/momentum/lib

SITE_GF_DATABASE Directory
Location of user Momentum Substrate files.
Example: SITE_GF_DATABASE = {$HOME}

LOCL_GF_DATABASE Directory
Location of project Momentum Substrate files.
Example: LOCL_GF_DATABASE = ./

MOM_SLM_PATH Path
Path to search for Momentum Substrate file that is saved

with design files.

Example: MOM_SLM_PATH =
./networks:{%SUPL_GF_DATABASE?}

MOMDDS_FILE Filename
On UNIX, location of default template file for Momentum

Data Display.

Example: MOMDDS_FILE=

{$HPEESOF_DIR}/sess/ael/momdds.ael

MOMMSH_REFACET_ARC_RESOLUTION Integer
Maximum resolution for the automatic refacetting of arcs

and circles in

Momentum. Setting a lower value results in a higher

resolution

representation with more unknowns in the mesh,

resulting in a longer

simulation time.

Example: MOMMSH_REFACET_ARC_RESOLUTION = 45

MOM3D_USE_MATRIXSOLVER 0
Sets solver algorithm to non-blocked or blocked. 1
Example: MOM3D_USE_MATRIXSOLVER = 0

non-blocked
blocked

MOM3D_USE_MATRIXSOLVERBLOCKSIZE Integer
On UNIX, the block size used to tune the linear solver.
Example: MOM3D_USE_MATRIXSOLVERBLOCKSIZE = 16

Variables in the File smg_ui.cfg

This configuration file is used by the SPICE Model Generator.

Variable, description, and example

SMG_AEL_PATH Path
PATH to look for top level AEL file.
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Example: SMG_AEL_PATH={$HOME}/hpeesof/smg/ael:
{$HPEESOF_DIR}/smg/ael:
{$HPEESOF_DIR}/ael_smg_ui

SMG_UI_AEL Filename
Top level AEL file.
Example: SMG_UI_AEL = smg_main

Variables in the File hpeesofsim.cfg

Variable, description, and example

AEL_PATH Path
Search path for locating AEL files loaded by the simulator

Example: AEL_PATH = $HOME/hpeesof/circuit/ael:
$HOME/hpeesof/expressions/ael: $HPEESOF_DIR/custom/circuit/ael:
$HPEESOF_DIR/custom/expressions/ael: $HPEESOF_DIR/circuit/ael:
$HPEESOF_DIR/expressions/ael:.

USER_MODEL_PATH Path
Path for User-Compiled models
Example: USER_MODEL_PATH

/some/path/to/model/directory:/some/path/to/a/directory

USER_SIM_FILE_PATH Path
Path for user-defined simulation files

Example: USER_SIM_FILE_PATH

= /path/to/my/directory:/some/path/to/somewhere

ADSLIBCONFIG_PATH Path

Path for ADS library configuration file

Example: ADSLIBCONFIG_PATH =

$_HP_GEMINI_LIBPATH: %

DKIT_ADSLIBCONFIG_PATH: $HOME/hpeesof/circuit/config:
$HPEESOF_DIR/custom/circuit/config: $HPEESOF_DIR/circuit/config:.

Variables in the File hpeesofsess.cfg

This configuration file is used by the Status window.

Variable, description, and example

STATUS_LINES_SHOWN Integer
Sets the maximum number of lines visible in the Status
window.
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Example: STATUS_LINES_SHOWN =100

SIMEXEC_MAP_TO_FRONT ON or OFF
Sets the default behavior of the Status window, where

on (the default) means

the Status window pops to the front of the screen

anytime new messages are

displayed in it, and off means it does not pop forward

automatically.

Example: SIMEXEC_MAP_TO_FRONT = on

HPEESOFSIM_BIN Path
Path to the hpeesofsim executable. Relative pathnames
are evaluated relative

to the current project's top-level directory. Note that
using HPEESOFSIM_BIN

to point to a user-defined hpeesofsim executable will
cause problems with

statically-linked user-compiled models since the
simulator containing the

models is prevented from being used. If this variable is
changed, ADS must

be restarted for the changes to take effect.

Example: HPEESOFSIM_BIN=hpeesofsim

Setting Design Environment Preferences

You can easily customize many aspects of design entry and display through the Preferences and Layer Editor dialog
boxes accessed through the Options menu. Some of the options set here serve as defaults and can be changed on an
individual basis through the Edit menu.

Some of the things you can customize are:

e The default settings for color of the grid, pins/tees, highlighted and selected objects, and the background and
foreground of the design windows

e The sizes of pins/tees, the selection pick box, and the size of the marker drawn when you have the Vertices filter
turned on and select the vertices of objects in the drawing area

e The display of the Component Parameters dialog box, coordinate readouts, pin names and numbers, and
pins/tees

When you change the settings in this dialog box and click Apply, the design window is updated with the changes, and
these changes will serve as defaults for all designs in this project. For details on saving changes to a file so that
specific preferences can be associated with specific designs, refer to Saving and Reading Preference Files.
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Specifying Design Entry and Display Preferences

To change design entry and display preferences:

Choose Options > Preferences in any design window.

Click to see additional tabs

= Preferences for Schematic _‘
— |
Select Grid/Snap Placement |  PinfTee | Entry/Edit >
Select
Select Filters Select Mode for Polygons
X Arcs X Polygons _I By edge
X Circles X Polylines @ Inside
¥ Components  Ports Size
- Drawing Format = Text Pick Box Units
X Paths X Vires pli] screen pize |
® Vertices Selected Vert Units
0. 05 schem unit ¢ |
Set All Clear All -
oK Apply Reset Save... Read... Cancel Help

Many options relating to the size of an item displayed on the screen offer a choice of specifying the size in terms of
screen pixels or schem units (or layout units, in the Layout window).

screen pixels—Use this setting to specify sizes in terms of pixels on the screen. For example, if you set 10 screen
pixels for the Pick Box size, the pick region will be 10 pixels by 10 pixels.

schem units—Use this setting to specify sizes in terms of inches, in the Schematic window. In the Layout
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window, select layout units to specify a size with respect to the design units of the Layout window.

Setting Select Options

The Select options can assist you in editing your designs by modifying how items are selected.

Using Selection Filters

Selection filters enable you to specify types of items you want included in or excluded from your selections. For
example, if you turn on only Components and Wires, none of the other types of items in the drawing area will be
available for selection. By default, all types of items are turned on except Drawing Format.

— Select Filters
R Ares = Polygons
K Circles X Polylines

B Components B Poris
-l Drawing Format B Text
M Paths X Wires

¥ Vertices

To change the default settings:

Select the types of items you want available for selection, and deselect the types of items you want excluded
from selection.

Hints:

e Any item type that is turned off will not be selected when you click it individually, attempt to enclose it in a
selection window, or choose the Select All command.

¢ Only the Select By Name and Deselect By Name commands ignore the selection filters.

e To enable most filters, choose Set All to quickly select all filters, then deselect those you want excluded.

e To disable most filters, choose Clear All to quickly deselect all filters, then select those you want included.

Changing the Select Mode for Polygons
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e Choose By Edge to be able to select polygons by clicking on the outer edge.
e Choose Inside if you want to be able to select polygons by clicking anywhere inside the shape.

Changing the Pick Box Size

The pick box is a region you define that determines how close your cross cursor must be to an object before clicking
will select that object. You can choose a size in schem/layout units, relative to the units of the design window, or you
can choose a size in screen pixels.

The following figure shows an example of the region defined by a pick box specified in inches.

Fick Box=0.25
'.-—F'ickreginn
I——Cursur
: 0125
] |------+--
[ " [ " 1 [ 'fi‘IEEI"'I " [

Pick region based on schem Units

In the previous figure, the pick box size was set to 0.25 inch (the same as the default grid display).

When you define the region using n screen pixels, the pick region is a square of n pixels x n pixels, centered around
the spot where you click. For example, if you specify 20, the pick region extends 10 pixels beyond the spot where you
click, horizontally and vertically.

Size

Pick Box Units

|1I] screen pixels IE]
& Hint

It may be necessary to use a very small number in designs where items are tightly spaced.
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Changing the Selected Vertex Size

When the Vertices filter is enabled, and you select a vertex (or vertices), a marker appears identifying each selected
vertex. You can change the size of the marker from the Select tab of the Preferences dialog box.

To change the size of the marker that identifies selected vertices:

1. Choose the desired units from the drop-down Units list box.
2. Change the value as desired.

Changing the Select Color

When objects in the drawing area are selected, a box is drawn around them identifying them as being selected. By
default, this highlight color is black, but you can change it from the Select tab of the Preferences dialog box. This color
is also the color of the marker that identifies selected vertices.

Setting Grid/Snap Options

The display grid and cursor snap features are provided to assist you in creating and editing your designs more quickly
and accurately.

By default, snap mode is turned on and the cursor snaps to pins and to the grid defined by the snap spacing. The
default snap spacing is 0.125 inch (in the Schematic window) with a display factor of 2. This means that although the
cursor snaps every 0.125 inch, the dots only appear every 0.25 inch. If you set the display to anything smaller than
0.25 inch, the grid will be too dense to display without zooming in on it.

& Hint
The default component symbols have been created uniformly, in 0.125-inch increments. Thus, if you keep the
default settings while creating your design, you should be able to connect all symbols with minimal effort.

Display
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) Dots Select Dots or Lines to display a visible grid made up of dots or lines
) Lines

Select None if you want no visible gnd
@ MNone

coior [

Click to access a palette for choosing a grid color

Spacing

e Snap Grid Distance (in schem units) represents the snap spacing, where the number you specify determines the
distance (in design units, or inches) between the points to which the cursor snaps.

snap Grid Distance (in schem units)

X 0.128 ¥ 0128

e Snap Grid per Display Grid represents the spacing between the dots (or lines) on the display grid in terms of a
factor of the snap spacing. The smaller the number, the finer the grid.

3hap Grid per Display Grid
X 2 Yy 2

& Hint
If the display factor you specify makes the grid too dense to display, it is invisible unless you zoom in. To see
the grid without zooming, choose a larger display factor.

e Snap Distance - all other modes represents how close to an object the cursor must be before it will snap to that
object.

3nap Distance - all other modes

Diameter Units

15 screen pize

Active Snap Modes
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This section enables you to restrict the manner in which the cursor snaps. You can activate any combination of
choices. If you select more than one, the cursor snaps to the nearest one. By default, Grid and Pin are turned on to
assist you in quickly creating schematics.

e Enable Snap -Toggles snap mode on and off. You can also toggle snap mode on and off from the Options menu

itself ( Snap Enabled ).

To select all or most snap modes:

Click Set All and then deselect those you want excluded.
To deselect all or most snap modes:

Click Clear All and then select those you want included.

Hint
All snap modes (except Grid) rely on the cursor being within the distance specified as Snap Distance
(Diameter).

Pin -When the pin of an object you are positioning gets within the snap distance of a pin on an existing object,
the pins are automatically connected. Pin snapping takes priority over all other snap modes.

Note

Angle Snapping automatically occurs when only Pin snapping is enabled and you place a part so that the pin at
the cursor connects to an existing part. The placed part rotates so that it properly aligns with the connected
part.

Vertex -When the object you are positioning gets within the snap distance of a vertex on an existing object, the
object you are positioning is automatically placed at that vertex. This snap mode is especially helpful if
something was originally drawn or placed on the grid and then moved off, or the grid spacing has been changed.
Grid -The cursor snaps to points on the grid defined by snap spacing. All other snap modes have priority over
grid snap mode.

& Hint

The Reset button returns settings to their defaults (if you have not yet clicked Apply).

Setting Placement Options

Set the following options-related to placing components in the drawing area-in a manner that suits the way you work:

Defining the Placement Mode for Schematic and Layout Representations

When you are working with both schematic and layout representations, you can select the simultaneous placement
mode that works best for you. For schematic only design work, use the default option, Single Representation.
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e Single Representation (schematic OR layout)
When you place an item in one representation, nothing is placed automatically in the other representation.

e Dual Representation (schematic AND layout)
When you place an item in one representation and move the pointer into the window for the other
representation, the equivalent component is already selected. Position the pointer as desired and click to place it.
(If a window for the other representation-containing the same design-is not open, one will be opened
automatically.)

¢ Always Design Synchronize (schematic AND layout)
Causes the program to fully synchronize both representations after each part is placed, ensuring all parts are
fully interconnected. This takes more time than the Dual Representation mode and may move or rearrange the
layout of the schematic to preserve connectivity.

Displaying the Component Parameter Dialog Box by Default

When you place a component in the drawing area, you can change parameters using the on-screen editor.
Alternatively, you can make changes through the Component Parameter dialog box. By default, in the Schematic
window, the option that controls the automatic display of the component parameter dialog box is turned off. You can
turn this option on if you want the dialog box to be displayed every time you select a component ( Options >
Preferences > Placement ).

e Show Component Parameter Dialog Box
Controls whether or not the Component Parameters dialog box appears every time you select an item to place in

the drawing area.

e Show Component Parameter Dialog Box for components without parameters
Select this option if you want the Component Parameters dialog box to be displayed even for components that do
not have parameters (for example, a design used as a subnetwork for which no parameters have been defined
through File > Design Parameters). By default it is off and the dialog box does not appear.

Setting a Default for Component Swapping

e Keep the original instance name(s) when swapping components
Retains the component ID of the original component when using the Swap Components command. (Tip: this
setting serves as a default; it can be changed for any given operation through the Swap Components dialog
box.)

Setting Pin/Tee Options

You can change several options relating to pins/tees through Options > Preferences > Pin/Tee.

e Pin Size
Enables you to change the size of the pins drawn on all components.
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e Tee Size

Enables you to change the size of the Tee connections between interconnected wires.
e Color

Enables you to specify colors for the items shown here. Click each to display a color palette with the available
selections.

I Connected Pins

Bl Tee
I Node Voltage
P  Fin Current

B Hode NHame

o Visibility
Enables you to change the visibility status of pin humbers and names, and whether or not pin connections are
identified by markers.
Connected Pins -Select this option to display a marker identifying a pin connection. The marker is drawn using
the size specified in the Pin/Tee tab of the Preferences dialog box.
Pin Numbers -Select this option to display pin humbers.
Pin Names -Select this option to display pin names.

Setting Entry/Edit Options

This group of options allows you to control several aspects of shape entry and editing including the angle at which
lines and wires are drawn, the resolution of arcs and circles, and how wires are routed relative to component text.

) Note

Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For
details on saving to a file, see Saving and Reading Preference Files.

e Reroute entire wire attached to moved component
When this option is selected, the wire connection is allowed to be completely redrawn and rerouted as needed.
When this option is deselected, only the segment (up to the first bend) of the wire attached to the component
you are moving is rerouted; the remainder of the wire is unaffected.
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¢ Route around component text
By default, wires are routed through component text. If you want wires routed around component text, select
this option. Note that routing around pins, wire endpoints, and collinear wires takes precedence. If the program
cannot route wires around these items, as well as the component text, it will route wires through the component
text.

e Route around component symbol
By default, wires are routed through component symbols. If you want wires routed around component symbols,
select this option. Note that routing around pins, wire endpoints, and collinear wires takes precedence. If the
program cannot route wires around these items, as well as the component symbols, it will route wires through
the component symbols.

e Polygon Entry Mode: Any angle
Enables you to draw polylines, polygons, and wires using all angles.

e Polygon Entry Mode: 45 degree angle only
Restricts shape entry to 45 degree rotation increments.

e Polygon Entry Mode: 90 degree angle only
Restricts shape entry to horizontal or vertical.

e Show Coordinate Entry Dialog for Insert and Edit commands
Select this option to force the Coordinate Entry dialog box to be displayed when invoking the following
commands:

Insert (Shape)—Polygon, Polyline, Rectangle, Circle, Arc (clockwise and counter-clockwise), Text, Construction
Line, Symbol Pin, Path, Trace.

Edit—Move Wire Endpoint, Mirror X, Mirror Y, Move & Disconnect, Step And Repeat, Set Origin, Move Component
Text.

e Show Set Paste Origin Dialog for Copy Command
Select this option to force the Set Paste Origin dialog box to be displayed when you choose the Copy command.
This dialog box enables you to specify X and Y coordinates to be used as a reference point when pasting.

¢ Polygon self-intersection checking
Prevents you from placing additional points on a polygon if overlapping lines will result.

¢ Maintain adjacent angles for Move Edge command
Restricts the Move Edge command to stretch an edge while maintaining the adjacent angles of the edge being
stretched to other edges adjacent to that edge.

¢ Arc/Circle Resolution (degrees)
This setting determines how smoothly curves are drawn. The length of each line segment making up the arc is
determined by the size of the angle drawn using the specified humber of degrees.
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In general, the smaller the number of degrees, the smoother the shape, but the longer it will take to redraw the
screen.

Note
This setting only affects circles in that the number specified here is used if you convert a circle to a polygon.

Auto-backup edit count

Your file is automatically saved every time the number of edits you have performed reaches the number in this
field.

Undo edit count

This option represents the maximum number of commands held in the stack. Selecting Undo from the Edit menu
or clicking the Undo button on the toolbar undoes the last editing command. A stack of edit commands is
maintained for each window, thus the Undo command works independently from window to window. You can
choose Undo repeatedly to return to an earlier state of your design. You can specify the number of commands
you want the stack to hold using the Undo edit count option.

Rotation Increment (angle)

This option forces objects you rotate to snap-during rotation-in n -degree increments, where n is the number you
specify here.

Rotation Increment (angle) U5

Drag and Move

This option is designed to prevent you from moving an item when you click to select it (for any purpose) and
unintentionally move the pointer in the process. By default, a move less than 10 screen pixels is not recognized
as a move. An intentional move must be more than the distance specified here for it to be recognized as a move.

Drag and Move
[X Drag and Move enabled

Threzhold Units
|1I] screen pixels IE]

Setting Component Text/Wire Label Options (in Advance)

Component text is the text associated with components selected from a Library or Palette. This text appears
automatically when you place the component in the drawing area and consists of a name, a unique ID, and
parameters (where applicable).

There are two ways to change component text attributes:
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¢ In advance of placing components, through the Options menu ( Options > Preferences > Component Text/Wire
Label ). This setting serves as a default, but attributes of component text for an individual component, or all
components, can be changed later through the Edit menu.

e After placing components, through the Edit menu ( Edit > Component > Component Text Attributes ). Refer to
"Changing Component Text Attributes" in the Schematic Capture and Layout manual.

You can specify the following display characteristics of component text: font, point size, maximum numbers of rows
displayed in a single column, precision, and the layer on which each type of text is placed.

e Font Definition
All TrueType fonts installed on your system are available. Select the desired font type from the drop-down list.
When printing to an HP-GL/2 file, text information will not be saved if the font is a TrueType font. To preserve
the text in your output file, convert it to HersheyRomanNarrow before saving to HP-GL/2.

 Note

On UNIX, if you want to add additional TrueType fonts that were not supplied with ADS, copy them to
$HPEESOF_DIR/lib/fonts.

Point represents the size of text in traditional units used in printing.

e Apply To Layer
Each of the three types of component text resides on its own layer. This enables you to quickly change the
appearance of the component text by changing the attributes of a layer, or making a layer invisible. For more
information on changing layer attributes, refer to Specifying Layer Definitions.

Apply To Layer:

Component Mame

| labels j C

Sample of component text for a

capacitar
|hztance Name P

identifiers j C 1

Compornent Parameter

parameters j C — ]_

To change the layer for any given type of component text, click the arrow and select a new layer from the
drop-down list.

e Parameter Rows
Represents the maximum number of rows of component text displayed in one column. Using a relatively small
number here is helpful for large parameter sets so you can view the parameters in several short columns.

e Format
Enables you to abbreviate the displayed annotation on a schematic for Tune, Opt, Stat, and DOE syntax. This is
useful when the standard annotation overlaps on the schematic. The format for Tune, Opt, Stat, and DOE can be
set to one of the following three types:
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° Full displays the standard syntax used in ADS 2004A and before (e.g., 50 Ohm tune{ 25 Ohm to 75 Ohm
by 5 Ohm }).

° Short displays an abbreviated syntax (e.g., 50 Ohm {t}):
{t} for tune and {-t} for notune
{0} for opt and {-0} for noopt
{s} for stat and {-s} for nostat
{d} for doe and {-d} for nodoe

° None only displays the nominal values (e.g., 50 Ohm).

¢ Wire/Pin Label
Enables you to select defaults for the font, point size, and color of wire labels.

Setting Text Options (in Advance)

You can establish text attributes-prior to adding text to your design-that affect all subsequently added text.
Establishing attributes in advance is done through the Options menu. Editing attributes of existing text is done
through the Edit menu.

To establish text attributes:

1. Choose Options > Preferences > Text and set the text attributes as desired.
e Font Type -All TrueType fonts installed on your system are available. Select the desired font from the
drop-down list. When printing to an HP-GL/2 file, text information will not be saved if the font is a TrueType
font. To preserve the text in your output file, convert it to HersheyRomanNarrow before saving to HP-GL/2.

 Note

On UNIX, if you want to add additional TrueType fonts that were not supplied with ADS, copy them to
$HPEESOF_DIR/lib/fonts (where $HPEESOF_DIR represents your complete installation path).

e Point -Represents the size of text in traditional units used in printing.

o Justification, Horizontal -This setting represents two types of justification: one is how individual lines of text
in a block of text are aligned with one another; the second is how an individual line of text or block of text
is positioned horizontally, relative to the reference point you specified to begin typing the text.

e Justification, Vertical -This setting aligns a string or block of text vertically, relative to the reference point
you specified to begin typing the text.

e Placement Angle -The angle at which all text subsequently added to your design will be drawn.

e Non-rotating (when in hierarchy) -Select this option to prevent text on a symbol or design from being
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rotated when the symbol is rotated.
2. Change any or all options as desired and click Apply (or OK if you are not changing any other preferences).

Setting Display Options

The Display tab enables you to change the Foreground, Background, and Highlight colors.

e Foreground
The color of the lines making up polygons, polylines, and arcs while they are being drawn.
e Background
The color of the drawing area background in the design window.
¢ Highlight
The color used to identify problem items (with respect to simulation), orphaned items in schematic and layout
representations, and unconnected pins.
e Fixed Component
The color of fixed components.
e Deactivated Component Text
The color of component text for deactivated components.
e Minimum Object Size To Display (in pixels)
The minimum size—in pixels—an object must be before it is actually drawn in the Schematic window. Objects
smaller than this are not visible.

Setting Units/Scale Options

With the exception of the Resistance setting, the settings in the Units/Scale tab of the Preferences dialog box serve as
defaults only in the following situations:

¢ When a parameter of a supplied component does not have a default unit and you do not assign one (in the
component parameter dialog)

e When you supply a default parameter value without units while creating a parametric subnetwork ( File > Design
Parameters )

The Resistance setting can be changed to serve as a default for all resistors (subsequently) placed in this project.

Setting Tuning Options

The Tuning settings in the Preferences dialog box serve as defaults and can be changed during tuning in the Tune
Control and Tune Control Details dialog boxes.
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Select the Tune Analysis mode that you want to serve as the default:

¢ Analysis Mode
Single—Perform analysis after each change.
Multiple—Perform analysis only after the Tune button is clicked. This is designed for tuning after multiple
changes, but can be used for single changes.
Continuous—Perform analysis while the slider is moving.

Set the Tune State to the desired default:

e Data Displays
Restore data displays—Opens all the data displays that were saved for a design when tuning is launched.

Set the following Slider options to the desired defaults:

e Range Min and Max—Set the minimum and maximum range to the initial parameter value plus or minus the
percent you enter here.

e Step Size—Enter a percentage of the initial parameter value.

¢ Slider Scaling—Choose Linear or Logarithmic.

e Snapping—Choose Snap to Step to increment Linear sliders by Step Size. When OFF, Linear sliders increment
continuously.

Saving and Reading Preference Files

When you create a project, the files schematic.prf (for schematics) and layout.prf (for layouts) are copied to the new
project from the installation directory. By default, all designs in a given project use the preference file by this name.
You can customize these preference files, as well as create additional preference files by other names.

e To use the same set of customized preferences for every design in the project, customize the files with the
default filenames ( schematic.prf and layout.prf ).

e To use a different preference file for any given design in a project, open that design, customize the preferences
as needed, and save them to a preference file with a unique name. To associate this customized preference file
with a another design, open that design, read the customized preference file, and save the design.

You can save any number of files containing customized preferences. Whenever you open a design, the last preference
file associated with it is automatically read.

 Note

When you save a preference file, all the current settings found in the Preferences dialog box are also saved,
with the following exception: Options that may be set differently within individual designs, such as text height,
are not saved in the preference file.
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To customize preferences while retaining the default filenames:

Choose Options > Preferences.

. Change preferences as desired and click OK. The preference files with the default filenames are updated. Every
design in the project will now use these preferences unless you explicitly associate a unique preference file with a
given design.

N =

To create customized preference files with unique filenames:

1. Choose Options > Preferences.

2. Change any desired settings and click Save. The Save Preference File dialog box appears displaying the default
filename, schematic.prf.

3. Enter a name of your choosing (the .prf extension is added automatically) and click OK.

& Hint
If you have a design open when you create a customized preference file, that design will take on the
preferences just saved when you click OK in the Preferences dialog box. However, this association is only in
memory unless you save the design file.

To associate a previously saved preference file with a specific design:

Open that design.

. Choose Options > Preferences and click Read. The Read Preference File dialog box appears.

3. Select the desired preference file from the list of files, and click OK. (You can read in preference files from other
project directories.)

4. Save ( File > Save ) the design.

N

& Hint
The variable that defines the search path for these files is PREFERENCES_PATH. For details refer to
PREFERENCES PATH.

Preference File Format and Descriptions

In a preference file, each preference must be on a separate line and must use the following format:
preference_name value

Preference Name Description
autoRepeatableCompPlcmnt Auto-repeatable component placement
0=0ff
1=0n
backgroundColor Color of background represented as an index into the

eecolorRGB.cfg. It can be any integer in the range of 0,
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to the number of colors defined in eecolorRGB.cfg
backupCount Number of edits before auto-backup of design

bboxColor Color of bounding boxes below the hierarchical plotting
depth represented as an index into the eecolorRGB.cfg.
It can be any integer in the range of 0, to the number of
colors defined in eecolorRGB.cfg

checkBinding Wire/Trace check layer binding (Layout only)
0=0ff
1=0n

checklIntersection Polygon self-intersection checking
0=0ff
1=0n

coordEntryPopup Show Coordinate Entry dialog for Insert and Edit
commands
0=0ff
1=0n

currentColor Color of pin current represented as an index into the
eecolorRGB.cfg. It can be any integer in the range of 0,
to the number of colors defined in eecolorRGB.cfg

dispSubnetInstNames Display instance names of components in
subnetworks (Layout only)
0=0ff
1=0n

dragMove Drag and Move enabled
0=0ff
1=0n

dragMoveThresholdSize Drag and Move threshold size

dragMoveThresholdUnits Drag and Move threshold units
0=User units
1=Screen pixels

DSEartDistanceX Connecting wire length in X direction in layout units for
Generate/Update Layout

DSEartDistanceY Connecting wire length in Y direction in layout units for
Generate/Update Layout

dseFixAllComponents Default value for fixing all components in destination
Schematic or Layout
0=0ff
1=0n
DSEL2Sreport Show status report from Generate/Update Schematic
dsePrefLayoutLayer Entry layer name for Generate/Update Layout command

60



DSES2Lreport

DSEsymbDistanceX

DSEsymbDistanceY

dualPlacement

dveBinWidth
dveEpsilon
dveFringe
dveRealMemory

dveSortMode

dveStoragePerArea

editInPlaceBoxColor

entryMode

fixedInstHighlightColor

forceSynchronize

foregroundColor

genericArtworkSize

genericSizeUnits

globalArcResolution
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Show status report from Generate/Update Layout

Connecting wire length in X direction in schematic units

for Generate/Update Schematic

Connecting wire length in Y direction in schematic units

for Generate/Update Schematic

Control of simultaneous placement of components in
Layout and Schematic

0=Single representation

1=Dual representation

2=Always Design Synchronize

Verification bin width
Verification epsilon
Verification fringe
Verification memory in MB

Verification sort GEM layers
0=0ff
1=0n

Verification memory storage per area in bytes

Color of Edit In Place box represented as an index
into the eecolorRGB.cfg. It can be any integer in the
range of 0, to the number of colors defined in
eecolorRGB.cfg

Polygon entry mode
0=Any angle

1=45 degree angle only
2=90 degree angle only

Color of fixed components represented as an index into
the eecolorRGB.cfg. It can be any integer in the range of

0, to the number of colors defined in eecolorRGB.cfg

Delete equivalent components in destination

Schematic or Layout that have been deleted/deactivated

in source Schematic or Layout

Color of foreground represented as an index into the

eecolorRGB.cfg. It can be any integer in the range of 0,

to the number of colors defined in eecolorRGB.cfg

Generic artwork size for Generate/Update Layout
command (Layout only)

Generic artwork size units for Generate/Update Layout

command (Layout only)

Resolution of arcs in degrees
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gridColor

gridDisplayMode

gridDisplayOn

gridDisplaySameXY

gridDisplayX
gridDisplayY
gridSnapMode

gridSnapOn

gridSnapX
gridSnapY
highlightColor

instanceRotate

instIDLayer

instNamelLayer

instParamlLayer

instTextDoeFormat
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Color of grid dots/lines represented as an index into the
eecolorRGB.cfg. It can be any integer in the range of 0,
to the number of colors defined in eecolorRGB.cfg

Grid display type
0=Dots
1=Lines

Snap grid display
0=0ff
1=0n

Automatically set Y=X when any X value is modified in
Preferences>Grid/Snap>Spacing dialog box

Snap grid per display grid along X axis
Snap grid per display grid along Y axis

Bitwise value of items to be snapped to
1=Grid

2=Pin

4=Vertex

8=Edge

16=Midpoint

32=Arc center

64=Intersection

Enable snap
0=0ff
1=0n

Snap grid distance along X axis in user units
Snap grid distance along Y axis in user units

Color of highlighted objects represented as an index
into the eecolorRGB.cfg. It can be any integer in the
range of 0, to the number of colors defined in
eecolorRGB.cfg

Auto-rotate components being placed (only in layout)
0=Do not auto-rotate
1=Auto-rotate

Layer number used for component text instance name
(e.g. C1)

Layer number used for component text name (e.g. C)

Layer number used for component text parameters
(Schematic only)

Component text format for doe syntax
where
O0=Full
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1=Short
2=None

instTextFontName Component text placed in design will use the font given
here

instTextOptFormat Component text format for opt syntax
where
O=Full
1=Short
2=None

instTextPoint Component text size in points

instTextRows Number of rows of component text displayed in one
column

instTextStatFormat Component text format for stat syntax
where
O=Full
1=Short
2=None

instTextTuneFormat Component text format for tune syntax
where
O=Full
1=Short
2=None

layoutIncr Layout increment is a multiplier against the precision.
An increment of 2 and precision of -3 would make the
conversion factor .001*2 = .002. In practice, an
increment other than 1 is rarely used. Note: This
preference is not used when a design is opened.

layoutPrec Layout precision is an integer representing the
conversion of user units to data base units. It is the
power of 10 used to multiply against a data base unit to
get a user unit.
e.g., prec -3 = 10 -3 or .001 If db unit = 1000,
then 1000*.001=1 user unit
Note: This preference is not used when a design is
opened.

layoutUnits Layout unit

where
1=mil

2=in

3=um
4=mm
5=cm
6=meter
7=ft
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maintainAngle

majorGridDisplayOn

majorGridDisplayX

majorGridDisplayY

minPixelDisplaySize

minVertexDistance

miterVertexLength

moveVertexKeepRect

newRouteAroundInstSym

newRouteAroundInstText

nodeNameColor

onscreenCoordMode

oversize

oversizeMiter

pathBend
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Note: This preference is not used when a design is
opened.

Maintain adjacent angles for Move Edge command
0=0ff
1=0n

Major snap grid display (Layout only)
0=0ff
1=0n

Minor grid per major display grid along X axis
(Layout only)

Minor grid per major display grid along Y axis
(Layout only)

Minimum object size to display in pixels

Final minimum vertex distance for Merge/Boolean
Logical/Create Clearance in Layout units (Layout only)

Desired length of the mitered edge in user units

Drag rectangle vertex maintains rectangularity
0=0ff
1=0n

Wire avoidance routing around component symbol
(Schematic only)

Wire avoidance routing around component text
(Schematic only)

Color of node names represented as an index into the
eecolorRGB.cfg. It can be any integer in the range of 0,
to the number of colors defined in eecolorRGB.cfg

On-screen coordinate display at cursor (Layout only)
0=None

1=Absolute

2=Relative

Default value in user units which the oversize
command will use

Cutoff angle for mitering corners. Any angle of a
polygon smaller than the specified cutoff angle is
mitered. The default cutoff angle is 45 degrees.

Bend type of paths and traces
where

1=Mitered

2=Square

3=Curved
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pathMiterPercent

pathRadius
pathWidth

pinColor

pinSize

pinSizeUnits

pinSnapSize

pinSnapUnits

placePopUp

placePopupOnZeroParm

plotDepthForLessThanMinPixels

plotLessThanMinPixels

plotPinNames

plotPinNumbers

plotPins

plottingDepth

portColor

portOrientation
portSize

portSizeUnits
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Mitered corner cutoff ratio of mitered paths or traces
in percent

Curve radius of curved paths or traces in user units
Width of paths and traces in user units

Color of component pins represented as an index into
the eecolorRGB.cfg. It can be any integer in the range of
0, to the number of colors defined in eecolorRGB.cfg

Size of pins

0=User units
1=Screen pixels

Snap distance for all modes except grid

Snap distance units
0=User units
1=Screen pixels

Show component parameter dialog box during
placement

Show component parameter dialog box for
components without parameters during placement

Maximum hierarchical depth at which to draw box for
objects smaller than minimum object size

Display box for objects smaller than minimum object
size

Plot pin names next to component pins
0=0ff
1=0n

Plot pin numbers next to component pins
0=0ff
1=0n

Plot component pins
0=0ff
1=0n

Hierarchical plotting depth

Color of Symbol pins represented as an index into the
eecolorRGB.cfg. It can be any integer in the range of 0,
to the number of colors defined in eecolorRGB.cfg

Default value of Symbol Pin angle
Port/Ground size (Layout only)

Port/Ground size units (Layout only)
0=User units
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rerouteTraces

rerouteWires

rotationIncrement
scaleX
scaleY

schemIncr

schemPrec

schemUnits

selectBoxSize

selectBoxUnits

selectColor

selectFilter
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1=Screen pixels

Reroute entire trace attached to moved component
(Layout only)

0=0ff

1=0n

Reroute entire wire attached to moved component
0=0ff
1=0n

Rotation increment in degrees
Default value of scale command in X direction
Default value of scale command in Y direction

Schematic increment is a multiplier against the
precision. An increment of 2 and precision of -3 would
make the conversion factor .001*2 = .002. In practice,
an increment other than 1 is rarely used. Note: This
preference is not used when a design is opened.

Schematic precision is an integer representing the
conversion of user units to data base units. It is the
power of 10 used to multiply against a data base unit to
get a user unit.

e.g., prec -3 = 10 -3 or .001 If db unit = 1000,

then 1000*.001=1 user unit

Note: This preference is not used when a design is
opened.

Schematic unit
where

1=mil

2=in

3=um

4=mm

5=cm
6=meter

7=ft

Note: This preference is not used when a design is
opened.

Size of cursor select pick box

0=User units
1=Screen pixels

Color of selected objects represented as an index into
the eecolorRGB.cfg. It can be any integer in the range of
0, to the number of colors defined in eecolorRGB.cfg

Bitwise value of selectable items
0=None
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1=Components
2=Wires

4=Polygons
8=Polylines

16=Paths

32=Text

64=Arcs

128=Circles

256=Port Components
512=Drawing Formats
1024=Vertices
8192=Traces

selectMode Select mode for polygons
0=By edge
1=Inside
selectPointSize Size of selected vertex
selectPointUnits 0=User units

1=Screen pixels

setPasteOriginPopup Show Set Paste Origin dialog for Copy command
0=0ff
1=0n
showConnectedLay Show Connected Components in Layout
0=0ff
1=0n
showConnectedSchem Show Connected Components in Schematic
0=0ff
1=0n
showFixedLay Show Fixed Components in Layout
0=0ff
1=0n
showFixedSchem Show Fixed Components in Schematic
0=0ff
1=0n
stepRepeatConnect Automatically connect the pins of Step And Repeat
items with one another
0=0ff
1=0n
stepRepeatNumCols Number of columns for Step And Repeat command
stepRepeatNumRows Number of rows for Step And Repeat command
stepRepeatXspace X spacing between columns in user units for Step and

Repeat command

stepRepeatYspace Y spacing between rows in user units for Step and
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swapKeeplInstName

tapLength

teeColor

teeSize

teeSizeUnits

textAbsolute

textAngle
textFontName

textJustification

textOrigin

textPoint
toArcRadius

traceSimMode

traceTech

traceTraverse
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Repeat command

Default value for keeping the original instance name for
Swap Components command

0=0ff

1=0n

Length of tee element for Tap Transmission Line
command in user units

Color of tees represented as an index into the
eecolorRGB.cfg. It can be any integer in the range of 0,
to the number of colors defined in eecolorRGB.cfg

Size of tees

O=User units
1=Screen pixels

O=text will rotate when in hierarchy
1=text will not rotate when in hierarchy

Angle of text placed in design in degrees
Text placed in design will use the font given here

Justification for text placed in design
9=Left Bottom (default)

10=Left Middle

12=Left Top

17=Center Bottom

18=Center Middle

20=Center Top

33=Right Bottom

34=Right Middle

36=Right Top

Display text origin marker (Layout only)
0=0ff
1=0n

Text size in points
Radius of arc in user units for Vertex to Arc command

Type to convert trace to
O0=Transmission line elements
1=Single Transmission line elements
2=Nodal Connection (short)

Element set used during trace conversion
0=Microstrip

1=Strip line

2=Printed circuit board

Insert Tee and Cross components during trace
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conversion
0=0ff
1=0n

tuneRange Tune dialog slider range as a percentage plus or
minus of the value (Schematic only)

tuneScale Tune dialog slider scaling
O=Linear
1=Logarithmic

tuneSimMode Tune analysis mode (Schematic only)
0=Single-after each change
1=Multiple-after one or more changes
2=Continuous-while slider is moving

tuneSnap Tune dialog slider snap to step
0=0ff
1=0n
tuneStepSize Tune dialog slider step size as a percentage of the value

(Schematic only)
undoEditCount Maximum number of commands held in the undo stack

unitsAng Default scale factor for angle parameters
0=deg
1=rad

unitsCap Default scale factor for capacitance parameters
0=fF
1=pF
2=nF
3=uF
4=mF
5=F

unitsCond Default scale factor for conductance parameters
0=pS
1=nS
2=uS
3=mS
4=S

unitsCur Default scale factor for current parameters

0=fA

1=pA
2=nA
3=uA
4=mA
5=A

6=kA

unitsDist Default scale factor for distance parameters
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O=meter
1=km
2=ft
3=mi
4=nmi

unitsFreq Default scale factor for frequency parameters
0=Hz
1=kHz
2=MHz
3=GHz
4=THz

unitsind Default scale factor for inductance parameters
0=fH
1=pH
2=nH
3=uH
4=mH
5=H

unitsLng Default scale factor for length parameters

O=um

1=mm

2=cm

3=meter

4=mil

5=in

6=ft

unitsPower Default scale factor for power parameters

0=pW

1=nW

2=uW

3=mW

4=W

5=kW

6=dBm

7=dBW

unitsRes Default scale factor for resistance parameters
0=mOhm
1=0hm
2=kOhm
3=MOhm
4=GOhm
5=TOhm

unitsTime Default scale factor for time parameters
0=fsec
1=psec
2=nsec
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3=usec
4=msec
5=sec

unitsVolt Default scale factor for voltage parameters

0=fV

1=pV
2=nV
3=uV
4=mV
5=V

6=kV

voltageColor Color of node voltage represented as an index into the
eecolorRGB.cfg. It can be any integer in the range of 0,
to the number of colors defined in eecolorRGB.cfg

windowLLX Default X coordinate of lower left corner of design
area in user units

windowlLLY Default Y coordinate of lower left corner of design
area in user units

windowURX Default X coordinate of upper right corner of design
area in user units

windowURY Default Y coordinate of upper right corner of design
area in user units

wireLabelColor Color of wire labels represented as an index into the
eecolorRGB.cfg. It can be any integer in the range of 0,
to the number of colors defined in eecolorRGB.cfg

wireLabelFontName Wire label will use the font given here

wireLabelPoint Wire label size in points

Specifying Layer Definitions

All shapes and text are entered on layers. By placing various groups of items on different layers, each of which may
be assigned different characteristics, you can customize and easily alter the overall visual effect of the design in the
viewing area. To access the Layer Editor, select Edit from the Layers window or select Options > Layers. The Layer
Editor enables you to:

¢ Change display characteristics on a layer-by-layer basis

e Define new layers

¢ Change the plotting priority of layers (Layout window)

e Turn the display of items on and off on any specified layer. For example, you can turn on and off the display of
any or all the parts making up component text-Name (labels), ID (identifiers), Parameters (parameters).

e Protect items on any given layer from being selected, that is, when clicking in the drawing area to select items,
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those items on a protected layer cannot be selected as you edit your design. This is helpful when you have a lot
of editing to do on certain kinds of items, but not others, in a crowded design.

e Save the layer definitions to the default schematic.lay file or to a unique filename.lay file
At any time during the modification of layer definitions, if you have not yet clicked Apply, you can click Reset to
return to the previous settings.

& Note

The layer number-not the name-is the common identifier used in both the design file and the layer file, and
should not be changed.

The order in which layers are plotted is determined differently in the Schematic window than it is in the Layout
window.

e In the Schematic window, layers are plotted in numerical sequence-based on the layer number-beginning with
zero and ending with the highest number. You can rearrange layers in the list for your convenience, but it will
have no effect on the plotting order.

¢ In the Layout window, the position of the layers in the list, relative to each other, indicates their priority when
plotted. Higher priority layers are plotted on top of lower priority layers-the lower in the list, the higher the
priority.

The following figure shows the list of default defined layers. These are the default layers in the Schematic window; for
details on layers in the Layout window, refer to Defining Layers.

. D Hame
: o Hefault
1 beer_symbody
i Jser symtxt
i3 ser aymhol
2! wire
g textl
[ Aabels
M Hdentifiers
i parameters
; e pin_rom

 Important
Be sure to use compatible layer definitions for related designs, especially designs that are related
hierarchically.
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To move a layer within the layer list:

1. Click once to highlight the layer ID or Name.
2. Click Cut. The name and number disappear from the list.
3. Highlight the layer you want to paste the cut layer above, click Paste and click Apply.

To delete a layer:

 Note

Do not delete the supplied, default layer definitions; the ability to delete is provided to enable you to redefine
layer definitions you have created. Deleting supplied layer definitions will degrade the appearance of your
schematic, as parts whose layer has been deleted will now be drawn on the default layer.

1. Click once to highlight the layer ID or Name.
2. Click Cut. The name and number are deleted from the list, and that number is now available for a new layer.
(Hint: If you change your mind, use Paste to add the layer back.)

To change a layer's name:

1. Click in the Name field and change the name as desired.
2. Click Apply.

To add a layer:

1. Click New from the group of buttons labeled Layer.
Layer
Mew Cut | Paste

The layer list scrolls to the bottom and a new layer is added. The layer humber is the next available, sequential
number, and a default name appears that includes the layer number.

2k layer 24

2. Rename the layer as desired and click Apply.

Setting Colors and Fill Patterns

The Color/Pattern columns of the Layer Editor dialog box enable you to choose colors and fill patterns of items, on a
layer-by-layer basis.

Color/Pattern

CJoEe
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To change color and/or pattern settings for any given layer:

1. Click to access the available colors or patterns (PC-click the arrow for the drop-down list; UNIX-click the color bar
itself) from the color or pattern box of the layer you want to modify.

2. Click the desired color or pattern (UNIX-click OK ).

3. The new color is displayed in the Layer Editor dialog box. To see the change in the drawing area, click Apply.

 Note

When choosing Fill Patterns, keep in mind that the patterns produced by a Postscript printer are Postscript fill
patterns and will vary somewhat from those on your screen.

Setting Shape Display Characteristics Layer-by-Layer

All shapes are drawn with one of the following display types:

e Both (both an outline and a fill pattern)
e Outline (an outline with no fill pattern)
o Filled (a fill pattern with no outline)

The following illustration shows the shape display Both, where you see both the fill pattern and the outline.

Fill pattern

Cutline

The Shape Display drop-down list for each layer enables you to choose the shape display of items, on a layer-by-layer
basis.

Shape Dizplay

||:Iut|ine _ﬂ

& Hint
For details on changing the shape display globally for all layers, refer to Setting Layer Characteristics Globally.

Setting Line Style Characteristics Layer-by-Layer

When you include the Outline of shapes as part of Shape Display on ay given layer, you can also choose a line style
for that outline. Click to select a different line style from the drop-down list.

74




Advanced Design System 2008

Line Style

|5 alid |

& Hint
For details on changing the line style globally for all layers, refer to Setting Layer Characteristics Globally.

Setting the Visibility of Items Layer-by-Layer

The Vis (visible) column enables you to turn on and off the display of items on any given layer. For example, if you
want to print or plot your schematic without component annotation, you could make the labels, identifiers, and

parameters layers invisible. By default, all layers are visible.

& Hint

For details on changing the visibility globally for all layers, refer to Setting Layer Characteristics Globally.

Setting the Selection Status of Items Layer-by-Layer

If you need to edit certain types of items (that reside on a given layer) and not others (that reside on other layers),
and the selection filters do not meet your needs, you can prevent items from being selected by disabling the Sel

(select) option for any layers as needed.
Sel

v
3

]
When you disable the select status for any given layer, items on that layer will not be selected as you edit your

design.

& Hint
For details on changing the shape display globally for all layers, refer to Setting Layer Characteristics Globally.

Setting Layer Characteristics Globally
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This section of the Layer Editor dialog box enables you to change the Selection, Visibility, Shape Display, and Line
Style status of all layers at once. For example, if you want to prevent selection on all layers except one or two of

them, use Select None, then select the individual layers you want access to, and turn on the Select status for those
layers.

Select Wizible Shape Dizplay Line Style

Al | None | Al | None ! =l =

Miscellaneous Layer Editor Features

e The Ins (insert) column enables you to change the current entry layer while working in the Layer Editor dialog
box so that you can quickly see the effect of your changes.
e The Reverse button toggles the display of the layer list top-to-bottom, or vice versa.

¢ The Visibility tab enables you to reduce the size of the Layer Editor dialog box while keeping the most commonly
used features of it available for editing.

Saving and Reading Layer Files

The default layer definitions are contained in the files schematic.lay (for schematics) and layout.lay (for layouts).
These files are read automatically-from the installation directory-every time you open a design, unless you have
explicitly associated another layer file with that design. To associate a customized layer file with a specific design,
open the design, read the customized layer file, and save the design. Whenever you open a design, the last layer file
associated with it is automatically read.

You can create any number of files containing customized layer definitions, and subsequently read in any of these files
for any design.

To save customized layer files:

1. Make all the desired changes in the Layer Editor dialog box and click Save. The Save Layer File dialog box
appears, displaying the default filename, schematic.lay.

2. To use the default filename for the current settings, click OK.
For another layer file, enter a name of your choosing (the .lay extension is added automatically) and click OK.

To read in a previously saved layer file:

1. Click Read from the Layer Editor dialog box. The Read Layer File dialog box appears.

2. Select the desired file from the list of files, and click OK. (You can read in layer files from other project
directories.)
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& Hint

The variable that defines the search path for these files is LAYERS PATH.

Changing the Current Entry Layer

To change layers:

1. Choose Insert > Entry Layer and the Layers window appears listing all the currently defined layers.

Layers Options Help

Current entry layer

|wire
Sel YWie Laperz

[defaul
[user_symbal
fwire
feat
|labets

[parameters
[pinum
frotes

e
Me | av | wv | Edi. |

£ B B3 B3 B4 Bd Bt Bt Bt B

1

45

I:hipu:ap Schematic)

2. Click a layer that is appropriate for the task at hand.
3. Click OK. Anything you draw now is drawn on this layer. The name of the layer is displayed in the status panel of
the Schematic window. See Using the Layers Window for more information.

Customizing Keyboard Shortcuts

You can redefine default keyboard shortcuts as well as create new ones. These shortcuts are maintained individually
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for the different ADS windows.
To change or add a keyboard shortcut:

1. Choose Tools > Hot Key/Toolbar Configuration and click the Hot Key tab in the dialog box that appears.

2. Select the menu name or menu/command sequence from the Category list box.

3. Select the command from the Item list box. If a shortcut currently exists for the item, the current assignment is
displayed.

Editt
Undo |

Undo Last Command
Current Hot Key: Cirs7Z

4. Select the modifier key(s)-Ctrl, Alt, Shift-and type the letter(s) you want to use in the Key field (UNIX is
case-sensitive; the PC is not). If the combination you choose is currently assigned to another command
sequence, you are warned and given the choice to proceed or to select another key sequence.

 Note

If you use Alt as the modifier key, and a letter that is already assigned as an accelerator for a menu (see the
underscored letters on the menu bar), the menu accelerator is replaced by your custom shortcut (with no
warning).

5. To replace the assignment with your own choice, continue, otherwise choose a new key combination and click
Apply. When you are through making all keyboard changes, click OK to dismiss the dialog box.

Configuring Toolbars

By default, the toolbar in each design window contains:

A drop-down list for selecting the group of components you want to place on the palette (Palette List)
A dynamically updated list of components you have placed in that window (Component History)

In the Layout window, a drop-down list for selecting a different entry layer (Entry Layer List)

A button for choosing the orientation of the component you are about to place

Buttons representing frequently used commands

You can reconfigure these default toolbars and create your own to better meet your design needs ( Tools > Hot
Key/Toolbar Configuration ).

Customizing an Existing Toolbar
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To reconfigure an existing toolbar:

1. Choose Tools > Hot Key/Toolbar Configuration and click the Toolbar tab in the dialog box that appears.
2. In the Toolbar Group list box, select the name of the toolbar you want to change.

Toolbar Group

defaultl
default]
To display the selected toolbar, select the Display Toolbar check box. Unselecting the Display Toolbar check box

will hide the toolbar.

To change the display order, click the Up or Down buttons to move the selected toolbar.
5. To add or delete icons, use one of the following methods:

e To delete an icon from the toolbar, select the associated command in the Tool Item list box, and click the

Cut button.
Tool Item T ool Item
Zoom Dut x2 + Zoom Out x2 +

Zoom In Point

Zoom In Point
Zoom Window

Zoom Window

Select the View All N
View All eommand ||

______ + Text +
« ] [+ «| | >

Click the Cut button

e To add an icon to the toolbar, select the appropriate menu/command sequence from the Menu Category list

box, select the command from the Menu Item list box, and click the Add button. The command is added to
the Tool Item list box.

Menu Category

Edit\Pointk +
Edits\Modify
Selecth Menu ltem
Yiew All +
View''Zoom By Facly i Pan Yiew I
Il']anill“—la“-“‘t
* + Zoom Window ;ﬂul "T]m >
Zoom In Point oom Dut x. s
- +| |Zoom In Point
- I - Zoom Window L

Redraw View
Yiew All —

When you select acommand, its default

bitmap is displayed @
& Hint

When you add a button to the toolbar, its position relative to the other buttons is determined by its position in
the Tool Item list box. Before you click the Add button, be sure to highlight the command that the new

command should follow. In this example, Zoom In Point was highlighted before the Add button was clicked so
that Redraw View would take the place of Pan View (deleted in the previous example).
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6. If you want to edit another toolbar, click Apply to effect these changes and begin the process again. When you
are through making changes to the toolbars, click OK.

Creating a New Toolbar

To create a custom toolbar:

1. Choose Tools > Hot Key/Toolbar Configuration and click the Toolbar tab in the dialog box that appears.

& Hint
The position of the new toolbar, relative to the position of any existing toolbars, is determined by its position in
the Toolbar Group list box; the new name is added below the name that is highlighted when you click the Add

button. For example, if you keep both default toolbars and want to add a third one below them, highlight the
bottom one before you click the Add button.

2. Supply a name in the Toolbar Name field and click Add.

Toolbar Hame
my_toolbar

[ Add | Cut

The name you supply is added to the Toolbar Group list box.

Toolbar Group
defaulti
defaultl

my toolbar

3. Select the desired Menu Category, select the desired Menu Item and click Add. The command name is added to
the Tool Item list box.

Menu Category

E dit\H ovel +
EEII“E:? ;_PEHE? Menu Item
E ditAT exth Hotate
E d:t\,ltg:ﬁ Mirror About X
i cize ¥ [Mirror About Y Tool ltem
"i ] -+ Mirror About ¥

4. When you are through making changes to this toolbar, click Apply to effect the changes.
5. When you are through making changes to all toolbars, click OK.

Creating a Custom Component Palette
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Creating a custom component palette can speed up the design creation process by grouping frequently used items in
one or more palettes.

To create a custom palette:

1. Choose Tools > Component Palette Configuration to display the Create Component Palette dialog box.

& Hint
By default, the components currently listed in Component History are listed for inclusion in the new palette. If
this list does not represent a significant number of components you want to include on the new palette, use
the Clear Component History command (View > Component > Clear Component History) to avoid individually
selecting and cutting components from the custom list.
2. Cut any components from the New Palette Group Components list box, as necessary.
3. Select a palette, from the List of Palette Groups, that contains components you want in the custom palette.
4. Select the desired component, from the Palette Group Components list box, and click Add.
5. Repeat as needed to include additional components from any palette.
6. Provide a name for the new palette in the New Palette Group Description field then click OK. This is the name

that will appear in the drop-down Palette List enabling you to place the custom group on the palette.

Customizing a Component

Custom component palettes are defined by the de_define_palette_group() function in the userpalette.ael file located
in your $HOME\hpeesof\de\ael directory.

To customize a component in the palette, for example to change the name of a component label, edit the
userpalette.ael file. Refer to the de_define_palette_group function.

Adding Custom Symbols

To add your own custom symbols to a custom component palette:

Create a directory named bitmaps under the $HOME\hpeesof\circuit directory.

2. Create a bitmap image of the symbol and save it as BMP_ SymbolName .bmp in the bitmaps directory, where

SymbolName is the unique name of your symbol.
Edit the userpalette.ael file. Refer to the de_define_palette_group function.

Deleting Custom Component Palettes

81




Advanced Design System 2008

You can either delete all or individual custom component palettes.

¢ To delete all custom component palettes, delete the userpalette.ael file located in your $HOME\hpeesof\de\ael
directory.

e To delete an individual custom component palette, open the userpalette.ael file located in your
$HOME\hpeesof\de\ael directory, then delete the de_define_palette_group() function that defines the palette.

Turning On/Off the Coordinate Readout Display

There are two types of coordinate readouts, positional and differential.

e Positional-the X,Y coordinates of the cursor position in relation to the total window. By default, the lower left
corner is 0,0. This display also reflects the current precision setting (in this example, 1,000).

o Differential-the distance in X,Y the cursor has traveled since the last click. Set the starting point to 0,0 by
clicking the left mouse button anywhere in the drawing area.

The X,Y coordinate readouts are displayed in the status bar of each window. By default, Positional readouts are turned
on in every window.

Positional 4.375, 4.000 1.125,0.500 Differertial

You can turn the coordinate readout on or off from the View menu.

Setting Layout Options

This chapter provides details for setting layout options so that you can create a layout in an environment that is
compatible with your design. Layout is shipped with preset options that can be modified on a project- or system-wide
basis. Before you begin a layout, be sure that the environment is appropriate for the design, the program options, and
the final output required.

Defining Layers

All shapes and text are entered on layers. Layout allows you to define any humber of mask layers in a file, and to
create any number of mask layer files. Each layer must have a unique name and number. Mask layers usually
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correspond to the masks used in manufacturing a layout. However, mask layers can be used for a number of other
purposes.

Often a single process mask layer is represented by a number of layers in a CAD program. For example, power and
ground lines are often placed on the same mask for manufacturing, but on a different mask for CAD layout to
distinguish them. Further, simple text notes and annotation can be placed on layers that are not output for
manufacturing at all.

The program provides a default set of layer definitions, but you can define and save your own layer sets. (See Saving
a Layout Setup.) Using a standard set of layer definitions saves time because you do not have to define the layers
each time you create a design. Note that it is important that hierarchically related designs use the same layer
definitions. (See Using an Existing Layout Setup.)

Layer definitions are modified through the Layer Editor. To display the Layer Editor, choose Options > Layers or select
Edit from the Layout window.

[X Layer Editor:2
Basic \l At:lvan[:ed\l

" D I Hame | Color/Pattern Ins Sel Vis Shape Display Line Style Reverse I

b [[Eefauit ® & Outine ‘| Solid .

j 4 [kond ® & Outine | Solid 0
2 |ond? ® & Outline ‘| Solid 0
B |kesi ® & Outine | Solid .
2 [Hiel ® &  Filled | Solid ’
A2 |diel2 ® &  Filled | Solid ’
5 |hole ® K Filled | Solid .
% |bond ® &  Filled | Solid ’
f |eymbol ® &  Filled | Solid ’

B et ® &  Filled | Solid 0

Select Visible Shape Display Line Style Layer

(HII | Hone| (.ﬁll | Mone| | «| (New' cut | Paste

Search For Layer: Messages:

f |
oK | Apply | Reset Save... Read... Cancel Help
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Setting Layer Characteristics Globally

You can set attributes layer-by-layer or you can use Global Attributes Control to set the following attributes on all
layers at once:

Protection (against selection) of items on layers
Visibility of items on layers

How shapes are displayed

The style of lines used

The buttons in this area of the Layer Editor dialog enable you to change at once the layer protection and visibility
status, how shapes are displayed, and the line style used for all layers. This can be easier than making the same
change layer-by-layer. It can also be faster to set an attribute the same for all layers, and then individually change
that attribute on the few layers that are an exception. If you want to prevent selection on all layers except one or two
of them, use Select None, then select the individual layers you want access to, and turn on the Select status for those
layers.

Miscellaneous Layer Editor Features

e The Ins (insert) column enables you to change the current entry layer while working in the Layer Editor dialog
box so that you can quickly see the effect of your changes.

e The Reverse button toggles the display of the layer list top-to-bottom, or vice versa.

e The Visibility tab enables you to reduce the size of the Layer Editor dialog box while keeping the most commonly
used features of it available for editing.

The Default Layer

Every layer set contains a default layer. If you end up with a shape whose layer number does not exist in the current
layer set, the attributes of the default layer are assigned to the shape. For example, if you create a shape on a layer
and then you delete that layer definition from the Layers list, the shape appears with the characteristics of the default
layer. You cannot delete or change the name or number of the default layer, but you can modify all other attributes.

Determining the Layer for an Item

To determine the layer for a specific item:

e Select the item and choose Tools > Info.
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= Information

Design: untitled?, type: FAnalog/RF Metwork, modified
Location: untitled?

Layout representation
Layout Unit: mil. DB unit to Layout Unit: 10000,0
Bounding box: -320,0000, -57,5000, -220,0000, 17.5
Layers file: Aa'new/wlv/chico/dd/pubz/uzers/rnehro
Preference file: mil_layout.prf

oK Refresh Print Help

Changing Layer Priority

Layer priority is determined by a layer's position in the layer list. In the Layout window, layers are drawn from lowest
priority (at the top of the list) to highest priority (at the bottom of the list); higher priority layers are drawn on top of

lower priority layers.
To change a layer's priority, change the position of that layer in the list:

In the Layers list, choose a layer name or ID.

Click Cut. The name and number are deleted from the Layers list.
Highlight the layer name that will follow the moved layer.

Click Paste to add the layer above the highlighted layer.

il

To add a layer:

1. Click New.
2. The layer list scrolls to the bottom and a new layer is added. The layer number is the next available, sequential

number, and a default name appears that includes the layer number.
3. Rename the layer, if you want, and click Apply.

To delete a layer:

1. In the Layers list area, select a layer name or ID.
2. Click Cut. The name and number are deleted from the Layers list.

85



Advanced Design System 2008

 Note

Do not delete the default layer definitions. The ability to delete is provided to enable you to redefine layer
definitions you have created.

Changing the Entry Layer

The name of the current entry layer is displayed in the status panel at the bottom of the window, in the toolbar at the
top of the window, and in the Entry Layer dialog. Anything you draw is drawn on the layer you set.

To set the current entry layer, choose one:

e Choose Insert > Entry Layer. Select a layer from the entry layer list. See Using the Layers Window for more
information.

e Choose Options > Layers. Select the layer from the layer editor list.

e Choose Insert > Change Entry Layer To. Click the object whose layer you wish to make current.

e Click the entry layer drop-down in the toolbar. Choose the layer from the list.

Using the Layers Window

The Layers window opens automatically when a Layout window is opened, but can also be accessed by selecting Insert
> Entry Layer. The Layers window enables you to choose the design layer for each shape, set the visibility or
selectability of any layer, and access the Layer Editor dialog.

86



Advanced Design System 2008

& Layers [_ O]

Lavers Options Help

Current entry layer

|wire

Sel Vis  Lavers

v W [detait [ © Al
v @ [usecsymbody [T

v @ [useComt [T

<
<
B
3

W v lert |

frest
[labels |
[parameters
[pi_rum
[rotes

HEAA

3
<]

< < < < <
< < <A KF

1

A5

L:hipu:ap [Schematic)

To access the Layer Editor dialog, select Layers > Edit Layers... or click the Edit... button near the bottom of the
window. See Defining Layers for information on the Layer Editor dialog.

The Options menu enables you to select the following:

¢ Open With Layout Window—If selected, the Layers window always opens with the layout window unless the
Layers window is already open. This menu item is selected by default.

e Open With Schematic Window—If selected, the Layers window always opens with a schematic window unless the
Layers window is already open. This menu item is deselected by default.

e Auto Redraw Design Window—If selected, refreshes the current layout or schematic window each time the
visibility or selectability of any layer is changed within the Layers window. This menu item is selected by default.

The Current entry layer field displays the name, fill pattern, and color of the current design entry layer. In addition,
the current design entry layer is highlighted in the Layers list. To choose a current entry layer, click a layer's name or
fill pattern from the Layers list.

The Layers list displays the selectability status, visibility status, name, fill pattern, and color for each available layer in
the current design. Select the check box in the layer's Sel column to enable editing. To protect a layer from
unintentional editing, deselect its Sel check box. Select the check box in the layer's Vis column to display the layer. To
hide the layer, deselect its Vis check box.
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The four buttons below the Layers list enable you to set the selectability and visibility for all current design layers.

e Select the AS (All Selectable) button to set all current design layers to visible and selectable.

e Select the NS (Not Selectable) button to set all current design layers, except the default layer, to nonselectable.

e Select the AV (All Visible) button to set all current design layers to visible.

e Select the NV (Not Visible) button to set all current design layers, except the default layer, to nonselectable and
invisible.

Defining Port Connections (Layer Binding)

Layer Binding enables you to control which layers will make a connection to other layers when pins and shapes
overlap. Layer Binding is found under the Advanced tab of the Layer Editor dialog box. For ADS versions before
2004A, only pins could make connections. Starting with ADS 2004A, shapes (polygons, circles, paths, and rectangles)
can also make connections between components. Also, components can have area and edge pins in addition to their
point pins. Because of this, it is important to have your layer binding specified correctly.

In a design process, interconnects are made on metal layers or by holes in a via layer. To represent this in ADS, the
Layer Binding should have values on metal or via layers and other layers should have empty Layer Bindings.

The layer binding field is a list of words separated by spaces. The words typically are layer names, but this is not
required. When pins or shapes overlap but are on two different layers, they will connect if a word in the layer binding
list of the first layer matches the same word in the layer binding list for the second layer.

A layer binding of "*" will match any word or "*" in another pin's layer binding list. Agilent Technologies recommends
that you not use "*" because it can cause layers to be connected when you did not expect a connection. Connections
with shapes will ignore the layer binding "*" and treat the Layer Binding as if it were empty.

Examples

Layer Name Layer Binding List
Metall Metall
Metal2 Metal2

Since neither layer has the same word in their layer binding list, they will not connect to each other.

Layer Name Layer Binding List
Metall Metall

Metal2 Metall
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Since both layers have the same word (Metall ) in their layer binding list, overlapping pins and shapes on these layers
will connect to each other.

Layer Name Layer Binding List
Metall Metall Metal3
Metal2 Metal2
Metal3 Metal3 Metall

The pins and shapes on layers Metall and Metal3 will connect, but those on the Metal2 layer will not connect.

Layer Name Layer Binding List
Metall Metall
Vial Vial Metall Metal2
Metal2 Metal2
Via2 Via2 Metal2 Metal3
Metal3 Metal3

This is a typical way to setup metal and via layers. Pins and shapes will connect from Metall to Metal?2 if they overlay
shapes on the Vial layer. The same situation occurs for pins and shapes on Metal2 and Metal3 layers.

Layer Name Layer Binding List
Metall conductors
Metal2 conductors
Metal3 conductors

The three layers have a common word, conductors, in their list and each will connect to the others. Using "conductors"
this way enables you to refer to a group of layers that will all connect to each other.

Changing the Visibility and Protected Status of Items

Visible toggles the display of items on the selected layer. To display items on a given layer, enable the Vis option for
that layer. By default, visibility is turned on for all layers, making all items visible.

Selected toggles the protection status of items on the selected layer. To protect a layer so that you can prevent items
from being selected, disable the Sel option for that layer. This can be useful if you need to edit certain types of items,
but not others, in a crowded design. By default, protection is turned off for all layers, making all items available for

selection.
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Using IGES and GDSII Numbers

These numbers do not have to be unique. The IGES number is used to set the IGES level number. The GDSII layer
number is used for both reading and writing GDSII stream files; it must be a number between 0-255.

Using DXF Names

Use these names to map ADS layers to DXF layer names when exporting DXF hierarchical files. ADS layer numbers
are mapped to DXF layer names. From the DXF layer name column in the Advanced tab in the layer editor, users can
modify layer mappings and the DXF layer names.

Assigning Layers for Transmission Line Components

By default, transmission line components are placed on the cond layer, but you can specify different layers for
multi-layer designs.

To assign the layer for transmission line components:

1. Double-click the appropriate substrate item (to open the Component Parameters dialog box):
e For microstrip elements, this is the referenced MSUB.
e For Stripline elements, use SSUB (Stripline Substrate).
e For Suspended Substrate elements, use SSSUB (Suspended Substrate).

2. Select any of the following layer parameters to be re-mapped:

Cond1="cond"
Cond2="cond2"
Diell="ied"
Diel2="thel2"
Hole="hole"
Res="resi"
3. Select a different layer from the list of layers at the right and click Apply.
4. Regenerate the layout. All the microstrip components will be placed on the new layer.

Layer Files and Library Components

Library components rely on certain layers being defined. For example, by default, all top-level metallization for
components in microstrip and stripline libraries is placed on layer 1 ( cond ). In general, layers 1-12 should be defined
so that the layout libraries function properly. If a layer is missing, the artwork for an element can not be created.
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If you remove layer 1 cond, you must change the element's corresponding substrate element to specify a different
layer number. For example, if you remove layer 1, artwork for microstrip elements will not be generated unless you
change the cond parameter of the MSUB_DEFAULT item referenced by these elements. Also, the packaged parts
library uses a number of layers to display part-packaged outlines, leads and other information. If you plan to use this
library, be sure to include layer definitions compatible with the defaults.

Layer Files and Design Files

Every design has an associated layer file. When you create a design, the program automatically looks for a layer file
called layout.lay. By default, the program looks in the current project directory first. If it does not exist there, it looks
for it in the directory HPEESOF_DIR\lib\ <program_name>\defaults.

) Note

The variable that defines this search order is LAYERS_PATH. For additional details, refer to LAYERS PATH.

All text and shapes are entered on layers, and each layer has a number assigned to it. The layer number for each part
of a design is stored in the design file, but the attributes comprising the actual layer definition are stored in the layer
file. For example, if your design contains a polygon, the program notes the layer number for the polygon in the design
file and searches the current layer file for a matching layer number. It can then display the polygon with the
appropriate color, fill pattern, etc.

Ensuring Compatible Layer Definitions

Always use the same (or compatible) layer definitions for related designs. This is especially important for designs that
are related hierarchically. For example, if you use layer 1 for first layer metallization in one design, you should do the
same for all related designs. If designs have incompatible layer numbering, you can change the layer number
associated with a shape by moving that shape to the appropriate layer using the Edit > Move > Move to Layer
command.

If you have made any changes to the layer definitions but have not yet clicked Apply, you can click Reset (in the Layer
Editor dialog box) to return the layer definitions to the state they were in before you started making changes.

Different designs can have different layer sets associated with them by reading in different layer files.

Layer File Format

Each line in a layer file defines a layer. There is no limit to the humber of layers that can be defined. The layer names
and numbers must be unique. Any layer numbered 0, must have the name default. It can have its other
characteristics set to any valid value. By default, when a new design is created, it becomes associated with the
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schematic.lay and layout.lay layer file found on the path. If none are found, the program uses internal defaults.

In the layer file, information for all the fields for each layer need to be on a separate line, separated by spaces or
tabs:

default nunmber = 0 stream= 1 iges =1 color =59 fill =01line =0, 00 1, "*",
type = 1, dxf = "cond"

layer_name Name of the layer. It must be unique within this file. The name default has special significance and must
have layer number 0.

The string can be any length, but should only contain letters, numbers or the underscore.

layer_num This is the layer number. The number associates a layer's attributes (color, name, fill, etc.) with objects
stored in the design. For example, stored with a rectangle is the information that it is on mask layer 4. The program
searches the layer file by number to determine how to plot the layer.

All layer numbers are integers between 0 and the largest integer (approximately 2 billion). Layer number 0 is reserved
for the default layer (see above). Each layer number in the file must be unique.

gds_num This is the number to use as the GDSII stream layer number when translating a layout to GDSII stream
format with the GDSII export option.

This is an integer in the range of 0-255.

iges_num This is used as the IGES level number when exporting a layout to IGES format.

color An index into the eecolorRGB.cfg file that determines the color that an object is drawn. It can be any integer in
the range of 0, to the number of colors defined in eecolorRGB.cfg.

fill An index into the hpeefill.cfg file that determines the fill pattern used when the layer plot mode is filled or both. It
can be any integer in the range of 0, to the number of fill patterns defined in hpeefill.cfg.

) Note

The hpeefill.cfg file contains the names of X bitmap files that determine screen fill, and the HPGL fill pattern
numbers when plotting to a HPGL hardcopy device.

line_type An integer representing the line style type. The available line styles are:

0 = solid
1 = dot
2 = double dot

3 = short dash
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4 = short dot dash
5 = long dash
6 = long dot dash

plot_mode An integer representing how a closed object (circle or polygon) is plotted.

0 = outline
1 = filled
2 = both filled and outline

protect_flag Integer 0 or 1 representing whether a layer is protected or not (nothing can be selected on a protected
layer).

not protected
protected

= O
]

visible_flag The integer 0 or 1 representing whether a layer is visible or not.

not visible (not plotted)
= visible

= O
|

layer_binding Names of the layers a port must be on to connect to a port on this layer. An asterisk (*) = connection to
any layer.

layer_type An integer representing the layer type.

1 = Physical
2 = Notes
4 = DRC

DXF_layer_name Name of the DXF layer.

Preferences for Layout

To access Preferences for Layout, select Options > Preferences.
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Lse these to scroll among the various tabs

Preferences for Layout: 2
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Select
Select Filters Select Mode for Polygons
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v Cicles [v Polpines i+ |nzde
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[T Drawing Fomat [ Test Pick Box Uitz

[W Pathz [w wfiresd/Traces I‘":I W‘

Selected Vetar  Unils

[005 lvout uni JEY
Set 4l Cearad | Color =]

W Vertices

COE Apphy Reset Save. Read.. Cancel Help

Changing Select Options

To change select options, select Options > Preferences > Select.

© Note

To use the selection filters, see Using Selection Filters.
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Select
Select Fiters Salect Mode for Palygons
[w Ancs ¥ Polgons " Byedge
[+ Circles v Pollines % |rnside
[ Components v Poarts Cize
[~ Diawang Format [ Test Pick Box Uriitz

[ Paths [ Wi/ Traces I‘“:I W‘
Selected Verter Uitz

WV Wartices
[0.05 llzvout uni R
Set Al Ceartd || Color =]

Setting How Polygons are Selected

You can choose one of two select modes for closed shapes (polygons): clicking inside the shape or clicking near the
edge of the shape.

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Select tab.
3. In the Select Mode for Polygons, choose the method:
e By edge enables you to select a polygon by clicking on its outer edge.
e Inside enables you to select a polygon by clicking anywhere inside the shape.

Because this shape is inside
another, it can be hard to select
with | nside enabled.

Setting Color for Selected Items

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Select tab.
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3. Click the colored box next to the word Color and select the color from the displayed palette. This sets the color
for:
o the color of the marker that identifies a selected vertex,
e the box drawn around items identifying them as being selected.

Setting the Size of the Pick Region

The pick region defines how close the pointer must be to an item to select it.

— Outside pick region

|'I — Inside pick region

/
'l'lr [ * *—— Pointer

‘ 3

Pick Box=5

Choose the command Options > Preferences
In the Preferences for Layout Dialog Box, choose the Select tab.
In the Size area, locate the Pick Box field.
Enter the size for the marker, and select the units.
e Screen pixels specifies sizes in terms of pixels on the screen. For example, if you choose 5 screen pixels, an
item must be within 5 pixels of the pointer to be selected.
¢ Layout Units specifies sizes in terms of the current units of the window. For example, if you are using inches
and choose 0.1 layout units, an item must be within 0.1 inch of the pointer to be selected.

.

Setting the Size of Vertex Markers

A Vertex marker identifies a selected vertex.

Choose the menu command Options > Preferences.

In the Preferences for Layout Dialog Box, choose the Select tab.
In the Size area, locate the Selected Vertex field.

Enter the size for the marker, and select the units.

PN
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the size of the marker is 5 pixels.

e Layout Units specifies sizes in terms of the current units of the window. For example, if you are using inches

and choose 0.1 layout units, the size of the marker is 0.1 inch.

Changing Grid and Snap Settings

To change grid and snap settings, select Options > Preferences > Grid/Snap

Grid/Snap
Display

_I Minor Grid

¥ Hajor Grid

Type
& Dots

_1 Lines

Color

You can establish settings for a snap grid and a display grid to assist you in creating a layout. The display grid appears
on the screen as a series of vertical and horizontal lines or dots, but does not print. You use it to ensure exact

Spacing

Snap Grid Distance (in layout units)

X ® Y |5

Snap Grid Per Minor Display Grid

X [ v e

Minor Grid Per Major Display Grid
X |k v |5

X Automatically set ¥ =X
when any X value is modified

Snap Distance - all other modes
Diameter  Units

20 Screen pixze

Active Snap Modes

® Enable Snap

3nap to:

® Pin
_| Vertex
_| Midpoint

| Intersection

- ArcfQrcle Center

_I Edge

X Grid

Set Al

alignment of pins and vertices as well as provide visual clues to spacing.
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Dot on the major grid as an increme
of the minar gnd

Setting Grid Visibility and Color

unhwn e

o

Choose the menu command Options > Preferences.

In the Preferences for Layout Dialog Box, choose the Grid/Snap tab.

In the Display area, choose Major, Minor, or both.

Choose the Type of display (Dots or Lines). You may need to zoom in to see the grid display.

Click the colored rectangle next to the word Color, and choose the color for the grid. Click OK to dismiss the color
palette.

Click Apply.

Setting Snap and Grid Spacing

The ability to display a major grid as an increment of the minor grid enables you to better gauge distances and align
objects in layout.

[y

Choose the menu command Options > Preferences.

. In the Preferences for Layout Dialog Box, choose the Grid/Snap tab.

In the Spacing area, enter Minor Grid display factors for both X and Y.

The larger the number, the wider the grid spacing.

Click Apply.

If the display factor you specify makes the grid too dense to display, it is invisible unless you zoom in. To see the
grid without zooming, choose a larger display factor.

If the Major Grid requires changing, enter X and Y factors in those fields and click Apply.
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Setting Pin/Vertex Snap Distance

Represents how close the cursor must be to a pin of a component or a vertex of a shape before the cursor will snap to
it.

A large value makes it easier to place an object on a snap point when you are unsure of the snap point's exact
location. A small value makes it easier to select a given snap point that has several other snap points very near it.

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Grid/Snap tab. In the Pin/Vertex Snap area, enter a
number for the Diameter of the snap region.
3. Specify the Units.
e Screen pixels specifies sizes in terms of pixels on the screen. For example, if you choose 15 screen pixels,
the diameter of the snap region is 15 pixels.
Layout Units specifies sizes in terms of the current units of the window. For example, if you are using inches

and choose 0.1 layout units, the diameter of the snap region is 0.1 inch.
4. Click Apply.

Setting Snap Modes

Snap modes control where the program places objects on the page when you insert, move, or stretch them; you can
change snap modes when inserting, moving, or stretching an object, or drawing a shape. When snap is enabled, items
are pulled to the snap grid. You can restrict or enhance the manner in which the cursor snaps by choosing any
combination of snap modes. The following table lists the snap modes that you can set, and their priorities.

Setting Snap Modes

Snap Mode Priority

Pin 1

Vertex 2

Midpoint

Intersect

Arc/Circle Center

Edge 3

Grid 4

Angle Snapping automatically occurs when only Pin snapping is enabled and you place a part so that the pin at the
cursor connects to an existing part. The placed part rotates so that it properly aligns with the connected part.
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For example, if you have a microstrip curve at 30° and place a microstrip line so that it connects to it, the microstrip
line will snap to 30° so that it properly abuts the curve.

Enable Snap toggles snap mode on and off. You can toggle snap mode on and off from the Options menu itself, and by
default, there are snap mode buttons on the toolbar.

Except for pin snap, the pointer defines the point on the inserted object (the selected location).

When you set all snap modes OFF, you can insert objects exactly where you release them on the page. This is
sometimes called raw snap mode. Like other snap modes, the raw snap mode also applies when you move or stretch
objects.

Pin When a pin on an object you insert, move, or stretch is within the snap distance of a pin on an existing object, the
program inserts the object with its pin connected to the pin of the existing object. Pin snapping takes priority over all
other snapping modes.

Vertex When the selected location on an object you insert, move, or stretch is within the snap distance of a vertex on
an existing object, the program inserts that object with its selected location on the vertex of the existing object.
(Vertex refers to a control point or boundary corner on a primitive, or an intersection of construction lines.)

Midpoint When the selected location on an object you insert, move, or stretch is within the snap distance of the
midpoint of an existing object, the program inserts that object with its selected location on the midpoint of the
existing object.

Intersection When the selected location on an object you insert, move, or stretch is within the snap distance of the
intersection of the edges of two existing objects, the program inserts that object with its selected location on the
intersection of the existing objects.

& Hint
When working with a layout, if you notice a slowdown in the ADS environment, change your layout preferences
to turn off the Snap to Intersection option (Options > Preferences > Grid/Snap). Doing so may help improve
ADS responsiveness, especially if the layout or its subcircuits contain a large nhumber of polygons.

Arc/Circle Center When the selected location on an object you insert, move, or stretch is within the snap distance of
the center of an existing arc or circle, the program inserts that object with its selected location on the midpoint of the
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existing arc or circle.

Edge When the selected location on an object you insert, move, or stretch is within the snap distance of the edge of
an existing object, the program inserts that object with its selected location on the edge of the existing object. After a
point snaps to an edge, it is captured by that edge, and will slide along the edge unless you move the pointer out of
the snap distance.

Because edge snapping has a priority 3, if the cursor comes to within snap distance of anything with a priority 1 or 2
while sliding along an edge, it will snap the selected location to that.

Grid When the selected location on an object you insert, move, or stretch is within the snap distance of a grid point,
the program inserts that object with its selected location on the grid point.

All other snap modes have priority over grid snap mode.

@& Hint

e Whenever possible, keep grid snapping on. After data is off grid, it is difficult to get it back on.

e Use 45- or 90-degree angles to ensure even alignment of data with less probability of small layout gaps
due to round-off errors.

e Keep grid spacing set at increments of a base grid setting. When grid snapping is on, coordinates entered
with the mouse are rounded off or snapped to the grid setting.

Selecting Placement Options

To change placement options, select Options > Preferences > Placement.
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Placemert

Layout Control of simultaneous placement of components i layout and schemahc

¢+ Single Representation [zchematic OR layout]
¢ Dual Representation [schematic AND layout)

" Always Design Synchronize [schematic AMD layout]

[¥ Show Component Parameter Dialog Box
[~ Show Component Parameter Dialog Bos for components without parameters
¥ Keep the onginal component 1D[z] when swapping components

Size
Pott/Ground
|4

r

Single Representation When you place an item in one representation, nothing is automatically placed in the other

representation.

Dual Representation When you place an item in one representation and move the pointer into the window for the
other representation, the equivalent component is already selected. Position the pointer and click to place it. (If a
window for the other representation—containing the same design—is not open, one is opened automatically.)

Always Design Synchronize Causes the program to fully synchronize both representations after each part is placed,
ensuring all parts are fully interconnected. This takes more time than the Dual Representation mode and can move or

rearrange the layout or the schematic to preserve connectivity.

Toggling Display of the Component Parameter Dialog Box

The Component Parameter Dialog box displays the parameters for a selected component. Double-click a component to

view this dialog box.

1. Choose the menu command Options > Preferences
2. In the Preferences for Layout dialog box, choose the Placement tab.
3. Toggle the options for the Component Parameter dialog box.

e Component Parameter Dialog toggles the display of the Component Parameter dialog box. By default, when
you click a component, a dialog box appears that displays the component's parameters. If you disable this
feature, the dialog box appears only when you choose the command Edit > Item > Edit Component
Parameters, or when you click the Edit Component Parameters button on the toolbar.

e Show Component Parameter Dialog for components without parameters displays the Item Parameters
dialog box even for components that do not have parameters (GROUND, for example). By default it is off
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and the dialog box does not appear. Double-clicking the component symbol brings up the dialog box so that
you can change the item ID.

4. Click Apply.

Toggling Repeatable Component Placement

By default, a component remains selected for placement until you deactivate it. This enables you to place more than

one copy of a component without selecting it each time.

s

Click Apply.

Choose the menu command Options > Preferences.
In the Preferences for Layout dialog box, choose the Placement tab.
Enable/disable the Auto-repeatable component placement option.

Setting the Size of Ports and Grounds

Use the field in this panel to set the size (in layout units or screen pixels) of ports and grounds.

Changing Options for Pins/Tees

To change pins/tees options, select Options > Preferences > Pin/Tee.

Pin/T ee
Size Color Yizibility [ondoff)
-3 Connected Pins
Fin Uitz

oo [PEEE =]

Tee  Units

- ERE
I - | Mode Voltage
Il -] Pin Current
I - | Node Name

005

Urneconnected Pins uze Highlight

Color defined in Display page
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Setting the Size of Connection Markers

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Pin/Tee tab.
There are two types of connection markers:
¢ Pin sets the size of the marker that identifies component pins.
e Tee sets the size of the marker that identifies tee connections between interconnected wires.
3. Enter the size and select the units.
e Screen pixels specifies sizes in terms of pixels on the screen. For example, if you choose 5 screen pixels,
the size of the marker is 5 pixels.
e Layout Units specifies sizes in terms of the current units of the window. For example, if you are using inches
and choose 0.1 layout units, the size of the marker is 0.1 inch.

Setting the Color of Pin & Tee Connections

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Pin/Tee tab.
3. Use the selections in the Color area to specify the color of the markers that identify connected pins, tee

connections between interconnected wires, pin numbers, pin names, node voltages, pin currents, and node
names.

 Note

Unconnected pins appear in the color set for highlighted items (see Changing Display Colors).

Setting Visibility of Connected Pins, Pin Numbers & Names

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Pin/Tee tab.

3. Use the selections in the Visibility area to toggle the visibility status of connected pin markers, pin nhumbers, and
pin names.

 Note

The Connected Pin selection in the Color area of this panel sets the color for the markers that identify
connected pins, pin numbers, and pin names.

Changing Entry/Edit Attributes

To change entry/edit options, choose Options > Preferences > Entry/Edit.
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Polygon Entry Mode: Any angle
Enables you to draw polylines and polygons, using all angles.
Polygon Entry Mode: 45 degree angle only
Restricts shape entry to 45 degree rotation increments.
Polygon Entry Mode: 90 degree angle only
Restricts shape entry to horizontal or vertical.
Show Coordinate Entry Dialog for Insert and Edit commands
Select this option to force the Coordinate Entry dialog box to be displayed when invoking the following
commands:
° Insert (Shape)—Polygon, Polyline, Rectangle, Circle, Arc (clockwise and counter-clockwise), Text,
Construction Line, Symbol Pin, Path, Trace.
° Edit—Move Wire Endpoint, Mirror X, Mirror Y, Move & Disconnect, Step And Repeat, Set Origin, Move
Component Text.
Show Set Paste Origin Dialog for Copy Command
Select this option to force the Set Paste Origin dialog box to be displayed when you choose the Copy command.
This dialog box enables you to specify X and Y coordinates to be used as a reference point when pasting.
Polygon self-intersection checking
Prevents you from placing additional points on a polygon if it will lead to overlapping lines.

/— Self-intersecting

—
.

Mat self-intersecting

Drag rectangle vertex maintains rectangularity

Insures that the dragging, the move relative, or the move using reference of one selected vertex of a single
selected rectangle or of two adjacent selected vertices of a single selected rectangle will maintain its
rectangularity.

Maintain adjacent angles for Move Edge command

Restricts the Move Edge command to stretch an edge while maintaining the adjacent angles of the edge being
stretched to other edges adjacent to that edge.

Reroute entire wire attached to moved component

When this option is selected, the wire connection is allowed to be completely redrawn and rerouted as needed.
When this option is deselected, only the segment (up to the first bend) of the wire attached to the component
you are moving is rerouted; the remainder of the wire is unaffected.

Reroute entire trace attached to moved component

When this option is selected, the trace connection is allowed to be completely redrawn and rerouted as needed.
When this option is deselected, only the segment (up to the first bend) of the trace attached to the component
you are moving is rerouted; the remainder of the trace is unaffected.
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Turned ob—Orly ssgmen Turned on—Emlirs frace is
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Arc/Circle Radius (degrees)

Determines how smoothly curves are drawn. The number entered here defines when the program starts a new
line segment. For example, an entry of 5 means that the program begins a new line every 5 degrees. In general,
the fewer degrees, the smoother the shape, but the longer it takes to redraw the screen.

.:_'_1'\5" . -:4\50‘—3|wciff this angle

Arc drawn with Arc drawn with
5 degrees 45 degrees

Note
This setting affects only circles in that the humber specified here is used if you convert a circle to a polygon.

Auto-backup edit count

Automatically saves a file each time the number of edits to that file reaches the number in this field.

Undo edit count

This option represents the maximum number of commands held in the stack. Selecting Undo from the Edit menu
or clicking the Undo button on the toolbar undoes the last editing command. A stack of edit commands is
maintained for each window, thus the Undo command works independently from window to window. You can
choose Undo repeatedly to return to an earlier state of your design. You can specify the number of commands
you want the stack to hold using the Undo edit count option.

Rotation Increment (angle)

This option forces objects you rotate to snap—during rotation—in n -degree increments, where n is the number
you specify here.

Drag and Move

This option is designed to prevent you from moving an item when you click to select it (for any purpose) and
unintentionally move the pointer in the process. By default, a move less than 10 screen pixels is not recognized
as a move. An intentional move must be more than the distance specified here for it to be recognized as a move.
Merge/Boolean Logical/Create Clearance

Final Minimum Vertex Distance (in Layout Units)—Vertices that fall within the distance entered here are collapsed
into one vertex. This eliminates the spikes or slivers created during merge operations that happen when vertices
are too close together.
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Changing Component Text Attributes
To change text attribute options, select Options > Preferences > Component Text.

Component Text
Font Diefirution Apply To Layer;
Fonit Type Comporent Name
|HersheyFi armaniy arrow j | j
Component |0
=
Size
{01

Component text is the text associated with components selected from a library or palette. If the designated layer is
visible, this text appears automatically when a component is placed in the Layout window.

Setting Component Text Font & Height

Font Use the drop-down list to choose a font. The default is HersheyRomanNarrow.
HersheyRoman
HersheyRomanNarrow
HersheyvyRomanWide
He "L*_‘s:r‘gbﬂztéf,»k%D ST o tfannoew

Height represents the text height with respect to the current units in a window (displayed in the status panel at the
bottom of the window).

Setting the Layers for Component Text

When a component is placed in layout, its name and reference designator (ID) are automatically placed with it on the
silk screen layers. By default, the name is placed on the layer silk_screen2; the ID is placed on the layer silk_screen.
Name Use the drop-down list to define the layer for component names.

ID Use the drop-down list to define the layer for component IDs.

Changing Typed-in Text Attributes
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To change text options, select Options > Preferences > Text.

Text
Font Definition Justification
Faort Type Horizontal Vertical
|Hershe_l,th:|rnar1N Aty j & Left & Bottomn
Size ~ ~ M
T Center Middle
" Fight O Top

Placement Anale i

[T Morn-rotating [when in hietarchy)

e Font Type—All TrueType fonts installed on your system are available. Select the desired font from the drop-down
list. When printing to an HP-GL/2 file, text information will not be saved if the font is a TrueType font. To
preserve the text in your output file, convert it to HersheyRomanNarrow before saving to HP-GL/2.

) Note

On UNIX, if you want to add additional TrueType fonts that were not supplied with ADS, copy them to
$HPEESOF_DIR/lib/fonts (where $HPEESOF_DIR represents your complete installation path).

e Size—Represents the size of text in traditional units used in printing.

o Justification, Horizontal—This setting represents two types of justification: one is how individual lines of text in a
block of text are aligned with one another; the second is how an individual line of text or block of text is
positioned horizontally, relative to the reference point you specified to begin typing the text.

o Justification, Vertical—This setting aligns a string or block of text vertically, relative to the reference point you
specified to begin typing the text.

e Placement Angle—The angle at which all text subsequently added to your design will be drawn.

e Non-rotating (when in hierarchy)—Select this option to prevent text on a symbol or design from being rotated
when the symbol is rotated.

Changing Display Colors

To change display color options, select Options > Preferences > Display.
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Display
Color
Foreground Background Bl Highiight
Fixed Component Edit In Place Box
Hierarchical Plotting Depth An

Object Display Resolution
Minimum Ohbject Size To Display (in pixels) 4

X Display Box For Objects Smaller Than Minimum Object Size (4 pixels)

Maximum Hierarchical Depth At Which To Draw Box 2

_| Display instance names of components in subnetwrorks Onscreen Coord Display

1 Hone

_| Display text onigin marker
) Absolute

& Relative

Setting the Color of the Drawing Area

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Display tab.
3. In the Color area, click the color box to display a palette from which to choose a color.
Foreground defines the color of the lines making up polygons, polylines, and arcs.
Background defines the color of the Layout window background.
Highlight defines the color used to identify problem items, orphaned items in schematic and layout
representation, and unconnected pins.
Fixed Component defines the color of fixed components.
Edit In Place Box defines the color of the box around the hierarchical design that is being edited during Edit in
Place.
4. Click Apply.

Setting the Color of Unconnected Pins

Choose the menu command Options > Preferences.

In the Preferences for Layout Dialog Box, choose the Display tab.

In the Color area, click the colored box next to the word Highlight and select the color from the displayed palette.
Click OK to dismiss the palette.

PR
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5. Click Apply. This sets the color for:
e the marker that identifies an unconnected component pin, and
e the box that the program uses to highlight an item. This type of highlighting is used when you use choose
one of the Layout (Schematic) > Show commands.

Setting DRC Memory Use and Performance

To set preferences for DRC memory usage and performance, refer to Setting DRC Memory Use and Performance in the
Design Rule Checker manual.

Changing Miscellaneous Display Options

To change hierarchy display options, select Options > Preferences > Display.

Display
Color
Foreground Background Bl Highiight
Fixed Component Edit In Place Box
Hierarchical Plotting Depth pll]

Object Display Resolution
Minimum Object Size To Display (in pixels) #

X Display Box For Objects Smaller Than Minimum Object Size (4 pixels)

Maximum Hierarchical Depth At Which To Draw Box 2

_| Display instance names of components in subnetworks Onscreen Coord Display

1 Mone
_l Display text ongin marker
_) Absolute

# Relative

e Foreground—The color of the lines making up polygons, polylines, and arcs while they are being drawn.

e Background—The color of the drawing area background in the design window.

e Highlight—The color used to identify problem items (with respect to simulation), orphaned items in schematic
and layout representations, and unconnected pins.

e Hierarchical Plotting Depth—The level of detail displayed in hierarchical designs. Any item nested below the
plotting depth specified here is drawn as a bounding box, which can significantly increase the redraw speed of
complex hierarchical designs. Plotting depth affects both screen and hardcopy output.
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e Minimum Object Size To Display (in pixels)—The minimum size (in pixels) an object must be before it is actually
drawn in the Schematic window. Objects smaller than this are not visible.
e Display Box For Objects Smaller Than Minimum Object Size ( <current minimum size> )—Draws a box to
represent any object that is smaller than the minimum object size (based on the setting in the field above).
° Maximum Hierarchical Depth At Which to Draw Box—The number of levels in the hierarchical design for

which you want a box drawn.
e Display text origin marker—Displays a cross mark at the point you clicked to begin typing text (the lower left

corner of the text string).

Setting Units/Scale Factors

To change units and scale options, select Options > Preferences > Units/Scale.

Units
Scale Factors
Frequency Capacitance Power
IH ra TI |ﬁ - | |E - I
Resistance Length Vaoltage
= - -] & =
Conductance Time Cument
T - 1 B
Inductance Angle Digtance

= EE

Scale factors are used in simulation and in generating artwork for parameterized artwork components.

]

Scale factors used in the layout should match those you want in the final output.

There are usually no problems associated with translating units that are in the same measurement system (mils to
inches, or centimeters to millimeters), but round-off errors can occur when translating between metric and English

units.

Changing Layout Units & Resolution

To change layout units and resolution options, choose Options > Preferences > Layout Units.
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Layout Units Mate: Changing units vaill
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Layout units are used for any drawn item (such as a polygon, circle, or square).

 Note

Set the correct layout units at the beginning of a design. Changing units after a design is complete can result
in the loss of information (due to round-off errors). Because of this, if you must change the units of an existing
design, you should make a copy of the file before you change the units. Then you can compare the designs
after the change to determine if any information was lost.

When you change layout units, only the current design is rescaled to the new units

Setting Layout Resolution

Set the correct resolution (the smallest number allowed in layout) at the beginning of a design.

Choose the menu command Options > Preferences.

In the dialog box that appears, select the Layout Units tab.
Enter the resolution.

Click Apply. The resolution changes for the current design.

il

The smaller the number the more precise the data base, but because Layout uses a 32-bit integer data base, setting a
very small resolution limits the largest user nhumber that can be represented. This is usually not a problem for most
designs until the resolution is greater than 0.0001.

The greater the resolution, the more difficult it is to ensure exact alignment of vertices in layout. Conversely, the
greater the resolution, the smaller the gaps from round-off errors produced by non-orthogonal angles.

It is important to consider using a consistent resolution when creating related designs, or when using the packaged
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parts library. Information can be lost when going from a higher to a lower resolution. The packaged parts library was
created using the default resolution setting (100).

Angles are stored in the data base as integers, but they have a hard-coded resolution of 1000 data base units per
degree. All angles are stored in degrees between —180 and 180 degrees. Angles specified with more than three
decimal places are rounded off (24.7895 is stored as 24.790).

Toggling the Coordinate Readout Display

To change coordinate readout display options, select View > Coordinate Readout.

The X,Y coordinate display, which appears in the status bar at the bottom of the Layout window, displays two types of
coordinates: positional and differential.

The coordinate readout is on by default.

Positional displays the X,Y coordinates of the cursor position in relation to the total window. By default, the large
+ in the center of the drawing area is 0,0.

Differential displays the distance in X,Y the cursor has traveled since the last click. Set the starting point to 0,0
by clicking anywhere in the drawing area.

iR 47000, 10500 373.00, 13000 mil

|_ Pos itional L Differential

To toggle the display:

1. Choose the menu command View.
2. Click Coordinate Readout.

Saving a Layout Setup

After you have the layout environment set optimally for your design, you can save these settings to be used for other
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designs. A complete layout setup comprises two files:

¢ A preferences file that contains all settings under the Options menu except for layer information and options that
can be set differently within a design (such as text height).
¢ A layer file that contains all of the layer information.

© Note

When you save a design file, the preference and layer files that are current at that time are read the next time
you open that design file.

Saving Layout Preferences

You can save the settings in the Preferences for Layout dialog box to either the default preferences file (layout.prf), or
a new preferences file.

1. In the Preferences for Layout dialog box, click Save.

2. In the Save Preferences File dialog box, add the file name to the end of the path displayed in the Selection field.
If you use the default preferences filename (layout.prf), those preferences are read in each time you create a
design in the current project directory.

Saving Layer Information

You can save the settings in the Layer Editor dialog box to either the default layer file (layout.lay), or a new layer file.

1. In the Layer Editor dialog box (Options > Layers), click Save.

2. In the Save Layer File dialog box, add the layer file name to the end of the path displayed in the Selection field.
If you use the default layer filename (layout.lay), the default layer set is read in each time you create a design in
that project directory.

Using an Existing Layout Setup

You can re-use existing layout information for a design, rather than setting up the layout environment each time you
begin a design. A complete layout setup comprises two files:

¢ A preferences file that contains all settings under the Options menu except for layer information and options that
can be set differently within a design (such as text height).
¢ A layer file that contains all of the layer information.

114



Advanced Design System 2008

 Note

When you save a design file, the preference and layer files that are current at that time are read the next time
you open that design file.

Reading in an Existing Preferences File

1. In the Preferences for Layout dialog box, click Read.

2. In the Read Preferences File dialog box, double click the *.pref file you want to read.
Reading in an Existing Layer File

1. In the Layer Editor dialog box ( Options > Layers ), click Read.

2. In the Read Layer File dialog box, double click the *.lay file you want to read.

Reading a File from a Different Project Directory

1. In the Directories field, double click *_prj/...
2. Choose the project directory you want to read.
3. Double click the layer file.

Pick and Place Report

To generate a Pick and Place Report:

1. Select File > Reports > Pick And Place to open the dialog.

i Pick And Place:2 E

Fili= M are

Linhtled?

] 4 Apply | Cancel Help

This dialog box allows you to edit the report name.
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Viewing Pick and Place Report Configuration Options

To view the current pick and place report configuration options, do the following:

1. Select File > Reports > Pick and Place.
2. In the Pick And Place dialog box click the Show Options button.

i Pick And Place:2 E

Fili= M e

Linhtled?

] 4 Apply | Cancel Help

3. The Report Options dialog box appears. This dialog box allows you to view and print the current report
configuration options.

—| Report Options:3

Fick And Place Dptions
Defined in configuration file: de_parts,ssl

Check BOM Flag: FALSE

Hierarchical Reporting: TRUE
Center Placement: TRUE

Package Offsetst HULL

Attribute Columns: list{"PART_MUM")

0K Print Help

Configuring the Pick and Place Report

The Pick and Place Report is configured using the file de_parts.ael. This file is read during startup.

 Note

Prior to ADS 1.3, the de_parts.ael file contained an AEL script that generated a Parts List Report. The report
was generated when Parts List was executed. The de_parts.ael file is now used only to configure the Pick and
Place and Parts List reports.

If you have customized the Parts List report, you can retain this functionality by concatenating your custom
de_parts.ael file to the system de_parts.ael file. You will be redefining the de_parts function.
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You can customize the column data and the formatting of the report. You can add extra data columns in the report.
The columns can be instance parameters, instance properties, or instance attributes.

The procedure de_parts_set_pick_and_place_options is called every time a Pick and Place Report is generated.

To modify the format of the Pick and Place Parts list, make a local copy of the system de_parts.ael file:

cp $HPEESOF DI R/ de/ ael / de_parts. ael $HOVE/ hpeesof / de/ ael

To make your changes current without having to reboot ADS, reload the de_parts.ael file by typing the following line
in the Command Line dialog box:

load ("de_parts.ael");

DE_PARTS_SET_PICK_AND_PLACE_OPTIONS

Routine: Configure the pick and place report

Method: This procedure is called every time a Pick and Place Report is generated.

defun de_parts_set_pick_and_pl ace_options ()

{
de_parts_option_initialize ();
/* Reset to systemdefaults */
/* Null out the exclusion and
inclusion lists */
de_parts_option_set_hierarchical (TRUE); /* Hierarchical report */
de_parts_option_set_center_placenent (TRUE); /* X Y location at center */
de_parts_option_check_bom ( FALSE); /* Do not check BOMflag */

/* Do not include sinulation nodels */
de_parts_option_add_excl usi on_i tens (DePartsLunpedW thArtworKEl ements) ;
de_parts_option_add_exclusion_itens (DePartsM crostripEl enments);
de_parts_option_add_excl usi on_i tens (DePartsPCBoar dEl enents);
de_parts_option_add_exclusion_itens (DePartsStriplineEl ements);
de_parts_option_add_exclusion_itens (DePartsSuspSubEl enents);
de_parts_option_add_excl usi on_i tens (DePartsCopl anar El enents) ;
de_parts_option_add_exclusion_itens (DePartsMiltilayerEl ements);
de_parts_option_add_excl usion_i tens (DePartsBl ockText Font skl enents);

/* Add an additional colum to display the PART_NUM instance attribute */
de_parts_option_set_attribute_colums (list ("PART_NUM));
de_parts_option_set_delineter (NULL); /* Align colums */
de_parts_option_include_header (TRUE); /* Include header */
de_parts_option_sort_by conmponent (TRUE); /* Sort by conponent name */

}

Configuring the Parts List Report
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The procedure de_parts_set_parts_list_options is called every time a Parts List Report is generated.

B

/1 DE_PARTS_SET_PARTS_LI ST_OPTI ONS

/] Routi ne: Configure the parts list report

/1 Met hods: This procedure is called every time a Parts List Report

I/ i s generat ed.

e

defun de_parts_set_parts_list_options ()

{
de_parts_option_initialize (); /* Reset to systemdefaults */

/* Null out the exclusion and
inclusion lists */

de_parts_option_set _hierarchical (TRUE); /* Hierarchical report */
de_parts_option_set_center_placenent (TRUE); /* X Y location at center */
de_parts_option_check_bom (FALSE); /* Do not check BOMflag */
/* Do not include sinulation nodels */
de_parts_option_add_excl usi on_i tens (DePartsLunpedW thArtwor kEl ement s) ;
de_parts_option_add_excl usion_itens (DePartsM crostri pEl ements);
de_parts_option_add_excl usion_itens (DePartsPCBoardEl enents);
de_parts_option_add_excl usion_itens (DePartsStriplineEl ements);
de_parts_option_add_excl usion_itens (DePartsSuspSubEl enents);
de_parts_option_add_excl usion_itens (DePartsCopl anar El enents) ;
de_parts_option_add_excl usion_itens (DePartsMiltil ayerEl ements);
de_parts_option_add_exclusion_itens (DePartsBl ockText Font sEl ements);
de_parts_option_set_delineter (NULL); /* Align colums */
de_parts_option_include_header (TRUE); /* 1 nclude header */
de_parts_option_sort_by conmponent (TRUE); /* Sort by conponent name */

}

Reformatting the Reports

You can omit and reorder the columns in a Parts List or Pick and Place Report using AEL. Contact technical support if
you wish to get a copy of the report formatting AEL script.

Check BOM Flag

Command: de_parts_option_check_bom (TRUE|FALSE);
TRUE Only include instances with attribute INST_SPECIAL set as ITEM_BOM_ITEM

FALSE Do not test for ITEM_BOM_ITEM (default)

Exclusion List

Command: de_parts_option_add_exclusion_items (list ("MLIN"));
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Items in the list will not appear in the parts list.

This list is useful if parts have not been consistently flagged as BOM items. For this case, you wish to include
everything except items in the exclusion list.

To include everything, do not check the BOM flag.

For example:

de_parts_option_check_bom ( FALSE) ;
de_parts_option_add_excl usi on_i tens (DePartsLunpedW t hArtwor kEl ement s) ;

Inclusion List

Command: de_parts_option_add_inclusion_items (list ("res_smt"));

Items in the list will appear in the parts list.

This list is useful if parts have not been consistently flagged as BOM items. For this case, specify to include only items
flagged as BOM items, and add additional items in the inclusion list.

Inclusion items are treated as leaf-level parts and do not get flattened. For example, if an inclusion item is a
hierarchical part, its sub-elements will not be included in the parts list.

For example:

de_parts_option_check_bom ( TRUE);
de_parts_option_add_inclusion_itens (list ("res_sn"));

Hierarchical Reporting

Command: de_parts_option_set_hierarchical (TRUE|FALSE);

TRUE Produce a parts list containing instances from all levels of the hierarchy. (default)

FALSE Produces a parts list containing instances from only the top level of hierarchy.

e Enhancements:
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° Placement coordinates are in world space

° Arbitrary angles are supported

° Reference IDs are unique

° IDs contain the hierarchical path to the instance

Component Placement X,Y Coordinates

Command: de_parts_option_set_center_placement (TRUE|FALSE);

TRUE Coordinates represent the center point of the instance bounding box. The bounding box does not include the
annotation text. (default)

FALSE Coordinates represent the location of pin one.

e Enhancement:
° x,y placement coordinates can be either the center of the instance bounding box or the location of pin one

Component Placement X,Y Offset coordinates

Command: de_parts_option_set_package_offset (packageAttributeName, packageName, xOffset, yOffset);

For example:
de_parts_option_set_package_of f set ("Package", "P1", 15, 0);

For each instance which has a user attribute named "Package", with attribute value "P1", the placement coordinate
will be the origin offset by xOffset, yOffset.

e Enhancement:
° The x,y placement coordinate for an asymmetrical instance is not the center of the instance bounding box,

but rather a fixed offset from the origin. The offset can be incorporated in the report.

User Attribute Columns

Command: de_parts_option_set_attribute_columns (list ("INST_SPECIAL", "PART_NUM", "Price"));

Attributes in the list will appear as columns in the parts list. The attributes can be user properties, user parameters, or
instance attributes. The following instance attributes can appear in the report:
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INST_TYPE
INST_SPECIAL
INST_NAME
INST_DESIGN_NAME
INST_SYMBOL_NAME
INST_BBOX
INST_PROPERTY

Delimiter Character

Command: de_parts_option_set_delimeter (delimiter); where delimiter is used to separate column data (i.e. " ", ",")
Default is NULL.

If a NULL delimiter is specified, column widths will be determined by the longest data field and all data will be left
justified.

For example:

/* Separate columms w th conmas */
de_parts_option_set_delimeter (",");

For example:

/* Auto-format */
de_parts_option_set _delineter (NULL);

Include Header

Command: de_parts_option_include_header (TRUE|FALSE); TRUE = Output header information (default)

FALSE = Output part data only

¢ Enhancement:
° User can specify whether to include the header information in the report. A report containing only part data
will be easier to parse.

Sort by Component Name
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Command: de_parts_option_sort_by_component (TRUE|FALSE);
TRUE = Sort the parts list by the component name (default)
FALSE = Parts are listed as they appear in the database

e Enhancement:
° Default behavior is to sort the report by component name
° Parts previously appeared in the order they where found in the database. Simple edits could cause the parts
to be listed in a different order.

Customization Examples

The topics listed below represent some of the ways in which you can customize the Advanced Design System
environment.

e Creating a Custom Menu

e Creating Custom Libraries

e Advanced Library Customization Technigues
o Modifying the List of Available Symbol Names

e Adding Online Help for User-Defined Items
¢ Adding Custom Documentation for Online Access

Many of the topics presented here refer to the variables %0HOME% and %HPEESOF_DIR%. On the PC these variables
have the following meaning:

¢ %HOME%—the path you specified as the Home folder during installation ( C:\users\default by default)
e %HPEESOF_DIR%—the path you specified as your Program folder during installation ( C:\ADS2003 by default)

Creating a Custom Menu

You can add custom menus to the ADS Main window and Schematic and Layout windows by modifying the .ael file
usermenu.ael.

 Note

This procedure applies only to user-level custom menus. The number of slots available for custom menus is
limited; you must use care so that you do not wipe out another user's menu.
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To add a custom menu:

Under $HOME/hpeesof, create the additional directories /de/ael.

. Copy the file usermenu.ael from $HPEESOF_DIR/de/ael to the new directory $HOME/hpeesof/de/ael and ensure
you have write permission for this file.

Using any text editor, open the file usermenu.ael.

4. The file usermenu.ael contains sample code that can be uncommented to help you learn how to use the functions
available for defining user menus. Before proceeding, review the descriptions of the following functions in the
AEL manual: check_user_menu(), set_user_menu_label(), and add_menu(). After you understand how to use
the sample code, replace it with your own code.The function app_add_user_menus() is the function in which you
will add your custom code. The sample code provided includes the following function calls:

N =

w

/ to get the internal name of the first free user nenu

ecl freeMenuNane = app_find_enpty_user_menu(w nType);

/ uses the menu's internal nane to set the |abel on a free user menu
et _user _nenu_|l abel ("ny first nenu", freeMenuNane);

/ uses the menu's internal nane to add a nenu pick on a free user nenu
dd_menu( "nenuPi ckA", "ny_nmenu_cb", freeMenuNane );

Q = =0 =

Uncomment these lines in your file by removing the two slashes at the beginning of the three executable lines,
as shown above. Do not delete the slashes from the comment lines.

5. Save the file.
6. Restart ADS to see the change.

© Note
If this code is used as is, it will initialize the first user menu, unless your system already has user menus
defined. If your system does not have any user menus defined by other applications, and you want to see
what would happen if it did, you can uncomment the test function prefill_menus() and the call to it, both
provided in usermenu.ael. This will initialize the first two user menus, so that a call to
app_find_empty_user_menu() will return "User3" as the first available user menu.

Creating Custom Libraries

As with other aspects of ADS customization, you can create custom libraries at several levels: for site-wide use, for all
your projects, and for individual projects. The procedures are presented in three different groupings, based on the
following use models:

e Assisted customization for the average user, done through the user interface ( Tools > Custom Library ), for a
small number of designs

e Manual customization, typically done by a librarian, using the recommended directory structure, for a large
number of designs

e Manual customization, typically done by a librarian, using directories other than the recommended directories (
Advanced )
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If creating libraries via the user interface method, before defining a Library Name-through the Design Parameters
dialog box-for any given design, please review the following guidelines, as assigning a library name in this manner is
not always recommended:

¢ Basic-Do not use the Library Name field in the Design Parameters dialog box. Create a library via the user
interface method. Each process ( Create > User Part or Create > Site Part ) results in a single library. By default
the library name is User Library or Site Library. Note that because all designs are in a single library, the entire
library must be loaded or not loaded.

e Intermediate- Do use the Library Name field in the Design Parameters dialog box to categorize designs so that
they appear in the library browser under those categories (for example, My Resistors, My Capacitors). Create a
library via the user interface method. Each process ( Create > User Part or Create > Site Part ) results in a single
library. Note that because all designs are in a single library, the entire library must be loaded or not loaded.

e Advanced-Do not use the Library Name field in the Design Parameters dialog box. Set the MAKELIB_*
configuration variables to define multiple libraries. Create libraries via the user interface method ( Create > User
Part or Create > Site Part ). Each time you add a part you will be prompted to select one of your pre-defined
libraries. In this manner, the loading of individual libraries can be enabled or disabled.

Assisted Customization

The procedures in this section are geared toward individuals working with a small number of designs, because this
method is based on adding designs to a library one at a time. Once the libraries have been created, either restart ADS
to see the changes or use the Configuration Explorer to explicitly read the modified de_sim.cfg file for the current
session.

 Note

Because this method is based on copying designs from their source location to a library location, if the source
design is subsequently modified, you must repeat the process so that the design gets copied to the library
again.

Keep in mind the following limitations when creating libraries in this manner:

e Only the current design is copied to the library when using the Create > User Part or Create > Site Part
commands. If the design is hierarchical, you must open or push into each subnetwork and repeat the process.

& Hint
To easily see the designs comprising a hierarchical design, from the ADS Main window, choose View > Design
Hierarchies.

¢ Some files required to successfully recreate the design in its library location are not copied to the library. Those
files that are not automatically copied to the library must be explicitly copied to ensure the integrity of the
design:

Files Copied to the Library
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<design>.dsn -The design file

<design>.ael -The component definition AEL file

<design>.atf -The compiled component definition AEL file

<design>_art.ael -The layout artwork AEL file generated by the Graphical Cell Compiler, where applicable
<design>_art.atf -The compiled layout artwork (GCC) AEL file, where applicable

<datafile>.ext -Data files referenced by current design t

Files Not Copied to the Library

Custom symbols stored in a separate .dsn file. The workaround is to open the .dsn file containing the symbol and
add it to the library using the appropriate create part command.

Referenced fixed artwork stored in a separate .dsn file. The workaround is to open the .dsn file containing the
artwork and add it to the library using the appropriate create part command.

Artwork macros stored in a separate file, other than those created by the Graphical Cell Compiler. The workaround
is to manually copy the .ael file containing the artwork to the library ( $HPEESOF_DIR/custom/circuit/ael for Site or
$HOME/hpeesof/circuit/ael for User).

+
¢ If a design being copied to the library references a data file that is not in the project's /data directory-but is
specified using a path, absolute or relative—the file is not copied. Thus for site libraries, you must make sure all
users on all workstations can access the file(s) in this location.

¢ If your design contains a DAC that references a discrete MDIF file that lists multiple data files, only the directly
referenced file will be copied to the library. The individual files listed in the MDIF file must be manually copied to the
library ($HPEESOF_DIR/custom/datafiles for Site or $HOME/hpeesof/datafiles for User).

Site-Wide Customization (Assisted)

Copying designs to and removing designs from the site library requires write permission in that directory (by default,
$HPEESOF_DIR/custom/circuit).

To copy a specific design to a site library making it available for all users:

1. From the design you want to copy to the site library, choose Tools > Custom Library > Create > Site Part.
2. Repeat this process for each design you want to be part of a site library.

To remove a specific design from a library:

Choose Tools > Custom Library > Delete > Site Part and select the design you want to remove from the library.

& Hint
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If the design you select to remove from the library references any data files, you are prompted to choose to
keep or remove the data files.

To prevent an entire library of designs from being loaded when you start ADS:

Choose Tools > Custom Library > Disable > Site Library, and where applicable, select the library.

To enable the loading of a library that you previously disabled:

Choose Tools > Custom Library > Enable > Site Library, and where applicable, select the library.

Notes:

¢ When you use Create > Site Part, the design and related files are copied to a number of default directories under
$HPEESOF_DIR/custom/circuit.

¢ When you use Enable > Site Library, the appropriate variable (in the file
$HPEESOF_DIR/custom/config/de_sim.cfg ) is updated so that the library is loaded the next time you start ADS.
This command is used to enable libraries previously disabled.

e Site libraries created using the default procedure just presented will always be loaded by all users. To allow users
the freedom to enable/disable loading of these libraries, the following variables can be set in
$HPEESOF_DIR/custom/config/de_sim.cfg:

MAKELIB_USER_AEL_PATH
MAKELIB_USER_DSN_PATH
MAKELIB_USER_LIBRARY_NAMES *See note below
MAKELIB_USER_DATA_FILES

*Note: This variable is only used if no Library Name was specified in the Design Parameters dialog box, for any
given design. For details on using these variables, refer to Variables in the Files de.cfg and de sim.cfg in
Customizing the ADS Environment.

User Customization (Assisted)

To copy a specific design to a local library making it available for all your projects:

1. From the design you want to copy to the library, choose Tools > Custom Library > Create > User Part.
2. Repeat this process for each design you want to be part of a user library.
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To remove a specific design from a library:

Choose Tools > Custom Library > Delete > User Part, and select the design you want to remove from the library.

To prevent an entire library of designs from being loaded when you start ADS:

Choose Tools > Custom Library > Disable > User Library, and where applicable, select the library.

Manual Customization

This section is geared toward the librarian, or individual, working with a large number of designs, and working with
the recommended directory structure.

For the two manual methods, each case involves the following basic steps, though the details vary:

¢ Creating the directories shown, if they do not exist
e Copying the .dsn and .ae | files (you want made available) to these directories
¢ Modifying the search paths of specific variables to look in those directories

) Note

Do not include line breaks of any kind when setting variables; let the lines break wherever your text editor
breaks them.

When customizing for any of the scenarios described in the manual methods, wherever you see < product_area >,
replace it with one of the following:

e de—if you are customizing both Analog/RF and ADS Ptolemy libraries
e circuit—if you are customizing Analog/RF libraries only
¢ adsptolemy—if you are customizing ADS Ptolemy libraries only

Site-Wide Customization (Manual)

To make a specific design available for all users:

1. Copy the .dsn files to $HPEESOF_DIR/custom/<product_area>/symbols/ directory. Example:
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Copy mydesignl.dsn and mydesign2 .dsn to $HPEESOF_DIR/custom/de/symbols/
2. Copy the .ael files to the $HPEESOF_DIR/custom/<product_area>/ael/ directory. Example:
Copy mydesignl.ael and mydesign2.ael to $HPEESOF_DIR/custom/de/ael/

3. Edit or create a file $HPEESOF_DIR/custom/config/de_sim.cfg and set SITE_AEL equal to each of the .ael
filenames (separated by semicolons or colons). Example:

S| TE_AEL=nydesi gnl; nydesi gn2

© Note

If you want all .ael files in the directory to be loaded, a shortcut is to set the SITE_AEL variable to the
directory. For example: SITE_AEL=$HPEESOF_DIR/custom/de/ael/. Be sure to include the trailing slash.

User Customization (Manual)

To make designs available for all your projects:

1. Copy the .dsn files to $HOME/hpeesof/<product_area>/symbols/ directory. Example:

Copy mydesignl.dsn and mydesign2.dsn to $HOME/hpeesof/de/symbols/

2. Copy the .ael files to $HOME/hpeesof/<product_area>/ael/ directory. Example:

Copy mydesign.ael and mydesign2.ael to $HOME/hpeesof/de/ael/

3. Open $HOME/hpeesof/config/de_sim.cfg and set USER_AEL equal to each of the .ael file names (separated by
semicolons or colons). Example:

USER_AEL=nydesi gnl; mydesi gn2

Project Customization (Manual)

To make designs available in multiple-but not all-projects:
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1. Copy the .dsn files to $HOME/hpeesof/<product_area>/symbols/ directory. Example:
Copy mydesignl.dsn and mydesign2.dsn to $HOME/hpeesof/de/symbols/

2. Copy the .ael files to $HOME/hpeesof/<product_area>/ael/ directory. Example:
Copy mydesign.ael and mydesign2.ael to $HOME/hpeesof/de/ael/

3. For each project, open <project>/de_sim.cfg and set LOCAL_AEL to each of the .ael filenames (separated by
semicolons or colons). Example:

LOCAL_AEL=nydesi gnl; nydesi gn2

Advanced Library Customization Techniques

We recommend storing library designs for site-wide use in the following locations:

 Note

The custom directory shown here is created during installation, but you must create the product-specific
directories (beneath it) yourself.

Analog/RF Digital Signal Processing
.dsn files $HPEESOF_DIR/custom/circuit/symbolsSHPEESOF_DIR/custom/adsptolemy/symbols/
or or
$HOME/hpeesof/circuit/symbols/ $HOME/hpeesof/adsptolemy/symbols/
.ael files $HPEESOF_DIR/custom/circuit/ael/ $HPEESOF_DIR/custom/adsptolemy/ael/
or or
$HOME/hpeesof/circuit/ael/ $HOME/hpeesof/adsptolemy/ael/

If for some reason you cannot or do not want to store your files in the these directories and would rather locate your
files elsewhere, you can.

1. Copy the .dsn files to any directory. Example:

Q:\ads_designs\library1\designs

2. Copy the .ael files to any directory. Example:

Q:\ads_designs\library1\ael
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Choose one of the following customization schemes:

e Site-Wide basis (all users at the site)
¢ User basis (all projects for a single user)

 Note

There is no way to do this for project-level customization at this time.

Site-Wide Customization (Advanced)

Edit the $HPEESOF_DIR/custom/config/de_sim.cfg file as follows:

1. The SITE_AEL variable needs to be set to load your .ael files. Typically you would set it to point to the directory
containing your .ael files. Example:
S| TE_AEL=Q \ ads_desi gns\|i braryl\ ael (Loads all .ael files in directory)
Be sure to include the trailing slash. Note that you cannot not use relative paths; you must use either an
absolute path or an environment variable.
Alternatively, you can list specific files that you want to load. Example:
SI TE_AEL=Q \ ads_designs\libraryl\ael\nyfile
2. Set the SITE_DSN_PATH variable equal to the directory you copied the .dsn files to earlier. Example:
S| TE_DSN_PATH=Q \ ads_desi gns\ | i brary1\ desi gns (absolute path) or
S| TE_DSN_PATH={ $ADS_DESI GNS}\ | i br ar y1\ desi gns (environment variable)

i Important

If you set the SITE_AEL variable (in step 1) to a path, rather than a list of individual designs, you are done; if
you listed designs individually, continue with the next two steps.

Edit the $HPEESOF_DIR/custom/config/de_sim.cfg file as follows:

1. Note that every user will already have the variable AEL_PATH set in their $HOME/hpeesof/config/de_sim.cfg file.
It will be set to one of the following variables, based on the choice they made in the setup dialog box the first
time they started ADS:

{ YANALOG RF_AEL_PATH}

{ YDSP_AEL_PATH}

{ ¥BOTH_ANALOG RF_FI RST_AEL_PATH}
{ YBOTH_DSP_FI RST_AEL_PATH}

 Note

The setting chosen on startup can be changed at any time from within ADS from the Main Window through
Options > Advanced Design System Setup.
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The default definitions of these four variables can be found in $HPEESOF_DIR/config/de_sim.cfg.
Copy all four variables from $HPEESOF_DIR/config/de_sim.cfg and add them to the
$HPEESOF_DIR/custom/config/de_sim.cfg file.

. Modify each variable to add the path-that you copied the .ael files to earlier-to the front of the existing path.
Example:

ANALOG RF_AEL_PATH=Q \ ads_desi gns\libraryl\ael : {%OVE_CI RC. ..
DSP_AEL_PATH=Q \ ads_desi gns\ | i brary1\ ael : { “HOVE_HPTOL. . .

BOTH_ANALOG RF_FI RST_AEL_PATH=Q \ ads_desi gns\ | i brary1\ael : { %HOVE_. . .
BOTH_DSP_FI RST_AEL_PATH=Q \ ads_desi gns\ | i brary1\ ael : { “HOVE_HP. . .

Now, even if a user changes their setup (from within ADS) to start with a different design type-thereby updating
their local AEL_PATH variable-the designs can still be found because the search path is provided for all cases.

Example:

The AEL_PATH wvariable that is set based on your choice of design type:
$HOME/hpeesoficonfigde_sim.cfg—m= AEL_PATH=[?cANALOG_RF_AEL_PATH)

The variable your AEL_PATH variable points to, after being copied and modified:

$HPEESOF_DIR/custom/config/'de_sim cfg

I_p ANALOG_RF_AEL_PATH=Q:‘ads_designsilibrary1'ael:{HOME_CIRCUIT_AEL ..

User Customization (Advanced)

Edit the $HOME/hpeesof/config/de_sim.cfg file as follows:

1. Set the USER_AEL variable equal to the design filenames (separated by semicolons or colons). Example:

USER_AEL=nydesi gnl; nydesi gn2

 Note

If you want all .ael files in the directory to be loaded, a shortcut is to set the USER_AEL variable to the
directory. For example: USER_AEL=$HOME/hpeesof/MyLibrary/ael/. Be sure to include the trailing slash.

2. Set the USER_DSN_PATH variable equal to the directory you copied the .dsn files to earlier. Example:
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USER_DSN_PATH={ $HOVE} / hpeesof / MyLi br ar y/ Desi gns/

 Note
If you set the USER_AEL variable (in step 1) to a path, rather than a list of individual designs, you are done; if
you listed designs individually, continue with the next step.

3. Add the path-you copied your .ael files to earlier-to the front of the current AEL_PATH definition. Example:

AEL_PATH={ $HOVE} / hpeesof / MyLi br ar y/ ael ; { “BOTH_ANALOG RF_FI RST_AEL_PATH}

 Note

If you have customized the AEL_PATH path variable and you change the design type startup setting through
Options > Advanced Design System Setup, in the Main window and click OK, this variable will be overwritten
and you will lose your customized path. If you need to change your setup, you will either have to change it
manually in your de_sim.cfg file, or re-establish your customized path after changing it through the dialog box.

Example

The steps that follow can be used as a shortcut for creating a library from a single project.

Create a project, such as library_prj.

. Place in library_prj/networks only those parts you are interested in using directly.

3. Modify the variables USER_AEL and USER_DSN_PATH, shown in the example below, in the file $
HOME/hpeesof/config/de_sim.cfg. Example:

N =

USER _AEL = /eesof/users/kclarke/library_prj/networks/
USER_DSN_PATH = /eesof/users/ kclarke/library_prj/networks/

Modifying the List of Available Symbol Names

To assign a symbol to a schematic, you must supply a Symbol Name in the Design Definitions dialog box ( File >
Design Parameters ). You can type a symbol name or you can select one from the default list of commonly used
symbols. You can modify this list and add names of other supplied symbols as well as the names of custom symbols
you have created.

To modify the list of names, you modify the AEL function set_design_choices in the file shown next, in accordance with
its intended use ( circuit vs. adsptolemy ):
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e /circuit/ael/geminidsndef.ael
e /de/ael/spdsndef.ael

To modify this file for individual use, modify a local copy of it; to modify this file for site use, modify a copy of this file
on a shared drive. We recommend that you maintain the established directory structure for storing and referring to
.ael files. Note that the custom directory shown below is created during installation, but you must create the
product-specific directories (beneath it) yourself.

Use this directory structure on UNIX:

Individual Use $HOME/hpeesof/circuit/ael
$HOME/hpeesof/adsptolemy/ael

Site Use $HPEESOF_DIR/custom/circuit/ael
$HPEESOF_DIR/custom/adsptolemy/ael

Use this directory structure on the PC:

Individual Use %HOME%/hpeesof/circuit/ael
%HOME%/hpeesof/adsptolemy/ael

Site Use %HPEESOF_DIR%/custom/circuit/ael
%HPEESOF_DIR%/custom/adsptolemy/ael

%HOME% represents the path you specified as the Home Folder during installation (C:\users\default by default);
%HPEESOF_DIR% represents the path you specified as your Program Folder during installation (C:\AdvDesSys).

 Note

If you use a directory other than one of those shown in the tables for storing the modified file ( gemini.ael or
spdsndef.ael ), then you must declare the variable USER_AEL and provide the search path. The custom
directory shown here is created during installation, but you must create the product-specific directories
(beneath it) yourself.

To take advantage of the modified version of the gemini.ael or spdsndef.ael file-if stored in a directory other than one
of the defaults:

1. Using any text editor, open the file $HOME/hpeesof/config/de_sim.cfg.
2. Add the variable USER_AEL and set it equal to the path you have chosen for your modified file.
3. Save the file.

Once you modify geminidsndef.ael or spdsndef.ael, you must also modify the variable USE_RELATIVE_AEL_PATHS
(regardless of the location of the modified file). This should be done in the file $HOME/hpeesof/config/de_sim.cfg and
you must set the variable equal to TRUE (USE_RELATIVE_AEL_PATHS =TRUE). For information on modifying search
paths, "Modifying Search Paths" in the Schematic Capture and Layout book.

Once you have created the directory structure, copy the geminidsndef.ael (circuit) or spdsndef.ael (adsptolemy) file
from the installation directory to the newly created local / ael directory.
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To modify the list of symbol names appearing for selection:

1. Using any text editor, open the copied geminidsndef.ael or spdsndef.ael file in the local / ael directory.
2. Locate the heading

/* synbol |ist: DVDESI GN_SYMBOL_CHOI CES */

followed by the function

set_design_choices

Notice that the function name is followed by a list of symbol names, each surrounded by quotation marks,
separated by commas (including sequential numbering and commas), all enclosed in parentheses.

w

Add the desired names to the list using the same format.
4. Save the file.

After you have completed this process, you will be able to select your custom symbol from the drop-down Symbol
Name list (in the Design Definitions dialog box).
If the program is currently running, you need to restart the program to see these changes take effect.

Adding Online Help for User-Defined Items

When you create your own items, you can also create documentation for them and make that documentation available
online. The starting point of this procedure assumes you have already created the items.

 Note

Refer to the DesignGuide Developer Studio manual for more information on how to create custom
DesignGuides for the Advanced Design System.

© Note

This procedure requires the ability to write to the installation directory.

1. Create a directory, for example my_items, under $HPEESOF_DIR/doc for storing your new documentation files
(where $HPEESOF_DIR represents your complete installation path).

2. Change the write permission to this directory as needed, based on the users who will create documentation for
the new items.

3. Create documentation for the new items using the HTML format (one file for each item) and move (or copy) the
files to the new directory. While filenames can be any name you choose-except for the required .htm
extension-we recommend using < item_name >. htm. See Optional Document Template for a html template.
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4. Create a text file, for example my_items_help.txt, containing pointers to the new items, using the following
syntax (note the spaces before and after the first exclamation point and before the final exclamation point):

itemnane ! <path>/<fil enane> !

where

item_name_ is the element name you used in the AEL create_item() function

path_ is the directory you created below $HPEESOF_DIR/doc to store the HTML files you created (for example,
my_items )

This file should contain one line for each new item you created. An example line is shown next.

PIPAD ! ny_itens/pipad. htm!

5. The file that contains the pointers for help on all components is hamed hshpeesofsim_index and can be found in
$HPEESOF_DIR/doc. Create a copy of this file (as a safeguard), for example, hshpeesofsim_index.sav.

6. Using any text editor, add the contents of the help file you created (in this example, my_items_help.txt), to the
bottom of the hshpeesofsim_index file.

Optionally, on UNIX, you can use the cat command (instead of a text editor) and concatenate the files:

cat ny_itens_help.txt }} >> {{ hshpeesofsi mindex

The help file now contains pointers to the documentation you created.

7. Save the file (no extension) and restart ADS to verify your changes.

The following figure illustrates the directory structure for the user-defined files.
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Directory structure and files

/SHPEESCOF_DIE

Lfdoc

hzhpeesofzim index

my_items _help.txt

fmy_items

pipad.htm
cable.htm
——gainpass . htm
——¢gainact.htm
——gainnl .htm
demusb . htm
limiter.htm
iggrayv .htm

(with my_itemsz_help.txt appended)

'

PIPAD ! my_items/pipad.htm !
CABLE ! my_items/cable.htm !
GAINPASS ! my_items/gainpass.htm !
GAINACT ! my_items/gainact.htm !
GAIMMNL ! my_itemsz/gainnl . htm !
DEMUSE ! my_items/demush.htm !
LIMITEE ! my_items/limiter.htm !
igGRAY ! my_itemsz/iqgrav.htm !

The documentation you
—create for your new items

Directory Structure for User-Defined Help

Optional Document Template

Use the following html code when you create your document.
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Replace "ENTER YOUR DOCUMENT TITLE HERE" with the title you want to use for your document.
Replace "PATH_TO_HPEESOF_DIR" with the relative path to your ADS install directory.
Add your content after the "<!--Start Your Document Below -->" marker.

ght m >
<head>
<titl e>ENTER YOUR DOCUMENT TI TLE HERE</titl e>
</ head>
<body bgcol or="#ffffff">
<p><inmg src="PATH TO HPEESOF_DI R/ doc/ i nages/| ptop. gi f"

Wi dt h="550" hei ght ="40" border="0" usemap="#navt op" ></p>
<map nanme="navtop">

<area shape="rect" coords="-7,1, 326, 20" href="nanual s. ht ' al t =" ADS
Onli ne Docunentation" title="ADS Online Docurentation”
tlar get =" _parent ">
<area shape="rect" coords="2, 22,111, 40" href="doc.htm " target="_parent"
dl t="ADS Online Manual s" title="ADS Online Manual s">
<area shape="rect" coords="110, 23, 219, 39" href="exanpl es. htnl "
tlarget =" _parent" alt="ADS Exanpl es" title="ADS Exanpl es">
<area shape="rect" coords="220, 23, 328, 39" href="gui des. htm "
tlarget =" _parent" alt="ADS Desi gnGui des" title="ADS Desi gnCGui des">
<area shape="rect" coords="329, 22, 440, 40" href="adstour/i ndex. htm "
tlarget =" _parent" alt="ADS Quick Start" title="ADS Quick Start">
<area shape="rect" coords="440, 23, 549, 40" href="search/search. htm "
tlar get =" hel pcontent s" alt ="Search ADS Docunentation" title="Search ADS
Docunent ati on" >
</ map>
4! --Start Your Docunent Bel ow -->
</ body>
4/ ht m >

Adding Custom Documentation for Online Access

It is possible to create your own custom documentation for online access. For instance, you can put custom
documentation for a specific project in that project folder. You can also put documentation in other areas outside of
$HPEESOF_DIR, circumventing the issue of access permissions for $HPEESOF_DIR.

1. Create a directory, for example custom_doc, for storing your new documentation files. The LOCAL_DOC_PATH,
and LOCAL_BOOK_NAMES variables will need to be added to the hpeesofhelp.cfg file, so that your custom doc
will be accessed, instead of the standard ADS documentation. See Customizing Configuration Variables for more
information on the location of .cfg files. See Variables in the File hpeesofhelp.cfg for more information on the
LOCAL_DOC_PATH and LOCAL_BOOK_NAMES variables.

2. Create documentation using the HTML format and move (or copy) the files to the new directory. While filenames
can be any name you choose-except for the required .htm extension-we recommend using < item_name >. htm.
See Optional Document Template for a html template.

3. Create a file, for example custom_doc_index, (no extension, _index required) __ containing pointers to the items
that will be accessed in your documentation, using the following syntax (note the spaces before and after the
first exclamation point and before the final exclamation point):

IIndex ! <filenane>. htm !
opi cs and Index ! <filenanme>. htm!
iltem name ! <path>/<fil enane> !
ere

137


http://edocs.soco.agilent.com/display/ads2008/Customizing+the+ADS+Environment#CustomizingtheADSEnvironment-1104097
http://edocs.soco.agilent.com/display/ads2008/Customizing+the+ADS+Environment#CustomizingtheADSEnvironment-1105570

Advanced Design System 2008

I ndex

Topi cs and | ndex

i tem nane

pat h

is the file that you would |ike the user to be directed to if a topic
is not found

The standard for ADS docunentation is $HPEESOF_DI R/ doc/ adshel p. htm ,
if you choose to use your own file, make sure that it is |located in
your custom doc directory. (See note bel ow)

is the file that is opened when the user selects Topics and Index from
the Hel p Menu

The standard for ADS docunentation is $HPEESOF_DI R/ doc/ manual s. ht m

if you choose to use your own file, make sure that it is located in
your custom doc directory. (See note bel ow)

is the el enent nane you used in the AEL _create_iten{()_ function

is the directory you created to store the HTM. files you created
(for exanple, _customdoc_

This file should contain one line for each new item you created. An example line is shown next.

PI PAD ! custom doc/ pi pad. ht m!

 Note

If you point to custom Index and Topics and Index files within a specific project, and the project is moved,
your paths will no longer be correct.

4. Save the file (no extension) and restart ADS to verify your changes.

The following figure illustrates the directory structure for custom documentation files.
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Directory structure and files

Joustom _doc

cuztom _doo index

pipad.htm
cable .htm
——gainpass.htm
——gainact .htm
——gainnl.htm
demuskh. htm
limiter.htm
iggray.htm

- hpeezofhelp.cfg*

Directory Structure for Custom Documentation

Index !

Topicz and Index !

./index_ _filename.html !

./topics_index name.htm !

—® PIPAD ! my_items/pipad.htm !

CABLE !
GATMNPASS
GATIMNACT !

my_items/cable . htm !
! my_items/gainpass.htm !
my_itemz/gainact.htm !

The custom documentation
— youcreate

index filename.html*

See "Customizing Configuration Variables", for more info

—on cfg file placement
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