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Data Display Basics

Data generated by a simulation, as well as data that has been imported from other sources, such as a network
analyzer or CITlIfile, is stored in a dataset. The Data Display window enables you to view and analyze a dataset.
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In a Data Display window you can:

e Display data in a variety of plots and formats

e Create plots with more than two axes.

e Add markers to traces to read specific data points

e Write mathematical equations to perform complex operations on data, and display the results
e Add text and drawing objects to enhance your documentation

e Edit plot titles and axis labels, equations, text, drawing objects, and column headings in lists.

Data can be plotted on rectangular plots, polar plots, Smith charts, and stacked plots. Data can be displayed as linear
traces, histograms, scatter plots, and spectral plots, as well as in digital and wide-word (bus) data formats. In addition
to graphical displays of data, data can be viewed numerically in lists.

The basic process of creating a data display consists of the following steps.

Choose Choose Plot Select Data Choose Trace
Dataset ———W= Type ———® \ariable ——®= Type

I I

| |

I |

| |

L — — — — — Add Markers - — — — - Add Equatiocns  _ _ _ _ _ J
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The various plot and trace types enable you to display data in different formats. In addition, you can use equations to
perform complex mathematical operations on data for further analysis.

Spurious-Free Dynamic Range Calculation

The spurious-free dynamic range is calculated
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Opening and Closing Data Display Windows

To open a Data Display window:



Advanced Design System 2008

e In Advanced Design System, choose Window > New Data Display or click the New Data Display Window button
on the toolbar from the ADS Main or Schematic window.

¢ In RF Design Environment, choose Results > Plot Outputs in the Cadence Circuit Design Environment window or
click the Plot Outputs icon on the right-hand side of the Cadence Circuit Design Environment window.

To open additional windows from a Data Display window:

e Choose Window > New to open a new window showing the same contents as the current window.
e Choose File > New (or click the Open A New Data Display Window button) to open a new window that is empty.
Use File > Open to select a data display file (.dds) to show in the new window.

To open an existing data display:

¢ In Advanced Design System, choose Window > Open Data Display from the ADS Main or Schematic window,
select the data display file (.dds), and click OK.
¢ In RF Design Environment, choose Results > Plot Outputs in the Cadence Circuit Design Environment window.

To close a data display:

¢ Choose Window > Close in the window you want to close. This closes only the active window and does not affect
the rest of the data display. If the contents of the display have been modified and it is the only window
displaying data from that data display file, you will be prompted to save.

¢ Choose File > Close to close all windows that are showing the current data display file (if the contents have been
modified, you will be prompted to save). When the data display file is opened again, the same number of
windows will be opened to display it.

The basic elements of a data display window are:

e The Menu bar displays the menus that are available in a Data Display window.
e The Dataset List displays the datasets available in a Data Display window.
e The Title bar displays the window type, filename, and a number for identifying which data display window it is.
e The Toolbar contains buttons for frequently used commands.
e The Display Area is where you create your data presentations.
e The Instrument Server (Advanced Design System for PC only) enables you to read in data from instruments,
such as S-parameters from a network analyzer. It also sends data from Advanced Design System to instruments.
e The Data File Tool enables you to transfer data between datasets and files that are in the following file formats:
° Touchstone
° Measurement data interchange format (MDIF)
° CITIfile
° IC-CAP

Inserting Pages
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The Data Display enables you to add multiple pages to the display area. Multiple pages provide you with additional
display area that can be used to display and organize large amounts of data. To insert a new page:

1. Choose Page > New Page.... The New Page dialog box appears.
2. Enter a new name for the page.
3. Click the OK button to close the dialog box and insert the page.

Viewing Multiple Pages

When you have more than one data display page, you can quickly page through using the View Previous Page and
View Next Page buttons on the toolbar.

4

Alternatively, you can choose Page > Next Page or Page > Previous Page from the Page pull-down menu item.
Note that all of the buttons and menu items described above are deactivated when there is only one data display page
available to view.

Creating a Data Display

The basic process of creating a data display consists of:

Choosing a dataset (by name) to display

Choosing a plot type for the display (Rectangular, Polar, etc.)
Specifying the data variable to be displayed

Choosing a trace type (Linear, Scatter, Histogram, etc.)

 Note

The application uses the Auto trace type by default. In some cases, Auto will not provide accurate results and a
trace type will need to be manually selected.

The various plot and trace types enable you to display data in different formats. Equations enable you to perform
complex mathematical operations on data for further analysis.

Optionally, you can enhance your data display by adding:

e Markers identifying specific data points
e Text for clarification
e Graphical objects, such as lines and circles
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Using a Dataset

The numerical data presented in a data display window comes from two sources, datasets and equations. Datasets
collect and store data either from internal sources, such as a simulation, or from external sources, such as a network
analyzer or Touchstone file.

Using the data file tool, you can read a data file (i.e., Touchstone, MDIF, Citifile, or ICCAP) into a dataset, or you can
write a data file from a dataset. To use the data file tool, choose the Tools > Data File Tool menu item. The
dftool/mainWindow appears. Note that you may need to expand your window to view all available options.

For detailed information on using the data file tool, refer to Reading from and Writing to Files in Chapter 4 of the Using
Circuit Simulation documentation.

For information on how to write equations, refer to Equations.

Choosing a Dataset

When you open a Data Display window, all datasets defined for the current project are available for display. One
dataset is selected as the default; it will be used as the source of data unless a different dataset is chosen. If no
datasets have been defined for the current project, the label on the drop-down menu displays the current design
name.

—

1=

File Edit View Insert Marker
Je|gl & & M

Default Dataset —— | amplifier ‘ I.‘ |

You can also view datasets that are stored under other projects or are not part of a project, such as a dataset that
contains measured instrument data. This can be useful for comparing simulated versus actual results or comparing
results between projects.

The data display does not store any data, it only retrieves and displays the data within a dataset. Thus, if the data in
the dataset changes (for example, if you alter a design and re-simulate), the data display will be updated to reflect
the most current information in the dataset.

To choose a dataset:

1. Click the arrow to view the drop-down list of currently defined datasets.
2. Choose the name of the desired dataset. The Datasets and Equations list box is updated to reflect the data
variables contained in the selected dataset.

10
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Adding a Dataset
To view a dataset outside of the current project:

1. Choose Insert > Plot.

2. Position the pointer, click, and select a plot type.

3. Click the Manage Datasets button in the Plot Traces& Attributes dialog box. The Dataset Alias Manager dialog box
appears.

4. By default, datasets are saved with the .ds extension under the <project_name>/data directory. Navigate to the
file of interest and select the file. For more information, refer to Dataset Aliasing.

5. Click OK.

Using the Dataset Browser

The Dataset Browser enables you to clearly identify the hierarchy associated with a dataset variable name by
displaying information in a tree structure. The browser also enables you to examine or select dataset variables from
more than one dataset at a time.

The Dataset Browser is activated using the Show Hierarchy option. This option is a toggle checkbox that is available
from three different dialog boxes in the Data Display:

¢ Plot Traces & Attributes
e Enter Equation
e Browse Data
The functionality of this feature is the same regardless of how it is accessed.

Example

To browse through the datasets and equations hierarchy using the dataset browser:

Choose Insert > Plot.

Position the pointer and click. The Plot Traces & Attributes dialog box appears.

Select a dataset from the Datasets and Equations drop-down menu.

Select a dataset variable from the list box and activate the Show Hierarchy checkbox. Note that the variable you
selected in the flat view remains selected in the tree view. The dataset variables that are available in a dataset
are displayed in the Datasets and Equations list box in a tree structure.

i

 Note

In the tree view, when variables are selected and added to the trace list on the right, they are displayed in the
trace list with the short unique name (same as in the flat view).

11
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5. Use the + / - to further expand or collapse each item in the list. When a dataset is expanded, the hierarchy of

the dataset variables within the dataset is displayed.
Note that only the lowest level nodes can be selected in the dataset. More than one dataset variable may be

selected in a dataset and the variables do not need to be included in the same dataset.

© Note

When Show Hierarchy is toggled back to the flat view, the last item selected or expanded in the tree view is
displayed in the flat view.

6. Deactivate the Show Hierarchy checkbox to return to the default (flat) view. Only the shortest unique names are
displayed in the flat view.

Dataset Aliasing

The Dataset Alias Manager enables you to assign a shorter alias name to a dataset and use it within the Data Display
in place of the longer dataset path name. Aliases and their associated datasets can be saved and made available

12
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between sessions.

Using the Dataset Manager

Dataset alias names are managed using the Dataset Alias Manager in the Data Display. From within the Dataset Alias
Manager you can:

e Add a new alias
e Edit an existing alias
e Remove an existing alias

To access the Dataset Alias Manager from a Data Display window:
Choose File > Manage Dataset Aliases. The Dataset Alias Manager window appears.

=| Dataset Alias Manager:0
Make selection to add, edit, or delete a dataset alias

Add Alias... Pift AHan. . FarsErve SRR L] 4 Cancel

You can access the Dataset Alias Manager window from several other locations in the Data Display window.
From the Plot Traces & Attributes dialog box:

e Click the Manage Datasets button.

¢ Click the Advanced button, click the Variable Info button, then click the Manage Datasets button.

¢ Click the Trace Options button, then click the Trace Expression tab. Click the Variable Info button, then click the
Manage Datasets button.

From the Enter Equations dialog box:

e Click the Manage Datasets button.

To add a new alias to the Dataset Alias Manager window:

13
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1. Click the Add Alias button. The Add Dataset form appears.

—| Add Dataset:0
Alias: Dataset:
) I
Ok Cancel Browsse...

2. Click the Browse button and use the dataset browser to locate a dataset. Click the Add button in the browser
window to add the specified dataset to the Add Dataset form.

3. In the Add Dataset form, a unique alias name is supplied by default for newly selected datasets. You can choose
your own unique alias and override the default name by simply typing over it in the Alias field.

© Note

When choosing an alias name, try to select a unique name to avoid conflicts with existing aliases.

4. Click OK to add your new alias. Aliases are checked for unique names. If a conflict occurs, an message is
displayed asking you to resolve the conflict. Choose a different alias name or remove the existing alias in conflict.

5. After you have added the new alias to the Dataset Manager window, click OK in the Dataset Manager window to
save your changes.

To edit an existing alias from the Dataset Alias Manager window:

1. Select an alias in the Dataset Manager window and click the Edit Alias button. The Edit Alias form appears.
2. Modify the alias and/or dataset of the selected entry.
3. Click OK to implement your changes. The modified alias appears in the Dataset Manager.

To delete an existing alias from the Dataset Alias Manager window:

1. Select an alias in the Dataset Manager and click the Remove Alias button. A confirmation message appears
asking if you are sure you want to remove the alias.
2. Click OK to confirm removing the alias or Cancel to abort the process.

Saving a Data Display
There are three commands available for saving a data display: Save, Save As, and Save Copy As.

e Choose File > Save to save changes to the current data display window to an existing file. A file suffix of .dds is
automatically appended to a data display file. Note that .dds files should be saved in the <project_name>
directory.

e Choose File > Save As to save the current data display window to a new file and change the currently open
window view to the new file.

e Choose File > Save Copy As to save the current data display window to a new file and leave the currently open
window view of the original file.

14



Advanced Design System 2008

Exporting a Data Display Plot or List

Data displayed in rectangular plots, polar plots, Smith charts, stacked plots, and lists can be saved to a tab-delimited
ASCII file.

To export a data display plot or list to a tab-delimited ASCII file:

[y

Select one or more plots or lists.

2. Choose File > Export > Write selected item to tab-delimited ASCII. The Write Data To ASCII File window
appears.

3. Enter a filename then click OK. A file suffix of .txt is automatically appended to the selected file name.

Using a Template in Your Display

Templates are files that contain only the items that are placed in a display area. Templates enable you to store
pre-configured plots and other graphical items, which you can use in any data display. For example, you may have a
standard set of plots that you use in different projects. Rather than reinsert the plots and edit them for each data
display, you design it once and save it as a template. You can then add these plots to any data display window by
inserting the template.

Templates can include not only plots but traces, markers, annotation, or any other item that can be inserted in the
display area. The only thing that is not saved in a data display template is the default dataset.

To save a data display as a template:

1. Choose File > Save As Template in the Data Display window. The Component Library/Save Template Browser
appears.
2. In the Libraries list, select a directory in which to save the template.
e Product - This selection contains templates that are shipped with the product. Templates in this section are
located in $HPEESOF_DIR/circuit/templates
e User - This selection provides a location for personal templates. Templates in this section are located in
$HOME/hpeesof/circuit/templates.
e Customized - This selection is where site specific templates should be placed. This category may not appear
in the browser if there are no templates stored in this location. Templates in this section are located in
$HPEESOF_DIR/custom/circuit/templates.

© Note

The Product and Customized directories are typically specified as read only so you may not have permissions
to save to these directories.

3. Supply a name and click OK. The extension .ddt is automatically appended to filenames of data display
templates.

15
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1. From the Data Display window, choose Insert > Template.
2. Navigate to the name of the template file that you want to use.

3. Click OK.

To insert a data display template in a new data display:

Choose Insert > Template.

e

Click OK.

From a Data Display window, choose File > New.

Navigate to the name of the template file that you want to use.

Built-in Data Display Templates shows a number of built-in templates that are available to facilitate setting up

common measurements.

Template

BJT_curve_tracer
FET curve_tracer
S_ParamsQuad_Smith_PIr

S_Params_Quad_dB_Smith

S_Params_Quad_dB_Smith_Log

S_ParamsLargeSignal

SProbeT
SProbePairT

S 21 11 wZoom
Circles_Ga_NF
Circles_Ga_Stab
Circles_Stability
HB1Tone
HB1ToneSwptFreq

HB1ToneSwptPwr

Description
BJT curve tracer with power consumption calculation.
FET curve tracer with power consumption calculation.
S11, S22 on Smith Charts; S12, S21 on polar plots.

S11, S22 on Smith Charts; dB(S12), dB(S21) on rect.
plots.

S11, S22 on Smith Charts; dB(S12), dB(S21) on rect.
Log plots.

Displays the S-parameters as a function of frequency
and input signal power, as simulated by the
S_ParamsLargeSignal schematic template. Is also
computes the Rollett stability factor, K, and group delay
from these S-parameters.

Use with SProbeT schematic template

Use with SProbePairT schematic template

dB(S21), S11 with "zoomed-in" frequency ranges.
Available gain and noise figure circles.

Available gain and stability circles.

Source and load stability circles and K.

Output power, gain, and harmonic distortion.

Output power, gain, harmonic distortion vs. frequency.

Output power, gain, harmonic distortion vs. power.

16
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HB2Tone Output power, gain, TOI.

HB2ToneSwptPwr Output power, gain, TOI vs. power.
MixConvGainNF Mixer conversion gain, NF, noise contributors.
MixTOI Mixer output power, conversion gain, TOI.
SP_NWA_ T Use with SP_NWA_T schematic template
SP_NWA_LogT Use with SP_NWA_LogT schematic template
SP_NWA_4PortT Use with SP_NWA_4PortT schematic template
SP_NWA_4PortLogT Use with SP_NWA_4PortLogT schematic template
SP_NWA_4PortBiasT Use with SP_NWA_4PortBiasT schematic template
SP_NWA_4PortBiasLogT Use with SP_NWA_4PortBiasLogT schematic template
SP_FET_T Use with SP_FET_T schematic template

SP_DiffT Use with SP_DiffT schematic template

SP_BIT_T Use with SP_BJT_T schematic template
LinearStepRespT Use with LinearStepRespT schematic template
LinearPulseRespT Use with LinearPulseRespT schematic template
DC_FET_T Use with DC_FET_T schematic template
DC_BIT_T Use with DC_BIJT_T schematic template
ConvStepRespT Use with ConvStepRespT schematic template
ConvPulseRespT Use with ConvPulseRespT schematic template

Viewing the Display Area

To aid in viewing your work, the following commands are available from the View menu and as buttons on the toolbar.

Command Button Description
View > View All View All View all graphical objects on the
display area
View > Redraw View Redraw View Redraw the current view in the

display area

View > Zoom > Zoom Area Zoom Rectangle Zoom in so the selected area fills the
window
View > Zoom > Zoom In x2 Zoom x2 Zoom in to make objects appear

twice as large

17
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View > Zoom > Zoom Out x2 Zoom x1/2 Zoom out to make objects appear

twice as small
View > Zoom > Actual Size Actual Size View objects at actual size

Like other windows in the product, the Data Display window has scroll bars along the window edges so you can pan
across the display area.

Scrolling through Lists and Traces

The scroll buttons in the toolbar enable you to scroll through long lists of data in listing columns. This also works with

other types of plots. If you turn off automatic scaling to display smaller portions of data on a plot, you can use these
buttons to move data horizontally across the plot.

To use the scroll buttons:

1. Choose View > Scroll Data.
2. Select the list or trace you want to scroll.

3. Select scroll buttons as shown in the figures below.
Lizting Column

IS | | | o

I
| Scroll fo the bottomn of the it
Scroll down one page

Scrolldown one line
Scroll up one line
Scoll up one page
Scroll to the top of the list

Traces

I | [ o | | o

I
| Scmoll to the and of the trace
Scrollback by one step cize

Scrollback by one grid zaction
Scmoll forward by one grid =ection
Scroll lorward by one step =ize

Scnoll to the start of the trace

Editing a Data Display

18
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You can make changes to the data display as you work. The typical sequence is to select the object you wish to edit,
then perform the operation. In some cases, you can select the command first and then the object. If an edit command

has this capability, it is noted.

Selecting Objects
enclosed with a dashed outline and handles. A selected trace has a thicker, dashed appearance.

.'/ ‘\I —— A selected object

You can select one, several, or all objects on a data display area to facilitate editing your work. A selected item is

||I
|
i
T | T
This trace is selected

This trace is not selected
Action

The following select options are available.
Click the object.

Option
Shift+click the objects.

Select one object
Select several objects
Choose Edit > Select All.

Select all objects

Deselecting an Object
If you want to deselect an object, click anywhere on the display area that is not occupied by the object

Moving Objects
19
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You can move an object anywhere on the display area.
To move an object:

1. Select the object.

2. Drag the object to the new position.

3. The object remains selected and can be moved again.
To move several objects:

1. Select the objects.
2. Hold down the Shift key and drag the objects to the new position.

@& Hint
You can use the automatic panning feature by dragging an object to the edge of the data display window.
While dragging an object, the window will automatically pan when the cursor is placed at the very edge (within
a few pixels) of the display area. Note that you must be within the window, not the window border or scroll
area.

Scaling Objects

To scale an object:

1. Select the item.
2. Drag one of the object handles to reduce or enlarge the object to the desired size.

P ——————

By dragging a handle,
the cbjectcan be enlarged
[a= shown) or reduced.

Arranging Objects

Arranging objects is useful when you have overlapping objects. Select the object of interest and choose an arranging
option.The following options are available.

Command Description

Edit > Arrange > Move to Front Displays the selected object in front of all other objects
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Edit > Arrange > Send to Back Displays the selected object behind all other objects

Edit > Arrange > Move Forward Exchanges the positions of the selected object and the
object in front of it

Edit > Arrange > Move Backward Exchanges the positions of the selected object and the
object behind it

Activating or Deactivating Objects

If you want to selectively deactivate a plot or an equation in a data display:

1. Select the object or objects.
2. Click the Toggle Activation of Object button on the toolbar or choose Edit > Toggle Activation.

=

Once an object is deactivated, a red 'X' is drawn through the object to indicate that it has been deactivated. The
object will not respond to any dataset updates while inactive. Equations are also removed from the variables list
when inactive. This feature can be helpful in troubleshooting or when trying to speed up the re-draw process.

To activate a previously deactivated object:

1. Select the object or objects.
2. Click the Toggle Activation of Object button on the toolbar or choose Edit > Toggle Activation.

Cutting, Copying, Pasting, and Deleting

You can perform cut, copy, paste, and delete operations in the Data Display much like other windows in the product.
First select an item in the display area, then choose a command.

Command Action Keyboard Shortcut
Edit > Cut Erase the selected object from the CTRL + X
display area and place it on the
clipboard
Edit > Copy Place a copy of the selected object CTRL + C

on the clipboard

Edit > Paste Place the object on the clipboard in CTRL + V
the display area

Edit > Delete Erase the selected object without DEL
placing it on the clipboard
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Setting Data Display Preferences

The appearance of each type of graphical object can be customized in a humber of ways, depending on the type of
object. Objects are drawn initially using program defaults, but you can change these characteristics and use them as
new defaults for all projects, or you can save your settings to a file for use in an individual project.

To set new defaults for all projects:

Choose Options > Preferences.

Modify any or all settings as desired and click Save.

Save the modified settings in $HOME/hpeesof/config/ddsdefaults.ael.
Click OK.

Sl

© Note

Preferences are saved when you exit the program. These settings will be the defaults used when you restart
the data display.

To save preferences for an individual project:

1. Choose Options > Preferences.
2. Modify any or all settings as desired and click Save.
3. Type the desired filename and click OK.

To read a preferences file:

1. Choose Options > Preferences.
2. Click Read. Navigate to the preferences file, then select the file. Objects will be drawn using the new preferences.
3. Click OK.

You can save different sets of preferences to different files. You can update a Data Display window at any time with a
new preferences file. Reading in new preferences overwrites the existing ones.

For information on the characteristics you can change for the different types of objects, refer to the appropriate
chapter.

Preferences to be Edited Refer to
Plots and lists Plots and Lists
Traces Traces
Equations Equations

Lines, polylines, rectangles, circles, polygons, and text Annotating the Data Display

Markers Markers
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The Data Display's print functions enable you to print the current page, selected item, or all pages. The print functions
are available from the File menu. For information on setting up printers, refer to the ADS "Schematic Capture and

Layout" documentation.

Locating Data Display Examples

Many of the designs in the ADS Examples directory include data displays. The data displays use a variety of plots,
trace formats, markers, and many include equations. These examples can help you design your own data displays so
that you can analyze simulation data effectively. A list of some of the examples is given below.

Examples Subdirectory

Com_Sys

DSP

Project

BER_prj

cdmafilter_prj

DeltaSigma_prj

gsm_prj

IS95_prj

rfsystem_prj

widebandcdma_prj

CHBT_TH_prj
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Data Displays

Displays bit-error rate data in lists,
as time-domain waveforms, and on
scatter plots.

Displays the frequency response, unit
step response, and unit pulse
response of a filter.

Displays the magnitude of the output
of a delta-sigma modulator on a
rectangular plot.

Displays a variety of waveforms
generated in a basic GSM 0.3 GSM
system, including the output data,
recovered clock, recovered carrier,
modulated spectrum, and MSK
trajectory.

Displays the spectrum of a simple
1S95 forward channel carrier on a
rectangular plot.

Displays a wide range of simulation
results, including TOI in spectral
format, budget data in lists, and
channel spectra.

Displays waveforms generated in a
wide CDMA modulator.

Displays a wide range of results
simulating the output from a Sine
wave.
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Momentum Balun_prj

BoxExample_prj

Coupled_Stubs_prj
CPW_line_prj

Hairpin_filter_prj

Low_pass_filter_prj

Lp4_8Ghz_prj

MW_ Ckts LNA_prj

mw_filter_prj

Customizing Keyboard Shortcuts

Compares S-parameters of a balun in
magnitude and phase on rectangular
plots.

Compares the S-parameters from the
box example to a set of reference
S-parameters.

Displays S-parameters in magnitude
and phase on rectangular plots.

Displays S-parameters in magnitude
and phase on rectangular plots.

Displays the response of the filter.

Compares measured S(2,1) data to
Momentum and Advanced Design
simulations.

Identifies the numerical noise floor of
the filter.

Displays a wide range of results from
the simulations of a low-noise
amplifier, including the S-parameters
of an optimized amplifier displayed
using lists, Smith charts, and
rectangular plots; sweeps of
collector-emitter voltage and
collector current that display similar
to a curve tracer; and the amplifier
output from multiple input tones,
displayed in spectral format.

Displays the S-parameters of a 12
GHz bandpass filter, scaled for
display on a rectangular plot.

You can redefine default keyboard shortcuts as well as create new ones. These shortcuts are maintained individually

for the different windows.

To change or add a keyboard shortcut:

1. Choose Options > Hot Key/Toolbar Configuration and click the Hot Key tab in the dialog box that appears.
2. Select the menu name or menu/command sequence from the Category list box.
3. Select the command from the Item list box. If a shortcut currently exists for the item, the current assignment is
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displayed.
Editt

Undo Last Command
Current Hot Key: OCiH+Z

4. Select the modifier key(s)-Ctrl, Alt, Shift-and type the letter(s) you want to use in the Key field (UNIX is
case-sensitive; the PC is not). If the combination you choose is currently assigned to another command
sequence, you are warned and given the choice to proceed or to select another key sequence.

 Note

If you use Alt as the modifier key, and a letter that is already assigned as an accelerator for a menu (see the

underscored letters on the menu bar), the menu accelerator is replaced by your custom shortcut (with no
warning).

5. To replace the assignment with your own choice, continue, otherwise choose a new key combination and click
Apply. When you are through making all keyboard changes, click OK to dismiss the dialog box.

Shortcut Keys

Shortcut Keys lists the default keyboard shortcuts found in the Data Display windows. Some of the ADS individual

tools also offer the ability to customize shortcut keys. For details on customizing these shortcuts, refer to the section,
Customizing Keyboard Shortcuts.

Shortcut Keys

File Commands

New Ctrl + n
Open Ctrl + o
Save Ctrl + s
Print Ctrl + p

Edit Commands

End Command Esc

Undo Ctrl + z
Redo Ctrl + vy
Cut Ctrl + x
Copy Ctrl + c
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Paste Ctrl + v
Delete Del
Select All Ctrl + a
View Commands

View All Ctrl + f

Window Commands

New Ctrl + Shift + D
Close Ctrl + F4

Help Commands

What's This? Shift + F1
Topics and Index F1

Sorted Default Shortcut Keys lists the default shortcut keys, in alphabetical order, to enable you to see at a glance
which ones are in use. If you attempt to assign any of these to other commands, you are warned and given the choice

to proceed or to select another key sequence (see footnote for Alt).

Sorted Default Shortcut Keys

Ctrl

Ctrl + Shift

Shift

Alt

Others

Ctrl + a

Shift F1

Del

Ctrl + c

Esc

Ctrl + f

F1

Ctrl + f4

Ctrl + n

Ctrl + o

Ctrl + p

Ctrl + s

Ctrl + v

Ctrl + x

Ctrl +y

Ctrl + z

warning.

If you use Alt as the modifier key (when creating custom shortcuts), and a letter that is already assigned as an
accelerator for a menu (listed in this table), the menu accelerator is replaced by your custom shortcut with no
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Configuring Toolbars

By default, the toolbar in each data display window contains:

e Buttons for Previous Page and Next Page.

¢ A button for activating or deactivating plots and equations.
e A drop-down list for selecting the default dataset.

e Buttons used to scroll through lists and traces.

¢ A button for autoscaling your plot.

e Buttons used to zoom in and out of data.

¢ A button used to start the Data File Tool.

You can reconfigure these default toolbars and create your own to better meet your design needs ( Options > Hot
Key/Toolbar Configuration ).

Customizing an Existing Toolbar

To reconfigure an existing toolbar:

1. Choose Options > Hot Key/Toolbar Configuration and click the Toolbar tab in the dialog box that appears.
2. In the Toolbar Group list box, select the name of the toolbar you want to change.

Toolbar Group

DDS tools 2

3. To add or delete icons, use one of the following methods:
e To delete an icon from the toolbar, select the associated command in the Tool Item list box, and click the

Cut button.
Tool Item Tool Item
—————— View Al
Viewr All Joom %72
Select the Zoom x1/2
Zoom x2 command Actual Size
oomxlfee 0 ______
Actual Size PrevPage
“““ HextPage

&idd | Cut Click the Cut button

e To add an icon to the toolbar, select the appropriate menu/command sequence from the Menu Category list
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box, select the command from the Menu Item list box, and click the Add button. The command is added to
the Tool Item list box.

Menu Category
Edit\uranget Menu ltem
EditiTexth View Al |
i iews All Tool Hem
Edlt‘nnxt‘i.ant‘L e e
ey Zoom Inx2 e— 1
om In %2
View\Scroll Data Zoom Out x2 View All Bitmap Name
Zoom Rectangle
ViewiZoom Data’ | oy Size g o ——)
Insertl Zoom x2
Hew Window
Toolbar R Button +§+
Actual Size i
Item Palette

When you select a command, its default
bitmap is displayed

Hint

When you add a button to the toolbar, its position relative to the other buttons is determined by its position in
the Tool Item list box. Before you click the Add button, be sure to highlight the command that the new
command should precede. In this example, Zoom Rectangle was highlighted before the Add button was clicked
so that View All would come before Zoom Rectangle.

4,

If you want to edit another toolbar, click Apply to effect these changes and begin the process again. When you
are through making changes to the toolbars, click OK.

Creating a New Toolbar

To create a custom toolbar:

1. Choose Options > Hot Key/Toolbar Configuration and click the Toolbar tab in the Configuration dialog box that
appears.
& Hint
The position of the new toolbar, relative to the position of any existing toolbars, is determined by its position in
the Toolbar Group list box; the new name is added below the name that is highlighted when you click the Add
button. For example, if you keep both default toolbars and want to add a third one below them, highlight the
bottom one before you click the Add button.
2. Supply a name in the Toolbar Name field and click Add. The name you supply is added to the Toolbar Group list
box.
3. Select the desired Menu Category, select the desired Menu Item and click the Add button above the Menu Item.
The command name is added to the Tool Item list box.
4. When you are through making changes to this toolbar, click Apply to effect the changes.
5. When you are through making changes to all toolbars, click OK.
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A variety of plot types can be inserted into a data display so that you can view data in different ways. The plot types

are shown in the following table.

Rectangular

Polar

Smith Chart

Stacked

List

Plot Type

Description

Displays scalar data in a linear or logarithmic format.

Displays real and imaginary components of complex data

on a polar plot.

Displays real and imaginary components of complex data

on a Smith chart.

Displays a vertical stack of rectangular plots, each with
the same x axis and different y axes.

Displays data in columnar format.

You can have more than one plot in a single window. Some plot examples:

=

rectangular —

Curwe _Frocer,

Smith chart

Inserting Plots

B _ord_Soorome. 501,17

oo DDDKHT 1o 1, DDDGHT)
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To insert a plot, do the following:

1. Choose Insert > Plot or select a plot type from the palette.

k @ Rectangular Flot

Polar Plot @ @ Smith Chart
Stacked Plot % =

>
o] =174

2. Position the pointer on the display area. A ghost image of a rectangle is attached to the pointer. It indicates the
position and size of the plot.
o If you are satisfied with the size and position of the rectangle, click the mouse.
o If you want to customize the size of the plot, position the pointer where you want the upper-left corner of
the plot, then drag the mouse. When the rectangle is the desired size, release the mouse.
3. The Plot Traces & Attributes dialog box appears. Plot types are shown across the top and the selected plot type is
highlighted. To change to a different plot type, click the button that corresponds to the plot type that you want.
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Ogptions for the selected plot type

=| Plot Traces & Attributes:4

FPlot Type | Plot Options

HH 123 %
@ B G667 8
Plot types ! ' ' |

Datasets and Equations Traces

Finizshedimp Vraos (hitions.,.,

ForiZ(z) 4B(S(2,2))
:“ il dB(S(1,1))
Addtraces — 8(1,1) ARV

3(1,2)

5(2,1) cac el ¢

5(2,2)

Sopt

te

te(1)

te(2) Advanced...

_| Show Hierarchy

Manage Datasets...

OK Cancel Help §

4. The lower part of the dialog box contains selections for adding traces to the plot. These are described in Traces.

5. Click the Plot Options tab to set up the plot. Options include adding titles and scaling data. Changing options are
discussed in the next section.

6. Click OK to dismiss the dialog box and insert the plot.

Editing Plots

The title, grid, scale and other attributes can be can changed for an existing plot. Any changes that you make will only
affect the currently selected plot. To change properties for all plots added subsequently, refer to Setting Plot
Preferences.

© Note

Plot options for the chosen plot type are displayed automatically. If the plot options do not seem correct, click
the Plot Type tab, click the Plot button corresponding to the type of plot you want, then reselect the Plot
Options tab.
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To change the plot type:

1. Double-click the plot.
2. In the dialog box that appears, select a new plot type from the Plot Type tab.

To edit various plot characteristics:

1. Double-click the plot of interest, or choose Edit > Item Options , and select the Plot Options tab.
2. When you are through editing plot characteristics, click OK to dismiss the Plot Traces & Attributes dialog box and
save the changes.

Most plots use two axes but you can add an additional axis to rectangular plots. To add an additional axis to your
rectangular plot:

1. From the Plot Options tab, select an axis from the Select Axis list box and click Add Axis.
2. In the dialog box that appears, enter a name for the new axis, select the desired orientation and click OK.

To add a title above a plot or edit an existing title:

Noise Power Spectral Density— phttie

I 000E-18

1. 500E=-18  — —

1. 000E-18  —

H.o000E—1%  —

.owerspechensg

0. 000D T T T
L] LA 1] A1 IRI

heisefreg, MHz

1. From the Plot Options tab, enter the desired title in the Title field.
2. To change the font, size or color of the title, click More and change the characteristics as desired in the dialog
box that appears, and click OK.

The names of the variables that are displayed on a plot appear along the axes of a plot. The nhames of the independent
and dependent variables are displayed on the x and y axes, respectively. You can format the text along both axes and
the numbers on a single axis.

Plots can display the data from multiple independent variables. Each time a trace is added to a plot, a different color is
used to draw the trace. The color of the label for that trace matches the color of the trace to help you identify the
source of the data.
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The figure shown next displays default axis labels. Note that if you give descriptive names to schematic items such as
named connections and variables, as well as to data display equations, you may not need to change the default axis
labels.

SDE-C t rum=dBm(vif)

EBroodbond Spectrum

¥
- 4
=100 —
e 14
2 =200 —
o =00
[=] o
W
-500 4 14— N
¥ 1 2 3 4 5 & 7 ) 9
axicbbee ——— freq, GHz

To format a plot's axis labels and numbers:

1. Select the desired axis from the Select Axis list box and type the desired label in the Axis Label field.

 Note

By default, the names of the independent and dependent variables are displayed as labels along the axes of a
plot. If you enter text in the Axis Label field, the variable names along the selected axis will be replaced by this
text.

2. Click More (to the right of the Axis Label field) to format the label characteristics. The Axis Label dialog box
appears.
3. In the Axis Label dialog box, select a Format for the humbers along the axis:
e Auto A default format is automatically chosen, based on the type of data to be displayed along the axis.
o Full All digits before the decimal are displayed (i.e., 1530000).
e Scientific Numbers are displayed in scientific format (for example, 1000 is displayed as 1.00e3).
¢ Engineering Numbers are displayed using engineering notation. For example, frequency values end in Hz.
Additionally, numbers are displayed in powers of 10 3 (for example, 1000 Hz is displayed as 1.0 kHz).
¢ Hex Numbers are displayed in hexadecimal (base 16).
¢ Octal Numbers are displayed in octal (base 8).
¢ Binary Numbers are displayed in binary (base 2).
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4. In the field to the right of the Format drop-down list, enter the desired # of Decimal Digits (for Full) or
Significant Digits (for Scientific, Engineering, Hex, Octal, Binary). When Auto is the selected Format, the number
of digits after the decimal is chosen automatically; any value in the # of Decimal Digits field is ignored.

5. Select the desired font from the Font Type list.

6. Select the desired font size from the Font Size list.

7. Click the Color bar to select a new text color and click OK.

) Note

If you set this to a color other than black, all labels will be displayed in this color.

8. Click OK to dismiss the Axis Label dialog box.

The scale on rectangular and stacked plots and Smith charts can be set to linear or logarithmic format. The scale can
also be different along each axis.

yaxis in linear zcale

i}

om0 —
=R —

—dp) —|
E E o —60—
cE e
oo =80 —
-::-:: =100 = ¥ axis in logarith mic
oo = -

150 — =cale
~140 l l l l l
1 1E1 1EZ 1E3 1E4 1ES 1Eé

noisefreg, Hz
To change the scale format, do the following:
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Select either Linear or Log as the Scale type.

Select the desired axis from the Select Axis list box.
Select the Auto Scale option.

Select the other axis, as appropriate, and change its scale in a similar manner.

optimum view of the data.

The data display automatically scales plot axes to display the entire range of a variable on the plot and give an

of data.

e For rectangular and stacked plots, you can manually set the start and endpoints of a plot to show a limited range

variable.

e On polar plots and Smith charts, you can specify the radius of the plot and the range of data for the independent

 Note

You can scroll through traces that have more data than what is displayed on the plot. Select the trace, then

Scrolling through Lists and Traces.

use the scroll buttons on the toolbar to scroll through the trace. For more information on scrolling, refer to
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To manually scale a plot, do the following:

The full range of
data can zometimez
ba difficult to view

Viewing a portion
of the data can
faciltate analy=i=

1. Select the axis that you want to scale from the Select Axis list box.
2. Deselect the Auto Scale option.

3. Enter the starting value for the selected axis in the Min field.
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4. Enter the ending value for the selected axis in the Max field. For Smith plots, this is the maximum radius of the
plot.

5. Enter the incremental value in the Step field (rectangular, stacked, and polar plots only). Grid lines are drawn on
this axis at these intervals.

6. For polar and Smith charts only, to limit the range of data displayed, deselect Display All and enter the minimum
and maximum values in the Start and Stop fields, respectively.

 Note

For Smith charts only, the coordinates can be changed by selecting Impedance, Admittance, or Both from the
Coordinate drop-downlist.

The type, thickness, and color of lines in a grid can be changed. On rectangular plots and stacked plots, horizontal
lines and vertical lines can have different properties. The same is true for impedance and admittance lines on Smith
charts.

grid lineson the x axiz

grid lines.
on tha
— ¥ axi

| I I
ZAg el A0 a1 IRI

To edit a plot's grid:

1. For rectangular and stacked plots, select an axis from the Select Axis list box. Select the X axis to format the
vertical lines of the grid; select the Y axis to format horizontal lines. For stacked plots, the Y axis on each plot
must be formatted individually.

2. Click Grid. If the plot is a rectangular, polar, or stacked rectangular plot, you can modify the grid attributes. For
Smith charts, you can edit either the impedance or admittance lines.

3. Select a line type (solid, dot, dash, etc.) from the Type drop-down list.

4. Select a line thickness either by using the slider or by entering a value in the Points field. Thickness can range
from 0 to 10 points. The larger the value, the thicker the line will be drawn.

5. Click the Color bar, select a new color, then click OK.

6. Click OK to dismiss the Grid dialog box.

You can remove the grid from a plot. To remove the grid:

1. Click Grid. The Grid dialog box is displayed.
2. Deselect the Display Grid option.
3. Click OK to dismiss the Grid dialog box.
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Editing

Plot Axis Scales
The scale of a plot axis can be changed directly from a rectangular, polar, or stacked rectangular plot by using the

following steps:

1. Click on the first or last number label on the axis and enter a new value (on polar plots, you can only change the

outer-most number label).

 Note

The value you enter in the number label depends on the unit of measure used for the axis. For example, if the
x-axis uses "freq (GHz)" as the unit of measure, typing 9 in the number label would result in the label having a

value of "9 GHz" rather than "9".

2. Press Return or click anywhere in the Data Display window to make the scale change take effect.

Deleting Plots

To remove a plot, do the following:

1. To delete a single plot, single-click on the plot. For multiple plots, hold the Shift key down and single-click on

each plot of interest.
2. Press the Delete key or choose Edit > Delete.

© Note

If you just want to disable a plot temporarily, refer to Activating or Deactivating Objects.

Setting Plot Preferences

Plot preferences set the default plot properties and determine the appearance of a plot in the display area. Preferences
affect all plot types and include setting the font type, size, and color for titles and axis labels; the numeric format of

axis labels; and the line type, width, and color of grids.

Plot preference changes will apply to all plots created after the changes were made and saved. To change the
properties for an existing plot, refer to Editing Plots.

Data display preference settings can be saved for reuse by creating a preferences file. For more information on how to

create and use such a file, refer to Setting Data Display Preferences.

To set plot preferences, use the following steps:
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1. Choose Options > Preferences.
2. The Preference dialog box appears. Click the Plot tab followed by the Main tab.
3. To set the plot title attributes, do the following:

e Select a font from the Font Type list.

e Select a font size from the Font Size list.

¢ Click the Text Color bar, select a color, then click OK.

4. The axis numbers can be formatted for plots that use more than one axis. This is done as follows:

e Select an axis label format from the Label Format list. The choices are:

Auto A default format is automatically chosen, based on the type of data to be displayed along the axis.
Full All digits before the decimal are displayed (i.e., 1530000).

Scientific Numbers are displayed in scientific format (for example, 1000 is displayed as 1.00e3).
Engineering Numbers are displayed using engineering notation. For example, frequency values end in Hz.
Additionally, numbers are displayed in powers of 10 3 (for example, 1000 Hz is displayed as 1.0 kHz).
Hex Numbers are displayed in hexadecimal (base 16).

Octal Numbers are displayed in octal (base 8).

Binary Numbers are displayed in binary (base 2).

e To the right of the Format drop-down list, enter the desired # of Decimal Digits (for Full) or Significant
Digits (for Scientific, Engineering, Hex, Octal, Binary). When Auto is the selected Format, the nhumber of
digits after the decimal is chosen automatically; any value in the # of Decimal Digits field is ignored.

5. To format axis label text, click the Label button and make the following selections from the Axis Labels dialog
box:

e Select a font from the Font Type list.

¢ Select a font size from the Font Size list.

e Click the Text Color bar, select a new color, then click OK.

© Note

If you set this to a color other than black, all labels will be displayed in this color.

e Click OK to dismiss the Axis Label dialog box.
6. To set grid preferences, click Grid and make the following selections in the Grid dialog box:
¢ Select a line pattern from the Type list.
e Select a line thickness either by using the scroll bar or by entering a value into the Points field. Thickness
can range from 0 to 10 points. If 0 points is selected, a very thin line is drawn.
e Click the Color bar, select a new color, then click OK.
e Select a Smith chart admittance line pattern from the Type list.
e Select a Smith chart admittance line thickness by using the scroll bar or entering a value into the Points
field. Thickness can range from 0 to 10 points. If 0 points is selected, a very thin line is drawn.
e Select a Smith chart admittance line color by clicking the Color bar, selecting a new color, then clicking OK.
e Click OK to dismiss the Grid dialog box.
7. To set the axis scale for linear and stacked plots, click the Linear, Stack tab and select Linear or Log.
8. To set the coordinates used on Smith charts, click the Smith tab and select Impedance, Admittance, or Both from
the Coordinate list.
9. Click OK to dismiss the Preference dialog box and save the changes.

Inserting Lists
To insert a list, do the following:
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1. Select List from the palette or choose Insert > Plot.

>

— List
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Ol |/ |E|& [

2. Position the pointer on the display area. A ghost image of a rectangle is attached to the pointer. It indicates the
position and size of the list.
If you are satisfied with the size and position of the rectangle, click the mouse.
If you want to customize the size of the list, position the pointer where you want the upper-left corner of the list,
then drag the mouse. When the rectangle is the desired size, release the mouse.

3. The Plot Traces & Attributes dialog box appears. Plot types and list icon are shown across the top. If the List icon
is not highlighted, select it.
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4. Click the Plot Options tab to set up the list. Options are provided for formatting the data. Changing list options
are discussed in the next section.
5. Click OK to dismiss the dialog box and insert the list.

Editing Lists

Except for titles, lists have options that are not common to the other plot types. You can change these list settings:

Numeric format of data displayed in lists

Text format of data, such as font type and color
Format of the lines that outline a list

Display of column headings

Display of data in table format
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Any changes that you make will only affect the currently selected list. To change the properties for all subsequently
created lists, refer to Setting List Preferences.

To edit a list, do the following:

1. Double-click on the list.
2. The Plot Traces & Attributes dialog box appears. Click the Plot Options tab.
3. To specify the numeric format of the data, do the following:
e Select a format for the data from the Format drop-down list. The choices are:
Auto A default format is automatically chosen based on the type of data displayed.
Full All digits before the decimal are displayed (for example, 1530000).
Scientific Numbers are displayed in scientific format. For example, 1000 is displayed as 1.00e3.
Engineering Numbers are displayed using engineering notation. For example, frequency values end in Hz.
Also, numbers are displayed in powers of 10 3 (1000 Hz is displayed as 1.0 kHz).
Hex Numbers are displayed in hexadecimal (base 16).
Octal Numbers are displayed in octal (base 8).
Binary Numbers are displayed in binary (base 2).
e To the right of the Format drop-down list, enter the desired # of Decimal Digits (for Full) or Significant
Digits (for Scientific, Engineering, Hex, Octal, Binary). When Auto is the selected Format, the nhumber of
digits after the decimal is chosen automatically; any value in the # of Decimal Digits field is ignored.

 Note

If columns are too narrow to display data correctly, an ellipsis (...) appears in the data. To widen the columns,
select the list and drag the lower-right or lower-left handle horizontally.

4. To change the type font, size, and color of list text, do the following:
e Click Listing Text.
e Make the following selections from the Column Listing dialog box:
Select a font from the Font Type list
Select a font size from the Font Size list.
Click Text Color, select a color, then click OK.
e Click OK to dismiss the Column Listing dialog box
5. The type, color, and thickness of the line around the perimeter of a list can be changed by following
these steps:
¢ Click Outline.
e Make these selections from the Outline dialog box:
Select a line pattern from the Type list.
Select a line thickness either by using the Thickness scroll bar or by entering a value into the Points field.
Click Color, select a new outline color, then click OK.
¢ Click OK to dismiss the Outline dialog box.
6. Column headings display the name of the variable that is the source of the data. They are displayed by default.
To remove them, deselect Display Column Headings.
7. Table format is only used to display data with two independent and one dependent variable. It is chosen
automatically. To disable table format, select Suppress Table Format.
8. If you use table format, you can also transpose the data, which reverses the position of the two independent
variables. This is recommended if the independent variable data listed across the table has more values than the
independent variable data listed down the table. Transposing would give you a longer, narrower table.
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To transpose tabular data, select Transpose Data.

In the example below, the two independent variables are VCE and IBB. The measured data is IC.i. The first list is in
table format, which is the default and generally the best way to display data. The second list uses table format and
transposed data, note the change of position between VCE and IBB. The third list is in suppressed table format, both
independents are displayed in one column.

1. Click OK to dismiss the dialog box and save the changes.

Deleting

Lists

To remove a list, do the following:
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1. To delete a single list, single-click the list. For multiple lists, hold the Shift key down and single-click on each list
of interest.
2. Press the Delete key or choose Edit > Delete.

 Note

If you just want to disable a list temporarily, refer to Activating or Deactivating Objects.

Setting List Preferences

List preferences set the default list properties and determine the appearance of a list in the display area. List
preference changes will affect all lists created after the changes were made and saved. To edit the properties of an
existing plot, refer to Editing Lists.

To set list preferences, follow these steps:

1. Choose Options > Preferences.
2. The Preference dialog box appears. First select the Plot tab followed by the List tab.
3. To specify the numeric format of the data, do the following:
e Select a format for the data from the Format drop-down list. The choices are:
Auto A default format is automatically chosen based on the type of data displayed.
Full All digits before the decimal are displayed (i.e., 1530000).
Scientific Numbers are displayed in scientific format (for example, 1000 is displayed as 1.00e3).
Engineering Numbers are displayed using engineering notation. For example, frequency values end in Hz.
Also, numbers are displayed in powers of 10 3 (for example, 1000 Hz is displayed as 1.0 kHz).
Hex Numbers are displayed in hexadecimal (base 16).
Octal Numbers are displayed in octal (base 8).
Binary Numbers are displayed in binary (base 2).
e To the right of the Format drop-down list, enter the desired # of Decimal Digits (for Full) or Significant
Digits (for Scientific, Engineering, Hex, Octal, Binary). When Auto is the selected Format, the nhumber of
digits after the decimal is chosen automatically; any value in the # of Decimal Digits field is ignored.

 Note

If columns are too narrow to display data correctly, an ellipsis (...) appears in the data. To widen the columns,
select the list and drag the lower-right or lower-left handle horizontally.

4. To change the type font, size, and color of list text, do the following:
e Click Listing Text.
e Make the following selections from the Column Listing dialog box:
Select a font from the Font Type list
Select a font size from the Font Size list.
Click Text Color, select a color, then click OK.
e Click OK to dismiss the Column Listing dialog box
5. The type, color, and thickness of the line around the perimeter of a list can be changed by following these steps:
¢ Click Outline.
e Make these selections from the Outline dialog box:
Select a line pattern from the Type list.
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Select a line thickness either by using the Thickness scroll bar or by entering a value into the Points field.
Click Color, select a new outline color, then click OK.
e Click OK to dismiss the Outline dialog box.
6. Column headings display the name of the variable that is the source of the data. They are displayed by default.
To remove them, deselect Display Column Headings.
7. Table format is only used to display data with two independent and one dependent variable. It is chosen
automatically. To disable table format, select Suppress Table Format.
8. If you use table format, you can also transpose the data, which reverses the position of the two independent
variables. To transpose tabular data, select Transpose Data.
9. Select a complex data format from the Complex Data List. The choices are:
Real/Imaginary Real and imaginary values.
Mag/Degrees Magnitude and angle in degrees.
dB/Degrees The dB value and angle in degrees.
Mag/Radians The magnitude and angle in radians.
dB/Radians The dB value in radians.
10. Click OK to dismiss the Preference dialog box and save the settings.

Using Legends

Legends are provided in Data Display to help you quickly identify specific traces in a plot. Often times, sub-trace labels
will appear placed on top of each other making it difficult, if not impossible, to identify values assigned to a particular
sub-trace. Legends can also help to identify a traces associated with specific expressions.

Legends are especially helpful in ADS tuning sessions where it is important to keep track of the various traces
associated with specific tuning parameters. For more information on ADS tuning, refer to Tuning, Optimization, and

Statistical Design.

Inserting a Legend

There are two methods available for inserting a legend. The first method is the pre-select method and enables you to
add legends to more than one plot at a time. The second method, or post-select method only allows you to add one
legend to a single plot.

To insert a legend using the pre-select method,

1. Click the plot that you want to attach a legend to.

2. Choose Insert > Plot Legend. The legend object always appears to the right of the plot. You can then move the
legend to any desired location.
Examples of Different Trace Formats shows an example of a plot that uses different trace formats displayed in a
legend.
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Examples of Different Trace Formats

To insert a legend using the post-select method,

1. Choose Insert > Plot Legend.
2. Click the plot that you want to attach a legend to. The legend object always appears to the right of the plot. You
can then move the legend to any desired location.

Deleting a Legend

Removing an existing legend is easy.

1. Simply click the legend that you want to remove to activate the legend.
2. Press the Delete key. The legend is removed.

Changing Legend Fonts and Font Size

To change the font and/or font size used in your legend,

1. Right-click the legend you want to change.
2. Select Text from the pop-up menu.
3. Select a new Font or Font size from the available options.
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You can perform the same actions by choosing the Edit > Text pull-down menu item.

Changing Legend Formats

There are two types of legend formats available for changing the legend display format, the Indented legend format
and the Normal legend format.

¢ Indented legend format is used to reduce the width of the legend by collapsing common columns into a single
width header. Indented legend format is the default for legends that have duplicate adjacent data in a column
and can help when you have long header or equation names.

¢ Normal legend format is used when columns in the legend do not have duplicate adjacent data.
See the figure Examples of Indented and Normal Legend Formats for examples of both types of legend formats.

To select the Normal legend format,

1. Click the legend you want to change.

2. Choose Edit > Legend > Format > Normal. The legend format is changed to Normal.

3. To return to the Indented legend format, simply choose Edit > Legend > Format > Indented.
The plot pop-up menu item also includes legend format capability under the Insert Legend menu item. You can
also access this capability from the Legend pop-up menu.
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Traces are used to display the data that is stored in a dataset and the results of equations. There are several trace
formats available for displaying data. Selecting various combinations of traces and plot types enable you to analyze
simulation results in a variety of ways. Typical trace types are shown in the following table.

Auto

Bus

Linear

Scatter

Spectral

Histogram

Trace Type

Description

A default trace type that is assigned to the data during
simulation is automatically selected.

Displays bus or long-word data in octal, decimal, or
hexadecimal format.

Displays data as a line. Points between measured data
points are interpolated linearly to create a connected
trace.

Displays data as discrete points.

Each data point is represented as an arrow that is
perpendicular to the x-axis, the base of each arrow is on
the x-axis, and each arrow points in the positive
direction.

Displays data as a histogram or bar chart, which is useful
for statistical or yield analyses.
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Digital Displays data in a stair format, similar to a digital pulse.
The trace steps up or down depending upon the relative
position of two adjacent points.

Sampled Similar to a spectral trace, except that vectors point in
the positive and negative direction, and you can specify
the type of symbol used on the ends of the vectors.

Density Displays swept data in different colors. You can choose
the colors and sequence for colors.

Because an automatic trace type is selected for data, you can view simulation results with little effort. If you want to
analyze data in different ways, you can choose other formats or use equations to perform computations with data. For
more information, refer to Equations.

Examples of traces are displayed below.

linear

hiztogram

— zpectal

Inserting a Trace

You can add a trace as you create a new plot, or you can add a trace to an existing plot.
To insert a trace onto a plot:

1. Double-click on an existing plot or create a new plot by selecting a plot type from the palette, positioning the

48


http://edocs.soco.agilent.com/display/ads2008/Equations#Equations-1104336

Advanced Design System 2008

pointer over the display area, and clicking the mouse.
2. The Plot Traces & Attributes dialog box appears. Select the dataset containing the data from the Datasets and
Equations drop down list. There are two other choices:
e Select Equations at the end of the Datasets and Equations list to display the results of an equation on a
plot. Equations are discussed in Equations.
¢ Click the Manage Datasets button to set up an alias to display data in datasets that are not in the current
project. For more information, refer to Dataset Aliasing.

—| Plot Traces & Attributes:3 |

Plot Type  Plot Options |

FE oA & i 2T

Datasets and Equations Traces
1. Choose a : ;
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_| Show Hierarchy

Manage Datasets...
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. 4. Selections
3. Click Add —— appear here —

3. The variables in the dataset are listed under the dataset name. To add a variable to the plot, double-click on the
variable or select the variable and click the Add button. The selected variables appear under the Traces list.

4. A trace type for each selected variable is automatically chosen based on the type of data in the variable. You can
select a different trace type or change trace attributes such as color.

5. Click OK to dismiss the dialog box and insert the trace.

Selecting Independent and Dependent Variables
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When Add is used to add data to a plot, the data is plotted with respect to the independent variable of a simulation.
For example, transient simulations are a function of time, so any data from a transient simulation that is added to a
plot using Add would be plotted with respect to time.

If you want to use an independent variable other than the default, use Add vs. to add data to a plot. Note that the
dependent variable must be the same length or size as the independent variable when using Add vs. to add data to a
plot. Not doing so will result in an invalid trace. You can use Add vs. with rectangular plots and with lists. For
rectangular plots, you select the variables to be plotted along the x-axis and y-axis. For lists, the independent and
dependent variables appear in two separate columns.

To compare two variables, do the following:

1. To compare two variables on a new plot, choose Insert > Plot, position the pointer, and click or select a plot type
from the palette. To compare two variables on an existing plot, double-click on the plot. The Plot Traces &
Attributes dialog box appears.

2. If this is a new plot, select a plot type.

3. For new and existing plots, select the dependent variable from the list below Datasets and Equations and click
Add vs.

4. If you are using a rectangular plot and the dependent variable you selected is a complex number, the Complex
Data dialog box will appear. Select how the data is to be handled and click OK.

5. The Select Independent Variable dialog box appears. Select the independent variable from the list. It can be from
a different dataset or equation. Click OK.

6. If the independent variable you selected is a complex number, the Complex Data dialog box will appear. Select
how the data is to be handled and click OK.

7. Click OK to dismiss the Plot Traces & Attributes dialog box and display the trace on the plot.

Viewing Complex Data on a Rectangular Plot

The data from frequency-domain simulations, such as S-parameter or harmonic balance simulations, is stored in
complex format. You can plot data from these simulations on rectangular plots, but you must scale the data to one of
the following formats:

e dB

e dBm

e Magnitude
e Phase

e Real

e Imaginary

When you select the data and click Add or Add vs, if the data must be scaled the dialog box shown below will
automatically appear. Select a format and click OK, and continue with the plot as usual.
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Complex Datal:l3
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When adding one trace at a time, additional checking is performed based on the simulation type of the selected trace.
For example, if a trace is associated with a swept harmonic balance simulation is selected and you click the Add
button, the following dialog will appear:

—| Swept Harmonic Balance Simulation Data:0 |

You are adding data from a swepi hanmonic balance simulation to a plot
that only supports scalar data.

How would you like to handle this data?

# Fundamental tone in dB over all sweep values

_J) Fundamental tone in dBm over all sweep values

_) Magnitude of fundamental tone over all sweep values
_i DC component over all swept values

_J Second harmonic in dB over all swept values

_1 Third harmonic in dB over all swept values

_2 Time domain signal {(one trace for each sweep)

oK Cancel
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Note that this additional check is made only when a single trace is selected. When several traces are selected, the
check for the type of data being plotted is more general.

Editing Traces

Trace options enable you to choose different trace formats and change trace attributes. If the trace is generated from
an equation, you can also edit the equation.

The Trace Options dialog box is used to modify existing traces. Any changes made from this dialog box will only affect
the currently selected trace. To change the options for all subsequent traces, refer to Setting Trace Preferences.

© Note

Trace options for the chosen trace type are displayed automatically. If the trace options do not seem correct,
click the Trace Type tab, click the button corresponding to the type of trace you want, then reselect the Trace
Options tab.

To edit trace options:

1. Double-click on the trace or select the trace and choose Edit > Item Options.

2. The Trace Options dialog box appears.

3. The Data Display enables you to change an existing trace's type. This is done by
e Selecting the Trace Type tab.
¢ Clicking the button above the desired trace type (see figure below).

Select Type

- " " “ "

poc [ [ i i oo P [2C

futo Bus  Linear Scatter Spectral Histogram Digital Sampled Density

The suggested plot-trace combinations are:

Plot Type Trace Types
Rectangular and Stacked Any type
Polar Linear and Scatter
Smith Charts Linear and Scatter
List None. Data is formatted from Plot Options

4. You can keep the Auto trace type and still edit the attributes of the trace. Generally, the correct trace options will
be displayed automatically. If you are not sure about the trace type or options, perform the following steps:
e Click the Trace Options tab followed by the Auto tab.
¢ Note the trace type shown in the Auto tab.
5. The pattern, thickness, and color of a trace can be changed for all trace types except scatter. To modify a trace
line, make the following selections:
e Click the Trace Options tab followed by the tab that matches the trace type.
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e Select a line pattern from the Type list.
e Select a line thickness by using the scroll bar or entering a value into the Points field.
e Click the Color bar, select a new color, then click OK.

6. In addition to editing the trace of a histogram, and you can also fill the histogram with a pattern. The color of the

fill will be the same as the trace color. To fill a histogram:
¢ Click the Trace Options tab followed by the Histogram tab.
e Enable Use Fill Pattern.
e Click the Pattern bar, select a fill pattern, then click OK.

7. The type of symbol used on a trace can be changed. Symbols are used with linear, scatter, and sampled traces
to identify the data points that were measured during a simulation. To modify symbols, make the following
selections:

¢ Click the Trace Options tab followed by the tab that matches the trace type.

e For linear traces, enable Place Symbol at Data (symbols are automatically added to scatter and sampled
traces).

e Select a symbol from the Symbol Type list.

e For scatter traces, select a thickness for the line that outlines the symbol by using the scroll bar or by
entering a value into the Points field.

e For scatter traces, click the Color bar, select a new color, then click OK.

8. The Data Display enables you to change the text properties and numeric format used in bus traces. This is done

by clicking the Trace Options tab followed by the Bus tab and making the following selections:
e Select a format for the data from the Format list. The choices are:
Auto A default format is automatically chosen based on the data to be displayed.
Dec Numbers are displayed in decimal (base 10).
Hex Numbers are displayed in hexadecimal (base 16).
Octal Numbers are displayed in octal (base 8).
Binary Numbers are displayed in binary (base 2).
e Select a font from the Font Type list.
¢ Click the Text Color bar, select a color, then click OK.

9. The Data Display trace labels are disabled by default. Trace labels are added to the display for linear and digital

traces with subtraces (such as the curve tracer display) or plots with more than one independent variable along

the x-axis.
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To turn on trace labels, do the following:
¢ Click the Trace Options tab followed by the tab that matches the trace type.
e Select Display Label.

10. Data Display also provides options for displaying swept data (subtraces). These options are controlled by using
the checkboxes in the Automatic Sequencing section of the Trace Options dialog box. For more information, refer
to Setting Trace Preferences.

11. When you have finished editing the trace, click the OK button to close the Trace Options dialog box and save the
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changes.

Deleting Traces

To remove a trace from a plot, do the following:

1.

2.

To delete a single trace, single-click on the trace. For multiple traces, hold the Shift key down and single-click on
each trace of interest.
Press the Delete key or choose Edit > Delete.

Sometimes it is difficult to select a trace from a plot with multiple traces because the traces overlap. If you have
trouble selecting a trace, use the steps listed below:

uhwnNe

Double-click on the plot.

The Plot Traces & Attributes dialog box appears.

Under Traces, select the variables used to generate the trace.
Click Delete.

Click OK to dismiss the dialog box and delete the trace.

Setting Trace Preferences

Trace preferences set the default trace properties and determine how traces will appear when inserted onto a plot.
Any changes made to the preferences will only affect subsequently created traces. To change an option for an existing
trace, make the change using the Trace Options dialog box.

To save and reuse preference settings, you can create a preferences file that can be read by the data display. For
more information on how to create and use such a file, refer to Setting Data Display Preferences.

To set trace preferences, use the following steps:

Choose Options > Preferences.

. The Preference dialog box appears.

Click the Main tab. Set the trace line and symbol preferences by making the following selections:
e Select a line pattern from the Type list.
e Select a line thickness by using the scroll bar or entering a value into the Points field.
Click the Bus tab. Set the bus trace text and numbering preferences by using these steps:
¢ Select a format for the data from the Format list. The choices are:
Auto A default format is automatically chosen based on the data to be displayed.
Dec Numbers are displayed in decimal (base 10).
Hex Numbers are displayed in hexadecimal (base 16).
Octal Numbers are displayed in octal (base 8).
Binary Numbers are displayed in binary (base 2).
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e Select a font from the Font Type list.
e Click the Text Color bar, select a color, then click OK.
5. Click the *
Symbols* tab. Set the label and symbol preferences by doing the following:
o If you want to display labels, enable Display Label.
e Select Display Arrowheads On Spectral Traces if you want arrowheads to appear on the measured data
points on spectral traces.
¢ If you want symbols to appear on the measured data points on linear traces, select Place Symbol at Data.
e Select a symbol type from the Symbol Type list. This is the default symbol for linear, scatter, and sampled
traces.
6. Click the Histogram tab and set the histogram fill preferences by doing the following:
e Enable Use Fill Pattern.
¢ Click the Pattern bar, select a fill pattern, then click OK.
7. Click the Parameter Sweeps tab and set the options that control the appearance of swept data (subtraces). The
Automatic Sequencing options are:
¢ Line Type - Overrides the default Line Type of the trace and automatically uses different line types for each
sweep of the data.
e Symbol Type - Overrides the default Symbol Type of the trace and automatically uses a different symbol for
each sweep of the data.
¢ Line Color - Overrides the default Line Color of the trace and automatically uses different colors for each
sweep of the data.
One or all of the Automatic Sequencing options described above can be enabled at any one time. If all three
options are selected, the order in which they are sequenced is Line Type, Symbol Type and Line Color.

© Note

The Automatic Sequencing options only apply to linear data. If you check more than one option, you will not
see sequencing for the next option start until you have exhausted the previous option. There are many line
and symbol types. Be aware that if you check all three options, trace color won't start to change until over a
hundred subtraces exist, which is not a practical configuration.

8. When you have finished setting preferences, click the OK button to close the Preference dialog box and save the
changes.

History Traces

History traces enable you to perform a series of sequential simulations and have the resulting traces conveniently
displayed in a single Data Display window.

You can turn trace history on, pause it, or turn it off completely. You can also have history mode enabled on some
traces or plots, and disabled on others.

To enable history traces, select the plots or traces for which you want history traces gathered and then:

e Choose History > On in the Data Display Window
OR
¢ Right-click and select History On from a popup menu
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ﬂ Data Display/Untitled® [page 1]:0
File Edit VYiew Insert Marker | History Page Of

(84
Pause *i

Je|E|@| & ;
Iaint ﬁ_Jl

 Note

If no plots and/or traces are pre-selected when you choose History > On in the Data Display window, history
mode is enabled on all plots and traces in the window.

When history mode is enabled, an indicator appears at the top right hand corner of the plot and at the end of the axis
label. The indicator on the plot is green when history is being gathered and red when history is paused. The indicator
at the end of the axis label does not change color.

In history mode, the most recent data collected is represented by a thicker trace, and all previous traces become
thinner.

A e History
' - T indicator
Hisory e I
indicator = ] .
= ED
_':l
f aik i History
Active D s e~ traces
Trace —
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-?D TTT || TTT fl TTTT | TTT
1.6 1.7 1.8 1.8 plll 21 12 13
freq, GHz

To pause the gathering of trace history, choose History > Pause from the Data Display window menu.

To disable history traces, choose History > Off from the Data Display window menu. This command disables history
mode and clears all existing history traces in the Data Display window.

You can change the default number of history traces displayed using the Preference dialog box. Choose Options >
Preferences in the Data Display window, and use the History Traces area in the Main tab to change the number of
traces.
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Preference:0

Trace |Plat | Marker | Test | Equation | Line | Rectangle | ci4 | *

Main |Bus | Symbols | Histogram | Parameter Sweeps | Density

Trace Line/Symbol

Thickness (I-10)
Type 1
Salid Ling ﬂ A
05  pont

Trace Display Mode

w Momal

(" Draft (laster displey)

Histary Trace

Mumber of Histary Traces |3 =] N_umbercf
- history traces

QK | Save.. Fpad Cancal Help

© Note

History traces are available to you as display only, and only for the duration of the session. Unlike the active
trace, you cannot place markers on history traces, edit or save them.

Memory Traces

Memory Traces are primarily used in Advanced Design System tuning. For more information on using memory traces,
refer to the Tuning section in the Advanced Design System " Tuning, Optimization, and Statistical Design "

documentation.

Equations

Equations perform complex mathematical operations on data. You can display equations results on data display plots,
enabling you to analyze information in various ways.

This chapter describes how to write equations and how to display the results. It includes examples of how to use some
of the mathematical expressions that are in Advanced Design System. A reference of the functions that are available
can be found online, it can be accessed from the Equations dialog box.
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Equations can be simple or very complex. An equation can include:

e Mathematical expressions and operations
e Functions

e Other data display equations

e Dataset variables

e Dataset information

e Marker labels

The rules for writing expressions are minimal:

e Equations are case-sensitive

e Equation names cannot start with a digit

e All functions must be completed using the given syntax

e Parentheses are used to define order of operation

e Reserved names cannot be used as equation variables. For example, you cannot use mag as the variable
mag=[ 1: : 3] . Instead, it would need to be used as nynag=[ 1: : 3] or something similar.

Inserting Equations

To insert an equation on the data display:

1. Click the Equation button from the palette or choose Insert > Equation.
2. Position the pointer on the display area and click the mouse. The Enter Equation dialog box appears.
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=| Enter Equation:3

Enter equation here: sparam 1

freg

Errors: PorzZ
PortZ(1)
PortZ(2)
3

cemgart | | S(1T)
8(1,2)
8(2,1)
8(2,2)

_| Show Hierarchy

Manage Datasets...
Functions Help Equation Properties... Variable Info...

7 oK Apply Cancel Help 7
. Enter an equation with the equation variable name on the left side and the expression on the right. A sample
equation is shown below.

RL_1=dB(DC_and_Sparams..S(1,1))

Equation variable Function Datasetname Dataset variable

The expression can include any of the items in the previous list. Note that the Dataset name is not required if the
Dataset variable is included in the default dataset.

Click the Functions Help button for an alphabetical list of links to the available measurement functions. Click the
Index tab in the left-hand frame of the Measurement Expressions documentation for an optional method of
scrolling through the list of functions.

Note
Only the functions described in the " Measurement Expressions" documentation should be used to write Data
Display equations.

. To add a dataset variable to the equation, position the cursor in the equation where you want to insert the
variable.

. Select the dataset name from the list box.

. A list of variables in the dataset is presented. Select a variable from this list and click Insert.

. To modify the display properties of an expression, click Equation Properties. For more information, refer to
Editing Text.

. Activate the Show Hierarchy checkbox to display the dataset variables in a tree format. For more information,
refer to Using the Dataset Browser.

. Click the Manage Datasets button to locate a dataset that is not available in the current project. For more
information, refer to Dataset Aliasing.
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10. Click the Variable Info button to access the Browse Data dialog box. If you click a dataset variable in the list box
of the Browse Data dialog box, detailed information about the dataset variable is displayed on the right-hand
section of the dialog. For more information, refer to Viewing Variable Information.

11. When the equation is complete, click OK.

 Note

If you entered an equation incorrectly, a warning message will appear and the equation identifier, Egn, is
displayed in the color red (if an equation is correct, this is displayed in the color black).

Shortening Variable Names

When using variables in the default dataset, the dataset variable names can be shortened to make an equation easier
to read, as long as each name remains unique. For example, if the variable is entered as:
Curve_Tracer.Sweepl1.DC1.DC.IC.i

If this variable is in the default dataset, you can erase everything from the last period back and keep I C. i

If you want to use a variable with the same name, but from another dataset in the project, you cannot delete part of
the name of either variable. Variable names must be unique.

If you enter data from datasets that are outside the project, the full file path is entered. You may want to keep the full
path or you can erase the part of the file path that is common with the current project.

Viewing Data From Multiple Datasets

The default dataset list only allows you to refer to a single dataset. If you have several equations you can easily
change the referenced datasets by defining string variables with a dataset name and referring to the string variable in
the equations. For example:

MeasuredData="measured"
MeasS21=db($MeasuredData..S5(2, 1))
DiffS21=MeasS21 — SimS21
SimulatedData="simulated"
SimS21=db($SimulatedData..S(2, 1))

Viewing Equation Results
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Equation results can be plotted or displayed in a list. You treat results like any other data. You can apply markers, edit
the format, or use the results of an equation within another equation.

To view the results of your equation:

Click the Equation button on the palette or choose Insert > Equation.

Position the pointer on the display area and click the mouse to display the Enter Equation dialog box.

Select Equations from the Datasets and Equations list.

Select the equation variable and click the Insert button.

If the equation is entered incorrectly, an error indication is displayed. Some types of equation errors cause the

equation ( Egn ) identifier on the Data Display to be highlighted in red. Other errors will cause the error dialog

box to appear. This dialog box provides specific information about the error.

5. The default trace type for the chosen data will be used. If you want to verify or change the trace type, click Trace
Options and proceed to edit the trace.

6. Click OK to dismiss the dialog box and display the equation results.

sl

— egquation name

|— plotted equation results
6O |

o0 —

40—

30—

20—

10—

S1lvswr

D T I T ] T | T |' T I T '| T | T I T | T
0.00.170.20.30.40.50.60.70.80.91.0

freq, GHz

(AP S11vswr=vswr {DC_and_Sparams .SP2_SP.§(1,1))

L equation

Equation results can also be displayed in text objects. For more information refer to Embedding Equations in Text
Objects.

Working with Multidimensional Data
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It is not uncommon to sweep more than one parameter in a simulation. Data from such simulations is stored as
multidimensional data. If you want to perform calculations on, or display only portions of the data from such
simulations, you need to use equations to select the subsets of data.

The curve tracer example is used to illustrate how to do this. The example is under the Examples directory in the
MW__Ckts subdirectory. From this subdirectory, open the project LNA_prj and then open the Curve_Tracer schematic
that is part of this project.

To open the data display, from the curve tracer schematic window, choose Window > Open Data Display and select
Curve_Tracer.dds.

Refer to the schematic. In this example the base current, IBB, and the collector-emitter voltage, VCE are swept in this
manner: IBB is set to 5 mA, and VCE is swept from 0V to 3 V in 0.1 V steps. At each 0.1 V increment, IC is calculated
and stored in the dataset. When this sweep is complete, IBB is increased to 5 mA, VCE is swept from 0V to 3V, and at
every 0.1 V increment IC is measured and stored in the dataset. This is repeated until IBB equals 30 mA; a final
sweep of VCE is performed and the simulation is complete.

Refer to the data display. The curve tracer is the entire collection of IC data points. This data is stored in the dataset,
and the structure of how data is stored is described next.

IC results. VCE and IBE are swept variables

4D_ I 1 — . —~ |BB=2 S00E-£

IC i, mA
.
|
j
|

1 IBB=1 DO0DE.S

|BB=5 D00E-&

0.5

T | T | T | T | T | T I T | T | T | T | T | T | T I T | T
oo 02 04 06 08 10 12 14 16 18 20 22 24 26 28 30
WCE

Certain measurements, such as EVM in a DSP schematic window, treat each sweep point as a separate simulation and
returns a single point of data. Each point of data contains the swept variable, simulation results, and an index of zero.
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To display such data, create an expression such as my_evm = E [ : : , 0] to extract the zeroth index of the swept

expression.

Data Structure

Based on the simulation sweeps, there are six values for IBB and 31 values for VCE. The index for IBB is 0-5, the
index for VCE is 0-30. For each of these combinations of VCE and IBB, IC was calculated and stored in the dataset.

index=0

index=1

index==2

index=30

VCE=0V
|C=-4783uA

index=0 —— |BB=5uA

VCE=.1V
IC=230.2uA

VCE=2V
IC=728.6uA ...

VCE=3V
IC=BB82.4uA

VCE=0V
|C=-9.537uA

index=1 —+ IBB=10uA

VCE=.1V
|C=467.9uA

VCE=.2V
IC=

VCE=3V

14z22mA.. 1C=1.728mA

VCE=0V
|C=-14.25uA

index=2 ——- |BE=15uA

VCE=.1V
[C=690.4uf

VCE=2V VCE=3V
IC=2.072mA ... IC=2535mA

VCE=0V
IC=-28.21uA

index=5 — |BB=20u&

VCE=1V
IC=1.265mA

VCE=2V VCE=2V

It is possible to select a single point of data or a sequence of data. The next section describes how to access portions

of data using indices.

Accessing Data

Data is accessed by index values. The equation below returns the value of IC when VCE =0V and IBB =20 mA.

®=IC.1i[3,0] --—— usesquare brackets

Type the equation and use a list to display your results. For information on how to enter equations, refer to Inserting
Equations. For information on how to display equation results, refer to Viewing Equation Results.

T =ICi[2,0]

x
-1.893E-5

equation

—— equation result in a list
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For this equation, the order of the indices did not matter, but in general it does. The next section describes index
order.

Index Order

Data is retrieved by the index values. The index order is critical to returning intended data, and it is based on how the
simulation is set up. In the curve tracer simulation, the Parameter Sweep item references the DC Simulation item, and
the DC simulation parameter ( VCE ) is swept based on the parameter-sweep parameter ( IBB ). The index order is
outermost to innermost, so the index for IBB precedes the index of VCE.

PARAMETER SWEEP DC

FPoramSweep oC

Sweep L

SweepWars' SweepVars=s
Simlnstancefgme[1]="0DC1" Start=0
SimlnstanceNaye[2]= Stop=3

SimlnstaonceName[ 3]
SimlnstanceMama[ 4]
SimlnstaonceName
SimlnstanceName|[

Step=-

—
e
i

Start=% uaA
Stap=30 uA
Step=5 uh
x = IC. 0, 0]

i 0
|— inner index, VCE, 0-20
outer indlex, IBB, 0-5

variable containing data

Try retrieving other data points, such as:

x1=IC.i[1,0]
x2=IC.i[0,1]
x3=IC.i[1,30]

View the results in lists and compare your results to the data structure illustration.

Accessing Sequences of Data
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You can access subsets of data using indices. You can either specify the range, or use wild cards.
For example, to display only the trace for IBB = 20mA, type as an equation:

IBB20=IC.i[3,::]

Add IBB20 to the curve tracer plot to view the results.

The characters : : in the equation are the wildcard. In this equation, the wildcard substitutes for a VCE index value, so
all values of VCE are used and the entire trace of data is returned.

0.0050
IBB=2 000 E-5
00045
0 0040 — |BB=2 S00E-5
00035
IBB=2 000 E-5
00030
oo 00025 IBB=1 S00E5
M L~
DY 00020
IBB=1.000E-5
00015 |~
0.0010+ IBB=5 000 E-G
0.0005—
0.0000
00005+ 1T T T

I
o0 0.3

I I I I
04 06 05 1012 14 16 18 2

0 22 24 28 28 30

WCE

the result is the thick

- lBBED:lC'i[S'::] ~ line on the plot

To display only a portion of the trace, use a sequence:

IBBZ0=IC.i[3,10::1::20]

| =

start

stop

increment

The data in the 10th through 20th elements are displayed. The default increment is 1, so this sequence could also be
written as 10: : 20. If you want to skip data points within the sequence, set the increment to a value larger than one.
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00050
|BB=3 OO0 E.5
00045 -
00040 — |BB=2 SO0E.5
00035
|BB=3 OODE.5
0.0030—
o 00025 |IBB=1.500E-5
[
o
DL 00020
|BB=1 00DE.5
0.o015—
0.0010— |BB=5 O0DEG
00005 —
00000 —
-D.DDDS T I T I T I T I T I T I T I T I T I T I T I T I T I T I T
oo o2 04 06 08 1012 14 16 1.8 20 22 24 268 28 30
WiZE
ﬂlBBED:|C.i[3,1D::1::2D]
© Note

Try setting this trace to a Scatter trace type, then insert different increment settings in the equation to view
the effects of the increment parameter.

To display a portion of several traces, use two sequences:

IBB20=IC.i[3::5,10::20]

Note the results on the curve tracer plot.
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0.0050
IBB=3.000E-5

0.0045—

0.0040— 16B=2 500 E-5

00035
|BB=2.000E-5
0.0030— | __,_,_———ﬂ_——'_._—'_

er 00025 "II 1 - e IBB=1A00ES

IBE20

L 0.0020— (
al

0.0015— hll'lll,-'* ’
0.0010= .ﬁ'll." 1 i . —1 I  E— I i p— 1BB=5 000 E6

1BB=1.000E5

R e R
00 02 04 06 08 1012 14 16 1.8 20 22 24 25 28 30

WCE

B 'BE20=1C.i[3::5,10::20]

Accessing a Sweep of Data

You can return a sweep of data using a wildcard in the first position of the equation:
VCE5=IC.i[::,5]

This example returns the values of IC where VCE = 0.5V.

Do not plot this result on the existing curve tracer plot. Instead, insert a new plot and add the data to the new plot.
The axes on this plot are different from the curve tracer. VCE is plotted along the y axis as a function of IBB, which is

plotted along the x axis.

You can change the trace type from Linear to Scatter and see the individual data points.

You can also write the same equation as:

VCE5=IC.i[5]
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The wildcard in the first position is assumed.

0.005

0.004-

0.005—

0.002—

0.001—

D-DDD||||||||r|||||||||||||||
0.000005 0000010 0000015 0000020 0000025 0.000030

YCES

W VCES=IC.i[::,5]

Plotting Multidimensional Data

When you plot multidimensional data, the x-axis depends on whether the data is plotted using a single index value or
using the wildcard (::) to select all index values.

The what() function returns the dimensions in the dataset entry and the number of points in each dimension. The
following shows that the dimensions in BudGainl are Component, X, and freq.

ey a=what(BudGain1) q

Cependency . [Component X, freq)
MNum. Paints © [14, 11,1 ]

The following shows multidimensional data plotted using a single index value (0) for frequency:
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=gy BudiGain onefreq=BudGain1[0::9, 0]

30
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Since frequency is a single index value, the x-axis value shifts left to the next dimension, which is X in this example.
The following shows the same multidimensional data plotted using the wildcard to select all index values for
frequency:

=elglmy BudGain_allfreqs=BudGain1[0::9,::,:]

a0
0] ]
w20
i -
= .
= 104 2
| - &
it 0—
[ i
Y0 3
W] 0 =
i N :
=20
-3':' T T | T I T | T T T
- - — - — — - -
ih ih ik h i i Lh ik
[t} [} —r [ =} = [} i [t}
[} [} (= =) = (] ] i
[ ==t} = = = i (] 1 i
[t} [} i e = = 1 [}
p= = C =] = c bt bt
[} [t} [ i) i ('] = [t}

- i

Since frequency is all index values, the x-axis value is frequency. In this example, frequency was a single value so you
may have expected the same results as shown using a single index value. However, the plotting routine does not
make a distinction between the case where the wildcard represents one index value or multiple index values.
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Working with Swept S-parameters

If you want to access subsets of swept S-parameters, you need to use both index notation and S-parameter notation.
This section describes the various combinations and the results that are returned.

Setting up an Example

If you want to have an example to work with, set up and perform the simulation described here. Otherwise, skip to
the next section.

This example adds a parameter sweep to the amplifier.dsn schematic in the project SweptSparams_prj.

From the Main window, click the Examples directory.

Select Tutorial.

Select SweptSparams_prj.

Choose File > Copy Project and make a copy of the project.

Open the copy of SweptSparams_prj.

Open the schematic amplifier.dsn.

Add a swept parameter by modifying the voltage source using a Var Eqn Data item and a parameter sweep item,
as shown below.

NounAsLNE

a0l waRi i . .
Yhige=3%.0 ¥ inzarta variable and =&t it= valus
WD

SR
= Fde=Yhioa

=&t Vdc fo the variable

1—=]|I

|
+

| FARAMETER SWEEF I—i”’ﬂtﬂ
paramstar
ParamSwaap zwesp fem
anter the variable g‘-‘-'"F':I_ .
. waapWar= iam .
to be zwept Siminatancedame[1 J="5r1" Eerhrm Swesps aver
Siminatancetams [T ]= Spamameter simulation

STralng tancamams [3 )=
Simlnetancehlioma| £
Simlnetancehlioma| 5
SiminatancetMame | &

zatthe sweep Stork=3_O%
range of the gtgs:ég b

variable

8. Rerun the simulation. The simulation will run in this manner: Vbias is set to 3V and an S-parameter simulation is
performed at each frequency specified in the S-parameter simulation item and the S matrixes are stored in the
dataset; Vbias is set to 3.9 V and another set of S-parameter simulations are performed and stored in the
dataset; this continues until Vbias equals 2.0 V, when a final set of S-parameter simulations are performed and
the entire simulation is complete.

9. When the simulation is complete, open a new Data Display window.
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10. Set the default dataset to amplifier.
11. Insert a rectangular plot and add S(2,1) to the plot. The entire collection of S(2,1) data points that were
calculated for each frequency point and for each value of Vbias is displayed.

The next section describes how the data is stored in the dataset.

Data Structure

Based on the simulation sweeps, there are eleven values for Vbias and 200 values for freq. The index for Vbias is
0-10, the index for freq is 0-199. For each of these combinations of Vbias and freq, an S matrix was calculated and
stored in the dataset.

index=0 index=1 index==2 index=199
| | | |
freq=5MHz freg=10MHz  freg=15MHz ... freg=5GHz
index=10 —{-Vhias=oov | S | | S | | s [ .. S
freq=5MHz freq=10MHz  freg=18MHz ... freg=5GHz
. 3 3 3 3
. _ | Vhias=28V
index=2 1as matrix matrix matrix matrix
] freg=5MHz freg=10MHz  freg=15MHz ... freg=5GHz
index=1 —Vhias=2.9V S. S. S. S_
matrx matrx matrx matrix
— freq=5MHz freg=10MHz  freg=15MHz ... freg=5GHz
index=0 — | Vbias=av | > S S S
matrx matrx matrx matrx
— | S11 512
s 522

I_ a single S matrix

Index order is the same as described in Index Order. That is, the outermost index is first, innermost is last. In the
example above, the first position is the index of Vbias, the second is for freq.

Accessing Data

You can access S-parameters using indices. The equation below returns S 21 calculated for Vbias =2.9 V and freq = 5
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MHz:

myS21=5S21[1,0]

Type the equation and use a list to display your results. For information on how to enter equations, refer to Inserting
Equations. For information on how to display equation results, refer to Viewing Equation Results.

myod ]
9.604E-5 ,-"r -108,798 aquation rezult

ina list

The equation below returns S 21 at all frequencies for a single value of Vbias ( Vbias =2V):

S21at2V=S21[10,::]

Add this result to a plot. The wildcard : : is used to substitute for a freq index, so all values of freq are returned,
enabling you to display an entire trace of S 21 results.

210
- ? :@\
> _
ST -20 %%15% :
oo ——/-\VJDE= :
—5 40 VB10E=s;
[t}
2l 6o
w. -
5E
= =80

-1004 T T T
0.0 0.2 0.4 0.6 0.8 1.0
freaq, GHz

82’1atw:ampllfler..S(Q,’l)[1[],::]— Aeaulton Aol
To display only a portion of the trace, use a sequence:

SZ2lat2V=5Z1[10,80::1::199]

L .

increment
start

The data in the 50th through 199th elements are displayed. The default increment is 1, and the sequence could be
written as 50: : 199. If you want to skip data points within the sequence, set the increment to a value larger than one.
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Try setting this trace to a Scatter trace type, then insert different increment settings, for example replace 1

with 20, to view the effects of the increment parameter.

To display a portion of several traces, use two sequences:

S21block=S21[2::10,90::140]

Add this to the plot and note the results.
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Accessing a Sweep of Data

You can return a sweep of data using a wildcard in the first position of the equation:
column=S21[::,80]

This example returns S 21 for every value of Vbias at the frequency with index 80.

Do not plot this result on the existing curve tracer plot. Instead, insert a new plot and add the data to the new plot.
The axes on this plot are different from the curve tracer. S 21 is plotted along the y axis as a function of Vbias, which
is plotted along the x axis.

You can change the trace type from Linear to Scatter and see the individual data points.

You can also write the same equation as:
column=S[80]

The wildcard in the first position is assumed.

=egycolumn=amplifier 5[, 80](2,1)
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Working with an S Matrix

S-parameters are stored in an S matrix. In general, you will probably want to work with a specific S-parameter and
not the entire matrix. You can, however, access an entire matrix. If you do not specify an S-parameter, an equation
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using S returns the entire S matrix:
myMatrix=S[1,0]

m}rHﬂter=S[1,G]

mybdatria
mybdatriaf1, 1) mybatriaf1_ 2] mybatria{2 1]
G.BBS — jO. 002 -1.504E-5 + j2 _BOEE-& -1 .547E-5 + j9_uisE-2

 Note
If ellipsis points appear in the list of data, enlarge the list by selecting the list and dragging a handle
horizontally until all values are displayed correctly.

You can also use indices in this way without specifying an S-parameter and return the S matrix at each point:
manyMatrices=5[2::5, 80::90]

Use a list to display your results. Use the scroll buttons to browse the entire list of data. As you can see, a large
amount of data is returned.

Viewing Variable Information

Use the what function to view information about a variable, including:

Independent variables

Number of data points

Matrix size

Data type, such as real or complex

If the variable contains a single number or a one-dimensional sequence of numbers (like a row or column) it is termed
Scalar. If the data is two dimensional, it is termed a Matrix and the size of the matrix is given. Examples of two
variables from the swept S-parameter example, Vbias and the S matrix, S, are shown below. For details about these
variables, refer to Setting up an Example.
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whaoi{W¥bias)
Dependency : |¥bias
Mum, PFoinis : 11
Mairix Size : scalar
Twvpe : Real
whui(S}
Dependency : |vbias,Treq
Num. PFPoinis : 11, £010
Malrix Size 2.2)
Type : Complex

Finding an Index

The amount of data in this simulation is two dimensional and relatively small, and it is not difficult to determine the
swept parameter values that correspond to indices. For more complex problems, you can use the find_index()
function. The find_index() function returns the index that corresponds to a data value. For example, in the
Curve_Tracer example, VCE is a scalar that contains 61 points of data. The equation below returns the index when
VCE is 3 V:

VCEIndex=find index (VCE[Z, ::], 3)
\— find the index for 3V

use the entire range of VCE

select any single index of IBB

specify the variable of interest

The find_index() function works only on scalar data. VCE is specified using indices in order to present it in scalar
format.

Using Markers in Equations

You can add marker labels to equations and perform operations on marker data. The operation is performed on the
dependent marker data.

To add a marker to an equation:

1. Click the Equation button on the palette or choose Insert > Equation.
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Position the pointer on the display area and click the mouse.
The Enter Equation dialog box appears. Type the equation.

At the point where you want to add the marker, choose Equations __ from the Datasets and Equations ___ list.
Select the marker label and click Insert.

Complete the equation, then click OK.

ouALN

You can treat markers like any other variable in an equation.

© Note

If you change the marker label (which is accomplished by selecting the marker and choosing Edit > Item
Options), you must edit your equations by deleting the old marker label and entering the new marker label.

Using Independent Marker Data

You may want to retrieve the independent data in a marker. You can do this using the indep function. For example:
myequation=indep(m1)
where m1 is the marker label. You can also nest this within another function.

Markers on polar plots and Smith charts return data in complex format. You may want to work with only the imaginary
portion of the number, which you can retrieve using the imag function. The illustration shown next shows a Smith

chart, the marker applied to a trace, the equation used to isolate the imaginary component, and a list to verify the
equation is correct.

il

DC _ond _Sparama
DO _ond _Sparama

.. OOCHHz to 1 GGGGEH:z)

m
frag=285 . GO000Hz
DC_and_Sparaoms . .Sp . |l=0.ﬁ-33?1,‘3 — jO. 475679 — imaginary part of m1
impadanca = 200 * {1._03245330 - j2.ﬁi§dg1?j
m1 imag=imag(ml) — imagirary patefml retumed
fraq mil imag
BES . QOO -G 47E equation & carmect
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Generating a Histogram after Monte-Carlo Analysis

The example in this section demonstrates a simple histogram using data from the Tutorial/yldex1_prj example. The
example simulates the frequency response of an impedance transformer, with component values varied during a yield
analysis. For more information on generating a histogram, refer to chapter 3 of the " Tuning, Optimization, and

Statistical Design " documentation.

]
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Dependency : [mcTrial fred]
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freq, MHzZ Matrix Size - scalar
o Type  Complex

B freq_index=find_indexifreq[0, 1] 500MHz) [ freq_index
=il umBins=20
Hist_521_at_1Freqzhistngram(dﬁ(@ﬂ[::,freq_index]]l,NumBinﬁj

Histogram showing distribution of insertion loss
at one particular freguency, specified in "freg_index"
equation.

40

0
=]
|

[

|

—
i
|

L
1

Hist 521 at 1Fre
=
|

o]

4.0 35 -3a 25 20 A5 1.0
indepiHist_S21_at_1Fred)

Simple Histogram using data from the Tutorial/yldex1_prj Example

e The first plot in Simple Histogram using data from the Tutorial/yldexl prj Example above shows all of the

dB(S21) curves.
e The second plot shows the distribution of dB(S21) at one particular frequency, specified by the "freq_index"

equation.
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e The S21[::,freg_index] syntax selects the S21 values for all Monte Carlo iterations at the "freq_index" frequency.
e The NumBins variable just sets the number of histogram bins.

Using Predefined Equations

Data Display has a set of predefined equations that you can use to display and document current data properties such
as default dataset name and path.

The following table lists the predefined equations available:

Predefined Equation Name Description

Default_Dataset_Name The current default dataset name. This name does not
include the ".ds" extension

Default_Dataset_Path The full path to the directory that contains the default
dataset

Default_Dataset_Modified_Time The time the default dataset file was last modified

Default_Dataset_Modified_Date The date the default dataset file was last modified

Default_Dataset_Size The size in bytes of the default dataset

DDS_File_Name The current DDS file name without the ".dds" extension

DDS_File_Path The path to the directory that contains the current DDS
file

DDS_File_Modified_Time The last time the DDS file was modified

DDS_File_Modified_Date The last date the DDS file was modified

DDS_File_Size The size in bytes of the DDS file

You can display dataset information in two ways, using either a text object or a list.
To display dataset information in a text object refer to Embedding Dataset Properties in Text Objects.

To display dataset information in a list...

1. Select List from the palette or choose Insert > Plot, then click the mouse on the page to place the plot and
display the Plot Traces & Attributes dialog box.

2. Select List in the Plot Type tab.

From the Datasets and Equations dropdown menu select Predefined Equations.

4. Use the dialog box to select and add data properties to the display.

w
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Annotating the Data Display

Designs can be better documented by making annotations on the display. The Data Display includes drawing tools that
enable you to annotate the display by inserting text and drawing objects.
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Inserting Text

Adding Text

To add text to the Data Display:
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1. Choose Insert > Text or select Text from the palette.
==a=)

123 4

EEEE. EE?S.
o \
V| VI
C UL 3
Text — A

2. Click the mouse on the display page to place the text. The insertion point is marked by a red cursor.

3. Type the text.
4. When you are finished, click the End Command button on the toolbar or choose Edit > End Command.

End Command — %

Embedding Equations in Text Objects

You can display equation results as well as equation names in text objects.

Any named equation can be embedded in a text object by preceding its name with the "@" character, for example
"@freq". Use either the onscreen editor or the Enter Text dialog box to embed or edit equations in texts.

To embed equations in the text using the onscreen editor...

Choose Insert > Text or select Text from the palette.

Single-click the mouse on the display page.

Type the text and place the "@" character before any equation name.

When you are finished, click the End Command button on the toolbar or choose Edit > End Command.

Sl

To embed equation results in the text using the Enter Text dialog box...

1. Choose Insert > Text or select Text from the palette, then double click the mouse on the page to place the text
and display the Enter Text dialog box.
2. Select the Select Data and View Warnings/Errors checkbox to display the dataset browser.
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3. Insert an equation in the text by double-clicking it or by selecting its name from the dataset browser and clicking
the Insert button. The equation name will be added to the text field preceded by the "@" symbol. Click OK.

M Enter Text:0 R|

| testl _1n ﬂ
Froquencynlesd_tnis: @ed T

Fortd
FodZi1)
PortZ(2)
=

=(1.1]
S(1.8)
S(21)

-

Entar taxt hara:

[+ Select Data and View Wamings/Erors

Equations \Wamings/Emors
[~ Show Heararciy
Manage Datasats_
‘Wanable Infa...
QK | Apphy | Cancel | Froparties... | Halp |

When you deselect the text object, the equation results are automatically evaluated and displayed in the text. Up to
three data items, separated by commas, are displayed for each equation, followed by "..." if more data items are
available.

Frequency: 1000000000.000, 1100000000.000, 1200000000.000, ...

To re-activate the onscreen editor, single-click the text. The text is highlighted in red and displayed in its original
form, showing the equation name.

Frequency. @freq|

To display the equation name and not the calculated result, add a backslash before the "@" symbol in the text editor.
For example: "@freq".

If an error occurs, or the equation is not found, the equation name is displayed in the text instead of the equation
result.

 Note

Embedded equations may generate errors and warnings, which appear in the Equations Warnings/Errors area
in the Enter Text dialog box.

Embedding Dataset Properties in Text Objects
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Data Display has a set of predefined equations containing current dataset information such as default dataset name
and path. These equations enable you to embed dataset information in text objects, simplifying documentation.

The following table contains the list of predefined equations available:

Predefined Equation Name Description

Default_Dataset_Name The current default dataset name. This name does not
include the ".ds" extension

Default_Dataset_Path The full path to the directory that contains the default
dataset

Default_Dataset_Modified_Time The time the default dataset file was last modified

Default_Dataset_Modified_Date The date the default dataset file was last modified

Default_Dataset_Size The size in bytes of the default dataset

DDS_File_Name The current DDS file name without the ".dds" extension

DDS_File_Path The path to the directory that contains the current DDS
file

DDS_File_Modified_Time The last time the DDS file was modified

DDS_File_Modified_Date The last date the DDS file was modified

DDS_File_Size The size in bytes of the DDS file

You can embed dataset information in the same way you embed other equations in text objects:

1. Choose Insert > Text or select Text from the palette, then double click the mouse on the page to place the text
and display the Enter Text dialog box.

2. Select the Select Data and View Warnings/Errors checkbox to display the dataset browser.

In the dataset browser dropdown menu select Predefined Equations.

4. Insert the desired equation in the text by double-clicking it or by selecting its name and clicking the Insert
button. The equation name will be added to the text field preceded by the "@" symbol. Click OK.

w
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Editing Text

The text, fill, and outline of a text box can be easily changed by using the Enter Text dialog box. Any changes made
from this dialog box will only affect the currently selected text box. To change the options for all subsequent text
entries, refer to Setting Text Preferences.

To edit text:

Double-click on the text or select the text and choose Edit > Item Options.
The Enter Text dialog box appears.
Change the text as desired.
To change the text format, click the Properties button.
To change the font properties:
e Select a font from the Font Type list.
e Select a font size from the Font Size list.
e Click the Text Color bar, select a new color, then click OK.
6. The text is enclosed in a text frame. To display the outline of this frame, enable Draw Outline. To edit the
outline:
e Select a line pattern from the Type list.
e Select a line thickness either by using the scroll bar or entering a value into the Points field.
e Click the Color bar, select a new color, then click OK.
7. To fill the background of the frame, enable Use Fill Pattern. To edit the fill:
¢ Click the Color bar, select a new color, then click OK.
¢ Click the Pattern bar, select a pattern, then click OK.
8. Click OK to close the Edit Text Properties dialog box.
9. Click OK to close the Enter Text dialog box and accept the changes.

uhwNe

85



Advanced Design System 2008

Deleting Text

To remove a text frame, do the following:

1. To delete a single text frame, single-click on the frame. For multiple frames, hold the Shift key down and
single-click on each frame of interest.
2. Press the Delete key or choose Edit > Delete.

© Note

If you just want to disable a text frame temporarily, refer to Activating or Deactivating Objects.

Setting Text Preferences

Any changes made to the preferences will only affect subsequently created text. To modify existing text, make the
change using the Enter Text dialog box.

To save and reuse preference settings, you can create a preferences file that can be read by the data display. For
more information on how to create and use such a file, refer to Setting Data Display Preferences.

To set preferences:

1. Choose Options > Preferences.
2. The Preference dialog box appears. Click the Text tab.
3. Set the text preferences by doing the following:
e Select a font from the Font Type list.
e Select a font size from the Font Size list.
e Click the Text Color bar, select a new text color, then click OK.
4. The appearance of text box outlines is set by using these selections:
e Enable Draw Outline.
e Select an outline pattern from the Type list.
e Select the outline thickness either by using the Thickness scroll bar or entering a value into the Points field.
¢ Click the Color bar, select a new color, then click OK.
5. Text box fill preferences are set as follows:
e Enable Use Fill Pattern.
¢ Click the Color bar, select a new fill color, then click OK.
¢ Click the Pattern bar, select a fill Pattern, then click OK.
6. Click OK close the Preference dialog box and accept the changes.

Inserting Objects
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The commands used to add graphical objects to your display are found on the Insert menu as well as on the palette.
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To insert an object, do the following:

1. Click the button on the palette that corresponds to the desired shape (Circle, Rectangle, etc.) or choose the
shape from the Insert menu.
2. Position the pointer on the display page and click the mouse.
e For lines, move the pointer until the line is the desired length, then click the mouse.
e For rectangles and circles, move the pointer until the object is the desired size, then click the mouse.
e For polylines and polygons, continue adding segments by positioning the pointer and clicking the mouse.
To complete a polyline, double-click the mouse. For a polygon, draw the second to last segment and then
double-click the mouse. The last segment is added to make a closed region.

Double-click here Toclose a polygon

3. The object drawing mode remains active, allowing you to place other objects of the same type by moving the
pointer and clicking the mouse.
4. If you are finished, click the End Command button in the toolbar or choose Edit > End Command.

Editing Objects

You can edit object properties such as line width, line thickness, and color. For 2-D objects, you can fill the area with a
pattern and color.

87



Advanced Design System 2008

You can also edit objects by moving them, changing their size, or by using delete, cut, copy, and paste commands.
For more information on these functions, refer to Data Display Basics.

Any changes that you make will only affect the currently selected object. To change properties for all objects added
subsequently, refer to Setting Object Preferences.

Objects are edited using the following steps:

1. Double-click on the object or select the object and choose Edit > Item Options.
2. The edit dialog box appears.
3. Lines and object outlines are edited using these selections:
e Select a line pattern from the Type list.
e Select the line or outline thickness either by using the Thickness scroll bar or by entering a value into the
Points field.
e Click the Color bar, select a new color, then click OK.
4. An object's fill can be changed using these selections:
e Enable Use Fill Pattern.
e Click the Color bar, select a new fill color, then click OK.
e Click the Pattern bar, select a fill Pattern, then click OK.
5. Click OK close the dialog box and accept the changes.

Deleting Objects

To remove an object, do the following:

1. To delete a single object, single-click on the object. For multiple objects, hold the Shift key down and single-click
on each object of interest.
2. Press the Delete key or choose Edit > Delete.

© Note

If you just want to disable an object temporarily, refer to Activating or Deactivating Objects.

Setting Object Preferences

Object preferences determine how new graphical objects will appear when they are inserted onto a display area.
Object preferences affect all objects created after the changes were made and saved. To change the properties for an
existing object, refer to Editing Objects.

To save and reuse preference settings, you can create a preferences file that can be read by the data display, which
can facilitate setting preferences. For more information on how to create and use such a file, refer to Setting Data
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Display Preferences.

To set preferences:

1. Choose Options > Preferences.
2. The Preference dialog box appears. There are tabs for each type of object. Move through the tabs and define
your preferences.
3. Lines and object outlines preferences are set using these selections:
e Select a line pattern from the Type list.
e Select the line or outline thickness either by using the scroll bar or entering a value into the Points field.
e Click the Color bar, select a new color, then click OK.
4. An object's fill preferences can be set by using these selections:
e Enable Use Fill Pattern.
¢ Click the Color bar, select a new fill color, then click OK.
¢ Click the Pattern bar, select a fill Pattern, then click OK.
5. Click OK close the Preference dialog box and accept the changes.

Adding Date and Time to a Data Display

You can add the current date and time to a data display using the AEL function date_time(). You can add this (or any
other AEL expression) to a data display using an equation, then display the results on a plot. In the procedure below,
date and time are displayed in a list.

1. Click the Equation button on the palette or choose Insert > Equation.

2. Position the pointer on the display area and click the mouse button.

3. The Enter Equation dialog box appears. Enter the equation as current_date_time=date_time(). (Use any variable
name on the left side of the equation and the AEL function on the right side of the equation.) Click OK.
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4. From the tool bar on the left side of the Data Display window, click the List button, move the pointer into the
display area of the window, and click.

5. In the dialog box that appears, select Equations from the Datasets and Equations drop-down list.

6. Select the variable (in this case, current_date_time ) and click Add. Click OK.

|::urrent_date_time:date_time[] —— Equation

currert_dsate_time
Thu Jun 15 17:03:17 2000|— Curren date and time

Note this is not a date/time stamp, it is updated to reflect the current date and time.

 Note
You can add variables to an ADS schematic to display current date and time, plus other design and system
information. For more information, refer to the Advanced Design System "Schematic Capture and Layout"
documentation.

Markers

Markers enable you to read data values at specific points on a trace. They return the independent and dependent
values of the data.

Marker Types summarizes the types of markers available in Data Display:
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Marker Name Description

Returns value from any point on a trace

Normal

Delta Displays the difference between two markers

Offset Finds a fixed offset from a reference marker

Peak Finds the localized peak values of a trace

Valley Finds the localized valleys of a trace

Max Finds the data points that reflect the maximum data
values

Min Finds the data points that reflect the minimum data

values

For more information refer to Delta Mode, Offset Marker, Peak and Valley Markers and Max and Min Markers.

When a marker is inserted, the following items appear on the display page:

e The marker symbol.
e The marker readout, which returns the data at that point on the trace.
e Marker labels, one on the trace and one in the readout. This is helpful when you have multiple markers

displayed.

The figure below shows a marker inserted onto a trace and the data returned from that point on the trace.

marker label —— mil
marker readout r
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Markers can also be used in equations. For information refer to Using Markers in Equations.

Inserting Markers

91


http://edocs.soco.agilent.com/display/ads2008/Equations#Equations-1105196

Advanced Design System 2008

You can insert one or more markers onto a trace.
To insert a marker:

1. Choose Marker > New <Marker Type> or select the appropriate marker from the Marker toolbar.
File Edit Wiew Insert History Page Options Toc
Mew Crl+M |

i
J|@| [ﬂl = [ Mew Peak
Mew Yalley :
|aint Mew Max
Mew Min C

Marker toolbar y| N “\lﬂ‘ Dielta Mode On

Offset Mode On 3
k Delta/Offset Mode OFf

Mext Data Point

@ @ Frevious Data Poink
) Note

The Marker toolbar display is disabled by default. To enable it choose Options > Hot Key/Toolbar
Configuration, select the Toolbar tab and enable the Marker toolbar display.

2. The Insert Marker dialog box appears. Position the pointer on the trace where you want to insert the marker and
click.
3. The dialog box is automatically dismissed.

You can then drag the marker and move it to any position along the trace. An active marker readout is displayed to
help you position the marker.

The marker data appears next to the marker. To keep your plot uncluttered, enlarge the data display window, select
the marker readout text, and drag it off to one side of the plot.

Moving Markers

There are three ways to move markers:

e Drag the marker to any position along a trace. An active marker readout is displayed to help you position the
marker.
e Select the marker and move it to the next or previous data point by:
° Using the arrow keys on your keyboard
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° Using the arrow buttons on the Marker toolbar

© Selecting Next Data Point or Previous Data Point from the Marker pulldown menu or from the marker popup
menu

e Change the value and units of the independent variable in the marker readout. For more information, refer to
Editing the Marker Readout.

Editing Markers

You can change the properties of an individual marker using the Edit Marker Properties dialog box.

 Note

Any changes that you make will only affect the currently selected marker. To change the properties for all
markers added subsequently, refer to Setting Marker Preferences.

To edit a marker...

1. Double-click the marker or the marker readout to display the Edit Marker Properties dialog box.
2. Use the dialog box to edit the marker.

r

Edit Marker Properties:1

Main | Symbol/Label | Readout | Smith |
Marker Hame

|m3

Marker Type

I'l.-"alley ;I

Marker Mode
| Offset v
Feak Y alley Marker Delkta/Offeet Marker
Aperture Width % Reference Marker
0 [ -
Aperture Height % Relative Offset
110 [3

_K | Cocd| _Heb |

By default the Edit Marker Properties dialog box opens to the Main tab, where you can:
e Change the marker label text in the Marker Name field
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 Note

Markers can be used in equations by adding the marker label to an equation. Be aware that if you use a
marker label in an equation and then change the marker label in the Marker Name field, you must update your
equation with the new marker label.

e Change the marker type in the Marker Type field

e Select Delta or Offset mode in the Marker Mode field, or Off to deactivate those modes
e Control the aperture size using the Peak/Valley Marker area

e Select the reference marker in the Delta/Offset Marker area

e Enter the relative offset value in the Delta/Offset Marker area

The Symbol/Label tab enables you to make changes to the marker label and symbol appearing on the trace. You
can:

e Select a font type, text size and text color for the label in the Marker Label area
e Change the marker color using the Marker Color dropdown menu

Select the Readout tab to edit the marker readout. This tab enables you to:

e Select a font type

e Select a text size

e Select a text color

e Select a readout format

e Select a complex format

e Enter a number of significant digits

 Note

Before you click OK, you can check the Don't Move Readout With Plot checkbox to keep a specific marker
readout from moving with the associated plot. Note that this behavior is not saved between sessions and the
default behavior is always unchecked.

If the marker is used on a Smith chart, click the Smith tab, where you can:

e Select a marker type
e Select a marker format
e Enter a number of significant digits
e Select a complex format
e Select the Zo type
3. Click OK to close the dialog box and accept the changes.

Changing Marker Type

You can change the type of an existing marker in one of two ways:
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e Double-click the marker or its readout and use the Edit Marker Properties dialog box to select a different type of

marker.
OR
e Select the marker and right-click the mouse, then select a different marker type from the popup menu.

ltem Optons...
Delete Ol

Drelta Mode On
Offset Mode On
Delta/Offset Mode OFF

Mext Data Point
Frevious Data Point

Norma

Peak,

Valley
Pl

Min

Deleting Markers

To delete markers, do the following:

1. To delete a single marker, single-click on the marker. For multiple markers, hold the Shift key down and
single-click on each marker of interest.
2. Press the Delete key or choose Edit > Delete.

Setting Marker

Preferences
Marker preferences set the default marker properties and determine the appearance of a marker when it is inserted

onto a plot.
Marker preference changes will apply to all markers created after the changes were made and saved. To change
properties for an existing marker, refer to Editing Markers.

To save and reuse preference settings, you can create a preferences file that can be read by the data display. For
more information on how to create and use such a file, refer to Setting Data Display Preferences.

To set marker preferences, do the following:
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1. Choose Options > Preferences to display the Preference dialog box.
2. Click the Marker tab to edit the marker preferences.

Preference:0 E
Tiace | Plot  Matker | Test | Equation | Line | Rectangle | C4[ *]
Main | Freadout | Srith |
Marker Label
Fant Type Faont Size
|Avial For CAE ~|E
Test Color
K
Markiet Codar
e ———
Peal.fd abey Madker Difzet Marker
Apeiture Widh 3 Relatrees Offset
[10 |.3
Apesture Height %
(10
DKk | Save.|  Read. Cancel | Help |

There are three tabs under the Marker tab. Use the Main tab to:
e Select a font type, text size and text color for the label in the Marker Label area
e Change the marker color using the Marker Color dropdown menu
e Change the aperture size using the Peak/Valley Marker area
e Enter the relative offset in the Offset Marker area

Use the Readout tab to set the marker readout preferences:

Select a font type
Select a text size
Select a text color
Select a readout format

Select a complex format (for Polar plots or Smith Charts)
Enter a number of decimal digits

If the marker is used on a Smith Chart, click the Smith tab, where you can:

Select a marker type

Select a marker format

Enter a number of decimal digits
Select a complex format

Select the Zo type
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3. Click OK to close the dialog box and accept the changes.

Marker Readout

A marker readout includes:

A label that matches the label on the marker

e The value of the independent variable

e The value of the dependent variable. Values from polar plots and Smith charts are displayed in real and
imaginary components; markers on Smith charts also display either impedance or admittance. Values from
rectangular and stacked plots are returned in scalar format.

e The sweep value of the marker's position in the data

e The marker type (displayed for all marker types except for Normal marker)

Marker label —m4

Independent varisble — |y Delta=9. 000ES
Dependent variable _dep Delta=-3.270

Sweep indicator 2

Markertype ————\/g|ley, Delta Mode ON

Editing the Marker Readout

The independent value of the marker readout can be edited directly, thus avoiding the need to drag the marker to a
particular value. The following example illustrates the position of the independent variable value and units.
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Mote that only the value
and units are editable
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To edit the independent variable value:

1. Click the independent variable value and units portion of the marker readout. The text will turn red.
2. Enter the new value and/or units. The marker indicator will move to the point nearest the entered value.
Conversions between understood units will be updated automatically.

 Note

The units evaluator only understands a limited set of units. For instance, in the example shown above, usec is
understood as microseconds (i.e. 10e-6 seconds); however, micro secs is not.

Delta Mode

The difference between two markers can be displayed using delta mode. The readout of the selected marker changes
relative to the marker that you assign as the reference.

You can select any markers in a data display for comparison in delta mode. The markers can be on the same trace, on
different traces in the same plot, or on different traces in different plots. The delta marker equation is:
delta = delta marker - reference marker

The following example shows two markers used in delta mode. Note that the marker in delta mode is rotated. The
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reference marker is unchanged.

m2 is the delta. It displays m2 - m1 (delta marker - reference marker) results.
VCEmZ2 - VCEm1=2-2=0
IC.im2 - 1C.im1 = 10mA - 2mA = BmA

12
7 m2 m2
A ind Delta=0.000
IBB=0.000100
or dep Delta=0.008
= delta mode ON
[ ITI1 T
m1
L 4 T VCE=3.000
IBB=0.000020
IC.i=0.002
T T | T T T T | T T T T | T T T T | T T T T
1 2 3 4 5

m1 is the reference marker. It does not change.

To activate delta mode:

1. Hold the shift key and select the markers you want to display in delta mode. Be sure to include the reference
marker.

& Hint

As an alternative to selecting markers, you can select the marker readouts.

2. Choose Marker ** > ** Delta Mode On or right click and select Delta Mode On from the popup menu.

3. A dialog box appears listing the selected markers. Select one marker from this list to be the reference marker.
4. Click OK.

To deactivate delta mode Choose Marker ** > ** Delta/Offset Mode Off or right click and select Delta/Offset Mode Off
from the popup menu.

You can also activate and deactivate delta mode using the Edit Marker Properties dialog box. For more information
refer to Editing Markers.

Offset Marker

An Offset marker enables you to set a fixed offset from a reference marker on a linear trace contained in a rectangular
plot. When you move the reference marker, the Offset marker moves with it, keeping the relative offset unchanged.
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The Offset Marker snaps to the closest actual data point that matches the value you define in the Edit Marker
Properties dialog box. You can control which side of the reference marker the Offset marker will reside.

The following example shows two markers used in offset mode. Note that the marker in offset mode is rotated. The
reference marker is unchanged.

Feferencetarker
indep(Referencetarker)= 157076
data2=10.000

Referengehﬂarker Peak

1 Offsethdarker

5| ind offset=14106.000
i Crfsetidarker dep offset=-3.000

b Offset Mode O

T Lata

0. S0B4 10DES 15B5 20BE5 28BS 30ES 35BS
®Data

To activate offset mode:

1. Hold the shift key and select the markers you want to use in offset mode.

@ Hint

As an alternative to selecting markers, you can select the marker readouts.

2. Choose Marker > Offset Mode On or right-click and select Offset Mode On from the popup menu.
3. A dialog box appears listing the selected markers. Select one marker from this list to be the reference marker.

4. Click OK.

© Note

When you activate offset mode in this way, the offset is set to the default relative offset. To change the default
offset, use the Preference dialog box. For more information refer to Setting Marker Preferences. If you need to
set a unique offset each time, activate offset mode using the Edit Marker Properties dialog box. For more
information refer to Editing Markers.

To deactivate offset mode use one of the following options:
e Choose Marker > Delta/Offset Mode Off or right-click and select Delta/Offset Mode Off from the popup menu.

You can also deactivate offset mode using the Edit Marker Properties dialog box. For more information refer to Editing
Markers.
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 Note

When you attempt to add an Offset marker on a trace or a plot that doesn't support this marker type, the
marker is automatically converted to delta marker and a warning message pops up. The warning will also
occur if you change the trace type or if the simulation results change the automatic trace type to an
unsupported type.

Peak and Valley Markers

Peak and Valley markers enable you to find the localized data peaks and valleys of a linear trace contained in a
rectangular plot.

 Note

The value of each peak may be lower than the maximum data value for the entire trace, and the value of each
valley may be higher than the minimum data value for the entire trace. To find the minimum and maximum
data values use the Min and Max markers.

You can insert and drag Peak and Valley markers like any other marker. These markers snap to peak or valley points
automatically, and you can then move them to the next/previous peak/valley in different ways:

e Use the arrow keys on your keyboard.
e Use the arrow buttons on the Marker toolbar.
e Select Next data point or Previous data point from the Marker pulldown menu or popup menu.

 Note

When a Peak or Valley marker is placed on a trace or a plot that doesn't support this marker type, the marker
is automatically converted to a supported marker type (Max/Min) and a warning message pops up. The
conversion also occurs if the trace type is changed, either by you or by simulation results, to a type that
doesn't support Peak and Valley markers. Note that the markers are not automatically converted back to their
original type even if the data is restored to its original type.

Peak and Valley Marker Aperture

A marker aperture enables you to selectively include or exclude data peaks and valleys.

The aperture is a box that surrounds the marker and is used to identify peaks. It reflects the percentage of the
maximum data range. To include smaller peaks/valleys, make the aperture smaller, and to reject smaller peak/valley
locations, make the aperture larger.

The following figures demonstrate the role of the marker aperture:

e The first figure is an example of an invalid peak, because the data inside the aperture does not form a peak (in a
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valid peak the slope of the data leading to the peak is positive and the slope of the data trailing the peak is
negative).

1.4

] i
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I Pt [} m1
1.0 4 . % / S Data inside aperture
/ - ' e— does not form a valid
N ]I A peak
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e Reducing the size of the aperture (as shown in the next figure) makes the marker location a valid peak.
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The aperture enables you to reject peaks that you are not interested in, an important capability with signals that have
many "noisy" peaks.

To change the aperture size...
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1. Double click a Peak/Valley marker or its readout to display the Edit Marker Properties Dialog box.

2. Select the Main tab.

3. Use the Aperture Width % and Aperture Height % fields in the Peak/Valley Marker area to change the width and
height of the marker.

4. Click OK to save the changes and close the dialog box

To change the default aperture for all newly created Peak and Valley markers, refer to Setting Marker Preferences.
The new default aperture will apply to all markers created after the changes were made and saved.

Max and Min Markers

The Max marker snaps to the maximum data point of a trace, and the Min marker snaps to the minimum data point of
a trace.

You can only move Max and Min markers on a trace if there are multiple (equal) maximum data points or minimum
data points on the same trace.

To move a Max/Min marker to the next or previous Max/Min data point, select the marker and...

e Use the arrow keys on you keyboard
e Use the arrow buttons on the Marker toolbar
e Select Next Data Point or Previous Data Point from the Marker pulldown menu or from the marker popup menu

Autoplot, Probe Circuit, and Snapshot

This chapter describes some additional features of the Data Display including some features designed for the RF
Design Environment (RFDE). The Autoplot and Probe Circuit features described in this chapter are provided for
Cadence users who have installed RFDE and want to take advantage of the automated Data Display plotting capability.
The features described in this chapter are:

e Autoplot in RFDE

e Probe Circuit in RFDE

e Snapshot

Autoplot in RFDE

Autoplot in RF Design Environment enables you to control whether or not to automatically launch a Data Display
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window with your simulation results after a simulation is run. The Autoplot feature is enabled by default.
A Data Display window can be accessed in RFDE:

e When you click the Plot Outputs button. m

¢ When you select the Results > Plot Outputs menu item.
e After a simulation is run if Autoplot enabled .

To enable/disable Autoplot:

1. Choose Results > Data Display Options .
The Data Display Options form appears.

2. Select the Open Data Display After Simulation option if you want to automatically launch a Data Display window
after a simulation has completed. Deselect the option to disable this feature.

3. Select the Translate Results to PSF option if you want your output dataset translated to parameter storage
format (PSF), Cadence's native data format. This will enable you to view your output in the Cadence Waveform
Viewer. For information on this option, see the Using Circuit Simulators manual, "Simulation Basics" chapter,
"Dataset-to-PSF Conversion in RFDE" section.

4. Select the Enable Automatic Plotting of Output option if you want to automatically display the outputs defined on
the Outputs section of the Simulation window. When a measurement expression is added and this option is
enabled, a new plot will be created for the expression. Deselect the option to disable this feature.

5. The _

Dataset Used for Automatic Plotting_ option defaults to Use most recent dataset . Most analyses produce only a
single dataset. However, distributed simulation and wireless test bench can produce multiple datasets. The
Prompt for dataset selection enables you to choose from the available datasets during Plot Outputs.

6. Click OK to save your settings.

 Note

A separate plot is generated in the Data Display for each analysis type (i.e., AC, DC, HB, SP, Tran, and Env).

Probe Circuit in RFDE

The Probe Circuit feature enables you to interactively select voltages and currents from the simulation or schematic
window for plotting in RF Design Environment. You can plot common outputs quickly by choosing Results > Probe
Circuit from the main menu and then selecting a net or terminal in the schematic window. The Probe Circuit interface
also provides access to a pre-defined set of measurement expressions for the various analysis types. For information
on the pre-defined set of measurement expressions, refer to Expression Builder in the Measurement Expressions
documentation.

Before you can plot your results in a Data Display window, you need to run or have already run, a simulation.

To use Probe Circuit after running a simulation:
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1. Choose Results > Probe Circuit . Note that the menu is divided into two sections. The top section includes quick
access menu items that only require you to select a voltage or current on the schematic to display the results.
The bottom section of the Probe Circuit menu displays a list of analysis types (see the following table). After
selecting an analysis type, the Probe Circuit form appears enabling you to further define your output.

Analysis Type Measurement Description
DC DC Simulation
AC AC Simulation
SP S-parameter Simulation
Tran Transient (Time-Domain) Simulation
HB Harmonic Balance Simulation
LSSP Large-Signal S-parameter Simulation
Env Circuit Envelope Simulation
© Note
Some menu items in the Probe Circuit menu may be inactive if the corresponding analysis data is not
available.

2. In the Probe Circuit form, select the desired output option from the Plot Options section. The Probe Circuit Plot
Options are described in the following table.

Plot Option Description

Create a new plot Probe circuit default. Enables you to add outputs from
schematic to a new plot.

Add a trace to the selected plot Enables you to add multiple traces in a single plot.

Print numerical data Enables you to display your data in a tabular format.

3. The Analysis Type pull-down menu defaults to the analysis selected from the menu item. You can select any
analysis type in the menu; however, if the analysis data for that particular type is not available, a Data Not
Available message is displayed in the Measurement pull-down menu.

4. The Measurement pull-down menu contains a set of pre-defined measurement expressions to choose from. Use
the Measurement pull-down menu to select a specific measurement.

 Note

Depending on how your environment is configured, you may need to expand the Probe Circuit form to display
all of the options available for each measurement.

5. Click the Select button next to the desired voltage or current and view the prompt in the schematic window. The
prompt displayed will tell you what to select in the schematic window. The prompts are described in the following

table.
Prompt Description
Select a net This prompt appears when selecting a voltage.
Select a current probe or voltage source This prompt appears when selecting a current. Because

the simulator does not compute terminal currents, you
will need to select a current probe or voltage source
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instance.

6. Select the signal necessary for the function. The net name will be added to the field for the item you selected.
7. For certain outputs, you can select a specific Window Type . Windowing is used to reduce discrete Fourier
transform (DFT) leakage. For more information on Window Types, refer to the ts() function in the Measurement
Expressions documentation.
Depending on your selection, additional options are listed which enable you to further define your outputs.
Several example options are shown in the following table.

Options Description
Number of Points This field accepts either an integer or a string variable.
Stop Time This field accepts either a Real number or a string
variable.
Harmonic Index This field accepts a Vector number in the form {0, 23}.
S-parameter For Probe Circuit, this field is a selection field.

For detailed information on specific options, refer to the Expression Builder ** in the Measurement Expressions
documentation.

8. After selecting all of your voltages and/or currents and entering any other appropriate information, click OK in
the Probe Circuit form. The Data Display is launched with your results.

9. You can add additional traces to your plot by selecting Add a trace to the selected plot or display your data in
tabular form by selecting Print numerical data as described in the table of Probe Circuit Plot Options.

Snapshot

If you are running a long simulation and you want to look at data for a particular point in your design, or you just
want to check the progress of your simulation, you can take a Snapshot of the simulation results to quickly view the
data.

Snapshot in RFDE

To enable Snapshot mode, you first need to select your outputs. If you have not selected any outputs on the
schematic, the result will produce a blank Data Display window. Also, if the simulation is not running, clicking the Plot
Outputs button will launch a blank Data Display or a plain Data Display with the plots that you have configured for it.
To setup and enable a Snapshot:

1. Choose Outputs > To Be Plotted > Select on Schematic .

2. Use your cursor to select an output on the schematic. You can add additional outputs by simply continuing to
click points in your design.
An entry for each selected output appears in the Outputs section of the Circuit Design Environment window. Note
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that the Plot column displays yes for each of the selected outputs.
Once you have all of your outputs defined, choose Simulation > Netlist and Run or click the Netlist and Run
button to launch your simulation.

o
At any point during the simulation, choose Results > Plot Outputs or click the Plot Outputs button to display a
Snapshot of your results. m

The Data Display window is launched with your simulation data for that particular point in time.

While Snapshot makes sense for longer simulations, Autoplot in RFDE is recommended for shorter simulations.

i)

Note
Most Cadence users are familiar with the Cadence Snapshot mode which launches the Cadence Waveform
Viewer. In contrast, the RFDE Snapshot mode launches the Agilent Data Display.

Snapshot in ADS

To launch a snapshot during a simulation from an Advanced Design System schematic window:

Choose Simulation > Snapshot . When a snapshot is triggered in ADS, the snapshot display is updated soon after the
next available swept point in done. If a previous request is being processed, the subsequent request is ignored and a
status window is displayed that says,

Snapshot is being processed, please wait...

The dataset is then updated and the data display window is launched.

i)

Note

If the data display window associated with the particular design or simulation has been previously configured,
the window should display the appropriate graph or output. However, if you have not configured the data
display window for your specific simulation, an empty data display window that includes the dataset attached
may appear.

Some additional details for ADS snapshot:

A snapshot request that is sent after a simulation is completed will be ignored.

Snapshot is not available for Momentum simulations.

Snapshot is supported for remote simulations.

Results of source currents (e.g. include, I-Probe) and voltages of named nodes can be displayed in snapshot;
however, measurement data are not always valid. If the measurement variable is defined on a point base (i.e.
does not cross sweep points), and it is defined in the output plan inside the analysis, it can be displayed in
snapshot. Otherwise, the data will be invalid.

Eye Diagram FrontPanel
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The Eye Diagram FrontPanel enables easy computation of waveform and eye diagram measurements. Many of the Eye
Diagram FrontPanel measurement algorithms are derived from the Agilent Technologies Digital Communication
Analyzer but with simplified implementation. The Eye Diagram FrontPanel supports the NRZ data type.

For information on measurement expressions specific to the Eye Diagram FrontPanel, see Chapter 12, "FrontPanel Eye
Diagram Functions," in the Measurement Expression documentation.

The Eye Diagram FrontPanel can be accessed from the Data Display window or from the Schematic window.

e To access the Eye Diagram FrontPanel from the Data Display window, choose Tools > FrontPanel > Eye.
e To access the Eye Diagram FrontPanel from the Schematic window, choose DesignGuides > Signal Integrity
Applications > Eye Diagram FrontPanel.
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The basic measurements steps are:

Select Dataset.

Select Trace.

Define Data Rate in frequency units and define a measurement expression if required. See Defining Data Rate.
Select Measurement buttons to display various measurements. See Making Measurements.

AL

Defining Data Rate

When you select a trace name, the User Defined Data Rate dialog box appears.
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X

Trace Mame/Expreszion

Enter Trace Expreszion [if required]:

| ariable Infa... I

[ata R ate

E ztimate Data Rate |

I
Ok | Cancel |

The selected trace name appears in the Enter Trace Expression field. This field can also be used to enter an
expression. For example, the expression in the following dialog box produces the time difference differential NRZ
waveform from a Harmonic Balance simulation.

I Data Rak T

Trace Mame/E <prezsion

Enter Trace Expreszion [if required;
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Data Fate
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|5e9

3 | Cancel |

For waveform/eye diagram parameters, you need to define the NRZ data rate in the Data Rate field. If the data rate is
unknown, click the Estimate Data Rate button to approximate the rate. For circuit envelope simulation data, you can
define the expression to extract the NRZ baseband envelope using the frequency index.

Changing Measurement Settings

The Measurement Settings button displays the Plot Settings dialog box. You can define the Start Time, Stop Time,
Data Rate, Eye Boundary and Threshold Settings for waveform and eye diagram measurements. You can also change
the color preference for traces.
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Plot Settings:1 |
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To enable trace color grading for rise, fall, and eye diagram traces, select the Color Grade check box located below the
Measurement buttons.

Making Measurements

The Eye Diagram FrontPanel has two different measurement modes:

e Oscilloscope Mode

e Eye/Mask Mode

Oscilloscope Mode

In Oscilloscope mode, all measurements are performed automatically. Some measurements, such as peak-to-peak
jitter, require user intervention.

110



Advanced Design System 2008

i Hoda Gebect Dokt Gebeok Trace i Mansseraurd. S alings |
& Oecleosops |Tn:r_1[hn_m;_3l'4:q_1 :"Dl.ﬁ ﬂ [inda Tope = NFZ
1 B ek {15100 Teme =341 321 320008

[o1on e - 1 Szt 007
3 L] = A0
e [T s Dirionn = e
Theeslodd = 20 -20%

Epm Brmevdong = A0 605

Waniuramend Felly I

eSPEEE

H—T—T T T T T T T T T
[T PR PR TR TIY 2 BT T I T St 2]
bren

7
.
i

B

El

The Waveform button displays the time domain waveform.

The pointer maker on the waveform indicates the segment of the waveform used for parameter measurement. To
change the start and stop values, click the Measurement Settings button then edit the Plot Settings dialog box.
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The Amplitude Histogram button displays the amplitude histogram waveform.

A default sampling rate of 451 samples per wavelength across the time axis and 321 samples across the amplitude
axis is used to construct the amplitude histogram. This provides an idea of the level one and the zero of the
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waveform. To smooth out the noisy display of the amplitude histogram, increase the smoothing factor by adjusting
the Smoothing factor slider on the Amplitude Histogram dialog box. To readout the number of samples and amplitude
information, adjust the Marker slider.
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The Rise Time Measurement button displays the overlaid rising edge plot used for rise time computation.

Rise time is a measure of the transition time of the data on the positive (rising) edge of a waveform. The edge crosses
through the lower, middle, and upper threshold levels. The rising edges, which do not cross through all three
threshold levels, are not displayed and are not included in rise time computation. Horizontal histograms are created
across lower, middle, and high threshold levels of this display. The mean values at low and high threshold levels are
computed for rise time calculation. The default setting for the threshold levels are the 20% to 80% points on the
transition. To change the default threshold settings, click the Measurement Settings button then edit the Threshold
Settings tab in the Plot Settings dialog box.
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Pointer markers are placed at low, middle, and high threshold levels.
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The Fall Time Measurement button displays the overlay falling edge plot used for fall time computation.

Fall time is a measure of the transition time of the data on the negative (falling) edge of a waveform. The edge
crosses through the upper, middle, and lower threshold levels. The falling edges, which do not cross through all three
threshold levels, are not displayed and are not included in fall time computation. Horizontal histograms are created
across lower, middle, and high threshold levels of this display. The mean value at low and high threshold levels is
computed for fall time calculation. The default setting for the threshold levels are the 20% to 80% points on the
transition. To change the default threshold settings, click the Measurement Settings button then edit the Threshold
Settings tab in the Plot Settings dialog box.
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Jitter is @ measure of the time variances of the rising or falling edges of a pulse waveform at the middle threshold.
When a jitter measurement is selected, the instrument's measurement database is enabled. The waveform data that is
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sampled is accumulated in the measurement database.

2

The Rising Edge Jitter Histogram button displays the jitter histogram for the rising edge.

Jitter is a measure of the time variances of the rising or falling edges of a pulse waveform at the middle threshold.
When a jitter measurement is selected, a measurement window is placed horizontally through the middle threshold.
This measurement window is narrow in amplitude. A time histogram is then generated and the peak-to-peak jitter
value is determined. RMS jitter is defined as one standard deviation from the histogram mean.
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In the Rise Histogram dialog box, adjust the sliders on the Window Marker tab to define the rectangular area for jitter
histograms. Adjust the sliders on the Curve Fit tab for Gaussian fitting of the jitter histogram. If the jitter histogram
has a deterministic jitter component, the curve fit can be used to create a Gaussian curve in the tail region. The mean
and standard deviation of this Gaussian curve is displayed.
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The Falling Edge Jitter Histogram button displays the jitter histogram for the falling edge.
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Jitter is a measure of the time variances of the rising or falling edges of a pulse waveform at the middle threshold.
When a jitter measurement is selected, a measurement window is placed horizontally through the middle threshold.
This measurement window is narrow in amplitude. A time histogram is then generated and the peak-to-peak jitter
value is determined. RMS jitter is defined as one standard deviation from the histogram mean.
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In the Fall Histogram dialog box, adjust the sliders on the Window Marker tab to define the rectangular area for jitter
histograms. Adjust the sliders on the Curve Fit tab for Gaussian fitting of the jitter histogram. If the jitter histogram
has a deterministic jitter component, the curve fit can be used to create a Gaussian curve in the tail region. The mean
and standard deviation of this Gaussian curve is displayed.

The Measurement Summary button displays the measurement summary of the waveform parameters.
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Waveform Measurement Results

Start time 9.413E-9

Stop time 1.667E-T

Start index 1.412E3

Stop index 2.500E4

Sweep size 2.500E4

Data rate 3.000E9

Start measurement time 9.13E-9
Stop measurement time 1.644E-7
Minimum amplitude 0.007
Maximum amplitude 0.483
Low threshold 0.131

High threshold 0.363
Waveform level zero 0.053
Waveform level one 0.4
Waveform level mean 0.247
Waveform amplitude 0.388
Average rise time 1.719E-10

Average fall time 1.693E-10

15t period duty cycle 49.474

1st edge rise time 1.572E-10

15t edge fall time 1.507E-10

1=t positive pulse width 3.299E-10
15t negative pulse width 3.370E10
1=t rizing edge frequency 1.499E9
1st falling edge frequency 1.500E9
12t riging edge period 6.669E-10
1=t falling edge period 6.666E-10
Rizing edge jitter {pp} 3.769E-11
Rizing edge jitter {rms) 1.119E-11

EBye/Mask Mode

In Eye/Mask mode, the eye diagram is displayed for the user defined data rate and most measurements are
performed automatically.
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=

The Eye Diagram measurement button displays the eye diagram.
X
-+

The Eye Boundary measurement button displays the detected eye crossing points, the level one and level zero, the 3
sigma points, and the eye boundary (40% -60%), which indicates the measurement region between eye crossing
points. Use this display to verify and debug eye diagram measurements.

E

The Eye Rise Time measurement button displays the rising edge trace on the eye diagram.

The pointer markers indicate the threshold values. The eye diagram level one and level zero (computed within eye
boundary region) are used to compute the threshold levels. Rise time is a measure of the transition time of the data
on the waveform's positive (rising) edge. The edge crosses through the lower, middle, and upper threshold levels. The
rising edges, which do not cross through all three threshold levels, are not displayed and are not included in rise time
computation. Horizontal histograms are created across lower, middle, and high threshold levels of this display. The
mean value at low and high threshold levels is computed for rise time calculation. The default setting for the threshold
levels are the 20% to 80% points on the transition. To change the default threshold settings, click the Measurement
Settings button then edit the Threshold Settings tab in the Plot Settings dialog box.

0D

0.45_|
0404

0.25 ] T
0.30 L
0.25_| “\
0.20_|

0154

-5.0E . 5.0E11

e

The Eye Fall Time button displays the falling edge trace on the eye diagram.
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The pointer markers indicate the threshold values. The eye diagram level one and level zero (computed within eye
boundary region) are used to compute the threshold levels. Fall time is a measure of the transition time of the data on
the negative (falling) edge of a waveform. The edge crosses through the lower, middle, and upper threshold levels.
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The falling edges, which do not cross through all the three threshold levels, are not displayed and are not included in
fall time computation. Horizontal histograms are created across lower, middle, and high threshold levels of this
display. The mean value at low and high threshold levels is computed for rise time calculations. The default setting for
the threshold levels are the 20% to 80% points on the transition. To change the default threshold settings, click the
Measurement Settings button then edit the Threshold Settings tab in the Plot Settings dialog box.
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The Eye Jitter Histogram button displays the eye diagram jitter histogram.

NRZ Eye Jitter is the measure of the time variances of the rising and falling edges of an eye diagram as these edges
affect the crossing point of the eye. When a jitter measurement is selected, a measurement window is placed
horizontally through the middle threshold. This measurement window is narrow in amplitude. A time histogram is then
generated and the peak-to-peak jitter value is determined. RMS jitter is defined as one standard deviation from the
histogram mean.
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In the Rise Histogram dialog box, adjust the sliders on the Window Marker tab to define the rectangular area for jitter
histograms. Adjust the sliders on the Curve Fit tab for Gaussian fitting of the jitter histogram. If the jitter histogram
has a deterministic jitter component, the curve fit can be used to create a Gaussian curve in the tail region. The mean
and standard deviation of this Gaussian curve is displayed.
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The Eye Mask button displays the Eye Mask overlaid on the eye diagram plot.

A mask is a template that defines the regions on the eye diagram plots. Mask testing enables you to verify that the
displayed waveform complies with an industry standard waveform shape. To comply with the industry standard, the
NRZ waveform must remain outside the mask regions. The mask tracks the waveform as the waveform's parameters
are modified. The top, bottom, and center mask is automatically placed between the eye crossing points.

To modify the mask, adjust the slider bars in the Eyemask dialog box. You can alter the slope, the center mask length,
height and position of top/lower mask. You can also save masks at a global, local, or project level.
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The Measurement Summary button displays the measurement summary of the eye diagram parameters.

Eye Diagram Measurements

Start time 9.413E-9

Stop time 1.667E-7

Start index 1.412E3

Stop index 2.500E4

Sweep size 2.500E4

Data rate 3.000E9

Start measurement time 9.413E-9
Stop measurement time 1.644E-7
Eye level zero 0.068

Eve level mean 0.246

Eve level ohe 0.423

Eye amplitude 0.356

Eve height 0.206

Eve height {db) -6.860

Eye width 2.912E-10

Eve opening factor 0.795

Eye signal to noise 4,874

Eye duty cycle dist. 0.483E-13

Eve duty cycle dist. (%) 0.284
Eye crossing 1 time 1.716E-10

Eve crossing 1 amplitude 0.245
Eve crossing 2 time 5.047E-10

Eve crossing 2 amplitude 0.246
Average eye rise time 1.486E-10
Average eye fall time 1.494E-10
Eye jitter (rms) 1.132E-11

Eve jitter {(pp) 3.991E-11
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Saving the FrontPanel

H

The Save As FrontPanel Data Display toolbar icon saves the FrontPanel as a FrontPanel Data Display. The file is saved
with a .dds file extension. To open the saved FrontPanel, choose File > Open from the Data Display window.

|

The Save As Regular Data Display toolbar icon saves the FrontPanel as a regular data display and does not retain the
slider information. The file is saved with a .dds file extension.

Jitter Analysis FrontPanel

The Jitter Analysis FrontPanel enables easy computation of jitter separation measurements. Many of the Jitter Analysis
FrontPanel measurement algorithms are derived from an Agilent Technologies Digital Communication Analyzer, but
with simplified implementation.

For information on measurement expressions specific to the Jitter Analysis FrontPanel, refer to the jitter_separation()
function in the Measurement Expressions documentation.

The Jitter Analysis FrontPanel can be accessed from the Data Display window by choosing Tools > FrontPanel > Jitter
Analysis.
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M Jitter_Analysis [Instruction]:1

FE RIS R R

Measurements IMeazwement Sehup . I

Meamwement Fesuts

1. Press "Measurement Setup ..."
2. Specify dataset, traces, and trace parameters
3. Press "Start Analysis”

E‘ 4. Use Measurement buttons to manipulate results

Dataset Diaka Trace Clodk Trace

Follow these steps to perform jitter analysis:

Open the Measurement Setup dialog.

Select the Dataset and a suitable Data Trace.
Specify the Clock.

Define the Pattern Length.

Set the optional parameters.

Perform the analysis.

ok wN=

/r, Caution
Due to memory limitations, large datasets created for performing jitter analysis can cause instabilities in ADS.
This can result in the Data Display window crashing without saving the DDS file. To avoid losing any setup
information, save the DDS file before performing a jitter analysis.

Measurement Setup Dialog

From this dialog, you can specify all of the information required to perform a jitter separation measurement.
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X

Jitter Measurement Setup:1

Meazurement Data Trace Parameters
D atazet Pattern Length [integer ar expression)
I | Vaetelro... | |
Data Trace Mame/E spression Bit Period
| =l s =] _Estinste |
Clock Trace Mame/E xpression Data Rate

| =

| Help [click on item for description)

D atazet file containing zignal and clock,

Advanced Setup ... |

Cancel Help

To complete a successful analysis, specify the following:

e Dataset : This is the dataset file included in your current project that contains, at a minimum, the variable on
which the jitter measurement is to be performed. Once this dataset is selected, the Data Trace Name and Clock
Trace Name pull down lists will be populated with the variables contained in the dataset.

e Data Trace Name/Expression : This represents the data on which the jitter measurement is to be performed. You
may either choose a variable name from the list or enter an expression involving an appropriate variable name.
For simplicity, you may select the variable name and then edit the text to arrive at the desired expression.

) Note

Errors in the expression will not be identified until you try to perform the measurement.

¢ Clock Trace Name/Expression or Bit Period : If the dataset contains a variable that can be used (either alone or
in an expression) as the clock for the measurement, this can be specified. Alternately, specifying the Bit Period
will enable the analysis routines to determine the clock signal. If the data rate is unknown, click Estimate to
approximate the period from the Data Trace. Once a bit period has been specified, the corresponding data rate is
displayed.

e Pattern Length : This specifies the number of bits which form one period of the measurement pattern. It can
either be an integer number or an expression that provides this integer when evaluated.

) Note

Clicking on any item on the dialog will change the text in the Help box with some simple information regarding
the expected entry in that item.

Specifying a Time Gate
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To perform a jitter separation measurement on a subset of the data trace, specify a time gate which will limit the data
passed to the jitter analysis. Once a data trace has been specified, clicking Set Time Gate displays a plot of the data
along with a dialog containing two sliders used to move start and stop markers on the plot. The time corresponding to

the marker position will display below the sliders. Once you have selected a suitable window, click OK to return to the
Measurement Setup dialog.
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Specifying Optional Parameters

You can set a variety of optional parameters to improve the performance of the jitter measurement. These parameters
may be specified by clicking Advanced Setup to display the Jitter Measurement Advanced Setup dialog.
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Jitter. Measurement Advanced Setup:1

X

Bit Pattern Data Trace
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" Specify uzsing file

Bit Pattern (10110... Number of Sequences
| Browss... ||
Jitter BER Lewel Measwement Mode
[1e-12 .
. " Jitter Separation (R, D, TJ, P, 151, DDJ)
D ata Interpolation
|Mane > | @ Jitter Separation, Histograms, BER
AJ B andwidth ) )
| Marrow (pink] ﬂ " Jiiter Separation, Histograms, BER, Spectum
Edges Help [chck on tem for descnption)
. anually specify the pattem of bitz in one peniod of
*" Rising the sequence
ust be at least 01"
" Falling
* Bath
Restore Defaults

o | Iy

Use this dialog to specify the type of analysis performed by the jitter measurement (Measurement Mode). By default,
the Measurement Mode is set to compute the jitter separation as well as provide jitter histograms and bit error rate
(BER or Bathtub) results.

If a shorter analysis time is desired, change the mode to provide only the jitter separation results. If the spectrum of
the random and period jitter (RJPJ Spectrum) is desired, this can also be specified.

 Note
For large datasets, this spectrum computation may require significant computational time.

 Note
The plots that will be available after the computation is complete will depend on the Measurement Mode
selection.

The Advanced Setup parameters are equivalent to certain command arguments for the jitter_separation() function.
The table below describes each parameter; for additional information, see the jitter separation() function in the
Measurement Expressions documentation.
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Advanced Setup Parameter Equivalent Command Notes
Argument

Bit Pattern, Manually specify Pattern
e Manually specify the pattern of

bits in one period of the
sequence.
e Minimum pattern is [0, 1].

Bit Pattern, Specify using file Pattern
e Use a file name to specify the

pattern of bits in one period of
the sequence.
e Minimum pattern is [0, 1].

Bit Pattern (10110...) Pattern The choices are:

¢ A pattern entered manually, as
an array of Os and 1s (for
example:
[1,0,0,0,0,0,0,0,1,0]).

e A path to a pattern file (use the
Browse button to find a path).
The pattern bits in the file must
be space separated and in a
single line.

e If no pattern is specififed, the
pattern is automatically
detected from the signal bits.
For each sequence of data, the
pattern is detected and
compared with the previous
sequence pattern or the given
pattern. If the pattern matches,
that particular sequence of data
is used.

Jitter BER Level BERLevel

The probability level at which to
calculate TJ, RIpp in evaluating
bit error rate.

Must be between 1e-40 and
le-1.

Default setting is 1e-12.

Data Interpolation InterType

Interpolation to use between
points in original data
Choices are None and Linear.
Default setting is None.
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e For clock-type signals, the DFT
is calculated from the uniformly
spaced RJ, PJ time record,
where each value in the RJ, PJ
time record corresponds to a
voltage transition in the
clock-type waveform. For NRZ
data-type signals, the RJ, PJ
time record is not comprised of
uniformly spaced jitter values.
For these signals, the RJ, PJ
time record contains "holes"
caused by consecutive logical
ones or zeros. The lack of
information about the jitter at
times corresponding to these
holes makes it impossible to
determine the true RJ, PJ
spectrum.

RJ Bandwidth RIBWMode
¢ Bandwidth used for

computation of random jitter
(R7)

e Choices are Narrow (pink) and
Wide (white)

e Default setting is Narrow (pink)

e Jitter analysis uses a spectral
technique to separate RJ from
PJ. In the RJ, PJ Spectrum the
noise floor or baseline depicts
RJ. The narrow spikes above RJ
depict PJ (see RJ, PJ Spectrum
graph). This separation works
well for wide bandwidth RJ,
having a uniform PSD across
the entire jitter spectrum. But
in some cases, this is not the
norm and the PJ components
appear much broader. In such
cases PJ can be
mis-represented as RJ and this
affects the TJ (since T] is a
multiplier of RJ). Setting RJ
bandwidth mode to Wide or
White treats RJ as flat.

Edges EdgeType
e Data transition at which jitter is
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analyzed.
e Choose Rising, Falling, or Both.
e Default setting is Both.

Data Trace, Number of Nbps

Bits/Sequence ¢ Number of bits in a sequence or

acquisition.

e Must be at least the Pattern
Length

e Nbps is optional and the default
is 2 * Minimum # Whole Pattern
per sequence * Nbpp = 2 * 64
* Nbpp. (Nbpp is the number of
bits per pattern.) In most cases
this default value would work,
but in some cases this value
might need to be set manually
since this argument has a direct
bearing on the number of serial
bits needed for a valid jitter
separation and the RJPJ]
separation method.

Number of Sequences NumSeq
e Number of sequences in the

data.

e Must be at least 1.

e Can be used to control the
amount of data to be used in
jitter separation. The default
value is (# TIE Points)/Nbps,
and in most cases this would
work. But if increased control is
required over the number of
bits to be used, this argument
can be set to a different value.

Measurement Mode, Jitter Separation = MeasType Resulting data:

(RJ3, D1, T1, PJ, ISI, DDJ)
¢ Numeric (single-valued) jitter

separation.

Measurement Mode, Jitter MeasType Resulting data:
Separation,

Histograms, BER e Numeric (single-valued) jitter

separation.
e TJ, DDJ, RIPJ Histograms.
e DDJ vs. Bit and BER Bathtub.
e This is the default setting for
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Measurement Mode.

Measurement Mode, Jitter MeasType Resulting data:

Separation,

Histograms, BER, Spectrum ¢

Help (click on item for description) None

Performing the Jitter Measurement Computation

Numeric (single-valued) jitter
separation.

TJ, DDJ, RJP]J Histograms.
DDJ vs. Bit and BER Bathtub.
RJIPJ Spectrum.

Warning: Computation time
may be long.

This space is used to display
information about the advanced
settings.

Click on a setting to see the
information in the Help window

Once all of the parameters have been specified, click Start Analysis on the Measurement Setup dialog to begin the

measurement.

t.  Caution

Due to memory limitations, large datasets created for performing jitter analysis can cause instabilities in ADS.
This can result in the Data Display window crashing without saving the DDS file. To avoid losing any setup

information, save the DDS file before performing a jitter analysis.

After responding to some default warnings, the FrontPanel will inform you that it is completing the computation. Once
the computation is complete, the FrontPanel window will appear with the original data shown and with the jitter

separation results displayed as the Measurement Results .

) Note

If you do not wish to observe the warning dialogs, select the Do not show this dialog again checkbox.
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You may now interact with the results of your computation (assuming that you have selected a jitter Measurement
Mode which generates plots) using the measurements buttons on the left.

Time

ot

Clicking Time displays the time domain waveform of the original data used in the measurement (both the raw data
and the time-gated version if a time gate has been specified).

0.3

0z

0.1

0.0

StopFointer
StartPointer
JitDatasate
JitDataR aw

-0.1

-0.2

-0.3
I T | T I I | I | T |
0.000000 0.000002 0000004 0000006 0000008 0000010

time, =ec

130



Advanced Design System 2008

T,

Clicking TJ (Total Jitter Composite Histogram) displays histograms of the Total, Random plus Periodic, and Data
Dependent Jitter.
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Clicking DDJ (Data Dependent Jitter Composite Histogram ) displays histograms for data dependent jitter at the rising
edge (DDJR), falling edge (DDJF), and both edges (DDJ) if all measurements are available.
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Clicking TJ (Total Jitter Histogram) ___ button displays the histogram of the total jitter.
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TJHist
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Clicking RJPJ (Random and Periodic Jitter Histogram) displays the jitter histogram for the random plus periodic jitter.
]
a4
L
T
—a —
(L
=2
-
o ‘ H\H \H‘\ H\\ Hm
=120 =100 -80 -60 =40 =20 -0 20
Time, psec

| a8

Clicking DDJ (Data Dependent Jitter Histogram) displays the histogram for the data dependent jitter.
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Clicking DDJ vs Bit ___ displays the data dependent jitter for each bit index. To limit the range of the bits shown, use
the sliders that appear on the window when this plot is active. You may alternately specify the bit index by typing the
integer value into the corresponding text box.
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Clicking BER displays the bit error rate (bathtub) plot as a function of the fraction of the jitter of the unit interval.
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Clicking Spectrum ___ displays the frequency spectrum of the random and periodic jitter.
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Clicking Quad displays the four of the results together: TJ Composite Histogram, DDJ Composite Histogram, BER, and
RJPJ Spectrum.
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Saving the FrontPanel

=

The Save As FrontPanel Data Display toolbar icon saves the FrontPanel as a FrontPanel Data Display. The file is saved

135



Advanced Design System 2008

with a .dds file extension. To open the saved FrontPanel, choose File > Open from the Data Display window.

=l

The Save As Regular Data Display toolbar icon saves the FrontPanel as a regular data display and does not retain the
slider information. The file is saved with a .dds file extension.

! Caution
When you close the FrontPanel, you will lose all of the computed data. This means that when you reopen the
file either as a FrontPanel or a regular data display, you will have to wait for the computation to complete.
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