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About Digital Filter Designer

Digital Filter Designer is an integrated application within Advanced Design System's DSP Designer Pro and an option
with DSP Designer. It is a specifications-based software tool for designing, simulating, analyzing, and generating
coefficients for high-quality digital filters.

Digital Filter Designer enables you to design and analyze a range of digital FIR and IIR filters based upon your
specifications. Digital Filter Designer can automatically calculate the least number of taps that meet the desired
response specifications, and it can generate both a schematic and a table of coefficients for the designed filter.

The Digital Filter Designer environment has a Main window for entering the filter design specifications and a Status
window to display feedback, error, and status messages.

The results of an analysis are automatically displayed in a separate Data Display window that can be configured to plot
the frequency response, unit pulse response, unit step response, group delay, poles/zeros, and eye diagram. It can
also be used to display the coefficients in a table format.

Coefficients generated by Digital Filter Designer can be used to implement filters and they can be imported into
Agilent Ptolemy filter components. Schematics generated by Digital Filter Designer can be added to Advanced Design
System schematics.

Coefficient

_ _ _ (Generation
Filter Design and Analysis and
Specifications ™™ ™ Simulation ™™™ Data Display

=chematic

| .
Zenearation

Main Window

The Main window is displayed each time the application is launched. It displays a set of specifications that may be
modified as desired.
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In general it may be fruitful to think of the Main window in terms of its three regions, each with its own focus: filter
specification area, response specification area, and filter implementation area. While the first two regions are used to
design an ideal filter, the third region is used to specify the details for conversion from the ideal filter to a practical
filter design.

#» Note * Disabling conversion reduces the filter design time. So, if your current focus is to generate only an ideal
filter design, choose *Options > Disable/Enable Conversion to deactivate the implementation functions.

Menus and Toolbar
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The Digital Filter Designer environment provides six menus along with a toolbar that includes buttons for commonly
performed tasks.

Menubar

The Digital Filter Designer menubar is made up of the following six menus:

e File

e Design
e Options
e View

e Tools

e Help

The File menu includes the standard Advanced Design System project and file manipulation commands. The Design
menu includes commands used to design a filter based upon the displayed specifications and generate a schematic of
the filter design. The Options menu provides customizing options along with commands to use alternative design
methods. The View menu provides a command to display the filter coefficients and the toolbar. The Help menu
provides commands to access online documentation and context-sensitive help.
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Toolbar

The Digital Filter Designer toolbar includes frequently used buttons for folder and file manipulation, filter design, filter
analysis, and output generation tasks.
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The function of each button on the toolbar (going from left to right) is as follows:

e New Project

¢ Open Project

e Create New Filter Design

¢ Open Existing Filter Design
e Save Current Filter Design

e Print Current Filter Design

e Import Ideal Coefficients File
e Start Filter Design

¢ Analyze

e Setup Analysis Parameters
e [Root] Raised Cosine Wizard
¢ Disable/Enable Conversion
¢ Generate Schematic

¢ View Coefficients

e What's This?

Desired Response Tab

The Desired Response tab is used to enter the filter specifications for the desired response. These specifications
include the number of passbands and stopbands along with their frequency, amplitude, ripple, and phase values. The
numerical format, polynomial or linear, used to describe the amplitude can also be specified.
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Weighting Function Tab

The Weighting Function tab is used to define any weighting you may want to specify for the desired response.
Weighting specifications include the number of weightbands along with their frequency and magnitude values. The
numerical format, polynomial or linear, used for the frequency values can also be specified. The settings in this tab are

available when designing an FIR filter using either the Least Squares method or the Equiripple method with a manually
specified filter order.
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Other Parameters Tab

The Other Parameters tab is used to enter a collection of specifications for transformation, compensation,
symmetricity, and windowing parameters when designing certain special (and nonstandard) filters.
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Data Display Window

The Data Display window is used to plot and display the data and graphs generated when a filter is designed, a design
is analyzed, specifications are plotted, or coefficients are displayed. This window is launched automatically after a filter
is designed.

1 d
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Status Window

The Status window is displayed automatically when Digital Filter Designer is launched. This window is used to display
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feedback that is divided into two parts: simulation or synthesis messages including errors and warnings, and status or
summary messages.

— hpdspfilterui 16075@bamboo -53267:0
File Simulation/3ynthesis Text Window

Simulation # Sunthesiz Meszages

r-------------------------1

Status f Summary

Iz Starting Data Set Server process,,.

1T+ Starting Data Dlisplay Serwver process,,.
I Starting Digital Filter Engine process,,.
1T+ Program iz ready,

Digital Filter Designer Basics

The Digital Filter Designer offers you an integrated environment for creating and simulating a filter design based upon
your specifications. Once a filter is designed, you can view an analysis of its simulation in a Data Display window that
is launched automatically. The data displayed in this window can also be configured to use a variety of plot and
tabular options.

Digital Filter Designer uses the Advanced Design System project paradigm. A project acts as a container for the data
generated in designing, simulating, and analyzing one or more filter designs. It is also used to store the analysis
displays, filter coefficients, and implementation schematics.

You will need to create or open a design project before you begin using Digital Filter Designer for your filter design
tasks. Once you open or create a project, you can begin the process of either modifying an existing filter design or

12
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creating a new filter design using one of several available methods to define the filter specifications.

In addition to being able to print the filter specifications and the contents of any given display, coefficients or filter
taps generated using Digital Filter Designer can be exported in an ASCII format. Also, you can generate an

implementation schematic of the digital filter.

Define or Modify
Filter Specifications

f
Create or Create or Simulate and
Opena Open a ¥ Anal
| . yzZe a
Design ™ Filter r Filter Design
Project Design
L
Generate or
Import Filter
Coefficients

Launching Digital Filter Designer

View Filter
Coefficients
= and
Generate
Schematic

The Digital Filter Designer can be launched independently or from within the Advanced Design System (ADS).
Depending upon your computer platform and configuration, you can launch the Digital Filter Designer using any one of

the following methods:

From an ADS Schematic window:

Choose Tools > Digital Filter > Start Digital Filter from the Schematic window menubar for a signal processing design.

When you launch Digital Filter Designer this way, it uses the current design project directory and you can continue on

to creating or modifying a digital filter design.

On a UNIX workstation:

13
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To launch Digital Filter Designer without launching the ADS, type dfilter in a terminal window.

When you launch Digital Filter Designer in this manner, you need to open or create a project before you can continue
on to creating or modifying a digital filter design.

) Tip Navigate to within a project directory before you type dfilter in a terminal window to facilitate access to
designs within the project directory.

On a PC:

To launch Digital Filter Designer without launching the ADS, choose Start > Programs > Advanced Design System
2008 > ADS Tools > Digital Filter Designer .

When you launch Digital Filter Designer this way, you need to open or create a project before you can continue on to
creating or modifying a digital filter design.

Once Digital Filter Designer is launched and a project has been opened, the specification options in the Main window
become active. Choose Help > What's This? from the Digital Filter Designer menubar and click within the window to
display context-sensitive, online help for using the item you clicked.

Using Projects

Digital Filter Designer uses the Advanced Design System paradigm of projects. A project acts as an organizer of one or
more designs that may be created to accomplish a larger, overall design goal. A project is also used to keep together
all the information generated in the process of designing, simulating, analyzing, and implementing a digital filter
design.

Creating a New Project

You will need to create or open a design project before you can begin using Digital Filter Designer for your design
tasks. To create a new design project, choose File > New Project from the Digital Filter Designer menubar and display
the New Project dialog box.

14
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|

Project Hame
asnewlvchico /dd fpubs Msers Browse...
0K Cancel Help

Enter a name and path for the new project or click Browse and use the New Project File Browser dialog box to define
the path.

= Hew Project File Browser

Filter
new/wlv/chico/d4/pubs/users/*

selection

Directories Files
| hh

.- ke

.Quadralay .mosaic - personal-annotations
.cddbhslave .netscape

b softhench

TmUZduuPy . 4FI S

TmUZduuRG.0mC vue

TmUZduuRH. 3Va ads17

/new/wlv/chico/d4/pubs/usersd]/

oK Filter Cancel Help

Once you have defined a name and path, click OK in the New Project dialog box to create the project. A feedback
message is displayed to confirm that the current working directory has been changed to the project you specified.
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—| Current Working Directory Information |

« Hew project directory created successfully.
Current working directory has been changed to
famewr fwilvichicofd4pubsiusersidf_pH

0K

The Digital Filter Designer window is then updated to display the default filter specifications which you can modify as
desired to complete your digital filter design tasks.

Opening an Existing Project

To open and work within an existing project, choose File > Open Project from the Digital Filter Designer menubar and
use the Open Project dialog box that is displayed to locate the existing project you wish to use.

—| Open Project |
Filter
[funtitled_prj/=*
Directories Files
titled prji.
ititled_prjf.. .-
ititled_prjfdata data
ititled_prjfmom_dsn mom_dsn
ititled _prjmetworks networks
ititled_prjfsynthesis synthesis

ititled_prjfverfication verfication

Selection
Juntitled_prj/
Ok Filter Cancel Help
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Once you have selected the project you wish to use, click OK in the Open Project dialog box to open the project.

Managing Designs

Digital Filter Designer offers the standard file handling and management capabilities. Even though more than one file
or component is used to make up a design file, the interface is designed to present a simple and familiar environment.

Creating a Design

Choose File > New Filter Design from the Digital Filter Designer menubar to create a new design file. An alert message
is displayed to confirm whether you wish to save any changes made to the currently open file.

= Save Design |

Do you want to save changes to the current design?

Yes Mo Cancel

After you choose to save or discard any changes, a new, untitled design file is created and the Digital Filter Designer
window is updated to display the default filter specifications which you can modify as desired to complete your digital
filter design tasks.

Using Command Lines

Digital Filter Designer includes a command line interface that you can use to automate some of your filter design
tasks. Choose Options > Command Line to display the Command Line dialog box.

17
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— Command Line |

Comimand History

dfuiuser_set_auto_order_toggle value ("0");
dfuiuser_set_auto_order_toggle value ("1");
dfuiuser_set_order number_walue ("64");

dfuiuser_set auto_order_toggle value ("1");
dfuiuser set order number wvalue {"64");

dfuiuser set auto order toggle value ("0"});
diuiuser set auto order toggle value ("0"});

Command ==

I

7 Apply Cancel Help i

By keeping this dialog box open while you complete your filter design tasks, you can generate a list of commands that
you can reuse either directly or with any enhancements or parameters you wish to modify.

Opening a Design

Choose File > Open Filter Design from the Digital Filter Designer menubar to open an existing filter design file. An
alert message is displayed to confirm whether you wish to save any changes made to the currently open file.

After you choose to save or discard any changes, the File Open dialog box is displayed to enable you to identify the
existing file you wish to open.

18
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—| File Open |

Filter

1f_prj/synthesis/#*, f 11;

Directories Files
sfusersidf prsynthesis/. [ 1
1Isfusersidf_prjifsynthesis/..

Selection

sers/df_prj/synthesis/|

oK Filter Cancel Help

Once you have selected the design file you wish to use, click OK in the File Open dialog box to open the file and
proceed with your digital filter design tasks.

Retrieving Filter Designs

Choose Tools > Digital Filter > Retrieve and Place Current Ideal ( Scaled ) Coefficient Filter from an Advanced Design
System Schematic Window to retrieve a filter design and generate a schematic using the specified filter coefficients.
You must be running Digital Filter Designer to perform this operation. A schematic of the designed filter will be created
and saved using the filename you specify.

Using the Design List

If the design file you wish to open is located within the current project directory, choose File > Design List from the
Digital Filter Designer menubar to display the Design List dialog box that lists all the existing design files in the current
project.
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Click a design file to select it and click OK to open it. An alert message is displayed to confirm whether you wish to
save any changes made to the currently open file. After you choose to save or discard any changes, the design file
you selected is opened.

Using File History

If you wish to reopen one of the last four designs you created or modified using Digital Filter Designer, choose the
design from the list at the bottom of the Digital Filter Designer File menu. An alert message is displayed to confirm
whether you wish to save any changes made to the currently open file. After you choose to save or discard any
changes, the design file you selected is opened.

Importing Ideal Coefficients

To design a digital filter using an existing set of ideal coefficients, choose File > Import Ideal Coefficients File from the
Digital Filter Designer menubar and display the Import Ideal Coefficients File dialog box.

Import Filter Type

& FIR

—_

_J FIR Complex

Filename: || Browse...

oK Cancel Help

Enter a name and path for the file containing the ideal coefficients you wish to use or click Browse and use the File
Import Ideal Coefficients dialog box to define the filename and path.
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—| File Import Ideal Coefficients |

Filter

sr_prj/synthesis/#® mdb

Directories Files

dfilter_mpassideal.mdb

hesisf.. dfilter_mpassscaled.mdb

Selection

1filter_prj/synthesis/|

oK Filter Cancel Help

Once you have defined a name and path, click OK in the Import Ideal Coefficients File dialog box to import the file and
proceed with your digital filter design tasks.

Importing an AEL Ideal Coefficients Function

Digital Filter Designer also enables you to test, view, edit, and import an AEL function you've created to generate the
ideal coefficients for a custom, Gaussian, or Edge standard digital filter. Using this import function you can create your
own special FIR filter that can then be scaled, quantized, and implemented for simulation and synthesis.

To design a digital filter using an AEL function to generate its coefficients, choose File > Import Ideal AEL Coefficients
Function from the Digital Filter Designer menubar and display the Import Ideal AEL Coefficients Function dialog box.
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= Import ldeal AEL Coefficients Function
Import Filter Type: FIR

AEL Filename: Browse...

AEL Function name:

View fEdit Test

oK Apply Cancel Help

Enter a name and path for the file containing the AEL function you wish to use or click Browse and use the File Import
Ideal AEL Coefficients Function dialog box to define the filename and path.

You can use the Import Ideal Coefficients AEL Function dialog box to display and edit the function, and to test it. For
details on using AEL to create a function, refer to Manipulating Arrays".

Click OK in the Import Ideal AEL Coefficients Function dialog box to import the function and proceed with your digital
filter design tasks.

#» Note An AEL template that can be customized is included with the current installation of Digital Filter Designer.
You can modify this template to design symmetric FIR filters according to GSM specifications using the desired
rolloff, symbol period, and tolerable order values. The AEL template is located in the
$HPEESOF_DIR/dfilter/function directory.

Ideal Coefficients File Format

The ideal coefficients file you import needs to be created using a specific format. An example template is shown here.
Note that for an FIR filter, coefficients must be entered in a decimal format, while those for an IIR filter are entered in
a matrix format.

FIR Filter IIR Filter

BEGIN FIR# FIR % X 0.0012 0.234 ... 0.0023 END BEGIN IIR# IIR (time_dim parm_format T t
QuantizeCoeff) % X b(0,1)...b(0,2) a(0,1)...a(0,2)
b(1,1)...b(1,2) a(1,1)...a(1,2) ... END IIR

Where:

time_dim specifies the units used for the sampling time step t. The available formats are SEC, MSEC, USEC, NSEC,
and PSEC.

parm_format specifies the format used for the filter coefficients. The available formats are:

RI for real and imaginary

MA for magnitude and angle (degree)
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DB for 20log (magnitude) and angle (degree)

T is placed to make the file more readable and to indicate the following number is the sampling time and t is the
actual sampling time

QuantizeCoeff is used to indicate to the application the coefficients may be quantized, if needed.

Instrument Link

If your computer has a GPIB card, and its supporting software installed, you can use the Instrument Link feature. This
allows FIR filter coefficients to be exported to instruments such as the Agilent ESG-D signal generator and eliminates
the need to manually enter each coefficient with the FIR table editor.

To export a digital filter design, choose File > Export Ideal Coefficients from the Digital Filter Designer menubar. The
Export Ideal Coefficients to Instrument dialog appears.

—| Export Ideal Coefficients to Instrument
Select instrument type: Agilent_ESG
Enter instrument address: 1

Enter HPIB name: H

Enter output filename (up to 8 chars):

Sedwol Heglster ipoationm It

OK Cance] Help

Enter the address of the instrument that you want to connect to. The GPIB address for the Agilent ESG-D can be
found by pressing the Utility key on the instrument.

Enter the GPIB name. The GPIB, or symbolic interface nhame, is the name assigned to the GPIB interface card when
the card is installed. The name is required by the Digital Filter tool to transfer data to an instrument. For the E2050A
LAN/HP-IB gateway box, the symbolic name is in the form:

lan[IP_address]:hp-ib_name

For example, if an E2050 LAN/HP-IB gateway box with an IP address of 18.9.134.213 is to be addressed, the symbolic
interface name is:

lan[18.9.134.213]:hp-ib

The symbolic interface name can be redefined at any time. For details on changing the hp-ib_name, refer to the
documentation for the E2050A.

When you have entered the information, click OK to export the design data to the instrument.
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Copying and Saving a Design

Choose File > Save As from the Digital Filter Designer menubar to save a copy of the currently open filter design file.
Use the File Save As dialog box that is displayed to provide a name and location for the file you wish to create.

—| File Save As |

Filter
ibs/users/df_prij/#*,.flt

Directories Files

1sfusersfdi_prj/. [ 1

bsfusersfdf_prj!..
bsfusersfdf _prjfdata
bsfusersfdf _prjfnetworks
bsfusersfdf_prjfsynthesis
hsfusersfdf_prjfverification

aelection

‘d4/pubs/users/df_prj/]

Ok Filter Cancel Help

If you have computed the ideal and the implementation coefficients for the filter design, separate files containing each
set of coefficients are saved as ASCII files using the MDIF format. The naming convention used for these files is
<design_name>ideal.mdb and <design_name>scaled.mdb respectively and the files are saved in the synthesis
subdirectory within the project directory. Files without the header information are also saved in the same location
using the same naming convention and the .txt extension. Ideal coefficients from these files can be used for
components within Agilent Ptolemy or any other application.

Coefficients for an FIR filter are listed in a single column whereas those for an IIR filter are listed in six (6) columns
where each row corresponds to a second-order section and the coefficients are listed as b[ﬁl’ b 15 b, @g, @, 85

where bl:l* bl’ 52
andaga,a,

denote the numerator and denominator coefficients, respectively. For details on the coefficient formats, or for
information on how the coefficient values can be displayed, refer to Displaying Coefficients in Analysis and Output. For
details on using these coefficients, refer to Using Coefficients in Adilent Ptolemy Components in Analysis and Output.
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Generating Outputs

Digital Filter Designer can be used to print filter specifications, display plots for analyzing filter designs, view filter
coefficients, and generate schematic outputs.

Printing Specifications

Choose File > Print Filter Design from the Digital Filter Designer menubar to generate a printout of the filter
specifications. Choose File > Print Setup from the Digital Filter Designer menubar to modify the printer and printing
specifications, as desired.

The printed output lists the current filter, parameter, and implementation specifications.

Plotting an Analysis

Choose Design > Design Filter from the Digital Filter Designer menubar to design a filter based upon the entered
specifications. After the filter design process is completed, various plots are displayed automatically for your analysis.

The data computed and plotted for your analysis depends upon the kind of filter being designed, FIR or IIR, and the
analysis options you specify. To define the options and detail used in the display of plots for analysis, choose Design >
Setup Analysis from the Digital Filter Designer menubar to display the Setup Analysis dialog box. Click Help within the
dialog box to display online help instructions on the available options.
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— Setup Analysis

Mumhber of Frequency Points: 51z

Humber of Unit Pulse Response Points: 101

Responses

*X Frequency Response
¥ Unit Pulse Response
X Unit Step Response
X Group Delay

| Paton i

| Eye Diagram

it Hale fHry

Flotting Specs

X Include Specification Magnitude Plot
in the Frequency Response plot

Graphic Display
| Keep Previous Data

T Ok Cancel Help i

Use this dialog box to select the analysis options. Some of the options, such as the display of Poles/Zeros is only
available for IIR filters and the Eye diagram plot option is available for all FIR filters. Group Delay is available for both
IIR and FIR filters. Options that you select are used to display plots for analyzing your filter design.

Choose Design > Analyze from the Digital Filter Designer menubar to display the plots for designed filter.
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Generating a Schematic

Choose Design > Generate Schematic from the Digital Filter Designer menubar to generate a schematic based upon a
filter design. Use the Generate Schematic dialog box that is displayed to specify a name and type for the schematic to
be generated.
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=] Generate Schematic

Design Type

& Generate ldeal (Infinite Precision) Filter Design

_) Generate Scaled, Fixed Point Synthesizable Filter Design

Schematic Design Name
|Idfiltar_mpaaa

_I Overwrite any existing design with same name

The schematic is generated and displayed in a new schematic window that is launched within Advanced Design
System.
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Viewing Coefficients
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Choose View > Coefficients from the Digital Filter Designer menubar to display the coefficients for the designed filter.

Advanced Design System 2008

A table listing the filter coefficients is displayed automatically in the Data Display window.

Coafficiants

. ldeal _Coefficiants. data Scaolad_Coafficignts. _data
ind
itar=0 itar=0
[ -G C1F3RSI1E104 365 -0 _o1spnnEspIGI125
1 -G G177 14819805863 =G 015625000000 000
2 =0 COE23440007202027 =0 0021 3823046R750
k4 -G COoBR19153RI20B0 -G GOOAEININ4S3125
4 G.OC0ou227263410G51 G.OoGRS4482 187500
3 O OOoos3FS12262600 G OG04 RR2R1 250000
& -G C1EAT2Z21E72528 -0 015350341 706R75
7 -G 01E707825210484 -0 152BR30E840825
fal G.O0ES23RRR320E50 0. ORSUR1445312500
Lt} G O0200F4RE02 2000 G Oo1R2260 7421875
10 -0 0105559 6RRTR2ES -G GOaE4 3554 6R7S00
11 O 0155R50RS0S304E G014 25170R884 375
12 G 0I0ERFETSERNSR0 0L C2BOPEITIBIE000
12 G.oGY348E8R9 718735 G.ODET1IBE7 187500
14 G.oo2401807126720 G 002 1u7265625000
15 G OO0EE14005420873 DL O0EG424RN4 ERIEG
16 =G G4 192788215217 -G 0034521484 3750
17 G.02095541 3215823 G 027404 785156250
18 G.O72072483000803 0. 0ESR1TRERTS00O00
19 G 0135342360952627 G.o12300136718750
20 - 0ERoGTITSS513204 -0 _0538assS0s703125
21 -3 CI2PEIET44350R0 -G GIauERAE1 RIS
22 -3 0017987844 556364 -0 O01647940 218750
23 O_0O00SE145R4FERIR O ORGS1RTURBIR12S
24 G.03SEE00I2140518 G.O32E230010156025

Creating a Multipass FIR Filter

The exercises that follow demonstrate the ease with which you can design, analyze, and generate outputs for a digital
filter using Digital Filter Designer. Complete the exercises before you use Digital Filter Designer for your filter design
tasks. Doing the exercises first will help you understand the basic features and conventions of the Digital Filter
Designer and save you time later.

Feel free to go through the exercises at your own pace. Stop or digress at any time you wish, and pick up later where
you left off. The exercises, like Digital Filter Designer, put you in control with an environment that is flexible enough to
work the way you do.

This tutorial teaches you to design, implement, and generate outputs for a multipass FIR filter design using the
following exercises:

e Exercise 1: Entering Design Specifications introduces you to the basics of entering the filter design specifications
and the desired response and weighting specifications. After going through this exercise you should be able to
create a filter design based upon your specifications.

e Exercise 2: Designing and Analyzing a Filter introduces you to the basics of analyzing a design. After going
through this exercise you should be able to specify analysis options, design a digital filter, and generate analysis
plots.
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e Exercise 3: Implementing a Filter Design introduces you to the basics of implementing a filter design. After going
through this exercise you should be able to specify implementation options, display filter coefficients, and
generate a schematic from the filter design.

Response and Weighting Specifications

This exercise takes you through the design process for a 64-tap, symmetric, multipass FIR filter that uses the
Frequency Weighted Least Squares design method. The specifications call for two passbands and three stopbands with
a sampling frequency of 8 kHz. The desired magnitude response for this linear phase filter uses the following
specifications:

Frequency Band Magnitude
400 to 1200 Hz 1.0
1600 to 2400 Hz 1.0
0 to 400 Hz 0
1200 to 1600 Hz 0
2400 to 4000 Hz 0

These specifications can be represented graphically as follows:

100

wagnitde

0 100 200C 3700 4073

Freguency

The desired weighting specifications for the magnitude response of this filter conform to the following specifications
using the polynomial magnitude format:
Frequency Band Frequency Weighting
0 to 300 Hz 2.5, 0.03125

1 400 to 1200 Hz 1
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2 1300 to 1500 Hz 5
3 1600 to 2400 Hz 0.5, 0, 1.5625e-5
4 2500 to 4000 Hz 1

The weighting specifications can be represented graphically as follows:
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Keep in mind that weighting indicates the priority of desired magnitude response at the designated passband,
stopband, or transition band.

Exercise 1: Entering Design Specifications

This exercise is made up of three sections. Each section takes you through the steps involved in a specific aspect of
creating a digital filter design for a multipass FIR filter. The first section takes you through the process of launching
Digital Filter Designer and creating a design file. The next two sections take you through the process of entering,
saving, and printing the response and weighting specifications for the filter design.

Complete the following sections to create the filter design. At the end of this exercise, you will be familiar with the
major features and ease-of-use advantages of using Digital Filter Designer to enter and verify specifications for a
digital filter design.

e Create a filter design file
¢ Define the desired response
e Save and print specifications
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Creating the Filter Design

Assume that your goal is to create a multipass FIR filter design using the Frequency Weighted Least Squares method.
This section takes you through the process of launching Digital Filter Designer and creating a new design project. It

ends with saving the design and printing a copy of your filter specifications.

) Note This exercise assumes that you have a working knowledge of Advanced Design System. For more
information on the available features and functionality, refer to the Advanced Design System Schematic

Capture and Layout manual.

1. Launch Advanced Design System.

Launch Advanced Design System, create a new signal processing design project, and open a Schematic window

for a digital signal processing network design.
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The Main window is used to create and manage projects and designs, while the Schematic window is used to

actually create the design.
2. Launch Digital Filter Designer.

Choose Tools > Digital Filter > Start Digital Filter from the Schematic window menubar to launch Digital Filter

Designer.
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Dicitel [itter Designer Window

In addition to the Digital Filter Designer window, a Status window is displayed. Feedback messages on the
progress of tasks you initiate are displayed in this window.
3. Verify that FIR is the currently selected filter type.
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Filter Type Filter Order
Choose Filter Typg ———— | FIR ||| 1 Aura Oeder
Design Method Order Number:
Select Design Method ——— | | Least_Squares ‘| 64
Parameter Entry

'Desired Hespansei Weighting Function Other Parameters

Magaiive Frog | Positive Freq.

Response Type Amplitude Fon

Choose Response Type —— Multipass ‘| (& Polynomial

Set Filter Order

4. Choose Multipass as the desired response type to create a multipass FIR filter design.

5. Choose Least Squares as the desired design method.
When you choose Least Squares as the design method, you also need to specify the number of taps or filter

order. Accept the default filter order of 64.

6. Specify the frequency unit of measure.
Use the drop-down list to choose Hz as the unit of measure for the response specifications. The frequency unit

you specify is used automatically for any desired response values you enter subsequently.
Frequency Unit
Choose Unit of Measure ———  Hz ‘|
Sampling Frequency:
Enter Sampling Frequency —— | 8 kuzZ

7. Enter 8 kHz as the sampling frequency for the filter. You can override a default unit of measure by entering a
different unit of measure for a particular value.

8. Enter the desired number of passbands.
Enter 2 as the desired number of passbands and press Tab to validate your choice. Doing so displays the Select
Stopband Number dialog box, which you can use to specify the corresponding number of stopbands. Accept the

default of 3 stopbands.
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Select Stopband Number

|

Select corresponding humber of stopbands for 2 passhands

+ & stopbands (End Multipass with passhand)

Accept Default

Number ot
Stopbands (3)

# 3 stopbands (End Multipass with stopband)

oK Cancel Help

Defining the Desired Response

Now that you have defined a multipass FIR filter design using the Frequency Weighted Least Squares method, you can
begin the process of entering the desired response specifications. This section takes you through the process of
entering the desired response and weighting specifications using the Desired Response and Weighting Function tabs.

Paraieler Enlry
Desired REsponse | Welghting Funcion | Other Farametiers

Fhagivifoss Breg. | Psitive Fran.

Rezponse Type Amplltvde Fonnal

4 Folynomial Lnear

Miltipass
Humber of Fasshamis: | £ Humber of Stophands: 3
Luwr Frizg High Frey Sunpliluk: Hipple [UB} Exp. funplilude
Stophaornd ; b
n.ns KMHz? [ .15 KMHz 1.0 1.0

Paszhand

1. Enter the desired response specifications.
Enter the following values for the low and high frequencies of the two passbands:

Low Frequency High Frequency
1200 Hz

400 Hz
2400 Hz

1600 Hz
The grayed-out low and high frequencies for the three stopbands should change to the following values:

Low Frequency High Frequency
0 Hz 400 Hz
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1200 Hz 1600 Hz
2400 Hz 4000 Hz

2. Enter the weighting for the magnitude response specifications.
Click the Weighting Function tab. Enter 5 as the desired number of weightbands and press Tab to add the
weightbands.

Hegative Preg. | Positive Freq,

Copy Desired Bands Humber of Weightbands: &

Magnitude Format
#® Polynomial _ Linear

low Freq |  Highfreq |  Magnitude
Weightband 0 Hz | 300 Hz | 25000125
Weightband 400 Hz | 1200Hz | 1
Weightband 1300 Hz | 1500 Kz | 5
ooo o o e 0O | = e 00 | P, =

) Note To add weightbands when their specifications are similar to the desired response specifications, click
Copy Desired Bands to copy the specifications from the desired response bands and create weightband
specifications. You can then modify the specifications for each weightband, as desired.

Enter the following values for the low and high frequencies and magnitudes of the five weightbands:

Low Frequency High Frequency Magnitude
0 Hz 300 Hz 2.5, 0.03125
400 Hz 1200 Hz 1
1300 Hz 1500 Hz 5
1600 Hz 2400 Hz 0.5, 0, 1.5625e-5
2500 Hz 4000 Hz 1

Saving and Printing the Specifications

Now that you have created a multipass FIR filter design using the Frequency Weighted Least Squares method and
entered the desired response and weighting specifications, you can save your design specifications and verify their
accuracy. This section takes you through the process of saving the design and printing a copy of your filter design
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specifications.

1. Save the filter design.
Choose File > Save Filter Design and use the File Save As dialog box that is displayed to name and save the filter
design specifications you have entered.

2. Print the specifications.
Choose File > Print Filter Design and use the Print dialog box that is displayed to print the filter design
specifications you have just entered. Use the printout to verify the accuracy of what you have entered against
the following specifications.

Hilter type : FIR

Response type : Miltipass

Net hod type . Least_Squares

Qr der . 64

Hrequency unit: Mz

Sanpling frequency : 8 kHz

Desi red response specification:

Anpl i t ude for mat : Pol ynom al

Nurmber of passbands: 2

Nunber of stopbands: 3

Speci fication val ues:
Stopband\[O\]: \(0.0 MHz, 400 Hz, \(0.0\), n/a, \(1, O\)\)
Passband\[0\]: \ (400 Hz, 1200 Hz, \(1.0\), n/a, \(1, O\)\)
St opband\[1\]: \ (1200 Hz, 1600 Hz, \(0.0\), n/a, \(1, O\)\)
Passband\[1\]: \ (1600 Hz, 2400 Hz, \(1.0\), n/a, \(1, 0O\)\)
St opband\[2\]: \ (2400 Hz, 4 kHz, \(0.0\), n/a, \(1, O\)\)

\f¢éi ghting function specification:

Anpl i tude for mat : Pol ynom al

Nurmber of wei ght bands: 5

Speci fication val ues:
Vi ght band\[O\]: \ (0.0 MHz, 300 Hz, \(2.5,0.03125\)\)
Vi ghtband\ [ 1\]: \ (400 Hz, 1200 Hz, \(1.0\)\)
Wei ght band\[2\]: \ (1300 Hz, 1500 Hz, \(5.0\)\)
Vi ght band\ [3\]: \ (1600 Hz, 2400 Hz, \(0.5,0, 1.5625e-5\)\)
Wei ght band\[4\]: \ (2400 Hz, 4 kHz, \(1.0\)\)

Ot her paraneters specifications:

Conpensation: unity

Synmmetricity: symmetric
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Gonver si on/ | mpl enent ati on dat a:

| npl enent ati on structure: Direct

Nunber of bits : 32
| npl enent ati on for mat . Floating_poi nt
Norm criterion s Linfinity

Exercise 2: Designing and Analyzing a Filter

This exercise is made up of two sections. Each section takes you through the steps involved in a specific aspect of
designing and analyzing the multipass FIR digital filter. The first section takes you through the process of specifying
the analysis options. The second section takes you through the process of designing the filter and displaying the
analysis plots.

Complete the following sections to analyze the filter design. At the end of this exercise, you will be familiar with the
major features and ease-of-use advantages of analyzing filter designs using Digital Filter Designer.

e Choose the analysis options
e Display the analysis plots

Choosing the Analysis Options

Assume that your goal is to set up the analysis options for the multipass FIR filter design that you created. This
section takes you through the process of specifying the analysis options.

1. Specify the analysis options.
Choose Design > Setup Analysis to display the Setup Analysis dialog box.
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— Setup Analysis

Humber of Frequency Points: 519

Humber of Unit Pulse Response Points: 101

Responses

¥ Frequency Response
# Unit Pulse Response
¥ Unit Step Response
X Group Delay

| Ftasffmng

| Eye Diagram

syrndmd Bals fHry

FPlotting Specs

% Include Specification Magnitude Plot
in the Frequency Response plot

Graphic Display
| Keep Previous Data

7 0] 4 Cancel Help I

The Setup Analysis dialog box is used to define the three basic analysis options: the detail used to display results
graphically, the plots to be displayed, and whether comparative data needs to be retained.
First enter 512 as the number of frequency points to be plotted. The higher the number of frequency points, the
greater the response resolution.
Then select the option to plot the magnitude specifications within the frequency response plot. Choosing this
option will enable you to see the specified shape and how closely the response adheres to it.
Click OK to specify the setup options and close the dialog box.

2. Disable the conversion options.
Choose Options > Disable/Enable Conversion to disable the implementation details for the filter design. When the
implementation options are disabled, only the ideal filter analysis (using the full IEEE double precision or
machine-defined standard) is performed.

Designing and Analyzing the Filter

Now that you have specified the analysis options, it is time to design the filter and see how closely it meets the
desired response specifications. This section takes you through the process of designing the ideal filter and displaying
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the analysis plots.

1. Design the filter and display the plots.
Choose Design > Design Filter to begin the process of designing the digital filter using the specifications and
analysis options you have defined. Once the design process is complete, the analysis plots are displayed
automatically in a Data Display window. In the example below, the Y-axis displays dB.

Frequency Respansd Group Cwlay
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freq, Hz
Unit Pulese Reopanema Unit Step Rospones

L= T~ B+ R« B ]

amp

Lbod

agata

Exercise 3: Implementing a Filter Design

This exercise is made up of two sections. Each section takes you through the steps involved in a specific aspect of
implementing the digital filter design for a multipass FIR filter. The first section provides an overview of the
implementation options. The second section takes you through the process of generating a schematic from the filter
design.

Complete the following sections to generate a practical filter design. At the end of this exercise, you will be familiar
with the major features and ease-of-use advantages of implementing filter designs using Digital Filter Designer.
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e Choose the implementation options
e Generate a Schematic

Choosing the Implementation Options

Assume that your goal is to set up the implementation options for the multipass FIR filter design that you created.
This section takes you through the process of specifying the implementation options.

1. Activate the implementation options.
Choose Options > Disable/Enable Conversion and select the implementation details for the filter design. Once the
implementation options are activated, the ideal filter analysis (using the full IEEE double precision or
machine-defined standard) can be compared to a scaled analysis using the specified numeric format and
precision.

2. Choose the implementation structure.
Choose Direct Transpose as the implementation structure. A direct transpose structure can be used to implement
symmetric FIR filters with half as many multipliers as there are coefficients.

Scaled and Quantized Implementation Details
Implementation Structure

Direct

Direct Transpose

Direct Transpose Symmetric

3. Define the desired numeric format and bitwidth.
Select Fixed Point as the numeric format. A fixed-point format scales (quantizes) the filter coefficients based
upon the bitwidth you enter.
Once you select a fixed-point format, enter 16 as the desired bitwidth.

Coefficient Precision
Numeric Format Bitwidth
_) Aoating_point & Fxed_point 18
4. Design the filter and display the plots.
Choose Design > Design Filter to begin the process of designing the digital filter using the implementation

options you have specified. Once the design process is complete, the Data Display window is updated
automatically to display both the ideal and the scaled plots.
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As you can see, the performance of the scaled filter closely approximates the performance of the ideal filter.

Generating a Schematic

Now that you have designed a filter using the implementation options, you can generate a schematic from the filter
design. This section takes you through the process of generating a schematic from a digital filter design.

1. Save the filter design.
Choose File > Save Filter Design to save the filter design you have created.

2. Display the filter coefficients.
Choose View > Coefficients to display the coefficients for the filter you have designed. The coefficients are
displayed in a new table within the Data Display window.
Click the table to select it and choose Edit > Item Options from the Data Display menubar to display the Insert
Plot dialog box. Click the Plot Options tab and enter 15 in the # of Decimal Digits field.
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Click OK to dismiss the dialog box and display the table of coefficients. The first column displays the coefficient
number, the second column displays coefficients for an ideal or floating-point implementation, while the third
column displays coefficients for a scaled or fixed-point implementation.

43



Advanced Design System 2008

Coafficiants
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) Note To display the rest of the coefficients, enlarge the window or use the scroll bars. For details on using the
Data Display window, refer to the Data Display online help or the Schematic Capture and Layout manual.

3. Generate a schematic for the filter design.
Choose Design > Generate Schematic from the Digital Filter Designer menubar to display the Generate
Schematic dialog box.

| —-i Generate Schematic |

Design Type

_) Generate Ideal (Infinite Precision) Filter Design

# Generate Scaled, Fixed Point Synthesizable Filter Design

Schematic Design Name

dfilter mpass

_| Overwrite any existing design with same name

7 oK Apply Cancel

Enter a name for the scaled coefficient schematic to be generated and click OK to generate and display the
schematic in a new Schematic window within Advanced Design System.

Help i
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4. Save the schematic.
Choose File > Save Design As from the Advanced Design System Schematic window menubar and use the dialog
box that is displayed to save the schematic using the desired name and location.

5. Save the filter design and exit Digital Filter Designer.
Choose File > Save As from the Digital Filter Designer menubar and use the dialog box that is displayed to save
the filter design file using the desired name and location.
Choose File > Exit from the Digital Filter Designer menubar to exit the application.
Choose File > Exit Advanced Design System from either the Schematic or the Main window menubar to exit
Advanced Design System.
Congratulations. This marks the end of the tutorial exercises for Digital Filter Designer. The steps you have gone
through in this tutorial make up a majority of the tasks you are likely to use in your day-to-day filter design
tasks.
If you have completed all three exercises, you have created, analyzed, and implemented a multipass FIR filter
that conforms to the given desired response specifications.
Please refer to the online documentation for details on the tasks you have completed in these exercises and the
other features you can use to design a digital filter using Digital Filter Designer.

For more information on using either the Advanced Design System or Data Display, refer to their online
documentation.

Designing a Digital Filter
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This chapter describes the steps involved in designing a digital filter. It also includes reference and background
information on the available options. The two basic steps for designing a digital filter using Digital Filter Designer are:

1. Define the filter design specifications.

This step consists of defining the filter type, design method, and the filter order.

2. Define the filter response specifications.

¢ This step consists of defining one or more of the following specifications:
° Frequency unit
° Sampling frequency
° Response type selection
° Response specifications
° Amplitude entry format
° Weighting function
° Transform
° Compensation
° Symmetricity

Choosing a Filter Response Type

Choose either an Infinite Impulse Response (IIR) filter or a Finite Impulse Response (FIR) filter based upon your
performance, design, and implementation needs and limitations. For example, when linearity of phase is an issue, an
FIR filter is a better choice because an IIR filter achieves its computational efficiency at the cost of nonlinear phase.

e To specify the filter type for a design within Digital Filter Designer, click the desired option to select it.

Filter Type
. IR
Choose Filter
Type Design Method
Chebyshey |

FIR
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A Finite Impulse Response (FIR) type is an all-zero or moving average (MA) filter that uses past and present input
samples to calculate the output value.

In general the FIR design problem is easier to control in a wide range of practical situations. An FIR filter is able to
provide pure linear-phase characteristics. It also can accurately approximate arbitrary frequency-response
characteristics.

Even though a non-recursive design typically needs a large number of coefficients, it is inherently stable because it
does not involve feedback.

The following illustration depicts the difference equation and implementation structure for a transposed FIR filter.

%x[n]
b, X

=z

IIR

An Infinite Impulse Response (IIR) type is a pole and zero or auto-regressive, moving average (ARMA) filter. Each
output value in such a filter is calculated using previous outputs, as well as past and present input samples. The
feedback in this system gives this filter an impulse response that is infinite in duration.

Simplicity of its design procedure is a major advantage of an IIR filter. A variety of classical frequency-selective filters
can be designed using closed-form formulas. Another major advantage of an IIR filter is its computational economy
with respect to the filter implementation. Filter responses with high frequency selectivity can be obtained using a few
recursive coefficients.

An IIR filter is generally unable to provide a linear phase response and its implementation is relatively more complex.
However, when phase considerations are not an issue, a given magnitude response specification can be implemented
more efficiently with an IIR filter.

The following illustration depicts the difference equation and structure for an IIR filter.
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¥[r] = 2x[r]+5x[rn-1]+Tx[r-2] +4y[rn - 1]+ 3y[r - 2]

x[n-1] z! 2
/T
L] 5 |
x[n-2 71

74

Choosing a Frequency Response

The output spectrum of a linear, time-invariant filter is a result of the product of the input signal spectrum and the
filter's frequency response. Specifying the frequency response of a filter thus determines which frequency bands of the
input signal will be passed and which will be rejected.

#» Note: An ideal filter would do a perfect job of either passing or attenuating a region of the spectrum. Actual
filters, however, have passbands that are not perfectly flat, stopbands that don't reject bands of frequencies
completely, and transitions between passbands and stopbands that are not instantaneous.

Transition
R - Sl S

Passhand I|I||I  Ripple

h

F
v

Stopband :

e To choose the frequency response type within Digital Filter Designer, click the desired option to select it.
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Desired Response 'Wﬁégghééssag Frand

Response T
Choose i e
Frequency — | Lowpass
Hesponse

Hinher of Passhands .

Choose a frequency response to specify the desired passband and stopband response. In addition to the basic filter
responses, more advanced filter responses are also supported within Digital Filter Designer. Any one of the following
responses can be specified using Digital Filter Designer. The following table lists the amplitude responses Digital Filter
Designer currently supports for FIR and IIR filters.

Amplitude Response FIR Filter IIR Filter
Lowpass . .
Highpass . .
Bandpass . .
Bandstop . .
Multipass . .
Multistop . .
Differentiator o

Hilbert Transformer o

Raised Cosine o

Root Raised Cosine o

Gaussian .

Edge .

Lowpass

A lowpass frequency response can be achieved with either an FIR or an IIR filter. A lowpass filter is made up of a
passband and a stopband, where the lower frequencies of the input signal are passed through while the higher
frequencies are attenuated. An idealized lowpass filter frequency response has the following shape.
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F/2

Highpass

A highpass frequency response can be achieved with either an FIR or an IIR filter. A highpass filter is made up of a
stopband and a passband where the lower frequencies of the input signal are attenuated while the higher frequencies
are passed. An idealized highpass filter frequency response has the following shape.

F/2

Bandpass

A bandpass frequency response can be achieved with either an FIR or an IIR filter. A bandpass filter is made up of two
stopbands and one passband so that the lower and higher frequencies of the input signal are attenuated while the
intervening frequencies are passed. An idealized bandpass filter frequency response has the following shape.

Fi2

Bandstop

A bandstop frequency response can be achieved with either an FIR or an IIR filter. A bandstop filter is made up of two
passbands and one stopband so that the lower and higher frequencies of the input signal are passed while the
intervening frequencies are attenuated. An idealized bandstop filter frequency response has the following shape.
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F/2

Multipass

A multipass frequency response can be achieved with either an FIR or an IIR filter. A multipass filter begins with a
stopband followed by more than one passband. By default, a multipass filter in Digital Filter Designer consists of three
passbands and four stopbands. The frequencies of the input signal at the stopbands are attenuated while those at the
passbands are passed. An idealized multipass filter frequency response has the following shape.

Fi2

Multistop

A multistop frequency response can be achieved with either an FIR or an IIR filter. A multistop filter begins with a
passband followed by more than one stopband. By default, a multistop filter in Digital Filter Designer consists of three
passbands and two stopbands. The frequencies of the input signal at the passbands are passed while those at the
stopbands are attenuated. An idealized multistop filter frequency response has the following shape.

F/2

Differentiator

A differentiator frequency response can be achieved only with an FIR filter. An ideal differentiator provides a purely
imaginary, linear response across the entire spectrum with a slope of jsz/_’{‘ . An idealized differentiator filter

frequency response has the following shape.
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EY
Ly

Hilbert Transformer

A Hilbert transformer frequency response can be achieved only from an FIR filter. An ideal Hilbert transformer filter
provides a purely imaginary constant linear response across the entire spectrum.

F/2

Raised Cosine

A raised cosine frequency response can be achieved only from an FIR filter. A raised cosine filter provides a flat
passband with a roll-off that has a sinusoidal form. This type of a filter is typically used in the design of
pulse-amplitude modulation (PAM) digital communication systems. When used within such a system, it achieves a
minimum probability of error by reducing the combined effects of intersymbol interference and noise.

F/2

Root Raised Cosine

A root raised cosine frequency response can be achieved only from an FIR filter. Typically, two root raised cosine
filters are used together within a pulse-amplitude modulation (PAM) digital communication system, one in the
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transmitter and other in the receiver. When combined in this manner, they achieve the raised cosine characteristics.

Gaussian and Edge

Gaussian and Edge frequency responses can also be achieved for an FIR filter using AEL functions to generate their

ideal coefficients. For details on generating these frequency responses, refer to Importing an AEL Ideal Coefficients

Function. For details on using AEL to create functions that generate ideal coefficients for these frequency responses,
refer to the Manipulating Arrays.

#» Note An AEL template that can be customized is included with the current installation of Digital Filter Designer
in $HPEESOF_DIR/dfilter/function . You can modify this template to design symmetric FIR filters according to
GSM specifications using the desired rolloff, symbol period, and tolerable order values. For details on using an
AEL functions file to generate filter coefficients, refer to Importing an AEL Ideal Coefficients Function".

Choosing a Design Method

Digital Filter Designer's filter design methods include the classic algorithms for FIR and IIR filter design. Each method
offers its own way of approximating the desired response, where, depending upon the purpose of the filter, one
method may be better suited for a particular design.

FIR

The techniques for designing FIR filters are based on directly approximating the desired frequency response of the
discrete-time system. For an FIR filter, Equiripple and Least Squares are among the most flexible methods. In
addition, numerous windowing methods that truncate the ideal impulse response using a finite-length window are also
available. The simplicity of windowing makes it an attractive alternative to the other more complicated optimizations.

e To choose the design method for an FIR filter design within Digital Filter Designer, click the desired option to

choose it.
Filter Type
FIR
Choose Design Method
Design o
Method Equinpple
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Equiripple

The Equiripple method approaches filter design as an optimization problem in which the coefficient values are adjusted
to create an optimal filter with ripples that are of equal height. This method uses the most efficient optimization
procedure to minimize the transition width along with the stopband and passband ripple.

) Hint Modify the filter order if an optimization ever fails to converge. Although rare, such a situation may occur
occasionally in the design of a high-order filter.

The Equiripple method uses the Parks-McClellan algorithm to compute the filter such that its response j2nf
e

H( )

represents the best approximation to the ideal frequency response Hcf U'z J'Ef)

in @ manner that minimizes the maximum weighted approximation error (where Q() is the weighting function):

2npke M 2mf)[H ,(j2mf)-H (e ™
crmple M [@uampLH G2 )

» Note Specify a weighting function for the Least Squares method (and for the Equiripple method when the Auto
Order feature is not used) to assign an appropriate relative cost for the deviation from a desired response.
Frequency regions where more accurate approximations are required need larger weighting values than the
less critical regions. A zero weighting is typically specified in the transitional frequency band between a
passband and a stopband.

Least Squares

The Least Squares method computes the filter such that its response j2nf
e

Hi(
represents the best approximation to the ideal frequency response Hci U'z J'Ef}

)

in a weighted least-squares sense (where Q() is the weighting function):

= 0.5 i) 2
e = | H,(j2xp-H (™) Q(iznpdf
-0.5

Windowing

Windowing is the quickest method for designing an FIR filter. It begins with an ideal desired frequency response that
can be expressed in terms of the corresponding impulse response. A windowing function simply truncates the ideal
impulse response to obtain a causal FIR approximation that is noncausal and infinitely long. Smoother window
functions provide higher out-of band rejection in the filter response. However this smoothness comes at the cost of
wider stopband transitions.
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Selecting the appropriate windowing method for a particular application involves weighing trade-offs between ripple
and transition width to achieve acceptable results. For the most part, a good windowing method attempts to minimize
the width of the main lobe (peak) of the frequency response. In addition, it attempts to minimize the side lobes
(ripple) of the frequency response. Some of the windowing methods can be used to make this trade-off by adjusting
their windowing parameter.

Rectangular This is the most basic of windowing methods. It does not require any operations because its values are
either 1 or 0. It creates an abrupt discontinuity that results in sharp roll-offs but large ripples.

Rectangular
J. e .
0 i I
h=15 MN=31 oT
The Rectangular windowing method is defined by the following equation:
1,(0£nr<N)
wln] =

0, (otherwise)

Triangular This is the simplest windowing method that exhibits a nonnegative transform. The computational simplicity
of this window, a simple convolution of two rectangle windows, and the lower sidelobes make it a viable alternative to
the rectangular window.

Triangular
1 L
r"'.‘i
-+ -
4" .h
P‘. "‘
* *u
i.‘ .*
L
o b | |
M=15 N=31 oT

The Triangular windowing method is defined by the following equation:
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wln] = 4

0, (otherwise)

Kaiser This windowing method is designed to generate a sharp central peak. Although it is computationally involved,
its coefficients are easy to generate largely as a result of helpful design rules that eliminate iterations typically needed
to achieve desired ripple and transition specifications.

Kaiser
1 +— .¢-‘
- *
™ L
. .
-n" “1‘
- -
.‘I' .‘-
|:| -‘I I *'I.J
M=15 N=31 aT

The Kaiser windowing method is defined by the following equation using the windowing parameter, a:
2n 2n )
bessel| « 2 - J
N-1 N-1
bessel[ 0]

wln] =

Note For details on the Kaiser windowing method, refer to J. F. Kaiser, "Design Methods for Sampled Data
Filters," Proceedings First Allerton Conference on Circuit and System Theory, 221-236, November, 1963.

Hamming This windowing method generates a moderately sharp central peak. Its ability to generate a maximally flat
response makes it convenient for speech processing filtering.

Hamming
1 +— P
.'I 1‘.
L *
™ -
i- .ll‘
'I-' .1
n" *",.
0 L= | 2
M=15 MN=31 T

The Hamming windowing method is defined by the following equation using the windowing parameter, a:
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wln] = O[—(I—DE]CDS[ N

Hanning This windowing method generates maximally flat filter designs as well. Its other advantages are an easy to
generate set of coefficients and easily identified properties of the transform of the cosine function.

(2n + 1)1‘1}

Hanning
J. - LY
ot .
L L
i. "l-
- ..
- *
# »
0 M I . I
M=15 MN=31 aT

The Hanning windowing method is defined by the following equation using the windowing parameter, a:

wln] = a-(1- D[]cos[

(zn;;l )H}

Dolph Chebyshev This windowing method provides good sidelobe rejection but its sidelobe structure displays extreme
sensitivity to coefficient errors. It is optimal for most instances that don't use a fixed-point implementation.

) Note For details on the equations used by the Dolph Chebyshev windowing function, refer to "Digital Signal
Processing" by Roberts & Mullis. pp 225-228.

Blackman This windowing method provides good sidelobe rejection although it results in a broad central peak.

Blackman
J. - T
11' l|-l
- -
- ®
#l. 't
I-‘ ‘I-
- t'.
0 beas | -
M=15 N=31 aT

The Blackman windowing method is defined by the following equation:

wln] = 0.42 —D.Scos(%}

.,

+ D.DBCOSEJ‘E(ZITN—_FIJ

.,

IIR
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IIR filter design is based on transformations of continuous-time IIR systems into discrete-time IIR systems. For an IIR
filter type, Butterworth and Chebyshev are among the better known design methods. In addition to the auto-selection
option that picks the most suitable method automatically, the Elliptic method is also available.

e To choose the design method for an IIR filter design within the Digital Filter Designer, click the desired option to

choose it.
Filter Type
Choose IIR
Design
Method Design Methad
_Chebyshev_|

Auto Selection

Choose this option to pick the most appropriate method automatically. This option evaluates the filter design using
each of the available methods and picks the method that results in a filter with the smallest order. Typically this
choice is used to obtain the most economical filter design that may be further refined using a different method, if

desired.

Chebyshev I

The Chebyshev method of approximation provides an equiripple performance in the passband and it varies
monotonically in the stopband. Although an increase in the filter order increases the number of passband ripples, it
also leads to better stopband performance. In addition, the good magnitude characteristics of this method come at the
cost of phase characteristics that depart considerably from the ideal linear-phase.

0s | | —

05— II —
I

l S |

lo0o 2000 3000 4000 3000

An nth order Chebyshev I lowpass filter with cutoff frequency f
c

is specified using the following equation:
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1

ALF) = —5—
1+€° V2 (F/f.)

Chebyshev II

The Chebyshev II or Inverse Chebyshev method of approximation provides an equiripple performance in the stopband
and it is monotonic in the passband. Although an increase in the filter order increases the number of stopband ripples,
it also leads to better passband performance because it yields the smallest delay in the passband. In addition, the
Chebyshev II method provides good phase and delay response by providing the widest region of the passband over
which the group delay is constant.

Wl N -

04— —
|

02— II. -

) I~

1000 2000 3000 000 3000

An nth order Chebyshev II lowpass filter with cutoff frequency f
C

is specified using the following equation:

, EVAFL)
A () =

1+ V2(F/F)

Butterworth

The Butterworth method of approximation provides a monotonic performance in the passband and the stopband. As
the filter order is increased, the passband and stopband performance improves, with the transition from passband to
stopband becoming sharper. The Butterworth method is best suited for design problems that focus on controlling
passband and stopband ripple.
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I i

oa— ‘ |

1000 2000 3000 4000 3000
An nth order Butterworth lowpass filter with cutoff frequency f
c

is specified using the foIIowing equation:

A(F)= — >
() (i
.

Elliptic

The Elliptic method of approximation provides an equiripple response in both the passband and the stopband. This
method uses the smallest filter order for a transition from passband to stopband, but it does so at the cost of some
ripple in both bands. As a result, when phase linearity is not an issue, the elliptic method results in a filter with the
lowest-order and therefore the least computation overhead.

i
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An Elliptic filter is based on a mapping of the following function:

Tj(m} = = 1,,
1+&sn (w. k)

Defining the Filter Order
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The most apparent measure of the complexity of a filter is its order. The order refers to the order of the filter's system
function. Within Digital Filter Designer, the design process can be driven either by the filter order or by the filter
specifications.

That is, given the ripple specifications, the minimum filter order can be calculated automatically in all cases except the
Least Squares method. On the other hand, given a filter order constraint, the filter coefficients can also be generated
without constraining the ripple.

e To manually define the order for a filter design within Digital Filter Designer, click Auto Order to deselect it and
then enter the desired order in the Order Number field. Keep in mind that for an N -tap FIR filter the filter order

will be N-1 .
Deselect Filter Order
Auto Order —— | [ Aule Srder
Order Humber:
6 Erter Filter
Order

#» Note The auto order feature automatically sets the filter order and weighting, in the case of an equiripple FIR
filter. In the case of a windowing FIR filter, it sets the filter order and windowing parameter. As a result, when
you define an equiripple filter order manually, be sure to also specify the weighting for each band. In the case
of a windowing filter, be sure to specify the windowing parameter as well. For details on weighting, refer to
Specifying the Weighting. For details on the windowing parameter, refer to Entering a Windowing Parameter.

For a FIR filter the order is defined as the number of zeros of its transfer function H(z), which is a finite polynomial.
The number of filter taps (coefficients) will be the order+1.
For an IIR filter the order is defined as the number of poles of its transfer function H(z), which is a rational function.

Digital Filter Designer may be unable to achieve the desired response using certain window design methods,
regardless of the filter order. In such cases, a feedback message is displayed in the Status window to let you know.

Be sure you verify the accuracy of the results obtained using the auto-order feature when designing a filter with a
nonlinear passband amplitude, a raised cosine filter for example.

For best results in a filter design with passbands at the Nyquist frequency (frequency = sampling frequency/2) use an
odd numbered filter order for an antisymmetric filter, and an even numbered filter order for a symmetric filter. For
details on the symmetricity option used in a filter design, refer to Defining the Symmetricity.

Choosing the Frequency Unit

Choose a frequency unit for the specifications you enter. The default unit is MHz.
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e To use a frequency unit other than the default within Digital Filter Designer, choose the desired option from the

Frequency Unit drop-down list.
Frequency Unit

Choose MMz

Frequency Unit
Sampling Frequency:

1.0 MHZ

) Note The frequency unit you specify is used for specifications you enter subsequently. To override the default,

enter a different unit of measure for any individual specification.

Specifying the Sampling Frequency

Enter the desired sampling frequency. The default frequency is 1 MHz. The sampling frequency you enter is the rate at
which the signal is sampled ( ). The high frequency, FH, in the last band is automatically changed to " /2

to avoid designing a filter that suffers from aliasing distortion.
e To modify the sampling frequency, replace the existing value with the desired value in the Sampling Frequency

field.
Frequency Unit

MHz

) Sampling Frequency:
Enter Sampling D

Frequency 1.0 MHZ

Defining the Response Specifications

Desired response specifications define the parameters for the passbands, stopbands, and weightbands of a digital
filter. Response specifications include the number of bands in the case of a multiband filter, the low and high cutoff

frequencies, the amplitude, ripple or attenuation, and phase.

e To define the response specifications within Digital Filter Designer, enter values, as applicable.
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Parcuneler Enlry
Desired REsponse | Welghting Funcion | Other Paramel2rs

Faegmddvi Breg. ) Pgitive Froao.
Ampiivdge Fonnat
l {8 Foiynomial ) Lnear

Response Type
Minltipass

Humber of Fasshamds: | £ Humber of Stopbands: 3

Luwr Freg High Frex Pl Lok

Stophard 0.0 MHz 0.05 MH:z 0.0
! 1 ! : %

Fasshand .5 MHz 15 MHz i n

Hipple [dB) Exp. fanplilude

» Note When entering the values, keep in mind the default unit of measure. To use a unit of measure other than
the default, either change the default unit before entering a value or type in the unit of measure along with the

value.

Entering the Number of Bands

The number of bands you enter defines the shape of the filter. Within Digital Filter Designer you can specify the
number of passbands, stopbands, and weightbands. These values need to be entered for multipass and multistop
filters; they are otherwise automatically set to the appropriate values based upon the specified amplitude response.

Entering Low and High Frequencies

Define the acceptable cutoffs for the passbands, stopbands, and weightbands. Enter the passband cutoff as its High
Frequency value, and the stopband cutoff as its Low Frequency value. The region in the middle of the two values

defines the transition band.
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&
Passhand M* - Transition
Ripple * —————— BEand
e
1 Stophand
| Ripple or
E?gsr?band | Aftenuation
Frequency | SIS stopband
L : bt Low
Fregquency

f» Note When you use the Equiripple or frequency-weighted Least Squares method, take care to not use very
wide transition bands. Transition bands are treated as "don't care" regions and are left unconstrained in the
attempt to minimize the approximation effort while using the minimum filter order. Consequently, unexpected
peaks can occur in wide transition bands.

Entering the Amplitude

Define the amplitude for the passbands. For details on the format and conventions used for entering the amplitude
value, refer to Selecting the Amplitude Format and Nonsymmetric.

Specifying the Ripple

Define the acceptable deviation in the passbands and rejection (attenuation) in the stopbands. This value is specified
in dB.

Entering the Exponential Amplitudes

Define the desired exponential amplitude in the passbands. The exponential amplitude response field provides another
representation for the desired amplitude response.

The overall desired frequency response will be the product of the response specified in the amplitude and exponential
amplitude fields.

H () = GHS(P)

The response in the exponential amplitude field corresponds to
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S(f)= g P

These values are entered in the exponential amplitude field as

0, B> 0, By 05, By

For information on how to control the exponential amplitude specification of the filter design, refer to Nonsymmetric.

211
o4 u::-:leJ JIrBl+...

Specifying the Weighting

Weighting is an available option when the Equiripple or frequency-weighted Least Squares method is used to design
an FIR filter. The approximation to the desired frequency response can be weighted using one or more weightbands,
each with its own low and high frequency and magnitude specifications. The magnitude values you specify are
relative. That is, a magnitude value of 1 is ten times greater than a magnitude value of 0.1.

#» Hint For numeric simplicity, scale the weightband magnitude to the range 0 to 1.0 when using the Equiripple
method.

e To define the weighting specifications within Digital Filter Designer, enter the frequency and magnitude values.
For details on the format and conventions used for entering the magnitude value, refer to Selecting the
Magnitude Format.

Desired Response | Weighting Function Other Parameters

Copy Desired Bands HNumber of Weighthands: 1
Magnitude Format

# Polynomial ) Linear

low Freq |  HighFreq |  Magnitude
Weighthand 0.0 MHz 0.5 MHz 1.0

The weighting function assigns an appropriate relative cost for the deviation from a desired response. Frequency
regions where more accurate approximations are required need larger weighting values than the less critical regions.
A zero weighting is typically specified in the transitional frequency band between a passband and a stopband.

Specification of these bands is not required. However, regions that are not weighted are automatically assumed to
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have zero weighting.

) Note The response in weighted regions can be improved by not weighting the response in regions where the
response is not important. However, when an unweighted region becomes very wide, unexpected peaks may

result.

Copying the Response Specifications

Click Copy Desired Bands to use the stopband and passband frequency specifications of the desired response for the
weightbands as well. This feature provides a useful reminder of the passband edges specified in the Desired Response

tab. As a result, you may wish to add more weightbands subsequently to weight the stopbands.

Desired Response Weighting Function | Other Parameters

Clickto Gopy Copy Desired Bands Number of Weightbands: 1
Specifications
Magnitude Format

Selecting the Magnitude Format

For the case of weighting specifications, only magnitudes are considered. Therefore, all values in the magnitude
column should be real values. Also, unlike the desired response, there is no exponential amplitude specification for the

weighting response.

Selecting the Amplitude Format

The amplitude format used depends upon the desired shape of the passbands or weightbands. In both formats, the
amplitude is essentially represented by a polynomial of some degree, zero or greater.

Digital Filter Designer automatically computes the actual inverse Fourier transform for the piecewise polynomial
magnitude representation to provide superior optimization accuracy when compared to approximations that use FFTs.

e To define the amplitude format the desired response, select the desired format.
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ion  Other Parameters

Amplitude Fornmat
Select Amplitude

# Polynomial ! Linear
Format Y ‘

Polynomial

This is the recommended default for most designs. This format is able to express both linear and non-linear
polynomial response shapes. The overall desired frequency response will be the product of the response specified in
the amplitude and phase fields.

H (p = GHS(
Given a band in the range fLi -:_:f-:_: le. , the desired complex amplitude shape given values a, b, ¢, d is defined

by the equation:

G(f) = a+b(f—f;) +c(f—fr) +d(f-f;)

In addition, the polynomial format is best able to express a linear shape with a constant or zero slope. That is, this
format is also the most convenient for expressing the complex amplitude given by a single value, a.

Within Digital Filter Designer, multiple polynomial values for a given complex amplitude are separated by commas, as
follows: 2.5, 0.03125 or 0.5, 0, 1.5625e-5
where a=2.5, b=0.03125 or a=0.5, b=0.0, c=1.5625e-5, respectively.

Linear

This format is best able to express a first degree polynomial shape, that is a non-constant linear response using the
two band-edge complex amplitude values. In such situations, it is a more convenient format for expressing complex
amplitude values a, b . Within Digital Filter Designer, linear values are separated by commas, as follows: 0.5, 0.8 or 2,
2.5.

Given a band in the range fLi -:_:f-:_: in , the linear format for a complex amplitude that is expressed by two

values a and b so that H(fL) =a
nd Hify) = b

is best defined using the Linear complex amplitude format.

) Note For example, the following passband shape is obtained by using amplitude values of 0.5 and 0.8 with the
Linear format. To obtain the same passband shape using the Polynomial format would require that the
amplitude values be specified as 0.5 and 1.5e-6.
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Choosing the Filter Transform

A filter transform maps the filter's poles and zeros in the s plane to the z plane to convert the analog filter into an
acceptable digital IIR filter.

e To select the transform used for an IIR filter design within Digital Filter Designer, click the desired option within
the Other Parameters tab.

Desired Response | sighisng fiscticn Other Parameters

Select Filter . . ) L
——— | Transformation: /& bilinear 7 transform ) impulse_invariant
Transtform = -

Bilinear Z Transform

This transform avoids the problem of aliasing by using an algebraic transformation between the variables s and z that
map the j(ﬂ

axis in the s plane to one revolution of the unit circle in the z plane. However, neither the impulse response nor the

phase response of the analog filter are preserved in the digital filter that is obtained.
The mapping of the continuous-time system to the discrete-time system is accomplished using the following equation:
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— 1
) (1-
H(z) = H. T—d[—l :’_lJ
2

Impulse Invariant

This transform is a method for obtaining a discrete-time system whose frequency response is determined by the
frequency response of a continuous-time system. Because the impulse invariance relationship between
continuous-time and discrete-time frequency is linear, the shape of the frequency response is preserved, except for
aliasing effects. Filters with high frequency passband are not designed using this transform because of the threat of
aliasing.

The system function for the discrete-time system is expressed by the following equation where:

N 2.T

T z+e

Hp(z) = = C.———

D zlz T
=1 Z-—-e

Choosing the Compensation

Use Compensation when filtering a discrete-time signal prior to a D/A conversion. Compensation takes into account
any attenuation that occurs due to a zero-order hold operation. It is used only when designing an FIR filter.

e To select the compensation used for an FIR filter design within Digital Filter Designer, click the desired option
within the Other Parameters tab.

Desired Response | sighiin: figwtion | Other Parameters

Frapsformation: | 8 Bamar 2 Dassioen ) bwadss B

Select

. — | Compensation: 1 Sinc 4 unit:
Compensation P ‘ 4

anchor:1110306:index:compensation : choosing for FIR filters; FIR filter : choosing the compensation}
Sinc

Select this option to compensate for any magnitude attenuation in the designed filter.
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Unity

This is the default option that is used in the absence of any magnitude attenuation. That is, no compensation is
designed for the filter.

Defining the Symmetricity

Symmetricity is used only when designing an FIR filter. One of the reasons that the FIR filter is popular is the ease in
which linear phase frequency responses can be achieved. Specifically, a linear phase response is obtained if the
resulting unit pulse response is either symmetric or antisymmetric.

To select the symmetricity used for an FIR filter design within Digital Filter Designer, click the desired option within the
Other Parameters tab.

Desired Response | Weighting Function Other Parameters

Tragsformation: | @ hBwar 7 ety ) hmedse veariand

Compensation: Jsinc (@ unity
Select Symmetricity: @ symmeftnc Jantisymmetric ) nonsymmetric
Symmetricity i
Symmetric

This is the default option for most designs. Selecting this option results in an FIR filter design with a symmetric unit

ulse phase response of — .
pulse p p hn = hn_*,

Antisymmetric

An antisymmetric sequence is used to design FIR filters with a purely imaginary frequency response (such as
Differentiators and Hilbert Transformers). Selecting this option will result in an antisymmetric unit pulse response of

kn - hf’f—n

An antisymmetric design is not generally used for a filter with passbands starting at DC (frequency= 0 Hz) because of
the poor response characteristics that result from the basic Fourier transform properties.
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) Note For best results in a filter design with passbands at the Nyquist frequency (frequency = sampling
frequency/2) use an odd number for an antisymmetric filter with a manually specified order, and an even
number for a symmetric filter with a manually specified order. For details on the filter order used in a filter
design, refer to Defining the Filter Order".

Nonsymmetric

The Digital Filter Designer allows the user to control the phase by specifying a complex amplitude response if a
nonlinear phase response is desired. In this case, the Nonsymmetric option must be chosen to withdraw the design
constraint on symmetry. This is useful in applications that require phase compensation or low system delay.

Entering a Windowing Parameter

Enter a value for the windowing parameter, a. The value you enter as the windowing parameter is used in the
equation for the windowing method you selected.

e To enter the windowing parameter for a windowed FIR filter design within Digital Filter Designer, enter the
desired value within the Other Parameters tab.

Desired Response | ainhissg i"'ﬂi!i:fiﬁﬁ.. Other Parameters

Tragsformatian: | @ hnpar 2 beestarys ) bgedse Bvearint
Compensation: Jsinc (@ unity
Enter Symmetricity: 1 symmetnic i@ antisymmetric ) nonsymmetric
Parameter
Value — Window Parm:

The Kaiser window method uses a default value of a = 10.0 if the windowing parameter value equals 0.

The Hamming window method uses a default value of a = 0.54 if the windowing parameter value equals 0.

The Hanning window method uses a default value of a = 0.5 if the windowing parameter value equals 0.

The Dolph Chebyshev window method uses a default value of a = 0.5 if the windowing parameter value equals 0.
For details on using a windowing method refer to Windowing".

Raised Cosine Parameters

Response parameters specific to Raised Cosine and Root Raised Cosine filters are specified in a separate dialog box
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within the Digital Filter Designer.

¢ Select Raised Cosine or Root Raised Cosine from the Response Type list to open the Root/Raised Cosine

Parameters dialog box.

Passhand Ripple (dB): 0.

o

Stopband Ripple (dB): S0

Enter symbol rate

=| Computing Desired [Root] Raised Cosine Parms |
Symbol Rate (Hz): 250000,
Roll Off: 0.3

Click Mext: to compute the desired specification parameters.

- witank Hext= Cancel

¢ You can enter the desired [Root] Raised Cosine filter parameters in the dialog box and click Next to compute the

desired specification values.

The Finish Computing Desired [Root] Raised Cosine dialog box appears. The application automatically selects the
appropriate amplitude, frequency, ripple, and exponential amplitude values based on the entries made by the user.
The user can change the automatic selections by clicking Back , manually editing the field entries, and clicking Next .

If you are satisfied with the computed desired values, click the Finish button to dismiss the dialog box. Once the Finish
Computing Desired [Root] Raised Cosine dialog box has been dismissed, it can be reopened by clicking the

Root/Raised Cosine icon on the top toolbar.

Symbol Rate

Enter a value to specify the symbol rate in Hz.

When designing a Raised Cosine, or Root Raised Cosine filter a window pops up with fields: Oversampling Rate
(Hz), Roll Off, Passband Ripple (dB), Stopband Ripple (dB). For these filter types, Ovesampling Rate (Hz) is the

same as the Symbol Rate.
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B Computing Desired [Root] Raised Cosine ... H

Overzampling Fate [Hz):
Rall QFf: 03

Pazzband Ripple (B 0.4
Stopband Ripple (dB: 50

Click Mest: to compute the desired specification parameters.

M ety Cancel

Roll Off

Enter a value to specify the desired roll-off or width of the transition from a passband to a stopband. The acceptable
range for the roll-off value, ¢, isO<qag<1.- 0 = 0

leads to a zero-width transition band, while @y = ]
leads to a transition band width that is equal to the symbol rate.

Passband Ripple

Enter a value to specify the acceptable ripple in the passband.

Stopband Ripple

Enter a value to specify the acceptable ripple or attenuation in the stopband.

) Note For more information on pulse-amplitude modulation (PAM) digital communication systems and the use of
Raised Cosine and Root Raised Cosine filters, refer to R. W. Lucky, Salz J., & Weldon Jr. E. J., "Principles of
Data Communication," McGraw-Hill. New York, 1968. pp 45-51.
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Implementing a Digital Filter

This chapter describes the steps involved in implementing a digital filter design using Digital Filter Designer. It also
includes reference and background information on the available options in the three broad implementation areas:

structure, scaling, and quantization.

The implementation structure determines the realized structure of a filter, the scaling determines the numeric
precision used to represent the coefficients, and the quantization option determines the relative importance of
overflow and quantization.

Scaled and Quantized Implementation Details
Implementation Structure Coefficient Precisi

Cascaded Second Order Humenrc Format

Cascaded Second Order Transpose - -
Direct Il Cascaded Second Order & Floating_point
Direct Il Transpose Cascaded Second Order

Honmalization Crl
# L infinity - F

By default Digital Filter Designer generates both ideal and scaled coefficients for a filter that you design. It also offers
you the option of disabling the implementation options to speed up the filter design process. You should consider
disabling the implementation options when your goal is to generate ideal coefficients only, using the full IEEE double
precision or machine-defined standard without any number rounding or saturation.

You can disable the implementation options by choosing Options > Disable/Enable Conversion from the Digital Filter

Designer menubar.
The three broad implementation options for a digital filter design using Digital Filter Designer are as follows.

Implementation Options

Mumeric Format Duantization

Implementation e
and Bitwidth Norm

Structure

Choosing an Implementation Structure
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Choose the desired structure to implement the digital filter you have designed. Depending upon the filter response
type, one or more of the implementation structure options may not be available. The implementation structures are
supported for FIR filters while a range of Cascaded second order structures are supported for IIR filters. The
implementation structure you choose is used to generate a schematic within Advanced Design System.
Implementation only affects the schematic that is generated, and has no effect on the coefficients or the analysis

data.

FIR Filter

To specify the structure for the fixed-point implementation of an FIR filter, choose the desired option from the
Implementation Structure list.

Scaled and Quantized Implementation Details
Implementation Stnicture

Choose FIR Direct

Implementation ———

Structure Direct Transpose Symmetric

 Note Different implementation structures are used to minimize quantization effects that occur as a result of
coefficient scaling with the use of a fixed-point numeric format and finite-precision arithmetic. When you use
the ideal floating-point numeric format, the schematic generated remains constant for all implementation
structures. The following "ideal" structure is used to implement a floating-point design for an FIR filter.

J1==1
AN

i’y
o

Direct
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The Direct structure is typically used to implement the simplest form of a fixed-point FIR filter. This structure allows
highly parallel architecture because all the additions and coefficient multiplications can be done simultaneously. The

final addition can be performed either with a single, multiple-input adder or with parallel adders. In this structure, the
past N input samples are directly accessible from their respective delay blocks.

Direct Transpose

In the Direct Transpose structure inputs are multiplied by each filter coefficient before being delayed. As a result
multiplications can be avoided in filters that contain duplicate coefficients. For example, the Direct Transpose structure
can implement a symmetric, fixed-point FIR filter with half as many multipliers as there are coefficients.

Direct Transpose Symmetric

The Direct Transpose Symmetric structure is only available for symmetric FIR filters and it takes advantage of the
properties of the Direct Transpose structure.
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IIR Filter

To specify the structure for the fixed-point implementation of an IIR filter, choose the desired option from the
Implementation Structure list.

Scaled and Quantized Implementation Details
Implementation Structure

Cascaded Second Order

Choose _ Cascaded Second Order Transpose
Implementation ———|| pirect Il Cascaded Second Order
Structure Direct Il Transpose Cascaded Second Order

f» Note Different implementation structures are used to minimize quantization effects that occur as a result of
coefficient scaling with the use of a fixed-point numeric format and finite-precision arithmetic. When you use
the ideal floating-point numeric format, the schematic generated remains constant for all implementation
structures. The following "ideal" structure is used to implement a floating-point design for an IIR filter.
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Cascaded 2nd Order

The Cascaded Second Order structure implements a cascaded, fixed-point IIR filter. This structure relates directly to
the IIR difference equation.

Cascaded 2nd Order Transpose

The Cascaded Second Order Transpose structure reverses the cascaded second order implementation of the poles and
zeros in the fixed-point IIR filter.

Direct II Cascaded Second Order
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The Direct II Cascaded Second Order structure implements a design with the minimum number of delays and
multiplications in the fixed-point IIR filter.

Direct II Transpose Cascaded Second Order

The Direct II Transpose Cascade Second Order structure reverses the Direct II implementation of the poles and zeros.
This is typically done when the IIR filter is implemented on a fixed-point processor or in the presence of noise.
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Selecting the Numeric Format

Select the numeric format based upon the purpose, and resources available for the implementation, of a filter design.
Any change in the numeric format causes the filter response to deviate from the ideal.

Keep in mind that any change in the numeric format or bit width affects the performance of the filter. Be sure to check
that the filter performance is acceptable after any changes to these specifications. Within Digital Filter Designer, an
ideal filter analysis is always presented to enable you to compare the deviation between what is theoretically possible
and what is physically realized, based upon your implementation criteria. This ideal analysis is based upon the full
IEEE double precision or machine-standard definition.

In a schematic generated for a scaled filter design, you can use the global parameters component (VarEgn) to change
design parameters and propagate the change across the entire design rather than manually editing the parameters for
each component.

#» Hint If your goal is to generate ideal coefficients only (using the full IEEE double precision or machine-defined
standard without any number rounding or saturation), you can disable the implementation or conversion
options by choosing Options > Disable/Enable Conversion from the Digital Filter Designer menubar.

When the floating-point format option is selected, it scales to the IEEE single precision definition to achieve a word
length of 23 with a fractional length of 8.

The fixed-point format with a bitwidth of n uses 1 bit to represent the sign bit and n-1 bits to represent the fractional
coefficients.

To select an numeric format, click the desired format option.

Coefficient Precision

) Humenc Format PHwkiih
Select Numeric

Format || ‘@ Floating_point ) Fixed point ad

Norm Criterion

# L _infinity - Fractional -- £ }

) Note A scaled floating-point or single precision schematic can't be generated if the simulator does not provide
the library support for the required components.

Specifying the Bit Width

Specify the coefficient precision or bit width when implementing a filter design using the fixed-point numeric format.
Keep in mind that a fixed-point format with a bitwidth of n uses 1 bit to represent the sign bit and n-1 bits to
represent the fractional coefficients.
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To modify the bit width, replace the existing value with the desired value in the Bitwidth field.

Coefficient Precision

Mumeric Format Bitwidth

) ) ) . Enter
} Floating_point /@ Fized point 3z T Bitwidth
Horm Criterion

# L_infinity .- Fractional .- £ %

Selecting the Norm

Select a norm based upon the quantization criterion you wish to emphasize in the implementation of the filter design.

To select the norm, click the desired option.

Coefficient Precision

Humeric Format Pbwriith
# Floating_point ) Fixed_point a
Morm Criterion

Select

Norm # L infinity -~ Fractional .- i %

L Infinity

Use this option to prevent overflow at the expense of high quantization noise. This option scales the coefficients so
that the maximum magnitude response (for each section in the IIR case) is unity.

Fractional

Use this option when no scaling is desired. With this option, only when a coefficient is greater than unity it is scaled
just enough to make its largest value fractional.
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L1

Use this option to achieve a reasonable compromise while trying to minimize both overflow error and quantization
noise. This option scales the coefficients so that the sum of their absolute values is one.

£ Note An IIR filter may exhibit larger attenuation from unity after scaling. This is especially true for IIR filters
that have poles close to the unit circle. Digital Filter Designer attempts to alleviate this effect by implementing
the filter sections containing the poles closest to the unit circle at the edge closer to the filter output.

Analysis and Output

This chapter describes the steps involved in analyzing and generating the output of a digital filter design. It also
includes background information on the available options. Digital Filter Designer provides you with a number of
analysis and output options from printing specifications to analyzing filter characteristics and generating
implementation schematics.

Once a filter is designed, its characteristics are displayed automatically. By default Digital Filter Designer generates
both ideal and quantized coefficients for a filter that you design. These coefficients can be displayed in a table then
imported into Agilent Ptolemy filter components. You can also generate schematics for further simulation using
Advanced Design System.

The analysis and output options for a digital filter design using Digital Filter Designer are:

¢ Print specifications

¢ Define analysis options
e Display plots

¢ View coefficients

e Generate a schematic
e Save a filter design file

Filter Design
View Generate Print Save Define
Coeflicients Schematic Specifications Design File Analysis

Options
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Printing the Filter Specifications

Digital Filter Designer enables you to print the filter design specifications for future reference and use. Printing the
filter specifications can be accomplished using the standard functionality of the Print and Print Setup functions.

e To print the currently displayed filter design specifications, choose File > Print Filter Design from the Digital Filter
Designer menubar.

Lol ]

Printer: |ﬁ{P Laserlet 551 to ps

I Carveart g HP- GLE 8
) Cobar aifpul
I© Soaie ig A1 page

oK Cancel | Options...

The printed output lists the filter, parameter, and implementation specifications.

Filter type: IIR
Response type: Lowpass
Met hod type: Chebyshev |
Order: Auto order
Frequency unit: Mz

e To modify the default printing options, choose File > Print Setup from the Digital Filter Designer menubar.

Defining the Analysis Options

Use the setup analysis options to define the analyses that are plotted, to define the detail used in the display, and to
retain previous data for comparison.
To customize the analysis that is plotted:

1. Choose Design > Setup Analysis from the Digital Filter Designer menubar to display the Setup Analysis dialog
box.
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— Setup Analysis

Numhber of Frequency Points: 1024

Humber of Unit Pulse Response Points: (101
Compute

® Frequency Hesponse

¥ Unit Pulse Response

® Unit Step Response

¥ Group Delay
| Potasiferess

| Eye Diagram

My Bale fHry

Plotting Specs

| Include Specification Magnitude Plot
in the Frequency Response plot

Graphic Display
| Keep Previous Data

7 Ok Cancel Help i

2. Define the level of detail to be used.
The detail used in the display is determined by the number of frequency points and by the number of unit pulse
response points.
Frequency Points
Increasing the number of points leads to a corresponding increase in the display detail. The number of frequency
points is always rounded and expressed as a power of two.
Number of Unit Pulse Response Points
Increasing the number of points leads to a corresponding increase in the pulse duration for which the pulse
response is computed. This setting is only useful for an IIR filter because the unit pulse response for an FIR filter
is always a finite duration.

3. Specify the data to be displayed.
Select one or more of the Compute options as desired. Data for the options you select here is displayed in the
graphs that are generated for analysis.
Frequency Response
Select this option to plot the frequency response for the filter design.
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Frequency Response
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frequency

Unit Pulse Response
Select this option to plot the unit pulse response for the filter design.
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Unft Pulse Response
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Unit Step Response
Select this option to plot the unit step response for the filter design.
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Unit Step Response
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Group Delay
Select this option to plot the group delay response for the filter design. This option is only available for an IIR

filter.
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Group Delay
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Poles/Zeros
Select this option to plot the poles and zeros for the filter design. This option is only available for an IIR filter.

Poles/Zeros

Im

~175 -190 -0,5 ©0]0 0,5 1.0 1.5
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Eye Diagram
Select this option to plot the eye diagram and eye closure for a FIR filter design. Keep in mind that a lower eye
closure can be achieved with an even order filter.

Eve Didgram
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. Plot the specifications.
Select the option to include a plot of the magnitude in the frequency response plot. The magnitude plotted is
based on the filter specifications and can be used to visually verify the shape of the filter based upon the
specifications you have entered.
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5. Keep data for comparison.

Select the option to keep previous data if you wish to retain it for a comparative analysis of different iterations of

a design.

Displaying the Analysis Plots

The analysis plots for a filter are displayed automatically in a Data Display window after the filter design process is
completed. In addition, analysis plots for a filter that has been designed previously can also be displayed.

dd

amp

e To design a filter and display its analysis plots automatically, choose Design > Design Filter from the Digital Filter
Designer menubar. Plots for the specified analyses are displayed in the Data Display window.

Freguency Response

141 i &
e S e T 4
SO = - e e e e T L e e e e e e =
4 4
T T e LT 13—
4

T e a
4 E -
—4{H — o |
X3 -
4
+a -
4
a

Grouo Delaw

] S04 1[5 2[5 2[5 J85 A5 S5 4[5 4[5 SE a EL4 s A& JE 2SO AE 4[5 4[5 4[5 ALK
Trea Trea
. Un1i{ Pulse Raspagnse ‘s Unli Sier Response Pales/Taras
gad. i ran it
gzt aa SR . -
g e B e DD SR . ] : : g
3 I . : : i . - - = -m == Tf E Ta
aa 3 || I A s mmnond g et - - - : ;
PR D D L S P R ]
e T e S I S 9.4 — t + 1
B @ oa A o oo o o o o o & L
8§ F 8 % § § 8 & & ¢ e
11me 1 img
e To display the analysis plots for a filter that has been designed previously, choose Design > Analyze from the

Digital Filter Designer menubar. Plots for the specified analyses are displayed in the Data Display window.

By default, analysis plots are displayed for both ideal and scaled coefficients. The ideal coefficients are given in
the full IEEE double precision or machine-standard definition while the quantized coefficients are based upon the
numeric format you specified, floating-point or fixed-point, and the bit width. To display an analysis of just the
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ideal coefficients, disable the implementation or conversion options by choosing Options > Disable/Enable
Conversion from the Digital Filter Designer menubar.

Editing an Analysis Plot

Click a plot to select it and choose Edit > Item Options to display the Plot Traces & Attributes dialog box. Use the
Datasets and Equations drop-down list in the dialog box to choose the dataset . Click data from the list on the left and

click Add to move it to the list on the right. Digital Filter Designer consistently uses the label "data" for any data that
is generated while designing a filter.

=| Plot Traces & Attributes:0

=i & 5 Ea =¥

Datasets and Equations Traces

Desired_Response Fraoe (RillRm.

data eye(Scaled filte
ind eye(ldeal filter:
iter wr il

i WL e

<t ey a g

Advanced...

0K Cancel Help

Repeat this process to add all the desired data before you click OK to close the dialog box and display the plot.

Refer to the online help or printed documentation for details on using the features and functionality available within
the Data Display environment.

Displaying Coefficients
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Coefficients for a filter can be displayed after the design process is completed. In addition, coefficients for a filter that
has been designed previously can also be displayed.
Digital Filter Designer generates two sets of coefficients, ideal and scaled, for a filter design.

e The ideal coefficients are based upon the full IEEE double precision or machine-standard definition.

e The scaled coefficients use either a floating-point numeric format or a fixed-point numeric format. The
floating-point format quantizes to the IEEE single precision format to achieve a word length of 23 with a
fractional length of 8. The fixed-point format with a bitwidth of n uses 1 bit to represent the sign bit and n-1 bits
to represent the fractional coefficients.

) Hint If your goal is to generate ideal coefficients only (using the full IEEE double precision or machine-defined
standard without any number rounding or saturation), you can disable the implementation or conversion
options by choosing Options > Disable/Enable Conversion from the Digital Filter Designer menubar.

Choose View > Coefficients from the Digital Filter Designer menubar to display the coefficients generated for the
designed filter. A table of the filter coefficients is displayed in the Data Display window.
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In the case of an FIR filter, the coefficients are listed in a single column. To scroll through the table of coefficients,
click the table to select it and choose the desired option from the View > Scroll Data submenu in the Data Display
window menubar or click the appropriate button in the Data Display window toolbar.

Refer to the online help or printed documentation for details on using the features and functionality available within

the Data Display environment.
The coefficients for an IIR filter in each row correspond to a second-order section and the coefficients are listed as

E)D, bl* bj* ag @, a,

corresponding to the transfer function of the section as follows:

-
E)D +blz+bjzh

=
a0+alz+a23h

For the scaled coefficients, the pairing logic used follows the rule that pairs the poles closest to the unit circle with the
zeros nearest to them. In addition, the sections are ordered using the logic that it is best to keep the sections in a

92




Advanced Design System 2008

sequence from the least peaked to the most peaked (typically those with poles closest to the unit circle). For more
information on the pairing and ordering logic used for IIR filter coefficients, refer to "Digital Filters and Signal
Processing" by Leland B. Jackson, pp. 321-323.

Coafficiants

ldaal _Ceoefficiants. _data ind Scaled_Coafficiants. . data
itar=0, row=0
1 1000 1 G 037
2 2 000 2 C.073
z 1000 2 G.037
4 G957 4 0. 648
= -0 800 = —1_474
& 1000 & 1. 000
itar=0_, row=1
1 1000 1 G100
2 2 000 2 G200
k! 1000 3 G100
4 G.a74 4 0.0
= -0 0 5 —-1_218
& 1000 & 100G
itar=0, row=2
1 1000 1 G181
2 2000 2 0. 361
= 1000 2 G, 181
4 G790 4 G200
5 —-0_ 932 = -0 832
|+ 1000 & 1,000

Generating a Schematic

When generating a schematic, keep in mind that the topology of the schematic you generate is affected by the
implementation options you have selected. For information on the available implementation options, refer to Choosing
an Implementation Structure in Implementing a Digital Filter.

To generate a schematic from your digital filter design:

1. Choose Design > Generate Schematic from the Digital Filter Designer menubar to display the Generate
Schematic dialog box.
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—| Generate Schematic

Design Type
} Generate Ideal {Infinite Precision) Filter Design

# Generate Scaled, Fixed Point Synthesizable Filter Design

Schematic Design Mame

Schematic

® Overwrite any existing design with same name

7 oK Apply Cancel Help 7
If you disabled conversions by choosing Options > Disable/Enable Conversion , or if you selected Floating Point
as the numeric format while designing the filter, you will be able to generate a schematic for only an Ideal
(infinite precision) filter.

Specify the filename to be used for saving the schematic. A scaled floating-point or single precision schematic
can't be generated if the simulator does not provide the library support for the required components.

Enter the desired specifications in the dialog box and click OK or Apply to generate the schematic.

Note Keep in mind that various implementation structures are used to minimize quantization effects that occur
as a result of coefficient scaling with the use of a fixed-point numeric format and finite-precision arithmetic. As
a result, when you use the ideal floating-point numeric format, the schematic generated remains constant for

all implementation structures.

3.

The generated schematic is displayed in a new Schematic window within Advanced Design System.
If Advanced Design System is not running, it is launched and then the schematic is displayed in a new Schematic
window.
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The generated schematic can now be edited or printed on its own. It can also be placed within another schematic, if
desired.

) Note In a schematic generated for a scaled filter design, a component is added to provide global parameters
for the entire filter structure. Use this component to change design parameters such as bit width to propagate
the change across the entire design rather than manually editing the parameters for each component.

Retrieving and Placing Coefficients

Given an existing filter design, you can generate a schematic from its coefficients directly from within an Advanced
Design System Schematic window. To do so, choose Tools > Digital Filter > Retrieve And Place Current Ideal
Coefficient Filter or Tools > Digital Filter > Retrieve And Place Current Scaled Coefficient Filter and use the dialog box
that is displayed to specify a filename for the schematic. Using the coefficients you choose to retrieve (ideal or
scaled), a new schematic is generated and saved using the filename you specify.
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—| Digital Filter Design Hame:1

File Hame

dfilter_untitled

_I Overwrite any existing design with same name.

A OK Cancel Help

Saving a Design File

Choose File > Save Filter Design to save changes to an existing filter design file. If you wish to create a new filter

design file or save changes to a new file, choose File > Save As and use the File Save As dialog box to save the file
using the desired filename and location.

=| File Save As

Filter

| ftmp_mntiusers2/pubsiuserss fIt

Directories Files
| . A [ 1 A
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.mosaic-personal -annotations

.netscape F 7]
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Selection
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ok | | Fiter | cancel| Help |

If you have computed the ideal and the implementation coefficients for the filter design, separate files containing each
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set of coefficients are typically saved in the synthesis subdirectory as ASCII files using the MDIF format. These files
are used by Digital Filter Designer to store information on the filter you design. The naming convention used for the
.mdb files is <design_name>ideal.mdb and <design_name>scaled.mdb .

In the MDIF file, the coefficients for an FIR filter are listed in a single column whereas those for an IIR filter are listed
in six (6) columns where each row corresponds to a second-order section and the coefficients are listed as

I’D* b T bj,au, aj, a;

corresponding to the transfer function of the section as follows:

-
b[ﬁl +Blz+523h

=
a0+alz+a23h

Coefficient data without the header and footer information is also typically saved in the synthesis subdirectory as
ASCII files using the .txt extension. Use these text files to add the filter coefficients to a component within Advanced
Design System or your application of choice. The naming convention used for the .txt files is <design_name>ideal.txt
and <design_name>scaled.txt .

In the text files, the coefficients for an FIR filter are listed in a single column just as in the MDIF file. Coefficients for
an IIR filter are listed in six (6) columns where each row corresponds to a second-order section and the coefficients

are listed as I)I:I* b 1’ b, g, @, @

corresponding to the transfer function of the section as follows:

-2 -1
E)Dz + blz +b,

A

Z -1
anz + a,z +a3

This format facilitates the use of this data within Advanced Design System.

Using Coefficients in Agilent Ptolemy Components

Ideal filter coefficients that you generate using Digital Filter Designer can be read into Agilent Ptolemy components
you place within a schematic.
To use the filter coefficients for a component:

1. Place the component.
From the Numeric Signal Processing palette, choose the FIR or the BqdCscd (IIR) component and place it on the
schematic.
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2. Edit the component parameters.
Select the component and then choose Edit > Component > Edit Component Parameters to display the

parameters for the component.

=| Biquad Cascade IIR Filter

Biquad Cascade
Instance Hame

BL
Taps (Array, e.q. 1.5 3.5)

Select Parameter S 0.067455 1.0 -1.143 0.4124

15="0.067455 0.135 0.0

X Display parameter on schematic

Bgid f3f Panip Component Options...

Taps : sets of six biquad coefficients

7 0K Apply Cancel Reset Help 7

Click the Taps parameter and enter the relative or absolute path and filename for the text file containing the
coefficients you wish to use. Be sure to enter a left angle bracket (<) before the path and filename.

Click Apply or OK to close the dialog box and use the filter coefficients from the specified file.

Manipulating Arrays

Use AEL to manipulate arrays when you create AEL functions to generate ideal coefficients for designing custom filters.
For details on using AEL, refer to the AEL documentation. For details on importing an AEL function you have created,

refer to Importing an AEL Ideal Coefficients Function.
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Declaring and Initializing Arrays

AEL supports multidimensional arrays using the following conventions.

e Array values are enclosed in curly braces "{ }"
¢ Array elements are separated by commas ","

e Array elements may be integers, doubles, or complex numbers
e Sequences can be used to initialize an integer or double array

e Matrices (enclosed within brackets "[ ]") can be assigned by separating rows by semicolons ";" and elements

I
non

within rows by commas ",

Example:

/1 one dinmension (row vectors) decl x = {1+3i, 4-5i, 9+3i, 10i};
x = [1+3i, 4-5i, 9+3i, 10i];

x ={1::10} // x ={1,2,3,4,5,6,7,8,9,10} x = {1::2::.5}

/1 x ={1,1.5,2}

// columm vectors

decl z;

z = {{1},{2},{3}};
[1;2;3];

z

/1 two dimension (matrix)

decl vy;

y ={ {12}, {3,4}, {56}, {7,8} };
y=1[1,2; 3,4; 5/6; 7,8 ];

/1 three dinmension

decl s;

s ={[0,1;2,3],[4,5;6,7]};

s = {{{0,1},{2, 3}},
{{4.5}.{6,7}}};

Displaying Arrays

Use the following function to display and print arrays during the debugging process.

identify_val ue();

This function converts the value assigned to a variable (or array) to a string. This value can then be printed using an
output function such as fprintf .

Example :

99




Advanced Design System 2008

decl x= {1+3i, 4-5i, 9+3i, 10i};

fprintf(stdout, "%\n", identify_val ue(x));

[/ this would output "{1+3i, 4-5i, 9+3i, 10i}"
decl y= {{1,2},{3,4},{5,6},{7,8}};
fprintf(stdout, "%\n", identify_value(y));

/1 this would output "{{1,2},{3,4},{5 6},{7,8}}"

Accessing Array Elements

To access elements within an array, specify the array name followed by the indexes enclosed in square brackets "[ ]".

To access elements of multidimensional arrays:

e The indices may be separated by commas and the whole sequence enclosed in square brackets as follows: [1,3]

e Each index may be enclosed in square brackets as follows: [1][3]
¢ An index may be an AEL sequence as follows: [1::3]

Example:

/1 x's 2nd elenent is nodified to a new value x[1] = 10-10i;

/1 an elenent iny is printed, the value printed is "4" fprintf(stderr,
"Os",identify_value(y[1,1]));

/1 an element iny is changed from"7" to "50" y[3][0] = 50;

/1 this |loop produces the sumof all elenents of x sum = O;

for (i=0; i<4; i++)

sum += x[i];

Array Operations

Assignments, additions, subtraction, multiplication (which is essentially matrix multiplication), division, and negation

are some of the operations that may be performed on a whole array.

Example:
decl x = {1,2,3,4};
Iz ={1,2,3,4}
decl z = x;
/Il x ={1,2,3,4} and z = {5, 5}
z = {5, 5};

#» Note Unlike C arrays, when assignments are made in AEL arrays, the receiver of the assignment points to the
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original array. And when modifications are made to an array, a new array is created so that other variables
pointing to that array are not modified.

Addition and Subtraction

When addition or subtraction is executed between whole arrays, the math is executed one element at a time.
Therefore, the array bounds must be exactly the same. Element by element multiplication, division, and power are
also supported by using the operators ., ./, and .*.

Example:
decl x = {1, 2,3, 4};
decl y = {9,8,7,6};
/1l z = {10, 10, 10, 10}
decl z = x + vy;
x ={ {1,2}, {3,4} };
y ={ {10, 9}, {8,7}
Il z={{-9,-7}, {-5,-3} }
Z =X - Y;
/Il z = {9, 16,21, 24}
zZ =X .*Yy;
Multiplication

When multiplication is executed between whole arrays, matrix multiplication is executed. Therefore, the arrays must
be two dimensional and the array bounds must be compatible for matrix multiplication, which is rowl x coll * row2 x
col2 where coll must equal row2 and the new array will have the dimensions rowl x col2 .

Example:

{ {1,2}, {3,4} };

{ {10,9}, {87} };

I z ={ {26,23}, {62,55} };
=X *y,

» Note The following shorthand notations are supported: +=, -=, *=

I

Scalars and Arrays

Any math operation between an array and scalar values is legal. The result of such expressions is an array.
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Example:
decl x = {1, 2,3,4};
/Il x ="{6,7,8,9}"
X += b5;
Il x = "{32, 28, 24, 22}"
x =100 / x * 2;

Transposing Arrays

Transposition of arrays is supported using the following syntax.

Example:
decl x = {1,2,3,4};
1 x = {{1},{2}, {3}, {4}}
y = X'

) Note Several built-in math functions are also available for operation on arrays. These include functions such as
sin, cos, tan, asin, acos, atan, etc. For details on the math functions available within AEL, refer to the "Math
Functions" section in the AEL documentation.
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