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Transistor Bias Utility

The Transistor Bias Utility documentation provides an introduction to the Transistor Bias Utility. The complexity of the
Advanced Design System (ADS) is made easily accessible through the automated capability. A first-time or casual ADS
user can begin using the capability of ADS quickly, while experienced ADS users can perform tasks faster than ever
before. The Step-by-Step Example describes how a resistive bias network for a GaAs FET can be designed and verified
in a few minutes.

The Transistor Bias Utility provides SmartComponents and automated-assistants for the design and simulation of
common resistive and active transistor bias networks. The automated capabilities can determine the transistor DC
parameters, design an appropriate network to achieve a given bias point, and simulate and display the achieved
performance. All SmartComponents can be modified. You simply select a SmartComponent and, with little effort,
redesign or verify their performance. Using SmartComponents provides details about using SmartComponents.

Step-by-Step Example

The step-by-step example takes you through the design and analysis for a resistive bias network for a GaAs FET. After
completing this example, you should have a basic understanding of the Utility and be ready to begin using it. Follow
these steps to begin:

e Setting Up the Design Environment
e Designing and Analyzing a Network

© Note
You should already be familiar with the basic features of Advanced Design System. For help with ADS basic
features, refer to the Schematic Capture and Layout documentation.

Setting Up the Design Environment

Before you can use the Transistor Bias Utility, you must set up the design environment by using these steps:
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Setting DesignGuide Preferences
Opening a Project

Opening a Schematic Window

Opening the Transistor Bias Utility
Displaying the SmartComponent Palette.

& Note

Before beginning, you must have installed the DesignGuide with appropriate licensing codewords.

Setting DesignGuide Preferences

All DesignGuides can be accessed through either cascading menus or dialog boxes. You can configure your preferred
method in the ADS Main window or from the Schematic window.
To configure access through menus or dialog boxes:

1. From the Main or Schematic window, choose DesignGuide > Preferences.
2. In the DesignGuide Menu Style group box, choose either Use a selection dialog box or Use cascade menus.

: DesignGuide Preferences X|

PLEASE MOTE: Any changes made to theze options require
restarting A0S ta take effect.

[v Show DezsignGuide Menu

The DesignGuide Preferences menu will still be available
in the Main window if you hide the DesignGuide menu
in the Schematic and Laypout windows.

DezignGuide Menu Style
f* |ze a zelection dialog box

(" Uze cazcade menuz

WARMIMG: Due to *Windows resource issues, using
cazcade menus on a PC may destabilize your spstem
when multiple windows are open.

] Cancel |

3. Close and restart the program for your preference changes to take effect.

 Note
On PC systems, Windows resource issues might limit the use of cascading menus. When multiple windows are
open, your system could become destabilized. Therefore, the dialog box menu style might be best for these
situations.
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The ADS Main window DesignGuide menu contains these choices:

DesignGuide Developer Studio > Start DesignGuide Studio is only available on this menu if you have installed the
DesignGuide Developer Studio to open the initial Developer Studio dialog box.

DesignGuide Developer Studio > Developer Studio Documentation is only available on this menu if you have installed
the DesignGuide Developer Studio to open the DesignGuide Developer Studio documentation.

 Note

Another way to access the DesignGuide Developer Studio documentation is by selecting Help > Topics and
Index > DesignGuides > DesignGuide Developer Studio from any ADS program window.

Add DesignGuide opens a directory browser in which you can add a DesignGuide to your installation. This is primarily
intended for use with DesignGuides that are custom-built through the Developer Studio.

List/Remove DesignGuide opens a list of your installed DesignGuides. Select any that you would like to uninstall and
choose the Remove button.

Preferences opens a dialog box that enables you to:
e Disable the DesignGuide menu commands (all except Preferences) in the Main window by unchecking this box. In

the Schematic and Layout windows, the complete DesignGuide menu and all of its commands are removed if this
box is unchecked.

e Select your preferred interface method, either cascading menus or dialog boxes.
Opening a Project

The ADS design environment is set up within a project.
To create a new project:

1. From the ADS Main window, choose File > New Project or click Create a New Project on the toolbar.
— Create a New Project

D= =|%|E] EEE) =]

2. In the dialog, define the location of the project and assign a project name.

Opening a Schematic Window
A new schematic design is needed to contain the lowpass component for this example.
To open a Schematic window:

1. From the ADS Main window, choose Window > New Schematic or click New Schematic Window on the toolbar. A
new Schematic window appears.
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Mew Schematic Window
]

EEEReEEE=EEE

& Hint
Depending on how your ADS preferences are set, a Schematic window can appear automatically when you
create or open a project.

2. In the Schematic window, choose File > New Design to create a design named Example.

Opening the Transistor Bias Utility

The Transistor Bias Utility is accessed from the DesignGuide menu.
To open the Transistor Bias Utility:

1. In the Schematic window, choose one of these paths from the DesignGuide menu:
e DesignGuide > Amplifier > Tools > Transistor Bias Utility
e DesignGuide > Mixers > Tools > Transistor Bias Utility
e DesignGuide > Oscillator > Tools > Transistor Bias

& Hint

Expand the list under Tools by clicking the + sign.

2. Select Transistor Bias Utility and click OK to open the tool. The Control window opens.

Using the Control Window

All Utility features are available from the Control window. The Control window houses menus, a toolbar, and
SmartComponent manipulation controls. The menus and toolbar buttons perform the basic functions of design, delete,
and display the SmartComponent palette. Full features are available from each of the tab pages on the window. The
window can be placed anywhere on the screen. Explore each tab page by clicking on the tab at the top of each page.
Explore the window menus as well to familiarize yourself with the basic Utility capabilities.

The pull down lists at the top of the control window are designed to help you navigate multiple schematic windows and
SmartComponents. You can use the Current Schematic drop-down list box to select any of the currently opened
schematic windows. This field is updated any time Bias Control Window is selected from the DesignGuide menu. From
the SmartComponent drop-down list box, you can select any of the SmartComponents on the currently selected
schematic window.
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i Transistor Bias Utility -0 x|

Open File Tools Wiew

component

palette CARAAEE

Current Schematic SmatComponent
|[ passive_pri]: 1 ~| |DA_FETBiast =} Select

component
Cument Design SmantComponent Capahility
Select |ptest [Design, Simulate, Extract Parameters
simulation

fool ————— 34— Frrarrimm— Resiztive Networks Iﬁchve Hutwuks]

— Biaz Settings

Wdd Device Type

: = e g
Yds Id
Setvoltage 3 I"u‘ 3 I )

[ Include RF Chokes Bias Paint Selection |

Set current

L

Device Pararnsters

v Automatically Extract Device Parameters
Wt K [BA2)

& Device Parameters |-2.0000 |"L ;] |3.999%-005

Vs
{~ Oevice Bigs Faint J1.1623 |1 j

Helps
NFET  “dd andds must be positive. -
FFET  Vdd and Vds must be negative.

Id = K*[Wgs - Wi]"2

2

-

L

Start
simulation

- Design | Help |

To close the Control window:

e Select File > Exit DesignGuide from the Control window menubar. (You can also close the window by clicking the
x at the top of the window.)
Continue the step-by-step example by Designing and Analyzing a Network.

Designing and Analyzing a Network
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In this step-by-step example, you design and analyze a resistive bias network. A resistive bias network can be
designed easily by using the default component parameter settings. Using the Utility follows a normal design flow
procedure:

e Select and place a component needed for your design from the component palette (Displaying the
SmartComponent Palette and Placing Example Component in the Design).

¢ Provide specifications (Changing SmartComponent Parameters).

e Design and analyze the component (Designing the SmartComponent).

) Note

Before starting this section of the step-by-step example, confirm your setup ( Setting Up the Design
Environment).

Displaying the SmartComponent Palette

The DesignGuide contains a SmartComponent palette, Transistor Bias Networks, that provides quick and easy access
to the SmartComponents. A blue accent in the upper-left corner of a palette button indicates the component is a
SmartComponent.

Blue accent mark |Transistur Bias Networks LJ
indicates a

SEmartComponent —— #
{BJT {FET

Biaz Biasz
yit:iii yit:i"_lz
AmpBias | AmpBias
?’(_:.:...... ?’.:_:.:,_....

=iF| =1
AmpBias | AmpEias
?’itrli ?’iﬁ:"z
Reabios | ReaBids
?’(_:.:...... ?’.:_:.:,_....

=[z]| =¥

Feabiaz RETEIBil:IS

You can display the SmartComponent palettes in one of these ways:

e By clicking Component Palette on the Control window toolbar
e By choosing View > Component Palette from the Control window menu

e By selecting the Transistor Bias palette from the Component Palette drop-down list box in the Schematic window
toolbar (directly above the palette).

Continue the example by selecting the Transistor Bias palette. The palette displays in the Schematic window.

Placing Example Component in the Design
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To place a SmartComponent in the design:

1. Click FET Bias on the component palette to select the component.

w’{:m ?’{Im — Select

Eiaz Bias companent
T L

=1 =

FimpEins | AmpBigs
39"@u-. 3‘°"@u-.
AmpBiaz | AmpEiaz
Pt ¥
0| Fh
Re-gBius RE_gE‘-ius
?'.;_:.:,..... ?'.;_:.:,.....
=3 =4

RegBia: | RegBias

2. Click within the schematic window to place the component.
¢ You can change the orientation of the SmartComponent before placement by selecting from the Insert >
Component > Component Orientation commands or by selecting Rotate by -90 repeatedly from the
schematic toolbar.
e The place component mode remains active until you choose End Command from the schematic toolbar.

 Note

When a SmartComponent is placed initially, a temporary component is used to place and specify the
parameters for the SmartComponent. This component does not contain a subnetwork design. After the utility
has been used to design the SmartComponent, the temporary component is replaced with a permanent
component. The SmartComponent is renamed to DA_ComponentName_DesignName and an autogenerated
design is placed inside the SmartComponent's subnetwork design file. Subsequently, if the SmartComponent
parameters are edited, the utility must be used again to update the subnetwork design file.

Continue the example by placing and wiring the remaining components:

1. Display the Devices-GaAs palette.

2. Place a GaAsFET (GAASN) device and an Advanced Curtice 2 model (AdvCr2) into the design.

3. Wire the gate, drain, and source of the device to the appropriate SmartComponent pins, as shown in Wire the
Gate, Drain, and Source in the Example. The Vdd pin does not need to be connected at this time.

10
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TVdd
1 K.
chlE
sk
Pire DA%; :
components — P =ampE anced_CurticeZ_Model

as shown

GanksFET

Wire the Gate, Drain, and Source in the Example.

Changing SmartComponent Parameters

Parameters can be changed directly from the DesignGuide Control window.
To edit the FETBias component parameters:

1. In the Control window, select the FETBias component from the SmartComponent drop-down list. This ensures all
changes are referenced to this component.

2. Select the Resistive Networks tab.
3. Set Vds (drain to source voltage) to 3V and Id (drain current) to 1 mA on the control window Bias Settings edit

boxes. Leave all other parameters at default.

) Note

See Placing and Editing SmartComponents for details on changing parameters in the design window or
component dialog box.

Designing the SmartComponent

You can design and analyze the SmartComponent from the Control Window.

To start the simulation:

1. On the Resistive Networks tab, click Design to start a simulation. The simulation determines the DC parameters

11
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of the device at the selected bias point. When the simulation has finished, a Bias Network Selection dialog box

appears.

2. Select one of the networks and click OK to start a second simulation. (Networks that appear in gray cannot be
designed for the current parameter settings.) A second simulation takes place and a data display window
summarizing the DC performance of the device appears.

Bias Metwork Selection:1

IJze arrows to zcroll and zelect desired network. topology.

Fraction of OC Power Congumed in G ate Resistars

R atia of Saurce ta Supply Valtage

[0.000 < PR < 1.000)

X D<VR <05
|3_ZI of 3 networks
=
Ok Cancel
FET Bias Need
Display Assistant e
Transistor Bias Designer
Vo Ig
Achieved Bias Voltage/Current 1.76 W 0.00
Vs Id
Desired Bias Performance 3.00 1.00
Achieved Bias Performance 200 | 1.00e+D

Closing the FETBias Analysis Results Window

e To close the display window, choose File > Close Window from the menu.

Examining the Component Design

12

Select a
netwaork to
simulate
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You can look at the details of the autogenerated design inside the SmartComponent's subnetwork.
To examine the component's subnetwork:

1. Select the component FETBias.

2. Click Push Into Hierarchy on the schematic toolbar.

3. After examining the design, click Pop Out on the schematic toolbar to close the view.
Push Intc Hierarchy

Pa
Hum=3
|

HoSa ol -

| Rz R
§R=5.51312‘||Dhm R=0 mOhm

Pop Out

Lol

Fort
- P2
Fort ) Num=2
P4 < >
Hum=1 Port
Fz
Hum=3

1 1

R4 R3
g R=12 486588 kOhm R=3 kOhm

-

=

Deleting the SmartComponent

e To delete the FETBias SmartComponent, choose Tools > Delete SmartComponent from the DesignGuide control
window.

 Note

13
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The Delete button on the DesignGuide control window is different from the Delete button on the ADS
schematic window toolbar.

This completes the step-by-step example.

Using SmartComponents

This Utility provides several SmartComponents representing resistive and active bias networks. SmartComponents are
smart sub-network designs that provide the container for specification parameters and a schematic representation of
the design when placed into a design. The utility provides automated design and analysis for these SmartComponents.
SmartComponents can be placed, copied, edited and deleted like other components in the Advanced Design System.
The basics of placement, copying, editing and deleting are described briefly in this section.

) For help with ADS basic features, refer to the Schematic Capture and Layout documentation.

Placing and Editing SmartComponents

The components are placed in the schematic by selecting the SmartComponent from the palette and clicking at the
point where you want to place the component in the schematic.

Placing SmartComponents

To place a SmartComponent in the design:

1. In the Schematic window, select the component from the SmartComponent palette.
2. Click within the design window at the location where you want to place the SmartComponent.
e You can change the orientation of the SmartComponent before placement by selecting from the Insert >

Component > Component Orientation commands or by selecting Rotate by -90 repeatedly from the
schematic toolbar.

e The place component mode remains active until you choose End Command from the schematic toolbar.

Changing Position and Orientation

A SmartComponent is moved by dragging it to any location in the Schematic window.
To change the component's orientation:

14
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1. Select Edit > Advanced Rotate > Rotate Around Reference from the Schematic window or select Rotate Items

from the toolbar.

2. Click the SmartComponent you want to use.
3. Rotate the component. The rotate mode remains active until you select End Command from the toolbar.

Editing SmartComponents

Specifications of the SmartComponent are entered directly on the Resistive Networks or Active Networks tab on the
Control window. You can also modify the specifications in one of these ways:

¢ Click the SmartComponent parameters in the schematic window and change them (see The FET Bias Network

Component.)
e Double-click the SmartComponent to open a dialog box containing all parameters

|
T\e’dd
| ]
s hife
DA FETEIas ptest
DA_FETBias1
DeviceType=NFET
Yils=Et Y

L?;JEEva Edit SmadCE mpaonent
V=1 parameters here
kK=1e-2
Wis=

The FET Bias Network Component

The SmartComponent design (schematic) can be viewed by pushing into the SmartComponent's subnetwork. See

Examining the Component Design.

A SmartComponent subnetwork is empty until the design is generated (see the note in the section Placing and Editing
SmartComponents).

Copying SmartComponents
SmartComponents can be copied within a design, to another design, or to another Schematic window.

15
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Copying Within a Design

To copy a SmartComponent to the same design:

1. Click the SmartComponent to be copied.
2. Select Edit > Copy and then Edit > Paste from the schematic window.
3. Click where you want the copy placed.

Copying Between Designs or Schematic Windows

To copy a SmartComponent to another design:

Click the SmartComponent to be copied.

Select Edit > Copy from the Schematic window.

Display the design or schematic window you want to copy the SmartComponent to.
Select Edit > Paste to copy the SmartComponent to the design.

Click where you want the component placed.

uhwnNE

Copying a SmartComponent as a Unique Design

Initially, all copied SmartComponents refer to the same SmartComponent design. When the Design Assistant is used
to perform a design operation, the Design Assistant transforms each copied SmartComponent into a unique
SmartComponent design. A design operation is accomplished from the Utility Control Window.

Deleting SmartComponents

SmartComponents can be deleted from a design like other components, but completely removing a
SmartComponent's files requires the actions described here.

Deleting from Current Design

A SmartComponent can be deleted from a design in one of these ways:

e By selecting the component and pressing the Delete key,
e By selecting Delete ** from the toolbar,
¢ By selecting Edit > Delete from the schematic window.

16
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 Note
This procedure does not remove the SmartComponent files from the project directory. To delete files from the
project directory, see Deleting from Current Project.

Deleting from Current Project

To delete a SmartComponent and all associated files from your project:

1. From the DesignGuide Control window, select Tools > Delete SmartComponent or on the toolbar, click Delete
SmartComponent.

2. Click the SmartComponent you want deleted. This deletes the SmartComponent from the current design and
removes all of its files from your project. The SmartComponent delete mode remains active until you select End
Command from the schematic toolbar.

Deleting Manually Using File System

You can use your computer's file system to delete a SmartComponent by deleting the appropriate files in the network
subdirectory of a project. Delete files that start with DA_ or SA, contain the SmartComponent title, and end with .
_ael, .atf, or .dsn.

Using SmartComponents as Standalone Components

After SmartComponents are designed and tested, they can be used as standalone components. The Bias Utility is not
needed to use them in new designs unless you wish to modify or analyze them. When using the SmartComponent in a
design, however, the power supply pins (Vdd, Vcc, Vp, Vm) must be connected to a DC voltage source whose voltage
level corresponds the parameter setting.

Using an Existing SmartComponent Within the Same Project

To use an existing SmartComponent within the same project:

1. Open the Component Library window by selecting Insert > Component > Component Library from the Schematic
window or Display Component Library List on the toolbar.

2. Select the project name under All > Sub-networks in the Libraries list at the left of the Component Library
window. Available components are listed in the Components list at the right of the Component Library window.

17
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3. Select the SmartComponent in the Components list.
4. Place the SmartComponent into your design by clicking in the Schematic window at the location you wish it
placed.The insert mode remains active until you click End Command.

Using an Existing SmartComponent in Any Project

A library of predesigned reusable SmartComponents can be created by placing the reusable SmartComponents in a
project. This project can be included in any project and its SmartComponents can be accessed using the Component
Library.

To use an existing SmartComponent in any project:

Select File > Include/Remove Projects from the main ADS window.

Select the project that contains the SmartComponent from list in the Include & Remove window.

Click Include to include the project in the hierarchy and click OK.

Open the Component Library window by selecting Insert > Component > Component Library from the Schematic

window or Display Component Library List from the toolbar.

5. Select the included project name under All > Sub-networks in the Libraries list at the left of the Component
Library window. Available components are listed in the Components list at the right of the Component Library
window.

6. Select the SmartComponent in the Components list.

7. Place the SmartComponent into your design by clicking in the Schematic window at the location you where you

want to place the component. The insert mode remains active until you click End Command.

e

Automated Design and Analysis

The Automated Assistants provide quick design and performance analysis for SmartComponents. Two Automated
Assistants are available in this Utility for design:

¢ Resistive Networks is used to design and simulate the performance of resistive bias networks for BJT and FET
devices.
e Active Networks is used to design and simulate the performance of active bias networks for BJT and FET devices.

Explore each tab page by selecting the associated tab on the control window.

Resistive Networks

The Resistive Networks tab is used to generate and update the design contained within a resistive bias network
SmartComponent from the given specifications. This tool is accessed using the Bias Utility control window. From the
control window, full design control is enabled from the Resistive Networks tab. Component design operations can also

18
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be accomplished using the control window menu and toolbar. Any parameter change made from the Resistive
Networks tab is reflected on the SmartComponent in the schematic.

Overview i Resistive Netwarks ; Active Metworks I

— Biaz Settings
Wdd Device Type
G = e <]
Wds Id
f3 v = m 7]
[~ Include AF Chokes Biaz Point Selection |

— Device Parameters

v Automatically Extract Device Parameters

it KA
i Device Parameters J-2.0000 I‘f’ d J9.9999¢-005
Yaos
{~ Device Bias Poirt J1.1623 I‘f’ j
Helps
MFET “dd and Vds must be positive. ;I
PFET YWdd and Vdz must be negative.
Id = K5vgs - Wi)™2 _I
Design | Help |

Resistive Bias Network SmartComponents

Resistive bias networks can be designed for NPN BJT, PNP BJT, NFET, or PFET devices. Two different
SmartComponents are available on the Utility palette as shown.
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“oor | e | FET Devices

Bias Eiaz
F e | E e
TRl Fh
AmpBias | AmpEias
?@,t’ ¥ i
AmpBias | AmpBia:
?’.:.:..:,.. ?’E.:,..
= 1| ==
RE-gEil:IS RE-EIBil:IS
S - |
Tn| T

Reakias | ReaBia:

BJT Devices

Before designing a network, the SmartComponent pins must be wired to the corresponding pins of the device for
which the bias network is to be designed. If the device also has a model associated with it, then this model must be
placed on the schematic as well. If the device has pins that should be grounded, this grounding must also be done
before a design is attempted.

The SmartComponent supply pin (Vdd or Vcc) does not need to be connected at this time. However, when the
SmartComponent is used in a design, this supply pin must be connected to a DC voltage source set at the appropriate
supply voltage level. The following image is an example of an appropriate setup in preparation for design.
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4
fvdd
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s R o
b
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Appropriate Design Setup for Resistive Bias Network

BJT Networks

Resistive bias networks for BJT devices have the following options:

Vcc - DC supply voltage value. This is the DC voltage that will be connected to the collected side of the bias network.
Vce - Target bias point collector-to-emitter voltage.

Ic - Target bias point collector current.

Device Type - BIT device type. For NPN design, all voltages must be positive. For PNP design, all voltages must be
negative.

Include RF Chokes - If this option is set, the design incorporates RF choke (DC Feed) elements to isolate the bias
network from the RF signal.

Automatically Extract Device Parameters - The DC operation of the device near the operating point is modeled as Ic =
beta x Ib , where beta is a device parameter and Ib is the base current at the desired operating point. Furthermore,
the device is characterized by a base-emitter voltage drop Vbe at the desired operating point. If the option
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Automatically Extract Device Parameters is set, the utility attempts to extract beta and Vbe parameters using a
simulation. If the target bias point is inappropriate for the device, then this extraction can fail. Alternately, the
parameters beta and Vbe can be manually specified.

After parameters have been specified and you have pressed Design , the utility starts the design process. If
requested, the device parameters are extracted first. If this extraction is successful, then a dialog opens so you can
select the bias network topology. Any networks appearing in gray cannot be designed for the current bias parameters.
If all networks are gray, then the bias settings must be altered.

Bias Metwork Selection:1 |

Select desired nebwark, topology,
Metwaorks in gray are invalid for cument paramebers.

AN

W=D AN

Wi

U R

l
%

Fraction of DC Power Consumed in Base Hesistors
||:|_25 0002 < PR <1

g=AAS

Ratio of Emitter to Supply Yoltage
0.1 D<%R <05

] 4 | Cancel |

For 3 or 4 resistor topologies, additional specifications must be provided:

Fraction of DC Power Consumed in Base Resistors - This parameter sets the current through the base bias network
when two resistors are used. The specification is made in terms of the fraction of the total resistive power dissipated
in the device that is due to the base resistors.

Ratio of Emitter to Supply Voltage - For specifying the emitter resistance, the emitter voltage (specified relative to the
supply voltage Vcc) must be specified.

After a suitable network topology has been selected (indicated by a box around the topology), pressing OK completes
the design and simulation. A display window opens showing the achieved performance of the network.
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FET Networks

Resistive bias networks for FET devices have the following options:

Vdd - DC supply voltage value. This is the DC voltage that will be connected to the drain side of the bias network.

Vds - Target bias point drain-to-source voltage.

Id - Target bias point drain current.

Device Type - FET device type. For NFET design, Vdd and Vds must be positive. For PFET design, Vdd and Vds must be
negative.

Include RF Chokes - If this option is set, the design incorporates RF choke (DC Feed) elements to isolate the bias
network from the RF signal.

Automatically Extract Device Parameters - The DC operation of the device near the operating point is modeled as Id =
K x (Vgs - Vt) 2 , where K and Vt are device parameters and Vgs is the gate-to-source voltage at the desired
operating point. If the option Automatically Extract Device Parameters is set, the utility attempts to extract these
parameters using a simulation. If the target bias point is inappropriate for the device, then this extraction can fail.
Alternately, either the parameters K and Vt or the bias point Vgs can be manually specified.

After parameters have been specified and you have pressed Design , the utility starts the design process. If
requested, the device parameters are extracted first. If this extraction is successful, then a dialog opens so you can
select the bias network topology. Any networks appearing in gray cannot be designed for the current bias parameters.
If all networks are gray, then the bias settings must be altered.
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Bias Metwork Selection:1 |

Select desired nebwark, topology,
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For 3 or 4 resistor topologies, additional specifications must be provided:

Fraction of DC Power Consumed in Gate Resistors - This parameter sets the current through the gate bias network
when two resistors are used. The specification is made in terms of the fraction of the total resistive power dissipated
in the device that is due to the gate resistors.

Ratio of Source to Supply Voltage - For specifying the source resistance, the source voltage (specified relative to the
supply voltage Vdd) must be specified.

After a suitable network topology has been selected (indicated by a box around the topology), pressing OK completes
the design and simulation. A display window opens showing the achieved performance of the network.

Bias Point Selection for Resistive Bias Networks

Typically, selection of the bias point is performed based upon specifications provided by device manufacturers. To
assist in this selection process, simulation and display templates are provided. You can use these templates to choose
the bias point based upon optimal Class A operation for power amplifiers, or to achieve target gain or noise figure
specifications for small-signal amplifiers. The templates contain text on the schematic and display windows indicating
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the sequence of steps to follow to assess the device performance.

After a device bias point has been determined from these templates, the schematic template must be closed and the
design containing the original SmartComponent must be visible before the design can proceed.

Active Networks

The Active Networks tab is used to generate and update the design contained within an active bias network
SmartComponent from the given specifications. This tool is accessed using the Bias Utility control window. From the
control window, full design control is enabled from the Active Networks tab. Component design operations can also be
accomplished using the control window menu and toolbar. Any parameter change made from the Active Networks tab
is reflected on the SmartComponent in the schematic.

Owverview I Fesistive Metworks | Active Metworks I

~Supply Settingz

Pozitive Supply [Wp) Hegative Supply [Ym]

[15 v = [i5 v =]
— Biaz Settings

Device Yoltage [VBias)

I3 [v =] I Inclde RF Chokes

Device 1 Currert (11) [ievice 2 Curert [I12]

[10 jma =] e =]

Cresiee 3 Current (13] [Device & Curent [14)

| e =] e ~]
Bias Pairt Selection

Device Number
#FET ot i -] Open Selection Template |

Helps
The device can be a grounded source NFET or a grounded emitter MPN BJT.

Design | Help

Active Bias Network SmartComponents
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Active bias networks can be designed for NPN BJT or NFET devices. Eight different SmartComponents are available on
the Utility palette as shown.

# #
»{IEJT »{IFET

Bias Biaz
?’%qi ?"%qz
AmpEia: | AmpEias Mor-regulating circuits
y%:__g y%:__q for BJT/FET devices

AmpBia: | AmpBins

T TR

fiegéli:_ila_tll_[lg _F-idrceu'f_ts ReqBia: | ReaBigs
r ! VICES

y%[% ?"%Eq

ReaBia: | ReaBias

Active bias networks use operational amplifiers to create a network that can offer the specified bias point independent
of the device characteristics. The bias voltage and current are set independently. A non-regulating (OpAmp based)
design provides a simple network with low parts count. However, the performance can vary as a function of the
tolerances of the parts used to fabricate the network. The regulating designs use a zener diode to provide a more
tolerant design at the expense of a more complicated network.

Before designing a network, the SmartComponent pins must be wired to the corresponding pins of the device for
which the bias network is to be designed. If the device also has a model associated with it, then this model must be
placed on the schematic as well. If the device has pins that should be grounded, then this grounding must also be
done before a design is attempted. Since these bias networks can be used only for grounded source FET or grounded
emitter BJT devices, these pins on the device must be grounded.

The SmartComponent supply pins (Vp and Vm) do not need to be connected at this time. However, when the
SmartComponent is used in a design, these supply pins must be connected to DC voltage sources set at the
appropriate supply voltage levels.

For each type of network (non-regulating and regulating), the four SmartComponents available can accommodate
different numbers of devices (1 through 4 devices). All devices biased by a given SmartComponent must share the
same bias voltage (Vce or Vds), but can have independent bias currents.

Appropriate Design Setup for Active Bias Networks is an example of an appropriate setup in preparation for design.
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Appropriate Design Setup for Active Bias Networks

Network Design

Active bias networks for NPN BJT and NFET devices have the following options:

Positive Supply (Vp) - DC positive supply voltage value. This DC voltage runs the operational amplifiers that are used
to create the bias.

Negative Supply (Vm) - DC negative supply voltage value. This DC voltage runs the operational amplifiers that are
used to create the bias.

Device Voltage (VBias) - Target bias point collector-to-emitter or drain-to-source voltage for all devices.

Device Current (I) - Target bias point collector or drain current. Each device can have a unique bias current.

Include RF Chokes - If this option is set, the design incorporates RF choke (DC Feed) elements to isolate the bias
network from the RF signal.

After parameters have been specified and you have pressed Design, the utility starts the design process. A simulation
is performed after the design is complete, and a display window opens showing the achieved performance.
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Regulating Networks

The Regulating Bias Networks (RegBias) use a zener diode to regulate the actual bias voltage level achieved. This
makes for a design that is more tolerant to variations in component values. Furthermore, these networks use RC
networks such that the drain voltage is applied before the gate voltage is applied. For many FET devices, this
dramatically reduces device failure due to damaged gate oxide.

For these networks, the zener diode voltage ( Vzener ) and maximum power rating of the resistors used in the

network ( Pmax ) must be specified. These parameters cannot be specified on the control window, and therefore must
be specified directly on the SmartComponent on the schematic window or using the parameter dialog box that appears
by double-clicking on the SmartComponent.

Bias Point Selection for Active Bias Networks

Typically, selection of the bias point is performed based upon specifications provided by device manufacturers. To
assist in this selection process, simulation and display templates are provided. You can use these templates to choose
the bias point based upon optimal Class A operation for power amplifiers, or to achieve target gain or noise figure
specifications for small-signal amplifiers. The templates contain text on the schematic and display windows indicating
the sequence of steps to follow to assess the device performance.

To use this capability for Active Bias networks, the number of the device (1-4) as well as the device type (BJT or FET)
connected to the SmartComponent must be specified. Pressing Open Selection Template opens the appropriate
schematic and display templates.

After a device bias point has been determined from these templates, the schematic template must be closed and the
design containing the original SmartComponent must be visible before the design can proceed.

Load Pull Measurement Data Import Utility

The Load Pull Measurement Data Import utility is used to import Maury or Focus Loadpull measured loadpull data in
Agilent's Advanced Design System (ADS) for interpolation and generation of load and source pull contours. It is
assumed that the data is generated for a constant bias, fixed frequency and constant input power.

The Load Pull Measurement Data Import utility can be selected and installed during installation process of ADS. After
installation, the Load Pull utility can be accessed from Schematic window.

The process includes:

e Importing Loadpull Measurement Data
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e Preparing Data for Interpolation
e Interpolating the Data and Displaying Results

Importing Loadpull Measurement Data

Before you can use Loadpull Measurement Data Import utility, you must have measured loadpull data available on
your system. If you do not have measured loadpull data, you can access and copy sample measured data file for
Maury and Focus microwave system to your project directory by selecting DesignGuides > Loadpull > Sample Loadpull
Data File.

To import loadpull measurement data:

1. In the Schematic window, choose DesignGuides > Loadpull > Loadpull Measurement Data Import Utility. Click
OK. A dialog box appears.

2. Specify the File Format option. You can import either Maury or Focus measured data.

3. Select Select Loadpull Data File to open the File Selection dialog box. You can select either Browse or Load
Output File.

e Use the Browse option to select a specific data file from the project directory and define the output file
name.

e Use the Load Output File option to load a previously-prepared load pull data file. You can use this option if
you have successfully prepared loadpull data earlier and you want to load it now. All the prepared loadpull
file have an extension .Ip . When selecting the data file, all the Measurement Variable for contour plots
loads directly. You can add a Measurement Variable to Trace and Generate Contours.

4. Select the measured data file using Browse button and define the Output File Name. Click OK.

Open Data File x|

Loadpull D ata File Mame

Browse. .. I

Output File Name |Urititled_Loadpull I

T he output file will be zaved ta vour project [Ipa)

ok, L Cancel

During selection of loadpull-measured data file, the format of the loadpull impedance data is determined. If the
impedance value is normalized to its characteristic impedance, the Data Format dialog box displayed during this

process reflects these settings.
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Data Format il
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Impedance Data Fomat
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i+ Real/lmag
Impedance Marmalzation

[ Check the box if data fle impedance
value iz not nomakzed

()4 Cancel |

In some cases, it is difficult to determine the data format correctly due to non-availability of measured data
points across the entire Smith Chart region. In this case, you must make the changes manually. If the
impedance values are not normalized and appear in the load pull file as, for instance, 52+jx32, check the

Impedance Normalization check box and set the value of Zohm to the applicable normalized impedance (such as,
50 ohms).

Preparing Data for Interpolation

In this step, the tool reads the measurement points and prepares the data for interpolation. You also have an
opportunity to select the measurement variables you want to plot.

To prepare data for interpolation:

1.

In the Load Pull Utility dialog, select Prepare Loadpull Data to prepare the data for interpolation. The process
takes all the measurement points and generates a triangular mesh to perform linear interpolation on scattered
data. After the data is prepared for interpolation, the measurement variables for which the contours can be
generated appear in the Measurement Variable field. The utility does not restrict the number of variables you can
plot simultaneously. You can generate loadpull contours for multiple variables at the same time, provided you
have valid measurement data to generate loadpull contours.

Select the variable from the Measurement Variable field and add to the Trace field. During this process you enter
the minimum and maximum bounds for your contour plots and the number of contours you want to generate
within defined bounds. Add all the Measurement Variables you want to plot to the Trace field.
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3. Select Open New Data Display Page so you can plot loadpull contours on Smith Chart or on Polar Chart. (Note: to
view contours on a rectangular grid, select Plot real(Variable_Name) vs. imag(Variable_Name)). For details on
using the data display, refer to Plots and Lists in the Data Display documentation. Select the Output Mesh option
to export the triangular mesh generated during Prepare Loadpull Data to a data display page. The output mesh
can be plotted by plotting the variable Zmesh on the Smith Chart or Polar Chart. You can use the output mesh to
view the measurement points and for debugging purposes.

Interpolating the Data and Displaying Results

The interpolation process generates load pull contours and displays the results.
To interpolate the data:

1. Click Generate Contours to start the interpolation process. This process interpolates the prepared data and
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generates load pull contours. At the end of the interpolation process, the data display opens.
2. Select the type of display from the list. During the translation process, the measurement variable name changes
to remove all special character and a prefix "Z" is appended at the beginning. To view the new assigned name in

the Data Display Variable Name, select the name in the Trace window.
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