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About RFIC Dynamic Link

Agilent Technologies and Cadence Design Systems both offer powerful EDA design tools. Many of today's design
engineers prefer to use a combination of these tools to take advantage of the strengths of both design environments.
Because of this desire to use multiple tools, Agilent Technologies has developed the RFIC Dynamic Link for Cadence.
The Dynamic Link enables both top-down and bottom-up design and simulation in Advanced Design System (ADS)
using IC designs from the Cadence database.

Advanced Design System

Advanced Design System has been developed specifically to simulate the entire communications signal path. This
unique solution integrates the widest variety of proven RF, DSP, and electromagnetic design tools into a single,
flexible environment. Building on years of expertise developing new technologies for our EDA tools, Advanced Design
System provides a broad range of high-performance capability. This makes it easy to explore design ideas, then model
the electrical and physical design of the best candidates.

Virtuoso Schematic Composer

The Virtuoso Schematic Composer from Cadence Design Systems is a hierarchical design entry tool used by RFIC
circuit designers. Useful for both analog and digital designs, the database created is accessible by the Cadence
simulation and physical layout tools. The tool supports multi-sheet schematics, including cross-referencing, symbol
creation, automatic HDL cell template generation, global nets and hierarchical property definition for most database
objects. The tool also provides hierarchical checking of connectivity, consistency of different cell representations and
label attachments.

RFIC Dynamic Link

RFIC Dynamic Link is an EDA framework integration software product based on Inter-Process Communication __
(IPC), rather than data file translation, maximizing data integrity and ease of use.This manual describes how to install
and configure the RFIC Dynamic Link product and assists you in designing and analyzing analog mixed-signal and RF
circuits via Dynamic Link. Getting Started Tutorial is provided to help you quickly get started with using the RFIC
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Dynamic Link. For information on Library Customization, refer to the RFIC Dynamic Link Library Guide.

RFIC Dynamic Link Use Model

The RFIC Dynamic Link use-model coincides with that of both Cadence and ADS, with only a few exceptions.
Essentially, the Affirma Analog Circuit Design Environment user interface is replaced with Advanced Design System
and all of its functionality. The Affirma features that are not directly replaced by ADS are provided on the DynamicLink
pull-down menu in the Cadence Virtuoso Schematic window.

 Note

If the DynamicLink pull-down menu does not appear in the Cadence Virtuoso Schematic window, choose Tools
> ADS Dynamic Link in the Cadence schematic window.

Usage assumes basic familiarity with the Cadence IC Design Framework II (DFII) , including Virtuoso schematic
capture and Affirma Analog Circuit Design Environment , as well as basic familiarity with design and simulation in the
Advanced Design System.

Additional Information

e Wherever a shell variable is set, this manual uses the K-shell syntax.

¢ Unless otherwise mentioned, assume case sensitivity.

e Terminology used for Agilent Technologies and Cadence EDA Tools is frequently different. For example, a project
in ADS is similar to a library in Cadence and design in ADS is similar to a cellview in Cadence.

What's in this Manual

The goal of this manual is to help you get started, providing relevant examples that teach you how to use the
software, and show you where you can get more information as you need it. This manual contains:

e Configuring RFIC Dynamic Link describes the system requirements and how to install and configure the software.

e Getting Started Tutorial steps you through the process of simulating a circuit using components from the
Dynamic Link analogLib library. Other examples are also included to help you become more familiar with the
product.

¢ Using RFIC Dynamic Link provides information on launching ADS from a Cadence Schematic window, performing
some basic operations and closing the Dynamic Link between ADS and Cadence.
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e Netlisting, Simulating, and Displaying Data describes the procedures for netlisting and simulating a design as
well as viewing the netlist from either ADS or a Cadence schematic window. Information on net, instance and
expression name mapping is also provided.

e Running a DSP and Analog/RF Cosimulation with RFIC Dynamic Link provides and example of how to run an ADS
Ptolemy Cosimulation using RFIC Dynamic Link.

e Tuning and Optimizing Designs provides information on tuning and optimizing designs using the ADS tuning and
optimization capabilities.

e Using Additional Features of RFIC Dynamic Link includes a collection of Dynamic Link features such as "Freezing"
selective subcircuits. Compatibility features covering support for Duplicate Pin Names, Bus-ports, Buses and
Bundles, Unnamed Nets and pPar and iPar are also discussed.

e Using Switch Views, Stop Views and the Hierarchy Editor provides information on using switch views, stop views
and the Hierarchy Editor in Dynamic Link.

e Troubleshooting provides information that can help you resolve common problems with RFIC Dynamic Link.

e Command Reference describes the function of each of the menu selections available for using RFIC Dynamic
Link.

Configuring RFIC Dynamic Link

This chapter describes system requirements and how to install and configure the software. You may require help from
a UNIX or EDA Administrator to complete these tasks. For general system requirements, refer to Check the System
Requirements in the UNIX and Linux Installation documentation.

System Requirements

This section provides a reference to the minimum hardware and operating system requirements and also describes the
EDA Framework and License requirements necessary for using the RFIC Dynamic Link.

Hardware Requirements

For information on the minimum hardware requirements for installing and using RFIC Dynamic Link, refer to Check the
System Requirements in the UNIX and Linux Installation documentation.
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Software Requirements

The specific RFIC Dynamic Link version requires that you use a compatible Advanced Design System version. For
example, if you are using RFIC Dynamic Link 2006A, you must also use ADS 2006A.

Dynamic Link supports Cadence DFII versions on UNIX & Linux operating system versions from vendors which run this

Cadence software. For a summary of supported platforms, refer to Check the System Requirements in the UNIX and
Linux Installation documentation, or contact Cadence Design Systems Inc.

Note that the following Cadence context files must be present under your Cadence installation directory in order to run
RFIC Dynamic Link:

<Cadence Installation Dir>/tools/dfll/etc/context/spectrei.cxt

<Cadence Installation Dir>/tools/dfll/etc/context/asimenv.cxt

If either of these files is missing, please contact Cadence Design Systems Inc. for information on how to install it.

License Requirements

In addition to your standard Advanced Design System licenses, the following additional product licenses are required.

RFIC Dynamic Link License

e trans_idf

Cadence Licenses

e OASIS_Simulation_Interface
e 34510 - Affirma(TM) analog design environment
e 300 - Virtuoso(R) layout editor (if using layout)

 Note

You must purchase all required Cadence licenses from Cadence Design Systems.
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Installing RFIC Dynamic Link

The RFIC Dynamic Link installation procedure continues to be improved to make it easier for you to install and
configure.

To install RFIC Dynamic Link:

1. Follow instructions in the UNIX and Linux Installation documentation to run the SETUP utility and load the install
program.

2. After the Agilent EEsof Installation Manager starts, you are prompted to select one of the following installation
options:
e Typical - If you choose a Typical installation, the RFIC Dynamic Link will not be installed.
e Complete - If you choose a Complete installation, the RFIC Dynamic Link will be automatically installed.
e Custom - If you choose a Custom installation, you must select both Simulators and Design Entry and The

RFIC Dynamic Link components from the scroll-down list in the Agilent EEsof Software Installation dialog
box.

) Note

The Simulators and Design Entry component is the basic ADS software, including the Design Environment,

Data Display, and Analog/RF Systems and Signal Processing simulators. This is a minimum requirement for
RFIC Dynamic Link.
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E Agilent EEsof Software installation

Watonme Platforms | Selp | Components | Opliens | Sunwnwry | Bsial

3elect the Components from the list below which you would like to have installed on this
system. Make sure you have enough disk space to install all the components you select.
Use the Scroll bar to select additional components from the list.

After you have selected the desired components, click the Hext button.

Click the 'Description” button for a more detailed description of each component.

Previously installed components are marked by a small blue icon to the left of the corresponding
component checkhox. This does not, however, prevent reinstallation of the component.

i
! Library Translator : 3656 KBytes Description i

-1 FLEXIm licensing software : 4872 KBytes Description

N The RFIC Dynamic Link : 88396 KBytes Description

-! CDMA Design Library : 3976 KBytes Description
| TD-3CDMA Design Library : 8526 KBytes Description

! GSM Design Library : 4280 KBytes Description

4

- Component Description

This component includes the RFIC Dynamic Link.

- Disk Usage -

Destination Directory: fifsidl lecaliusersicrscoit/ADS2005A
Disk Space Required: 1477146 KBytes
Disk Space Available: 2036411 KBytes
- <« Back Mext = Cancel Help

3. After the installation is complete, you will need to run the idfConfigCadence script to configure Cadence for use
with RFIC Dynamic Link. This script is located under:
$HPEESOF_DIR/bin/idfConfigCadence

© Note

For ADS 2001, the Cadence configuration script was located at $HPEESOF_DIR/idf/config/configCadence.
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For more information on the idfConfigCadence script, refer to Customizing a Cadence Installation.

For more information on installation procedures, refer to the["../install/wwhelp.htm" UNIX and Linux Installation]
documentation.

Configuring the Cadence Installation

After the installation procedure (see Installing RFIC Dynamic Link), you will need to run the idfConfigCadence script if
you want to customize your Cadence installation for Dynamic Link. This script configures the Cadence install directory
for use with ADS by adding or modifying five files.

If you prefer not to modify your existing Cadence installation(s), refer to the section on Avoiding Maodifications to Your
Cadence Installation.

 Note

You must have write access to your Cadence install directory in order to run the idfConfigCadence script.

The following files are created:

<Cadence Installation Dir>/tools/dfIl/etc/tools/ads/.cdsenv

<Cadence Installation Dir>/tools/dflIl/etc/tools/ADSsim/.cdsenv

<Cadence Installation Dir>/tools/dflI/etc/tools/adsDL/.cdsenv

<Cadence Installation Dir>/share/cdssetup/hierEditor/templates/ads

<Cadence Installation Dir>/tools/dfIl/etc/skill/hnl/ads.ile
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<Cadence Installation Dir>/tools/dfII/etc/skill/si/caplib/ads.ile

An additional file, <Cadence Installation Dir> /tools/dfII/etc/tools/auCore/.cdsenv, is edited to add ads to the Tool
Filter list of simulators.

 Note

The files described in this section are created or modified based on detailed instructions provided in the
Cadence OASIS Direct Integrator's Guide . The information in the Cadence manual __ describes how to
integrate a simulator into the Cadence Analog Design Environment using the Cadence direct toolkit .

Important While deviating from the information described in the Cadence OASIS Direct Integrator's Guide may
work for RIFC Dynamic Link, the files have been specifically set up to follow the Cadence documentation.
Agilent Technologies does not support deviations from this information.

For more information, refer to the Cadence documentation:

- OASIS Integrator's Guide , Product Version 4.4.5, December, 1999 - Pages 4-12, 4-13, 6-2 and 6-6.

- OASIS Direct Integrator's Guide , Product Version 4.4.6, September, 2001- Pages 67, 101 and 105.

Customizing a Cadence Installation

Before running the idfConfigCadence script, set HPEESOF_DIR to your ADS installation directory and set your PATH to
include Cadence software.

The idfConfigCadence command uses the following general syntax:
i df Confi gCadence {-h | -Is | -rm}

Simply entering idfConfigCadence at the command line with no options runs the script to configure Cadence for RFIC
Dynamic Link. The following table shows a list of the options and definitions used by the idfConfigCadence command.

Option Definitions for idfConfigCadence

Option Definition

-h This option can be used to display the idfConfigCadence
help file.

-Is This option can be used to list the Cadence configuration

files for ADS/RFIC Dynamic Link and indicate whether
Cadence is ready for ADS RFIC Dynamic Link or not.

-rm This option removes the Cadence configuration for
ads/RFIC Dynamic Link by deleting the files previously
installed with the idfConfigCadence script and removing

12
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ads from the Cadence tool Filter. For more information
on the Cadence Tool Filter, refer to your Cadence
documentation.

Understanding the idfConfigCadence Script

When the idfConfigCadence script is executed without any options, the script performs the following operations:

e Copies
$HPEESOF_DI R/i df / confi g/ adsCdsenvFi |l e
to
<Cadence Installation Dir>/tools/dfll/etc/tools/ads/.cdsenv
e Copies
$HPEESOF_DI R/ i df / confi g/ ads. hi er Ed
to
<Cadence Installation Dir>/share/cdssetup/hierEditor/tenpl ates/ads
e Creates two new empty files called ads.ile in the following locations:
<Cadence Installation Dir>/tools/dfll/etc/skill/hnl/ads.ile
<Cadence Installation Dir>/tools/dfll/etc/skill/si/caplib/ads.ile

Customizing Multiple Cadence Installations

The idfConfigCadence script configures the Cadence installation directory for use with Dynamic Link. However, if a new
version of the Cadence software is subsequently installed or you have multiple Cadence installations, neither will have
the Dynamic Link configuration. In this case, you would need to run the idfConfigCadence script as described in
Configuring the Cadence Installation for each Cadence installation.

Avoiding Modifications to Your Cadence Installation

If you do not want to change your Cadence installation or create a Cadence shadow directory tree for RF Design
Environment (RFDE) or RFIC Dynamic Link, there is an alternative approach available. You will need to set the
following three environment variables before starting Cadence Design Framework II:

CDS_LOAD_ENV=CSF

13
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o0ssSi muser Hnl Di r =$HPEESOF_DI R/ i df / ads_si t e/ hnl

0ssSi nUser Si Di r =$HPEESOF_DI R/ i df / ads_si t e/ si

In addition to the above, you will need to add the following path to your setup.loc file:

$HPEESOF_DI R/ i df / ads_site

Sourcing the setCSF.ksh (or setCSF.csh) sample script under $HPEESOF_DI R/ bi n is one method of accomplishing the
tasks above. Assuming you are using the Korn shell, the following is a list of steps for using the sample scripts to
setup the environment for RFDE or Dynamic Link in order to work with your original Cadence installation:

1. Change to a directory where you have write permission. For example,

cd /tnp

2. Set your HPEESOF_DIR to your RFDE or ADS installation root directory.
3. Add $HPEESOF_DIR/bin to your path. For example,

PATH=$HPEESOF_DI F/ bi n: $PATH

4. Ensure your Cadence and Agilent licenses are set correctly for your environment.

5. Ensure that the Cadence <cadence_installation_root> /t ool s/ bi n and <cadence_.installation_root>
/tool s/ df I I/bin directories are in your PATH.

6. Set the CDS_LOAD_ENV, ossSimUserHnIDir, ossSimUserSiDir, and setup.loc files appropriately. For example, if
using the Korn Shell,

. $HPEESOF_DI R/ bi n/ set CSF. ksh

If you are using the C Shell, use the following command,

sour ce $HPEESOF DI R/ bi n/ set CSF. ksh

7. Ensure that you have included RFDE Libraries. For example,
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echo | NCLUDE \ $HPEESOF DI R/ cdslibs/rfde.lib > cds.lib

8. Ensure that the RFDE and Dynamic Link startup file ads.ini will be loaded upon starting Cadence Design
Framework II. For example,

cp $HPEESOF_DI R/ i df / exanpl es/ . cdsinit .

9. Launch Cadence by entering i cns& or nsf b&.
If Cadence fails to locate the RFDE or Dynamic Link OASIS files under your Cadence installation, the software will
look for these OASIS files under $HPEESOF_DI R/ i df / ads_si te.
The alternate search location will be used because of the way CDS_LOAD_ENV, ossSimUserHnIDir,
ossSimUserSiDir, and setup.loc are set in step 6 above. RFDE and Dynamic Link will still operate normally with
your original Cadence installation. This may be the prefered approach when you have multiple Cadence
installations, in which case you would need to add RFDE OASIS files to every individual installation or create a
shadow directory for each installation.
According to the Cadence Application Infrastructure User Guide, Product Version 5.01 , Cadence looks for the
Cadence setup search file, $CDS_SI TE/ cdsset up/ set up. | oc, if $CDS_SITE is defined in the environment;
otherwise, it will look for <your_installation_directory> / shar e/ cdsset up/ set up. | oc.
For more information about CDS_LOAD_ENV, CSF, setup.loc, or OASIS, refer to your Cadence documentation or
contact your Cadence customer support representative.

Configuring the Software

This section describes the various aspects of configuring and/or modifying the software to provide additional flexibility.

Configuring the UNIX Environment

There are several UNIX environment variables relevant to Dynamic Link. These are described in the following table.

UNIX Environment Variables

Environment Variable Description

IDF_CONFIG_FILE The name of the configuration file (only the file name,
not the entire path). Default value is idf.cfg.

IDF_ADS_PROJ_DIR If this environment variable is defined, ADS will attach to
the specified project when RFIC Dynamic Link launches
ADS.
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IDF_DEBUG_MODE If set to TRUE debugging will be turned on and additional
log messages will be written to the CIW; the log files
mps.log and emx.log are also created. Default value is
FALSE.

IDF_LOG_FILE Name of the file (only the file name, not the entire path)
to which ADS messages, normally written to stderr are
redirected. Default value is idf.log .

PATH The UNIX path variable.

Configuring the ADS Install Directory

The installation procedure configures the ADS install directory by automatically adding, modifying or replacing some
files and/or directories.
The following files and/or directories are created, modified or replaced:

$HPEESOF_DI R/ bi n/i df np

$HPEESOF_DI R/ bi n/ i df

$HPEESOF_DI R/ bi n/ i df Confi gCadence
$HPEESOF_DI R/ i df

$HPEESOF_DI R/ i df / ael

$HPEESOF_DI R/ cdsl i bs

$HPEESOF_DI R/ i df /config

$HPEESOF DI R/ i df / exanpl es

$HPEESOF_DI R/ i df / ski | |

$HPEESOF_DI R/ ci rcui t/ synbol s/ i df Synbol . dsn
$HPEESOF DI R/t ool s/ 1i b/ dpkg/ i nfol/idf\*

Modifying the RFIC Dynamic Link-Cadence Initialization File

The RFIC Dynamic Link-Cadence initialization file ( .cdsinit) is located in the directory
$HPEESOF_DIR/idf/config/.cdsinit . Append it to or load it from the first available .cdsinit file from the list below:

e <Cadence Installation Dir> /tools/dfIl/local/.cdsinit
e ./.cdsinit
¢ $HOME/.cdsinit

Modifying the Configuration File

Dynamic Link comes with the default configuration file $HPEESOF_DIR/idf/config/idf.cfg . This file is used to set

various site-specific or user-specific options. It is searched for and read sequentially from the following locations in the
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order given, so that settings in files read later override those of earlier files:

$HPEESCOF_DI R/ i df / confi g/

$HOME/ hpeesof / confi g/

The name of the configuration file can be set via the UNIX environment variable IDF_CONFIG_FILE. By default the
configuration file is named idf.cfg .

The configuration file consists of lines in the form < parameter > = < value >. The various parameters that can be set
in the configuration file are listed below, with brief descriptions and an example for each. If no configuration file is
found or some parameters are not set, internal default values are used. Note that wherever a file name is required for
a configuration parameter value, it may be specified with a path prefix that is a UNIX environment variable value or
using standard UNIX conventions such as ~. A complete example configuration file can be found at the end of this
section.

e Switch View List: If an instance has none of the views listed in the switch view list, the netlister reports an error.
The default is ads sch.model schematic . Example:

IDF_SWITCH_VIEW_LIST = "ads sch.model schematic"

e Stop View List: The netlister identifies primitives with a stop list. When it reaches a view that is listed in both the
switch view and stop view lists, the instance is netlisted and no expansion occurs below this level. There is
normally no reason to change the Stop View list to anything other than ads . Example:

IDF_STOP_VIEW_LIST = "ads"
e Project Path: This indicates the path to the ADS project to attach to upon starting ADS via RFIC Dynamic Link.

© Note
Unless Cadence and ADS are installed on the same workstation where you run RFIC Dynamic Link, using this
parameter is not recommended.

Example:
IDF_ADS_PROJ_DIR = /tmp/ads_prj

¢ Netlist Filter: When you have site customization that is not performed by the supplied netlister, this option
enables you to specify the name of the program or script used to post-process the netlist generated by the
Dynamic Link netlister. Example:
IDF_NETLIST_FILTER = "$HPEESOF_DIR/bin/myfilter"
If you want to change all "vss!" in the netlist to 0 (zero or the ground in ADS), the script ( myfilter ) would look
similar to the one below:
sed -e s/\"vss!\"/0/g

¢ Netlist Suffix: This is the suffix for the Advanced Design System netlist file generated by the Dynamic Link
netlister for each sub-circuit. The default is .net. Example:
IDF_NETLIST_SUFFIX = ".net"
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e Debug Mode: This option enables you to turn debugging messages on or off. These messages appear in order to
help you determine the cause and/or location of problems.
By default, debugging is turned off. To enable debugging, set this option to TRUE . Example:
IDF_DEBUG_MODE = TRUE

e Symbol Generation: This option enables you to specify whether to generate a missing symbol using the Cadence
symbol generator or the Advanced Design System symbol generator. The Cadence symbol generator is used as
the default. Example:
IDF_CADENCE_SYMBOL = FALSE

e User AEL Files: Users can define their own AEL functions and load them into the ADS environment via a list of
comma separated file names. These files get loaded just after the Dynamic Link environment is initialized.
Example:
IDF_USER_AEL_FILES = "filel.ael, $HOME/file2.atf"

e Expression Mapping: This causes sub-strings in Cadence expressions to be mapped to corresponding sub-strings
in ADS expressions in the netlist file and/or in the design variable values used. Example:
IDF_EXPR_MAP = "foo bar"

e Freezing Subcircuit Netlists: When this variable is set to yes (or TRUE), all Cadence subcircuits for which a netlist
already exists are not re-netlisted. The default is FALSE . Example:
IDF_FREEZE_NETLISTS = TRUE

© Note

The Freeze parameter can be set to yes (TRUE) or no ( FALSE).

To freeze selected subcircuits, see Freezing Selected Subcircuits.

e Message Timeout: This specifies the timeout period in seconds for message actions initiated in ADS to complete
in DFIL. The default is 45; however, you will need to set it to a value larger than the default for netlisting large
Cadence circuits. Example:

IDF_MSG_TIMEOUT = 200

e Other Parameters: The following parameters should not be altered.
IDF_AEL_FILES = "globals.atf, utils.atf, commands.atf, callbacks.atf, symbol.atf"
IDF_PDE_EXEC = hpeesofde
IDF_PDE_ARGS = "-env de_sim"

IDF_SCALE_FACTOR = 2.0

Example Configuration File

| DF_SW TCH VI EW LI ST = "ads sch. nodel schematic"

| DF_NETLI ST_FI LTER

"~/ bin/nmynetlistfilter"

| DF_NETLI ST_SUFFI X = ". net"
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Managing Projects and Designs

Your Cadence designs will remain in their original locations. They are not copied, translated, or otherwise modified.
When ADS starts up in Dynamic Link mode, it puts you in a project directory defined by the IDF_ADS_PROJ_DIR
environment variable. If this variable is not defined, only the ADS Main window will open and no project will be
attached. This is the recommended option.

To change this behavior, you can do one of the following:

e Specify your own startup project directory by defining IDF_ADS_PROJ_DIR in your UNIX environment or via the
configuration file idf.cfg.

o After the Advanced Design System has come up, go to the Main window and open a new or existing project (File
> New Project or File > Open Project).

For more information on projects and design files, refer to Managing Projects and Designs in the Schematic Capture
and Layout documentation.

Getting Started with RFIC Dynamic Link

This tutorial steps you through the process of simulating a circuit using components from the Agilent version of the
analogLib library. Other examples are also included to help you become familiar with the product.

Both the drop-down menus and icons are described to help familiarize you with the Advanced Design System
environment.

Setting up the Examples Directory

To set up the examples directory, first ensure that:

e The HPEESOF_DIR environment variable is set to your ADS installation directory
e $HPEESOF_DIR/bin is in your PATH
e Your environment is set up to run the Cadence icms or msfb tool

From any directory of your choice, enter:

cp -r $HPEESOF_DIR/idf/examples ./
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cd examples

 Note

This must be done before attempting the Getting Started Tutorial. The cds.lib file under the examples directory
defines libraries provided by Dynamic Link.

The .cdsinit file under this directory loads the Dynamic Link .cdsinit file which then loads the context files
required to run Dynamic Link.

Starting the Cadence Design Framework

Ensure that you are in the examples directory then launch Cadence Design Framework II by typing the appropriate
command (typically icms or msfb ). The Cadence Command Interpreter Window (CIW) appears.

= icms - Log: fgfsisream3/d] localiusersicrscott/CDS.log =]
File Tools Options Technology File Help | 1
COPYRIGHT & 1992-2000 CADENCE DESIGN SYSTEMS ING. ALL RIGHTS RESERVED.

@ 1092-2000 UNIX SYSTEMS Laboratories IMG.,

Reproduced with permission.

This Cadence Design Systems program znd online documentation are
proprietary/confidential information and may be disclesedsused only
as suthorized in a license agreement controlling such use and disclosure.

REESTRICTED RIGHTS NOTICE (SHORT FORM)
Use/reproduction/disclosure 1s subject to restriction
set forth at FAR 1252 227-19 or its equivalent.
Brogram: R{F)EC05: icms. exe wersion 4.4 6 0873052000 11:37 (cds11701) &

Sub version: sub-version 4.4 6. 38 {32-bit addresses)
Loading ge¥Wiew. cxt

Loading aulore. cxt

Loading sch¥iew. cxt

Loading selectSv. cxt

Loading oasis. cxt

Loading analog. cxt

mouse Lo M: R:

Cadence CIW Window

) Note

Non-standard or customized start-up scripts for Cadence Designh Framework II may not be supported. If you
have difficulties, contact your system administrator.
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Opening a Cadence Composer Schematic

To open a schematic cellview in Cadence Composer:

1. Choose File > Open from the Cadence CIW. The Cadence Open File form appears.

=| Open File |
Ok Cancel | Defaults Help
Library Hame examples Cell Hames
LG filter
Powerim —
Cell Name F o LA
. =
View MName schematic bit_sub
buf
Browrse examples
1nw
Mode @edit  read Ina
mixer
Library path file mutual
— |mwline
flocal Masers/focracottfexamples fods. Lik

Select examples from the Library Name drop-down list.

Click PowerAmp in the Cell Names list. This sets the Cell Name field to PowerAmp.
Select schematic from the View Name drop-down list if not already selected.
Select the edit Mode if not already selected.

uhwnN

(-

Note
To open a file in edit mode you must have write permission.

6. Click OK . The Cadence examples, PowerAmp schematic cellview appears.
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Cadence Virtuoso Schematic Composer Window

Linking with Advanced Design System

To link the Cadence design environment to Advanced Design System:
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1. Choose Tools > ADS Dynamic Link from the menu bar in the Cadence Schematic window. In a few moments, the
Advanced Design System Main window appears in the upper-left hand corner of your display.

—| Advanced Design System (Main) - |1
File View Tools Window DesignKit DesignGuide Help
S HRECR e A

File Browser Project Hierarchy

B Cexamples_pn hfttsersfcrscuttfexamplesfexamples _m

'| mifsfd1 Aocalusersicrscottiexamplesfexamples_prj

Advanced Design System Main Window

 Note

Depending on your system, it may take a few moments for the ADS windows to appear. View the Cadence CIW
window for the link status.

2. From the ADS Main window, choose File > Open Project and select the examples_prj project. The ADS Schematic
window displays a DynamicLink menu item and is automatically titled untitled1 (see the following figure).
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ADS Schematie Title

DynamicLink Menu Item

A

=] [ examples_prj ] untitied1 {Schematic):1 I

|

File Edit Select View Insert Options Tools Layout Simutate Window Dynamiclink DesignGuide

Help

e E & B =ed 95 sl elnnE#E s Held

[Lumped—Cnmpnnenls Ll | [ i | D«I —é—l m | \_

AR

=
i
R R
o
L L
Ak
G G
L T
OGFeed, DGBlck
=
SHORT | MUTIND
il
Lok | £
PRL | PRLG | 2
'| Select: Enter the starting point 0 items wire -3.200, 3.750 -3.a00, Z2.675

Gyl

Advanced Design System Schematic Window

At this point, ADS and the Cadence Design Framework II are working together.

Opening a Test Schematic Design

To open a test schematic design:

1. Choose File > Open Design in the ADS Schematic window to display the Open Design dialog box. Use this dialog

box to select the design you wish to simulate.
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= Open Design:1

Project

examples_prj | Include/Remove...

Filter

scal/users/crscott/examples//examples prij/networks/+ dsi Brovwsse...

Open Design in:
& Current Window _) New Schematic Window _) New Layout Window
Designs

bjt_sub_test.dsn
examples_bjt_sub_schematic.dsn

BHH.ITIEES PIJWEI'PIHE schematic.dsn

* Design has been modified but not saved

OK Filter Cancel Help A

2. The examples_prj selection in the Project drop-down list is set by default in the Open Design dialog box.
3. Select PowerAmp_test.dsn from the Designs list. The PowerAmp_test.dsn schematic contains simulation

components that can be selectively activated or deactivated.
4. Click OK to include the PowerAmp_test.dsn schematic in the ADS Schematic window.

Adding a Symbol of the Cadence Cellview

To add a symbol of the Cadence cellview in the Advanced Design System Schematic window:

1. Choose DynamicLink > Instance > Add Instance of Cellview in the ADS Schematic window.
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| [ examples_prj | PowerAmp_test {Schematic):l g J|
dle  Edit Select View Insert Options Tools Layout Simulate Window Dynamiclink DesignGuide Help
J= B & ] D*Du g Q e i @ % Instance
: : : : : Design VYarahles
imped- Components o= Add Netiist File Include
Top-level Design Hetlist
B I — ) ;| Annotate
i i = = | set Cadence Project Directory ...
| ] - - joct Sectony
L L = <+ |CQose Connection
It = 1 —
L& | i BEZT et
Bt B
iFeed| DCBlck -
; ; + wn-aun- _ﬂ
=
HORT | MUTIND ,
] : == l@ s.P.u.R.n.uErEgs-' [ |
m&_] A T ! :
E% L8 E'I’:L.;,ur 'z“'t-:.‘ﬁ;:* e 1
" " Y | T ! |
GoF| 4 '
I
PRL | PRLG N . |
e EEEEL N
|| A L e e e Y,
SLC | SRG |
FIERSS s
elect: Enter the starting point 0 items wire -f7.625, -1.375 -8.375, 2.625 in |

Adding a Cellview

A Select Design dialog box appears, enabling you to select the Cadence Cellview to simulate.

Help

=| Select Design
oK Cancel | Defaults
Library Hame examples
Coll MHam Botwrer Amp
View Hame schematic
1 Browse

2. In the Cell Name field of this dialog, verify the entry or type the name of the Cellview you want to simulate (in
this case PowerAmp ). Alternatively, you can use the Browse button and library manager to select the name.
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w

Click OK . A symbol of your Cadence Cellview is automatically generated.

4. An instance of the symbol is attached to the cursor for you to place. In the Advanced Design System Schematic
window, click the left mouse button to place the symbol as desired.

. You may continue placing more instances of the same cellview, or, in this case, choose the Cancel Command And
Return To Select Mode icon to proceed with the next step. Similarly, you may place instances of other Cadence

designs. E |

Adding Design Variables

To add the design variables from the Cadence Cellview to the ADS schematic window choose DynamicLink > Design
Variables > Get Design Variables .

This places a corresponding VAR component on the ADS schematic containing the design variables from Cadence (i.e.
Rcc, Rout, Remitin and Remitout).

‘,‘g’g; VAR
VAR1
Cseries=7.0pF
Lshunt=7.5nH
Rout=12
Rcc=10
Remitin=200
Remitout=163

Adding Model Files

To add a model file

1. Choose DynamicLink > Add Netlist File Include
2. Place the NetlistInclude component in an open area on the schematic.
3. Double click the include component icon. The Netlist File Include dialog box appears.
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_.| Metlist File Include

Hetlistinclude

Instance Hame

HetlistIncludsl
Select Parameter -
Model Library File
Include Path=
IncludeFiles[1]= 1
UsePreprocessor=yes Browse
Section (optional)
_I Display parameter on schematic
Add {agd Pasie Component Options...

IncludeFiles : List of files to include

T OK Apply Cancel Reset Help I

. In the Netlist File Include dialog box, click IncludeFiles in the Select Parameter list box. The Model Library File

field appears in the dialog box.
. Click Browse just below the Model Library File field to locate the first model library file. The Select File dialog box

appears.
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—| Select File:1 |

Filter

:/crscott/examples/models/*

Directories Files

nl.ads

zamples/imodels/..
npnpwaz.ads
npnsub.ats
parms.inc
pifell .ads
pmesfetl .ads
pmos.ads

Selection

xamples/models/npnpwal.add

OK Filter Cancel Help

In the Select File dialog box, use the Directories field to locate the models directory.
<your_current_working_dir> /examples/models

This sets the path for the location of the model library files.

In the Select File dialog box, use the Files field to locate and click the npnpwal.ads model file, then click OK . An
information message appears stating that a new path has been added to the include path list.

= Information Message:1 |

i The path rs/dl localfusersicrscotifexamplesimodels has been added to the include path list.

OK

Click OK in the Information Message dialog box. You are returned to the Netlist File Include dialog box.

In the Netlist File Include dialog box, notice that the Model Library File field now contains the npnpwal.ads model
file. Click Apply to add the npnpwal.ads model file.

Click Browse again to locate the second model library file. The Select File dialog box appears.

. In the Select File dialog box, use the Files field to locate and click the npnpwa2.ads model file, then click OK .

You are returned to the Netlist File Include dialog box.

In the Netlist File Include dialog box, notice that the Model Library File field now contains the npnpwa2.ads model
file. Click Add to add the npnpwa2.ads model file.

The Select Parameter field should now contain the information below.

IncludeFiles[1]=npnpwal.ads
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IncludeFiles[2]=npnpwa2.ads.
13. Click OK in the Netlist File Include dialog box.
For more information on the Netlist File Include Component, refer to Adding Model Files.

Performing a DC Simulation

To run a DC simulation on an ADS schematic and then annotate the results to the Cadence Composer Window:

1. Choose Edit > Component > Deactivate/Activate then click the DC component in the ADS Schematic window to
toggle and activate the component. Alternatively, you can choose the Deactivate/Activate Components icon to
activate the DC component.
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Activating Components in an ADS Schematic Window

2. Choose Simulate > Simulate or choose the Simulate icon to run a simulation. A simulation dialog box appears in

your display. {g}l
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=| hpeesofsim -31595:0

File Simulation/3ynthesis Text Window

Simulation ¢ Syntheszis Messzages

| e e e e |

Status f Summary

Convergence achieved in ¥ iterations,

Simulation finished: datazet ‘Powerfmp_test” written in:
“rhfsddld lozal fusers/cracott/exanpl esdexanples_prjfdata”,

Resource uszage:
Total stopwatch time: 2,18 seconds,

. After the simulation is complete, a Data Display window titled PowerAmp_test automatically appears. Close this
window using the File > Close Window menu option.

. Click the PowerAmp schematic symbol in the ADS Schematic window.

. Choose DynamicLink > Annotate > Annotate DC Solution to Selected Cellview . This displays the DC node
voltages on the Cadence schematic.
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Cadence Schematic with Annotated Display

Annotating DC Operating Points to a Selected Cellview

Any simulation that includes a DC analysis produces DC operating point information for most active and some passive
devices in the circuit. This data includes currents, power, voltages, and linearized device parameters of the selected

device.

To run a DC Operating Point Simulation on an ADS schematic and then annotate the results to the Cadence Composer
Window:

1. Double-click the DC Simulation component in the ADS schematic window. The DC Operating Point Simulation
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dialog box appears.

—| DC Operating Point Simulation:1
DC Instance Name
o1
Sweep | Parameters  Output | Display
Convergence
Max. Delta ¥ 0.0V Volts

Max. terations 250

Mode Auto sequence

Levels
Status level 2
Device operating point level

1 None ) Brief ‘@ Detailed

Output solutions

_| Output solutions at all steps

QK Apply Cancel Help

. Click the Parameters tab in the DC Operating Point Simulation dialog box.
. Click Detailed in the Device operating point level section of the DC Operating Point

Note
For a subset of the detailed DC Operating Point Simulation information that covers most common parameters,
click Brief in the Device operating point level section of the DC Operating Point Simulation dialog box.

. Choose Simulate > Simulate or choose the Simulate icon to run a simulation. A simulation dialog box appears in
your display. @|

. After the simulation is complete, a Data Display window titled PowerAmp_test automatically appears. Close this
window using the File > Close Window menu option.

. Click the PowerAmp schematic symbol in the ADS Schematic window.

. Choose DynamicLink > Annotate > Annotate Operating Points to Selected Cellview . This displays the DC
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operating point values for each component on the Cadence schematic.
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Annotated Cellview with DC Operating Points

Saving Node Voltages and Pin Currents with RFIC Dynamic Link

With the RFIC Dynamic Link Probing feature, you can select nodes or pins of interest in a Cadence subcircuit and
display their voltages or currents in an ADS Data Display window.

The following is an example session using the Dynamic Link Probing feature with the PowerAmp example.

1. Double click the DC Simulation controller component in the ADS schematic window to open the DC Operating
Point Simulation dialog box.
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DC Operating Point Simulation: 1

2. Click the Output tab in the DC Operating Point Simulation dialog box.
3. Click Add/Remove in the Output section of the DC Operating Point Simulation dialog box to open the Edit
OutputPlandialog box.
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Edit OutputPlan: 1

. Click the + sign to the left of the X1 component in the Available Outputsfield to start Dynamic Link Node Probing
setup. This raises the Cadence schematic window containing the PowerAmp cellview. The prompt in the Cadence
schematic window is changed to: ADS Probing Setup: Click a wire or a pin>.

. Click the right pin of the RO resistor on the upper-left region of the schematic window.
"X1.R0O.MINUS.pinCurrent.i" appears in the Current Selection field on the right side of the ADS Edit OutputPlan
dialog box.

. Click the collector pin at the top of the Q1 BJT. "X1.Q1.C.pinCurrent.i" appears in the Current Selection field on
the right side of the ADS Edit OutputPlan dialog box.

. Click the vertical net connected from above Q1 to the collector pin of the Q1 BJT. "X1.net44" appears in the
Current Selection field on the right side of the ADS Edit OutputPlan dialog box.

. Click the vertical net connected from below Q1 to the emitter pin of the Q1 BJT. "X1.net12" appears in the
Current Selection field on the right side of the ADS Edit OutputPlan dialog box.
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. Click OK in the ADS Edit OutputPlan dialog box to close the dialog box. The DC Operating Point Simulation dialog
box should now appear similar to the following figure.
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DC Operating Point Simulation: 1

Click OK in the DC Operating Point Simulation dialog box to instruct ADS to save currents for X1.R0.MINUS and
X1.Q1.C in addition to voltage values for X1.netl12 and X2.net44 after DC simulation.

Click the Simulate icon or select Simulate > Simulate menu item in the ADS schematic window to run a DC
Simulation. The ADS Data Display window appears automatically once the ADS DC Simulation is complete. I_m__

Click the List icon on the left of the Data Display window, then click a desired location in the ADS Data Display

window to bring up the Plot Traces & Attributes dialog box.
BET &
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Plot Traces & Attributes: 1

13. In the Plot Traces & Attributes dialog box, press the Ctrl key and click the following four items on the left, then
click >>Add>> in the middle to add these four items to the Traces field on the right.

C.pinCurrent.i
MINUS.pinCurrent.i
netl2

net44

14. Click OK to close the Plot Traces & Attributes dialog box. The currents of R0O.MINUS and Q1.C pins and voltages
of netl2 and net44 are immediately listed in the ADS Data Display window.

Additional Notes:

e When the Add/Remove button in the DC Operating Point Simulation dialog box is clicked to bring up the Edit
OutputPlan dialog box, as described in step 6 above, all of the named nodes and subcircuit components at
current circuit level appear in the Available Outputs field on the left. You can select a named node from the
Available Outputs field and then click Add>> to add it to the Current Selection field on the right. You can also
remove a named node from the Current Selection field by clicking <<Remove after selecting it.
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e Clicking the + sign to the left of a subcircuit component in the Available Outputs field displays all the named
nodes and subcircuit components within that subcircuit. In step 7 above, nothing was displayed initially because
there was no named node or subcircuit in the PowerAmp cellview.

e After a Cadence schematic window is raised as a result of clicking the + sign mentioned above, any named or
unnamed node in the Cadence subcircuit hierarchy can be selected by clicking the left mouse button at any point
on the wire. To select a node in Cadence subcircuit, choose Design > Hierarchy > Descend Edit menu item in the
Cadence schematic window, click OK in the form popped up, and then click a wire of interest. Valid selections are
limited to the current window and the current circuit hierarchy.

e During the Node Probing operation, the left mouse button in the Cadence Virtuoso schematic window is mapped
to a Dynamic Link SKILL procedure. Do not bind any function to the left mouse button during this period. Any
bindkey function previously mapped to the left mouse button will not work until the tune mode ends.

Performing an S-parameter Simulation

To perform an S-parameter Simulation on an ADS schematic:

1. Deactivate the DC component using the Deactivate/Activate toggle. m

2. Activate the S-parameter component using the Deactivate/Activate toggle.The ADS schematic is now ready to
simulate an S-parameter.
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Activating Components in an ADS Schematic Window

3. Choose Simulate > Simulate or choose the Simulate icon to run the S-parameter simulation. @|

After the simulation is complete, a Data Display window titled PowerAmp_test automatically appears.

© Note

The amplifier used in this tutorial is not a traditional microwave amplifier for use by itself. It is meant to be
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used as part of an RFIC, where it takes a small voltage signal and converts it into a current for driving a
larger-signal amplifier, off chip. It has not been designed to have S 11 and S 22 less than 1. More simulations
are run on the amplifier in the ADS example file, IQ_Mod_from_MDS_prj.zap, which you can download from
the Agilent EEsof EDA external Web site. The example described in this document is only illustrating the RFIC
Dynamic Link for Cadence.

Displaying Your Results

To view the results of your simulation in a plotted Data Display:

Select PowerAmp_test from the Default Dataset __ drop-down list if not already selected.

2. From the Data Display window, choose Insert > Plot , move the frame to an appropriate location within the
window and click. This anchors a frame for your plot. Similarly, you can choose the Rectangular Plot icon to drag
and drop the plot frame. @

[y

3. The Plot Traces & Attributes dialog box appears. Select S(2,1) and then click Add . Select dB from the dialog box
then click OK .
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=| Plot Traces & Attributes:4

Plot Type | Plot Options
E & 6 B B
====) 567 8

Datasets and Equations Traces

PowerAmp_test Traon dplinng...

freq [eB(sizayy |
PortZ
2>
PortZ(1) >»ild>
L) oAl VS0
3
5(1,1) <acldeslerbes < o
$(1,2)
8(2,1)
$(2,2)

Advanced...

_| Show Hierarchy

Manage Datasets...

oK Cancel Help

4. Click OK again to view the Data Display .

i)

Note

The following figure shows the forward gain, S(2,1), at 1.9 GHz to be approximately 12.57 dB. By varying the
value of Remitout in this case, you can modify the circuit to achieve the desired results. After you have
completed the tutorial, take some time to experiment with different values of Remitout .
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Data Display with S-parameter Simulation Results

Performing a Parameter Optimization

To optimize the parameters of Varl in the ADS schematic:

1. Choose the Deactivate/Activate Components icon then place the cross hair over the Nominal Optimization
component to toggle and activate the component. Repeat this step for the Goal component. The ADS schematic
is now ready to optimize the S-parameter. m
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Activating Components in an ADS Schematic Window

2. Choose Edit > Component > Edit Component Parameters and then click the VAR component. The Variables and
equations dialog box appears.

In the Variables and equations dialog box, select the parameter Remitout in the Select Parameter field.

Click the Tune/Opt/Stat/DOE Setup button. The Setup dialog box appears.

Click the Optimization tab and set the Optimization status to Enabled .

Set the Minimum Value to 120 and the Maximum Value to 200 .

ou kW
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—~| Setup:1 |
‘Optimization; Statistics | DOE

Optimization Status Enabled |

Type Continuous / |
Format min/maz f |
Nominal Value

[te3 None |

Minimum Yalue
120 None |
Maximum Value

20g ‘None ¢ |

| Post Production Tuning

OK Cancel Help

7. Click OK twice, once in the Setup dialog box and once in the Variables and equations dialog box. Note that the
Remitout parameter on the ADS schematic now displays:
Remitout= 163 opt{120 to 200}

8. Choose Simulate > Simulate or choose the Simulate icon. This netlists each Cadence subcircuit in the Affirma
Analog Circuit Design Environment , as well as the top-level ADS schematic, and starts the Advanced Design
System simulator. @|

 Note

A simulation status window appears, reporting the status of the simulation; depending on your system, this
may take some time. Check this status window to see if any errors occurred during netlisting or simulation.

After the simulation is complete, a Data Display window titled PowerAmp_test automatically appears. For
information on configuring the Data Display, refer to Displaying Your Results.

 Note
The following figure shows the optimized forward gain, S(2,1), at 1.9 GHz to be approximately 13.08dB as set
by the Goal component in the ADS Schematic window.
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Data Display with Optimized Simulation Results

9. Choose Simulate > Update Optimized Values to update the optimized values. This changes the value of Remitout
in the VAR component to the optimized value.
10. Choose DynamicLink > Design Variables > Update Design Variables to Cellviews to update the optimized value to
the Cadence cellview. A Confirmation Message dialog box appears.
=| Confirmation Message |
Design variables for <examples PowerAmp schematic= updated to cellview database
Select <Copy From:= on the Design Variables form to update the Artist session
Close
11. Click the Close button.
12. From the Cadence menu bar, choose DynamicLink > Design Variables . A Design Variables form appears.
) Note
If the DynamicLink pull-down menu does not appear in the Cadence Virtuoso Schematic window, choose Tools
> ADS Dynamic Link in the Cadence schematic window.
13. Click Copy From in the Cellview Variables section. This enables you to update the design variables to the Artist

session.
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—|  Design Variables -- Affirma Analog Circuit Design Environment (1) |
0K | l:an[:EI| Apply | Help
Selected Varable Fable of Design Yariables
Haums # Name Value
Value (Expr l 1 Rout 12
2  FRecco 10
3 ERemitin 200
.F'wll|| Delete| Change| Hext| Clear| chl| 4  Remitout 163
| Cellview Variable: Copy Frum; Copy Ta| A

Verifying Your Results

You may now verify the results of your optimization by using the optimized value of Remitout in an S-parameter
simulation . Set the value of Remitout = 120 (approximate optimum value) and repeat the steps in Performing an
S-parameter Simulation _ with the new value of Remitout.

i)

Note

The following figure again shows the optimized forward gain, S(2,1), at 1.9 GHz to be approximately 13.08 dB
as set by the Goal component in the ADS Schematic window. By using the optimized value of Remitout , you
have verified the optimum desired results of the circuit.
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Ending the Session

Use the following steps to exit the Dynamic Link environment and close both ADS and Cadence.

1. Choose the Advanced Design System Schematic menu option DynamicLink > Close Cadence Connection . This
closes ADS and terminates the link between Cadence and the Advanced Design System.

2. Exit from the Cadence CIW.

3. Congratulations... you have now successfully completed the Tutorial.

Using RFIC Dynamic Link

This chapter describes the procedures for:
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e |Launching Advanced Design System

e Adding an Instance of a Cadence Design

e Pushing into the Design Hierarchy

e Using Design Variables

¢ Adding Model Files

e Annotating a Cellview

Launching Advanced Design System

To run Advanced Design System from the Cadence Schematic window using RFIC Dynamic Link:

1. In the Cadence Schematic window, open the desired cellview.

2. Choose Tools > ADS Dynamic Link from the Cadence Schematic window. The Advanced Design System Main
window appears in the upper left corner of your screen followed, to the right, by an empty ADS Schematic
window (this may take some time).

The Cadence schematic window displays a DynamicLink pull-down menu. This menu provides some familiar, useful
Affirma Analog Circuit Design Environment interface functionality. For further information about these options, consult
your Cadence documentation.

Setup Options ...

 Note

The terminal output ( stderr ) of ADS gets redirected to the file idf.log in the directory in which the Cadence
framework is started. Once the link is started, subsequently opening a Cadence design will not involve the
overhead of re-starting ADS, but you will need to select Tools > ADS Dynamic Link just to see the DynamicLink
pull-down menu.

Adding an Instance of a Cadence Design
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To add an instance of a Cadence design to an ADS test schematic, choose DynamicLink > Instance > Add Instance of
Cellview .

A dialog box appears, allowing the selection of a Cadence design.

—| Select Design |
Ok Cancel Defaults Help
Lib Hame examples
PowerBAmp
Cell Hame I
View Name schematic
i Browse b

If a symbol already exists for the design in Cadence, the symbol geometry is duplicated in ADS; otherwise the
Cadence symbol generator is automatically invoked to generate a Cadence symbol, which is then automatically

duplicated in ADS.

If Cancel is selected, or if the configuration file has the entry,

IDF_CADENCE_SYMBOL = FALSE

the ADS symbol generation is automatically invoked (as opposed to the Cadence symbol generation). This generates
the symbol in ADS.

© Note

The generated symbol can be edited and modified if needed. If aesthetics are a concern, it is recommended
that the symbol be manually created in Cadence and then automatically replicated in ADS as described above.
The symbol of the Cadence design is given the following nomenclature <library> _ <cell> _ <view> . For
example, examples_PowerAmp_schematic . There is a skeleton schematic of the Cadence design that also gets
created in ADS. This is used as a placeholder to link with the actual Cadence design; you do not need to edit

this.

Pushing into the Design Hierarchy

To view a design deeper in the Advanced Design System schematic hierarchy:

1. Select the component you want to push into in the ADS Schematic window.
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2. Choose the Push Into Hierarchy icon . This downward arrow icon is located below the Cadence menu item in the

tool bar. | =
&%

3. If the selected component is a Cadence cellview instance, the corresponding Cadence cellview is opened in the
Cadence design editor. If this view is already open, it is simply raised to the top of the window stack.

Using Design Variables

This section describes how to add and edit design variables in Advanced Design System and also update your Cadence
design variables.

Cadence Affirma Analog Circuit Design Environment design variables are intended to be global in the context of a
particular Artist session or Cellview. When you select DynamicLink > Design Variables > Get Design Variables , these
variables are automatically mapped to corresponding variables in a VAR component in the Advanced Design System
schematic. This mapping ensures that these variables can be used for optimization or statistical analysis in ADS.

All the design variables for each Cadence design are put into a single VAR component. Each time the menu item
DynamicLink > Design Variables > Get Design Variables is selected, this component is updated with the most recent
values from Cadence.

Adding and Editing Design Variables

To add or edit a design variable for the ADS schematic:

1. From the Cadence schematic menu bar, choose DynamicLink > Design Variables . The Cadence Design Variables
form appears.

—|  Design Variables - - Affirma Analog Circuit Design Environment (1) |

OK | Cancel | Apply Help
Selected VYariable Table of Design Variables
M Remitout #  Name Yalue
Value [Exnr 120, 0 :..'.||||| (120ta200) 1 Eout 12
2 Reoe 10

3 Remitin 200

Add | Delete| Change | Next| Qear| Find Rematout 120, 0. .

| Cellview Variahle: Copy From | Copy To

For more information one using this form, refer to Design Variables and Simulation in your Cadence
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documentation.

2. In the ADS Schematic window, choose DynamicLink > Design Variables > Get Design Variables . This places a
corresponding VAR component on the ADS schematic containing the design variables from Cadence. If the VAR
component already exists it is updated only with variables and values that are not already there.

ggrq VAR
VAR
Cseries=7.0pF
Lshunt=7.5nH
Rout=12
Rcec=10
Remitin=200
Remitout=120.037 opt{ 120 to 200 }

VAR Block corresponding to Design Variables

 Note

There is no way to distinguish a design variable of the same name coming from different Cadence cellviews. If
a variable has different values in different cellviews, the value sent to ADS is chosen arbitrarily.
Non-alphanumeric characters, like parentheses, in variable expressions must be preceded by a backslash (*\").

Updating Cadence Design Variables

To update your Cadence design variables:

1. In the Advanced Design System Schematic window, choose DynamicLink > Design Variables > Update Design
Variables .

 Note

Design variables can be used for optimizations and sweeps in ADS. Variables used for this purpose should not
be assigned a value or expression in Cadence; the Value (Expr) text entry box should be left blank.

Closing the Cadence Connection
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If you have changed your design variables in Advanced Design System and attempt to close the Cadence connection
before updating your design variables in Cadence, an Update Design Variables To Cadence message will appear
prompting you to update design variables.

| —-i Update Design Yariables To Cadence?:1 |
‘ Design variables have changed!

Do you want to update design variables to Cadence?

Yes Mo

Adding Model Files

This section describes how to use the Netlist Include Component in RFIC Dynamic Link. The Netlist Include component
is provided as a means of utilizing external files in your design.

For more information on the Netlist Include component, refer to Chapter 5 of the ["../ccsim/wwhelp.htm"Introduction
to Circuit Components] documentation.

Adding a Netlist File Include Component

To place an instance of the Netlist Include Component :

1. From the top-level ADS schematic window, choose DynamicLink > Add Netlist File Include . An instance of the
NetlistInclude is attached to your cursor.

2. Move the cursor to where you want to place the component, then single click. A Netlist Include symbol is placed
on the schematic as shown in the following figure.

ﬁ% NETLIST INCLUDE

NetlistInclude
Netlistinclude

The Netlist Include Component Symbol
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 Note

Only one Netlist Include Component can be placed in a Dynamic Link design. This is to ensure that files are not
multiply included (this cause's redefinition errors within the ADS simulator).

Accessing the Netlist File Include Dialog

To access and edit information in the Netlist File Include component, double click the Netlist Include component
symbol. The Netlist File Include dialog box appears.

:
—| Netlist File Include |

Hetlistinchude

Instance Hame

NetlistIncludel
Select Parameter Cia
Include Path=
IncludeFiles[1]= 1
UsePreprocessor=yes Browse...
Section (optional )
_I Display parameter on schematic
Add L Paste Component Options...

IncludeFiles : List of files to include

T OK Apply Cancel Reset Help

Select Parameter

The Select Parameter list box displays a list of three parameters that enable you to create your include definition.
Refer to each of the sections listed for detailed information on defining these parameters.
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Set the path to where your model files are located (IncludePath).

Select the model files to include (see IncludeFiles).

Enter an optional section designator (see Section (optional)).

Determine the preprocessor setting (see UsePreprocessor).

IncludePath

The includePath parameter is a space delimited search path that is used to locate included model files. The include
path needs to be set up for the simulation machine in order to work properly. However, there is an issue with this. The
netlister searches through the include path to find files, and then outputs the values as expanded full paths (the
simulator requires this). If the expanded full path on the netlisting machine is different from the expanded full path of
the simulation machine, the simulator will not find the file to be included. If you want to do remote simulations,
ensure that the expanded full path of your included file is the same on the netlisting machine and the simulation
machine. Note that, in directory names, path prefixes such as '.", '..", '~', and '$' all have the usual UNIX
interpretation.

To enter a group of include paths:

1. Click the includePath= parameter in the Select Parameter list box.

2. Enter the name of the search path in the Search Path for included files (space delimited) field separating each
search path by a space.

IncludeFiles

This parameter enables you to build a list of model files that you want to include.To specify the path and filename of a
model file to include:

1. Click the IncludeFiles[n]= in the Select Parameter list box. This activates the Model Library File selection field.
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2. Click the Browse button. The Select File dialog appears.
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—| Select File:1 |

Filter

:/crscott/examples/models/*

Directories Files

Zamples/imodelsf.. hsim3Nch.ads
hsim3Pch.ads
capl.ads
diode] .ads
mrT349.ads
njfetl .ads

nmesfetl .ads

aelection

's/crscott/examples/models/]

OK Filter Cancel Help

3. Double-click as needed to locate the directory containing your model file or enter the full path and file name in
the Selection field. Click OK to return to the Netlist File Include dialog.
4. Once selected, the filename of the model file is displayed in the Library Model File field. Note that the path is

appended to the includePath parameter and the file name is added to the IncludeFile parameter definition.
Example:

includePath= Path1 Path2 ... ModelFilePath

IncludeFiles[ n ]= filename

5. To add additional model files, click Add . This creates additional model file parameter definitions in the Select
Parameter list box. Repeat steps 1 through 4 to define the path and file name. You can continue adding model

file parameters as needed. You can also use the Cut and Paste buttons to move or delete any model file
parameters.

Section (optional)

You may only have a single file for each IncludeFiles[n] parameter - unlike the prior parameters - this is not a space
delimited list. Each model file can have a Section designator. This enables you to include only a portion of a model file
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for corner analysis , provided your model file has been set up properly. The section designator is optional; if it is left
empty, the entire file will be included (provided it has no dependencies on needing a particular section set up).

To properly set up a model file to utilize the section directive, you must bracket the sections using #ifdef <section>/
#endif C-Pre-Processor(CPP) directives. The netlister automatically defines and undefines a variable with the name
section before and after the #include statement. As an example, if you wanted to have a file with corner cases, and
had a Nominal section, you would make the file as follows:

#i f def Nom nal

Nomi nal section
R RL in out R=50
#endi f

If the same library file is named, with a different section, a single #include is generated, with multiple #define
statements around it.

UsePreprocessor

The UsePreprocessor parameter defaults to " yes" . Setting this parameter to yes causes a preprocessor directive (
#include ) to be used which results in faster behavior by not copying the full text of the file. This parameter can also
be set to no to provide a slower, but more compatible, full-text inclusion behavior.

To set the UsePreprocessor parameter,

1. Click the UsePreprocessor=yes parameter in the Select Parameter field of the Netlist File Include dialog box. The
Parameter Entry Mode pull-down menu appears.

2. Click the Parameter Entry Mode pull-down menu in the Netlist File Include dialog box and select the appropriate
option.
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— Hetlist Fle Include
Metlistinclude Parameter Entry Mode
Instance Hame Yas
NetlistIncludel

select Parameter

IncludePath=
IncludeFiles(l-_ _ _ _ _
sePre WOCESSOr=Yes !
| Display parameter on schematic
Fighit 8134 Pagis Component Options...

directive (faster) or ‘no’ to copy the full text of the file

7 OK Apply Cancel Reset Help 1

The UsePreprocessor parameter was developed for delivering increased speed to old ADS designs that use the
geminilnclude , spicelnclude or csvinclude component and for delivering increased flexibility to old ADS designs
using the idfInclude component.

Display parameter on schematic

The Display parameter on schematic check box in the Netlist File Include dialog box is used to list the individual
parameters and their associated values on the schematic. If you want to display the parameters, activate the check
box.

Component Options

The Component Options dialog box enables you to change the visibility of the component parameters on a schematic
and/or reference items in hierarchical designs. To access the Component Options, click the Component Options button
on the Netlist File Include dialog box. A Component Options dialog box appears.
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—| Component Options:1 |

Parameter Visibility

1 et All ) Clear All

Hnaps

 FEEatesd ) Gl

OK Cancel Help

Changing the Visibility of Component Parameters on a Schematic

You can change the visibility status of all parameters of the Netlist File Include component through the Component
Options dialog box.

o Set All-Displays all parameters for this component on the schematic. Use this option to display all, or almost all,
parameters for this component. To display most-but not all-parameters, select Set All and then go back and turn
off the display of individual parameters as desired.

e Clear All-Clears the display of all parameters for this component from the schematic. Use this option to turn off
the display of all, or almost all, parameters for this component. To display a small subset of parameters, select
Clear All and then go back and turn on the display of individual parameters as desired.

Referencing VAR Data Items and Model Items in Hierarchical Designs

The Scope option applies to the VAR (Variables and Equations) data item and most model items (such as R_Model,
BJT_Model, BSIM3_Model). Exception: it does not apply to multi-layer models. Scope indicates the levels, from a
hierarchical standpoint, that recognize the expressions defined in the VAR data item or model item.

¢ Nested-VAR or model item expressions are recognized within the design containing the VAR or model item, as
well as within any subnetworks (designs at lower levels) referenced by the design containing the VAR or model
item.
Global-VAR or model item expressions are recognized throughout the entire design, no matter what level in the
design hierarchy the VAR or model item is placed.

Summarizing the Netlist File Include Component
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For all of the Netlist File Include component parameters, a single include statement is netlisted for each file. The
netlister checks to see if a file has already been output, to avoid having multiple definitions of files. The precedence is
that model files are output first, so that the segment directives can be placed around the #include .

If you are using the Netlist File Include component, it is not putting out #ifdef <file> statements to further ensure
that files are not multiply included. If you use a Netlist File Include component, you should not additionally use other
file include components to avoid multiple inclusions which will cause a simulator redefinition error.

Example:

Parameter settings

i ncl udePat h=". ./nodel s"
definitionFiles="functions. def"

stimul usFi |l es="vccdef. stint

nodel Li braryFiles\[1\]="resistor.lib Nom nal"

Netlist File Output (Note that . is /users/default/default_prj in this example):

#def i ne Nom nal

#i ncl ude "/users/default/default_prj/nodel s/resistor.!lib"
#undef Nomi nal

#i ncl ude "/users/default/default_prj/nodel s/functions. def"
#i ncl ude "/users/default/default_prj/nodel s/vccdef. stint

It is worth noting that, once the Netlist File Include component is netlisted, the simulator makes no differentiation
between definition, stimulus, or model files. Each file will generate the #include __ statements.

You may want to use the IncludeFiles parameter for all of your files so that you can put corner case statements into all
of your model files.
Annotating a Cellview

This section describes how to annotate your simulation results in Advanced Design System to a Cadence cellview.

Annotating DC Voltages to a Cadence Cellview

To annotate a DC voltage solution in Advanced Design System to the Cadence cellview:

1. In Advanced Design System, set up and simulate your schematic. This schematic must contain a DC Simulation
Component as shown in Example setup for DC Simulation.
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Example setup for DC Simulation

2. Select the schematic symbol in the ADS schematic that represents the Cadence circuit you want to back
annotate. For example, the amplifier block in the preceding figure.

From the ADS Schematic window, choose DynamicLink > Annotate > Annotate DC Solution to Selected Cellview .
4. The voltages are then displayed on the Cadence schematic as shown in the following figure.

w

62



Advanced Design System 2008

2.7 e
L .
|
2714
2.7%01 2.7%02 2.7%0z
2.7 Wit 2.7 2.7
(] ) [ . . \
71 71 7
47 +74 7
I-I'
o
=
.
= pE
B 'II‘I'.I I.'II.IllI I.'II.IllI I.' B
AN
-+
2.71M0s 47%as +7%ae +7%07

DC Voltage Annotation on the Cadence Schematic

Annotating DC Currents to a Cadence Cellview

To annotate a DC current solution in Advanced Design System to the Cadence cellview:

1. First annotate the DC voltages as described in Annotating DC Voltages to a Cadence Cellview.

2. From the Cadence schematic window, choose Edit > Component Display . The Edit Component Display Options
form appears.

3.

Click an instance in the Cadence Schematic window. For this example, Q0 was selected. Note that the title of the

Edit Component Display Options form changes to include the component selected. In this case, the title Edit
Component " QO' Display appears.
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4. Click the terminal checkbox from the Select Label options. Notice that the form now displays a Terminal Labels
section. This section shows that DC and voltage is currently selected as seen in Edit Component ~QQ' Display

form showing DC Voltage.
= Edit Component "Q0’ Display |

oK | Can[:el| Previuus| Next| Help

Select Labe W tenminal _ | parameter _ | instance
Auto Redrav. @ yes _no Save| Load | Attach| Detach |

Set Simulation Data Directory |

Terminal Labels
Apply Tt @library _cell instance
_Jnone _pin hame _net name (@ voltage  current
@ DC _ ) transient

Edit Component *QO' Display form showing DC Voltage

5. Click the currents checkbox in the Terminal Labels section of the Edit Component Display form to display currents
instead of voltage. The next figure shows the design with the DC currents annotated.
6. Click OK to clear the Edit Component *QO0' Display form.
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DC Current Annotation on the Cadence Schematic

 Note

If you do not select an instance, the library that your changes will apply to will be the library that contains the
schematic (i.e. examples for the PowerAmp example). Since the primitives (i.e. the res and npn cells) are not
in the schematic's library, you will not see any changes to the annotation if you do not first select an instance
from the proper library. The Edit Component Display form enables you to control how labels are displayed for
each library, cell and instance in the design.

Displaying Voltages or Currents from a Previous Simulation

To display voltages or currents from a previous simulation:
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1. Before displaying voltages or currents you must have annotated a DC solution to the schematic in a prior
Cadence session. Follow the instructions for annotating a DC solution (see Annotating a Cellview) to a schematic
if you have not already done so.

2. From the Cadence Schematic window, choose Edit > Component Display . The Edit Component Display Options
form appears.

=| Edit Component Display Options |
Ok | Cancel | Previous | Mext Help
Select Lahe terminal parameter instance

Auto Redrav. (@ yves  ino Save | Load | Attach | Detach

Set Simulation Data Directory

3. Click Set Simulation Data Directory . The Set Label Display Simulation Data Directory form appears.

Set Label Display Simulation Data Directory |

—

oK Cancel | Defaults | Apply Help

‘ Simulation Data Director, fPowerAmp /adsDL/schematic

4. Enter the full path to the Data Directory. This is everything up to the psf directory. The psf directory contains
Cadence formatted data. The structure for the path name is,
< Cadence_project_dir >/< cell_name >/< tool_name >/< view >
The path for the Data Directory used in the example for DC Voltage Annotation on the Cadence Schematic was,
~/simulation/PowerAmp/adsDL/schematic
The annotation code looks in the psf directory.

5. Click OK in the Set Label Display Simulation Data Directory form.

6. Click OK in the Edit Component Display Options form.
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Creating Symbols for Hierarchical Subcircuits with cdsTerm

If you want to annotate a hierarchical Cadence design, you must create a Cadence symbol for the design.
To create symbols for hierarchical subcircuits using cdsTerm :

1. From the Cadence Schematic window, choose Design > Create Cellview > From Cellview . The Cellview From
Cellview form appears.

= Cellview From Cellview |
0].4 Cancel | Defaults | Apply Help

Library Mame examples Browse

Cell Mame PowerAng

From View Mame schematic To View Hame symbol}

Tool f Data Type  Composer- Symbol

Display Cellview W
| Edit Options [ ] |

2. In the Cellview From Cellview form, ensure the following settings are correct:
e From View Name - schematic
e To View Name - symbol
e Tool / Data Type - Composer-Symbol
Click OK. The Symbol Generation Options form appears, assuming a symbol does not already exist.
3. In the Symbol Generation Options form, click the Edit Labels checkbox. Your form will display the Label options.
4. In the Symbol Generation Options form, select analog pin annotate from the Label Choice pull-down menu. The
Name field should now display cdsTerm("(pinname)").
5. Select all pins from the Apply To drop-down menu and click Add . This generates a new label rule that creates a
cdsTerm for each pin. You may alter the location if you choose. The form with all appropriate option settings is
shown in the following figure.
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d

= leam?2] Symbol Generation Options [SHARED] |
Ok | Can[:el| Apply | ﬂ
Library Mami Cell Mame View Name
| examples IuisrarchyS?nbolGrutimi | symbol
Fin Specifications Attributes
Left Pin: | in | List
Right Pins  |out | List
Top Fins l List I
Bottom Fins l List |
Load/Save | Edit Attribute: | Edit Label: H Edit Propertie: |
Labe 1. {pinName} (hottom) _Add | Delete | Modify |
Mame |cd3Term{"{pinName}" il Label Choice  analog pin annotate |
Apply To allpins s | Label Type  |LLabel
Orientation R270 | Font Heigh 0 0625
Justification centerRight | Font Style stick isOverbar |
Location  ypperCenter ||EIEi

Symbol Generation Options to create a symbol with cdsTerms on each pin

For more information on the Symbol Generation Option form, refer to your Cadence documentation.

Netlisting, Simulating, and Displaying Data

This chapter describes the procedures for netlisting and simulating a design as well as viewing the netlist from either
Advanced Design System or a Cadence Schematic window. Information on net, instance and expression name

mapping is also provided.
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Netlisting and Simulating a Design

Netlisting automatically occurs when you simulate your schematic in Advanced Design System. The complete netlist is
sent to the simulator, stored in memory, and written to a netlist.log file in the project directory of ADS. You can view
the netlist in the netlist.log file as needed.

To netlist and simulate a schematic in Advanced Design System:

1. In the ADS Schematic window, choose the Simulate icon or choose the menu item Simulate > Simulate . %}

A Simulation window appears, indicating the netlisting status and listing any errors encountered. If the netlisting
is successful, the design is then simulated; otherwise, act on the errors displayed in the Simulation window and
repeat step one above.

2. For information on configuring and viewing the simulation results in the Data Display window, refer to Data
Display Basics in the Data Display documentation.

Viewing Netlists

This section describes how to view the top-level netlist from Advanced Design System as well as how to view an ADS
subnetwork netlist for a Cadence design from a Cadence Schematic window.

Viewing Netlists from Advanced Design System

To generate and display the entire top-level ADS netlist, select DynamicLink > Top-level Design Netlist .
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— Hpeesofeedit: [/netlist.log]
File Edit Search

Options ResourcelUsage=yes UseNutmeqgFormat=no TopDesignName="fafnew/srieam?Zfdl flocalfusersicrsco

i Library name: examples

i Cell name: PowerAmp

; View name: schematic

#ifndef inc_examples PowerAmp schematic
#define inc_examples_PowerAmp_schematic
define examples_PowerAmp_schematic { GHND VCC1 VCCZ Vin Viout)
npnpwaz:Q7 neté YCC2 net37 0
npnpwaz:Q6 netd YCC2 net3s 0
npnpwaz:Qs net12 VOC2 net13 0
npnpwaz:Q4 netls VCC2 net3l 0
npnpwaz:Q3 netdd netls nets 0
nhpnpwaz:Qz2 netdd net1s net9 0

npnpwaz:Q1 netds net1s net12 0
npnpwal:Q0 netd4 Vin netl1s 0

R:R7 netd1 GND R=200

H:RE net13 GND R=Remitout

R:R5 net35 GMD R=Remitout

R:R4 net37 GND R=Remitout

R:R3 nett Vout R=Rout

R:R2 netd Vout R=Rout

R:R1 netl12 Vout R=Rout

R:R0 VCC1 netdd R=10 Tnom=23

7 Hpeesofeedit (T} 1.0 150.200 1,1 7

Viewing Top-Level ADS Netlist

Viewing Netlists from the Cadence Schematic Window

To generate and display the ADS subnetwork netlist for the Cadence design displayed in a particular Cadence
Schematic window:

1. From the menu bar, select DynamicLink > Subcircuit Netlist . Netlisting progress is displayed in the Cadence
CIW.

 Note

If the Dynamic Link pull-down menu does not appear in the Cadence Virtuoso Schematic window, choose Tools
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Window (CIW).

> ADS Dynamic Link > Add Dynamic Link menu to all schematic windows in the Cadence Command Interpreter

—iwmmmmwmm

J _”

File

Help

i Library name: examples
i Cell name: Powerkmp
; Wiew name: schematic

define examples Powerlmp schematic (
npopwad: 07 neth VCCE net3T O
nprpwal 06 netd VCCE net35 O
npnpwal 05 netll WOCEZ netld O
nprpwaZ: 04 netls VOCE net3l O
nprpwad: 03 netdd netlS netd 0
nprpwag: 02 netdd netlsS netd 0O
nprpwad: 01 netdd netls netls 0
nprpwal : Q0 netdd Vin netlS 0
R:R7 net31 GND R=200

RE:RE netl3 GND R=Remitout

‘RS net35 GHND ER=Remitout

:Rd net3T GND E=REemitoukt

nett Wout E=Rout

netd Wout R=Rout

E:Rl netl? Wout R=Rout

E:RO WCCl netdd R=10 Tnom=:25
end examples Powerdmp schematic
#endif

#ifndef inc examples Powerhmp schematic
#define inc examples Powerhmp schematic

GHD WCC1 WCCE Win Wouk)

]

Viewing a Subnetwork Netlist

2. A log window pops up, displaying the netlist results. Once you have viewed the results, you can select File >

Close Window to exit this window.

Net and Instance Name Mapping

Since Advanced Design System nomenclature rules differ from those of Cadence, nets, instances, etc. must be
properly mapped. This mapping is done automatically as part of the netlisting function. The mapping rules are as

follows.

¢ Advanced Design System keywords used as net or instance names are mapped by appending an underscore (_)
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Name Map

then then_

else else_
elseif elseif _
endif endif_
equals equals_
notequals notequals_
and and_

not not_

or or_

global global_
model model_
define define_
end end_
parameters parameters_

e Any non-alphabetical character (e.g. not a-z) in a net or instance name is mapped to an under bar (_).
e Advanced Design System uses a single name space for all names, regardless of object type (net, instance, etc.).
This may necessitate name mapping in addition to the above.

Expression Name Mapping

Most Cadence Analog Expression Language (AEL) expressions contain constants, functions and suffixes with
equivalents in ADS. In most cases the names of these equivalents are identical, requiring no mapping. As far as
possible, Cadence expressions are pre-evaluated in the Cadence environment, prior to netlisting and prior to getting
design variables from Cadence. This leaves only a few built-in function names to map (i.e. names that are not
identical in the two environments).

Cadence ADS
complex cmplx
fabs abs
log In
log10 log

Some built-in operator and function names in the Cadence Affirma Analog Circuit Design Environment as yet do not
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map to anything in the ADS environment.

Non-Mapping Operators

Cadence Description

- unary minus

~ unary one's complement
% modulo

<< left shift

>> right shift

& bitwise AND

| bitwise OR

n bitwise XOR

?: conditional expression

For these non-mapping functions, custom equivalents in ADS need to be written and mapped until they are available
as built-ins in ADS. Custom mapping is enabled via the configuration file option IDF_EXPR_MAP. For more information,
refer to Expression Mapping in Madifying the Configuration File.

Non-Mapping Functions

Cadence Description

acosh inverse hyperbolic cosine
asinh inverse hyperbolic sine
atanh inverse hyperbolic tangent
aelCheckRange determines if a number falls within a range
conjgate complex conjugate

floor floor of a real number

ceil ceiling of real number
mag magnitude

db10 10 times log10

db20 20 times log10

Using Global Nodes
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Cadence designs typically use implicit global nodes (names ending in ! ) for substrate power and ground connections.
This notation is now supported by Advanced Design System. If the exclamation point suffix is used, a globalnode does
not need to be placed in the ADS schematic.

Running a DSP and Analog/RF Cosimulation with RFIC
Dynamic Link

This chapter describes how to run cosimulation of behavioral Digital Signal Processing (DSP) designs along with
Analog/RF circuit designs. Using RFIC Dynamic Link, you can perform a cosimulation with DSP designs in Advanced
Design System (ADS) and your Analog/RF designs in Cadence. To run a cosimulation using RFIC Dynamic Link, you
will need to create an intermediate layer ADS design. This intermediate design must contain a dummy ADS design

representing the Cadence cellview in ADS and also include either an ADS Transient (Tran) or Envelope simulation
controller.

For more detailed information about ADS Cosimulation, refer to the ADS Ptolemy Simulation documentation.

RFIC Dynamic Link DSP and Analog/RF Cosimulation Example

The following example uses the RectifiedCx design (see the following figure) provided in the ADS Communication

Systems RectifierCosim_prj example project to demonstrate running a DSP and Analog/RF cosimulation using RFIC
Dynamic Link.
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Communications Systems RectifiedCx Example

The intermediate ADS design used in this example is a modified version of the rct_Env subcircuit design called
rct_Env_Cadence (see the following figure).
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= [ RectifierCosim_prj ] rct_Env * (Schematic):1 |

F

File Edit Select WView Insert Options Tools Layuut Simulate Window Dynamiclink DesignGuide Help

S EREE L s 8
Lumped- Components —"l[ il Gl ‘HEJ_'_'@ @IMQ

I 5] 5]

P p2
M1 Mums=2

&% | EnveLore I

Envelope

B End
MaxOrder=5
Frag[1]=11 MHz
Order[1]=5
FundCwvarsample=1 =
Cwersample[1]=
otop=2 usec
Step=0.01 usec

t3 BB s 50 O |-E HI A

- ) N
d A
| Select: Enter the starting point 0 items user sy -1.000, 00125 -4.750, 0.625 in

The rct_Env_Cadence Intermediate Design

Before you begin, ensure you are set up to run the RFIC Dynamic Link examples as described in Setting up the
Examples Directory.

1. Open the rct cellview under the examples library. This cellview is a duplicate of the Advanced Design System
rct_Env.dsn in the ADS example project $HPEESOF_DIR/examples/Com_Sys/RectifierCosim_prj.

) Note

As an alternative to performing steps 2 to 4 below, you can simply execute the get_cosim_example.sh script in
the examples directory at your system prompt.
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— Virtuosol Schematic Editing: examples rct schematic 4 J|
Cnd: Sel: 0 4
Tools Design Window Edit Add Check Sheet Opiions Help
: =
[ ] =

COMM . . . . CONND

grvd

mouse L. mouseSingleSelectPt  M: mousePopUp () F: hiZoomIn()

»

The rct Cell in the examples Library

2. Copy the ADS example project $HPEESOF_DIR/examples/Com_Sys/RectifierCosim_prj to a local directory.

3. Copy $HPEESOF_DIR/idf/examples/examples_prj/networks/rct_Env_Cadence.* to the local
RectifierCosim_prj/networks directory. This is the intermediate ADS design for this example.

4. Copy $HPEESOF_DIR/idf/examples/models/diodem2.ads to the local RectifierCosim_prj directory. This model file
contains the same ADS netlist as generated for the diode DIODEM2 in the original rct_Env subcircuit.

5. Start ADS by selecting Tools > ADS Dynamic Link in the Cadence schematic window.

6. Open the local RectifierCosim_prj from the ADS Main window, then open the rct_Env_Cadence ADS design.

7. Choose DynamicLink > Instance > Add Instance of Cellview to place the examples_rct_schematic design
between the two ports.

8. Add a NetlistInclude component to the rct_Env_Cadence design by choosing DynamicLink > Add Netlist File
Include .

9. Double click the NetlistInclude component and apply the diodem?2.ads model file to the IncludeFiles parameter.
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~i Select File:5 | | |

Filter

amples/RectifierCosim_prj/

Directories Files —| Hetlist File Include
arf_ful.rec
S . Hetlistinclude
oo e sim.cf
data Iiudemz.ads Instance Mame
networks dsp_ful.rec NetlistIncludel
hpeesofsim.cf
layout.prf Select Parameter -
Model Library File
momServerloy | | mrsdifocaliusersicrscottie : :
netlist.log IncludeFiles[1]=diodem? .ats dicdenZ. ads
UsePreprocessor=yes Browse...
selection
tifierCosim_prj/diode
Section (optional)
0K Filter Cancel I
_I Display parameter on schematic
Add L3 Pasie Component Options...
IncludeFiles : List of files to include
7 0K Apply Cance] Reset Help

Adding the Netlistinclude Component

10. Click OK to update the NetlistInclude component. The modified rct_Env_Cadence design should now appear
similar to the following figure.
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The Modified rct_Env_Cadence Design

11. Replace the rct_Env subcircuit component with rct_Env_Cadence in the RectifiedCx design by choosing Insert >
Component > Component Library and then selecting the rct_Env_Cadence from the Library Browser.

) Note

If a Failed to locate the component definition error occurs, you may need to create a symbol. Open the
rct_Env_Cadence design and select View > Create/Edit Schematic Symbol to create a new symbol.
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The RectifiedCx Design with rct_Env_Cadence

12. Choose Simulate > Simulate in the ADS schematic window of RectifierCx to simulate the design in ADS.
Simulation results of the modified RectifierCx design with rct_Env_Cadence subcircuit should be identical with
that of the original RectifierCx Design where the rct_Env subcircuit was included.

Tuning and Opt

Imizing Designs

This chapter provides information on tuning and optimizing designs using the Advanced Design System tuning and

optimization capabilities.
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Tuning Cadence Instance Parameters and Design Variables

The ADS tuning capability enables you to change one or more design parameter values and see its effect on the
output without re-simulating the entire design again from the beginning. Dynamic Link extends the ADS tuning
function to instance parameters and design variables in Cadence subcircuits. For more information on using the ADS
tuning feature, refer to Tuning in the["../optstat/wwhelp.htm" Tuning, Optimization, and Statistical Design]
documentation.

This section uses the PowerAmp example used in Getting Started Tutorial for demonstrating tuning of Cadence
instance parameters and design variables.

A Dynamic Link For Cadence Tuning Example

1. Follow the steps listed in Performing an S-parameter Simulation in the Getting Started Tutorial. Plot S(2,1) in the
ADS Data Display window after ADS S-parameter simulation is completed. The S(2,1) plot should resemble the
following figure.

m1
freq=1.900GHz
dB(S(2,1))=12.569
14
13 m1
—. 12—_
5 !
% 10—
a_
d | | | | |
14 16 148 2.0 22 24 20
freq, GHz

Data Display with S(2,1) of the PowerAmp_test Design.

2. In the ADS Schematic window, choose Simulate > Tuning or click the Tune Parameters icon (tuning fork) in the
toolbar. @ .
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3. Wait for the initial analysis to complete. The Tune Parameters dialog box appears as shown in the following

figure.
= Tune Parameters + |4

Simulate To tune a parameter:
While Slider Moves - Click on a parameter

_— - Click on a component

fune - Cick "Include Opt Params"

- Click "Enable/Disable..."

Parameters

Include Opt Params
EnablefDisable...

| Snap Slider to Step
Traces and Values
Store... g
Trage Vig#lify,
Reset Values
Update Schematic

4 Close Help 4

The Initial ADS Tune Parameters Dialog Box.

Note that the prompt at the bottom of the Cadence schematic window says:

ADS Tune Mode: Click an instance>

4. Move your cursor over resistor R7 in the Cadence schematic window and click the left mouse button (left click). A
slider control for R7.R immediately appears in the ADS Tune Parameters dialog box. Note that only integer and
floating point parameters are tunable. R7 contains only one tunable parameter R ( r in Cadence spectre), the
resistance.

5. Left click resistor RO in the Cadence schematic window. A menu pops up beneath RO as illustrated in the
following figure. The popup menu is displayed because there is more than one tunable parameter in RO , R and
Tnom . Cadence instance parameters are sent to ADS one at a time.
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— Virtuosol Schematic Editing: examples PowerAmp schematic

Cmd: Sel: 0
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woct 4y Uk

Belect one ofthe ADS tunable parameters

- vin 4l examples FPowerAmp_schematic EQ Tnom (250}
examples_ Powerd&mp_schematic RO.RE(10)

™ " "
L] L] -

L l L]
ahhh m & ot

vocz i ' " v "

. . = .
L] L] ; ]
. 1 ' -
GOl

) mouse L: mouseSingleSelectPt M: mousePopUp () E: schZoomFit{l.0 0.9

» ADS Tune Mode: Click an instance >

Select Tunable Parameter Pop-up Menu in the Cadence Virtuoso Schematic Window.

6. Select examples_PowerAmp_schematic.R0.R(10) in the pop-up menu. This creates a slider control for RO.R in
the ADS Tune Parameters dialog box.

7. In the ADS Schematic window, click the design variable Remitout in the VAR1 block.
The following figure shows the ADS Tune Parameters dialog box with VAR1.Remitout , R7.R , and RO.R being
selected. Recall that VAR1.Remitout is a design variable originated from the Cadence subcircuit.
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— Tune Parameters =
Simulate PowerAmp_test examples_PowerAmp_schematic
Yhile Slider Moves ~mitout R7.R RO.R

T
Parameters value [Tie3 200 10
Include Opt Params Max |44 5 il s
EnablefDisahle...
A A A
| snap Slider to Step
Traces and Values
Store... Pl
Trage Visiity.., Min 815 oo 5
Reset Values Step |1f. 3 B0 a
Update Schematic Scale Lin | Lin ‘| Lin
d Close Help " T

ADS Tune Parameters Dialog Box

10.
11.

Notice the distinction that a Cadence design variable is selected directly from the VAR1 block in the ADS
Schematic window, while an instance parameter is selected from the Cadence Schematic window.

In the ADS Tune Parameters dialog box, select a tune analysis mode from the Simulate drop-down list. This tells
ADS when you want tuning to occur. For this example, choose After each change if not already selected.
After you finish with all of the steps in this example, try each tuning analysis method ( After Each Change , After
Pressing Tune , While Slider Moves ) to see which one works best for you.
Drag the slider for examples_PowerAmp_schematic.R7.R to 300 (Ohms). You also can change the tunable
parameters by doing the following:
e Click the up or down arrows.
e Type the value directly into the box.
Observe the results in Data Display window each time you release the mouse button after dragging a slider
or changing a value in the Tune Parameters dialog box.
Drag the slider for examples_PowerAmp_schematic.R0O.R to 5 (Ohms).
Finally, enter a value for PowerAmp_test.VAR1.Remitout of 120 (Ohms). The Tune Parameters dialog box should
now appear similar to the following figure.
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— Tune Parameters N IE]
Simulate Powerfimp_test examples_PowerAmp_schematic
After Each Change ‘ ~mitout R7.R RO.R

Tung
Parameters Value 120 300 q
Include Opt Params Max 244 5 200 s
Enable/Disable...
A A A
- Snap Slider to Step
Traces and Values
v v v
Store... fHponll..
Trace Visiility... Min  81.5 100 5
Reset Values Step 16 3 20 a
Update Schematic Scale Lin “ | Lin Lin
A Close Help < T

ADS Tune Parameters Dialog Box (With VAR1.Remitout , R7.R , and RO.R values Changed).

12.

The next figure shows the resultant S(2,1) curve displayed in the Data Display window after changing
VAR1.Remitout , R7.R, and RO.R in the Tune Parameters dialog box. You can compare this to the initial results in

the figure Data Display with S(2,1) of the PowerAmp_test Design.

You can click the Reset Values button to restore all the sliders to their original values. The Update Schematic
button in the Tune Parameters dialog box enables you to write the instance parameter values currently displayed
in the dialog box into the Cadence Schematic window. For Cadence design variables, such as VAR1.remitout ,
you still need to select DynamicLink > Design Variables > Update Design Variables to Cellviews in the ADS
schematic window and then follow the instruction in the Confirmation Message form to complete the update.
Because there is no undo function for the Update operation, do not click the Update Schematic button if you do

not want to change values in the Cadence subcircuit.
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(as R7.R, RO.R and VAR1.Remitout are changed in the Tune Parameters dialog box)

13. Click the Close button in the Tune Parameters dialog box to end the tuning session. The prompt at the bottom of
the Cadence Virtuoso schematic window returns to its default greater than sign ( > ).

) Note
For more information on using the ADS tuning feature, refer to Tuning in Advanced Design System in Tuning,

Optimization, and Statistical Design.

This example demonstrated three types of tuning operations in Dynamic Link:

e Clicking a Cadence instance with a single tunable parameter causes that parameter to be sent to ADS for tuning.

e Clicking a Cadence instance with multiple tunable parameters results in a pop-up menu being displayed.
Selecting an item from the pop-up menu causes the parameter associated with that menu item to be sent to ADS
for tuning.

e After obtaining Cadence design variables by selecting DynamicLink > Design Variables > Get Design Variables in
the ADS schematic window, clicking a Cadence design variable in the ADS VAR1 block sends that variable for
tuning.

All the above three types of operation act like a toggle switch. Selecting an item already on the Tune Parameters
dialog box removes it from the dialog box.
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You can descend down a Cadence design hierarchy to find an instance parameter for tuning. You can then return to
higher level Cadence design hierarchy to select another instance parameter.

 Note

During the tuning operation, the left mouse button in the Cadence Virtuoso schematic window is mapped to a
Dynamic Link SKILL procedure. Do not bind any function to the left mouse button during this period. Any
bindkey function previously mapped to the left mouse button will not work until the tune mode ends.

If you have a problem while tuning and need to discontinue the operation, enter IdfMpsTuneEnd in the Cadence CIW
input area. This will end the Dynamic Link Tune Mode operation.

Optimizing Designs

Performance optimization enables you to specify a range of device or component values. The software can then
automatically compute the nominal values that best meet your performance goals or specifications. A family of
optimizers come with ADS, each with a different mathematical effect or use. For more information on performance
optimization, refer to Performing Nominal Optimization in the["../optstat/wwhelp.htm" Tuning, Optimization, and
Statistical Design] documentation.

To optimize a design in the Advanced Design System:

1. In the Schematic window containing the design you want to optimize, choose Optim/Stat/Yield/DOE from the
component palette. ** The Optim/Stat/Yield/DOE palette is displayed.
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5 e
I
i

| Select: Enter the starting point

The Optim/Stat/Yield/DOE Component Palette

2. Set the options ( Goal, Nominal Optimization, etc.) as desired.When a Nominal Optimization component is first
added, you need to enable the output to the dataset. Click the Nominal Optimization component and choose Edit
> Component > Edit Component Parameters . ** This brings up a Nominal Optimization dialog box. Select the
Parameters tab and ensure that the Analysis outputs and Optimization variables are checked. Click OK .
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3. Proceed with the Advanced Design System optimization.
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Both the Monte Carlo and Yield simulation controllers include options for specifying statistical variations. Note
that process and mismatch variations are only used for ADS RFIC Dynamic Link.

Statistical Variation Options

option Description
stat{...} ADS syntax for statistical variations.
process t For process only analysis, select the process checkbox
and unselect mismatch checkbox. For process and
mismatch analysis, select both the process and mismatch
checkboxes.
mismatch t For mismatch only analysis, unselect the process

checkbox and select mismatch checkbox. For process and
mismatch analysis, select both the process and mismatch
checkboxes.

T These options use Spectre syntax and are provided only for use with RFIC Dynamic Link. For more information on
process and mismatch variations, refer to the section on Monte Carlo Analysis in Chapter 6 of the Cadence _Virtuoso
Spectre Circuit Simulator User Guide, Product Version 5.1.41_ .
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Updating the Cadence Cellview

Once the optimum value of a variable is computed by an ADS simulation, you can update the value to the Cadence
cellview. To update the Cadence cellview:

1. In the Schematic window, choose DynamicLink > Design Variables > Update Design Variables to Cellviews .

© Note

Only the nominal values of variables get updated to Cadence; any range values are ignored. Variables to be
optimized should not be assigned a value in Cadence; they may be assigned a nominal value and a range in
ADS.

Using Additional Features of RFIC Dynamic Link

This chapter describes some of the additional features provided by the RFIC Dynamic Link. Some of the issues related
to compatibility between Advanced Design System and the Cadence tools are also discussed in this chapter.

Freezing Selected Subcircuits

The RFIC Dynamic Link Freeze mode enables you to keep Cadence from generating a new netlist each time you
simulate in Advanced Design System. This helps to avoid unnecessary time-outs caused by re-netlisting a large
Cadence subcircuit.

Setting the Freeze Parameter

If you want to keep a Cadence Cellview from being netlisted and a netlist already exists:

1. Edit the ADS dummy design for that Cellview which would have a name of the form < lib >< _cell >< _view
>.dsn. In this example, the name of the file is examples_PowerAmp_schematic.

2. Double click the _
idfSymbol_ in the schematic dummy design (see the following figure) and set the freeze parameter to "yes" or
"TRUE". Note that the idfSymbol contains the library name, cell name, view name and netlist file information
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| idf Symbol

idfSymbol
Instance Hame (name[<start:stop=])
IDE,

aelect Parameter

libHame="examples"
cellName="PowerAmp"

view Hame="schematic"
netlistFile="examples PowerAmp_schi

reeze=TRUE

Fagtad PR Pran i

freeze : Freeze netlist file

Parameter Entry Mode
Standard

freeze (Integer, e.g. 1)

TRUE

HNone

Equation Editor...

ChibnirationfBialintog 0T Salun

® Display parameter on schematic

Component Options...

1 oK Apply

Cancel Reset Help

Freeze Parameter Setting in idfSymbol

Refer to the example schematic in the following figure for the location of the freeze and netlistFile parameter settings.
To turn the freeze parameter off, set the parameter to "no" or "FALSE". The default value for the freeze parameter is

"FALSE".
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Defining the Freeze Parameter

To freeze all Cadence subcircuits, see Modifying the Configuration File.

Generating a Cadence Subcircuit Netlist

In order to run Dynamic Link in Freeze mode, the Cadence subcircuit netlist must exist. If a Cadence subcircuit netlist
does not exist, you can generate a new Cadence subcircuit netlist before running your ADS Simulation. Choose
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DynamicLink > Subcircuit Netlist from your Cadence Schematic window.

© Note

If the Dynamic Link pull-down menu does not appear in the Cadence Virtuoso Schematic window, choose Tools
> ADS Dynamic Link > Add Dynamic Link menu to all schematic windows in the Cadence Command Interpreter
Window (CIW).

This generates the Cadence subcircuit netlist. You can now run your ADS Simulation in Freeze mode.

© Note

If you set the Freeze parameter to TRUE but the Cadence subcircuit has never been netlisted, the Cadence
subcircuit will automatically be netlisted the first time an ADS Simulation is attempted.

Setting the netlistFile Parameter

The netlistFile parameter is used to specify the location of the ADS netlist of a frozen Cadence Cellview. On the
dummy (placeholder) design, set the netlistFile parameter to point to the appropriate netlist file. For example:

netlistFile="examples_PowerAmp_schematic.net"

The default location for storing the ADS netlist of a frozen Cadence Cellview is:

<current_ADS_project_directory> /networks/

If you want to copy the netlist file elsewhere, set the netlistFile parameter to point to the full path and file name of the
new location. For example:

netlistFile="/tmp/my_design.net"

Refer to the example schematic in Defining the Freeze Parameter for the location of the netlistFile parameter setting.

Using "Freeze" Mode to Simulate a Design in ADS Standalone

You can run Advanced Design System standalone (without Cadence DFII or RFIC Dynamic Link) using a frozen netlist
from an earlier RFIC Dynamic Link session (see Freezing Selected Subcircuits). The parameter Freeze=TRUE must be
set on all dummy designs in ADS that represent Cadence cellviews.

94



Advanced Design System 2008

While RFIC Dynamic Link is not designed to operate on a PC, you can take an ADS netlist (created using Dynamic Link
on your UNIX workstation) of your Cadence cellview and copy it to your PC for an ADS simulation. This type of
operation is typically done for board design. Once you have done some minor configuration, you can then add
simulation and control components externally to your design and resimulate on the PC.

To set up and simulate your Cadence cellview in Advanced Design System on a standalone Windows machine:

1. Install RFIC Dynamic Link on your PC.
2. For each Cadence CellView, copy the netlist, AEL and design files into your working project directory's networks
subdirectory. For instance, copy the following example PowerAmp schematic files into your project directory:

exanpl es_Power Anp_Schemat i c. net
exanpl es_Power Anp_Schemati c. ael
exanpl es_Power Anp_Schenmati c. dsn

3. If the Cadence CellView contains design variables, you will need to manually enter them into a VAR block in the
top level ADS schematic. To do this:
e Choose Data Items from the Component Pallet.
e Click the Var Eqgn block to add the component and use the cursor to place an instance on the schematic.
You may continue placing more instances of the Var Eqn block, or choose the Cancel Command And Return
To Select Mode icon to proceed with the next step. E

e Enter the appropriate values into Var Eqn block.

It is important to note that any changes made to the design on your standalone machine will not be reflected in your
original Cadence cellview. While you may add simulation and control elements externally, the fundamental design
should not be changed if you want it to match your original Cadence design.

Compatibility between Advanced Design System and Cadence Tools

Some of the features provided by the RFIC Dynamic Link include support for compatibility issues related to differences
between Advanced Design System and the various Cadence tools. This section addresses several of these
compatibility issues.

Support for Duplicate Pin Names

It is typical for the top (chip) level schematic to have multiple pins for the same signal, usually power and ground
connections. The netlister lists duplicate I/O ports only once in the subnetwork definition and likewise for the nets
connected to an instance of the subnetwork. However, the netlister in ADS (which does the top-level netlisting), writes
out the multiple connections to ports with the same name, causing a conflict to be reported by the ADS simulator
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while parsing the final netlist. To eliminate this conflict, when the symbol generator encounters duplicate pin nhames, it
draws only one pin with a given name and issues a warning message. However, duplicate pins at lower levels in the
Cadence schematic hierarchy are allowed, because no ADS symbol is involved.

Using Buses

For an example on using buses in RFIC Dynamic Link, refer to Getting Started Tutorial and use the PowerAmp2
Cadence cellview in place of the PowerAmp cellview. Then use the PowerAmp2_test ADS design in place of the
PowerAmp_test design. The PowerAmp2 example is the same as the PowerAmp example except that it uses bus wires.

For details on creating buses in ADS, refer to Chapter 3 of the ["../usrguide/wwhelp.htm"Schematic Capture and
Layout] documentation. __ For details on using buses within Cadence Design Framework II, refer to your Cadence
documentation.

Setting up Unnamed Nets

In ADS, unnamed nets begin with an _net prefix followed by an integer. All other net value are written out to the
output dataset during simulation. By default, Cadence tools use the prefix net followed by an integer. By default, the
dataset can get very large. To avoid this, set the Net Name Prefix in the Cadence schematic to _net instead of net .
To set the default Net Name Prefix in the Cadence schematic:

e Choose Options > Editor .

¢ In the Editor Options dialog box, enter _net in the Net Name Prefix field

e Click OK .

¢ Choose Design > Check and Save to save each related Cadence schematic.

Support for pPar and iPar

This section describes the general use of parent parameters (pPar) and instance parameters (iPar).

pPar()

The following figure shows an example of an inverter design that contains two CMOS transistors (MO & M1).
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Composer Schematic showing use of pPar()

This Composer circuit contains instances whose parameters are defined in terms of parent parameter values using
pPar() . The parameters in this case are defined as,

| = pPar("In")

w = pPar("wn"
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for MO, and

| = pPar("Ip")

w = pPar("wp")

for M1.

This inverter circuit also has an associated symbol view in Cadence Composer. The symbol view shown in the following
figure is equivalent to a black box that displays the input, output and instance properties for the circuit in the previous
figure.

The default values of wn, In, wp and Ip are displayed in the symbol view along with the associated symbol for the
device.
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Composer Symbol View showing default values for pPar()

The Composer symbol is instantiated in ADS via the Dynamic Link where the instance properties also appear in ADS
Schematic (see the following figure).
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The parameter values are reflected in the netlist that is sent to the simulator. These values can be viewed and edited
using the Cadence Edit Component CDF form (see the following figure).

Select: Enter the starting point 0 items wire 0125, 2.000 0.37a, -0.125 it

Inherited Symbol in ADS

If the Cadence menu option Design > Create Cellview > From Cellview is used, the CDF for the schematic will be set
up automatically. The Cadence software will traverse the hierarchy looking for pPar statements and automatically
generate parameters. It will also set up netlisting data for known simulators.

If you are modifying an existing schematic and you have already generated a symbol for your schematic, it may be
necessary to manually add the netlisting data for ADS. If this is the case, do the following:

1. Go to the Simulation Information section of the Edit Component CDF form (see the following figure) and click Edit

100



Advanced Design System 2008

— Edit Component CDF |
oK | Can[:el| Apply Help
CDF Selection ® Cell | Library CDF Type Base =
Library Name examples

Cell Name ind
Browse
File Hame

Load Sawve  File Hame Select  Change Directory

Component Parameters

Mame — Suld Exdit Move Select To Delete
In 2 -
Ip 2 -
wn 1d _
wp 1 -

Simulation Infornmation

Edit

ads wipn "l]'l].t.-‘; 1

Edit Component CDF Form

2. When the Edit Simulation Information dialog (see the following figure) appears, change the Choose Simulator
setting to "ads".
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3. In the netlistProcedure field enter IdfSubcktCall .

4. In the instParameters field enter the parameters you wish to have netlisted for ADS. For the inv circuit, this

means entering "wn In wp Ip". The parameter order does not matter.

Change the componentName field entry to "subcircuit" or leave it blank.

Set the termOrder field to the order you wish to netlist the terminals in for ADS. You should have one entry for

each terminal on your design. For the inv circuit, this is set to "in" "out". You can also quote the names, but it is

not necessary.

7. If you wish to back annotate currents, make the appropriate entry in the termMapping field. This is done by
specifying the name of a terminal, followed by the ADS pin number it will be. For the inv example, termMapping
entry would be "nil in ": P1" out ": P2"".

o w

For more information on editing simulator information, refer to Creating the Netlist Interface in the Cadence
Library Integration documentation.

iPar()

Similarly, the Dynamic Link supports the use of iPar . For any given instance, you can define an instance parameter as
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a function of another parameter of the same instance. For example, if the parameter w in the figure Composer
Schematic showing use of pPar() were defined as w=2*iPar("l"), then if I=10, then w=20.

Using Inherited Connections

Inherited connections used in Dynamic Link must all be resolved within the Cadence hierarchy. For example, if you
create a schematic in Cadence called test , that contains instances that have inherited connections with them, such as
nmos in analoglib, the default connectivity is used in test if no netset properties have been placed on instances in the
hierarchy of the top level circuit. If you have hierarchy above the top level Cadence schematic placed in the ADS
design environment, you cannot place netset properties on those instances.

Using S-parameter File Devices from analogLib

For information on S-parameter file components in the analoglLib library, refer to Using S-parameter File Devices from
analoglLib in the analogLib Components documentation.

Encoding Cadence Designs for RFIC Dynamic Link

This example demonstrates the use of Advanced Design System's RF IP Encoder command-line interface with RFIC
Dynamic Link. The Cadence and ADS designs provided in the RFIC Dynamic Link Tutorial are adopted here. The
PowerAmp Cadence design and the ADS model files that are used in the design will be encoded using the RF IP
Encoder, as a component in an ADS library. The encoded component will eventually be used in the PowerAmp_test
ADS design for a simulation. For more information, refer to the RF Intellectual Property Encoder documentation.

Familiarity with the Cadence environment and the RFIC Dynamic Link tutorial is assumed. The RFIC Dynamic Link
tutorial is provided in Getting Started Tutorial.

The following is a list of steps to encode a Cadence design and then use the encoded design in an ADS simulation via
RFIC Dynamic Link:

1. Make a copy of the Dynamic Link examples directory and start Cadence from the directory created. For example,
enter the following commands:

cp -r $HPEESOF_DI R/ i df / exanpl es /tnp
cd /tnp/ exanpl es
i cne&
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See Setting up the Examples Directory for details.

2. Open the PowerAmp cellview of the examples library in the Cadence schematic window.

Choose Tools > ADS Dynamic Link menu item in the Cadence schematic window to start ADS RFIC Dynamic Link.

4. Choose DynamicLink > Subcircuit Netlist menu item in the Cadence schematic window to generate the netlist for
the PowerAmp Cadence design.

5. Choose File > Save As in the netlist window and save the netlist file as examples_PowerAmp_schematic . For
demonstration purpose, it is more convenient to name the netlist file exactly as examples_PowerAmp_schematic
here, i.e. name the netlist file as <libName> _ <cellName> _ <viewName> with no extension.

6. Close the Cadence schematic window and the netlist window.

Open the examples_PowerAmp_schematic file in an ACSCII text editor.

8. Insert the two model files examples/models/npnpwal.ads and examples/models/npnpwa2.ads between the end
and the #endif statements in the examples_PowerAmp_schematic file as shown below. Save your changes and
quit the editor.

w

N

end exanpl es_Power Anp_schemati c

nmodel npnpwal BJT NPN=1 PNP=0 Bf =130 | kf=0.01085 \
| se=7. 56E- 13 Ne=2 Vaf=25 Nf=1.03 Tf=8.91E- 12 \
Xtf=3.35 Vtf=0 I1tf=0.0217 Ptf=18 Xtb=2.2 \
Approxgb=1 Br=5.123 | kr=0.056 |sc=2.01E-12 \
Nc=2 Var=0 Nr=1 Tr=1.6E-9 Eg=1.11 |s=2. 15E-16 \
I max=1 Xti=8 Tnomr25 Nk=0.5 |ss=3. 28E-13 Ns=1 \
g c=1. 045E-13 Vj ¢=0.75 M c=0.5 Xcj c=0.2292 \
Fc=0.5 G e=1.935E-13 Vj e=0.85 M e=0.4 \
G s=1.092E-13 Vjs=0.7 M s=0.5 Rb=317 Irb=0 \
Rbm=10. 63 Re=1.79 Rc=37.6 Af=1 Ab=1\
Fb=1 Ffe=1 Lateral =0

nmodel npnpwa2 BJT NPN=1 PNP=0 Bf =166 | kf=0.02325 \
| se=1. 218E-12 Ne=2 Vaf=25 Nf=1.03 Tf=7.97E- 12 \
Xtf=3.16 Vtf=0 |1tf=0.0465 Ptf=18 Xtb=2.2 \
Approxgb=1 Br=5.123 | kr=0.12 |sc=4.08E-12 \
Nc=2 Var=0 Nr=1 Tr=1.6E-9 Eg=1.11 |s=4.08E-16
I max=1 Xti=8 Tnomr25 Nk=0.5 |ss=4. 96E-13 Ns=1
g c=2.13E-13 Vj¢=0.75 M c=0.5 Xcj c=0.22 \
Fc=0.5 ¢ e=3. 123E-13 Vj e=0.85 M e=0.4 \
G s=1.65E-13 Vjs=0.7 M s=0.5 Rb=59.2 Irb=0 \
Rbnr14.1 Re=0.833 Rc=22 Af=1 Ab=1 \
Fb=1 Ffe=1 Lateral =0

#endi f

\
\

9. Make a temporary working directory. For example, enter

nkdir /tnp/ nyip
cd /tnp/ nyip

10. Copy the netlist fragment to be encrypted to the temporary directory. Make sure the filename is the name that
will be used to get the fragment out of the library and it does not contain an extension. For example, enter

cp /tnp/ exanpl es/ exanpl es_Power Anp_schemati c /tnp/ nyi p/

11. Create a new file named 'library.cfg' that contains the following three lines:
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Li brary nane: Power Anp_schemati c
Li brary size: 2
exanpl es_Power Anp_schenmat i ¢ exanpl es_Power Anp_schenmati c

12. Create another file named " ADSlibconfig' that contains the following line:

Power Amp_schemat i c /tnp/ nyi p/ Power Anp_schematic.library

13. Make sure LD_LIBRARY_PATH (Linux and SunOS) or SHLIB_PATH (HP-UX) is set to include shared libraries
required to run ADS. For example, entering the following command at the Korn shell prompt will accomplish this:

boot scri pts. sh

14. Make sure PowerAmp_schematic.library does not already exist by entering:

rm Power Anp_schematic.library

15. Enter the "hpeesofencode' command to create PowerAmp_schematic.library.
16. Edit or create one of three ADSIlibconfig files to add a line for mapping the library name to the full path to the
Jdibrary file. The line to add for this tutorial should read:

Power Anmp_schemati ¢ /tnp/ nyi p/ Power Amp_schematic.library

The library mapping line can be added to any of the three ADSIlibconfig files listed below:

$HOVE/ hpeesof / ci rcui t/ confi g/ ADSI i bconfi g
$HPEESOF_DI R/ cust oni ci rcui t/ confi g/ ADSl i bconfig
$HPEESOF DI R/ circuit/confi g/ ADSl i bconfig

17. Choose File > New > Cellview in the Cadence CIW to create a new examples_PowerAmp_schematic symbol in
the examples library, that is, enter the following information in the Create New File form:

Library Name: examples
Cell Name: examples_PowerAmp_schematic
View Name: symbol

Note that selecting Composer-Symbol in the Tool cyclic button will fill in symbol as the View Name.

18. In the Cadence Symbol Editor window, choose Add > Import Symbol to import the PowerAmp symbol in the
examples library. Save the symbol and close the Symbol Editor window.
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19. Use the Cadence CDF Editor or cdf Dunp() and | oad() SKILL commands to enter the following ads simInfo
(Simulation Information) for the examples_PowerAmp_schematic cellview:

netlistProcedure ADSsimCompPrim
termOrder (GND VCC1 VCC2 Vin Vout)
uselib PowerAmp_schematic

Note that the library name entered in the uselib field must be exactly the same as the name entered in the
ADSlibconfig file.

20. Create an ads view by copying the examples_PowerAmp_schematic symbol view to an ads view. One way is to
press and hold the middle mouse button at the symbol in the Cadence Library Manager and select Copy in the
popup menu. Enter ads in the View field of the To group in the Copy View form and click OK .

21. Create a cellview in the Cadence schematic window. For example, enter the following information in the Create
New File form:

Library Name: examples
Cell Name: trojan
View Name: schematic

22. Place an examples_PowerAmp_schematic instance in the schematic window. Add five Input/Output pins and
connect one to each pin of the instance as shown below.
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Virtuoso® Schematic Editing: examples trojan schematic

Sel: 0

Mindow Edit Add Check Sheet Options Dynamiclink

v1 4

v2 4

VCCZ
VCC

WYin Viout

GMND

[ ]
qd 4

23. Choose Tools > ADS Dynamic Link in the Cadence schematic window.
24. Choose DynamicLink > Design Variables in the Cadence schematic window in which the trojan cellview is
displayed. Add the following four design variables:

Rout 12
Rcc 10
Remitin 200
Remitout 163

It may be necessary to click the Copy To button in the Design Variables form.
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26.

27.
28.

29.

30.

Advanced Design System 2008

Choose Design > Create Cellview > From Cellview to create a symbol view for the examples/trojan/schematic
cellview. Save the symbol created and close the Symbol Editor window.

Click the Check and Save icon in the schematic window.

Open the PowerAmp_test ADS design in the examples_prj ADS project.

Choose DynamicLink > Instance > Add Instance of Cellview to place the examples_trojan_schematic instance in
the PowerAmp_test ADS design. Make an appropriate connection for each of the five pins as demonstrated in the
Dynamic Link Tutorial. Make sure the v1 pin, which connects to the VCC1 pin of the
examples_PowerAmp_schematic Cadence cellview, is connected to the SRC1 instance on the right side of the
PowerAmp_test ADS design.

Choose DynamicLink > Design Variables > Get Design Variables to add the Rout, Rcc, Remitin, and Remitout
Cadence design variables to the VAR1 block in the ADS schematic window.

Activate the DC and S_PARAMETERS simulation controllers and start an ADS simulation.

Note
Unlike in the Dynamic Link Tutorial, the model cards need not be included in a NetlistInclude component since
they have already been included in the encoded PowerAmp_schematic library.

31.

32.

Plot S(2,1) to ensure the simulation results are the same as illustrated in the Dynamic Link Tutorial. If the
simulation completed without error but the output plot looks different, check the pin order of the Cadence
instance.

Choose DynamicLink > Top-level Design Netlist in the ADS schematic window and observe the following lines in
the netlist file:

define exanpl es_trojan_schematic \( gd vl v2 vi vo \)

#{anchor: 1109884: i ndex: usel i b}usel i b " Power Anp_schematic", "exanpl es_Power Anp_schenatic"
exanpl es_Power Anp_schematic:10 gd vl v2 vi vo

end exanpl es_troj an_schematic

éklarrpl es_trojan_schematic: X1 0 net51 net50 net54 net52

33.

These lines are equivalent to the combination of the subcircuit call, the subcircuit definition of the
examples_PowerAmp_schematic, and the model card include statements in the netlist of the Dynamic Link
Tutorial.

Choose DynamicLink > Close Connection to end the Dynamic Link session. Exit Cadence.

Encoding Process Summary

When selecting the DynamicLink > Subcircuit Netlist menu item in a Cadence schematic window, Dynamic Link defines
the Cadence subcircuit name as <libName> _ <cellName> _ <viewName> , which can be renamed as desired in an
editor. The key is that a Cadence component with the same name as the subcircuit, with an ads view and appropriate
uselib, must be created. The name must contain an underscore character. The whole string with the underscore
character will be the encoded component name. The sub-string after the underscore will be the name of the new ADS
library that contains the encoded component.

If the Simulation > Netlist > Recreate menu item in the RF Design Environment (RFDE) Analog Design Environment is
used to create the initial netlist, a subcircuit definition (define <subckt_name> and end statements) must be inserted
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and undesired netlist fragments such as, Options and outputPlan, must be removed.

The encoded design will not work in spectre or other simulators integrated into the Cadence design environment.

In summary, here is the list of tasks to perform for creating and using an encoded Cadence design with Dynamic Link
or RFDE:

Create a subcircuit netlist for the Cadence design to be encoded. The subcircuit name must contain an
underscore character. For the ensuing context, assuming ABC_XYZ is the subcircuit name.

Merge model cards to be encoded with the above netlist file and save the file as the same name as the subcircuit
with no suffix, i.e. ABC_XYZ.

. Create a "library.cfg' file in a temporary working directory with the following three lines:

Li brary nane: XYZ
Li brary size: 2
ABC XYZ ABC XYZ

4

. Create another file named " ADSlibconfig' under the same temporary directory with the following line:

XYZ _<full_path_to_tenporary_directory>_ /XYZ. library

10.

11.

12.

Create a Cadence symbol with as many input/output pins as the encoded subcircuit. This symbol should bear the
same name as the subcircuit, i.e. ABC_XYZ.

Enter . bootscri pt.sh to set up shared library paths for ADS tools.

Enter " hpeesofencode' in the temporary directory to encode the ABC_XYZ netlist file into XYZ.library.

Copy the Cadence symbol view to create an ads view to indicate it being a primitive component in RFIC Dynamic
Link and RFDE.

. Add an ads simInfo section to the CDF of the Cadence component. Enter ADSsimCompPrim as the
netlistProcedure, the encoded library name (i.e. XYZ) as uselib, and appropriate termOrder entries that match
the subcircuit definition.

Create a Cadence subcircuit to encapsulate an instance of the above primitive component. This step is not
necessary for RFDE.

Instantiate an instance of the Cadence subcircuit cellview in the ADS schematic window via RFIC Dynamic Link to
use the encoded Cadence design in ADS; or, simply instantiate an instance of the Cadence primitive component
(i.e. the ABC_XYZ symbol) to use the encoded Cadence design in RFDE.

To distribute the encoded design to RFIC Dynamic Link users, deliver the encoded library (XYZ.library), the
primitive cellview (ABC_XYZ), and the Cadence wrapper subcircuit created for encapsulating the primitive
cellview. For RFDE users, only the first two items are necessary. The original Cadence design and its associated
model cards are protected in the encoded library.

Note that the user of the encoded library will need to add an entry with appropriate full path to define the
encoded library in one of the user's three ADSlibconfig files listed below:

$HOVE/ hpeesof / ci rcui t/ confi g/ ADSl i bconfi g
$HPEESOF_DI R/ cust oni ci rcui t/ confi g/ ADSl i bconfig
$HPEESOF DI R/ circuit/confi g/ ADSl i bconfig
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 Note
The contents of these ADSlibconfig files must contain only ASCII text. Some Windows applications may
introduce invisible encoding characters without your knowledge. These non-ASCII endcoding characters will
cause a library name to be interpreted incorrectly resulting in a failure that may be very difficult to diagnose. It
is highly recommended that you use an ASCII text editor such as vi or emacs to edit these files.

If you will deliver the library to users who will only use it on a PC, then instantiate the Cadence wrapper instance
in an ADS schematic window via Dynamic Link, and then set its Freeze Mode to yes after generating its ADS
netlist. You can create an ADS project with a design containing this instance and its design variables (in VAR1),
place the encoded library under this ADS project, and then send this ADS project to your users. You will not need
to send the Cadence library for PC (Dynamic Link Freeze Mode) users. The ADS design should contain:

<lib> _ <cell> _ <view> .dsn,

<lib> _ <cell> _ <view> .ael, and

<lib> _ <cell> _ <view> .net

Note that the <lib> _ <cell> _ <view> .net file is the Cadence wrapper circuit's Freeze Mode netlist.

Using Switch Views, Stop Views and the Hierarchy Editor

This chapter provides information on using switch views , stop views and the Hierarchy Editor . A switch view is a list
that describes the views to use and their priority. A stop view is a list that designates when to stop moving down in
hierarchy. In other words, if a view is in the switch view list, and also in the stop view list, it won't traverse any lower
in hierarchy.

RFIC Dynamic Link supports the concept of using switch views and stop views . Dynamic Link also supports Cadence's
Hierarchy Editor tool, which enables more detailed specification of switch views and stop views than the standard
Artist forms. Switch views and stop views are utilized by the netlister to expand hierarchy. The Hierarchy Editor
enables you to override the switch view list and stop view list for each instance in a schematic's hierarchy.

 Note
The information provided in this chapter refers to using the Cadence Hierarchy Editor tool with the RFIC
Dynamic Link and Advanced Design System. For more detailed information on using the Cadence Hierarchy
Editor tool exclusively, refer to your Virtuoso Analog Circuit Design Environment User Guide . For more detailed
information on expanding hierarchy in the Cadence environment, refer to the section on How the Netlister
Expands Hierarchy in your Cadence documentation.

Expanding Hierarchy with the Dynamic Link Netlister

The flowchart shown in the following figure describes the general process used by the RFIC Dynamic Link netlister to
move through and expand the hierarchy in Dynamic Link.
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Netlist Hierarchy Expansion

In the Cadence schematic window, choose the DynamicLink > Setup Options menu item to access the Setup Options
form. The Setup Options form enables you to designate a switch view list, and a stop view list.
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= Setup Options |
OK Cancel | Defaults | Apply Help
SWit[:h WEW us- ..u.| B _{= k ||||.||.||-_'J_ s |||-.-|||..q . 'I'"l
1 Stop View Lis ads :

Setting a Switch View List and a Stop View List.

Each instance in a hierarchy has a master cell, that contains a number of views for that cell. Typically views are
schematic, symbol, layout, extracted, etc. The switch view list is used to enable you to designate the priority of each
view for hierarchical netlisting. The stop view is used to designate whether a view in the switch view list should be
traversed for hierarchy. A stop view is implied to have no hierarchy. For an example of this, refer to the design
hierarchy_bottom in the library examples that is provided with the Dynamic Link installation.

In this example, the cell hierarchy_bottom has two alternate schematic views, schematic_ideal and
schematic_parasitics (see the following two figures).

RE

Alternate schematic view schematic_ideal for the example cell hierarchy_bottom .
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Alternate schematic view schematic_parasitics for the example cell hierarchy_bottom .

Two instances of the cell hierarchy_bottom have been placed in the schematic hierarchy_top (see the following figure)
in the examples .
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The schematic view for the example cell hierarchy_top

This cell is in turn placed in the ADS example project design hierarchyTest , with the schematic view chosen as the
Cadence view (see the following figure). Because there are two alternate schematics, it becomes necessary to tell the
netlister which one to use when you netlist the design hierarchy_top . The switch view list is used to tell the netlister
which one you want to use.
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The cadence cell hierarchy_top placed in ADS

The following figure shows how the setup options have been changed to designate that schematic_ideal takes priority.

= Setup Options N

0].4 | Cancel |Defaults| Apply | Help

Switch View Lis ads schematic schematic ideal schematic parasiticd

- Stop View Lis |ad5.§.
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Switch View List with schematic_ideal taking priority

Referring to the Hierarchy Expansion flowchart in the figure Netlist Hierarchy Expansion, when an instance of
hierarchy_bottom is encountered, the following occurs:

There is no ads view, so the next switch view is looked at.
. There is no schematic view, so the code continues to the next switch view.
3. There is a schematic_ideal view. Since schematic_ideal is not in the stop view list, it is opened, so that a
subcircuit can be netlisted for it.
4. With hierarchy_bottom as the top cell, now the first instance, and only instance encountered, is the analogLib res
component. The switch view list is consulted.
e Is there an ads view? Yes, there is.
e Is the ads view a stop view? Yes, it is.

N =

This means that the res component will not be opened as a schematic with hierarchy. Instead, it is meant to be a
simulator primitive. Either a built in simulator component exists, which will be used, or a subcircuit definition has
been included into the simulator that defines what the component is. A single component line is output for it,
and the netlister continues on.

The following figure shows the resulting netlist from netlisting hierarchy_top with schematic_ideal having higher
priority than schematic_parasitics . Note that the instances and subcircuit definition have been highlighted.

|

a

— | learmn?2] fgfsisrieam2id] localfusersicrscottfsimulationfhierarchy _topfads/schematic/netlist/netlist
File Help | 6

; Library name: examples

i Cell name: hierarchy hottom

i View name: schematic ideal

#ifndef inc examples hierarchy bottom_schematic_ideal
#define inc_examples hierarchy bottom_schematic_ideal

Fine exsmples hierarc ; ideal ([ in ouk)

E:RO in out R=1Z2 27K

end examples hierarchy bottom_schematic_ideal

#endif

i Library name: examples

i Cell name: hierarchy top

i View name: schematic

#ifndef inc_examples hierarchy top schematic

#define inc_examples hierarchy top schematic

define emamples hierarchy top schematic { center in out)

exanples hierarchy bottom schematic i1deal:XHIT center out
examples hierarchy bottom_schematic_ideal EIG6 in center
end examples hierarchy top _schematic

#endif
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Netlist of the example cell hierarchy_top with schematic_ideal taking priority

If you prefer to use the schematic_parasitics schematic, the hierarchy_top schematic does not need to be changed.
Instead, in the setup options form, you change the switch view list so that schematic_parasitics comes before

schematic_ideal as shown in the following figure.

Setup Options |
Help

oK Cancel | Defaults | Apply

ads schematic schematic_parasitics schematic_ideal

Switch View Lis

1 Stop View Lis ads

Switch View List with schematic_parasitics taking priority over schematic_ideal

Referring to the flowchart in the figure Netlist Hierarchy Expansion again, when an instance of hierarchy_bottom is
encountered, the switch view list is checked. There is no ads view or schematic view. There is a schematic_parasitics

view, which is not a part of the stop view list. This results in the netlister opening the schematic_parasitics view, which
is netlisted as a subcircuit. The netlister then goes on to the next instance, without ever checking for a
schematic_ideal view (in point of fact, it is not necessary to put schematic_ideal in the switch view list, since it will not
be used). The following figure shows the resulting netlist with the setup options from the previous figure.
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= fgfsisrieam2fdl localfusersicrscott/simulation/ierarchy _topfadsfschematic/netlist/netlist

File Help

i Library name: examples

i Cell name: hierarchy hottom

; Wiew name: schematic parasitics

#ifndef inc examples hieracchy bottom schematic parasitics
#define inc emamples hierarchy bottom schematic parasitics
define exanples hierarchy hottom schematic parasitics [ 1n out)
L1 netll out L=100.0p

L0 din onetS L=100, Op

cocg? netlS 0 C=2Gf

regl netld 0 C=25f

‘RO netl3 netls R=12 27K

rroontacty netlS netll Re3

rrcontact]l neth netld Red

end examples hisrarchy bottom_schematic_parasitics

#endif

; Libracy name: examples

i Cell name: hierarchy top

i View name: schematic

#ifndef inc_exmamples _hierarchy top schematic

#define inc_emamples hierarchy top schematic

define examples hierarchy top schematic ( center in ouk)

mm=moob e

examples hierarchy hottom schematic parasitics:XIT center ou
examples_hierarchy bottom_schematic_parasitics: XIE in center
end examples hierarchy top schematic

#endif

Netlist of example hierarchy_top with schematic_parasitics taking priority

In all of the above examples, the stop view list was set to ads . This is the recommended stop view list to use for the
RFIC Dynamic Link netlister. If you consult the netlist flowchart in the figure Netlist Hierarchy Expansion, you will

notice that it is not necessary for the stop view to be ads , any view can be used to designate that a part is a

primitive. In the future, the RFIC Dynamic Link netlister will be expanded, so that alternate simulation definitions can
be used based on which stop view is encountered (e.g. ads vs. ads_ptolemy). At present, the netlister always uses the

simulation definition defined for ads in the cell's CDF, no matter which stop view is encountered.

Using the Hierarchy Editor with RFIC Dynamic Link

The Hierarchy Editor is a stand alone Cadence tool that enables switch views and stop views to be designated for each
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instance in a schematic hierarchy. For information regarding the hierarchy editor in general, consult your Cadence
Hierarchy Editor User Guide .

When the Hierarchy Editor is used, a cell view specific to that tool is generated. The view itself is actually a text file,
and cannot be opened directly in anything other than the Hierarchy Editor. The default view name for the Hierarchy
Editor is config . A config view has a top cell view that it points to. All other information regarding switch views and
stop views is then created based on the top cell view that is being pointed to. It is not necessary for the Hierarchy
Editor view to be a part of the cell that it is pointing to, although in most cases this will be the simplest way to
organize things.

The following figure displays the Create New File form used to create a Hierarchy Editor view. In this case, a Hierarchy
Editor view is being made for the example cell hierarchy_top (see the figure The schematic view for the example cell
hierarchy top). The goal is to set up this config view so that, during netlisting, it is possible to specify that one
instance of hierarchy_bottom should use the schematic_ideal view, while the other instance uses the
schematic_parasitics view.

=| Create New File |

0].4 Cancel | Defaults Help

Liby Name examples

Cell Mane hierarchy top

cont 10

Views Mainie

Tool Hierarchy - Editor

Library path file

4|ocalfusers/oracott/exanplescds. 1ik -

Creating a Hierarchy-Editor view

After the new view is created, the Hierarchy Editor tool is started. For a new view, the New Configuration form
appears as shown in the following figure.
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] i)

—| Hew Configuration

—Top Cell
Library: |examples Cell: hierarchy top View: |

—Global Bindings

Library List: |

View List: |

Stop List: |

—Description

T OK Cancel Use Template... Help 7

New Hierarchy Editor Configuration

Notice that all fields are left blank initially, except the Library and Cell fields which were specified in the Create New
File form shown in the figure Creating a Hierarchy-Editor view. At this point, it is necessary to designate the top cell
view, as well as the switch view list and stop view list. The Library List can normally be left blank. For more
information on the Library List field, refer to your Cadence Hierarchy Editor User Guide .

It is necessary to fill in the Top Cell view. The top cell view should be a standard CDB view. From the standpoint of
RFIC Dynamic Link, this means either a view that is edited with Virtuoso-schematic, or Virtuoso-layout. If you use a
layout view, it should be an extracted view of some sort (i.e. the layout will contain connectivity and instances that
can be traced back to schematic equivalents). Typically, you will put in either schematic or extracted as the view
name.

The Library List, View List, and Stop List can be filled in by using a template. Templates contain default settings for
particular simulators. To select a template, click the Use Template button in the New Configuration form. The Use
Template form appears.
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= Use Template T

Template

Hame: ads - |

From File: liierEd]. tor ftemplates fads

1 ok | cancel | apply | Hep |;

In the following figure, the ads template was selected, which has filled the View List in as ads schematic extracted ,
and the stop list as ads . These names represent the default view names for the tools that the Dynamic Link netlister
supports. During netlisting, the view list and stop list will override the switch view list and stop view list that is
specified using the Dynamic Link setup options dialog. Also, the Hierarchy Editor view will not consult the Dynamic
Link options dialog to fill in the switch view list or stop view list, it is a completely separate tool, and must be set up
independently.

—| Mew Configuration

—Top Cell

Library: |exanples Cell: hierarchy top View: myView

—Global Bindings
Library List: myLib

Views List: |au:13 schematic extracted

Stop List:  Jads

—Description

Default template for ADS

Hote:
Please remember to replace Top Cell Library., Cell, and View
fields with the actuval names wvsed by your design.

T 0K Cancel Use Template... Help 7

New Hierarchy Editor Configuration, using ADS template

When the new configuration is accepted, the main Hierarchy Editor window will be filled out. The main window shows
the current Top Cell setting, as well as the global Library List, View List, and Stop List. In addition, the Hierarchy
Editor will expand the hierarchy of the top cell, and show which views will be used for each instance within the top
cell's hierarchy. When nothing has been overridden, the expansion will follow the flow chart shown in the figure Netlist
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Hierarchy Expansion. The following figure shows how the example hierarchy_top schematic view was expanded using
the global bindings. The Cell Bindings shows the two cells that were found, hierarchy_top and hierarchy_bottom . You
may need to select View > Update to see the hierarchy_bottom Cell in the Cell Bindings list. The view found for
hierarchy_top was schematic, this is a special case. Because it is the top cell, the library, cell, and view found will
always be the same as what is specified for the top cell, regardless of the view list and stop list. The cell
hierarchy_bottom says that the view found was **NONE**. Because hierarchy_bottom has the views schematic_ideal
, schematic_parasitics , and symbol , this is accurate. None of hierarchy_bottom 's views are in the global view list. If
netlisting were attempted at this point, an error would result. The cell bindings give a visual indication of this.

| Cadlence( hierarchy editor: New Configuration i
File Edit View Plug-Ins Help
DEE KB o~ S0 EnB
—Top Cell
Library: |exa.mples Cell: lhieraru:hy_tu:up View: |schematic Open |
—Global Bindings
Library List: |
Viewr List: |ads schematic extracted
Stop List:  jads
—Cell Bindings
Library | Cell | WView Found | View to Use  [Inherited View List
exanples hierarchy bo. .. *+*NONE++ ads schemati. ..
exanples hierarchy top schematic ads schemati. ..
—Messages .................................................................................................................................
COPYRIGHT @ 1997-1999 CRDENCE DESIGN SYSTEMS INC. ALL |=
EIGHTS RESERVED. =
This Cadence Design Systems program and online
documentation are |
"|Ready... Filters OFF |CDBA |
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Initial Hierarchy Editor Main Window

In the following figure, the global view list has been changed, so that it now includes schematic_ideal and
schematic_parasitics . The cell bindings are now updated to reflect the new hierarchy expansion. Because
schematic_ideal precedes schematic_parasitics in the global view list, the expansion now says that, for
hierarchy_bottom , schematic_ideal is the view found. Also, the analogLib res cell has been found, because
hierarchy_bottom was expanded. This expansion happens because schematic_ideal is not listed in the global stop view
list. Since res has an ads view, the expander decides that ads will be the view used for the res cell.

= Cadence() hierarchy editor: (examples hierarchy _top config) + | o
File Edit View Plug-Ins Help
Dl e o 20 EnB
—Top Cell
Library: |exa.mples Cell: lhieraru:h?_tnp View: |schematic Open |
—Global Bindings
Library List: |
View List: |au:13 schematic schematic_ideal schematic_parasitics extracted
Stop List:  Jads
—Cell Bindings
Library | Cell | View Found | View to Use [Inherited View List
analoglLib res ads ads schemati. ..
examples hierarchy_bo. .. schematic_ideal ads schemati. ..
examples hierarchy_top schematic ads schemati. ..
~Messages
EESTEICTED EIGHTS NUTLICE (ZHOET FOEM) -
Use/reproduction/disclosure is subject to restriction |
set forth at FAR 1252.227-19 or its equivalent. B
Created new configuration. —
Nafanlt srdiswr licetr oot +04 "osde sabhematrisn caheamatio 4daal |7
"|Ready... Filters OFF |CDBA |
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Hierarchy Editor with schematic_ideal in Global View List

So far, all of this demonstrates is that the Hierarchy Editor can be used to see how expansion would occur for a
specified view list and stop list. That's nice, but it doesn't add any functionality over what was provided by the Setup
Options form. What is needed is a way of overriding the view list. As it happens, the Hierarchy Editor is capable of

doing just that.

In the following figure, the switch view list has been changed, so that schematic_parasitics is now first in the switch

view list.
= cadencel hierarchy editor: (examples hierarchy_top config) =t
File Edit View Plug-ins  Help ]
T DERB B «~ &0 EmH
CTep Cell e
Library: |sxanples Cell: haerarchy_top View: |[schenatic Dpen
Global Bindings
Library List: |
View List:  |ads achematic achematic_parasitics schematic_ideal extracted
Stop List:  [ads
Cell Bindings
. Library . Call | View Found View to Use | Inherited View List |
analoghib ind ads ads schematic schemat. . .
analoglib res ads ads schematic schemat ..
emamples hierarchy bottom schematic_ideal schematic_ideal ads schematic schemat. .|
examples hierarchy_bottom schematic_parasitics ads achematic achemat. . . |4
Instance Bindings (examples hierarchy _top schematic)
Instance | Libyrasy | Cell [ View Found | View to Use Inherited View List
I6 examples hiecarchy bottom schematic_ideal schematic_ideal ads schematic sch. ..
I7 exanples hisrarchy botton schematic parasitics ads achematic sch. ..
2= T
EBound instance "I6" in cellview {examples hierarchy _top schematic) to wview =
"schematic_ideal". ||
Saved the current configuration. 7]
-

[Reay...

Filters OFF |COBA |

Hierarchy Editor with an instance view overridden

Notice that the instance bindings table is now displayed. When hierarchy_top is selected, the instance table shows all
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of the instances in the schematic. As it happens, hierarchy_top contains two instances of hierarchy_bottom , 12 and I3
(see the figure The schematic view for the example cell hierarchy top). If the global switch view list is used, both
instances will expand to use schematic_parasitics. In this case, we have chosen to change the default behavior. In the
view to use field, schematic_ideal has been specified. The view found field now specifies schematic_ideal instead of
schematic_parasitics . Now, when the cell hierarchy_top is netlisted with this configuration, it will be necessary to
expand the hierarchy for both schematic_parasitics and schematic_ideal. The netlister keeps track of the proper
component name for the netlist.

The figure below shows the resultant netlist that is created using this configuration.
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Netlist using configuration detailed in figure 10-15.

An alternate way of viewing the overridden expansion is to look at the tree view, as opposed to the cell and instance
binding tables. This is shown in the following figure.
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Tree view of hierarchy_top configuration with I2 set to use schematic_ideal.

The Hierarchy Editor makes it possible to override the hierarchy expansion on any instance. It is also possible to
override the global switch view list on any instance. This allows you to change the expansion options for one tree of a
hierarchy, while leaving all other trees intact.

Placing the config view in ADS

In order for a Hierarchy Editor configuration to be used during netlisting, it is necessary to place the Hierarchy Editor
view in the ADS schematic. This is done by selecting the DynamicLink > Instance > Add Instance of Cellview menu
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option in ADS. When the Select Design dialog appears, set the view name to the Hierarchy Editor view. In the
hierarchy_top example, this is done by selecting the view name config (see the following figure).

—| Select Design |
oK Cancel Defaults Help
Lib Hame examples
cell Hame hierarchy_top
View Mame _
schematic
7 Browsse b

Selecting the Hierarchy Editor view for placement in ADS.

A new symbol is generated for the config view, and you are then be able to place it. In the hierarchy_top example, the
symbol graphics are inherited from the hierarchy_top cell. This results in a symbol that looks identical to the

hierarchy_top schematic symbol for ADS. However, this symbol is now linked to the Hierarchy Editor view, as opposed
to being linked to the schematic view.
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Hierarchy Editor test bench with config view placed

The previous figure shows the new test bench where the config view is used instead of the schematic view. If the
Cadence instance is selected, and you descend into it's hierarchy, the top cell view for the configuration will be
opened. The configuration being used will be indicated in the title of the schematic/layout window that is opened. The
following figure shows the hierarchy_top schematic that will be opened. Note that the title indicates that the Config in
use is examples hierarchy_top config . This is important, as it means that hierarchy expansion will obey that particular

configuration.

Note also that the top cell view does not need to remain constant. Thus, if you wish to do a simulation where the top
cell schematic is used, and then do another simulation wherein an extracted view is used, you do not need to make
multiple ADS symbols and then swap them. You can make a single Hierarchy Editor configuration, and swap the top
cell view name. Once the test bench is set up, you do not need to modify anything in ADS to change your simulation.

For the hierarchy_top example, a simulation would result in the netlist shown in the figure Netlist using configuration
detailed in figure 10-15., based on the configuration shown in the figure Hierarchy Editor with an instance view

overridden.
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Schematic window attached to a Hierarchy Editor configuration

Troubleshooting RFIC Dynamic Link

This chapter provides troubleshooting information that can help you resolve common problems is also provided in this

appendix.

All errors, warnings, and other messages are directed to the Cadence CIW. When a new message is written to the
CIW, the window is raised to the top of your window stack so that new messages are always visible. Error messages
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may also be logged in a file, idf.log.

Some known problems and solutions are listed in the following section. You may find this information helpful in
determining how to resolve a particular problem however, if you're unable to resolve a problem with the RFIC
Dynamic Link using the information provided, contact Agilent EEsof EDA customer support.

Known Problems and Solutions

Problem: By default, ADS does not create its own private color map, which may lead to unpredictable color behavior
and/or menu buttons in place of icons.

Solution: Try one or more of the following:

e Set HPEESOF_COLORMAP = private in the ADS configuration file $HOME/hpeesof/config/hpeesof.cfg or
$HPEESOF_DIR/config/hpeesof.cfg .

e Set CDS_NUM_USER_COLORS = 16 in your .profile or .cshrc file.

¢ Restart Dynamic Link after exiting all other color-intensive applications.

Problem: When you remake a symbol, even when the old symbol is deleted, ADS does not allow you to create another
symbol with the same name.

Solution: Click the instance in the ADS schematic window, then choose DynamicLink > Instance > Update
Instance of Cellview . If the problem persists:

e Delete the <lib> _ <cells> _ <view> symbol in the ADS Design.

e Save the ADS design.

e Exit ADS.

e Delete all the <ADS_proj_dir> /networks/ <lib> _ <cells> _ <view> .* files.
e Restart ADS.

Problem: *Error* Could not find " nlpglobals/ads' in library "basic'. The nlpglobals' cell view is required. Netlisting
aborted. This error occurs either while netlisting in Analog Artist or after clicking Simulate in the ADS.

Solution: Copy the spectre view in the nlpglobals cell to create an ads view.
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Problem: There is no distinction between a design variable X from Design A and a design variable X from a different
Design B .

Solution: Use unique design variable names for different designs, unless you really intend them to be the same
variable, in which case there's no problem.

Problem: Symbol generation via Cadence symbol duplication does not reproduce arcs.

Solution: Use line segments instead of arcs.

Problem: Could not spawn master program . This message appears in your parent terminal window upon attempting
to use the ADS link.

Solution: Ensure that $ HPEESOF_DIR/ bin is in your PATH and that $ HPEESOF_DIR/ bin/idfmp is a valid
executable. If this does not work, ask your UNIX System Administrator to reboot your system or otherwise
determine if a socket address is in use.

Problem: The UNIX environment does not set up properly when an in-house script for DFII is used.

Solution: Starting DFII using an in-house script may not set up the UNIX environment properly for RFIC Dynamic
link. Work with your System Administrator to ensure that you understand what environment variables need to be
set in the in-house script and modify your script accordingly.

Installation and Use Checklist

This section provides a checklist that can be used to help you resolve problems with RFIC Dynamic Link. You can use
the questions below to help determine what the cause of a particular problem might be.

e Is RFIC Dynamic Link installed? If yes, the following files/directories should exist:
° $HPEESCOF_DI R/ bi n/ i df
° $HPEESCOF_DI R/ bi n/ i df np
° $HPEESOF_DI R/ ci rcui t/ synbol s/ i df Synbol . dsn
° $HPEESCF_DI R/ i df / ael /
° $HPEESCOF_DI R/i df /skill/5.0.0/ads.ini
° $HPEESCOF_DI R/i df /skill/5.0.0/ads. al
° $HPEESOF DI R/ i df/skill/5.0.0/ads. cxt
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° $HPEESOF DI R/idf/skill/4.4.6/ads.ini
° $HPEESOF DI R/idf/skill/4.4.6/ads.al
° $HPEESOF DI R/idf/skill/4.4.6/ads.cxt
° $HPEESOF DI R/idf/skill/4.4.5/ads.ini
° $HPEESOF DI R/idf/skill/4.4.5/ads.al
° $HPEESOF DI R/idf/skill/4.4.5/ads. cxt

° $HPEESOF_DI R/ i df / confi g/

° $HPEESOF_DI R/ cdsl i bs/ 5. 0. 0/ anal ogLi b/

° $HPEESOF_DI R/ cdsl i bs/ 4. 4. 6/ anal ogLi b/

° $HPEESOF_DI R/ cdsl i bs/ 4. 4. 5/ anal ogLi b/

° $HPEESCF_DI R/ cdsl i bs/ 5. 0. 0/ basi ¢/

° $HPEESCOF DI R/ cdsl i bs/ 4. 4. 6/ basi ¢/

° $HPEESCF DI R/ cdsl i bs/ 4. 4. 5/ basi ¢/

° $HPEESOF DI R/ i df / exanpl es/
Is Cadence configured for RFIC Dynamic Link? Run idfConfigCadence -h (RFIC Dynamic Link 2002) or
$HPEESOF_DIR/idf/config/configCadence -h (RFIC Dynamic Link 2001).
Is HPEESOF_DIR set? Run idfenv (RFIC Dynamic Link 2002 or later).
Is $HPEESOF_DIR/bin in your $PATH?
Is icms in your $PATH?
Are cds_root and cdsd both in your $PATH?
Is PATH, AGILEESOF_LICENSE_FILE or LM_LICENSE_FILE set in ~/.cshrc, ~/.profile, ~/.kshrc, or other scripts
sourced by these scripts? Execute echo $SHELL or finger to display your login shell.
Is your ADS license.lic file in the default $HPEESOF_DIR/licenses/ directory or is it set in
$AGILEESOF_LICENSE_FILE?
Is there a trans_idf (RFIC Dynamic Link 2002) or Idf_c_interface (previous versions of RFIC Dynamic Link)
feature in the ADS license.lic or license.dat file? Has this feature expired?
Which item in the following list defines the Cadence license file?

° $CDS LI C FILE

° <Cadence_install_dir>/share/license/clients

°© $LM LI CENSE_FI LE

° <Cadence_install_dir> /share/license/license. dat
Does the Cadence license contain the valid features listed below:

° QASI S Sinulation_lnterface

° 34510

© 300 (only if using |ayout)
Are all seats of the above ADS and Cadence licenses taken?
Does $HPEESOF_DIR/idf/config/.cdsinit exist?
Is $HPEESOF_DIR/idf/config/.cdsinit loaded in <Cadence_installation_directory>/tools/dfII/local/.cdsinit?
If the above file does not exist, is $HPEESOF_DIR/idf/config/.cdsinit loaded in ./.cdsinit?
If the above files do not exist, is $HPEESOF_DIR/idf/config/.cdsinit loaded in $HOME/.cdsinit?
If none of the .cdsinit files exists, cp $HPEESOF_DI R/ i df / exanpl es/ . cdsinit ./
Does the .cdsinit file that loads RFIC Dynamic Link's .cdsinit file change PATH, CDS_INST_DIR,
LM_LICENSE_FILE?
Does the icms , icfb , or msfb script change your PATH or LM_LICENSE_FILE? Run idfenv at the UNIX prompt,
start Cadence, enter system("idfenv") in the Cadence CIW, and then compare the output of idfenv before and
after the Cadence script is executed.
What is in the ./cds.lib ? Do all of the libraries appear in blue in Cadence Library Path Editor form? If you are
using the Agilent Technologies version of analogLib and analogLib appears in red, check to see if
IDF_CDS_VERSION is used in cds.lib and it is not defined in the effective .cdsinit file.
Does an ads view exist for the components in use? Use the Cadence Library Manager to check to see if the

133



Advanced Design System 2008

analogLib/cap cell contains an ads view.

e Does the ads simInfo section exist in the Cadence Component Description Format (CDF) for the components in
use? Is all of the information in the ads simInfo correct? Use the Edit Component CDF form ( Tools > CDF > Edit
) or cdf Dunp(“<lib>" "/tnp/<cell> cdf" ?cell Name "<cel | >" ?edit t) function to see if the ads simInfo
section exists in a cellview (leave out the '?cellName "<cell>"' for dumping the library CDF instead of the cell
CDF).

e Does the ads view exist for the global cellview nlpglobals under the basic library? If not, open the Cadence
Library Manager, select symbol or spectre view, press middle mouse button, choose Copy from the popup list,
and copy the symbol or spectre view to the ads view.

e If RFIC Dynamic Link failed to create an ADS netlist, can the Cadence netlister create a spectre netlist? Select
Tools > Analog Environment from Cadence schematic window, select Setup >Simulator/Directory/Host from the
Affirma DE window and ensure that spectre is selected as the Simulator, then select Simulation > Netlist >
Create to generate a spectre netlist.

¢ Has the Cadence symbol changed since the instance was placed in ADS? Select the instance in the ADS 2002
schematic window, then choose DynamicLink > Instance > Update Instance to Cellview to recreate ADS symbol
and remove the <Cadence_project_dir> / <cell> / directory to force Dynamic Link to regenerate the netlist. With
RFIC Dynamic Link 2001, remove <lib> _ <cell> _ <view> .* under <ads_prj> /networks/, delete
<Cadence_project_dir> / <cell> , then delete the instance in the ADS schematic and replace the instance.

¢ Is the de_sim.cfg file under the ADS project directory corrupted?

¢ Is there any local ADS customization in $HOME/hpeesof/config/de_sim.cfg? Search for AEL .

¢ Is there site-wide ADS customization in $HPEESOF_DIR/config/de_sim.cfg or custom/config/? For example, the
line that reads "+ dynamic_link" in the de_sim.cfg file includes the file dynamic_link.cfg .

¢ If some components require models, are the associated ADS model files included with the modelLibraryFiles
parameter in the idfinclude component?

e For debugging purposes, if the ./idf.log file appears to be shorter than expected for debugging, is
IDF_DEBUG_MODE set to TRUE in the UNIX environment?

e If the current GMT in ./idf.log and ~/CDS.log do not match, is there a lock on ~/CDS.log ? Is it ~/CDS.log.1 or
~/CDS.log.2 that is the Cadence log file for this session?

¢ Are there any suspicious options set in any of the following four Cadence .cdsenv files?

° <cds> /tools/dfll/etc/tool s/ <application> /. cdsenv

° <cds> /tools/dfll/]ocal/.cdsenv

° $HOVE/ . cdsenv

° ./.cdsenv

The above files contain user preference options.

o If DC Operating Point Back Annotation failed, check the following in the order given:

° <ads_prj> /data/ <ads_dsn_name> .ds

° <ads_prj> / psf/ <lib> {} _<cell> {} _<view> /dcOpl nfo.info

° <Cadence_proj_dir>/ <cell> /adsDL/ <view> / psf/dcOplnfo.info

° View the contents of the last file to see if there are any reasonable numbers.
e If DC Back Annotation failed, check the following in the order given:

° <ads_prj> / psf/ <lib> {} _<cell> {} _<view> /dcOp. dc

° <Cadence_proj_dir>/ <cell> /adsDL/ <view> [ psf/dcOp. dc

° View the contents of the last file to see if there are any reasonable numbers.

Command Reference for RFIC Dynamic Link
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This appendix describes the function of each menu selection provided in Advanced Design System ( DynamicLink
Menu), the Cadence Schematic window ( Tools > ADS Dynamic Link & DynamicLink Menus) and the Cadence CIW (
Tools > ADS Dynamic Link Menu item) while using the RFIC Dynamic Link.

ADS Schematic window DynamicLink Menu

Instance > Add Instance of Cellview...

Add a symbol of a Cadence design to the current Advanced Design System Schematic window. For example, see
Adding a Symbol of the Cadence Cellview.

Instance > Update Instance of Cellview

Discards <ads_prj> /networks/ <lib> _ <cell> _ <view> .dsn and <ads_prj> /networks/ <lib> _ <cell> _ <view>
.ael, regenerates an ADS symbol from the Cadence symbol, and deletes the $HOME/simulation/ <cell> directory.
Deleting the $HOME/simulation/ <cell> directory forces ADS to recreate a new netlist the next time ADS requires a
netlist for a Cadence subcircuit.

Design Variables > Get Design Variables

Add design variables from a Cadence Cellview to an Advanced Design System Schematic window. For example, see ___
Adding Design Variables.

Design Variables > Update Design Variables to Cellview

Update the value of the Advanced Design System schematic design variables to the Cadence Cellview. For example,
see Updating Cadence Design Variables.
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Add Netlist File Include

Enables duplication of the Definition, Stimulus, and Model Library File include used in Cadence/Affirma. For more
information, refer to Adding Model Files.

Top-level Design Netlist

Generate and display the Advanced Design System subnetwork netlist for the Cadence design displayed in a particular
Composer window. For example, see Viewing Netlists from Advanced Design System.

Annotate > Annotate DC Solution to Selected Cellview

Display the DC node voltages, generated by the ADS simulator, on the Cadence Schematic Window. For example, see
Performing a DC Simulation.

Annotate > Annotate Operating Points to Selected Cellview

Display the DC operating points, generated by the ADS simulator, on the Cadence Schematic Window. For example,
see Annotating DC Operating Points to a Selected Cellview.

Set Cadence Project Directory

This is the Cadence project directory and not the ADS project directory. The subcircuit netlist for a Cadence cellview is
saved as:

<Cadence_Proj_Dir> / <cellName> /adsDL/ <viewName> /netlist/netlist

The Cadence subcircuit netlist will be merged with the top-level ADS netlist under the ADS project directory and used
for Dynamic Link simulation. DC back annotation data for Dynamic Link is saved in the PSF files under:
<Cadence_Proj_Dir> / <cellName> /adsDL/ <viewName> /psf
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Close Connection

Closes ADS and terminates the link between Cadence and ADS. For example, see Ending the Session.

Cadence Schematic Window DynamicLink Menu

Setup Options ...

Set parameters such as Switch View List and Stop View List. The default values for this dialog are obtained from the
configuration file. For more information, consult your Cadence documentation.

New Design ...

Select a new design to include in the Cadence Cellview. Set parameters such as Library Name, Cell Name and View
Name. The dialog also offers a browse feature to search for existing designs. For more information, consult your
Cadence documentation.

Design Variables ...

Modify the Component Description Format (CDF) information for a component so that it works with ADS. For example,
see Using Design Variables. For more information, consult your Cadence documentation.

Save State ...

Save a state of a simulation. The simulation name, variables, model path, outputs and environment options are all
available selections. For more information, consult your Cadence documentation.

Load State ...
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Load an Analog Artist state. For more information, consult your Cadence documentation.

Subcircuit Netlist

Generate and display the Advanced Design System subnetwork netlist for the Cadence design displayed in a particular
Cadence Schematic window. For example, see Viewing Netlists from the Cadence Schematic Window. For more
information, consult your Cadence documentation.

© Note

If the Dynamic Link pull-down menu does not appear in the Cadence Virtuoso Schematic window, choose Tools
> ADS Dynamic Link > Add Dynamic Link menu to all schematic windows in the Cadence Command Interpreter
Window (CIW).

CIW Tools > ADS Dynamic Link Menu Item

There are two additional ADS sub-menu items accessible from the Cadence CIW.

Start ADS Dynamic Link

Launch Advanced Design System without opening a Cadence cellview.

Add Dynamic Link menu to all schematic windows

Adds the Dynamic Link menu item to the Cadence schematic window with only the Subcircuit Netlist menu item
enabled. This option enables you to create a Cadence subcircuit netlist without launching Advanced Design System.

Glossary for RFIC Dynamic Link

ADS (Advanced Design System)
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Advanced Design System is an EDA System for high-frequency circuit and system design.

AEL (Cadence Analog Expression Language)

In the Cadence context, AEL is the syntax and API (available in Skill or C) to support full or partial expression
evaluation for repetitious circuit simulation.

AEL (ADS Application Extension Language)

This is a C-like interpretive programming language to configure, customize and enhance the Advanced Design System
design environment.

Affirma Analog Circuit Design Environment

Cadence's interface for analog circuit design and analysis in versions 4.4.5 and 4.4.6.

bindkeys

Settings used to map individual keystrokes to a particular function within the software.

callback

A function or expression that gets evaluated when certain events occur; for example, clicking on a menu item.

CDF (Component Description Format)

The CDF is Cadence's mechanism to interactively define and evaluate parameters and attributes for individual
components and designs.

CIW (Command Interpreter Window)
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The CIW is Cadence's command window.

colormap

Indexed color table where each entry is a combination of R, G, and B pixel intensity values for UNIX X-windows
display. Table size (number of colors) per software application is limited by the number of display bits per pixel,
commonly eight.

DFII (Design Framework II)

Cadence's overall IC design environment.

EDA (Electronic Design Automation)

Software and services that give customers a distinct advantage by improving time-to-market, quality and productivity
in the design of electronic products.

GUI (Graphical User Interface)

The interface between the user and the application.

HB (Harmonic Balance Simulation)

An iterative method of analysis that is based on the assumption that for a given sinusoidal excitation, there exists a
steady-state solution that can be approximated to satisfactory accuracy using a finite Fourier series.

iPar()

The function used in an AEL expression for a parameter which is a function of another parameter of the same
instance. For example, for MOSFET instances we might use AD=iPar("w")*5u.

IPC (Inter-Process Communication)
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The protocol for passing messages between two or more processes.

OASIS

Open Analog Simulation Integration Socket. The procedural interface for simulator integration into the Cadence
simulation environment.

optimization

Mechanism by which a simulator finds the optimal value of a global parameter within a user-supplied range of values.

OS (Operating system)

Such as HP-UX, Solaris, or Win2000.

pPar()

The function used in a Cadence AEL expression for a parameter which is a function of some parameter of the parent
instance. For example, for CMOS inverters we might use W=pPar(wp) (where wp is a parent instance parameter) on
one of the pull-up FETs, enabling use of the same inverter symbol for different size inverters.

PSF

Parameter Storage Format. This is a Cadence-defined file format for storing complex structured data.

Ptolemy

A design environment that supports simultaneous mixtures of different computation models. Ptolemy, named after the
second-century Greek astronomer, mathematician, and geographer, was developed at the University of California at
Berkeley. For detailed information, refer to the ADS Ptolemy Simulation documentation.

RF Design Environment (RFDE)
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RF Design Environment provides a more tightly integrated EDA solution that enables RF/mixed-signal IC designers to
simulate their designs directly in the Cadence environment using the ADSsim RF simulator. This enables the RF/MS IC
customer to take advantage of complementary features provided by both Agilent Technologies and Cadence Design
Systems.

RFIC Dynamic Link (Dynamic Link)

RFIC Dynamic Link (Dynamic Link) for Cadence is an EDA framework integration software product. The product
enables both tops-down and bottoms-up design and simulation in Advanced Design System(ADS) using IC designs
from the Cadence database. RFIC Dynamic Link is based on IPC rather than data file translation maximizing data
integrity and ease of use.

SKILL

Cadence's C/lisp-like interpretive programming language for framework and database integration.

testbench

Top-level schematic used to analyze a sub-circuit using a circuit simulator.

tuning

Mechanism by which a simulator can quickly re-simulate a circuit using new values for a number of parameters
without having to re-input the netlist and recreate its data structures.

Virtuoso Analog Design Environment

Cadence's analog design and simulation environment for the Virtuoso custom design platform. It is a task-based
environment for simulating and analyzing full-custom, analog, and RF IC designs.
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