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- Example
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- Syntax:

- Example

Using LineCalc

LineCalc is an analysis and synthesis program for calculating electrical and physical parameters of single and coupled

transmission lines.

LineCalc can communicate directly with the circuit simulators. You can send parameter data for selected circuit design
elements, along with data on any associated substrates or walls, directly from the simulator to LineCalc. After the
element parameter values are calculated, you can update the associated schematic or layout circuit design in the
active simulator immediately with the LineCalc results. Or you can place a newly synthesized component into the

Schematic window.

Using dialog boxes, you can make changes in parameter values of your transmission lines and see the results of those
changes on the screen. You can use LineCalc like a spreadsheet, in the sense that a change in one value brings about
a recalculation through all related values when you choose the appropriate Calculate button.
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You can print results, save results to an element data file, or instantly update a schematic or layout in a circuit design.

 Note

LineCalc cannot be used with the signal processing simulators.

The Basic LineCalc Process

e Select a LineCalc component.

e Select one or more independent parameters for calculation.
e Change default parameter values, as necessary.

e Perform the analysis or synthesis.

e Update the design, if applicable.

Key Terms

Analysis Calculation of electrical parameters from physical data.
Synthesis Calculation of physical parameters from electrical data.
Shared Parameters Parameters common to a group of components and required for both analysis and synthesis.

LineCalc File (<filename>.Ics ) The data file created when results from a LineCalc analysis or synthesis of a
component are saved. The file contains information about the component's parameters, associated shared
parameters, frequency, and units to support design iteration.This data file is created when you save results from a
LineCalc analysis or synthesis of a component. The file contains information about the component's parameters,
associated shared parameters, frequency, and units to support design iteration.

Starting LineCalc

Before running LineCalc, you should be familiar with the basic operation of the ADS design environment. (For details,
refer to the Schematic Capture and Layout manual.)

To run LineCalc from within the Design Environment:

e From the Schematic window, choose Tools > LineCalc > Start LineCalc .

To run LineCalc in stand-alone mode:
e On the PC, from the Start menu choose Programs > Advanced Design System 2006A > ADS Tools > LineCalc .
¢ On UNIX, in a terminal window, type linecalc .
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 Note
Starting LineCalc in this manner assumes you have established a path to the ADS installation directory. If you

have not, type <install_dir>/bin/linecalc , where <install_dir> represents your complete installation path. For
details on establishing a path statement, refer to Chapter 2 of the UNIX and Linux Installation manual.

When LineCalc is launched, the LineCalc window appears, as well as the Message/Status window. The
Message/Status window displays messages about the status of the current process as well as warning messages.

The LineCalc Window

The LineCalc window is divided into several regions.
e Title Bar, Toolbar, and Menu Bar
e Component Display

e Shared Parameters Display

e Parameters Display

e Results Display

e Status Bar

The following sections describe these regions.

Title Bar, Toolbar, and Menu Bar

The Title bar displays the application name and the name of the active data file (or untitled if no data file is associated
with the data being displayed).
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—Menu bar r Title bar
=] Line Calc Auntitied |
File Simutation Options Help
Je B8
Toolbar

The Toolbar contains buttons for frequently-used commands.
The Menu bar displays the available menus and commands.

Component Display

The Component display lists the currently-selected component type and ID. You can choose a different component
type and ID to analyze or synthesize, by the Selection arrow .

Component
pra MLIN <[ MLIN: MLIN_DEFAULT «

Select a component type and |1D J

Shared Parameters Display

The Shared Parameters display consists of the Substrate Parameters and the Component Parameters sections. The
parameters shared by all components with substrate parameters are listed in the Substrate Parameters area. The
parameters shared by components with frequency or mwall parameters are listed in the Component Parameters area.
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Substrate Parameters

ID  MSUB_DEFAULT

Er 600 N/A !
Mur 1.000 /A f
H 0. 000 mil !
Hu 3 0e+34 mil 3
T 0.150 mil !
Cond . 1e7 /A f

Component Parameters

Freq 10. 00d GH=
walll mil
WallZ mil

Parameters Display

The Parameters display lists the physical and electrical parameter values of the currently-selected component.
In the Physical section, the Fix button indicates the status of the associated physical parameter:

o If the button indicates Fixed, the adjacent parameter is fixed during synthesis

o If the button indicates Fix, the adjacent parameter is updated during synthesis
You can compute the physical parameter values from electrical data by clicking Synthesize .
and clicking Analyze computes the electrical component parameters from physical data.
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Physical
. 2
W 25 000 mil fix , f:“_'ﬁ:
| J)" L f.r.r ‘r],:_?
L 100. 00d mil Fis / Fa 4
- ! i
- . Al 4
: HiA [
: { [t
. . L}
?{-é:__f r‘%\
synthesize Analyze
A y — Compute parameter values
Electrical
20 47. 250 Ohm
E_Eff 230. 000 deg
i HiA
"" Efj r‘%
v ?lg;’; F

Results Display

The Results display shows the parameter values that change as a result of the synthesis or analysis. These are
displayed as the calculated results.

Calculated Results

K._Eff = 6.400
A DB = 0.070
SkinDepth = 0.000 m

Status Bar

The Status Bar at the bottom of the window shows the status of your displayed data. When you have changed a
parameter value without recalculation (synthesis or analysis), the message appears: Parameter(s) modified - Values
are not consistent. After you perform the calculation, the message appears: Values are consistent .
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Parameter (s) modified - ¥alues are not consistent

LineCalc Menus and Commands

This section describes the LineCalc Menus and Commands. The LineCalc User Interface has the following menus:

File Menu
Simulation Menu
Options Menu
Help Menu

Changing the Default Data Directory

The LincCalc program reads the files from and save these to your program startup directory, unless you change the
default directory.
To use an alternate directory during your current program session:

1. From the Synthesis/LineCalc window, choose File > Change Dir.
2. Use the displayed dialog box to specify a directory path (other than the program startup directory) for reading
and saving files until you exit the program.

Resetting the Display
You must clear any currently active work before selecting or importing components for a new synthesis or analysis.

e To save your work, choose File > Save ; then choose File > New .
e To cancel a design in progress and start over, choose File > New .

 Note

Choosing New displays the default component.

Opening a Component File

After resetting the display, you can activate a component that you want to synthesize or analyze in one of these ways:

12
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e By opening a previously-saved LineCalc component file, or
e By importing components from the active schematic or layout design

 Note

When you activate LineCalc, the last-saved component is displayed. Clear the display before opening a
component file (see Resetting the Display).

Opening a Previously-Saved LineCalc Component File

You can activate a component that you want to synthesize or analyze by opening a previously-saved LineCalc
component file.

To open a previously-saved LineCalc component file:

1. Choose File > Open to display the dialog box.
File Open
Filter
mel/hpads prj/*.lcs

Directories Files
elfhpads1d prf. [ 1
ielhpadsi1s_prf..
ielhpads1s_prjfdata
ielhpadsis_prifmom_dsn
ielhpadsi15_primetworks
ielhpadsi1s_priisynthesis
ielhpads1s_priverification

Selection

s/hpads_prij/

oK Filter Cancel Help

2. Specify the path to the directory where the component file is located. Click Filter to activate a list of data files in
the specified directory. This step may not be necessary if the file is located in your current directory or if you
changed your default data directory.

) Note

Choosing a file from a different directory does not change the default directory.

13
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3. In the Data Files list, select the component file. The component data saved to that file becomes active in the
LineCalc window.

Importing Components from the Active Design

You can activate a component that you want to synthesize or analyze by importing components from the active
schematic or layout design.
To import components from an active design:

1. In the Schematic or Layout window, select the component you want to send to LineCalc. In the illustration, a
portion of a schematic example, MLIN:TL2 is selected.

) Note

You can send only one component at a time.

.ﬁqu%f T 11 N
RES ML I N
B1 TL3 ggp
R=RFB W=2
L=43 G=1G
MESUB=kS B
—
| v — —
S —
ML I M 1
TLZ
— MO EEFET1
L34 L1 FETH
_ L=1iD0D FILE=na71
KMESUB=M3UE 1
pMODE=naon |

2. Choose Tools > Send Selected Components to LineCalc . The component data for all selected components is sent
to LineCalc.

In the LineCalc window, each component that you import from the Schematic or Layout window, along with its ID
name, is listed in the Component ID Selection dialog box. In the illustration the two MLINs (TL2 and TL3) that were
sent to LineCalc from the Schematic window are now displayed in the Component ID Selection list and can be selected
for evaluation.
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Components sent
from Schematic

Only one component/ID calculation can be performed at a time. For example, select and perform any calculations on
MLIN:TL3 before you attempt to select and modify MLIN:TL2.

Selecting a Component

 Note

Before selecting or importing components to begin a new synthesis or analysis, be sure to clear any currently
active work. See Resetting the Display".

To select a component:

1. In the Component ID field, click Select to display the dialog box. The LineCalc window changes to display the
active Component Type, Component ID, parameters, and other data.

Componenk
’;wﬂ MLIN =]
MLANG -
Sub MLANGE

MLANGE

e Select the Component
D |FWG ‘R! Type and Component |D

SBCLIM
—1SCLIN

-

"Emponent
T

YPE [MLIN [ |MLIN MLIN_DEFAULT =l

Substiate Parameters | BFINL EFINL DEFALILT
CO&: COAX_DEFAULT
CPuw: CPwW_DEFAULT
CPWCOPLZ: TPWCPL2_DEFAULT
1D [MSUB_DEFAULT CPWECPL4: CPWCPLA_DEFAULT
= —— | CPw/G: CPw/iG_DEFAOLT

2. Select the component you want displayed and click OK to accept the component and dismiss the dialog. Click
Apply to accept the component and keep the dialog open.
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Displaying Component Help

To display detailed information for a component, select Help > What's This? and place the question mark on the
component illustration.

2

Vi ;;

¢

L/ ¥
4/
4

v

[ T

Changing Default Units

You can modify program units or frequencies before calculating the results by setting the Frequency, Length,
Resistance, and Angle units.
To modify default units or frequencies:

1. In the Menu bar, select Options > Preferences. Change the default unit preferences by selecting from the
drop-down lists. Default Units lists program options.

Unit Preference

Freq: GHz Click arrow 1o display
5 unit options.

Length: mil

Res: Ohm

Angle: deg

OK Apply | Cancel, Help

Unit Options Default

Frequency GHz, MHz, kHz, Hz GHz
Length in, mil, m, cm, mm, um mil
Resistance kohm, ohm ohm

16



Advanced Design System 2008

Angle deg, rad deg

2. In the Units display, modify the settings and click OK to accept your changes. The newly-chosen unit is reflected
when a new component is chosen.

Changing Parameter Values

To change any values in the Physical or Electrical parameter fields:
e Select the value and type a new value in the field.
To change Shared parameter values:

e Select the default value and type a new value in the field.
e To change the units associated with each shared parameter, select the units button next to each parameter field.

© Note

See also: Interdependent Values for Electrical Parameters and Fixed Values for Physical Parameters

Interdependent Values for Electrical Parameters

For certain components, some of the electrical parameter values depend on the current values assigned to other
parameters. In the following illustration, note the beginning values for ZO and Z0 in the Electrical portion of the
Parameters display for the MCLIN component.

To observe the values of related parameters change automatically, change the value of ZO to 22 and press Enter (or
click one of the other fields containing interdependent parameters).

Original values Moditied values
Electrical Electrical
ZE 65.952 Ohm _ ZE 65. 982 Ohm
Z0 36.115 Ohm | Z0 22. 000 Ohm
70 48 815364 Ohm _ 20 29, 099921 Ohm
C_DB -10. 6TE42E WA | C DB -6.02237F NiA
E_Eff 77831200 deg _ E_Eff 77. 831200 deg
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The display updates to show that the corresponding Z0 value changed from 48.815 to 38.099. Also, the C_DB value
changed from —10.676 to —6.022. Generally, the last two visited fields are used to compute the other parameters.

Fixed Values for Physical Parameters

Certain components require the value of one of the physical parameters to be fixed (not modifiable) during synthesis.
For these components, one parameter must be assigned a fixed value before you can perform a synthesis. For
example, observe how the W and G parameters of the CPW component are interrelated. By default, when you select
the CPW component, the value of G is fixed and the value of W is not. This default condition is shown by the label on
the Fixed button, which is dimmed.

Physical
W 20, 00000q mil | Fix
G 5. 00d, mil ‘| lwd —— This value does not change
during syrthesis
L 99 297244 mil
Synthesize _
A Pertorm Synthesis
Physical
W 24 . 000000 mil Ax —— Observe change invalue
' after synthesis
G 5,000 mil Find

If you want to change the value of G, you must click the Fix button for W. The new condition is shown by the label on
the button which changes to read Fixed and is dimmed. An active Fix button on the G value indicates that value is
currently not fixed and will change during synthesis.

18
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Physical

W 2. 000000 mil ; | ftwed| — This value does not change
: : during synthesis
G 5. 00d mil ¢ | Fix
Synthesize
A —— Perform Synthesis

Physical
W 20. 00G mil | Fined
G T.2726TE mil i | Fix Observe change in value

after synthesis

Performing a Synthesis

A synthesis computes the physical parameter values based on the electrical parameter values.
To synthesize a revised component:

e Select Simulate > Compute Physical Params or click Calculate (Up button) in the Parameters display. The values
for physical parameters (shown in the upper portion of the display) are computed from the electrical values and
the values in the Results display are updated.

Performing an Analysis

An analysis computes the electrical component parameters based on the physical parameter values.
To analyze a revised component:

e Select Simulate > Compute Electrical Params or click Calculate (Down button) in the Parameters display. The
values for electrical parameters (shown in the lower portion of the display) are computed from the physical
values and the values in the Results display are updated.

Updating Schematics with LineCalc Results

19
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After performing a synthesis or analysis, you can place the component to the Schematic window.
In the Schematic window, select Tools > Linecalc > Place New Synchronized Component.

If you start LineCalc from the Schematic and send selected components to LineCalc for synthesis or analysis, you can
update your schematic when your calculations are complete.

In the Schematic window, select the component to be updated. Then select Tools > LineCalc > Update Selected
Component From LineCalc .

Saving Results

To save a LineCalc component file:

¢ Choose File > Save from the Synthesis/LineCalc window. The program automatically saves the filename with an
.Ics extension. Unless you change the default data directory, the data file is saved in the program startup
directory.

File Save As
Filter

/hpads_prj/#*,lcs

Directories Files
[ ]
iel/hpads15_ph/..
iglhpads15_prjfdata
ielhpads15_prfmom_dsn
ielhpadsis_prnetworks
iglhpads15_prifsynthesis
ielhpads15_prjfverification

aelection

i/hpads_prj/

oK Filter Cancel Help

20



Advanced Design System 2008

To save a LineCalc component file to a different data file:

In the Synthesis/LineCalc window, choose File > Save As .
. In the dialog box, enter a filename and specify a directory path.
To save a design that was modified by LineCalc calculations:

N =

e In the Schematic or Layout window, choose File > Save .

Printing

You can print the data for a component.

e To specify a printing configuration, choose File > Print Setup .
e To print the data associated with the currently displayed component, choose File > Print.

The printed data format is:

product information
date information
component type
component ID

units information
frequency value
shared parameters
physical parameters
electrical parameters

result parameters

 Note
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For detailed information on print and print setup options, refer to your operating system documentation.

Exiting the Program

To exit LineCalc:

1. Choose File > Exit. If any unsaved changes are detected, you are prompted, Do you want to save the design?

2. Select Yes or No , as appropriate.
If you select Yes , and the currently active file had not been saved previously (that is, labeled untitled at the top
of the window), the Save As dialog box appears, prompting you for a filename.

Using AEL Commands

Using the program's Applications Extension Language (AEL), you can create entries for user-defined components,
customize the contents of library and palette menus, and write customized commands. For configuration details on
using AEL, see the AEL manual.

To execute AEL commands:

e Choose Options > Command Line to open the Command Line dialog.

— Command Line |

Command History

Command ==

[

T Apply Cance] Help '

e Type the command(s) in the Command >> field or select one of the commands in the Command History list.
Click Apply to execute the command. You can double-click a command in the list to select and execute it.
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 Note

All commands entered in the Command >> field must be in correct AEL format.

Using Macros to Automate Tasks

Creating a Macro File

To create a macro file:

e Using any text editor, create a file in one of your project directories and type the lines containing the AEL
functions you want to execute. The filename must have the extension .ael .

Recording a Macro
To record a macro:
¢ Choose Options > Command Line to open the Command Line dialog.

1. Select Options > Start Record Macro . In the dialog, enter a filename for the macro file you are going to record
and choose OK to close the dialog.
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Start Macro Recording
Filter
/hpads _prij/#, lcm The macro file
extension is .lcm
Directories Files

elfhpads1a prif. [ 1
ielfhpads1s_prjf..

ielfhpads1s_prjfdata
ielfhpads1s_prjifmom_dsn
ielfhpads1s_primetvworks
ielhpads1s_prfsynthesis
ielfhpads1s_prjfverfication

Selection

Enter a filename
/hpads prij/test

for the macro
Ok Filter Cancel Help

2. In the Command Line dialog, the Command History displays all actions taken in the LineCalc window during the
recording. Alternatively, enter the AEL functions you want to record in the Command >> field.
3. Select Options > Stop Record Macro to stop recording.

Running a Macro from the Design Environment

To play back a macro:

1. Choose Options > Playback Macro . A dialog displays all the .lcm files in the current project directory. You can
browse to display macros from another directory.
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Run Macro

Filter
/hpads_prij/#®.lcm

Directories Files

test.lom Selectthe macro
hpads1s_prj/.. to playback
hpads15_pr/data

hpads15_prifmom_dsn

hpads15_primetworks

hpads15_prfsynthesis

hpads15_prfverification

Selection

/hpads_prj/test, lcm

0K Filter Cancel Help

2. Select the macro you want to play back and click OK to execute the selected macro.

Running a Macro from the UNIX Command Line

To run a macro file from the UNIX command line:
e Change directories (cd) to your working directory and type:

$ linecalc -m<filename>.lcm

or

$ linecalc -msynthesize.lcm
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LineCalc Components

Components and Parameters

Components and Associated Parameters lists the LineCalc-supported components and any associated parameters that
can be modified or calculated. Components are grouped by substrates and details regarding their electrical and
physical values, references, and other computed results are given.

Components and Associated Parameters

TanD Rough

Component Electrical Parameters | Physical Parameters | Substrate Parameters Calculated Values
COAX Z0 E_Eff Di Do L Er TanD Rho Sigma A_DB
RWG Z0 E_Eff ABL Er Rho TanD Mur K_Eff A_DB
TanM Sigma
Components using the CPWSUB substrate (CPWSUB = * )
CPW Z0 E_Eff WGL Er Mur H Hu T Cond K_Eff A_DB
TanD Rough SkinDepth
CPWCPL2 ZE ZO Z0 C_DB WGSL Er Mur H Hu T Cond KE KO AE_DB AO_DB
E_EffComponents TanD Rough SkinDepth
using the SSUB
substrate (SSUB = *
)
CPWCPL4 ZEZO ZOC_DBE_Eff [ W=WiGS=SilL Er Mur H Hu T Cond K_Eff KE KO AE_DB
TanD Rough AO_DB SkinDepth
CPWG Z0 E_Eff WGL Er Mur H Hu T Cond K_Eff A_DB
TanD Rough SkinDepth
Components using the FSUB substrate (FSUB = * )
BFINL Z0 E_Eff DL Er Cond Fa Fb Fdw K_Eff A_DB
SkinDepth
IFINL Z0 E_Eff DL Er Cond Fa Fb Fdw K_Eff A_DB
SkinDepth
UFINL Z0 E_Eff DL Er Cond Fa Fb Fdw K_Eff A_DB
SkinDepth
Components using the MSUB substrate (MSUB = * )
MCLIN ZE ZO Z0 C_DB E_Eff ]WS L Er Mur H Hu T Cond KE KO AE_DB AO_DB

SkinDepth
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MLANG ZEZO ZOC_DBE_Eff ]WS L Er Mur H Hu T Cond KE KO AE_DB AO_DB
TanD Rough SkinDepth

MLANG6 ZE ZO Z0 C_DB E_Eff J]WS L Er Mur H Hu T Cond KE KO AE_DB AO_DB
TanD Rough SkinDepth

MLANGS8 ZE ZO ZO C_DB E_Eff ]WS L Er Mur H Hu T Cond KE KO AE_DB AO_DB
TanD Rough SkinDepth

MLIN Z0 E_Eff WL Er Mur H Hu T Cond K_Eff A_DB
TanD Rough SkinDepth

Components using the SSUB substrate (SSUB = * )

SBCLIN ZE ZO ZO C_DB E_Eff f]WS L Er Mur B T Cond AE_DB AO_DB
TanD SkinDepth

SCLIN ZE ZO Z0 C_DB E_Eff ]WS L Er Mur B T Cond AE_DB AO_DB
TanD SkinDepth

SLIN Z0 E_Eff WL Er Mur B T Cond A_DB SkinDepth
TanD

SLINO Z0 E_Eff WSL Er MurBS T Cond A_DB SkinDepth
TanD

SOCLIN ZE ZO Z0 C_DB E_Eff [IWWO S L Er Mur B T Cond AE_DB AO_DB
TanD SkinDepth

Components using the SSSUB substrate (SSSUB = * )

SSCLIN ZEZO ZOC_DBE_Eff ]WS L Er MurHHuUHIT KE KO AE_DB AO_DB
Cond TanD Rough SkinDepth

SSLIN Z0 E_Eff WL Er MurHHu HIT K_Eff A_DB
Cond TanD Rough SkinDepth

References/Shared Parameters

References/Shared Parameters lists the LineCalc-supported references/shared parameters.

References/Shared Parameters

References/Shared Parameters

Parameters

Parmeter Name

Default Value

CPWSUB Er HT Cond Rough TanD Hu Mur 10.0 25.0 0.150 4.1e7 0.0 0.0
COND 3.9e+07 mil 1.0 Cond
FSUB Er Fdw Fa Fb Cond 2.2 62.5 mil 900.0 mil 400.0 mil
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5.8e7
MSUB Er HT Cond Cond1 Cond2 Rough 9.6 10 mil 0.150 4.1e7 Cond Cond1
TanD Hu Mur Diell Diel2 Hole Res 0.0 0.0 3.9e+34m 1.0 Diel Diell hole
resi
SSSuUB Er H T Cond Rough HU HL TanD Mur |10.0 25.0 0.150 4.1e7 0.0 100.0
COND 100.0 0.0 1.0 Cond
SSuUB Er B T Cond Cond1 Cond2 TanD Mur |2.562.50.150 5.8e7 Cond Con1 0.0

1.0

Note: The default MSUB Cond value has changed to be 4.1e7 (the conductivity of gold).

Parameter Definitions

Parameter Definition

A Width of rectangular waveguide

A_DB Total attenuation of the structure in dB

AE_DB Total even mode attenuation of coupled section in dB

AO_DB Total odd mode attenuation of coupled section in dB

B Ground plane spacing from top to bottom (stripline) or
height of rectangular waveguide

C_DB Coupling factor in dB, i.e., C(dB) = 20log10
[(ZE-Z0O)/(ZE+Z20)]

D Gap width in length units

DI Inner diameter (COAX)

DO Outer diameter (COAX)

E Electrical length of line or coupled section (angle units)

E_EFF Effective electrical length of line or coupled section
(angle units)

E_MEAN Mean electrical length of coupled microstrip or coplanar
waveguide section (angle units)

ER Substrate relative dielectric constant

G Gap between conductor and ground planes (CPW, CPWG)

H Substrate thickness in length units

HL Lower ground plane to substrate spacing in length units

HU Upper ground plane to substrate spacing in length units
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HC Distance from top cover to top of substrate in length
units

KE Even-mode effective dielectric constant: KE=[C/Vp(even
mode)]2

K_EFF Effective dielectric constant: K_EFF=(C/Vp)2

KO 0Odd-mode effective dielectric constant: KO=[C/Vp(odd
mode)]2

L Length of line or coupled section

MUR Relative permeability

Rough RMS surface roughness in length units

S Spacing between lines

SI Spacing between inner center conductors (CPWCPL4)

SIGM Dielectric conductivity value in Siemens per meter

T Metal thickness

TAND Dielectric loss tangent

TANM Magnetic loss tangent

TEMP Temperature; can not be modified by the user

W Width of line

WI Width of inner center conductors (CPWCPL4)

WO Offset of coupled lines for offset coupled stripline

Ze Impedance for even-mode

Zo Impedance for odd-mode

Z0 For coupled-line components, such as SCLIN or MCLIN,

Z0=sqrt(Ze x Zo)

Changing Parameter Defaults

The default parameters that appear in the LineCalc window for editing are set in a file called Icuiinit in the directory
$HPEESOF_DIR/linecalc/lib (where $HPEESOF_DIR represents the complete path for your installation). You can make
a local copy of this file and change the default parameters so that less editing is required whenever you use LineCalc.

To modify the Icuiinit file:

1. Copy the file Icuiinit to a directory of your choosing. Using any text editor, make the desired changes. Save the
file.
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2. Now you need to tell the program where to look for your customized file. Make a local copy of the LineCalc
configuration file linecalc.cfg found in $HPEESOF_DIR/config. Copy this file to $HOME/hpeesof/config .

3. Using any text editor, locate the variable LCALCUI_INIT_FILE and modify the path to point to the location of your
modified Icuiinit file.

 Note

On the PC, $HOME represents the path you specified as the Home Folder during installation ( C:\users\default
by default); $ HPEESOF_DIR represents the path you specified as your Program Folder during installation (
C:\AdvDesSys ).

The component definition format is:

ELEMENT <el ement _name> <el ement _i d> <# of ports> <units> <physical > [ <physi cal _fi xed>

<physi cal >] <subst> <tand> <si gna> <tenp> <el ectrical > [<el ectrical _fixed><electrical >]<result>
For example:

ELEMENT COAX COAX_DEFAULT 4 UNITS PHYSICAL PHYSICAL_FIXED PHYSICAL SUBST ELECTRICAL RESULT
UNITS UNITS_DEFAULT

FREQ_VAL=10.00 FREQ=GHz LENGTH=mil RES=ohm ANGLE=deg

PHYSICAL DI=37.00

PHYSICAL_FIXED DO=90.00

PHYSICAL L=650.00

SUBST COAXSUB=COAXSUB_DEFAULT ER=2.10 TAND=0.0003 RHO=1.0

ELECTRICAL Z20=35.00 E=90.00

RESULT A_DB=0.01

LineCalc Error Messages

This section describes the possible error messages and how to handle each one of them.
Syntax error in AEL file
Comment: An error has occurred in an AEL file.

Category: Syntax error in AEL file

How to resolve it: Check the AEL file, confirming that all the parentheses are matched, there are no missing ";",
etc.
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AEL files not loaded

Comment: The AEL files are not loaded due to error(s) occurred.
Category: Syntax error in AEL file

How to resolve it: Check the AEL file, confirming that all the parentheses are matched, there are no missing ";",
etc.

Invoke process failed

Comment: Unable to invoke process (could be the LineCalc Engine, Help Server, etc.)
Category: Error in the initialization phase

How to resolve it: Confirm that all the necessary tools (LineCalc Engine, Status Server, Help Server, and
Hardcopy Server) are available and functional.

Unable to connect to the Status Server

Comment: The LineCalc User Interface cannot connect to the Status Server process.
Category: Error in the initialization phase.

How to resolve it: Confirm that all the necessary tools (LineCalc Engine, Status Server, Help Server, and
Hardcopy Server) are available and functional.

AEL command not found

Comment: The specified AEL command is not found
Category: Invalid AEL command.

How to resolve it: Confirm that the command is spelled properly and is indeed a supported function.
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Incomplete config file

Comment: Some information in the configuration file, linecalc.cfg, is missing.
Category: Error in configuration file.

How to resolve it: Search the linecalc.cfg file to find the required information that is missing and replace it.
Without this information, the program cannot function.

Init file not found

Comment: The initialization file, Icuiinit, is not found.
Category: Error in the initialization file.

How to resolve it: The initialization file must be placed where the program can read it. This is usually
$HPEESOF_DIR/lib/linecalc . Confirm that all the information is there: the users can add more information to it,
but the user should never delete any information from the original initialization file.

Syntax error in init file

Comment: A syntax error in the init file, Icuiinit , has been found.
Category: Error in the initialization file.

How to resolve it: The initialization file must be placed where the program can read it. This is usually
$HPEESOF_DIR/lib/linecalc . Confirm that all the information is there: the users can add more information to it,
but the user should never delete any information from the original initialization file.

Missing units information

Comment: Units information is not found.
Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.
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Missing substrate information

Comment: Substrate information is not found.
Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

Missing tand information

Comment: Tand information is not found.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.
Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

Missing mcover information

Comment: Mcover information is not found.

Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.
Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

Missing mwall information

Comment: Mwall information is not found.
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Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

Missing perm information

Comment: Perm information is not found.
Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

Missing sigma information

Comment: Sigma information is not found.
Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

Missing temp information

Comment: Temp information is not found.
Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

Missing parameters information

Comment: Some parameters are missing.

Category: Error in data file.
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How to resolve it: Confirm that all information exists for a given component in the data file.

Missing number of nodes information

Comment: The number of nodes information is missing.
Category: Error in data file.

How to resolve it: Confirm that all information exists for a given component in the data file.

Save element type failed

Comment: Unable to save the component type.
Category: Invalid component type to be saved.

How to resolve it: Confirm that the component type is one of the supported LineCalc components.

Save element ID failed

Comment: Unable to save the component ID.
Category: Invalid component ID to be saved.

How to resolve it: This is very unlikely to happen. However if it does happen, it is most likely due to unable to
allocate more memory to store the information.

Save number of nodes information failed

Comment: Unable to save the number of nodes information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
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information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Save units information failed

Comment: Unable to save the units information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Save freq unit failed

Comment: Unable to save the frequency unit information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Save length unit failed

Comment: Unable to save the length unit information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.
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Save res unit failed

Comment: Unable to save the resistor unit information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Save angle unit failed

Comment: Unable to save the angle unit information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Save substrate information failed

Comment: Unable to save the substrate information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Save mwall information failed

Comment: Unable to save the mwall information.
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Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Save shared parameters failed

Comment: Unable to save the shared parameters information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Save physical parameters information

Comment: Unable to save the physical parameters information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Save electrical parameters information

Comment: Unable to save the electrical parameters information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
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the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Save result parameters failed

Comment: Unable to save the result parameters information.
Category: Unable to save the specified component.

How to resolve it: If this error occurs, the program is probably unable to allocate more memory to save the
information. Another issue which needs to be looked at is that the information should be in the proper format: if
the format is expected to be a number, it should be a number; if the format is expected to be a string, it should
be a string type.

Invalid element type

Comment: Invalid component type.

Category: Invalid component type.

How to resolve it: An invalid component type has been requested. Confirm that the component type is spelled
correctly is indeed a LineCalc supported component.

Unable to write the data file

Comment: Unable to save to the specified data file.
Category: Unable to write the data file.

How to resolve it: If this error occurs, the current user probably cannot write to the specified data file; this can
also occur if the directory is not writable by the current user.

Create new shared parameters failed
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Comment: Unable to create a new shared parameters information.
Category: Unable to create a new shared parameters.

How to resolve it: When this error occurs, the program is probably unable to allocate more memory to store the
data.

Invalid substrate

Comment: Invalid substrate.
Category: Invalid substrate type.

How to resolve it: Confirm the substrate type entered is supported by LineCalc.

Error Retrieving DONE NETLIST

Comment: Invalid parameters for analysis/synthesis.
Category: Invalid parameters for analysis/synthesis.

How to resolve it: Ensure the electrical, physical, and substrate parameter values are within the range of usage,
per user guide.

Inconsistent Electrical Parameter Value. Ze and Zo must be of the same sign.

Comment: Ze and Zo must be of the same sign.
Category: Ze and Zo must be of the same sign.

How to resolve it: Use the same sign for both Ze and Zo.

LineCalc AEL Functions
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This section describes the supported AEL functions for the LineCalc User Interface.

Icuiuser_analyze()

Computes the electrical parameters from the physical parameter values. In addition, the result parameters are
computed. Returns: None.

See also: [cuiuser synthesize(), Icuiuser simulation analyze(), Icuiuser simulation synthesize()

Syntax:

defun Icuiuser_analyze()

Example

Icuiuser_analyze();

Icuiuser_elemid_select()

Displays the dataset belonging to the specified component ID, elemID. Returns: None.
See also: [cuiuser elemtype select()

Syntax:

defun Icuiuser_elemid_select( elemID )

where
elemID is the component ID to be displayed.

Example
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Icuiuser_elemid_select( "MLIN_DEFAULT");

Icuiuser_elemid_select_apply()

Obsolete; see |cuiuser elemid select().

Icuiuser_elemtype_select ()

Displays the dataset belonging to the specified component type, elemType. If there are multiple components in the
memory for a given component type, the first component type found from the list is displayed. To display a
component type that has a specified ID, select the component by ID by calling the Icuiuser elemid select apply

function. Returns: None.
See also: Icuiuser elemid select()

Syntax:

defun Icuiuser_elemtype_select (elemType)

where
elemType is the component type to be displayed.

Example

Icuiuser_elemtype_select("MLIN");

Icuiuser_elemtype_select_apply()

Obsolete; see Icuiuser elemid select.
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Icuiuser_file_chdir_ok()

Performs a change directory command to the specified directory, dirName. If a local configuration file (linecalc.cfg)
exists, the function reads in the information and, if needed, overwrites any default values. If the current component
has been modified and has not been saved, a question dialog box opens asking if the current component should be
saved prior to performing a change directory command. Returns: None.

See also: |cuiuser file save(), lcuiuser_ file save as ok()

Syntax:

defun Icuiuser_file_chdir_ok(dirName)

where
dirName is the directory to go to

Example

Icuiuser_file_chdir_ok("dirNamel");

Icuiuser_file_exit()

Exits the LineCalc User Interface program. If the current component set is not saved, a dialog box opens asking if the
data should be saved prior to exiting the program. If no data needs to be saved, a different dialog box opens asking to
confirm the exit command. Returns: None.

See also: Icuiuser file save(), Icuiuser file save as ok()

Syntax:

defun Icuiuser_file_exit()

Example

Icuiuser_file_exit();
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Icuiuser_file_new()

Displays the default component. The default component is the first component being displayed when the LineCalc User
Interface is invoked. If the component is not saved yet, a dialog box opens so that the component can be saved prior
to switching to a different component. Returns: None.

See also: |cuiuser file save(), lcuiuser file save as ok()

Syntax:

defun Icuiuser_file_new()

Example

Icuiuser_file_new();

Icuiuser_file_open_ok()

Opens the data file specified by filename and displays the data properly. If the current component is not saved yet, a
dialog box opens so that the data can be saved before moving on to a different component set. Returns: None.
See also: Icuiuser file save(), Icuiuser file save as ok()

Syntax:

defun Icuiuser_file_open_ok(filename)

where
filename is filename to be opened

Example

Icuiuser_file_open_ok("dirName1l/linecalcl.lcs");
or
Icuiuser_file_open_ok("linecalcl.lcs");
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Icuiuser_file_print()

Sends the displayed data to a printer using the program's Hardcopy Server . Returns: None.
See also: |cuiuser file print setup()

Syntax:

defun Icuiuser_file_print()

Example

Icuiuser_file_print();

Icuiuser_file_print_setup()

Opens the print setup dialog box to set the printer selections using the program's Hardcopy Server . Returns: None.
See also: [cuiuser file print()

Syntax:

defun Icuiuser_file_print_setup()

Example

Icuiuser_file_print_setup();

Icuiuser_file_save()

See also: Icuiuser_file_save_as_ok()
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Syntax:

defun Icuiuser_file_save()

Saves the data to the current data filename. If there is no associated data file for the current component or if
write permission is not set for the current data file, opens the File Selection dialog box to either select or enter
the filename to save the data. Returns: None.

Example

Icuiuser_file_save();

Icuiuser_file_save_as_ok()

Saves the currently displayed component to a different file, specified by filename. Returns: None.
See also: [cuiuser file save()

Syntax:

defun Icuiuser_file_save_as_ok(filename)

where
filename is filename to be saved

Example

Icuiuser_file_save_as_ok("filenamel.lcs");

Icuiuser_option_cmdline_apply()

Executes the AEL command string, cmmdString. Returns: None.
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See also: Icuiuser option pbmacro ok()

Syntax:

defun Icuiuser_option_cmdline_apply(cmdString)

where
cmdString is AEL command string to be executed

Example

Icuiuser_option_cmdline_apply("lcuiuser_file_exit()");

Icuiuser_option_pbmacro_ok()

Executes the specified AEL macro file, filename, which contains of a set of supported AEL functions. Returns: None.
See also: lcuiuser option cmdline apply()

Syntax:

defun Icuiuser_option_pbmacro_ok(filename)

where
filename is AEL macro file to be executed

Example

Icuiuser_option_pbmacro_ok("macrol.ael");

Icuiuser_set_angle_unit()
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Sets the angle unit to the specified string, angleUnitString. Note that angleUnitString must be one of the unit strings
supported by LineCalc. The supported angle units are: deg, and rad. Returns: None.

See also: Icuiuser set freq unit(), Icuiuser set freg value(), lcuiuser set length unit(), Icuiuser set res unit()

Syntax:

defun Icuiuser_set_angle_unit(angleUnitString)

where
angleUnitString is the new angle unit string

Example

Icuiuser_set_angle_unit("deg");

Icuiuser_set_elec_res_unit()

Sets the unit of specified electrical parameter parmName, to the specified string, elecUnit. Note that elecUnit must be
one of the unit strings supported by LineCalc. The supported units for electrical resistance parameters are: ohm and
kohm. The supported units for electrical angle parameters are: deg, and rad. Returns: None.

See also: lcuiuser set mwall length unit (), lcuiuser set phys length unit(), Icuiuser set subst length unit ().

Syntax:

defun Icuiuser_set_elec_res_unit ( parmName, elecUnit )

where
parmName is electrical parameter name of unit to be modified
elecUnit is new electrical unit string

Example
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Icuiuser_set_elec_res_unit ("E_Eff", "rad");
Icuiuser_set_elec_res_unit("z0", "kohm");

Icuiuser_set_electrical_parms()

Sets the electrical parameter value of parameter name, parmName, to parmValue. parmName must be one of the
valid electrical parameter for the currently displayed component. Returns: None.

See also: Icuiuser set physical parms(), Icuiuser set physical parms fix()

Syntax:

defun Icuiuser_set_electrical_parms(parmName, parmValue)

where
parmName is electrical parameter name to be modified
parmValue is new electrical parameter value

Example

Icuiuser_set_electrical_parms("E_EFF", "360");

Icuiuser_set_freq_unit()

Sets the frequency unit string value, freqUnitString. Note that freqUnitString must be one of the unit strings supported
by LineCalc. The supported frequency units are: GHz, MHz, kHz, and Hz. Returns: None.
See also: [cuiuser set angle unit(), lcuiuser set freq value(), lcuiuser set length unit(), Icuiuser set res unit()

Syntax:

defun Icuiuser_set_freq_unit(freqUnitString)
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where
freqUnitString is the new frequency unit string

Example

Icuiuser_set_freq_unit("GHz");

Icuiuser_set_freq_value()

Sets the frequency unit value, freqUnitValue. It should be passed as a string value. Returns: None.

See also: Icuiuser _set angle_unit(), lcuiuser set freq unit(), Icuiuser set length unit(), Icuiuser set res unit()

Syntax:

defun Icuiuser_set_freq_value(freqUnitValue)

where
freqUnitValue is the new frequency unit value

Example

Icuiuser_set_freq_value("10.00");

Icuiuser_set_length_unit()

Sets the length unit string value, lengthUnitString. Note that lengthUnitString must be one of the unit strings
supported by LineCalc. The supported length units are: in, mil, m, cm, mm, and um. Returns: None.

See also: |cuiuser_set_angle_unit(), lcuiuser set freg unit(), lcuiuser_set res unit()
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Syntax:

defun Icuiuser_set_length_unit(lengthUnitString)

where
lengthUnitString is the new length unit string

Example

Icuiuser_set_length_unit("mil");

Icuiuser_set_mwall_length_unit()

Sets the unit of specified mwall parameter parmName, to the specified string, mwallUnit. Note that mwallUnit must be
one of the unit strings supported by LineCalc. The supported length units for mwall length parameters are: mil, um,
mm, cm, meter, in, and ft. Returns: None.

See also: Icuiuser set phys length unit (), Icuiuser set subst length unit(), Icuiuser set elec res unit ().

Syntax:

defun Icuiuser_set_mwall_length_unit ( parmName, mwallUnit )

where
parmName is mwall parameter name of unit to be modified
mwallUnit is new mwall unit string

Example

Icuiuser_set_mwall_length_unit ( "Wall1", "mil");
Icuiuser_set_mwall_length_unit ("Wall2", "um");

Icuiuser_set_physical_parms()
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Sets the physical parameter value of the specified parameter name, parmName, to parmValue. parmName must be
one of the valid physical parameter for the currently displayed component. Returns: None.
See also: |cuiuser_set_electrical parms(), lcuiuser_set physical parms_fix()

Syntax:

defun Icuiuser_physical_parms(parmName, parmValue)

where
parmName is physical parameter name to be modified
parmValue is new physical parameter value

Example

Icuiuser_set_physical_parms("W", "25.00");

Icuiuser_set_physical_parms_all()

Obsolete.

Icuiuser_set_physical_parms_fix()

Sets the physical parameter fixed value of the specified parameter name, parmName, to fixValue. fixValue should be
either 0 or 1. parmName must be one of the valid physical parameter for the currently displayed component. Returns:
None.

See also: [cuiuser set electrical parms(), Icuiuser set physical parms()

Syntax:

defun Icuiuser_set_physical_parms_fix(parmName, fixValue)
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where
parmName is physical parameter name to be modified
fixValue is new fixed physical parameter(either 0 or 1)

Example

Icuiuser_set_physical_parms_fix("W", 0);

Icuiuser_set_phys_length_unit()

Sets the unit of specified physical parameter parmName, to the specified string, physUnit. Note that physUnit must be
one of the unit strings supported by LineCalc. The supported length units for physical length parameters are: mil, um,
mm, cm, meter, in, and ft. Returns: None.

See also: |cuiuser set mwall length unit (), Icuiuser set subst length unit(), Icuiuser set elec res unit().

Syntax:

defun Icuiuser_set_phys_length_unit ( parmName, physUnit )

where
parmName is physical parameter name of unit to be modified
physUnit is new physical unit string

Example

Icuiuser_set_phys_length_unit ( "W", "mil");

Icuiuser_set_res_unit()

Sets the resistor unit string value, resUnitString. Note that it must be one of the unit strings supported by LineCalc.
The supported resistor units are: kohm and ohm. Returns: None.
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See also: [cuiuser set angle unit(), lcuiuser set freq unit(), Icuiuser set length unit()

Syntax:

defun Icuiuser_set_res_unit(resUnitString)

where
resUnitString is the new resistor unit string

Example

Icuiuser_set_res_unit("ohm");

Icuiuser_set_shared_parms()

Obsolete; see Icuiuser_set subst parm_value().

Icuiuser_set_subst_length_unit()

Sets the unit of specified shared parameter parmName, to the specified string, substUnit. Note that substUnit must be
one of the unit strings supported by LineCalc. The supported length units for shared length parameters are: mil, um,
mm, cm, meter, in, and ft. Returns: None.

See also: |cuiuser set mwall length unit (), lcuiuser set phys length unit(), Icuiuser set elec res unit ().

Syntax:

defun Icuiuser_set_subst_length_unit ( parmName, substUnit )

where
parmName is shared parameter name of unit to be modified
substUnit is new shared unit string
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Example

Icuiuser_set_subst_length_unit ( "Hu", "mil");

Icuiuser_set_subst_parm_value()

Sets the shared parameter value of the parameter name, parmName, to parmValue. parmName must be one of the
valid shared parameter for the currently displayed component. Shared parameters are substrate, tand, mcover,
mwall, perm, and sigma parameters. In addition, shared parameters for COAX and RWG components include those

listed in References/Shared Parameters". Returns: None.

Syntax:

defun Icuiuser_set_subst_parm_value(parmName, parmValue)

where
parmName is shared parameter name to be modified
parmValue is new shared parameter value

Example

Icuiuser_set_subst_parm_value("ER", "9.91");

Icuiuser_simulation_analyze()

Computes the electrical parameters from the physical parameter values. In addition to computing the electrical
parameters, the result parameters are computed. Returns: None.
See also: [cuiuser analyze(), Icuiuser synthesize(), Icuiuser simulation synthesize()

Syntax:

defun Icuiuser_simulation_analyze()
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Example

Icuiuser_simulation_analyze();

Icuiuser_simulation_interrupt()

Interrupts the simulation. LineCalc remains available for future simulation usage. Returns: None.
See also: [cuiuser simulation stop()

Syntax:

defun Icuiuser_simulation_interrupt()

Example

Icuiuser_simulation_interrupt();

Icuiuser_simulation_stop()

Interrupts the simulation process and the LineCalc engine becomes unavailable. If a user requests another simulation
to be done, the LineCalc engine is invoked automatically. Returns: None.
See also: [cuiuser simulation interrupt()

Syntax:

defun Icuiuser_simulation_stop()

Example

Icuiuser_simulation_stop();
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Icuiuser_simulation_synthesize()

Computes the physical parameters from the electrical parameter values. In addition to computing the physical
parameters, the result parameters are computed. Returns: None.

See also: |cuiuser analyze(), lcuiuser synthesize(), lcuiuser simulation analyze()

Syntax:

defun Icuiuser_simulation_synthesize()

Example

Icuiuser_simulation_synthesize();

Icuiuser_synthesize()

Computes the physical parameters from the electrical parameter values. In addition to computing the physical
parameters, the result parameters are computed. Returns: None.

See also: [cuiuser analyze(), Icuiuser simulation analyze(), Icuiuser simulation synthesize()

Syntax:

defun Icuiuser_synthesize()

Example

Icuiuser_synthesize();
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