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About RF Intellectual Property Encoder

Protecting intellectual property (IP) of any form has always been a challenge. The EDA industry has its own unique set
of challenges in that high priced encryption technology is not generally justified for protecting IP since most designs
change rapidly. While different EDA vendors want to share their designs with their foundries for better efficiency, they
typically do not want to share their intellectual property. The RF Intellectual Property Encoder (RF IP Encoder) was
designed with this in mind and created specifically for vendors who wish to share their designs, but not their
intellectual property. Encoded libraries can be distributed as an ADS Design Kit.

RF Intellectual Property Encoder

The RF IP Encoder provides a mechanism for sharing a simulatable Advanced Design System (ADS) schematic design
or netlist without divulging your actual design information.

Major Benefits

RF IP Encoder enables you to perform the following:

e protect your intellectual property
¢ share a simulatable ADS design or netlist without sharing your IP
Major Features

Key features of RF IP Encoder include the following:

e simple encoding process
e ease of packaging and delivery
¢ ability to include design variables

Intended Audience
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This manual describes how to install and configure the RF IP Encoder product and assists both the model-provider and
model-user in generating and utilizing encoded designs and netlists. Usage assumes basic familiarity with design and
simulation in Advanced Design System.

The audience for this document includes:

e System Administrators(or CAD managers). Configuring RF Intellectual Property Encoder is intended to assist the
system administrator or CAD manager with installing the RF IP Encoder product.

e Model-Providers. Getting Started Tutorial is intended to familiarize the model-provider with the entire process of
encoding designs and using encoded IP libraries. Encoding Schematic Designs and Netlists is intended to quickly
assist the model-provider in encoding and packaging an IP Library in ADS.

e Model-Users. Working with Encoded Designs is intended to quickly provide instructions on using encoded IP
libraries. This information is ordinarily needed by the model-user, however, model-providers may also need to
use this when working with their customers. The Getting Started Tutorial also demonstrates how to use an
encoded library however the tutorial requires that you first build a simple library.

General Process

RF IP Encoder is accessible from the ADS Tools, menu once the product is properly installed. The following steps
describe a typical process for encoding a design or netlist with RF IP Encoder:

Create your IP Library.

Encode your IP Library into an ADS Design Kit.
Package your Encoded IP Library.

Send the encoded IP to your model user.

Model user installs your Encoded IP Library.
Encoded IP Library is used within another design.

ok WwWNRE

Use Model

The diagram shown in RF IP Encoder Use Model describes the general use model for encoding schematic designs and
netlists.
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RF IP Encoder Use Model

e The Model-Provider groups schematic designs or netlist into a single ADS project.

e The Model-Provider then uses the RF IP Encoder product to create an encoded IP library. This library contains
information that is the encoded version of the original schematic design(s) or netlist. For convenience, RF IP
Encoder bundles the files that represent the encoded IP library into an ADS package file that can be easily
delivered to the Model-User (vendor's customer).

e The Model-User then installs the encoded IP library into their ADS installation. The encoded IP library appears in
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the library browser and the component palettes. The library is now accessible for use in simulations.

About ADS Design Kits

A library can be encoded into an ADS Design Kit. When you encode your library as an ADS Design Kit, you have the
option of creating a zip file of the kit for ease of distribution. The zip file can be easily installed anywhere on a network
or computer, it does not have to be installed in the ADS installation directory. Furthermore, installation is made easy
because there is a simple user interface within the main window of ADS that automates the installation and
configuration. The ADS Design Kit Installation and Setup manual explains how to install, manage and use design Kkits
in ADS.

Another benefit of using ADS Design Kits is that you can include documentation about your design kit within the zip
file. For example, if certain simulation controllers are required for a particular library, that can be specified in the
design kit documentation and included with the design kit. For more information on providing documentation in a
design kit, refer to the ADS Design Kit Development documentation.

What's in this Manual

The goal of this manual is to help you get started, providing relevant examples that teach you how to use the
software, and showing you where you can get more information as you need it. This manual contains:

e Configuring RFIC Dynamic Link describes how to install and configure the software.

e Getting Started Tutorial steps you through the process of creating an encoded IP library using two sample
schematic designs, installing this encoded IP library into ADS and using the encoded schematic designs within a
test schematic to perform a simulation. This simple Getting Started Tutorial enables you to immediately use the
product.

¢ Encoding Schematic Designs and Netlists is a quick reference for encoding designs and netlists.

e Working with Encoded Designs assists the model-user with instructions on installing, viewing, removing and
using encoded IP libraries.

e Troubleshooting RF Intellectual Property Encoder provides helpful information on known problems and solutions.

Configuring RF Intellectual Property Encoder
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This chapter describes how to install and configure the software. You may require help from a UNIX or CAD
Administrator to complete these tasks.

Hardware Requirements

Refer to the Advanced Design System Installation documentation for UNIX or PC systems.

Operating System Requirements

Refer to the operating system requirements for ADS. Although the product may work satisfactorily on later operating
system versions, support for these later versions may not be available.

EDA Framework Requirements

The software requires ADS 2006A. Additional module licenses within each framework are also required as described in
License Requirements.

License Requirements

In addition to ADS schematic and simulator licenses, the RF IP Encoder product license, ads_encoder, is required.

Installing and Removing the RF IP Encoder

Before you install the RF IP Encoder engine, ADS must be installed on your computer. For general installation issues,
refer to the Advanced Design System installation manuals for UNIX or PC systems.

If you installed a previous version of RF IP Encoder, it is recommended that you remove the software. Instructions for
removing the package files are included in Removing RFIP Encoder Engine.

The RF IP Encoder is shipped in two parts due to international restrictions on encoding technology. The user interface
(UI) is available by using the Custom Installation option and is distributed on the Advanced Design System CD ROM.

This enables you to access the UI; however, to be able to encode designs you will also need the proper ads_encoder

license as well as the RF IP Encoder engine.
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 Note

The ads_encoder license is only required for the encoding process. Using an encoded library in simulation does
not require a license.

If an attempt is made to encode a design from the UI and the license or RF IP Encoder engine has not been installed,
a warning dialog box will appear indicating the missing feature.

The RF IP Encoder engine is not provided on the standard Advanced Design System CD ROM. It must be downloaded
from the Agilent EEsof EDA Technical Support website. To download the encoder engine software:

1. Access the Agilent EEsof Knowledge Center at:
http://www.agilent.com/find/eesof-knowledgecenter

2. In the Software Downloads section, click ADS. Note that you are directed to the Agilent EEsof Knowledge Center
Login page where you are required to enter a Username and Password.

3. After logging in, select your product version.

) Note
The ADS version should correspond with the version of RF IP Encoder. For more information, refer to ADS
Versions.

1. Select the RF IP Encoder Engine option.

2. Information on how to download and install the RF IP Encoder engine is provided near the bottom of the page.
Select the appropriate version from the list and follow the instructions. The instructions will guide you to save
and run the executable.

Configuring the Environment

This section describes how to configure your environment in order to use the hpeesofpkg command. The hpeesofpkg
command uses shared libraries that are set in the $HPEESOF_DIR/bin/bootscript.sh script. Before attempting to use
the hpeesofpkg commands, you should source the bootscript.sh file using one of the following commands:

. $HPEESOF_DIR/bin/bootscript.sh (If using the Korn shell)
sh (If using the C shell)
. $HPEESOF_DIR/bin/bootscript.sh

 Note
The above commands are only necessary if SHLIB_PATH for HP-UX or LD_LIBRARY_PATH for SunOS does not
include the shared libraries required to run hpeesofsim.

Removing RFIP Encoder Engine
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You can easily remove the RFIP Encoder engine by entering:
hpeesof pkg --remove rfi p-encoder

Before attempting to use the hpeesofpkg command, refer to Configuring the Environment.

 Note

For further information on working with packages, refer to Working with Encoded Designs.

Important Information about RF IP Encoder

This section provides important information about the RF IP Encoder version, security and technical support.

ADS Versions

Encoded libraries are version dependent and may not work with different versions of ADS. When using a different
version of ADS, the library may need to be re-encoded using that particular version. In general, a library from a
current version of ADS should be usable in a future version of ADS, but not in an earlier version.

Security

It is recommended that you share models generated by the RF IP Encoder only under the protection of a
Non-Disclosure Agreement and through the use of private media distribution.

Technical Support

Agilent Technologies provides technical support to users of the RF IP Encoder who have also purchased the related
support product. Support covers the use of the interface and the encoding process. The users of the RF IP Encoder are
responsible for the support of the encoded models that they generate. Due to the sensitive nature of the encoded
intellectual property, if a third party encounters problems arising from the use of an encoded model, technical
assistance will be provided only to direct users of the RF IP Encoder product.

Getting Started with RF Intellectual Property Encoder
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This tutorial guides you through the process of creating an encoded IP library using two sample schematic designs,

installing this encoded IP library into ADS and using the encoded schematic designs within a test schematic to perform
a simulation.

Installing the Tutorial Examples

This section provides information on how to install the tutorial example files.

The example projects for this tutorial are provided as _.zap_ files. After the RF IP Encoder is installed , these .zap files
are located in the installation directory under the ComponentLibs/examples subdirectories.

For example, if your installation directory is C:\ADS2008 on a Windows system, then the example files are located
under C:\ADS2008\ComponentLibs\examples. On a UNIX system, the example files are located in
$HPEESOF_DIR/ComponentLibs/examples.

1. From the ADS Main window, select File > Unarchive Project . An Unarchive Project dialog box is displayed.

= Unarchive Project |

Unarchive File: /EncoderExample zap  Browse... Working Directory Startup Directory

To Directory: | /IP_Encoder Tutorial | Browse...| Working Directory Startup Directory

% Open Project After Unarchive

A OK Cancel Help

2. For each of the .zap files ( EncoderExample.zap and EncoderTest.zap ), set the Unarchive File: path to unarchive
from the appropriate location. Then set the To Directory: path to a convenient working directory.

The first project (EncoderExample.zap ) contains the designs that will be encoded during the tutorial. The second
project ( EncoderTest.zap ) contains test bench circuits for simulations that use the designs from the first
project.

Creating an Encoded IP Library

After you have successfully installed the RF IP Encoder example projects, perform the following steps:

1. Open the project EncoderExample_prj that was previously unarchived.
2. Open the schematic design simpleR.dsn from the networks directory of the project. This file is a basic schematic
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design of a resistor with specified ports. The design includes a modifiable parameter, Rx, that allows the end user
to vary the design parameter without viewing the encoded IP.

For more information on working with variables, refer to " Creating Hierarchical Designs " in the ADS "Schematic
Capture and Layout" documentation.

Note

Each of your schematic designs must include specified ports (that is, they must be defined as a Parametric
Subnetwork) in order to encode the design. Be aware that anything included in your Parametric Subnetwork is
not modifiable, with the exception of design variables. This includes, but is not limited to, sources and

simulation control components.

The following figure displays the simple resistor network that includes the parameter Rx in the design.
—| [ EncoderExample prj | simpleR {Schematic):1 |
Fle Edit Select View Insert Options Tools I_aymt Simulate Window DynamicLink DesignGuide Help

Fl

2| W0 @] 9.7 e B HE e B
4] 1O = 21l il N\ @ QIE

]
|

D= — AN\ —= -~ >
DGFeed| DGBlK =
Bart Ferd
B’

= =N R=Rx F2
SHORT | MUTIND M urm=1 Murre=2
PLG PR
k| 3
FRL | PRLG
i || b
JALG LSRG
| Select: Enter the starting point 0 items wire 0.1250, 5.5000 -2.6250, 1.5000 it

Simple Parametric Subnetwork

3. From the Schematic window, select View > Create/Edit Schematic Symbol to view the schematic symbol that

represents your schematic design. The following figure shows the basic schematic symbol that represents the
simpleR.dsn schematic design.
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— [ EncoderExample_prj | simpleR (SYMBOL) (Schematic):1 EE
File Edit Select View Insert Options Tools Layout Simufate Window Dynamiclink DesignGuide Help

Delglé E =ein 95 S euhHEE & d
Symbol View Palette A A el il s | B MI_E
D D I

5
- .

i

F-J | [
’| Select: Enter the starting point 0 items symbody  -0.1250, 0.0625 -2.8750, -3.9375 it

d

simpleR Schematic Symbol

 Note

If a symbol is not created for your design before you encode, ADS provides a default symbol to represent the
encoded component. For more information, refer to Symbols in Encoded Libraries.

4. Select File > Open Design and then select the GilCellMix.dsn from the list of designs. The following figure
displays the more complex design that will also be included in the encoded IP Library.
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= | EncoderExample_prj | GilCellMix {Schematic):1 | -]

File Edit 3Select View Insert Options Tools Layout Simulate Window Dynamiclink DesignGuide

oegla El =enal O

Lumped- Components _"'l [

e
=

Help

e
5LC

k-1 J
1
Felect: Enter the starting point 0 items wire -6.930, 9.513 -2.394, 13.167

Mixer Schematic Design

5. From the Schematic window, select View > Create/Edit Schematic Symbol to view the schematic symbol that
represents the mixer schematic design. The following figure shows the schematic symbol that represents the
mixer schematic design.
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— [ EncoderExample_prj | GilCellMix {SYMBOL) {Schematic):1 -]

|

File Edit Select View Insert Options Tools Layout Sinmulate Window Dynamiclink DesignGuide

Help

geigg kl =edn 9.5 QNN EHEE HeEd
'Symbol View Palette | = 'ULE{J'

D D % I
=@
-rl:l Ml

- |
Select: Enter the starting point 0 items symhbody  -0.630, 0.378 3.906, 4.032

GilCellMix.dsn Schematic Symbol

) Note

If a symbol is not created for your design before you encode, ADS provides a default symbol to represent the
encoded component. For more information, refer to Symbols in Encoded Libraries.

6. Select View > Create/Edit Schematic to return to the schematic view.

7. Select File > Design Parameters . The Design Parameters dialog box appears. Type in a description in the
Description field. For this tutorial, use Encoded Gilbert Cell Mixer as shown in the following figure. This
description will be the Component Library description for the encoded component.

8. Click OK to close the Design Parameters dialog box.

9. Save the design to save any changes entered in the Design Parameters dialog.
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=| Design Parameters:1

Mame: | GilCellMix

General Parameters

Description

Encoded Gilbert Cell Mixed

Component Instance Name Simulation

i1 Model
Subnetwaork

Symbol Name

Sinolate Ag

I

[3i1CellMix

More Symbols...

Library Name I Copy Covpnnent's Pararmglers
- Artwrork
Hote: An "*" indicates current project. Type

I Allow only one instance synchronized

_| Include in BOM
R
I Layout Object

_I Simulate from Layout (SimLay)

7 Ok Save AEL file Cancel Help

Setting the Encoded Component Description

Symbols in Encoded Libraries

There are a few different ways to define the symbol to be used with each library component. Be sure to note the
associated limitations related to using symbols in design kits or encoded libraries.

¢ Using Pre-defined Symbols - Create or open a circuit in the schematic editor. From the schematic view of the
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circuit, select File > Design Parameters . In the General tab, define the symbol name by selecting a common
pre-defined symbol from the drop-down list or by selecting More Symbols , which gives you access to all
pre-defined library symbols in ADS, sorted by category. This method works best for encoded libraries and design
kits.

e Schematics and Custom Symbols in One Design File - Create or open a circuit in the schematic editor. From the
schematic view of the circuit, select View > Create/Edit Schematic Symbol . Draw a custom symbol and save the
design. This will save the symbol information directly with the schematic design.

This method works well for encoded designs but has limitations if the encoded design is made into a design kit. If
the design kit is enabled at the project level, the user will get an error message when selecting the component
from the palette and will not be able to place the component. If the design kit is enabled at any other level, this
problem will not occur. Simply closing and re-opening the project will fix this.

e Schematics and Custom Symbols in Separate Design Files - From the schematic view of a new, empty design,
select View > Create/Edit Schematic Symbol . Draw a custom symbol in the symbol view and save the file
without entering anything in the schematic view.

Create or open a circuit in the schematic editor. From the schematic view of the circuit, select File > Design
Parameters . In the General tab, type the symbol name into the Symbol Name field, or select More Symbols and
browse to select the name of the design file. The symbol name should be stored with the .dsn extension and no
path (ex: myR_SYM.dsn).

Running the RF IP Encoder

To encode your designs using the RF IP Encoder perform the following steps:

1. From the Schematic window, select Tools > Encode Designs. A dialog box appears asking your permission to
close all designs and schematic windows. Select No if you have unsaved changes that you need to save. If you
select Yes, the Create Encoded Library dialog box appears.
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TH Create Encoded Library

Library Conkents
FAevailable Designs and Metlists List of Designs and Metlists to Encode
Gl el dsn GilCelMix, dsn
simpleR.dsn simpleR.dsn
[ add == ]
[ << Remove ]
[ Browse Metlists, ., ]

[ Set Bitmap (dsn only). .. ]

[ Visible Devices (dsn only).., ]

[] wisible all
Library Information
Library Mame Library Version
ak_mixlib 1

Library Descripkion
Encoded Gilbert Cell Mixer

Destination Path

CuserstADSZ003kesk_encode_prj

Encoding Format

(%) Design kit with .zip File () Design kit with no . zip file

Encoded By
Mame Compan Ernail Address
Skevenj Agilent Technologies stevenj@agilent . com

2. Use the Library Contents section to select which schematic designs you want to encode. In the Available Designs
and Netlists list box (on the left), highlight each individual schematic design you want to include in your library
and then click Add . This adds each selection and displays the selected schematic designs in the List of Designs
and Netlists to Encode list box (on the right). If you hold down the CTRL key while clicking the mouse you can
make multiple selections. Clicking the mouse while holding down the SHIFT key will enable you to select
everything between the first highlighted item and the last one selected. Double clicking the mouse on a selection
will automatically move a single item to the Encode list box. Individual schematic designs can be removed from
the List of Designs and Netlists to Encode by selecting them and then clicking Remove.

 Note

To include your own netlists in the Available Designs and Netlists list, place your netlists under the current
project directory, in the networks subdirectory, with a .net extension. For example, <your_project>
/networks/ <your_netlist> .net.

Do not redistribute models from an outside source without permission.
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3. By default, each encoded library on the palette is represented by an image of a padlock. To set a custom bitmap
that will be more meaningful, first select the component in the right hand column labeled List of Designs and
Netlists to Encode. This will make the Set Bitmap button available for selection (this button is only available for
schematic designs, not netlist files).

Select the mixer design file first, then click the Set Bitmap (dsn only) button and the bitmap selection dialog will
appear. Some bitmaps that can be used are located in $HPEESOF_DIR/circuit/bitmaps as well as with the
DesignGuide Developer Studio.

Depending upon whether you are running on UNIX or the PC, select the appropriate Bitmap File entry field and
enter the path:

Unix Bitmap File

<Install Dir> / desi gngui des/ pr oj ect s/ dgst udi o/ ui / bi t maps/ adsbnps/ M XER. BMP

PC Bitmap File

<Install Dir> \ desi gngui des\ pr oj ect s\ dgst udi o\ ui \ bi t maps\ adsbnps\ M XER. BMP

=| Set bitmap for GilCellMix |

Uniz Bitmap File
fdesigngquides fprojects/dgstudio i bitmaps /adshbnps MIXER . BME

Browse...

PC Bitmap File

"

Browse...

Ok Cancel

To use the browser, click the Browse button and change the filter to upper case BMP. Select the desired bitmap
and close the bitmap selection dialogs.

Select the resistor component and enter the bitmap R.BMP from the same directory listed above. When a library
is created, a copy of the bitmap will be made and a new name assigned to it, to match the name of the
component. This file will be installed with the library, so the end user will not be required to have the complete
set of ADS bitmaps installed if they are just using the library. If you do not select a bitmap for a particular
platform the default padlock will be used when running ADS on that platform.

4. By default, all the circuits and the devices being encoded have their DC device operating points suppressed.
However, you have control over that and can change it. An easy way to do this is to click on the Visible All
checkbox. This will ensure that all the devices in all the circuits that are being encrypted will have their DC device
operating points accessible to the end users. Such DC device operating point information can be seen in the Data
Display after running a DC simulation. Note that this is optional; it is not a required step to encode your designs.

5. If you want finer control over which devices in your circuits have their DC device operating points accessible,
select a design in the list on the right, and then click on the Visible Devices (dsn only)... button. In the dialog box
that opens up, you can now select one or more devices.
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T Edit visible Components
Invisible Devices Visible Devices

i

AR

=
[] select al [] select al
[ ik, ] [ Cancel ] [ Help ]
6. Use the Library Information section to define your new encoded IP library. The name at_mixlib should be used
for this tutorial. Enter it into the Library Name field.

& Note
Valid library names contain only alphanumeric and underscore characters. All other punctuation characters are
illegal. The first character must be alphabetic or an underscore. Names starting with the string untitled are not
allowed.

& Hint
When selecting a library name for your custom library, choose a name that is unique and descriptive. This will
help avoid name conflicts with other IP providers.

7. Enter a version number into the Version Number field. The default version value is 1.

8. Enter a clear description of your library into the Library Description field.

9. The current working directory is the default for the Destination Path field. If you wish to change the path, enter a
new path in the Destination Path field or click Browse to view and choose a currently available path. The encoded
library package will be created in the specified directory.

10. Select Design Kit with no .zip file . If you choose to create a zip file of an encoded Design Kit, refer to the ADS
Design Kit Installation and Setup documentation for instructions on how to install a design kit from a zip file.

11. Enter your Name, Company, and Email Address in the respective field within the Encoded By section. This will
provide contact information about the person creating the encoded library.

12. After all of the appropriate information is entered, select the Encode button in the lower left-hand corner of the
dialog box. An Encoding Status box appears.

13. Click OK to dismiss the Encoding Status dialog box.

Once the encoding process is complete, you should have one of the two results described below:

An ADS Design Kit with a zip file (extension = .zip ).
An ADS Design Kit directory structure without a zip file. This will be created under the path that you specified as
the Destination Path.

For a Design Kit, information about the kit can be found in the design kits doc directory in a file called about.txt.
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Installing the Encoded IP Library

The method used for installing your encoded IP library will depend on how the library was packaged.

 Note

Before installing an encoded library, be sure to exit ADS. Also ensure the $HPEESOF_DIR environment variable
(%HPEESOF_DIR% for PC) is set to your installed location of Advanced Design System and that
$HPEESOF_DIR/bin (%HPEESOF_DIR%\bin for PC) is in your path. For more information, refer to Installing
and Removing the RF IP Encoder.

e If your library was packaged as an ADS Design Kit, follow the steps provided in Installing an Encoded Design Kit.

© Note

For further information on working with packages, refer to Working with Encoded Designs.

Installing an Encoded Design Kit

To install an encoded design kit from the ADS Main window:

1. Choose DesignKit > Install Design Kits . The Install ADS Design Kit dialog box appears.

2. In step one of the dialog box ( Unzip Design Kit ), click the Unzip Design Kit Now button to unzip a design kit.
The Unzip ADS Design Kit dialog box appears enabling you to set the source and target directories for your
design kit. Use the Browse buttons in the dialog to quickly locate the source and target. Click OK once the source
and target are defined. The design kit zip file is unzipped in the specified location.
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=| Install ADS Design Kit |

1. Unzip Design Kit
This step may be skipped if the Design Kit is already unzipped.

Unzip Design Kit Mow...

2. Define Design Kit

Enter full Path to the directory of the desired Design Kit.
IT available, the remaining info will be automatically filled in.

Path

Browse...

Hame

Boot File {optional)

"

Browrse...

Yersion

Warnhug Design K4 warndus sl nfamalion,

3. Install Design Kit

Select Installation Level :  TUSEERE LEVEL

PLEASE HOTE: Enabling a Design Kit will close all open schematic
and layout windows.

7 oK Cancel Help I

3. In step two of the dialog ( Define Design Kit ), notice that the Path, Name, Boot File, and Version are now all

displayed automatically.
4. In step three of the dialog ( Select Installation Level ), select USER LEVEL for this tutorial.
5. Click OK in the Install ADS Design Kit dialog box. A confirmation message indicating that the design kit was

successfully installed should appear.
For more information on installing design kits, refer to the ADS["../dkug/wwhelp.htm" Design Kit Installation and

Setup] documentation.

Opening the Test Schematic Design
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Use the following steps to open a test schematic design.

1. Restart ADS and attach to the EncoderTest_prj .
2. From the Schematic window, select File > Open Design to display the Open Design dialog box.

=] Open Design:2 |

Project

EncoderTest_prj Include/Remove...

Filter
al Musers/crscott/rfipenc /EncoderTest prj/fnetworks/+ dsr Brovrse...

Open Design in:
@ Current Window _) New Schematic Window ) New Layout Window

Designs
GilCellMix .dsn

BWBEtFI F.dsn

* Design has been modified but not saved

0K Filter Cancel Help |

Click TestCkt.dsn from the Designs list. The TestCkt.dsn schematic already contains simulation components used

for this example.
4. Click OK to open the TestCkt.dsn schematic in the ADS Schematic window.
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Test Circuit Schematic

Adding the Encoded Designs

Newly encoded libraries will appear in the Library Browser under the category Encoded Designs .
Use the following steps to add the encoded designs into the Advanced Design System Schematic window.

1. From the Schematic window, select Insert > Component > Component Library .
A Component Library Schematic dialog box appears, enabling you to select the components in the encoded IP

library.

24



Advanced Design System 2008

| Component Library/Schematic: Z « ||
File Edit View Options Tools Help
Coxdd B DE=EE W O
Libraries Components
[ System Library Component Description
| Mixers simpleR_at_mixlib Encoded: simpleR i
——— Amplifiers GilCellMix_at_mixlikb Encoded:; Encoded |, _ |
—— SMT Mixers
—— SMT Amplifiers
——— SMT Filter
- Filters
—— Power Dividers
—— Switches
—— SMT Crystals

——C0E Encoded Library

User Library
Block Text Fonts
—— IDF Components

'| Default Mode: Browse A/RF Library: License: at_mixzlib

2. In the Component list box of this dialog, click the component you want to include in your schematic. In this case,
click GilCellMix_at_mixlib .

 Note

GilCellMix_at_mixlib and simpleR_at_mixlib are the newly encoded designs in the at_mixlib encoded IP
Library.If you want a description name other than the default, the name must be specified while creating the
encoded library. See Creating an Encoded IP Library for more information.

 Note

Only encoded designs will appear in the Component list. Encoded netlists will not be listed.

3. An instance of the encoded design is attached to the cursor for you to place. In the ADS Schematic window, click
the left mouse button to place the symbol as shown in Adding the Encoded Designs.

4. After the mixer is placed in the schematic, choose the Cancel Command And Return To Select Mode icon to
proceed with the next step. %

 Note

While the simpleR_at_mixlib encoded design could be added to the schematic in the same manner as above,
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the following describes a different method.

5. Select the Component palette selection for at_mixlib . Click the simpleR_at_mixlib to place it on the schematic.

 Note

Only encoded designs will appear in the component palette . Placing the cursor over an encoded design in the
palette displays a description of the encoded design. Encoded netlists will not appear in the palette.

6. After the resistor is placed in the schematic, choose the Cancel Command And Return To Select Mode icon to
proceed with the next step. You will need to rotate the simpleR_at_mixlib component and place it in the circuit
output as shown in Adding the Encoded Designs. The schematic is now complete and ready for simulation.

~| [ EncoderTest_prj ] TestCkt * (Schematic):2
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Adding the Encoded Designs

Editing Design Variables

Use the following steps to edit a design variable in the Advanced Design System schematic.

1. Select the X2 component simpleR_at_mixlib .
2. Select Edit > Component > Edit Component Parameters to edit the value of Rx or choose the Edit Component

26



http://edocs.soco.agilent.com/display/ads2008/Getting+Started+with+RFIC+Dynamic+Link#GettingStartedwithRFICDynamicLink-1104227

Advanced Design System 2008

Parameters icon.

3. A dialog box appears enabling you to modify the value of Rx.

simpleR - encoded

|

simpleR_at_mixlib
Instance Name (name[<start:stop=])

HZ
Rx (Real, e.g. 1.25)

500 Ohm

aelect Parameter

R==50.0 Ohim

Equation Editor...

Optimization/Statistics/DOE Setup...

X Display parameter on schematic

Fgid £ Faste Component Options...

7 oK Spply Cance] Reset Help

Pushing into the Design Hierarchy

Use the following steps to view a design deeper in the Advanced Design System schematic hierarchy.

1. In the ADS Schematic window, click the component you want to push into.

2. Choose the Push Into Hierarchy icon. ‘il

 Note

If you select a component that is encoded, you will not be able to view the contents of the design.

3. Try to push into the GilCellMix_at_mixlib and simpleR_at_mixlib subnetworks. Note that you are not able to view
the contents of the encoded designs and that an error dialog is displayed.
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=| Error:2 |

(etrror) GilCellMiz_at_mixlib
@ Cannot push into this component

oK

Performing a Simulation

Use the following steps to perform a simulation on the TestCkt schematic and view the results in a plotted Data
Display.

1. From the Schematic window, select Simulate > Simulate or choose the Simulate icon. This netlists the top-level
Advanced Design System schematic, and starts the Advanced Design System simulator. @|

) Note

A simulation status window appears, reporting the status of the simulation; depending on your system, this
may take a few moments. Check this status window to see if any errors occurred during netlisting or
simulation.

2. After the simulation is complete, a Data Display window automatically appears.

Displaying Your Results

Use the following steps to view the results of your simulation in a plotted Data Display.

1. Select TestCkt from the Dataset drop-down list if it is not already displayed.

2. From the Data Display window, select Insert > Plot , move the frame to an appropriate location within the
window and click. The Plot Traces & Attributes dialog box appears. Similarly, you can choose the Rectangular Plot
icon to drag and drop the plot frame.

e

Select ConvGain and then click Add . Select dB from the dialog box then click OK .
4. Click OK again to view the Data Display . The plot below shows the Conversion Gain, at 1.0GHz to be
approximately 21.59 dB.

w
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m1
Frf=1.000E9
dB(ConvGain)=21.586

m1

dB(ConvGain)

1|:| IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII

0.0 T0EH ZO0OEY 30EY 40EH S50EY GBOES T.0EH
Frf

Data Display of Conversion Gain for TestCkt

For more information on displaying results, refer to the Data Display documentation.

Verifying Your Results

You can also verify the results of your simulation by running a simulation using the original schematic and comparing
the results. The original schematic is called SweptRF and is also saved in EncoderTest_prj . This design uses a
subcircuit that has not been encoded. Note that you can push into the Gilbert Cell Mixer in this design.

Ending the Session

Use the following steps to exit ADS.

1. Choose the Advanced Design System Schematic menu option File > Exit Advanced Design System . This displays
a Save Changes dialog box that asks: Do you want to save changes to design?
2. Select No To All from the dialog box.
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Congratulations... you have now successfully completed the Tutorial.

Encoding Schematic Designs and Netlists

This section is intended to be a quick reference for encoding schematic designs and netlists. Most of this material is
repeated in Getting Started Tutorial.

Creating an Encoded IP Library

Follow the steps below to create an encoded IP library from one or more schematic designs and/or netlists.

1. Remove any simulation controllers present on the schematics of the designs that are to be encoded.

2. From the schematic window, select Tools > Encode Designs. A dialog box appears asking your permission to
close all designs and schematic windows. Select No if you have unsaved changes that you need to save. If you
select Yes, the Create Encoded Library dialog box appears.

3. In the Available Designs and Netlists field, highlight each individual schematic design or netlist you want to
include in your library and then click Add. This adds each selection and displays the selected schematic designs
and netlists in the List of Designs and Netlists to Encode field . Similarly, individual schematic designs or netlists
can be removed from the List of Designs and Netlists to Encode by clicking Remove.

To include your own netlists in the Available Designs and Netlists list, place your netlists in the networks
subdirectory of the current project directory. For example:

<your_project>/networks/<your_netlist>.net

All netlist files must have a .net extension to be recognized by the IP Encoder. To find netlists which are not in
the networks directory, click the Browse Netlists button.

 Note

Encoded designs will appear on the palette and library browser. Encoded netlists will not appear on the palette
and library browser. For more information, refer to Using Encoded Netlists.

In case of designs that have several levels of hierarchy (i.e., designs with other subcircuits included in them),
you can encode the entire design by selecting the top level design .dsn file for encoding. However, if a design
is encoded in this manner, only the top level ports are accessible in the encoded component. If you wish to
access a subcircuit individually, then that subcircuits .dsn file must be selected and encoded explicitly. In this
case, two different encoded components are formed (one for top level and another for subcircuit) each of
which are complete in themselves.
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Library Contents

Arvailable Dezigns and Metlistz

- - Lizt af Dezignz and Metlists to Encode
GilCellbdix.d
ﬁm' o GiCelMixden

| Add »> |

<< Remove I

Browse Methsts. . I

Set Bitmap [dzn only]...

Library Information

Libramy Mame Libram YYerzion
| at_mixlibs [

Library Descrphion
|Encoded Gilbert Cell Mixer

Destination Fath

|I::"~L|SEFES"-.DEF.-“-‘-.L| LTuP_Encoder_Tutonal\EncoderE sample_prj Browse...
E ncoding Format
f* Deszign Kit with zip file (" Design Kit with no . zip file
Encoded By
M ame Comparny Email Address
|Steveni |.-’-'-.gi|ent Technologies |steve_iacksun@agilent.|:|:|m

Encode Cancel | Help

4. By default, each encoded library on the palette is represented by an image of a padlock. To set a custom bitmap
that will be more meaningful, first select the component in the right hand column labeled List of Designs and
Netlists to Encode. This will make the Set Bitmap button available for selection. This is only available for
schematic designs, not netlist files.

With a design file selected, click the Set Bitmap (dsn only) button and the bitmap selection dialog will appear.
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=| Set bitmap for GilCellMix |

Unix Bitmap File
Ffdesignouides projects dgstudio i hitmaps fadshnps MIEER . BME

Brovwsse...

PC Bitmap File

Browsse...

Ok Cancel

Enter the path to a bitmap. Libraries of ADS palette bitmaps are contained in:

$HPEESOF_DI R/ ci rcui t/ bi t maps

and

$HPEESOF_DI R/ desi gngui des/ proj ect s/ dgst udi o/ ui / bi t maps/ adsbnps

To use the browser, click the Browse button. Some of the bitmaps have upper case names and some have lower
case names. To see all selections, change the filter to *.*. Select the desired bitmap and close the bitmap
selection dialogs.

When a library is created, a copy of the bitmap will be made and a nhew name assigned to it, to match the name
of the component. This file will be installed with the library, so the end user will not be required to have the
complete set of ADS bitmaps installed if they are just using the library.

Use the Library Information section to define your new encoded IP library. Choose a unique name for your
encoded IP Library and enter it into the Library Name field.

Note

Valid library names contain only alphanumeric and underscore characters. All other punctuation characters are
illegal. The first character must be alphabetic or an underscore. Names starting with the string untitled are not
allowed.

Hint
When selecting a library name for your custom library, choose a hame that is unique and descriptive to avoid
possible confusion with other encoded libraries.

10.

Enter a version number into the Version Number field. The default version value is 1.

Enter a clear description of your library into the Library Description field.

Manually enter a path in the Destination Path field or click Browse to view and choose a currently available path.
The encoded library package will be created in the specified directory.

Select an encoding format.

A design kit style library has a lot more flexibility and support in ADS. It can be installed from the DesignKit
menu in the ADS Main window, and can be installed anywhere on the user's machine. Select Design Kit with .zip
file if your library will be complete as is or if you would like to test it immediately. If you would like to add more
capability or customization, consult the Design Kit Development documentation for detailed instructions and
examples, as well as instructions on how to manually package the file for distribution. Whether or not you select
the .zip file option, the complete library in unzipped format will remain on your machine in the directory you
specify.

Enter your Name, Company and Email Address in the respective field within the Encoded By section. This will
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provide contact information about the person creating the encoded library.

11. After all of the appropriate information is entered, select the Encode button in the lower left-hand corner of the
dialog box. An Encoding Status box appears.

12. Click OK to dismiss the Encoding Status dialog box.

Once the encoding process is complete, you will have an ADS Design Kit with a zip file (extension = .zip ), or an ADS
Design Kit directory structure without a zip created in the path you specified as the Destination Path.

For a Design Kit, information about the kit can be found in the design kits doc directory in a file called about.txt.

Libraries with Data File References

The RF IP Encoder does not support the encoding of file-based components (such as S-parameter data file
components). The Encoder will automatically move any referenced data file components into the Design Kit
circuit/data directory. The encoded library will then reference these un-encoded data files in this new location.

If encoded data files are required for the release of your design, please contact your Agilent Technologies technical
support representative. For more information, refer to http://eesof.tm.agilent.com/support/.

Working with Encoded Designs

This section will assist the model-user (typically an RF Board designer) with instructions on installing, viewing, using
and removing encoded IP libraries. Your encoded IP library is created as either a standard ADS Add-on package or an
ADS Design Kit. For information on installing or removing ADS Design Kits, refer to the ADS Design Kit Installation and
Setup documentation. Before attempting to use the hpeesofpkg command, refer to Configuring the Environment.

Viewing Packages

To view the list of currently installed packages, including your encoded IP libraries, open a terminal window and type
the following:

hpeesof pkg --1i st

A list similar to the one below will be displayed (only partial list is shown).

Desi r ed=Unknown/ | nst al | / Renove/ Pur ge

| Status=Not/Installed/ Config-files/Unpacked/ Fail ed-config/Half-installed

|/ Err?=\(none\)/Hol d/ Rei nst - r equi r ed/ X=bot h- probl ens \ (Status, Err: uppercase=bad\)
||/ Nane Ver si on Description
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\ H\ H -

ii antennas-prop 1.9.1 Ant ennas and Propagation Library

ii at-mxlib 1 1\) Glbert Cell Mxer, 2\) Resistor
ii cdma 1.9.1 CDVA

ii circuit-encoder 1 Circuit Encoder

ii controls-displa 1.9.1 Interactive Controls and Displ ays

ii fixpt-analysis 1.9.1 Fi xed Poi nt Anal ysis}}

Using Encoded IP Libraries

Encoded IP libraries can be used in Advanced Design System just like any other library with two exceptions. If you are
using an encoded subcircuit from a schematic design, you will not be able to push into its hierarchy. Also, there are
special instructions for including the contents of an encoded netlist file in a simulation. For more information, refer to

Using Encoded Netlists.

Using Encoded Subcircuits

To use an encoded subcircuit, first select the library to display in the component palette on the left hand side of the
schematic window. Encoded components may be displayed with a generic padlock icon. To identify the name of the
component, hold the cursor over the padlock icon until the component name appears. Alternatively, you can select
components in an encoded library from the library browser by choosing Insert > Component > Component Library in
the schematic window or simply click the library tool button. m

If an encoded component design has variable parameters, you are able to change the value of certain components
within the design. This information is typically provided by the Model-Provider. For more information on variable
parameters, refer to " Creating Hierarchical Designs " in the Schematic Capture and Layout documentation.

Using Encoded Netlists

Encoding Schematic Designs and Netlists, described how to create an encoded library out of schematic subcircuits. It
is also possible to create a library when you have an ADS netlist. This is a typical scenario for a foundry creating a
design kit. In this section, you will learn how to encode a netlist that contains subcircuits, and how to use the encoded
library in a simulation. It is also possible to encode a netlist that contains model cards and variables. For more
information about this topic, refer to the Design Kit Development documentation.

 Note
The following steps assume that you have completed the Getting Started Tutorial and created a design kit.
Note that this is an advanced topic and will require manual editing of AEL and other text files.
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To create a netlist to encode:

1. Open the EncoderExample_prj project that was used in Creating an Encoded IP Library.
2. Create a new design and place an instance of simpleR and an instance of GilCellMix as shown in Simple Design.
The location and connectivity is not important so feel free to place them anywhere and do not place any wires.

S—"\NNT—=®

simpleR

GilCellMix X1
X2 Rx=50.0 Ohm

Simple Design

3. From the ADS Main window, choose Tools > Command Line.
4. In the Command>> field, enter the command de_netlist(); The de_netlist(); command should appear in the
Command History field after it has been entered.

=| Command Line [ Session file: fvarftmp/maaal6110.dem | |
Command History
de_netlist(};
Command == Save Favorite
| Del Favorite
7 Apply Clear History Cancel Help

5. From the ADS Main window, choose Tools > Text Editor. Use this or any other text editor to open the file called
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netlist.log. The netlist.log file can be found in the EncoderExample_prj project directory.

Edit the text file and remove the first line at the top that starts with the word " Options".

Remove the last two lines at the bottom of the netlist.log file. One line starts with "simpleR:X" and the other with
"GilCellMix:X ".

Save your netlist in the project networks subdirectory as gilcellmix.net (note the .net extension). Your
EncoderExample_prj/networks/gilcellmix.net netlist file should look like the example shown below.

Example Netlist File

[T W o e B

bn—_——=

T =

e i e I Wl e i B B O el Wi B e s B e B e W i e B s W o Wi Bl = Bl

efine sinpleR\( _netl6 _netl5\)

arameters Rx=50.0

Rl _netl6 _net1l5 R=Rx Noi se=yes

nd sinpleR

efine GlCelIMx \( _netl2 _net6 _net22 _netl5\)
par aneters

"R6 _net9 _net28 R=20 Chm Noi se=no
:R3 _netl7 _net2 R=50 Chm Noi se=no
:C3 0 _net2 C=1.0 uF

:Cl _netl2 _netl0 C=1 uF

:L1 _netl0 _net2l1 L=0.5 nH Noi se=yes
Rl _netl1l3 _net2l1 R=50 Chm Noi se=no
" R7 _netl7 _netl16 R=100 Chm Noi se=no
:C4 _netl5 _net7 C=1 uF

:L2 _net7 _netl1l6 L=0.5 nH Noi se=yes
:R10 _net6 _netl R=400 Chm Noi se=no
RO _netl7 _netl6 R=100 Chm Noi se=no
R2 _net13 _net3 R=50 Chm Noi se=no
R8 _net6 _net26 R=400 Chm Noi se=no
:R11 _net6 _net24 R=800 Chm Noi se=no
:R12 _net24 _net18 R=700 Chm Noi se=no
:C5 _netld4 _net25 C=1 uF

:L3 _net25 _net22 L=0.5 nH Noi se=yes
" R13 _net18 _net4 R=500 Chm Noi se=no
R4 _net20 0 R=170 Chm Noi se=no

R5 net23 0 R=170 Ohm Noi se=no

:R14 _net19 0 R=200 Ohm Noi se=no

:C2 0 _net3 C=1 uF

:R15 _netl1l 0 R=1000 Chm Noi se=no
:R17 _net5 0 R=45 Ohm Noi se=no

BJTML": BJT8 _netl _netl6 _net8 Area=1 Mbde=1 Noi se=yes

"IBJTML": BJT6 _net26 _net2 _net8 Area=1 Mbde=1 Noi se=yes

BIJTML": BJT5 _netl _net2 _net27 Area=1 Mbde=1 Noi se=yes

"IBJTML": BJT7 _net26 _netl6 _net27 Area=1 Modde=1 Noi se=yes
"IBJTMR": BJT4 _net8 _net3 _net28 Area=1 Mbde=1 Noi se=yes

BJTM2": BJT3 _net27 _net 21 _net9 Area=1 Mbde=1 Noi se=yes

"IBJITMA": BJT9 _net6 _netl _netl4 Area=1 Mbde=1 Noi se=yes
"IBJTMB": BJT14 _netl4 netll net5 Area=1 Mode=1 Noi se=yes

BIJTM3": BJT10 _net6 _net24 _netl7 Area=1 Mode=1 Noi se=yes

"IBJTM3": BJT11 _netl7 _netl8 _netl1l3 Area=1 Mode=1 Noi se=yes
"IBJTM3": BJT12 _netl3 _net4 _netll Area=1 Mode=1 Noi se=yes

BIJTM3": BJT13 _net4 _netll _netl19 Area=1 Mode=1 Noi se=yes

"IBJTM3": BJT1 _net28 netll net23 Area=1 Mode=1 Noi se=yes
"IBJTM3": BJT2 _net9 _netll net20 Area=1 Mode=1 Noi se=yes

lodel BJTM2 BJT NPN=1 PNP=0 | s=2.1482293E- 16 Bf =1. 30035647E\ +02

If =1. 03E\ +00 Vaf =2. 50E\ +01 | kf =1. 08500002E- 02 | se=7.56173434E- 13

le=2. 00E\ +00 Br=5.12295082E\ +00 Nr=1. 00E\ +00 | kr =5. 600000013E- 02

sc=2. 00640001E- 12 Nc=2. 00E\ +00 Rb=3. 16646062E\ +01 Rbm=1. 06309524E\ +01

be=1. 78571429E\ +00 Rc=3. 75704756E\ +01 | max=1.0 A C e=1. 93536003E- 13

[ e=8. 49999987E- 01 M e=3. 99999994E- 01 Cj c=1. 04500002E- 13 Vj c=7. 49999989E- 01
| c=4.99999993E- 01 Xcj c=2. 92440187E-01 Cj s=1. 09200002E- 13 Vj s=6. 99999990E- 01
| s=4. 99999993E- 01 Fc=7.99999988E-01 Xt f=3. 35472224E\ +00 Tf=8.91292803E- 12

t f =2. 17000005E- 02 Pt f=1. 80E\ +01 Tr=1. 60000005E- 09 Kf=0. 00E\ +00 Af=1. 00E\ +00
\b=1. 00 Fb=1.00 Iss=0 A Ns=1.00 Nk=0.50 Ffe=1.00 Lateral =0 RbMddel =0

\ppr oxgb=1 Tnon¥25. 0 Eg=1.11 Xtb=2.20E\ +00 Xti =8. 00E\ +00

[odel BIJTML BJT NPN=1 PNP=0 |s=1.07411147E-16 Bf =1. 30035647E\ +02
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Now that you have a netlist file, encode the netlist as described in Creating an Encoded IP Library, creating a design
kit named at_mixlib, in a different location than the original at_mixlib design kit that was created with the schematic
subcircuits in the tutorial. Then follow the next steps to modify the design kit created in the tutorial. In this process,
you will copy some files from the new at_mixlib design kit in the old mix_lib design kit, and then modify a few files. It
is important that these 2 design kits have the same name. You may prefer to make a copy of the old design kit before

Advanced Design System 2008

b—_——=

h - N

bn—_——=

T =

If =1. O3E\ +00 Vaf =2. 50E\ +01 | kf =5. 42499974E- 03 | se=3. 78086717E- 13

le=2. O0E\ +00 Br=5. 12295082E\ +00 Nr=1. 0O0E\ +00 | kr =2. 80000006E- 02

sc=1. 16160000E- 12 Nc=2. 00E\ +00 Rb=6.12458791E\ +01 Rbn¥1l.91785714E\ +01
e=3.57142857E\ +00 Rc=6. 96232096E\ +01 | nex=1.0 A G e=9. 67680017E- 14

[} €=8. 49999987E- 01 M e=3.99999994E- 01 C c=6. 05000011E- 14 Vj c=7. 49999989E- 01
| c=4.99999993E- 01 Xcj c=2.52561980E- 01 C s=8. 68000015E- 14 Vj s=6. 99999990E- 01
| s=4. 99999993E- 01 Fc=7.99999988E- 01 Xt f =3.35472224E\ +00 Tf=8.91292803E- 12
tf=1. 08500002E- 02 Ptf=1.80E\ +01 Tr=1. 60000005E- 09 Kf=0.00E\+00 Af=1.00E\ +00
\b=1. 00 Fb=1.00 Iss=0 A Ns=1.00 Nk=0.50 Ffe=1.00 Lateral =0 RbMbddel =0

\jopr oxgb=1 Tnon¥25. Eg=1.11 Xt b=2. 20E\ +00 Xti =8. 00E\ +00

fpdel BITMA BJT NPN=1 PNP=0 |s=4.29644587E- 16 Bf=1. 30035647E\ +02

if =1. 03E\ +00 Vaf =2. 50E\ +01 | kf=2. 17000005E- 02 | se=1. 51234685E- 12

le=2. O0E\ +00 Br=5. 12295082E\ +00 Nr=1. 00E\ +00 | kr=1. 11999998E- 01

sc=3. 69600001E- 12 Nc=2. 00E\ +00 Rb=1.61795253E\ +01 Rbn¥5. 66269841E\ +00

e=8. 92857130E- 01 Rc=2.27441087E\ +01 | max=1.0 A Cj e=3. 87072007E- 13

[} e=8. 49999987E- 01 M e=3. 99999994E- 01 C c=1. 92500003E- 13 Vj c=7. 49999989E- 01
| c=4.99999993E- 01 Xcj c=3. 17506489E- 01 { s=1. 54000003E- 13 Vj s=6. 99999990E- 01
| s=4. 99999993E- 01 Fc=7.99999988E- 01 Xt f =3. 35472224E\ +00 Tf=8.91292803E- 12

t f=4. 34000010E- 02 Ptf=1.80E\ +01 Tr=1. 60000005E- 09 Kf=0.00E\+00 Af=1.00E\ +00
\b=1. 00 Fb=1.00 Iss=0 A Ns=1.00 Nk=0.50 Ffe=1.00 Lateral =0 RbMbddel =0

\ppr oxgb=1 Tnon¥25. Eg=1.11 Xt b=2. 20E\ +00 Xti =8. 00E\ +00

fodel BJTM6 BJT NPN=1 PNP=0 |s=4.08631847E-16 Bf =1. 66178934E\ +02

If =1. O3E\ +00 Vaf =2. 50E\ +01 | kf =2. 32500005E- 02 | se=1. 21824776E- 12

le=2. 00E\ +00 Br=5. 12295082E\ +00 Nr=1. 00E\ +00 | kr=1. 199999998E- 01

sc=4. 08480002E- 12 Nc=2. 00E\ +00 Rb=5.91784277E\ +01 Rbn¥1l.41063123E\ +01

be=8. 33333321E- 01 Rc=2. 20144369E\ +01 | max=1.0 A C e=3. 12320005E- 13

[} €e=8. 49999987E- 01 M e=3.99999994E- 01 C c=2. 12750004E- 13 Vj c=7. 49999989E- 01
| c=4.99999993E- 01 Xcj c=2. 21856636E- 01 C s=1. 65300003E- 13 Vj s=6. 99999990E- 01
| s=4. 99999993E- 01 Fc=7.99999988E-01 Xtf=3.16117215E\ +00 Tf=7.97477712E-12
tf=4. 65000010E- 02 Ptf=1.80E\ +01 Tr=1. 60000005E- 09 Kf=0.00E\+00 Af=1.00E\ +00
\b=1. 00 Fb=1.00 Iss=0 A Ns=1.00 Nk=0.50 Ffe=1.00 Lateral =0 RbMbdel =0

\ppr oxgb=1 Tnon¥25. Eg=1.11 Xt b=2. 20E\ +00 Xti =8. 00E\ +00

[odel BJTMB BJT NPN=1 PNP=0 | s=2. 04315924E- 16 Bf=1. 66178934E\ +02

If =1. 03E\ +00 Vaf =2. 50E\ +01 | kf =1. 16250003E- 02 | se=6. 09123888E- 13

le=2. 00E\ +00 Br=5. 12295082E\ +00 Nr=1. 00E\ +00 | kr =6. 00000013E- 02

sc=2. 31840001E- 12 Nc=2. 00E\ +00 Rb=1.17166379E\ +02 Rbm=2. 70221484E\ +01

be=1. 66666667E\ +00 Rc=3. 58072512E\ +01 | max=1.0 A C e=1. 56160003E- 13

[ e=8. 49999987E- 01 M e=3. 99999994E- 01 Cj c=1.20750002E- 13 Vj c=7. 49999989E- 01
| c=4.99999993E- 01 Xcj c=1. 95445132E- 01 Cj s=1. 18900002E- 13 Vj s=6. 99999990E- 01
| s=4. 99999993E- 01 Fc=7.99999988E-01 Xtf=3.16117215E\ +00 Tf=7.97477712E-12

t f =2. 32500005E- 02 Ptf=1. 80E\ +01 Tr=1. 60000005E- 09 Kf=0. 00E\ +00 Af=1. 00E\ +00
\b=1. 00 Fb=1.00 Iss=0 A Ns=1.00 Nk=0.50 Ffe=1.00 Lateral =0 RbMddel =0

\jppr oxgb=1 Tnon¥25. Eg=1.11 Xt b=2.20E\ +00 Xti =8. 00E\ +00

nd G CellM x

you start modifying it. You should also make a copy of EncoderTest_prj.

1. From the new design kit, copy the file circuit/models/at_mixlib.library to the circuit/models directory of the old

2.

design kit.

In the old design kit, edit the file circuit/ael/at_mixlib_encode_item.ael. For each of the two item definitions, you
will need to modify the netlistFormat and netlistData information as shown in the example below. Note that the
changes are shown in bold. After you have modified the file, be sure to save your changes.
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" Conponent Paraneters",
"#uselib \"at_mixlib\"

% Y%e%e" ,
" *gilcell mx* _at_mxlib",
Conponent Annot Fnt ,
"SYM G I Cell Mx_at_mxlib",
0,
NULL,
| TEM PRI M TI VE_EX
NE

et _sinmul ator_type\(1\);

et _design_type\(1\);

reate_item ("sinpl eR at_m xlib",
"sinmpl eR - encoded”,
N

| TEM_NOT_ALL_PARM

-1,

NULL,

" Conmponent Paranet ers",

"#uselib \"at_mixlib\"

% Y%e%e" ,
*gilcellmx*
Conponent Annot Fnt ,
"SYM si npl eR_at _mi xIi b",
0,
NULL,
| TEM PRI M Tl VE_EX,

et _sinmulator_type\(1\);
et _design_type\(1\);
reate_item ("Gl Cell Mx_at_mixlib",
"Encoded G lbert Cell Mxer - encoded"
v
| TEM NOT_ALL_PARM
-1,
NULL,

\"9%e\"\n}} *\"GICellMx\"*

UBL2%C% _net %% % Y% % YbYB?9R9?% Y80?%p% UKIR\ [ %A \ | % =%p%

\ " og\ "\ n}}
UB129C% _net %% % Ye % YbYB29R9?% %B0?% % YKYR\ [ %i\ ] % =%p%

*\"si

_at_mxlib",

/| Nane
/| Label
/1 Prefix
/I Attribute
//Priority
/1'i conName
/1 di al ogNane
// di al ogDat a
{{: % %t%44?0%

/I netlistFormat

[/ netlistData
/1 di spl ayFor mat
/| synmbol Name
/] artWor kType
/I art wor kDat a
/lextraAttrib

/ | Nare
/| Label
/] Prefix
/I Attribute
/IPriority
/'1'i conNane
/1 di al ogName
/1 di al ogDat a
mpl eR " * % %t%447?70%
/I netlistFormat

/I netlistData
/1 di spl ayFor nat
/' synbol Nane
/] art Wor kType
/I art wor kDat a
/lextraAttrib

reate_parm ("Rx","", 68608, " St dFornSet", " 1", prm (" StdForni', "50. 0"\)\)\);

w

&

@ N U

To test these changes, start ADS and open the EncoderTest_prj used previously in the tutorial.

If you previously installed the design kit at_mixlib as described in Installing an Encoded Design Kit, disable or cut
that design kit from the ADS Main window menu pick DesignKit > Setup Design Kits. For more information, refer

to the Design Kit Installation and Setup documentation.
After the design kit has been disabled, close and restart ADS.

Now install the modified design kit as described in Installing an Encoded Design Kit.
Open the TestCkt design, and delete and replace the GilCellMix and simpleR components.

Simulate the circuit. The top few lines of netlist.log file in the project directory after simulation should resemble

the following:

pt i ons Resour ceUsage=yes UseNut megFor mat =no
opDesi gnNanme="/ Encoder Test _prj / net wor ks/ Test Ckt "
uselib "at_mxlib" "gilcellmx_at_mxlib"
simpleR': X2 Vif 0 Rx=50.0 Chm

uselib "at_mxlib" "gilcellmx_at_mxlib"
GlCelIMx": X1 Vrf _netl net2 net5
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Removing Encoded IP Libraries

You can remove an encoded IP Library that has been previously installed by entering:

hpeesof pkg --renobve < package_name >

Where package_name is the name of the encoded IP library being removed. Close ADS before removing a library.

 Note

Ensure the encoded IP library package exists and that you have the correct spelling before attempting to
remove it. See Viewing Packages for information on how to view the existing packages.

Troubleshooting RF Intellectual Property Encoder

This chapter provides information on known problems and solutions to help you resolve unexpected issues.

Known Problems and Solutions

Problem: Third party customer is unable to use two packages created by two separate vendors.

Solution: When selecting a library name, choose a name that is unique and descriptive. Two encoded libraries
with identical names will prevent a third party from using both simultaneously.

Problem: Encoded schematic designs do not work for my customer.

Solution: Encoded schematic designs may be version dependent. Verify the version that the library was created
in.

Problem: Encoded libraries do not appear on the component palette.

Solution: Ensure that the unix or windows environment variable COMPL_DIR is set. This environment variable
can be set to the same value as $HPEESOF_DIR (ADS install directory) if you have installed your encoded
libraries in the default location.
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Also make sure that the following configuration variables have not been modified.

Configuration Variable Must Contain
SYSTEM Cl RCUI T_SYMBOLS $HPEESOF_DI R/ Conponent Li bs/ synbol s
COVPONENT_LI BS_AEL {$COWPL_DI R}/ Conponent Li bs/ ael / Conponent Li bs

These are set in $HPEESOF_DIR/config/de_sim.cfg but can be overwritten in
$HPEESOF_DIR/custom/config/de_sim.cfg or $HOME/hpeesof/config/de_sim.cfg.

Problem: Custom bitmaps in a library created on a PC do not show up when the library is installed on unix. Or, custom
bitmaps in a library created on unix, do not show up when the library is installed on a PC. The IP Encoder is not

currently linked with a bitmap translator.

Solution: After the library is installed, it is possible to replace the default bitmaps if you have access to the
proper bitmaps for the second platform. The bitmaps in a library installed in the default location are stored in
$HPEESCF_DI R/ Conponent Li bs/ <libname> / bi t maps/ <platform>. The bitmap bears the same name as the
component. Some bitmaps that are available to copy are found in: $HPEESOF DI R/ ci rcui t/ bi t maps and
$HPEESOF_DI R/ desi gngui des/ pr oj ect s/ dgst udi o/ ui / bi t maps/ adsbnps.

Problem: When simulating with an encoded library, an error is generated about not finding the library.

Solution: The model may be missing from the configuration file, ADSlibconfig. A configuration line looks like this:

< encoded_lib_name > $HPEESOF_DI R/ Conponent Li bs/ nodel s/ < encoded_lib_name >.library

This line needs to be in one of the following files. All three will be read and the contents combined.

e $HPEESOF_DI R/ circuit/config/ ADSLi bconfi g
e $HPEESOF_DI R/ cust oni ci rcui t/ confi g/ ADSLi bconfi g
e $HOMVE/ hpeesof/circuit/confi g/ ADSLi bconfig

Additional Known Issues
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Netlist file must have the file extension .net.

No layout information is encoded. Fixed artwork will be copied over and included in the encoded library. AEL Macro
Artwork and Synchronized Artwork will have to be a manual step. Refer to Design Kit Development for Layout in the

Design Kit Development documentation.

There is a report of a failure during encoding when using some built-in ADS symbols.

Glossary for RF Intellectual Property Encoder

Add-On

A debian package file (.deb) that contains additional capabilities for Advanced Design System.

ADS (Advanced Design System)

This is the Agilent Technologies Advanced Design System.

AEL (Application Extension Language)

This is a C-like interpretive programming language to configure, customize and enhance the Advanced Design
System design environment.

callback

A function or expression that is evaluated when certain events occur; for example, clicking on a menu item.
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colormap

Indexed color table where each entry is a combination of R, G, and B pixel intensity values for UNIX X-windows
display. Table size (number of colors) per software application is limited by the number of display bits per pixel,
commonly eight.

DES (Data Encryption Standard)

Data Encryption Standard (DES) is a widely-used method of data encryption developed in 1977.

EDA (Electronic Design Automation)

EDA software and services give customers a distinct advantage by improving time-to-market, quality and
productivity in the design of electronic products.

encoded IP (encoded intellectual property)

A protected version of the contents of a schematic design or netlist.

encoded IP library (encoded intellectual property library)

A collection of encoded designs or netlists that appear on the ADS palettes as well as in the library browser.

HB (Harmonic Balance Simulation)

An iterative method of analysis that is based on the assumption that for a given sinusoidal excitation, there
exists a steady-state solution that can be approximated to satisfactory accuracy using a finite Fourier series.
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optimization

Mechanism by which a simulator finds the optimal value of a global parameter within a user-supplied range of
values.

OS (Operating system)

Such as HP-UX, Solaris, WinNT.

package

A special file archive that allows the easy distribution, installation and removal of Add-Ons for the Advanced
Design System.

RFIC

Radio Frequency Integrated Circuits.

RF IP Encoder (Radio Frequency Intellectual Property Encoder)

The product that takes schematic designs and netlists and generates package files that contain encoded IP
libraries which in turn contain encoded IP. The RF IP Encoder product provides a mechanism for sharing
simulatable ADS schematic designs and netlists without divulging your actual design information.

schematic design

A schematic circuit design created using the Advanced Design System.
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testbench

Top-level schematic used to analyze a sub-circuit using a circuit simulator.

tuning

Mechanism by which a simulator can quickly re-simulate a circuit using new values for a number of parameters
without having to re-input the netlist and recreate its data structures.
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