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About Importing and Exporting Designs

Translating CAD data between various systems can be difficult. Different CAD systems have different representations
of data. For instance, some systems contain the concept of a hole and some do not. Differences in translation formats
often cause data to be lost or transformed.

In Advanced Design System, translating physical designs is initiated from the layout window using the File > Import
and File > Export menu commands. The program's import/export translators are highly configurable. Each translator
has associated options that you can set from the Import and Export dialog boxes. These options control how the
translator works. For example, with the IGES and GDSII format flatten option, a layout can be translated as a flat,
non-hierarchical design. Similarly, the merge option for these formats creates two new polygons from two intersecting
closed shapes.

Other options include arc conversions, treatment of holes and text, and in the layers file, specification of layer
translation tables. The IGES translator has the greatest number of options because IGES is such a broad standard.
System defaults are included with the product and are automatically used if no others are specified.

Translating schematic designs is initiated from the ADS Main or Schematic window using the File > Import and File >
Export menu commands. Similar to the Layout translators, each schematic translator has associated options that
control how the translator works.

Layout Export Considerations

Before starting a layout, you should consider how the final output could affect the layout process. Different output
formats impose different restrictions. The restrictions imposed by GDSII are very different from those imposed by
DXF, HPGL, Mask, or Gerber.

With all export formats, you must consider layout units and data base precision. The units and precision used in layout
should match those you want in the final output.

Usually no problems are associated with translating units that are in the same measurement system (such as, mils to
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inches or centimeters to millimeters). However, round-off errors can occur when translating from metric-to-English

units or vice versa.

Similarly, no problem is associated with translating a less precise data base resolution in the program to a more
precise output resolution. However, the reverse process (such as, 0.001 Layout to 0.01 GDSII) can result in loss of

data.

Available File Formats

The Import and Export commands enable you to import and export files in a variety of different formats. You can

import files through Advanced Design System's Main, Schematic, or Layout window. All file export is currently done
from the ADS Layout window with the exception of Intermediate File Format (IFF) files. The following table shows the
available file formats and the individual import/export options.

Available Formats and Import/Export Options

Available File Formats and
File Extensions

ADS Main Window

ADS Schematic Window

ADS Layout Window

DXF/DWG (hierarchical) - - Import/Export
(.dxf, .dwg)

DXF/DWG (flattened) (.dxf, | - - Export

.dwg)

EGS Archive Format (_a) - - Import/Export
EGS Generate Format (_g) |- Import Import/Export
GDSII Stream Format - - Import/Export
(.gds)

Gerber (.gbr) - - Export

Gerber Viewer (.msk, .gbr) | - - Export
HPGL/2 (.hpg) - - Export

IFF (.iff) Import Import/Export Import/Export
IGES (.igs) - - Import/Export
Mask File (.msk) - Import Import/Export
MGC/PCB (.iff) - - Import/Export
Netlist File T Import Import -

1 For detailed information on SPICE (.cir, .cki) or Spectre (.
SPICE and Spectre documentation.

scs) netlist file import, refer to the Netlist Translator for
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Steps for importing and exporting these files are outlined in Importing and Exporting Schematic and Layout Designs.

DXF/DWG

The Drawing Exchange Format (DXF) was developed by Autodesk for its AutoCAD product and is widely used to
transfer geometric data between systems. Like the mask file format, it provides a simple geometric representation of
data. DXF files can be transferred between PC-based or UNIX-based systems. DXF is a very simple file format that can
be read by most CAD programs that support DXF.

DWG is a binary format, therefore the files take less time to load and save. Advanced Design System supports
importing and exporting to/from AutoCAD. AutoCAD versions 12 to 2007 are supported for import. AutoCad versions
2000, 2004 and 2007 are supported for export. Carefully consider how you want to use DXF/DWG output - including
layer numbering, use of holes, and polygon shapes - before beginning your layout design. Setting up the proper layout
rules in ADS can save a lot of time in generating acceptable DXF/DWG output. For specific considerations or
limitations, consult your AutoCAD documentation. For details, see DXF/DWG Translator.

EGS (Archive/Generate)

Engineering Graphics System (EGS) format is a general graphics format used for capturing manually entered designs.
EGS has been applied to ICs, Micro-circuits, Hybrids, and PC Board design applications. Using this format, you can
easily exchange data with other programs using EGS formats.

The layout portion of Advanced Design System has adopted many of the primitive types and styles that are part of the
EGS standard, but has a more enriched set of capabilities that structure information not representable in EGS. For
example, EGS files cannot represent embedded arcs.

Two variations of the EGS format are:

e The Generate format is a flattened list of EGS primitives specified in the user-defined unit space. No additional
information is supplied such as supplied with the Archive format.

e The Archive format is a hierarchically organized list of EGS primitives specified in the user-defined unit space.
Information such as drawing shapes, layout units, database precision, and grid spacing is included.

For details, see EGS Archive Files and EGS Generate Files.

GDSII Stream

GDSII Stream Format (Calma) is an industry standard for translating final mask data to foundries. The Advanced
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Design System reads GDSII versions 4.0 through 6.0 and writes GDSII version 6.0.

Unlike other data formats, GDSII stream format is binary. You cannot easily view or edit a stream format file using a
text editor. This format is easily translated between different CAD systems because it represents a highly restrictive
data type. However, the format has a number of significant limitations; these limitations are discussed in GDSII
Stream File Translator.

Gerber

Gerber refers to various data input formats that Gerber Scientific uses to drive its photoplotters. The Gerber format is
used by photoplotters produced by other manufacturers also. Advanced Design System supports various types of
Gerber output via mask files to either the Gerber or DXF translator. For details, see Gerber Translator.

Gerber Viewer

Gerber Viewer appears as an export file option. It is not a file format, but is placed on the export file menu so you can
open the Gerber Viewer at any time. In addition, you can access the Viewer during a DXF or Gerber export (see Using
the Gerber Viewer).

You can use the Gerber Viewer to view Gerber or mask files to help verify the correctness of your data. Also, you can
use the Gerber Viewer to configure mask file data for photoplotting.

HPGL/2

HPGL/2 output is a subset of the HPGL/2 printer/plotter language. In Advanced Design System, you can export
HPGL/2 files from the Layout window. For details, see HPGL/2 Files.

IFF

The Intermediate File Format (IFF) is an ASCII file with a simple, line-oriented command structure and a fairly rich set
of constructs. This format is machine- and application-independent, thus simplifying design data transfer.

IFF files are used as the exchange mechanism when transferring designs between Advanced Design System and
third-party EDA tools such as Mentor Graphics Design Architect and Cadence Analog Artist. For more information
about these framework links, contact your Agilent Technologies sales representative.

For details, see IFF Files.
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IGES

The Initial Graphics Exchange Specification (IGES) is an approved ANSI standard of the U.S. Department of
Commerce (ANSI Y14.25M) that is used extensively throughout the computer-aided design and manufacturing world.
The IGES format can represent both mechanical and electrical design data in two and three dimensions.

Because IGES is such a broad standard, the government has attempted to further define a stricter standard of IGES
for the transfer of electrical design data. This standard is known as CALS specification. The CALS specification for IGES
is officially contained in the military specification MIL-D-28000, Digital Representation for Communication of Product
Data: IGES Application Subsets.

The Advanced Design System supports version 4.0 and 5.0 IGES formats. The program reads and writes IGES CALS
Level 1 (technical illustration) and Level 3 (electrical/electronic applications) files. Level 2 (engineering drawings) is
not fully supported since Level 2 is used primarily for drafting applications.

Even with the CALS standards, CAD systems accept very different IGES formats. Although it is impossible to
accommodate every format, you can use a humber of options to configure various IGES translators, including
translators supplied by Autodesk, Mentor Graphics, and Cadence. For details, see IGES Translator.

Mask File

Mask file format is a simple flat (non-hierarchical) geometric description. The format facilitates the transfer of simple
geometric data for final mask processing. Only geometric forms are described in a mask file; simulation data, element
parameters, substrate definitions, and hierarchy are not included.

The Gerber and DXF translators use the mask file format as an intermediate file when converting data to Gerber and
DXF. For details, see Mask Files.

MGC/PCB

MGC/PCB files are IFF files that are used exclusively for Mentor Graphics design transfers. Although this format is
available from the Advanced Design System layout menu only, you can transfer both schematic and layout
information.

MGC/PCB files write to a specific location each and every time. When you select this format, the filename and location
of the IFF transport is determined automatically.

Netlist Files

Simulation Program with Integrated Circuit Emphasis (SPICE) is a simulation tool used by engineers throughout the
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world for simulating circuits of all types. Since its development at the University of California Berkeley, SPICE has
been commercialized and modified by a large number of vendors and also adopted and modified by electronics
companies for their own in-house use. Many designers and companies have large investments in existing subcircuits
or device models described by SPICE netlists that they want to use with the Advanced Design System from Agilent
Technologies.

Spectre is an EDA (Electronic Design Automation) tool produced by Cadence Design Systems, Inc. Spectre is used by
engineers throughout the world for simulating circuits of all types. Many designers and companies have large
investments in existing subcircuits or device models described by Spectre netlists that they want to use with the
Advanced Design System (ADS) from Agilent Technologies.

For detailed information on SPICE or Spectre file import, refer to Netlist Translator for SPICE and Spectre.

Importing and Exporting Schematic and Layout Designs

This chapter provides information on importing and exporting schematic and layout files as well as how to use the
Advanced Design System Layer Editor. For information on importing Netlists, refer to Importing a Netlist File.

 Note

To prevent performance and memory consumption problems with large designs such as reticles or imported
designs for use with Momentum, refer to Disabling Layout Connectivity Features.

Importing a Schematic

For available file formats that you can import from an ADS Schematic window, refer to Available Formats. For
information on importing SPICE and Spectre netlist files, refer to the Netlist Translator for SPICE and Spectre.

The procedure for importing each format is generally the same, however the available options differ. For options
relating to a particular file format, see the appropriate chapter.

To import a schematic design:

1. Open a project and choose File > Import. The Import dialog box appears.
2. Select the appropriate file format from the File Type drop-down list.
3. To define options for the imported file, click the More Options button. The Import Options dialog box appears.

 Note

The program translators are controlled by translator options files. A system-wide options file exists for each
translator. These files can be found in the $HPEESOF_DIR/config directory. The default system file is
automatically read when you click More Options in the Import dialog box (unless a local options file already
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exists in the current project directory). When you make changes in the options dialog box and click OK, a local
copy of the options file is written to the current project directory.

4. To specify the path and filename of the file you want to import, click Browse.

5. Double-click as needed to locate the directory containing the design. By default, all files are listed that have the
file suffix appropriate for the chosen file format.

6. Select the design you want to import and click OK. You are returned to the Import dialog box and the selected
filename appears in the field labeled Import File Name (Source).

7. Where applicable, type a new name for your imported design in the New Design Name (Destination) field.

 Note

For certain file types, the translator uses the existing filename to determine the new design name.

8. Click OK to import the design and dismiss the Import dialog box.

Exporting a Schematic

For available file formats that you can export from an ADS Schematic window, refer to Available Formats.

The procedure for exporting IFF files is the same as the import, but the available options differ. For options relating to
the IFF file format, see IFF Files.

To export a schematic design:

1. Open your design and choose File > Export. The Export dialog box appears.

2. Select IFF file format from the File Type drop-down list.

3. To set export options, click the More Options button. The Export Options dialog box appears.

4. Change options as needed and click OK.

5. To specify a path for the exported file, click Browse.

6. Double-click as needed to locate the directory for the exported design. By default, all files are listed that have
the file suffix appropriate for the chosen file format.

7. Click OK.

8. Type a new filename in the Export dialog box, following the path, and click OK. The file is written to the specified
directory.

Importing a Layout

For available file formats that you can import from an ADS Layout window, refer to Available Formats and

Import/Export Options.

The procedure for importing each format is the same, but the available options differ. For options relating to a
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particular file format, refer to the associated chapter.

To import a layout file:

1. In the Advanced Design System layout window, choose File > Import to open the Import dialog box.
_.| Import:4 |
File Type
GD5ITI Stream Format More Options..,
Import File Hame {Source)
i Browse...
Dethulls Degign
Herwr Deshgn Hame {Oasthration )
! Brivwse...
Layers File Mame
| Browse...
Ok Cancel Help iy
2. In the File Type field, click the arrow in the right-hand corner to display a drop-down list of available formats.
Select the format you want to import.
3. Click the More Options button to define the options for your selected format.
= Import GDSII Options:4 |
Attributes Define Layers...
_| Data Type Property
Text Size
_| Plex Property Ii.o
oK Cancel Help
 Note

Each format has its own set of import options. Refer to the individual translator topic.

4. Click Define Layers to set the layer options. For information on the Layer Editor, see Defining Layers. Close the

Layer Editor dialog box.

5. In the Import Options dialog box, click OK to save your settings and return to the Import dialog box.
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6. In the Import File Name (Source) field enter the full path of the source file. Alternatively, click Browse to open
the Import File Selection dialog box and locate the file you want. After locating the file, click OK to accept the
selection and return to the Import dialog box. The appropriate suffix (.dsn) is appended to the filename
automatically.

—| Import File Selection:11 |

Filter
:cott/Slot_dipole_prj/+*.gds

Directories Files
Slot dipole prif. [ 1

fSlot_dipole_prijf..
{3lot_dipole_prjfdata
fSlot_dipole_prifmom_dsn
fSlot_dipole_prifnetworks
{Slot_dipole_prifsubstrates

aelection

'g/crescott/Slot_dipole_prj/]

oK Filter Cancel Help

7. In the New Design Name (Destination) field, enter the full destination path and a name for the new file.
Alternatively, you can click Browse to open the Design File Selection dialog box and locate the destination path.
After locating the file, click OK to accept the selection and return to the Import dialog box. The appropriate suffix
is appended to the filter automatically.
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—| Design File Selection:11 |

Filter

—dipole_prj/networks/*.dsn

Directorie: Files

i | A Readme.dsn

orks!.. dipole.dsn
dipole_us.dsn
dipole_us_denseMesh.dsn

aelection

/Slot_dipole_prj/networks/]

OK Filter Cancel Help

Note

New Design Name (Destination) cannot be specified for EGS Archive Format, GDSII Stream Format, IFF, or
IGES files.

. In the Layers File Name field, enter the full path and name of the layers file to be referenced during import. If
the name you enter does not exist, a .lay file will be created using the information defined in the Layer Editor.

Note

If the import results in changes to the layers that you have defined, then those updates are written to the
custom layers file. If the custom layers file is defined as non-writable, then a warning is generated.

Alternatively, you can click Browse to open the Layers File Selection box and locate the path and file name. After
locating the file, click OK to accept the selection and return to the Import dialog box. The appropriate suffix (.lay)
is appended to the filename automatically.
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—| Layers File Selection:11 |

Filter
:cott/Slot_dipole_prj/*.lay

Directories Files

layout.lay
._tipole_prjf..

_dipole_prjidata
_dipole_prj/mom_dsn
_dipole_primetworks
_dipole_prj/substrates

aelection

's/crscott/Slot_dipole_prj/

OK Filter Cancel Help

The specified layers file contains the layer definition from the file you are importing.

 Note

Layers File Name cannot be specified for HPGL/2, IFF, or Mask files.

9. Click OK to accept the selections and start the import process. One or more files may be created.

Exporting a Layout

For available file formats that you can export from an ADS Layout window, refer to Available Formats.

The procedure for exporting each format is the same, but the available options differ. For options relating to a
particular file format, see the appropriate chapter.

© Note

Gerber Viewer appears as an export file option. It is not a file format, but is placed on the export file menu so
you can open the Gerber Viewer at any time. In addition, you can access the Viewer during a DXF or Gerber

export (see Using the Gerber Viewer).
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To export a layout file:

1. In the Advanced Design System layout window containing your design, choose File > Export. The Export dialog
box appears.

File Type
GDSII Stream Format “| More Options...
Mew File Hame (Destination)
dipole. gds Browse...
0K Cancel Help

2. In the File Type field, click the arrow in the right-hand corner to display a drop down list of available formats.
Select the format you want to export.
3. Click the More Options button to define the options for your selected format.

=| Export GDSH Options:11 |
Attributes kMaximum Humber of Vertices
| Paths As Polygons J2T6E
| Holes As Polygons Layers To Exclude
| Aatten -
| Auto Merge Define Layers...
| Data Type Propert:
o L Text Size

I Plex Property 1.0

oK Cancel Help

 Note

Each format has its own set of import options. Refer to the appropriate chapter in this book.

4. Click Define Layers to set the layer options. For information on the Layer Editor, see Defining Layers.

 Note

ADS layer numbers are mapped to DXF layer names. You can modify layer mappings and DXF layer names by
editing the DXF Layer Name column in the Advanced tab section of the Layer Editor.
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5. In the Export Options dialog box, click OK to save your settings and return to the Export dialog box.

6. In the New File Name (Destination) field enter the full path of the destination file. Alternatively, click Browse to
open the Export File Selection dialog box. After locating the destination directory, click OK to accept the selection
and return to the Export dialog box. Enter a filename. The appropriate suffix is appended to the filename
automatically.

=| Export File Selection:11 |

Filter
icott/Slot_dipole_prj/*.gds

Directories Files
Slot dipole prjf. [ 1

f5lot_dipole_prjf..
fSlot_dipole_prjfdata
fSlot_dipole_prjfmom_dsn
fSlot_dipole_prifmetworks
fSlot_dipole_prjfsubstrates

Selection

z/crecott/Slot_dipole_prj/

oK Filter Cancel Help

 Note
New File Name (Destination) cannot be specified for MGC/PCB files. MGC/PCB files are written to the same
predetermined location each and every time. For more information on this file type, see MGC/PCB Files.

7. Click OK to accept the selections and start the export process. Additional dialog boxes display for the DXF,
Gerber, IFF, and MGC/PCB formats. To complete translation of these formats, refer to the appropriate chapter in
this book.

Defining Layers

Using the Advanced Design System Layer Editor (More Options > Define Layers) in the Import or Export dialog box,
you can define design layers and add, delete, or rearrange layer priority. The contents of this dialog box change to
reflect the layer assignments associated with the open design. For information on the defining layers using the ADS
Layer Editor, refer to Setting Layout Options.
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% Layer Editor:2

Basic ‘| Fu:lvanced"l

2 1D | Hame | Color/Pattern Ins Sel Vis Shape Display Line Style Reverse I
< [b |[|default ® & Outline ‘| Solid ’
j 1 |iond ® & oOutline ‘| Solid ’
2 [bondz ® & Outline ‘| Solid ’
B |resi ® & oOutline ‘| Solid .
4 [Hiel ® &  Filled | Solid ’
a2 [Hiel2 ® %  Filled | Solid ’
t  |hole % B  Filled | Solid ’
% |bond ® B  Filled | Solid ’
7 |lymbol ® B  Filled | Solid ’
B [iext [ ® &  Filled | Solid ’
— Select Visible Shape Display Line Style Layer
Al | None| (HII | Hone| “ | (Hew' cut | Paste
search For Layer: Messages:
E |
oK I Apply | Reset | Save...| Read... Cancel Help

Using the Pre-Production Editor

ADS includes an editor that can display DXF/DWG designs. Using the editor, you can compare the DXF/DWG files to
the original ADS layout design to verify that the design was exported correctly. Similarly, DXF/DWG files can be
previewed prior to import into ADS:

e to edit a large design down to a smaller design prior to importing it into ADS. This edited design can be saved
and then imported in ADS.
e or after import, to verify that the DXF/DWG design data and the ADS-imported design appear similar.
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File Menu

The File menu contains common Open, Save, Save As, and Close functions and lists the four most recent files viewed
in the editor.

Edit Menu

The Edit menu contains common and specialized editing commands.

Enable Editing

Enables editing commands to be performed on the current design. Deselect this item to view the design in read-only
mode. In this mode, editing commands are unavailable.

Undo

Undoes the last editing command. A stack of edit commands is created enabling you to choose Undo repeatedly to
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return to an earlier state of your design. A stack is maintained for each window, thus the Undo command works
independently from window to window.

Redo

Returns the file to the pre-undo state.

Cut

Enables you to delete one or more items from one window, and paste in another window.

Copy

Enables you to copy items in a given design window and then paste those items within the same design window or
another design window.

Paste

Enables you to paste items that you previously cut or copied. You are prompted to enter the X and Y coordinates of
the position where you want to paste the copied items. Select Apply to paste or Cancel to dismiss pasting.

Delete

To delete selected items, click the Delete button on the toolbar, or press the Delete key on the keyboard, or choose
Delete from the Edit menu. Deleted items can be restored using the Undo command.

Select All

Enables you to select all figure(s).

Deselect All

Deselects all the selected figure.

Modify

This choice lets you modify the following items:
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Select figures and click Union to perform union of the figures.

Select figures and click Intersection to perform union of the figures.

Select figures and click Union Minus Intersection to perform union of the figures
Select Crop to crop an area from a figure(s).

Select Chop to chop an area from a figure.

& Note

Union, Intersection, Union Minus Intersection, Crop, and Chop do not work for open ended figures with zero
width (for example arc and polylines).

View Menu

The view menu contains commands that allow you to alter the view of the current design.

View All

Your design is scaled and repositioned to fit within the viewing area.

The Zoom Commands

The Zoom commands enable you to enlarge or shrink the area being viewed. You can zoom in and zoom out using
mouse wheel. The enlarged or condensed figure is moved towards the center of the window.

Click Zoom To Area > click a point and then with the mouse button pressed move the mouse to the bottom right of
the area and release the mouse button to define a new view.

Click Zoom to Point to zoom in on a specified point in the window. Click to specify a point and the current view is
magnified by a factor of two, moving the point you specify to the center of the window.

Click Zoom In By 2 to zoom in by a factor of 2.

Click Zoom Out By 2 to zoom out by a factor of 2.

Measure

21



Advanced Design System 2008

Sl Measure E|®

Absohite XY
Delta X, Y

0,0

Anghs

0,0

Curnialstive Distance

LU

Gear | [ coca ][ hep

The Measure dialog allows you to measure lengths.

e Absolute X, Y displays the absolute coordinates of the point of mouse click.

¢ Delta X, Y gives the relative X and Y coordinates from previous mouse click.

e Angle gives the angle with respect to a line horizontal to the X axis.

e Cumulative distance gives the total length from starting point to current point.

e Click Clear to reset the values for Absolute X,Y, Delta X, Y, Angle and Cumulative distance.
¢ Click Cancel to dismiss the measure dialog box.

Undo/Redo Stack

Undo,/Redo Stack
<empky >
Delete
Delete

Unian
Hntersection

Shows last performed actions. You have an option to undo or redo the last operations performed.

Layer Table

22



Advanced Design System 2008

Layer Table ]

[ Select Al ] [ Deselect ol ]

on o WNum | Mame | Color

default .
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The layer Table displays the layer information. It enables you to switch on/off layers from display. It also enables you
to view layer number, layer name and layer color. Click Select All to view all the layers and Deselect All to switch off
all the layers. All the layers are displayed by default.

Status

The status window displays messages about the status of the current design, as well as warning and error messages.

Window Menu

This menu contains the following common Window commands.

Click Close to close the active window.

Click Close All to close all open designs.

Click Tile to arrange all child windows in a tile pattern.

Click Cascade to arrange all the child windows in a cascade pattern.

Click Arrange Icons to arrange all iconified windows at the bottom of the workspace.
Click Next to navigate to next open window.

Click Previous to navigate to previous open window.

Viewing Files in the Pre-Production Editor During Export

To view a DXF/DWG file during export from ADS:

1. Select DXF/DWG from File type drop-down list in Export dialog.

2. Select the View file after export checkbox and click OK.
This will display the exported DXF/DWG file. A status window shows if the export is complete or failed and the
design is displayed in the Pre-Production Editor.
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Viewing Files in the Pre-Production Editor During Import

To view a DXF/DWG file during import to ADS:

1. Select DXF/DWG from File type drop-down list in Import dialog.
2. Click Preview to view the file in the Pre-Production Editor.

Editing Files in the Pre-Production Editor

Using the Pre-Production Editor you can cut, copy, paste and modify designs. From the Modify menu, you can perform
editing functions like union, intersection, union minus intersection, crop, and chop.

To edit using the Pre-Production Editor:

1. Open a design in the Pre-Production Editor as described above.
2. Click Edit > Edit Enable.

e To cut a figure, select the figure and then click Edit > Cut.

e To copy a figure, select the figure and then click Edit > Copy.
3. To crop or chop a figure:

a. Select the figure.

Selected Dbject ——

B v wrdom Heo
jroetem B HRQYQY
b |
S ke 4ﬂ]

Ciogry [ T

Dislete %]

Seect & Cirled

Demlect il
e

5 el T o fanbathy

Lirecem Mirws. Bk e tion
Crogs
Thep

o Table UndeRedo Sack

b. Click Crop or Chop.
c. Mark the area to crop/chop using mouse.
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Area Selected To Crop i

d. Release the mouse to crop/chop the selected area.

Cropped Area i

4. Click Delete to delete selected item.
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5. Click Undo to revoke last Edit command.

DXF/DWG Translator

The DXF/DWG translator enables you to convert ADS designs into AutoCAD's DXF/DWG file format, as well as convert
DXF/DWG files into ADS designs. DXF is a very simple file format that can be read by most CAD programs that
support DXF. The DXF/DWG translator is bidirectional and provides support for hierarchical and all layer separation.

DWG is a binary format, therefore the files take less time to load and save. Advanced Design System supports
importing and exporting to/from AutoCAD. AutoCAD versions 12 to 2007 are supported for import. AutoCad versions
2000, 2004 and 2007 are supported for export. Carefully consider how you want to use DXF/DWG output - including
layer numbering, use of holes, and polygon shapes - before beginning your layout design. Setting up the proper layout
rules in ADS can save a lot of time in generating acceptable DXF/DWG output. For specific considerations or
limitations, consult your AutoCAD documentation.

Note: Password protected DWG files are not supported.

ADS includes an editor that can display the DXF/DWG design. Using the editor, you can compare the DXF/DWG files to
the original ADS layout design to verify that the design was exported correctly. Similarly, DXF/DWG files can be
previewed prior to import into ADS:

e to edit a large design down to a smaller design prior to importing it into ADS. This edited design can be saved
and then imported in ADS.
e or after import, to verify that the DXF/DWG design data and the ADS-imported design appear similar.

For details, see Using the Pre-Production Editor.

Importing DXF/DWG Files to ADS

The procedure for importing each format is generally the same, however the available options differ. For a
step-by-step tutorial on importing a layout file, refer to Importing a Layout. For specific import options related to
importing DXF/DWG files, refer to Import DXF/DWG Options. For information on mapping DXF/DWG entities to ADS
layout components, refer to Mapping DXF to ADS.

Import DXF/DWG Options
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This section describes the definable options available for importing files in the DXF/DWG format. To view the options,
click File > Import > DXF/DWG > More Options.

The Import DXF/DWG Options dialog enables you to specify flattening, units, and layers to control the import of
DXF/DWG format files. A DXF/DWG file must be selected in the main export dialog for the Import DXF/DWG Options
dialog to open.

Options

Z=| Import DXF/DWG 0 ptions

Options Layers
[] Flatten hierarchy

Lnits

Mo units were specified in the input DFDYWG File,

Select the units below,
&) mil
) inch
) um
) mm

K ] ’ Cancel ] ’ Help

Flatten hierarchy

Select Flatten hierarchy to remove any hierarchy that may be present in the DXF/DWG selected. Default setting
retains the hierarchy.

Note: If you select a DXF/DWG that contains more than 50 component designs this option gets automatically enabled.
This is to avoid long import times.

Units

Older versions of the DXF file format may not specify units. If no Units were specified in the input DXF file, this option
is enabled. Default setting is mil.
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Options Layers |
DF Laver Import
10
2 OUTLIME
5 KIRIHOLE
4 L15R
5 LISRCUT
& YIA
K ] ’ Cancel ] Help

The Layers tab displays a list all the layers in DXF/DWG file. Layers can be selectively imported to ADS using the
import column. By default all layers are imported.

Mapping DXF to ADS

The following table represents the mapping of DXF/DWG file shapes ADS shapes.

Mapping DXF File Shapes to ADS File Shapes

DXF/DWG

Line with width = 0

Line with width > 0
Polygon with width = 0
Polygon with width > 0
Rectangle with width = 0
Rectangle with width > 0
Circle with width = 0

Circle with width > 0

ADS Layout Equivalent
Polyline
Path
Polygon
Polygon with cutline
Rectangle
Polygon with cutline
Circle

Polygon with cutline
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Arc with width = 0 Arc

Arc with width > 0 Polygon

Exporting an ADS Design to DXF/DWG Files

To export DXF/DWG files:

1. Follow the steps as outlined in Exporting a Layout. For available options (accessed via More Options in the Export
dialog box), see Export DXF/DWG Options.
2. After clicking OK in the Export dialog box, the translator converts your ADS Layout to DXF format.

Once in DXF/DWG file format, the file is available for use in AutoCAD or other Mechanical CAD systems.
Export DXF/DWG Options

The Export DXF/DWG Options dialog box enables you to set file format, Autocad version, path geometry, and hole
format.

%] Export DXF/DWG Options 2]

Options Layers

File Format Aukocad version
() D¥F ( Text ) Autocad 2000 v
) DG

Paths as polygons

Hale Farmak

{(¥) Holes as cutlines

{3 Holes as polvgons

[ O H Cancel H Help

Options

29


http://edocs.soco.agilent.com/display/ads2008/Importing+and+Exporting+Schematic+and+Layout+Designs#ImportingandExportingSchematicandLayoutDesigns-ExportingaLayout

Advanced Design System 2008

The Options tab enables you to select various design attributes and AutoCad File Formats in the translation.
File format
DXF (Text)

Select this option to export the ADS design to DXF format as an ASCII text file. This selection is the default settling.

DWG

Select this option to export your ADS design to a binary DWG file format. Exporting to DWG file format is faster than
the DXF (Text) format. Also file size of the DWG file will be smaller as compared to corresponding DXF (Text) file.

Autocad version

Use this drop-down list to select the AutoCad version. ADS layout can be exported in three AutoCad versions: 2000,
2004, and 2007.

Paths as polygons

Select Paths As Polygons to export the design paths or traces as polygons. Paths or traces have mitered or curved
corners that need to be preserved in the translation. The ADS layout has paths with endpoint types other than flush
that need to be preserved in the program database. This option is selected as the default.

Hole format

The Hole format section enables you to define how the translator deals with holes in a design.
Holes as polygons

Select Holes As polygons to convert holes into polygons. One polygon will be created for each hole in the same layer.

 Note
Some systems may not be able to tolerate complex polygons with cutlines. For these systems, select Holes as
polygons. This option is deselected as the default.

Holes as cutlines

Select Holes as cutlines to convert holes into cutlines. This option is selected as the default.

Layers
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=| Export DXF/DWG Options EIB‘_TI
Options | Layers |
abs Laver Export
1 OUTLINE
2 KIRIHOLE
3 LI5R
4 L1SRCUT
5 YIA
Ik l ’ Cancel ] [ Help

The Export column enables you to deselect one or more layers to exclude it from the output file. Default setting is all
layers selected and exported.

Mapping ADS to DXF (hierarchical)

The DXF file created by the DXF/DWG translator is as simple as possible so that many DXF parsers, even primitive
ones, can read the file. The DXF translator performs the following mapping between ADS Entity and DXF files.

Hierarchical DXF Output

ADS Entity DXF Entity
Polygon closed LWPOLYLINE
polyline open LWPOLYLINE
path open LWPOLYLINE with width
path with PathAsPolygons closed LWPOLYLINE
wire open LWPOLYLINE
circle circle
text text
rectangle closed LWPOLYLINE
arc arc
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EGS Archive Files

The EGS Archive format is an ASCII text format that represents multiple hierarchical designs. EGS Archive files include
information such as drawing shapes, layout units, database precision, grid spacing and, optionally, a layers definition
including layer colors, numbers, and names. They do not contain information about the connectivity of a layout
design.

Originating from a former Hewlett-Packard product called the Engineering Graphics System (EGS), the EGS Archive
format is useful as an intermediate file for transferring input/output to various third-party translators. It is also the
best format for translating graphic shapes into the Series IV and MDS products. In addition, the EGS Archive format is
easy to parse and read, so if you have created your own software tools, this is a very useful format for transferring
graphics shapes into these tools.

When importing an EGS Archive file into Advanced Design System, you may specify a Layers File Name for the
creation of a layers definition file (the Layers File Name field is located in the Import dialog box). This file will be
automatically created and will contain the layer information from the EGS Archive file, as well as layers automatically
added as necessary during import. All designs created during import reference this layers file.

Oval or hatch shapes of the EGS Archive format are not supported in Advanced Design System.

Importing EGS Archive Files

The procedure for importing each format is generally the same, however the available options differ. For a
step-by-step tutorial on importing a layout file, refer to Importing a Layout. For specific import options related to
importing EGS Archive Files, refer to Import EGS Archive Options. For information on mapping EGS Archive files to
ADS, refer to Mapping EGS Archive to ADS.

Import EGS Archive Options

File > Import > EGS Archive Format > More Options

Other than layer characteristics, there are no definable options available for importing files in the EGS Archive format.
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—| Import EGSARC Options:11

Define Layers...

0K Cancel Help

The Define Layers button invokes the Layer Editor. For Layer Editor options, see Defining Layers.

 Note

ADS does not support the character " $' in layer names. Translation will fail if the import file contains this
character in the layer names.

Mapping EGS Archive to ADS

The table below shows the mapping of EGS Archive file shapes to Advanced Design System layout shapes.

EGS Archive Object Advanced Design System Layout Equivalent
Line with width = 0 Polyline
Line with width > 0 Path
Polygon with width = 0 Polygon
Polygon with width > 0 Polygon with cutline on longest segment
Rectangle with width = 0 Rectangle
Rectangle with width > 0 Polygon with cutline on longest segment
Circle with width = 0 Circle
Circle with width > 0 Polygon with cutline to the right
Arc with width = 0 Polyline
Arc with width > 0 Polygon

Exporting EGS Archive Files

The procedure for exporting each format is generally the same, however the available options differ. For a
step-by-step tutorial on exporting a layout file, refer to Exporting a Layout. For specific export options related to
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exporting EGS Archive Files, refer to Export EGS Archive Options. For information on mapping ADS to EGS Archive
files, refer to Mapping ADS to EGS Archive.

Export EGS Archive Options

File > Export > EGS Archive Format > More Options
Export EGSARL Options:2

Atributes Layers To Exclude
[~ Include Mazk Layers |

[~ Pathz &z Palygons Define Layers...

[ Hales Az Palygons

™ Flatten Components
[~ A&l Fillad

[ Flatten Al

=

Cancel Help

Include Mask Layers

When this option is selected, a list of mask layers is included with the translated design. This option is selected as the
default.

Paths As Polygons

When Paths As Polygons is selected, the design paths or traces are exported as polygons. This should be selected for
the following conditions:

e Paths or traces have mitered or curved corners that need to be preserved in the translation.
e The EGS Archive file has paths with endpoint types other than flush that need to be preserved in the program

database.

This option is deselected as the default.
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Holes As Polygons

When this is selected, holes are converted to polygons. When Holes As Polygons is not selected (this is the default),
polygons with holes are translated as single-segment polygons, the false edge segment becoming part of the polygon.
Some systems may not be able to tolerate this type of complex polygon. For these systems, select Holes As Polygons .
This option is deselected as the default.

Flatten Components

When Flatten Components is selected, all instances whose artwork type is defined with an AEL macro will be flattened
when exported. For example, if a design contains an MLIN it will be flattened. This option is deselected as the default.
It only affects the current design and will not change the hierarchy.

All Filled

When this is selected, all data is transferred as filled. This option is deselected as the default.

Flatten All

When Flatten All is selected, all levels of hierarchy are automatically removed and a single flat design is exported.
There are no references from the top-level structure to any other structure in the design. This option is useful when
your post-processor does not support or correctly translate hierarchy in EGS Archive files. Please note: if a
substructure was instanced more than once, selecting this option can substantially increase the size of the file.

This option is deselected as the default.

Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap are merged. This option is
deselected as the default.

Layers To Exclude

Layers can be excluded from the EGS Archive export by entering the layer IDs. Multiple IDs can be entered using
space or comma delimiter.
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Define Layers

The Define Layers button invokes the Layer Editor. For Layer Editor options, see Defining Layers.

Mapping ADS to EGS Archive

The table below represents the mapping Advanced Design System layout shapes to EGS Archive file shapes.

Advanced Design System Layout Object EGS Archive Equivalent
Polyline Line
Path with PathsAsPolygons Polygon
Path without PathsAsPolygons Line
Circle Circle
Rectangle Rectangle
Polygon Polygon
Wire Line

EGS Generate Files

The EGS Generate format is an ASCII text format representing a single, flat design. It is a subset of the EGS Archive
format that contains only the shape information. If an hierarchical design is exported, it is automatically flattened
during the export process.

Originating from a former Hewlett-Packard product called the Engineering Graphics System (EGS), the EGS Generate
format is useful as an intermediate file for transferring input/output to various third-party translators. Also, the EGS
Archive format is easy to parse and read, so if you have created your own software tools, this is a very useful format
for transferring graphics shapes into these tools.

When importing an EGS Generate file into the Advanced Design System, you may specify a Layers File Name for the
creation of a layers definition file (the Layers File Name field is located in the Import dialog box). This file will be
automatically created and will contain the layer information from the EGS Generate file, as well as layers automatically
added as necessary during import. All designs created during import reference this layers file.

Oval or hatch shapes of the EGS Generate format are not supported in the Advanced Design System.
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Importing EGS Generate Files

The procedure for importing each format is generally the same, however the available options differ. For a
step-by-step tutorial on importing a layout file, refer to Importing a Layout. For specific import options related to
importing EGS Generate Files, refer to Import EGS Generate Options. For information on mapping from EGS Generate
files to an ADS layout, refer to Mapping EGS Generate to ADS.

Import EGS Generate Options

File > Import > EGS Generate Format > More Options

Other than layer characteristics, there are no definable options available for importing files in the EGS Generate
format.

—| Import EGSGEN Options:11 |

Define Layers...

oK Cancel Help

The Define Layers button invokes the Layer Editor. For Layer Editor options, see Defining Layers.

 Note
ADS does not support the character " $' in layer names. Translation will fail if the import file contains this
character in the layer names.

Mapping EGS Generate to ADS

The table below represents the layout mapping from EGS Generate format to Advanced Design System layout.

EGS Generate Object Advanced Design System Layout Equivalent
Line with width = 0 Polyline
Line with width > 0 Path
Polygon with width = 0 Polygon
Polygon with width > 0 Polygon with cutline on longest segment
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Rectangle with width = 0 Rectangle

Rectangle with width > 0 Polygon with cutline on longest segment
Circle with width = 0 Circle

Circle with width > 0 Polygon with cutline to the right

Arc with width = 0 Polyline

Arc with width > 0 Polygon

Exporting EGS Generate Files

The procedure for exporting each format is generally the same, however the available options differ. For a
step-by-step tutorial on exporting a layout file, refer to Exporting a Layout. For specific export options related to
exporting EGS Generate Files, refer to Export EGS Generate Options. For information on mapping ADS to EGS

Generate files, refer to Mapping ADS to EGS Generate.

Export EGS Generate Options

File > Export > EGS Generate Format > More Options

[#] Export EGSGEN Options:1

—Attnbutes ————— | avers To Exclude
-l Include Mask Layers

Paths As Pol
- $ ygons Define Layers...

.l Holes As Polygons
1 All Filled

Ll Auto Merge

Include Mask Layers

When this option is selected, a list of mask layers is included with the translated design. This option is selected as the
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default.

Paths As Polygons

When Paths As Polygons is selected, the design paths or traces are exported as polygons. This should be selected for
the following conditions:

e Paths or traces have mitered or curved corners that need to be preserved in the translation.
e The EGS Generate file has paths with endpoint types other than flush that need to be preserved in the program
database.

This option is deselected as the default.

Holes As Polygons

When this is selected, holes are converted to polygons. When Holes As Polygons is not selected (this is the default),
polygons with holes are translated as single-segment polygons, the false edge segment becoming part of the polygon.
Some systems may not be able to tolerate this type of complex polygon. For these systems, select Holes As Polygons.
This option is deselected as the default.

All Filled

When this is selected, all data is transferred as filled. This option is deselected as the default.

Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap are merged. This option is
deselected as the default.

Layers To Exclude

Layers can be excluded from the EGS Archive export by entering the layer IDs. Multiple IDs can be entered using
space or comma delimiter.
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Define Layers

The Define Layers button invokes the Layer Editor. For Layer Editor options, see Defining Layers.

Mapping ADS to EGS Generate

The table below represents the layout mapping from Advanced Design System layout to EGS Generate format.

Advanced Design System Layout Object EGS Generate Equivalent
Polyline Line
Path with PathsAsPolygons Polygon
Path without PathsAsPolygons Line
Circle Circle
Rectangle Rectangle
Polygon Polygon
Wire Line

GDSII Stream File Translator

The end result of many MMIC designs is a Calma or GDSII stream format file. Advanced Design System's Layout
provides a flexible GDSII translator for both reading and writing this format.

The GDSII Stream File Translator is a bi-directional graphics file translator. It can create files in GDSII Stream file
format from Advanced Design System layouts, and it can translate graphics files from GDSII Stream file format into
Advanced Design System layouts.

The Advanced Design System to GDSII Stream file format translation links the Advanced Design System directly to
mask-making equipment that uses the popular GDSII Stream file format. This format, in turn, gives access to a wide
range of photoplotters, coordinatographs, E-beam machines, and pattern generators.

The GDSII Stream file format to Advanced Design System format translation makes it easy to use the cell libraries
offered by many GaAs semiconductor foundries.

Translation from a layout in the Advanced Design System into GDSII Stream file format is done with the menu
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command File > Export > GDSII Stream Format.

GDSII has some limitations that may affect your layout, including:

No support for arcs or circles

No support for holes or empty regions
32-character name limitation

Limit of 255 mask layers

Curved Element Limitation

Although the Advanced Design System has options for re-mapping layer numbers and structure names, it does not
have the full ability to overcome the GDSII limitations regarding curved elements. The program stores arcs as true
arcs. When translating arcs to GDSII format, the program converts each arc into line segments. This number can be
controlled via the Arc Resolution dialog box (select Edit > Modify > Arc/Circle Resolution from the Layout window).
However, a shape with several arcs, such as a transmission line with curved elements, may not be approximated with
sufficient resolution given the 200 vertex limitation. Therefore, some consideration should be given to the use of
curved elements and the extensive use of arcs and circles in your layout design.

Lack of Support for Holes

Lack of support for holes is usually not a problem, but should be considered. The Advanced Design System can
convert shapes with holes into contiguous single polygons by inserting an extra edge (shown below). Inserting an
edge is valid for GDSII output, but may be a problem for certain mask generation software.

Shape with a hole. Extra edge inserted for
GDS|| translation.

Filename Limitation
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Very long file names (greater than 32 characters) are not supported by GDSII.

Limit on the Number of Layers

If your layout has more than 255 layers, some of these can be re-mapped to appear on the same GDSII layer.

UNITS Limitation

The UNITS record within the GDSII file contains two numbers. The first indicates the ratio of (user units)/(db units),
the second indicates the number of db units in a meter. GDSII specifications state that the first number should
typically be set to less than 1. ADS requires that this GDSII value to be less than 1 since values greater than 1 are not
valid for ADS resolution.

Conclusion

GDSII limitations can affect how you design your layout. The limitation that bears particular consideration is the fact
that GDSII Stream format is limited to 200 vertices per polygon/polyline and does not include arcs.

In the Advanced Design System, arcs are stored as true arcs, but are evaluated as polygon segments when translated
to GDSII. Although the number of vertices used to approximate an arc can be controlled via the Arc Resolution dialog
box (see Curved Element Limitation), the 200 vertices limit may prevent the program from correctly evaluating
polygons consisting of several arcs. Therefore, it is best to consider the number of arcs your shapes contain before
designing your layout.

GDSII does not have the ability to empty a polygon or create a hole. The translator can output polygons with holes as
single-segment polygons with an extra edge added, or as separate polygons. If this is not acceptable, you may want
to prohibit the use of holes in your design.

The table below describes GDSII elements and their Advanced Design System layout equivalents.

Calma/GDSII Element Layout Equivalent(s)
Box element Rectangle
Boundary element Polygon, Rectangle
Path element Path
Boundary element Circle, Polygon
Element Text
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Boundary element Hole
Structure element Design
Sref element Instance
None Pin

Path element Wire
Path element Trace
Plex None
Array Instances
Node None

Importing GDSII Files

The Advanced Design System reads GDSII files into a layout design without circuit or schematic information, internally
converting the drawing data to the current layout units.
For a step-by-step tutorial, see Importing a Layout. For import options, see Import GDSII Options.

Guidelines/Considerations

o If a layers file name is defined in the Import dialog, the file is loaded into memory before the GDSII importer
starts. See Importing a Layout for more information.

o If the importer encounters elements on layers not present in the layer definition file, it will automatically add new
layers. If new layers are added, the importer saves the revised layer definition file to disk.

e When transferring a GDSII file via FTP, you must specify the binary option.

¢ When transferring a file via tape, the 2048 block size must be preserved. To write fixed-block sized tapes for
transfer to other systems, refer to your computer system documentation.

¢ When reading a GDSII file, the Advanced Design System ignores reference libraries, font files, generations,
format types, and nodes. Element flags (ELFLAGS), complexes (PLEX, see Plex Property), data types, path types,
extensions, and element properties are also skipped.

e Reading a GDSII file may also fail if the file is the wrong version or has been corrupted.

 Note

Because the GDSII stream is a block-structured binary file, it can easily be corrupted when transferring the file
from one system to another.

¢ When reading GDSII path elements, note the following for each path type:

type 0 GDSII path is imported as an ADS path with square
corner type.

type 1 GDSII path is imported as an ADS path with square
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corner type resulting in the loss of data in the path's
round-ended endpoints and corners.

type 2 GDSII path is imported as an ADS path with square
corner type and with endpoints that have been extended
1/2 of the path's width.

GDSII type 3 is non-existent

type 4 GDSII path is imported as an ADS path with square
corner type resulting in the loss of data in the path's
variable defined endpoints.

Filenames Versus Instance Names

When importing a GDSII file into the Advanced Design System, the design name on the Layout title bar may differ
from the GDSII filename. The reason for this is as follows.

The GDSII file format can contain multiple top-level instances that may or may not be related to one another. Because
of this, the GDSII filename may not be identical to the top-level instance name.

When importing a GDSII file, the top-level instance is automatically displayed in the Layout window. The name of that
instance is reflected in the Layout title bar. In some cases, this name does not match that of the imported file.

GDSII file instance names simplify the tracking of hierarchies within the file. Exporting a GDSII file under a new name
will have no effect on the named data contained in the file.

Import GDSII Options

The Import GDSII Options dialog box enables you to specify certain local attributes to control the import of GDSII
Stream files. An x appears in the box to the left of selected attributes. To select or deselect an attribute, click it.
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= Import GDSII Options:4 |
Attributes Define Layers...
_I Data T ert
ywe Froperly Text Size
_I Plex Property .o
oK Cancel Help

) Note
To control attributes globally, click the Define Layers button to invoke the Layer Editor. For more information
on the Layer Editor, see Defining Layers.

Data Type Property

Selecting Data Type Property enables import of GDSII files that use the Data Type record in GDSII and retain the
information in a property attached to the corresponding Advanced Design System data structure. When enabled, any
Data Type records encountered on Boundary or Path structures while importing a GDSII file cause a property named
Data Type to be created and attached to the resulting data group in the Advanced Design System. The value of the
property is set to the integer value found in the GDSII record. In the reverse manner, Data Type records are created
in the GDSII file when enabled for data groups that have a Data Type property with integer value.

Plex Property

Selecting Plex Property enables import of GDSII files that use the PLEX record in GDSII and retain the information in a
property attached to the corresponding Advanced Design System data structure. When enabled, any PLEX records
encountered on Boundary, Path, SREF, AREF, and TEXT structures while importing a GDSII file cause a property
named PLEX to be created and attached to the resulting structure in the Advanced Design System. The value of the
property is set to the integer value found in the GDSII record. In the reverse manner, PLEX records are created in the
GDSII file when enabled for structures that have a PLEX property with integer value.

Define Layers

This button invokes the Layer Editor. For Layer Editor options, see Defining Layers.
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Text Size

The size, in layout units, for text in the imported design. The default value is 1.0. The same size is assumed for all
fonts in the GDSII file.

Exporting GDSII Files

When writing a Calma/GDSII file, the GDSII 6.0 release format is used.

For a step-by-step tutorial on exporting files, see Exporting a Layout. For export options, see Export GDSII Options.

Guidelines/Considerations

e You can create a bidirectional GDSII file from the current design file. Translated GDSII files appear in layout
representation only. Although no electrical connectivity information is included, hierarchy and mask layer
information is preserved.

e The Advanced Design System writes the layout representation of a hierarchical design into GDSII stream format
using the current layout units and precision.

e The GDSII file created is of fixed-block size (2048 bytes), and is a proper subset of the stream format.

¢ Valid GDSII layer numbers are from 0 to 255. The data type for all objects is set to 0.

¢ Note that only some object attributes are translated:

° A polyline is translated as a path with no specified width, path type, or extension.

° When paths are converted, the endpoint type is ignored and the type 0 is applied (square-ended at digitized
point).

° Holes in the program are translated as filled polygons, or as a single polygon with the hole joined to other
polygons by a new edge.

° Circles are converted to polygons and arcs are converted to chords.

° Text is translated with a bottom left justification. A scale factor showing magnification of the text height
over one user unit and an optional rotation angle are also translated.

° Relative mirroring, translation, scaling, and rotation are transferred. Absolute rotation and magnification are
not supported.

e Data groups with more vertices than the number specified by the Maximum Number of Verticies option will be
skipped during the translation and a warning will be issued. This value can be as high as 8191 (the UI will not
allow higher values). Error and warning messages generated during translation are also printed to the log file.
After the translation, this file can be viewed.

e Precision and unit information is stored differently in the GDSII Stream format than in Advanced Design System,
but no information is lost in translation. A database-unit to user-unit size appears in the GDSII format; this is
equivalent to the Advanced Design System's data base precision. This measurement specifies the smallest
dimension obtainable in a design. In the Advanced Design System, this is established as a power of ten. For
example, a precision of 3 indicates that .001 is the smallest dimension achievable in the design. Since GDSII
format contains database to user units, a 3 precision in the Advanced Design System becomes 1000 database to
user units in GDSII.
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GDSII dB/user unit = 10 | dB precision |

GDSII further employs user units in terms of number of user units to a meter. Since Advanced Design System units
can be inches, microns, mils, etc., the GDSII number of user units to meters is equal to the program dB unit
converted to meters.

When reading a new GDSII file, the program precision and units should be set to match those that are in the GDSII
file, otherwise information may be lost (especially if the program's database precision is less than that of the GDSII
Stream file).

Export GDSII Options

The Export GDSII Options dialog box enables you to specify certain local attributes to control the export of GDSII
Stream files. An x appears in the box to the left of selected attributes. To select or deselect an attribute, click it.

Export GDSII Options:2
Attributes bl asimurmn Mumber of Wertices
[T Paths Az Polygons EIEL

[T Holes As Palpgons

Layers To Exclude

[T Rectangles Az Bozes |

Flatten Ci i :
M =tz Lo iz Define Layers. .. |
[~ Flatten

r
[T Data Type Property Text Size

[T Plex Property |1'D
Cancel |

) Note

To control attributes globally, click the Define Layers button to invoke the Layer Editor. For more information
on the Layer Editor, see Defining Layers.

Paths As Polygons

When Paths As Polygons is selected, the program paths or traces are exported as polygons and GDSII paths are
imported as polygons. This should be selected for the following conditions:
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e Paths or traces have mitered or curved corners that need to be preserved in the GDSII translation.

This option is deselected as the default.

Holes As Polygons

When this is selected, holes are converted to polygons. GDSII has no concept of holes. When Holes As Polygons is not
selected, polygons with holes are translated as single-segment polygons, the false edge segment becoming part of the
polygon. Some systems may not be able to tolerate this type of complex polygon. For these systems, select Holes As
Polygons.

This option is deselected as the default.

Rectangles as Boxes

ADS rectangles get mapped into GDSII box elements.

Flatten Components

When Flatten Components is selected, all instances whose artwork type is defined with an AEL macro will be flattened
when exported. For example, if a design contains an MLIN it will be flattened. This option is deselected as the default.
It only affects the current design and will not change the hierarchy.

Flatten

When Flatten is selected, all levels of hierarchy are automatically removed and a single flat design is translated. A
component is flattened into its geometric primitives. There are no references from the top-level structure to any other
structure in the design. This option is useful when your post-processor does not support or correctly translate
hierarchy in GDSII Stream files. Please note: if a substructure was instanced more than once, selecting this option
increases the size of the file.

This option is deselected as the default.

Auto Merge

48



Advanced Design System 2008

When this attribute is selected, the program outputs shapes and forms with data from simulator elements (mlins,
slins) and performs an or operation on each layer before outputting. The original dataset is not modified. This option is
deselected as the default.

Data Type Property

Selecting Data Type Property enables export of GDSII files that use the Data Type record in GDSII and retain the
information in a property attached to the corresponding Advanced Design System data structure. When enabled, any
Data Type records encountered on Boundary or Path structures while importing a GDSII file cause a property named
Data Type to be created and attached to the resulting data group in the Advanced Design System. The value of the
property is set to the integer value found in the GDSII record. In the reverse manner, Data Type records are created
in the GDSII file when enabled for data groups that have a Data Type property with integer value.

This option is deselected as the default.

Plex Property

Selecting Plex Property enables export of GDSII files that use the PLEX record in GDSII and retain the information in a
property attached to the corresponding Advanced Design System data structure. When enabled, any PLEX records
encountered on Boundary, Path, SREF, AREF, and TEXT structures while exporting a GDSII file cause a property
named PLEX to be created and attached to the resulting structure in the Advanced Design System. The value of the
property is set to the integer value found in the GDSII record. In the reverse manner, PLEX records are created in the
GDSII file when enabled for structures that have a PLEX property with integer value.

This option is deselected as the default.

Maximum Number of Vertices

This enables you to define the maximum number of vertices allowed for one polygon. Valid values are 1 - 8191
inclusive. The default value for this option is 8191.

Layers To Exclude

This enables you to exclude one or more layers from the output file by specifying the layer numbers to exclude,
separated by commas. For example:
1,4,9
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Define Layers

This button invokes the Layer Editor. For Layer Editor options, see Defining Layers.

Text Size

The size, in layout units, for the text in the exported design. The default value is 1.0. The same size is assumed for all
fonts in the GDSII file.

Gerber Translator

The Gerber Artwork Translator can translate artwork directly from circuit layouts created with Advanced Design
System into Gerber format. It exports ADS layouts into ASCII files that control Gerber photoplotting equipment.

The Gerber Viewer is a companion program included with the ACS Gerber translator. The Viewer is used for viewing
artwork on a computer monitor and for printing it to a graphics printer before creating artwork on the Gerber
photoplotter. It is also used for generating drill data and tooling reports.

The Gerber Union tool is also available within the Gerber Viewer. This tool requires a separate license from the Gerber
export license. The Gerber Union tool provides the ability to import Gerber files into ADS. It can create EGS Archive
files from a set of Gerber files which can then be imported into ADS.

Gerber Command Format

The Gerber format is a numerical control language developed to generate photo artwork. The output of this translator
is an ASCII file that contains the following Gerber commands:

GO1E = linear interpolation
G54 = aperture select

D01 = shutter open

D02 = shutter close

D03 = flash

M02 = end of program

X and Y = coordinates

* = end of block
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Coordinates are absolute, with implied decimal point and optional leading zero suppression. However, the literal string
values may be modified in the message file. For example, GO1 may be changed to AB. A sample listing of the Gerber

file commands, with interpretation to the right, might look like this:

G54Dle* <— gelect aperture 16 (20 mil circle trace)
GO1E90Y85D0O2* <— move the shutter to 90, 85

Y185DOL1* <— open the shutter and draw teo 50, L85

X190* <— while shutter remains open, draw to 150, 185
YEE* <— draw to 190,85

90w <— draw to 90, 85

G54D45* <— gelect aperture 45 (60 mil circle flash)
¥140¥135D02* <— g¢lozse shutter and move to 140, 135

DO3* <— flach expoze

H0YoDozZ+MoZzZ* <— return to the origin and stop

This example would produce the following figure.

60 mil

20 mil

The output files are:

e The Gerber Drawing File (.gbr) is the actual Gerber command file.

e The Aperture Usage Report (.apt) reports primitive counts, aperture utilization, and the total distance traveled by

a mechanical photoplotting system.

The photoplotter vendor receives both output files.

Importing Gerber Files
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Gerber files can be imported into ADS layout by following a two step process. First, one or more Gerber files are
converted into a single EGS Archive file using the Gerber Union tool. This EGS file is then imported into ADS layout.

 Note

Only Gerber RS274X files can be processed by the Gerber Union tool.

A layer will be created for each Gerber file that is imported. The names of the layers created will be "1", "_2", "_3",
"_n". The layer table (_File > Layer) in the Gerber Viewer will show how the Gerber files are mapped to each layer

ey

number. This is the default behavior when using the option Multi-Layer Output. Changing this option to Single-Layer
Output places all elements on the layer "_1".

To import Gerber Files into ADS layout:

1. In the Layout window, select File > Import.
2. Set the File Type to Gerber Viewer and click OK, this invokes the Gerber Viewer tool.

» Import:1

File Type

Gerber Viewer

Cancel | Help |

3. When the Gerber Viewer (GBRVU) opens, a browser window entitled Open GRB File appears. This window
enables you to browse to the folder containing the Gerber files. Select the Gerber file(s) you wish to use and click
Open. This dismisses the Open GRB File window and moves the Gerber Viewer tool to the foreground, enabling
you to view the contents of the file(s).
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7

4. Select Tools > Gerber Union from the GBRUV window. A dialog appears with the following options.
5. Setting the Gerber Union options:
Settings Use Multi-Layer Output to generate a layer for each Gerber file imported. Use Single-Layer Output to
place all elements on the layer "_1".
Window Specifies an area of the Gerber files to import by defining its region here.
Output Defines the units and scale of the output EGS Archive file.
Output File Name Destination path and filename of the EGS Archive file.

Note
Details on all options can be seen by clicking the Help button in the Gerber Union options dialog.

-

Set the options as desired, then select OK to create the EGS Archive file.
Close the Gerber Viewer tool.

In the layout window, select File > Import.

Set the File Type to EGS Archive.

10. Select the file to import and click OK.

© o N

Exporting Gerber Files

ADS Release 2008 contains a simplified Gerber export tool. This tool can generate Gerber files in RS274X and MDA
format for raster photo plotters. For instructions on using MTools to export Gerber files, see Exporting Gerber Files

Using MTools.

The Gerber export tool creates one output file for each different layer used in the layout design. For example, if the
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design contains two layers, cond and cond2, two Gerber files will be generated:

e cond.gbr
e cond2.gbr

To export Gerber files:

1. In the layout window containing your design, choose File > Export.
The Export dialog box appears.
2. In the File type field, select Gerber.

=| Export

File bype

Mare Options. ..
|:'|,|:|ui||:|'l,|:|ru:ujeu:ts'l,test_gerl:uerJ:urj'l,mFg'l,test'l,gerI:uer | Browse...

[] wiew file after expart

Destination directory

o ] [ comed | [ b |

w

To define export options, click More Options.
4. Set the options that apply.
For available options, see Gerber File Options.
5. Click OK to save your settings or Cancel to retain the default settings.
6. In the Destination Directory field, accept the default directory, or click Browse to locate a new destination
directory.
The destination directory will be the <Project Dir>/mfg/<Design Name>/gerber/
where:
<Project Dir> is the project directory
<Design Name> is directory named with the design name
The checkbox option View file after export is not applicable for the Gerber file type.
7. Click OK to export the ADS layout design to a Gerber file.
A Status window appears detailing the export information.

54



Advanced Design System 2008

i Status

Fri 2ep 258 121235116 2007
Writing Gerber File "C:\sroibuild\projectsitest_gerber_priimfgitestigerber”,
Export Complete

8. Examine the log, searching for any warnings or errors that may have occurred during translation.
To save the log message in a file: select the text, copy, and then paste into any text editor.

Gerber File Options

You can view or edit the translator settings, by clicking More Options in the Export dialog box.

The Export Gerber Options dialog appears, providing access to these options.

=| Export Gerber Options

Cptions | Lavers Doill

File Farmat Hole Format Murnber Formak
(@) RS2743 © Holes as cutlines Integer digks |2 &
) Holes as palvgons

MDA Fractional digits |4 &
o ) Preserve holes .
Cutput unit - Zero SUPRRESSIon | ine widkh For polyvliines (mil) ||:|.|:u:|25|:u:| = |
(%) inch (%) Leading
O mm O None Enter zero to prevent export of polylines.

[] cenerate single file |

Ik H Cancel H Help

Gerber file choices can be edited in the Options tab.
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File format

e Select RS274X for an enhanced version of Gerber RS274D format that supports embedded apertures and
G36/G37 polygons.

e Select MDA if your photoplot shop uses a FIRE 9000 plotter. It embeds apertures and supports POEX/POIN
polygons for fill on the fly.

Hole format

In ADS, when a hole is created in a geometrical figure (like polygon), a cutline is introduced. This is a false edge
connecting the outer boundary of the polygon with the inner boundary. This polygon is actually a single re-entrant
polygon. When you select Holes as cutlines this re-entrant polygon is translated to Gerber as-is. The default is Holes
as cutlines.

Holes as Cutlines

Select Holes as polygons or Preserve holes to remove the false edge from the polygon.

Holes as polygons

When Holes as polygons is selected, holes are exported as filled elements. Therefore the polygon will appear to have
no holes.

Preserve holes
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When Preserve holes is selected, the resultant polygon in Gerber contains a dark area and empty area. This option is
not available for exporting Gerber files in RS274X format.

Unit

Available units are inch or mm. Inch is the default.

Number format

The number of integers placed before and after the decimal point. If chosen incorrectly, Gerber data resolution can be
poor. The default is 2.4. If the unit is set to mm then you can set the number format to 3.3.

A warning message is displayed in the Status window to notify the user that to preserve the precision in the Gerber
data, number format has to be selected carefully. If the Gerber data is not generated correctly for the selected
number format then a suitable error message is displayed in the Status window.

Zero suppression

Available settings are Leading and None. Select Leading (the default) to remove all leading zeros in the coordinate
data, making the Gerber file smaller.

Line width for polylines

Polylines in ADS have zero width, but you can use this option to provide a width to be used for drawing this polyline in
the Gerber file.

If the polylines and arcs (both zero width entities) are not required to be exported, then set the width to zero.

Generate single file

When this checkbox is selected, a single file is generated for all the selected layers in the Layer tab. Specify the file
name with extension .gbr. This file will be created in the destination directory selected in the Export dialog box.

57



Gerber Layer Options

Advanced Design System 2008

All the layers used in the design are displayed in a table in the Layers tab of the Export Gerber Options dialog. By
default, all the layers will be displayed with positive polarity and all layers will be exported. You can avoid exporting a
specific layer by deselecting the checkbox in the Export column for that layer.

=| Export Gerber Options

Options Lavers Corill
ADS Layer Polarity Export
1 cond Pasitive b
2 condz Positive F ]
Pasitive
(0] 4 l ’ Cancel ] ’ Help

Limitations and Considerations

¢ No intermediate mask file is generated.

e The new Gerber export tool is targeted for the raster photoplotters to generate RS274X and MDA file format.

¢ No aperture filling is supported for polygons.

¢ No separate aperture file is required for RS274X and MDA files.

e It is recommended to create the ADS design using inch or mm as the unit and set the appropriate resolution.

¢ You must set the appropriate humber format in the Export Gerber Options dialog so that the precision in Gerber
data is more than the precision in layout design.

e The Gerber translator can generate a single Gerber file for all layers. However, the Gerber Viewer cannot process
a Gerber file in which multiple layers are defined in a single file. It imports only the first layer defined in the file.

Exporting Drill Files

In ADS 2008, drill file export is accomplished simultaneously as part of the Gerber export. The procedure for
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generating the drill file is similar to generating the Gerber file.

Drill files are configured from the Drill tab in the Export Gerber Options dialog.

=| Export Gerber Options

Options | Layers | Corill |
Drawing Dia. Tool Dia. G
ADS Layer Export (inch) {inch) Tool Count
1 7.945 7946 1000
2 7.943 7.948 1501
cond
3 o1.886 o1.886 z2
4 Gl.854 G1.5854 Z
5 7.945 7945 105
condz
=] 7.945 7.946 a6
7 |resi [ i7.946 7.046 2
w
(04 l ’ Cancel ] ’ Help

Select the checkbox to designate the layer for which you want to generate the drill file. When a layer is selected, all
the tools on that layer are automatically selected. By default, no drill file will be generated during Gerber export.

The drill file options Number format, Output unit, and Zero suppression are same as options set for Gerber export in
Options tab of Export Gerber Options dialog. However, note that the zero suppression in Drill is actually a zero
inclusion.

Tool Dia. (Diameter) is an editable field. By default the Tool Diameter value equals the Drawing Diameter value.

Considerations:

e If a layer does not have any via (circles) then it will not be displayed in the Drill table and no drill file will be
generated for that layer.

¢ One drill file will be generated for each layer.

¢ Drill files will be created in the Destination directory selected in the Export dialog.

¢ Drill file name is the same as layer name with extension .drl. For example, drill file for the layer cond will be
cond.drl.

o If Tool Diameter is set to 0.0, the Tool Diameter will be equal to the Drawing Diameter in the output drill file.
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Exporting Gerber Files Using MTools

The ADS-to-Gerber translator creates one output file for each different layer used in the layout design. For example, if
the design contains two layers, cond and cond2, two Gerber files will be generated:

cond.gbr
cond2.gbr

In ADS 2002C and earlier versions of ADS it was not possible to perform multiple Gerber translations in a project, as
these filenames would be overwritten. However, starting with the ADS 2003A release it is possible to specify a
destination folder for each Gerber file, allowing for multiple translations in a single project.

To export Gerber files:

1. In the layout window containing your design, choose File > Export.

2. The Export dialog box appears. In the File Type field, click the arrow in the right-hand corner to display the
available formats. Select Gerber.

Export:1

File Type
Gerher 'I More Dptiuns...|

Destination Directory

I unewfwivirivets/d2/stevenjfjunktest_prjf Browse... |

3. To define export options, select More Options. Set the options that apply. For available options, see Export
Gerber Options. Click OK to save your settings or Cancel to retain the default settings.

4. In the Destination Directory field, accept the default directory, or use the Browse button to locate a new
destination directory.

 Note

If you generate Gerber files for more than one design in the same project, you need to specify different

destination folders to avoid overwriting common files (i.e., layers common to most projects like cond and
cond?2).

5. Click OK to accept the settings. The status window appears:
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[¢] Mtools ¥3.51 (Mar 7,2005)

Mtools v3.54 (Mar 7,2000) HPUX Key SOFTWARE

Activated Modules:
Mask to Gerher

-l Keep History

The entry Mask to Gerber displays under the heading Activated Modules. The Gerber translator converts your
design into a mask file before outputting it in Gerber format.

The option Keep History is selected as the default. When this option is selected, the preferences you specify are
saved and used as the default for future translations. If you do not want your settings saved, deselect this
option.

Click OK to proceed. The Mtools Log and Gerber Translator Interface window appear.

6. Verify that the Mtools Log contains the correct information. If necessary, edit the information. To dismiss the
Mtools Log window, click OK.
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|E| Mtools Log

File Search

aun May & 15:32:47 2005
mil
|::— 150, 0000 L 2R0, 0000

(=100.0000 ,50.0000

) Note

You may view the Mtools Log at any time by clicking the GERBER tab in the translator interface window.

7. In the Gerber Translator Interface window, set the Mask Files and Aperture File paths. The Mask Files field
displays the mask file created in the Export dialog box. This is the file that the Gerber translator converts into

Gerber format.
The Aperture File field displays the configuration file used to hold all of the translation parameters and Gerber

apertures. When performing a translation, you can create a new configuration file or reuse the same file. To

modify this file, see Gerber File Options.
To view the Mask Files and Aperture File paths, click the adjacent Browse button.

62




8.

9.

10.
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EGEHBEH

Mask Files

Famewhwlvirivetsid2istevenjfjunktest_prj/Remotei Browse...

english.apt Browise...

Ii
Aperture File
Ii

[ Eavmperures

Exit. .H.huut. Help

Select Gerber File Options , Translation Settings , and Edit Apertures to specify settings. Select View Mask to
invoke the Gerber Viewer for DXF and Gerber translations and View Gerber for Gerber translations only. For
details on Gerber translator interface options, see the appropriate section: Gerber File Options, Translation
Settings, Edit Apertures, and Using the Gerber Viewer.

Click Translate to select the layers you want to include in the translated file (see Translate). After selecting the
layers, click OK to complete the translation. A window appears briefly, indicating that the file is being converted
to Gerber format.

When the translation is complete, the Mtools Log appears, detailing the export information. Examine the log file,
searching for any warnings or errors that may have occurred during translation.
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When you are finished viewing the log file, click OK to dismiss the MTools Log and exit the Gerber translator.

Gerber File Options

You can view or edit the translator settings, by selecting Gerber File Options in the Gerber Translator Interface
window.
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_. — Gerber File Options

Gerber Unit INCH —

Format 3.3 —

Zero Suppress Leading — |

Data Mode Absulute  — |

Circular 360 —

EOB Character Ll

EOJ String Wiz —

CR/LF Suppress — |
OK ‘ Cancel Help ‘

A dialog appears, providing access to these options:

Gerber Unit. Available units are INCH or MM. MM is the default.

Format. The number of integers placed before and after the decimal point. If chosen incorrectly, Gerber data
resolution can be poor. The default is 3.3.

Zero Suppress. Available settings are Leading and None. Leading (the default) removes all leading zeros in the
coordinate data, making the Gerber file smaller.

If the setting is inappropriate, the Gerber data display is nonsensical.

Data Mode. The program always writes out absolute coordinates.

Circular. Available settings are 360 or Off. When Off is selected, arcs are fractured. When 360 is selected, arcs are
written by means of GO2/G03 with 360 interpolation. The default is 360.

EOB Character. Sets the character that denotes the end of a Gerber data block. Currently set as an asterisk (*).
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EOJ String. This string, inserted at the end of the Gerber file, indicates that the plot is complete. Currently set as MO2.

CR/LF. Available settings are Include or Suppress. Some Gerber files include a carriage return/line feed (CR/LF) at the
end of each command. When the CR/LF is suppressed, the file size is reduced by twenty percent and the translation is
completed more quickly. Suppressing the CR/LF does not effect your ability to view the Gerber data in the Gerber
Viewer. Suppress is selected as the default.

 Note

After you have set these options, you do not need to do so again unless you deselect the Keep History option
in the initial Mtools dialog (see Exporting Gerber Files).

Translation Settings

You can control how the program converts the mask data into Gerber format by selecting Translation Settings in the
Gerber Translator Interface window. These settings, crucial to correct output, are described in this section.
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Global Parameters

Line DCode. Open figures output to this D-code.

Scale Factor. Output data is scaled up or down according to this factor.
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ArcRes. Value, in degrees, by which arcs are broken up.

APT Out. Drop-down list for selecting aperture output from popular CAM software.

Outline/Fill

Outline or Fill. Each closed area is either outlined or filled, depending upon selection.

 Note

Maximum vertex count for polygons is 50k.

© Note

When Fill mode is selected, large shapes will be chopped into blocks of 1000 pt Gerber polygons. When Outline
mode is selected, large shapes will be chopped into blocks of 5000 pt Gerber polygons.

e Filled. D-codes used for outlining the closed filled figures.
e Empty. D-codes used for outlining the closed empty figures.
e StartApt. The smallest aperture used to start the filling.

Compensation

Compensate for etch factor by the given inch amount, shrink or swell , as needed.

Output Offset

The Gerber data coordinates are moved by the amount defined in the X and Y fields.

Gerber Output Format
The flavor of Gerber output: standard RS274D, extended RS274X or MDA with the Autoplot header. Barco DPF is

planned for the future.

Considerations
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When setting the translation options, consider the following:

¢ Qutline vs. Fill - Outline is much more efficient if your vendor accepts it. (Use POEX aperture for polygon fill as
needed.)

e Compensation - We recommend that you leave the default setting of None. The compensation available in the
Gerber translator is not intelligent and does not take butting or overlapping polygons into account.

e Gerber Output Format - RS274X is the best choice if your vendor accepts it. This format already contains an
embedded aperture list. RS274X and RS274D do not currently support empty polygons.

Edit Apertures

When you click Edit Apertures , a table listing the aperture settings appears.
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Click DCode to select the desired aperture type.

¥ Aperture (1.16) - english.apt

DCode Type Block Name

0  Round I 0.00100

11 ‘Round 1.00200

e
4
=
o

0T

0.00100 [

1

1.00200 H

P

Round 000400 | Doosoo |

—r
[ ¥4 ]

i
]

‘Round 10.00800 10.00800 H

0.01500 | .01500

=

AMARNARNINY

10.02500 |

=

02500

0.04000 | .04000

.
e
o
o
|T
KB
KB
KB
KB
KB
I_
—

[ALEERREE
LEULE
HLLL

—

PgUp Pg[)n Hume End Clear Line Hutu Flash
Md Default. Set Clear Al Cil'fHE[:UPDIy

Gerber files use apertures much like plotters use pens. Defining available photoplotter apertures is very similar to
installing pens into a pen plotter carousel.

To insert a standard set of apertures into the list, click Add Default Set in the Aperture dialog box.

To add a setting, change a coordinate, or change an aperture type, click in the section you wish to change and enter
the desired value. You can also change the aperture type via the Dcode dialog:

1. Click the D-code number under the heading DCode. A dialog box appears, listing the available aperture types.
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=l Dcode - D10

Type Block
Donut
Square
Rect
Thermal
Target
Octagon
Oblong
Poex
Poin
Thmsq
Custom

OK Cancel

2. Select the desired type and click OK. The dialog box disappears.

Among the available aperture types are POEX and POIN. These are special apertures for the FIRE 9000 laser plotter.
This plotter can take outline data and fill the inside of each polygon. If you are using such a plotter, the D-codes
should be defined for POEX and POIN and the translator should be run in outline mode (see Translation Settings). For
more information about this plotter, see FIRE 9000 Photoplotter Configuration.

Cir/Rect/Poly allows you to flash specific shapes with fixed dimensions, and will bring up the Map
Circles/Rectangles/Polygons dialog. When a shape is flashed it will only be defined once in the Gerber file. Every
instance of the shape can be referenced in the Gerber file with only the x,y coordinates of its location. Flashing shapes
in Gerber files reduces the file size and simplifies the output file.

71



Advanced Design System 2008

¥ Map Circles,/Rectangles;/Polygons

LT

RI0_08xD_D55

RID_1=D D4

i |
2 |
; |
:s: |
:s: |
:z: |
:s: |
; |

L
LR

I |
] |
] |
; |
] |
I |

-J Update Aperture

shog ——M8¥ M Min. Count
- Grcles _J Rectangles _J Pobygons F Oon

Show Circles, Rectangles, Polygons check boxes can be used to filter the list of shapes. Unchecking a box will remove
those elements from the list of shapes that can be flashed. The default postion is checked.

When the Min. Count On checkbox is selected, only shapes that have a minimum count specified in the field will be
shown in the list of shapes that can be flashed. The default position is unchecked.

Polygons can be prevented from being processed by the boolean engine if it has the property DB_NO_BOOL and its
value is 1.

To add this property to a shape:

Select the shape.

Select Edit > Properties.

Type DB_NO_BOOL in the name field, with a value of 1 in the value field.
click Add > OK.

AN

Note
Selecting the Auto Flash button in the Aperture dialog will automatically add all elements that can be flashed to
the aperture table, bypassing the Map Circles/Rectangles/Polygons dialog.

When you are satisfied with the aperture settings, click Save or Save As , or click Cancel to return to the default
settings. The Aperture settings window disappears.
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Translate

Select Translation Layers

Layer GDSIl Layer Name

slot

momentum_ref_offset

Select All| Clear All 0K Cancel

The Translate button invokes the Select Translation Layers dialog. This dialog enables you to select the layers to be
included in the translated file. (The Gerber translator creates a Gerber file for each layer in the mask file.) All layers
are selected as the default.

 Note

Layers are selected when they are highlighted.

To select or deselect a layer, click it. You may also choose Select All or Clear All.

To complete the translation, click OK. A dialog briefly appears, informing you that the mask file is being converted into
Gerber format. When the translation is complete, the Mtools Log appears. Inspect the log to verify that the file was
translated as expected. (To dismiss the log window, click OK.)

View Mask
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The View Mask button invokes the Gerber Viewer to display the mask file. For information on the Gerber Viewer, see
Using the Gerber Viewer.
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View Gerber

Once the translation is complete, click View Gerber to launch the Gerber Viewer and load the Gerber file(s). The
Gerber Viewer enables you to view your file(s) and generate drill data.

Check the bottom of the Viewer window for messages or instructions.

For more information on the Gerber Viewer, see Using the Gerber Viewer.

Export Gerber Options

~ Export GERBER Options:11

Units Scale X Scale ¥ L T
= ame /| 1.0 "1 0 1 Auto Merge

.| Arcs As Polygons
Define Layers...
| Rectangles As Polylines

Layers Layer Number(s)
. ? Hole Format
@ Include

_) Holes As Polygons

] Exclude I_ayer File HEITIE{S}
# Holes As Cutlines

Preserve Holes
Etch Factor  Miter Angle - ;

0 90,0

0K Cancel Help

Units

These are the units that the Gerber file will be written in. You may select from the following options: same , mil , inch
, um , mm , cm. The default is same. When same is selected, the design is written in the same units that are stored in
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the design file. For information on choosing layout units, refer to Setting Units/Scale Factors in the Customization and
Configuration manual.

Scale X, Scale Y

These are the fields for inputting the scale factors for shapes in the direction of X and Y. The default settings are 1.0,
1.0.

Define Layers

Clicking the Define Layers button invokes the Layer Editor. For Layer Editor Options, see Defining Layers.

Layers Include, Layers Exclude

The Include and Exclude buttons enable you to specify layers to either include or exclude.

e Include. Exports information only from layers specified in the Layer Number(s) and Layer File Name(s) fields.
Include is selected as the default. Unless you specify layer numbers to include in the Layer Number(s) field, all
layers are automatically included.

e Exclude. Exports all layers except those specified in the Layer Number(s) field (it is not necessary to fill in the
Layer File Name(s) field).

Layer Number(s)

The numbers of the layers to be included or excluded in the export process. Entries are separated by commas. For
example:

1,6,20

Layer File Name(s)

The numbers and names of the layers to be included in the export process. The information must be presented in
pairs, as follows:

<layer_number> <layer_name> <layer_number> <layer_name>...
where all are separated by spaces. For example:
1 mskl 3 msk3
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Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap are merged. This option is
deselected as the default.

Arcs As Polygons

When Arcs As Polygons is selected, the design arcs are exported as line segments (or polygons). This option is
deselected as the default.

Rectangles As Polylines

When Rectangles As Polylines is selected, all rectangles are translated as open plane figures bounded by straight lines.
When this option is deselected, all rectangles are translated as closed plane figures bounded by straight lines. This
option is deselected as the default.

Holes As Polygons

When Holes As Polygons is selected, holes are exported as a filled element, which is also how polygons are exported in
the gerber format. When Holes As Polygons is not selected, polygons with holes are translated as single-segment
polygons, the false edge segment becoming part of the polygon. Some systems may not be able to tolerate this type
of complex polygon. For these systems, make certain that Holes As Polygons is selected. This option is deselected as
the default.

Holes As Cutlines

When Holes As Cutlines is selected, holes are converted into cutlines. This option is selected as the default.

Preserve Holes

When Preserve Holes is selected, holes are exported as an empty element. This option is not available for exporting
gerber files.
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Etch Factor

The etch factor applies a global over/undersize amount to each shape translated. This is meant to compensate for etch
effect during processing. However, using this option can be problematic. Thus, we recommend that you retain the
default setting of 0.

If you use Etch Factor, carefully verify the correctness of the compensation to minimize problems. Limitations include
the following: When a figure has a side smaller than the etch factor, this function may fail. If two boundaries butt up
against one another before compensation, because each boundary is handled independently, such boundaries will
either overlap or show a gap when compensation is specified. When Etch Factor is applied, re-entrant polygons may
be transformed into illegal polygons.

Miter Angle

This is the angle cutoff used with the etch factor. The miter angle controls acute angle edge over-extension. Any angle
below the miter angle amount is mitered. The default value is 90.0.

Limitations and Considerations

How you want to use the Gerber output-including layer numbering, use of holes, and polygon shapes-should be
extensively considered before beginning your layout design. Setting up the proper layout rules can save a lot of time
in generating acceptable Gerber output. For specific considerations or limitations, particularly in relation to apertures
and film wheels, consult with your photoplotter vendor.

Using the Gerber Viewer

The Gerber Viewer enables you to view mask (.msk) and Gerber (.gbr) files. The Gerber viewer can be invoked from
the layout window File menu, or during export from the Mtools DXF or Gerber translator window.

Criteria for Viewing Gerber Files

In order to be viewed, the files must meet the following criteria:

¢ Use either absolute or incremental data coordinates
e Support apertures from D10-D999
e Have data formats from 0.1 to 4.5
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Launching the Viewer from a Layout Window

1. From an Advanced Design System layout window, choose File > Export. The Export dialog box appears.
2. Select Gerber Viewer as the file type.

File Type

Gerher Viewer T wdore Gutions..

Mew File Hame (Destination)

dipole. gbt Browse...

0K cancel Help

3. In the New File Name (Destination) field, enter the name of the file you wish to view. Alternatively, you can click
Browse and the Export File Selection dialog box appears, enabling you to browse your directories for the desired
file.

4. Click OK and the following window appears:

=l Mtools v3.26 (Mar 12, 1998)

Mtools v3.26 (Mar 12, 1998) HPUX Key SOFTWARE

Activated Modules:
Mask to Gerber

~ Keep History

OK

o

In this window, click OK. The Mtools translator and log windows appear.

6. To dismiss the Mtools Log window, click OK in the window. You may review it at any time by clicking the GERBER
tab in the translator window.

7. In the Mtools translator window, enter the name of the file to view in the Mask Files field. This file must carry the
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extension .msk.

= Mtools v3.26 (Mar 12, 1998)
GERBER

Mask Files

i/hfs/d1/users/daniwill/ads/Slot_dipole/ Browse...

Aperture File

metric.apt Browse...

Gerber File Options

Translation Settings

Edit Apertures

Translate

View Mask

View Gerber

Exit | About| Help |

8. To invoke the Gerber Viewer, click either View Mask (for DXF and Gerber translations) or View Gerber (for Gerber
translations only). The Gerber Viewer appears.
For information about Gerber Viewer options, see Gerber Viewer Menu Options. For information on the buttons
available from the Gerber translator interface, see Exporting Gerber Files.

9. To exit the Viewer, select File > Exit Xgbrvu.

Launching the Viewer During File Export

You can launch the Gerber Viewer from the Mtools translator window when exporting DXF or Gerber files.

1. From the Mtools translator window, click View Mask (for DXF and Gerber translations) or View Gerber (for Gerber
translations only). The Gerber Viewer appears.
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= Mtools v3.26 (Mar 12, 1998)
GERBER

Mask Files

i/hfs/d1/users/daniwill/ads/Slot_dipole/ Browse...

Aperture File

metric.apt Browse...

Gerber File Options

Translation Settings

Edit Apertures

Translate

View Mask

View Gerber

Exit | About| Help |

For information about Gerber Viewer options, see Gerber Viewer Menu Options.. For information on Gerber
translation options, see Exporting Gerber Files. For information on the options available from the Mtools DXF
translator interface, see DXF Translator.

2. To exit the Viewer, select File > Exit Xgbrvu.

Loading a File to View

1. Choose File > Open/Import
If there is a file in current memory (that is, you have initiated the Viewer during a file export) and it is not yet

loaded, that file is automatically loaded at this time. There is no need to proceed with the following steps.
Otherwise, the Open Job/Import Gerber dialog appears.
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Open Job / Import Gerber

( ACS Job / Standard RS274D
MDA

- JRS274-X

~ J/RS274 Dark Mode

~ /RS274 Reverse Mode

_|DSN/GAP

_)GAP

JALLEGRO

- JMENTOR

_ JPROTEL

) TANGO

0K Cancel

This dialog enables you to load an existing file, or to create a new job file. (The job file is used for purposes
internal to the Viewer and is not required by the vendor.)

. Select the desired file type and click OK. A browser dialog that is specific to the file type you selected appears.
For example, if you chose ACS Job/Standard RS274D , the Select/Create Job dialog appears.
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=4 Select/Create Job
Filter
11/ads/Slot_dipole/*.jol
Directories Files
SR /dipole.job
. 1/dipole2. job
data y/dipole_us.job
mom_dsn :/test. job
networks
substrates
synthesis
to_mgc H
AN T N T
Selection

5/Slot_dipole/dipole.joh

OK | Filter | Cancel

3. Select the file you want to load or create and click OK.
If you cannot remember the name of the file you want to load, you can use a wildcard (*). The browser will
display all files that match the wildcard specification.
If the file you choose does not exist, a dialog appears asking if you want to create it. Click Yes to create the file,
or No to cancel.

4. The Select/Create Aperture dialog appears. Select the file you want to load or create and click OK.
If the file you choose does not exist, a dialog appears asking if you want to create it. Click Yes to create the file,
or No to cancel.

— File Open

’ File "/users/daniwill/mask.apt’ does not exist.
Do you want to create it?
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5. The Gerber Settings dialog appears. Set options as desired and click OK. (For more information, see Gerber
Settings.)

. — Gerber Settings — mask.apt

Gerber Unit MM —

Format 2.4 — |

Zero Suppress _ None - ‘
Data Mode Absolute — |

Circular 360 —

Arc Resolution ‘9 .0

OK Cancel

6. The Layer dialog appears. Select layers as desired and click OK. (For more information, see Layer.)
7. The Aperture dialog appears. Set apertures as desired (see Aperture) and click Save.
8. Set options, view, and plot as desired. See Gerber Viewer Menu Options.

Gerber Viewer Menu Options

This section describes the Gerber Viewer menu options. A message area at the bottom of the Viewer window provides

information specific to your situation.
The two file display options are: Outline or Fill. Click the appropriate button to change the window display. The button

title changes to reflect the display.
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___ File Display Options

__ Display Area

— xgbrvu = dipole. job,mask.apt

E_Iln Enrw Iunls !nfu Elut

Fill | Layer| Aperture| Plot Screen| Plot Window| Highlight Apt. |

Configuring Layer Settings...
—-- Finished Layer Settings —-
Configuring Aperture Settings...
o Finished Aperture Settings —-

i

Al |
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File

Click File and a drop-down menu containing the following options appears:

Open/Import loads the job file. The job file contains the name of the aperture file, data units, and Gerber files to
load. For more information, see Loading a File to View.

e Layer invokes the Gerber Viewer Layer menu. For more information, see the section Layer.
e Aperture invokes the Gerber Viewer Aperture menu. For a description of this menu, see the section entitled
Aperture.
e Preferences leads to the following menu choices:
° Gerber Settings invokes the Gerber Settings dialog. See Gerber Settings.
° Grid/Snap Settings opens the Snap Settings dialog. See Snap Settings.
° Poex Check
e Exit Xgbrvu dismisses the Gerber Viewer.

View

The following display options are available:

¢ All displays the extents of the data. This is the default option.

¢ Window enables you to use the mouse to draw a window around the area you wish to view.
e In zooms in, or magnifies, the view by two times.

e Out zooms out by two times

e Pan enables you to pan the display window.

e Last restores the previous view.

e Redraw refreshes the screen.

Tools

The Tools menu contains the following options:

¢ Drill enables you to select your drill output. Available choices are listed below. When you click your selection, the
Drill Output dialog appears, stating layer, drill output and tool count. To dismiss this dialog, click Close.
° Excellon (Suppress Leading Zero) is the default option.
° Excellon (No Zero Suppress)
° XY Table outputs a drill summary table.
e Report displays the Gerber Report dialog. This dialog provides a text summary of the current file, including layer
and aperture information. To dismiss this dialog, click Close.
e Film Merge invokes the Gerber Merge dialog. For more information, see Gerber Merge.
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Info

The Info menu provides the following options:

e Vertex Query searches for the vertex point nearest to where you click the mouse.

¢ Window Query summarizes the trace information of a specified area.+

¢ Flash Query identifies the flash point nearest to where you click the mouse.

e Measure measures the distance between two points.

¢ Highlight Apertures invokes the Highlight Aperture dialog. For more information about this dialog, see Highlight
Apt.

When you select (click) an option, information and instructions appear in the message area at the bottom of the
Gerber Viewer window. To quit a task, press the ESC key.

© Note

Actions prompted for in the Viewer message area (such as pressing ESC to abort) are effective only when the
mouse is pointed in the Viewer display area.

Plot

The following options are available from the plot menu:

e Plot/Page Setup invokes the Page/Plotter Setup dialog, enabling you to specify page setup, plot format, output,
and setup strings.

e Plot Screen plots only the area displayed on the screen.
e Plot Window enables you to plot a selected area. You use the mouse to draw a box around the specific area you

wish to plot. For instructions on how to do this, see the Gerber Viewer message area at the bottom of the Viewer
window.

e Plot Window Coords invokes the Plot Window dialog, enabling you to specify plot coordinates.
- Plot Window

Extents (MinX, Min¥Y)

i
i

Extents (Max>, MaxY)

OK Cancel
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Outline/Fill

The Outline/Fill button reads as either Outline or Fill , depending upon the display type activated. That is, if Outline
appears, the file is displayed in outline form, and if Fill appears, it is displayed as filled.

To change the display from outlined to filled, or vice-versa, click this button.

Layer

The Layer button invokes the Gerber Viewer Layer menu. (You can also choose the menu command File > Layer to
open the Layer menu.)

The Layer menu enables you to select which layer files are loaded for display; whether these are displayed as paint,
scratch, or negative; and the color they are displayed in. Up to 48 layers may be simultaneously displayed. For
information, see Layer Menu.

 Note

Changes to the Layer dialog options do not affect the raw Gerber data. They change the display only.

Gerber Settings

File > Preferences > Gerber Settings

- — Gerber Settings — mask.apt

Gerber Unit MM —

Format 5.4 — _

Zero Suppress _ None ) J
Data Mode Absolute — |

Circular 360 — |

Arc Resolution |'5I .0

OK | Cancel
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Gerber Unit. The units the Gerber data adopts when it is loaded. You may select either INCH or MM. MM is the default.

Format. Gerber data does not contain the decimal point. For coordinate data, you must tell the program the number of
digits to insert before and after the decimal point. The default Format value is 3.3. Other common formats are 2.3 and
4.4.

Data formats from 0.1 to 6.3 are acceptable. However, arithmetic problems may arise when very large data values are
rendered precisely. For example, if you have a circuit board that extends out 20 inches from the origin and you
require 4-place accuracy across the board, you may find that some data points out at the 20,20 coordinate have only
3-place accuracy. This may cause the program to incorrectly fill polygons in this region.

Zero Suppress. Gerber files are normally compressed by suppressing either the leading or trailing zeros of the Gerber
data. You may specify Leading , Trailing , or None. Leading is the default. If you choose the wrong setting, the Viewer
displays nonsensical data.

Data Mode. The data coordinates can represent either absolute or incremental values relative to 0,0. Absolute is the
default. When Incremental is selected, each coordinate represents the distance from the previous coordinate.
Selecting an incorrect data mode results in an incoherent display of the data.

Circular. You may select either 90 or 360. Older photoplotters used 90 degree arc interpolation. Newer machines
support 360 degree interpolation. The default setting is 360.
If your arcs display incorrectly, try changing this setting.

Arc Resolution. To display Gerber circular commands (G01/G02), the Gerber Viewer uses small, straight segments to
approximate the data. How fine the approximation is depends upon the Arc Resolution value. The default value of 9
degrees is appropriate in most cases. This value offers a good compromise between speed and resolution. Valid values
are between 0.5 and 30 degrees.

Snhap Settings

File > Preferences > Grid/Snap Settings
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Snap Settings

Grid Spacing
0.00001

| Snap On
| Grid On

OK | Cancel

Grid Spacing. Use Grid Spacing field to set the grid spacing as desired.

Snap On. Click the selection box to turn this option on or off. This option is selected as the default.

Grid On. Click the Grid On selection box to turn this option on or off. This option is deselected as the default.

Gerber Merge

To invoke the Gerber Merge dialog, select Tools > Film Merge
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— Gerber Merge (v 1.00) = dipole_us.mrj « |
—Films Gerber File Delete Paint/Scratch
/hfs/d1/users/c J i X ps0
II i XA ps1
ﬁ.ﬂtil Duiete I x ps2
_| Negative Image =
! A ps3
I i A psa
— Gerber Files i x ps5
|l' 1 /hfc/dtincar -
S ' X psB
Dalote/Undalete
! | i A ps7
— Output Type —
i
" RS274D ‘ A ps8
IRS274X I X ps9
 JMDA Autoplot | | X ps10
|| Addressibility 14 @ View Film OK| Cancel Help||

Films. The current filename is displayed in this field. To enter a filename, click in the entry box and type the desired
file path. You can also click the ellipses box (...) in the right-hand side of the Film field to select a file from the
Working Directory browse dialog.

Negative Image. Click the selection box to turn this option on or off. This option is deselected as the default.

Gerber Files. Your Gerber files are listed in this field. You may delete or undelete these by clicking the Delete/Undelete
button below this field.

Output Type. You may select RS274D, RS274X, or MDA Autoplot as the output format. RS274D is selected as the
default.

Gerber File. List the Gerber files that you wish to merge in this column.
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Delete. This field is disabled.
Paint/Scratch. This field is disabled.

View Film. Click the selection box to select or deselect this option. View Film is selected as the default.

Layer Options

To load your Gerber files, click on a Layer number button. A file selection dialog box appears, enabling you to select
the file(s) you want loaded. You may select display options as desired.

The Layer dialog and its options are shown in the figure.
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Click the Layer number to open —— Type the full name of the Gerber or mask Click this button to specify Paint,
the Select Gerber File diakeg. file inthis field. Alternatively, click the Layer Scratch, or Negative. For more
Browse your directories, select number to open the Select Gerber File information on these display types, refer
the fileis) you desire, and click dialog and select the file from your to the text following this figure.
oK. directories (see left).
! Click the Color
- Layer = dipole_us.job field to open the
Layer Colkr
Layer Name On/Off Paint/Scratch/Neg Color palette. Click the

desired layer

Jl dipole/dipole_us.msk W Paint -l cobor.
gl ~<1>:slot] v Paint |
;" ~<1>:uStrip 4 Paint |
g| ~<l>:vid v Paint [ |
jl :momentum_ref_offset] W Paint -l

6 || I N Paint

7 ] Paint
g“ N Paint
ﬁh N Paint
_E-Jli ] Paint
1 ] Paint

12 ||} N Paint ;

" Up| Down| Home| End| All On| All Off| OK Cancel| Help|

This field toggles the layer display. When highlighted, the layeris
displayed. To turn all layers on oroff, use the All On or All Off
buttons at the bottom of this dialog.
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Paint displays the layer data normally.

Scratch performs an XOR operation on all data previously loaded. The resulting display mimics the effect of scratch
behavior available on many photoplotters.

Negative reverses the polarity of the layer and is useful for displaying ground planes.

Aperture

File > Aperture
The aperture button in the Gerber Viewer Options window invokes the Aperture menu, enabling you to define
apertures from D10 through D999 and assign drill tools to create Excellon drill codes.
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— Aperture (1.07) — metric.apt '
DCode Type X f(inch) Y Tool # Drill Dia.
10 |Round  [8.025 0.025 i ! Save
" 11 [Rouna  |p.05  |0.05 | I
12 [Rownd  |B.1 0.1 I 1 Sovele
13 | Round 0.2 0.2 i i Cancel
18 [Rowna |04 |04 |1 |
15 [Rowna |p.8 0.8 ; 1 Help |
T Round n.s 1.5 i |
17 [Rouna |1 T O
8 ] 1 1 L
e 1 I [
20 |Poex o o { {
21 [[peex  |B o L i
PuUpl FgDn| Home| End Clear Line
- Add Default Set Clear All -

To accurately display your data, you must set the correct apertures.

DCode. You may define D-codes from D10 through D999. Click in this field and the Dcode dialog appears, enabling
you to select one of 12 standard types (see below).

Type. Twelve types are available: round, donut, square, rectangle, thermal, target, octagon, oblong, poex, poin,
thmsqg, and custom.

To specify a type, click in the Type field and enter the desired type. Alternatively, click the DCode number and the
Dcode dialog appears, presenting the available types for selection.

X, Y. These are the aperture dimensions in units of inches or millimeters (mm), depending on the Gerber unit
selected (see Gerber Settings). Some apertures, such as round pads, have only an X value; others require X and Y
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values.

Tool #. This field is for specifying an Excellon drill data tool. This field is optional and need only be specified when
converting Gerber flashes to Excellon drill commands. Valid ranges are TO1 through T99.

Drill Dia. Enter the drill tool diameter in this field. This field is optional. Valid ranges are 0.001 inch to 0.99 inch.

Add Default Set. When you click this button, a standard set of apertures is inserted into the list.

Plot Screen

You may select this option by clicking the Plot Screen button on the Gerber Viewer menu bar or by selecting the menu
command Plot > Plot Screen. The screen is plotted, and the plot information appears in the message area at the
bottom of the Viewer.

Plot Window

You may select this option by clicking the Plot Window button on the Gerber Viewer menu bar or by selecting the
menu command Plot > Plot Window. This option enables you to plot a portion of the screen by using the mouse to
draw a box around the area you wish to plot. This is done by clicking the mouse on the first and second corners,
diagonally, of the plot window. Instructions and plot information appear in the message area at the bottom of the
Viewer.

Highlight Apt.

The Highlight Apt. button opens the Highlight Aperture dialog. This dialog enables you to select apertures to be
highlighted on the display.
ltrans-08-1-33.gif!

 Note
Double click an aperture to select and display it. All traces associated with a highlighted aperture appear in
light gray rather than in the assigned layer color. Click OK to dismiss the dialog box.

Page/Plotter Setup

This dialog box contains four tabs: Page Setup, Plot Format, Output, and Setup Strings. The options available from
each tab are as follows. To access this dialog box, select Plot > Plot/Page Setup
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Page Setup. This tab provides access to page size, margin values, and orientation options.

Plot Format. This tab provides access to the plotter driver type, print type, scaling factor, raster memory size (in
MBytes), and dpi (dots per inch).
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Output. This tab enables you to select the output file name and designate a printer path.
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Setup Strings. This tab enables you to set up headers and trailers.
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Gerber Viewer Keyboard Commands

You can access many Gerber Viewer commands either through the mouse or the keyboard. In fact, a few commands
are available only through the keyboard.

Key Action

Esc Cancels command or moves up one level in the menu
structure.

Toggles the grid on and off.
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+ Zooms in 2x.
- Zooms out 2x.
Ins Same as Pan command.

Home Zooms to extents. Same as All command.

Configuring the Gerber Translator for Photoplotters

Types of Photoplotters

There are two types of photoplotters: vector and raster.

Vector Photoplotters

Vector photoplotters process each draw and flash command directly from the Gerber database. These are normally
mechanical plotters with an X-Y table, a light head, and an aperture wheel. Examples of vector plotters include the

Gerber 3200 and 4000 series flatbed plotters.

Raster Photoplotters

Raster photoplotters rasterize the input Gerber data using a computer, and then use the resulting bitmap to modulate
a laser that is scanned across the film. What is interesting about raster plotters is that many of them can accept
polygons in addition to draws and flashes. The ability of a photoplotter to fill a polygon is extremely useful to the
microwave and RF designer. Examples of powerful raster plotters that support polygons include the Gerber Crescent
family of plotters and the Cymbolic Sciences family of FIRE 9000 plotters.

Vector Plotter Configuration

The mask file input to the Gerber translator is essentially a collection of polygons that need to be filled. Therefore,
when you run the translator you should:

e Set the Translation Settings option Outline/Fill to FILL.
e Have a reasonable selection of round apertures available to fill. The smallest aperture diameter should be at least
2-3 times less than your smallest line width, otherwise you may not get a good representation of your design.
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-004 / \ 006
IQ [x Y, \ / n‘é lz\___

Ideal Size Increase Diameters Too Far Apart

Typical D-code diameters range from 0.001 inch up to 0.200 inch. Most mechanical photoplotters support up to 24
D-codes.

The Gerber translator uses an advanced multi-aperture fill instead of what we call a pen plotter fill. The multi-aperture
fill generates Gerber files with the same resolution as a pen plotter fill, but creates data files 5-10 times smaller.

Aperture Too Large to Resolve Small Feature Aperture Smaller than Critical Feature

——— e

Polygon Filling Rules

Each polygon is filled independently of any other polygon in the mask file.

Any arcs that are part of a polygon boundary are broken into segments using the ArcRes parameter. This parameter is
the number of degrees per segment. The default of ArcRes is 9 degrees. If you need smoother arcs in your film,
reduce the number to 6 or even 4 degrees.

The routines start filling at the inner edge of the polygon with the smallest aperture (the one you specify as the Start
Aperture in the translation configuration menu). This aperture is normally used twice and is offset from the edge of
the polygon by 1/2 diameter (see A below). The first two strokes overlap by 1/2 diameter (see B below).

%L (:8—@
'8 ] &
A B

The routines then select a larger aperture (but normally no larger than 2 times the starting aperture) and repeat this
process.
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The interior of most large polygons is scan-filled with a fat aperture. There is no overlap between strokes once the
routines jump into scan-fill mode.

Empty Polygons

Because the Gerber translator fills each polygon as it encounters it in the data stream, when it encounters an empty
polygon it cannot clear away areas already filled. Therefore, for vector photoplotters, avoid using empty polygons in
your layout. (This limitation is not in effect for some raster plotters.)

The translator issues a warning in the log file when it does encounter an empty polygon so that you do not
accidentally plot over it.

If you have used empty polygons in your design, you may select the Advanced Design System Gerber export option
Auto Merge , enabling you to merge filled and empty polygons to form a single filled polygon. This creates what we
call a re-entrant polygon and is supported by the Gerber translator. However, while we recommend this function for
relatively simple structures, we do not recommend you use such a function where hundreds of drill holes must appear
in a power plane.

Compensation

Compensation works by swelling or shrinking each polygon prior to filling it. Again, because the translator views
polygons independently, it cannot take into account spatial relationships between polygons. If you attempt to use a
shrink compensation with butting polygons, a narrow gap will form between them.

FIRE 9000 Photoplotter Configuration

The Cymbolic Sciences FIRE 9000 photoplotter is a raster laser plotter that is ideal for creating microwave and RF
artwork. Not only does this photoplotter have a very high resolution (typically 1/8 mil), but its RIP front end supports
two very important extensions to standard Gerber (RS274D) data:

e POEX - external polygons (filled areas)
¢ POIN - internal polygons (empty areas)

Because of these high level commands, the Gerber translator can translate a mask file with empty polygons directly
into a stream of POEX and POIN commands. Configuring the translator for MDA output is the only mode that supports
empty figures in the mask file.

Not only does configuring the translator for MDA output eliminate the need to stroke out the interior of each polygon,
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but the resulting artwork is limited only by the precision of the photoplotter. The FIRE 9000 autoplot format also
embeds all Gerber format, unit, and data mode information into its header so that a separate aperture and
information list is not needed.

We highly recommend (if possible) that you send your data to a photoplot or board shop equipped with a raster
photoplotter such as the FIRE 9000.

The Gerber Viewer can properly view both POEX and POIN data so that you can verify the correctness of the output.

Recommended Settings for FIRE 9000 Output

The proper settings for FIRE 9000 output are summarized in the table below. When Outline/Fill is set to OUTLINE ,
each mask polygon is outlined. If a polygon is filled, then it is sent to either D20 or D21; these are both assigned as
POEX. If it is an empty polygon or a hole, it is assigned to D22 or D23 which correspond to a POIN. Any open mask
entities are sent to D10, which is a standard round aperture.

Gerber Translator Settings for FIRE 9000 Output

Gerber File Options Translation Settings Apertures (inches)

Option Setting Option Setting D-Code Type Inch (X,Y)

Unit INCH or MM Line DCode dio 10 Round 0.005

Format 4.4 0r4.3 Scale Factor 1 20 Poex 0.000

Zero Leading Outline/Fill Outline 21 Poex 0.000

Suppression

Circular 360 Filled D-codes | d20, d21 22 Poin 0.000
(POEX)

CR/LF Suppress Empty D-codes | d22, d23 23 Poin 0.000
(POIN)

Compensation | None

Output Offset | 0,0

Gerber Output | MDA Autoplot
Format

RS274X Output Configuration

Gerber Scientific's laser photoplotters read the extended RS274X specification. These photoplotters also support a
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file they will be covered up.

Other photoplotters may also support the RS274X specification, but before using them you should verify that they
properly support the G36/G37 command used to switch into polygon mode.
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Recommended Gerber Translator Settings for RS274X Output

Gerber File Options Translation Settings Apertures (inches)
Option Setting Option Setting D-Code Type Inch (X,Y)
Unit INCH or MM Line DCode dio 10 Round 0.005
Format 4.4 0r4.3 Scale Factor 1 20 Poex 0.000
Zero Leading Outline/Fill Outline 21 Poex 0.000
Suppression
Circular 360 Filled D-codes | d20, d21
(POEX)

CR/LF Suppress Compensation | None
Output Offset | 0,0
Gerber Output | RS274X
Format

Creating an Excellon Drill File from an ADS Layout Using MTools

This section describes the procedure for creating an Excellon drill file from an ADS Layout. Excellon drill files define x
and y coordinates for hole location and drill size. These files are used to automate the drilling process in
manufacturing environments.

To create a drill file:

1. In the layout window containing your design, choose File > Export. The Export dialog box appears.

2. Select Gerber from the File Type drop down list then specify the file name in the New File Name (Destination)
field. Click OK. The Mtools status window appears.

3. Click OK in the Mtools status window to accept the settings. The Mtools Log and Gerber Translator Interface
windows appear.
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GEHHEH

Mask Files

Aperture File

lenglish.apt

T

Exit |About |Help

Gerber Translator Interface Window

4. From the Gerber Translator Interface window, click Edit Apertures. A table listing the aperture settings appears.
5. In the Aperture dialog box, click Flash Circles. A Map Circles/Holes dialog box appears.
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Block

- Names

6. In the Map Circles/Holes dialog box, verify that the circle Count and Diameter for each Block are correct. Ensure
that the Update Aperture box is checked. Note the Block name of each of the circles in the Map Circles/Holes
dialog box. Click OK in the Map Circles/Holes dialog box.

In the Aperture dialog box, using the information from step 6, note which D-codes have the Block names that
were mapped to circles and then click Save. A small dialog box asking if you want to save the changes appears.
Click OK.
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E Aperture (1.10) - english.apt

DCode Type X (inch) Block Hame

18  Round

[7=]

Round

21

22  Poin

23  Poin Block
Names

F' ound

r
h

Round

P
=r}

Round
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P

AEEEEEEONEE

Round

za F ound

r
4=

‘Round

ed
Auto Flash

Cear Line
Add Defaull Set Clear All Flash Circles

7. From the Gerber Translator Interface window, click Translate to select the layers you want to include in the
translated file (see Translate). After selecting the layers, click OK to complete the translation. A window appears
briefly, indicating that the file is being converted to Gerber format.

8. When the translation is complete, the Mtools Log appears, detailing the export information. Examine the log file,
searching for any warnings or errors that may have occurred during translation.
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Fle Search

Mazk To Gerber Translator v3.40 (Aor 30, 1999) Key

APT File: eng

CIRCULAR an

FORMAT 4.4

LIME dZ5

M=CALE 1

START _APT di10

OUTLIME on d20 d2l d2
:BR_END MOZ

GERTYPE
FLASH on
TRACE off
FEND 0
TUNIT inch
TRES 0,000
LIPPRE ;

SUPPRESS LEADING

When you are finished viewing the log file, click OK to dismiss the MTools Log and exit the Gerber translator. You
can also save the MTools Log before exiting using the File > Save As menu pick.

From the Gerber Translator Interface window, click View Gerber. The GBRVU dialog appears with a Gerber view
of your layout.

From the GBRVU dialog, click Aperture. The Aperture dialog box appears.

In the Aperture dialog box, enter the Tool # (integer only) and Drill Dia. for each of the D-codes that were noted
in step 7. Click Save. A small dialog box asking if you want to save the changes appears. Click OK.

From GBRVU, choose Tools > Drill > Excellon. Choose whether or not to suppress the leading zero's. The Drill
Output dialog box appears.

Click the appropriate Drill Output and then click Report. The GERBER VIEWER - DRILL REPORT file is displayed.
This file contains a DRILL TOOLS TABLE that lists tool numbers, tool size, quantity and remarks.

Example Drill Report:
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| File Search

£

GEREER WIEWER - DIRILL REPCRT

Date/Tine = B/B 2:04:10 pm

2.4, Leading Zeros Suppre
: inch

Drill File 1,drl

Drill Farmat: Excellon Format Two

A e e e e e e e et e et et e e e e ]

I DRILL TOODLS TABLE

e e e e e e e e e e |

| Drill | Deill | Deill
] B x

Tool Count

15. Use any ASCII text editor to open and view the drill file (file extension .drl) stored in the current ADS project
directory.

Example Drill File:
M48

INCH,TZ

VER,1

FMAT,2
DETECT,ON

%

M72

GO5

TO01C.025
X-03000Y001000
X-03050Y-00500
X-01500
X002000

110



Advanced Design System 2008

X001500Y000000
T02C.125
X-01500Y001000
Y000500

X-01000
Y001000

M30

) Note

Both the drill report and drill file are created in the ADS project directory with the layer name as a prefix and
.rpt and .drl as suffixes.
Example: layer_name.rpt is the drill report and layer_name.drl is the drill file.

HPGL/2 Files

The HPGL/2 format is a subset of the HPGL22 printer/plotter language and can be exported from a Layout.

Exporting HPGL/2 Graphics Files

The procedure for exporting each format is generally the same, however the available options differ. For a
step-by-step tutorial on exporting a layout file, refer to Exporting a Layout. For specific export options related to

exporting HPGL/2 Files, refer to Export HPGL/2 Options.

Export HPGL/2 Options

The Export HPGL/2 Options dialog box enables you to set Units, Precision, Scale, Attributes, Etch Factor and Miter
Angle as well as access the Layer Editor and specify layer options.
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—|  Export HPGLi2 Options:3 |

Units Precision

Sane -3 ‘

Define Layers...

0K Cancel Help

Units

These are the units with which the HPGL/2 file will be exported. You may select from the following options: same, mil,
inch, um, mm, cm. The default is same. When same is selected, the design is written in the same units that are stored
in the design file. For more information on choosing layout units, refer to Setting Layout Options > Preferences for
Layout > Setting Units/Scale Factors in Customization and Configuration.

Precision

This value should be the same as the precision with which the drawing file was created. A warning is generated if the
precision is less than the drawing file precision. Possible values are —2 and —3. The default is —3.

Define Layers

The Define Layers button invokes the Layer Editor. For Layer Editor options, see Defining Layers.

IFF Files

The Intermediate File Format (IFF) is an ASCII intermediate file. The file has a simple, line-oriented command
structure with a fairly rich set of constructs, thus simplifying design transfer between Agilent Technologies products
and third-party EDA tools. This format is machine- and application-independent.
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The types of information that can be represented in the IFF format include:

Design Objects
° Symbols
° Layouts
° Schematics
Connectivity
Design Object Hierarchy
Hierarchical and Design Object Properties

IFF files are used as the exchange mechanism when transferring designs between Advanced Design System and
third-party EDA tools such as Mentor Graphics Design Architect and Cadence Analog Artist.

Importing IFF Files

The procedure for importing each format is generally the same, however the available options differ. For a
step-by-step tutorial on importing a layout file, refer to Importing a Layout. For specific import options related to
importing IFF Files, refer to Import IFF Options.

Import IFF Options

The Import IFF Options dialog box that appears is dependent upon where you execute the IFF import from. If the
import is invoked from the ADS Main window, the following Import IFF More Options dialog box appears.
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Import IEF Options E|

[~ Remove IFF File After mport

[ Log verbose messages

[~ Synchronize ports to symbol using node name

[v Uze port name for connected wire label

[v Usze layouts from libraries inztead of building local copies from IFF file

Default Library Mame For Library Partz

|hpeezofib
Trace Handling

f* Trace
" Path

(™ Polpgon

Cancel Help

Remove IFF File After Import

When this option is selected, the .iff file is removed once the file is successfully imported. This option is not selected
as the default.

Log verbose messages

When this option is selected, ALL translation information is recorded in the ifftolib.log file resulting in step-by-step
description of what happened internally during your translation. This option is primarily intended to be used as a
diagnostics tool so the default mode for this option is deselected. Note that error and warning messages will always
appear in your status window regardless of this selection.

Synchronize ports to symbol using node name

When this option is selected, the IFF import resets the symbol pin humbers to match port numbers based on the node
name of the schematic port. By default, symbol pin humbers are matched to schematic port numbers based on the
port's instance name.
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Use port name for connected wire label

For each wire attached to a port, the wire label will be set to name of the port from the Cadence environment. To
maintain proper connectivity in the ADS environment, this option must be enabled if connectors share a common

name in the Cadence environment.

Use layouts from libraries instead of building local copies from IFF file

When this option is selected, library elements that already exist in the system libraries are not recreated for the
imported file. Instead, these elements are read from the local libraries; if an element does not exist in a local library,
then it is newly created. This option is deselected as the default, and all elements are created/recreated in the local

project.
Default Library Name For Library Parts

When the IFF file does not specify a library name for a component that needs to be created, the library name specified
in this field is used. This is necessary for environments that do not support the concept of a library.

© Note

The Default Library Name For Library Parts field is identical to the field of the same name in the Export IFF
Options dialog box. Changes made to this field will modify the contents of the field in the Export IFF Options

dialog box.

About Component Libraries

A component library in ADS consists of a collection of component definitions. Each primitive component has an
associated component name, symbol and predefined component parameters that include relevant physical and
electrical characteristics.

The IFF translator can be used as the initial step in creating an ADS component library however, this topic is outside of
the scope of this manual. Creating an ADS component library using IFF requires specialized tools and training. If
you're interested in learning more about this topic, contact Agilent EEsof-EDA's Solution Services.

Trace Handling

Trace Handling enables you to select how you want your meander elements interpreted during a translation.
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Trace When this option is selected, meander elements are translated as simulatable traces with pins. This is the

default setting.
Path When this option is selected, meander elements are translated as primitive data type with center line and width.

The default for this option is deselected.
Polygon When this option is selected, meander elements are translated as polygons. The default for this option is

deselected.

 Note

If you choose Use layouts from libraries instead of building local copies from IFF file in the Import IFF Options
dialog box, choose Path in the Trace Handling options. Fixed artwork is not simulatable, therefore it is not
necessary for the interconnects to be simulatable.

Importing from a Schematic Window

If the import is invoked from the ADS Schematic window, the following Import IFF More Options dialog box appears.

Import IFF Options:3 &|

[ Remowve IFF File After Import

[~ Log verbosze meszages

[ Synchronize ports to symbol using node name
[v Usze part name for connected wire label

Default Library Marme For Libran Parts
|hpeesuf|il:u

Cancel Help

Note that the same options are used with the exception of the Use layouts from libraries instead of building local
copies from IFF file check box and the Trace Handling options. For information on these options, refer to Import IFF

Options.

Exporting IFF Files

To export an IFF file:

1. Follow the steps as outlined in Exporting a Layout. For available options (accessed via More Options in the Export

dialog box), see Export IFF Options.
2. When the translation is complete, an Information Message window appears. Click OK to dismiss this window.

3. The IFF Export log appears:
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Review the log, searching for any warnings or error messages generated during export.
The log file appears in the hpeesofeedit window by default. This window is provided as a means of viewing the

file and is not intended for editing.
4. To dismiss the log window, choose File > Quit.

Export IFF Options
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X

Export IEF Options:3

Destination IFF File name:

I Browse...

[FF File Ovenwrite Options Owenarite IFF File L]

[ Qutput dizabled instances to the IFF file

[w Output ADS [tem Definition properties

[ Put a space between numbers and the scalar/unit

[w Output annotation pazsition far schematic components

Default Library Wame For Librany Parts
|hpeesoflib

Schematic Hierarchy Option
|Eurrent Dezign, Selected Projects ancLJ

Project Hierarchy Projects Included During Schematic Export

C:hoypgwinhuzershstauffersads_projectsadz2006aMNFE_ir

»» Include 3> I

C:hoygwintugzers'staufferhads

»» Include All 33 ]

<< Remove << I

<< Remove All << I

Cancel | Help

Destination IFF File name

Use the Destination IFF File name field to enter the full path of the destination file. Alternatively, you can click Browse
to open the Export File Selection dialog box and locate the destination path. After selecting the destination path and
entering the file name, click OK to accept the selection and return to the Export IFF Options dialog box. The

appropriate suffix is appended to the filename automatically.

IFF File Overwrite Options

Overwrite IFF File When writing to an existing file, the contents of that file are overwritten.
Append to IFF File When writing to an existing file, the new data is appended to the existing file. This is the default

setting.
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Output disabled instances to the IFF file

When this option is selected, if an instance is disabled in the schematic, it will still be output into the IFF file. If the
checkbox is deselected (default), disabled instances will not be exported. This option can be utilized to omit certain
components from being transferred to remote environments that might not support the components (e.g. disable the
simulation components prior to creating an IFF file to send to Cadence, which does not have any definitions for the
simulator components). Activate this option if you want to get everything. Deactivate this option if you want to filter
out the unused/unwanted components.

Output ADS Item Definition properties

When this option is selected, ADS Item Definition properties are utilized to recreate the information necessary to
simulate a component for ADS. For example, if you have parameters on a resistor, some Item Definition properties
are created in the IFF file (e.g. R_ADS_UNIT=1), which allow the IFF importer to exactly recreate the component as it
exists in ADS. However, other tools will not recognize the Item Definition parameters, and may misinterpret the
properties as being separate. If library symbols are being exported to other environments that do not recognize the
ADS Item Definition parameters, the option should be turned off. This option is deselected by default.

Put a space between numbers and the scalar/unit

When this option is selected, parameter values are exported as they normally appear in ADS (i.e. with a space
between the number and the scalar, e.g. "1 pF"). If the checkbox is deactivated, the exporter converts the values into
the IFF value specification, which is to have no space between a number and a scalar (e.g. "1pF"). Ideally, an IFF
exporter should interpret either form of number, and set the value internally to whatever is normal for that
environment. Some environments (e.g. Mentor Graphics) do not interpret the IFF property values in any way. For
Mentor IC, this means the numbers need to have no space in them, because, when they are used within SPICE
simulations, the space will cause syntax errors in the simulator. However, for Mentor Board, they require the ADS
components to have a space in them, because the RF Architect ADS library is set up to expect values to have a space
between a number and a scalar/unit.

If you are exporting designs to Mentor Boardstation, you must select this option for IFF imports to work into their
environment. An additional issue can come up if you create variables, and then assign scalar values to the variable
(e.g. "R1 kOhms"). When this is exported, if the option is not set, it would convert to "R1koh", which could no longer
be interpreted correctly. Note that this second option is considered bad practice (the scalar should be included in the
variable value for R1, and no units should be specified); however, ADS does allow you to format variables in this way.
If you are using variables in this way, you must set this option to true. This option is deselected by default.

Output annotation position for schematic components

This option stores information about the position of the component text annotation in the schematic window.
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Annotation text includes the component type, nhame and parameters as displayed next to the component. Enabling
this option may be useful if the annotation has been moved in ADS, though even with this option enabled some
environments may not preserve the position of the annotation.

Default Library Name For Library Parts

When the IFF file does not specify a library name for a component that needs to be created, the library name specified
in this field is used. This is necessary for environments that do not support the concept of a library.

© Note

The Default Library Name For Library Parts field is identical to the field of the same name in the Import IFF
Options dialog box. Changes made to this field will modify the contents of the field in the Import IFF Options
dialog box.

About Component Libraries

A component library in ADS consists of a collection of component definitions. Each primitive component has an
associated component name, symbol and predefined component parameters that include relevant physical and
electrical characteristics.

The IFF translator can be used as the initial step in creating an ADS component library however, this topic is outside of
the scope of this manual. Creating an ADS component library using IFF requires specialized tools and training. If
you're interested in learning more about this topic, contact Agilent EEsof-EDA's Solution Services.

Schematic Hierarchy Option

The Schematic Hierarchy Option drop-down list enables you to establish how much of the schematic hierarchy is
exported:

Current Design Only Write current level only. Complete design information for the current design is exported.
Instance-specific information (parameter values and coordinates identifying position) is also exported. Detailed
definitions of a referenced design are not exported.

Current Design, Selected Projects and No Library Parts Complete design information for the current design is
exported. Referenced designs that reside in a project selected for inclusion during export and are part of the current
design's hierarchy are also exported. Library parts are not exported. This is the default setting.

Current Design, Selected Projects and All Library Parts Complete design information for the current design is exported.
Referenced designs that reside in a project selected for inclusion during export and are part of the current design's
hierarchy are also exported. In addition, library parts are exported.
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Project Hierarchy

Displays the current project. If hierarchical, all included projects are listed in the appropriate order.

Projects Included During Schematic Export

The projects for which schematic design information is exported. You may customize this list if the current project is
hierarchical. (Note that complete layout hierarchy is always exported.)
To add a project to this list:

1. In the Project Hierarchy list, click the desired project.
2. Click the Include button. The project is added to the Projects Included list.

To include all projects, click Include All.
To remove a project from the Projects Included list:

1. In the Projects Included list, click the entry you want to remove.
2. Click the Remove button. The project is removed from the list.

To remove all entries from the Projects Included list, click Remove All.

IGES Translator

IGES (Initial Graphics Exchange Specification) is a neutral graphics database format designed primarily for data
exchange between mechanical CAD systems. The IGES file format links mechanical CAD systems to Advanced Design
System. Two-dimensional geometry can be used to interchange layout or package outline information.

The Advanced Design System IGES translator can either create or read an IGES ASCII form file. The basic input
requirements for the translator are the file to be translated and the configuration message file. The output is the
translated file.

The IGES translator can be run via the layout window menu commands File > Import and File > Export.
The IGES format can represent both mechanical and electrical design data in two and three dimensions.

For IGES output, it is important to consider the limitations and capabilities of the intended receiving system. IGES is a
very general language. Many IGES translators understand only a sub-set of IGES entities. If the receiving system is
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CALS Level 1 compliant, there should be no problem. If it is not, before you begin layout carefully review the types of
entities the receiving system is able to accept and what options are available in the layout output translator. The
translator is extremely configurable, but may still be unable to output every entity in a form acceptable to another
system.

Translator Description

The Advanced Design System's IGES output is compatible with IGES versions 4.0 and 5.0. The output is CALS Level 1
compliant. However, because many IGES pre-processors accept different types of IGES files, the translator is designed
to be highly configurable through the use of the Import and Export Options dialog boxes. For more information on the
options provided in these dialog boxes, see the sections Import IGES Options and Export IGES Options later in this
chapter.

Importing IGES Files

The procedure for importing each format is generally the same, however the available options differ. For a
step-by-step tutorial on importing a layout file, refer to Importing a Layout. For specific import options related to
importing IGES Files, refer to Import IGES Options.

Import IGES Options

=| Import IGES Options:3

Precision
-3 Define Layers...

Font Translation

Hershey Roman | 2

Hershey Roman Harrow 13

oK Cancel Help

Precision

This value should be the same as the precision with which the drawing file was created. A warning is generated if the
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precision is less than the drawing file precision. Possible values are 0, —1, —2, —3, —4, or —5. The default is —3.

Define Layers

The Define Layers button invokes the Layer Editor. For Layer Editor options, see Defining Layers.

Note that the layer-to-IGES level number is controlled in the Layer Editor IGES Layer entry field for each program
layer.

Exporting IGES Files

The procedure for exporting each format is generally the same, however the available options differ. For a
step-by-step tutorial on exporting a layout file, refer to Exporting a Layout. For specific export options related to
exporting IGES Files, refer to Export IGES Options.

Export IGES Options

= Export IGES Options:3 |

IGES Extension Attributes

igs Define Layers... ¥ Create Top | Polygons As Open Polylines
Units ST Sl Bl X Include Fill | Polygons As Segments

S ame il *X Include Text | Ezplicitly Define Defaults
Exponent Clmrax:ter. Precision ¥ Holes As Polygons || Zerofill Sequence Mumbers

E | -= | | ./ Ratten X ZeroFillTerminate Section
Author Organization | Reverse Arcs | Hame Properties

? ? | Conv Arc to Lines

Ok Cancel Help
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IGES Extension

If you do not specify an output file name when exporting the file, the program takes the input file name and appends
this extension to create the output file name. The default extension is igs , but any three character string can be used.

Units

These are the units that the IGES file will be written in. You may select from the following options: same, mil, inch,
um, mm, cm. The default is same. When same is selected, the design is written in the same units that are stored in
the design file. For more information on choosing layout units, refer to Setting Units/Scale Factors in the
Customization and Configuration manual.

Exponent Character

For case sensitive post processors, this option enables you to specify either upper-case (E) or lower-case (e)
exponents. The default is E, or upper-case.

Author

Your name. This is written into the Global Section (the first three lines of the IGES file) and is not required.

Define Layers

The Define Layers button invokes the Layer Editor. For Layer Editor options, see Defining Layers.

Addnl. Scale Factor

If this value is other than 1.0, the output coordinates are multiplied by that value. The default is 1.0. You may enter
any integer or double precision float number.

Precision
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This value should be the same as the precision with which the drawing file was created. A warning is generated if the
precision is less than the drawing file precision. Possible values are 0, —1, —2, —3, —4, or —5. The default is —2.

Organization

Name of your company or organization. This is written into the Global Section (the first three lines of the IGES file)
and is not required.

Create Top

When selected, this adds a Substructure Instance Entity to the IGES file at the top level of hierarchy. Create Top is
selected as the default.

Include Fill

This is selected as the default. However, not all post-processors support fill patterns. To eliminate fill patterns in filled
polygons, deselect this item.

Include Text

This is selected as the default. However, not all post-processors support text. When this option is deselected, text is
eliminated from the IGES file.

Holes As Polygons

This is selected as the default. However, not all post-processors support holes in polygons. When Holes As Polygons is
deselected, polygons are written with false edges.

Flatten

When Flatten is selected, all levels of hierarchy are automatically removed and a single flat design is translated. There
will be no references from the top level structure to any other structure. This option is useful when your
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post-processor does not support or correctly translate hierarchy in IGES files. Please note: if a substructure was
instanced more than once, selecting this option increases the size of the file.
This option is deselected as the default.

Reverse Arcs

When selected, the program writes all arc— as arc+ by interchanging the start and end points. This forces polygons to
be written as line segments. This option is deselected as the default.

Conv Arc to Lines

When selected, the program translates an arc into of line segments. You should select this option if your
post-processor places random arcs on a drawing. This option is deselected as the default.

Polygons As Open Polylines

When selected, closed polygons are written as open contours. This retains arcs in outline form. This option is
deselected as the default.

Polygons As Segments

When selected, all copious data entities are changed to composite curve entities. Arcs are retained in outline form.
This is useful for post-processors that cannot read IGES solids. However, when this option is selected, the size of the
output file greatly increases because each line segment is written on a separate line, and each coordinate that is a
vertex gets written twice. Also, knowledge of segments belonging to a polygon is not retained.

This option is deselected as the default.

Explicitly Define Defaults

If your post-processor complains because there are blanks in the Directory Entry Section fields, or that the parameter
and record delimiters are not specified, select this option. Otherwise, Explicitly Define Defaults is deselected as the
default.

ZeroFillSequenceNumbers
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If your post-processor complains because the sequence numbers do not have zero fill, select this option. Otherwise,
ZeroFillSequenceNumbers is deselected as the default.

ZeroFillTerminateSection

If your post-processor complains because the terminate section has zero fill, deselect this option. Otherwise,
ZeroFillTerminateSection is selected as the default.

Name Properties

When selected, all Name Properties are preserved and exported with the IGES file. This option is deselected as the
default.

Overcoming Limitations of Other IGES Readers

IGES Reader Problem Advanced Design System Solution
Can't read clockwise arcs Convert arcs to lines (Conv Arc to Lines)
Can't read hierarchical IGES Flatten the design
Can't read IGES solids Reverse arcs (polygons are converted to line sets)
Can't read lower-case exponent Specify Exponent Character as E (or e)
Text won't transfer Deselect Include Text
Defaults not explicitly defined Select Explicitly Define Defaults
Zero fill in termination section Deselect ZeroFillTerminateSection
Zero fill not in sequential numbers Select ZeroFillSequenceNumbers

Mask Files

Created by Agilent EEsof EDA for use with its EDA tools, the mask format is a simple ASCII format that provides a flat
geometric representation of a layout. Because of its simplicity, this format offers great flexibility when transferring
designs between the Advanced Design System and other design environments.
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The Gerber and DXF translators use the mask file format as an intermediate file when converting data to Gerber and
DXF. The mask format is also used as an intermediate file when translating other formats such as HPGL/2. In addition,
the simplicity of the mask file format makes it an appealing option for post-processing designs and extracting drill hole
file information (you will need to create your own programs for these tasks).

Mask files can include multiple layers of data, but this data describes geometric forms exclusively. Simulation data,
element parameters, substrate definitions, and hierarchy are not included.

Importing Mask Graphics Files

For a step-by-step tutorial, see Importing a Layout.

Import MASK Options

—|  import MASK Options:1

Scale X acale ¥
.o a0

Define Layers...

Mask To Layer

"

0K Cancel Help

Scale X, Scale Y

These are the fields for inputting the scale factors for shapes in the direction of X and Y. The default settings are 1.0,
1.0.

Define Layers
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This button invokes the Layer Editor. For Layer Editor options, see Defining Layers.

Mask To Layer

This field enables you to specify a list of mask files to be read and the layer numbers to be created within them. The
information must be presented in pairs, as follows:

<layer_number> <file_name> <layer_number> <file_name>...
where all entries are separated by spaces.

Exporting Mask Graphics Files

For a step-by-step tutorial, see Exporting a Layout.

Export MASK Options

—| Export MASK Options:1
Units Scale X Scale Y Attributes
Same ¢ 1.0 3.0 - futo Merge
.| Arcs As Polygons
Define Layers...

Hole Format
Layers Layer Number{s)

: ] Holes As Polygons
& Include ¥

@ Holes As Cutlines
1 Exclude Layer File Hame{s)

1 Preserve Holes

Etch Factor  Miter Angle

fi B0.0

0K Cancel Help

Units
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These are the units that the mask file will be written in. You may select from the following options: same, mil, inch,
um, mm, cm. The default is same. When same is selected, the design is written in the same units that are stored in
the design file. For more information on choosing layout units, refer to Setting Layout Options > Preferences for
Layout > Setting Units/Scale Factors in Customization and Configuration.

Scale X, Scale Y

These are the fields for inputting the scale factors for shapes in the direction of X and Y. The default settings are 1.0,
1.0.

Define Layers

Clicking the Define Layers button invokes the Layer Editor. For Layer Editor Options, see Defining Layers.

Layers Include, Layers Exclude

These buttons enable you to specify layers to either include or exclude.

e Include — exports information only from layers specified in the Layer Number(s) and Layer File Name(s) fields
(see descriptions below).

e Exclude — exports all layers except those specified in the Layer Number(s) field (it is not necessary to fill in the
Layer File Name(s) field).

Include is selected as the default. Unless you specify layer numbers to include in the Layer Number(s) field, all layers
are automatically included.

Layer Number(s)

The layer numbers to include or exclude in the mask file output. Entries are separated by commas. For example:
1, 6, 20.

Layer File Name(s)

This option is used only when Layers Include is selected. The information must be presented in pairs, as follows:
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<layer_number> <layer_name> <layer_number> <layer_name>...
where all are separated by spaces. For example:
1 mskl 3 msk3

Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap are merged. This option is
deselected as the default.

Arcs As Polygons

When Arcs As Polygons is selected, the design arcs are exported as line segments (or polygons). This option is
deselected as the default.

Holes As Polygons

When Holes As Polygons is selected, holes are exported as a filled element, which is also how polygons are exported in
the mask format. When Holes As Polygons is not selected, polygons with holes are translated as single-segment
polygons, the false edge segment becoming part of the polygon. Some systems may not be able to tolerate this type
of complex polygon. For these systems, make certain that Holes As Polygons is selected. This option is deselected as
the default.

Holes As Cutlines

When Holes As Cutlines is selected, holes are converted into cutlines. This option is selected as the default.

Preserve Holes

When Preserve Holes is selected, holes are exported as an empty element. This option is not available for exporting
mask graphics files.

Etch Factor
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The etch factor applies a global over/undersize amount to each shape translated. This is meant to compensate for etch
effect during processing. However, using this option can be problematic. Thus, we recommend that you retain the
default setting of 0.

If you use Etch Factor, carefully verify the correctness of the compensation to minimize problems. Limitations include
the following: When a figure has a side smaller than the etch factor, this function may fail. If two boundaries butt up
against one another before compensation, because each boundary is handled independently, such boundaries will
either overlap or show a gap when compensation is specified. When Etch Factor is applied, re-entrant polygons may
be transformed into illegal polygons.

Miter Angle

The angle cutoff used with the etch factor. The miter angle controls acute angle edge over-extension. Any angle below
the miter angle amount is mitered. The default is 90.0.

MGC/PCB Files

MGC/PCB files are IFF files that are used exclusively for Mentor Graphics design transfers. This format is available
from the Advanced Design System layout menu only, yet it enables the transfer of both schematic and layout
information.

When you select the MGC/PCB export format from an Advanced Design System Layout window, both a layout and
schematic IFF file are exported in a single step. The design data is exported into a standard directory tree contained in
the program's project directory structure. The standard directory is called to_mgc.

The exported files are placed within this directory in a subdirectory that is named the same as the design being
exported. This subdirectory contains an information file and the translated schematic and layout IFF files. Thus, if you
were translating a design called test, the exported files (design_info, schematic.iff and layout .iff) would found in a
directory called to_mgc/test.hpxfer.

From the Mentor Graphics Design Manager, a single command called import_hpeesof imports the schematic and
layout data into Boardstation and Design Architect. This command automates to a single procedure the steps required
to transfer both the schematic and the layout.

Mentor PCB products do not accept layout hierarchy, so the entire layout is flattened prior to building the Mentor
layout.

Exporting MGC/PCB Files
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This section outlines the procedure for translating designs into MGC/PCB format. For more information on transferring
designs between the Advanced Design System and the Mentor Graphics Falcon Framework, contact your Agilent
Technologies sales representative.

To export an MGC/PCB file:

1. Follow the steps as outlined in Exporting a Layout. For available options (accessed via More Options in the Export
dialog box), see Export MGC/PCB Options.
2. If the option Prompt For User Message was selected, an Export MGC/PCB Options message dialog appears:

|
— MGC/PCB User Message |

,_.
L

N 0K | Print Help

Enter any messages to be included with the design transfer. This information is used only by the import_hpeesof
utility (see MGC/PCB Files) and is not kept with the design.
If you do not wish to include a message in the file, you may leave this window empty. If you want to print the
message, click Print.
To proceed with the transfer, click OK.

3. When the translation is completed, the following message window appears:

|
— Information Message |

§ MGCIPCB export completed

K|

Click OK to dismiss this window.
4. The IFF Export log appears:
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Review the log, searching for any warnings or error messages generated during export.
The log file appears in the hpeesofeedit window by default. This window is provided as a means of viewing the
file and is not intended for editing.

5. To dismiss the log window, choose File > Quit.

Export MGC/PCB Options
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—| Export MGC/PCB Options:1

IFF File Overwrite Options
Overwrite IFF File

Default Library Mame For Library Parts

hpeesoflihb

| Dutput disabled instances to the IFF file
X Output ADS Item Definition properties
| Put a space hetween numbers and the scalarfunit

schematic Hierarchy Option
Current Design, Selected Projects and No Library Parts

Project Hierarchy Projects Included During Schematic Export
. - .-m -

mifsfd1 localfusersicrscott/Slot_dipole pr fifsfdl Aocalfusersicrscott/Slot_dipole_py
=» Include All ==
== Remove <<

<< Remove &l <<

X Prompt For User Message

oK Cancel Help

IFF File Overwrite Options

e Overwrite IFF File

When writing to an existing file, the contents of that file are overwritten. This is the default setting.
e Append to IFF File

When writing to an existing file, the new data is appended to the existing file.

Default Library Name For Library Parts
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The name of the library to which the library parts are written. Design objectives are stored in a group that uses the
same name as the project directory, but library parts are stored in either the default library hpeesoflib or a library that
you specify.

#» Note The default library name can contain only alphabetic and numeric characters.

Output disabled instances to the IFF file

When this option is selected, if an instance is disabled in the schematic, it will still be output into the IFF file. If the
checkbox is deselected (default), disabled instances will not be exported. This option can be utilized to omit certain
components from being transferred to remote environments that might not support the components (e.g. disable the
simulation components prior to creating an IFF file to send to Cadence, which does not have any definitions for the
simulator components). Activate this option if you want to get everything. Deactivate this option if you want to filter
out the unused/unwanted components.

Output ADS Item Definition properties

When this option is selected, ADS Item Definition properties are utilized to recreate the information necessary to
simulate a component for ADS. For example, if you have parameters on a resistor, some Item Definition properties
are created in the IFF file (e.g. R_ADS_UNIT=1), which allow the IFF importer to exactly recreate the component as it
exists in ADS. However, other tools will not recognize the Item Definition parameters, and may misinterpret the
properties as being separate. If library symbols are being exported to other environments that do not recognize the
ADS Item Definition parameters, the option should be turned off. This option is deselected by default.

Put a space between numbers and the scalar/unit

When this option is selected, parameter values are exported as they normally appear in ADS (i.e. with a space
between the number and the scalar, e.g. "1 pF"). If the checkbox is deactivated, the exporter converts the values into
the IFF value specification, which is to have no space between a number and a scalar (e.g. "1pF"). Ideally, an IFF
exporter should interpret either form of number, and set the value internally to whatever is normal for that
environment. Some environments (e.g. Mentor Graphics) do not interpret the IFF property values in any way. For
Mentor IC, this means the numbers need to have no space in them, because, when they are used within SPICE
simulations, the space will cause syntax errors in the simulator. However, for Mentor Board, they require the ADS
components to have a space in them, because the RF Architect ADS library is set up to expect values to have a space
between a number and a scalar/unit.

Schematic Hierarchy Option
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This establishes how much of the schematic hierarchy is exported:

e Current Design Only
Write current level only. Complete design information for the current design is exported. Instance-specific
information (parameter values and coordinates identifying position) is also exported. Detailed definitions of a
referenced design are not exported.

e Current Design, Selected Projects and No Library Parts
Complete design information for the current design is exported. Referenced designs that reside in a project
selected for inclusion during export and are part of the current design's hierarchy are also exported. Library parts
are not exported.
This is the default setting.

e Current Design, Selected Projects and All Library Parts
Complete design information for the current design is exported. Referenced designs that reside in a project
selected for inclusion during export and are part of the current design's hierarchy are also exported. In addition,
library parts are exported.

Project Hierarchy

Displays the current project. If hierarchical, all included projects are listed in the appropriate order.

Projects Included During Schematic Export

The projects for which design information will be exported. You may customize this list if the current project is
hierarchical. (Note that complete layout hierarchy is always exported.)
To add a project to this list:

1. In the Project Hierarchy list, click the desired project.
2. Click the Include button. The project is added to the Projects Included list.

To include all projects, click Include All.
To Remove a project from the Projects Included list:

1. In the Projects Included list, click the entry you want to remove.
2. Click the Remove button. The project is removed from the list.

To remove all entries from the Projects Included list, click Remove All.

Prompt For User Message
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When selected, a user message window appears before the transfer is initiated. This window enables you to enter any
messages that you want included in the translated file. For more information about the user message, see Export

MGC/PCB Options.

This option is selected as the default.
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